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Introduction to Backup Agents

Sun StorageTek Business Analytics provides three backup agents supporting the 
Symantec NetBackup, IBM Tivoli Storage Manager (TSM), and EMC Legato 
NetWorker backup products. 

Note – Sun StorageTek Business Analytics was formerly called Global Storage 
Manager (GSM). While the agents share broad areas of similarity, each agent has 
unique attributes that are based on the differences among the product lines and 
interfaces. Refer to the Sun StorageTek Business Analytics Support Matrix to obtain the 
latest information on supported backup products and support prerequisites. In 
addition, consult the Sun StorageTek Business Analytics Backup Reports Quick Facts 
Sheet to obtain an overview of the Sun StorageTek Business Analytics reports 
supported by a particular Backup Agent.

Sun StorageTek Business Analytics provides three agent installation CDs: Windows 
Local Manager, Solaris Local Manager, and UNIX Agents (HP-UX and IBM AIX). If 
you are upgrading a backup agent on a Windows server, proceed as follows:

■ Uninstall the backup agent. Using a text editor, verify that all the configuration 
settings for the backup agent have been removed. If not renoved, manually 
remove these settings.

■ Install the Version 5.1 backup agent and specify to install the new version of the 
Configuration Tool becasuse all Version 5.1 backup agents have new 
configuration settings.
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Backup Reporting Concepts
Business Analytics backup reporting utilizes data that can be accessed from a 
backup application server. We gather information using data collection software 
(agents) that are installed on either the backup server, such as the NetBackup master 
server, or a separate host. The backup agents collect data through the use of vendor-
supported means of gathering backup data.

Because Business Analytics is designed for multi-vendor reporting, it is necessary to 
standardize the data obtained from the different backup applications into a common 
data model.  Within this process, the individual concepts and terminology used by 
the different backup applications are normalized into a single set of concepts and 
terms, including:

■ Job - Refers to a backup application transaction for a specific purpose.  These are 
normally called jobs in NetBackup, save sets in Legato NetWorker, and events in 
TSM.  Jobs have a number of attributes associated with them - type, properties, 
status, and so forth.

■ Job Type - Consists of a vendor-specific, naming convention for various 
operations. For example, NetBackup has a job type, called tpreq , where as TSM 
has a job type that is called TAPE MOUNT.  Both perform the same function , but 
the backup applications designate different names for them.

■ Job Properties - May be characterized as administrative or non-administrative, 
configured or non-configured, client-side or server-side, or synthetic backup.

■ Administrative Job - Performs some administrative task on the repository. These 
are clientless jobs.

■ Non-Administrative Job - Performs some non-administrative task.  These jobs 
may or may not be clientless.

■ Configured Job - Refers to a job where the backup server (e.g., master server) has 
all the necessary information to run a job without human intervention.

■ Non-Configured Job - Refers to a job that is not run by the backup scheduler 
within the backup software. This job may have been run manually by a user or by 
an external scheduler package (Cron, Maestro, etc)

■ Client-side Job - Refers to a job that is associated with a particular client.

■ Server-Side Job - Refers to a job that does not directly involve a client, only the 
master/media server is required to run these jobs.

■ Synthetic BackUp - Is a NetBackup-specifc job type. It is the combination of 
multiple incremental backup jobs, creating together a full backup job.

■ Client - Is the source (location) of the data that is backed up.
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■ Group - Refers to a logical set of clients that have been structured so that jobs can 
run against them using the same set of setup properties. For NetBackup, this is a 
policy and for NetWorker this is a group. For TSM, this is a policy domain.

■ Schedule - Determines how often a job will be run. For NetBackup, it is 
associated with a policy, whereas a schedule is associated with a client for Legato 
NetWorker. For TSM, a schedule is associated with a policy domain.

Client-side and Server-Side Jobs
Business Analytics provides the following support for job reporting:

■ Server-side job reporting is supported for three backup applications.

■ Client-side job reporting is supported for NetBackup and TSM but not for Legato 
NetWorker.

The client-side limitiation stems from the fact that Buisness Analytics can only report 
on client-side jobs known to the backup server.

Standarizing Job Status
The following table describes how Business Analytics standardizes the status of jobs.

TABLE 1 Standardizing Job Status

Job Status Status Code

Success 0

Partial 1

Failure >1 (NetBackup), 9100 (NetWorker), and 8100 (TSM)

Missed Not applicable for TSM or Netbackup, 9200 (NetWorker)
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Backup Jobs Table
The Business Analytics 5.1 database includes a new backup table, gsa_backup_jobs.  
This transactional jobs table holds all information about a backup job, and is used by 
all the currently supported backup products. By unifying the jobs table, we have 
simplified the database insertion process and the database structure, resulting in 
faster data loading and reporting. 

The new jobs table includes fields from the following Business Analytics Version 5.0 
tables:

■ gsa_backup_master used by NetBackup and NetWorker

■ gsa_backup_filelist-2_2 used by NetBackup and NetWorker

■ gsa_backup_status_NEW used by NetBackup and NetWorker

■ gsa_backup_summary used by TSM

■ gsa_backup_events used by TSM

These legacy tables are not used in Business Analytics Version 5.1. 

Backup Agent Characteristics
All backup agents support the data model changes that were describedin the 
preceding sections. In addition, changes have been made to the agents to make them 
more consistent with other Business Analytics data collectors, including:

■ Removal of agent-specific table caching; the common cache refresh parameter is 
now used.

■ Suport for reporting on non-configured backup jobs. If no specific schedule or 
policy is associated with a client, the policy will be presented as "NON-CONFIG".

■ Support for six data groups, described below, whose data collection can be turned 
on or off using several new configuration settings.

■ Support for populating the new object gsa_backup_jobs object.
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Backup Data Collection
In Business Analytic 5.1, data collection on backup data is grouped into a total of six 
data groups: 
■ Config
■ Jobs
■ Media
■ Schedule
■ TSMOptional
■ NetbackupOptional

In your backup environment, you may only be interested in some of this data. 
Business Analytics addresses this requirment by allowing you to “turn off” data 
collections as follows:
■ Stop collection entirely for a specified group.
■ Stop collection during a specified time interval for a group. If the time of the data 

collection is outside of this range, the data collection will occur.

The following new configuration settings (storability.ini) have been added to 
support this functionality:
■ NON_COLLECTION_DURATION= <Comma separated list of Data Group 

Names | 'ALL'> | <Start Time>|<Finish Time> where time is specified in 24 hour 
format (i.e. 12:45:50). The <Start Time> specifies the start time of when the 
collection for the group is blocked. The <Finsish Time> specifies the time when 
the blocked data collection is lifted. During this time interval, cache is not cleared 
and cache age continues to grow. It will be reset with the first collection after the 
Finish time has passed.

■ NO_COLLECTION=<List of Data Group Names|"ALL">. In conjunction with 
this setting, each collection attempt results in the cache being cleared and setting 
the cache age back to zero.

Automatic and Static Agent Registration
Automatic agent registration is a configuration option for agent data collection. In 
the storability.ini file, automatic agent registration is configured as follows:

■ Local Manager – Specify the IP address or host name of the Local Manager to be 
contacted to activate agent registration. 

■ Local Manager Registration Port – Specifies the TCP port number used by the 
Local Manager for agent auto registration. The default port number is 17146.

■ Enable Auto Registration – Turns agent auto registration on (default) or off.
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To register the Backup Agent statically, proceed as follows:

■ Enter false in the Enable Auto Registration field. 

■ Modify the Routing Agent static agent configuration to include an entry (port 
number|<agent IP address/name>). 

■ Restart the Routing Agent.

■ Restart the companion Central Manager agents.

Solaris Local Manager Installation Script
The setup script on the Solaris Local Manager Installation CD provides the following 
features:

■ Provides a command line interface for the user to perform Business Analytics 
Local Manager (Solaris) installation. 

■ Validates that the user is root to perform the installation.

■ Validates that the Solaris server is equipped with a supported Operating System, 
which includes between Solaris 5.7 and Solaris 5.10.

■ Provides a list the agents available, depending on the platform, for the user to 
choose to install or uninstall (setup -u).

■ Performs agent installation depending on the user's selection.

■ Performs agent upgrade for existing SUNWbizan packages.

■ Automatically installs the SUNWbizanbase and SUNWbizanlmutil packages 
where required and not already installed.
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Backup Agent Objects
All Business Analytics backup agents publish the same objects. If a particular agent 
does not support a particular object, it publishes an empty object.

TABLE 2 lists the objects that all Sun StorageTek Business Analytics backup agents 
publish. 

TABLE 2 Backup Agent Objects

Table Column

alerts-3_1 sourceip, priority, alert_id, progname, alert, time, firsttime, 
refreshedtime, int1, text1, text2.

gsa_agent_version-2_0 ip_address, agent_name, version, compile_time, managed_entities, 
tz_name, tz, timestamp

gsa_cache_contro0l-2_1 ip_address, port, table_name, cache_age, 
last_update_request_length, update_request_pending, 
group_name, group_master,timestamp

gsa_ini_control-2_0 ip_address, port, domain, parameter, value, status, timestamp

gsa_parm_info ip_address, port, object, parm_name, value_syntax, description, 
example

gsa_backup_calendar ip_address, master_server, policy, schedule, backup_type, 
schedule_type, value_1, value_2, value_3, timestamp

gsa_backup_cat_usage-2_3 ip_address, server_name, product, cat_path, blocks_used, 
blocks_available, filesystemid, timestamp

gsa_backup_client_policy-2_1 ip_address, master_server, policy, active_status, effective_date, 
timestamp

gsa_backup_detail_new ip_address, backup_id, copy_number, frag_number, kilobytes, 
remainder, media_type, density, file_number, media_id, block_sz, 
offset, media_date, dev_written_on, flags, timestamp

gsa_backup_device_class ip_address, server_name, devclass_name, access_strategy, 
stgpool_count, devtype, format, capacity, mountlimit, mountwait, 
mountretention, prefix, library_name, directory, servername, 
retryperiod, retryinterval, shared, last_update_by, last_update, 
timestamp

gsa_backup_events ip_address, job_id, class, client, schedule, schedule_type, 
storage_unit, volume_pool, status, error_msg, host_id, 
error_explanation, error_recommendation, timestamp
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gsa_backup_filelist-2_2 ip_address, backup_id, job_id, client, slave, master, storage_unit, 
class, file_list, job_type, kilobytes, files, status, message, 
start_time, timestamp 

gsa_backup_frequency ip_address, master_server, policy, schedule, backup_type, 
retention_level, frequency, day_of_week, open_window, 
close_window, timestamp

gsa_backup_jobs ip_address, job_id, backup_id, parent_job_id, 
scheduled_start_time, actual_start_time, end_time, elapsed_time, 
comm._wait, media_wait, type, type_code, status, status_code, 
master, source, number_of_tries, media_server, kb_transferred, 
destination_storage_unit, destination_drive, affected_file_count, 
examined_file_count, failed_file_count, schedule, schedule_type, 
expiration_date, error_message, data_set, class, class_type, 
product, backup_software, compresse, encrypted, reconcile_status, 
reconcile_note, reconcile_user, window_status, window_id, 
timestamp

gsa_backup_legato_err_msg ip_address, backup_id, job_id, sequence_num, error_msg, 
timestamp

gsa_backup_libraries ip_address, server, library_name, library_type, acs_id, 
private_category, scratch_category, external_mgr, shared, lanfree, 
obeymntretention, primary_lib_mgr, last_update_by, last_update, 
timestamp

gsa_backup_library_volumes ip_address, server, library_name, volume_name, status, owner, 
last_use, home_element, cleanings_left, timestamp

gsa_backup_master ip_address, backup_id, client, class, class_type, proxy_client, 
creator, schedule, schedule_type, retention_level, start_date, 
elapsed_time, expiration_date, compressed, encrypted, 
backed_up_kb, backed_up_files, number_of_copies, 
number_of_frags, db_compressed, catalogue_file_name, status, 
timestamp

gsa_backup_status_new ip_address, time, netbackup_version, message_type, 
message_severity, server, job_id, job_group_id, client, class, 
schedule, error_ms, timestamp

gsa_backup_storage_pools ip_address, server, stgpool_name, pooltype, devclass, 
est_capacity_mb, pct_utilized, pct_migr_pct_logical, highmig, 
lowmig, migproess, nextstgpool, maxsize, access, description, 
ovflocation, collocate, reclaim, maxscratch, reusedelay, migr-
running, migr_mb, migr_seconds, recl_running, recl_volume, 
chg_time, chg_admin, reclaimstgpool, mig_delay, migcontinue, 
dataformat, copystgpools, copycontinue, crcdata, timestamp

TABLE 2 Backup Agent Objects (Continued)

Table Column
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gsa_backup_volhist ip_address, server, date_time, unique, time, backup_series, 
backup_operation, volume_seq, volume_name, location, 
command, timestamp

gsa_backup_volume_info-2_1 ip_address, media_id, media_type_desc, media_type, barcode, 
description, volume_pool_type, rebot_type_desc, robot_type, 
robot_number, robot_slot, robot_host, volume_group, 
creation_date, assigned_date, last_mount_date, first_mount_date, 
expiration_date, number_of_mounts, max_mounts_allowed, 
timestamp, status, status_flags

gsa_backup_volumes ip_address, server, volume_name, stgpool, devclass_name, 
est_capacity_mb, pct_utilized, status, access, pct_reclaim, scratch, 
error_state, num_sides, times_mounted, write_pass, 
last_write_update, last_read_date, pending_date, write_errors, 
read_errors, location, chg_time, chg_admin, timestamp

gsa_media_list-2_2 ip_address,media_id, partner_id, version, density, allocated_date, 
last_written_date, expiration_date, last_read_date, bu_Kbytes, 
bu_images, bu_unex_images, retention_level, volume_pool, 
num_restores, status, media_type, status_flags, bu_server, 
timestamp

gsa_backup_drives ip_address, server, library_name, drive_name, device_type, online, 
element, acs_drive_id, drive_state, allocated_to, last_update_by, 
clean_freq, timestamp

gsa_backup_filespaces ip_address, server, nodename, filespace_name, filespace_id, 
filespace_type, capacity, pct_util, backup_start, backup_end, 
delete_occurred, unicode_fiilespace, filespace_hex_name, 
timestamp

gsa_backup_occupancy ip_address, server, nodename, type, filespace_name, 
stgpool_name, num_files, physical_mb, logical_mb, filespace_id, 
timestamp

gsa_backup_paths ip_address, server,source_name, destination_name, 
destination_type, library_name, node_name, device, ext_manager, 
lun, initiator_id, directory, online, last_update_by, last_update, 
timestamp

gsa_backup_sched_events ip_address, server, scheduled_start, scheduled_end, actual_start, 
domain_name, schedule_name, status, result, reason, timestamp

gsa_backup_summary ip_address, server, start_time, end_time, activity, number, entity, 
address, schedule_name, examined, affected, failed, bytes, idle, 
mediaw, processes, successful, volume_name, drive_name, 
library_name, last_use, comm._wait, timestamp

TABLE 2 Backup Agent Objects (Continued)

Table Column
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NetBackup Agent Version 5.1
The following changes have been made to the NetBackup Agent in Version 5.1

■ No longer uses the external executable DBImport. The agent now executes CLI 
commands directly.  There is no longer a data collection dependency on the 
DBImport schedule.

■ Data collection” is controlled by the CACHE_REFRESH_INTERVAL variable that 
is defined in the NetBackup section of the storability.ini file. 

■ The agent collects data required to populate the new gsa_backup_jobs object.

Note – The Sun StorageTek Business Analytics NetBackup Agent must be installed 
on the NetBackup Master server.
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NetBackup Agent Matrix
TABLE 3 NetBackup Agent Matrix

Feature Description

Support Prerequisites

Verify supported version of NetBackup 
product

See the current version of the Sun StorageTek Business 
Analytics Support Matrix

Verify Ethernet connectivity to Master 
Servers 

ping <IP Address>

Base Package (SUNWbizanbase) Required on Solaris server

 Host Agent Required to support the Meta Database Capacity report for 
NetBackup.

Agent Installation

Windows Windows Local Manager Installation CD (InstallShield)
Windows Administrator privileges

Solaris Installation script (setup) on Local Manager Install CD
root user account privileges

HP-UX UNIX Agent Installation CD 
root user account privileges

Job History Retention Sun Storagetek recommends retaining this information for a 
minimum of three (3) days, which is the Symantec NetBackup 
default value.

ntegration with SNMP Extension for the Real Time 
Event report

Requires installation and configuration of the SNMP Extension 
for Symantec NetBackup (NBU). For more information about 
functionalities, you may email: vxsnmp@veritas.com.
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NetBackup Agent Trap Settings •  NETB_SNMP_PORT- Default value is 1100 seconds. 
Specifies the port that will be used to listen for SNMP traps.

• NETB_TRAP_VERITAS_SUCCESS- Default value is 
1.3.6.1.4.1.1035.1.1.251.0.2S. Specifies the trap value that 
indicates success.

• NETB_TRAP_VERITAS_FAIL- Default Value is 
1.3.6.1.4.1.1035.1.1.251.0.1. Specifies the trap value that 
indicates failure.

• NETB_TRAP_CLASS_ID- Specifies the SNMP trap binding 
for the class id.  Allows non-standard values in the MIB

• NETB_TRAP_CLIENT_ID - Specifies the SNMP trap 
binding for the client id.  Allows non-standard values in the 
MIB.

• NETB_TRAP_JOB_SCHEDULE - Specifies the SNMP trap 
binding for the job schedule.  Allows non-standard values in 
the MIB.

• NETB_TRAP_JOB_SCHED_TYPE - Specifies the SNMP trap 
binding for the schedule type.  Allows non-standard values 
in the MIB.

• NETB_TRAP_JOB_STU - Specifies the SNMP trap binding 
for the storage unit.  Allows non-standard values in the MIB

• NETB_TRAP_JOB_POOL - Specifies the SNMP trap binding 
for the job pool.  Allows non-standard values in the MIB

Common Configuration Settings • CACHE_REFRESH_INTERVAL- Specifies how often the 
'table cache' should be refreshed. The default value is 14400 
seconds.

• CMD_EXECUTION_TIMEOUT - Specifies how long the 
backup agent will wait for the successful execution of a CLI 
command and the successful read of the CLI output. The 
default value is 600 seconds.

• NO_COLLECTION - Specifies blocking data collection for 
specified data collection groups or for all groups (ALL).

• NON_COLLECTION_DURATION - Specifies a time interval 
during which data collection for a data group or groups is 
blocked.

TABLE 3 NetBackup Agent Matrix (Continued)

Feature Description
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NetBackup Agent Installation
The following sections provide instructions on installing the Sun StorageTek 
Business Analytics NetBackup Agent on supported platforms.

Installing NetBackup Agent – Windows
1. Insert the Sun StorageTek Business Analytics Windows Local Manager CD into 

the CD-ROM drive.

2. Click Next on the Welcome menu to continue the installation.

3. Click Yes to accept the terms of the software license agreement.

4. Review/modify the User Name and Company Name and click Next.

Agent Parameters • VERITAS_CATALOG_DIR - The default value for Windows 
is :C:\Program\Files\VERITAS\NetBackup\db\Images. 
For UNIX servers, the default value is 
usr/openv/netbackup/db/images. It specifies the root 
directory of the NetBackup catalog.  This directory controls 
where the Netbackup Agent begins its filesystem walk that 
calculates the size if the NetBackup catalog.

• NBU_CMD_PATH - Specifies the Netbackup installed 
directory on the server and is used to determine the path to 
the bpXXXXXXX CLI commands. The default value for 
Windows is C:\Program Files\VERITAS\NetBackup. For 
UNIX, it is /usr/openv/netbackup. 

• NBU_VOLMGR_PATH - Specifies the directory where the 
volume manager is located on the server. Is used to 
determine the path to the vmquery CLI command.The 
default parameter for Windows is C:\Program Files\
VERITAS\VolMgr. For UNIX servers, it is 
/usr/openv/volmgr

• NBU_REPORT_PERIOD- This value, sometimes called the 
‘look back’ period, is used as a parameter that is passed to 
the bperror and bpimagelist CLI commands. The default 
value is 72 hours.

TABLE 3 NetBackup Agent Matrix (Continued)

Feature Description
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5. Select the Veritas NetBackup Agent checkbox on the screen that lists agents for 
installation.

FIGURE 1 Select Features to Be Installed

6. Review the settings and click Next> to continue.

7. Specify whether or not to install the new version of the Configuration Tool, if 
prompted.

8. When the Configuration Tool is automatically launched, select File -> Edit -> 
Smart Agent Configuration.

9. Click the NetBackup Agent tab.

10. Review/modify the following configuration parameters: 
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Note – For the parameters that require specifying a folder/directory, you can click 
the Folder icon to browse your system, or click the template-supplied value to move 
that value into the respective input field.

■ Local Manager - Specify the IP address or host name for the Local Manager to be 
contacted for agent auto registration. The default value is localhost.

■ Local Manager Registration Port - Specify the TCP port number the Local 
Manager uses for agent auto registration. The default TCP port number is 17146.

■ Cache Refresh Interval - Specifies how long backup information remains in table 
cache. The default value is 14000 seconds.

■ Event Cache Duration - The default value is 14400 (same as 
CACHE_REFRESH_INTERVAL).

■ Command Execution Timeout - Specifies how long the agent will wait for the 
successful execution of a CLI command and the successful read of the CLI output. 
The default value is 600 seconds.

■ NetBackup Command Path - Specify the fully qualified path to the NetBackup 
software that provides the CLI commands. The default value is C:\Program 
Files\VERITAS\NetBackup.

■ NetBackup Report Interval - Enter the NetBackup Agent report interval that 
specifies the time range (e.g., last 72 hours) for backup data reporting. Sun 
Microsystems recommends that you do not set this parameter to a value less 
than the default interval (72 hours). 

■ NetBackup VolMgr Install Path - Specify the fully qualified to the NetBackup 
Volume Manager. The default value is C:\Program Files\VERITAS\VolMgr.

■ Full path to NetBackup catalog directory - Enter the directory that will be the 
target of the cat_usage command. The default value is C:\Program\Files\
VERITAS\NetBackup\db\Images.

11. Click Show Advanced Settings to review/modify the following configuration 
parameter:

■ Enable Auto Registration – Turns agent auto registration on (default) or off.

12. With “Save Configuration Settings” turned on (check mark), select File->Save 
and confirm saving changes to the storability.ini file.

13. Select File->Exit to close the Configuration Tool.

14. Use the Windows Services panel to start the Storability NetBackup Agent before 
you verify agent functionality.
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Installing NetBackup Agent on HP-UX 
All currently supported HP-UX agents are provided as zipped tar archives with 
installation scripts. To install an agent, simply ensure that the archive  
(netBackupAgent-hpux.tgz) and the install script (netbackupAgent-install.sh) reside 
in the same location, and run the script. 

./netbackupAgent-install.sh

HP-UX supports neither Rock Ridge nor Joliet extensions to the ISO 9660 filesystem 
specification. As a result, support for long filenames may not be available.

During the installation, the installer must specify the following information:

■ The location of NetBackup if not detected

■ The location of NetBackup vmquery if not detected

■ The location of the NetBackup catalog if not detected

To configure agent auto registration on an HP-UX server, you can add the 
NetBackup Agent to a Local Manager Routing Agent configuration as a 
SUB_AGENT entry or manually add the required entries to the agent storability.ini 
file.  Sample storability.ini file entries appear below.

■ GSM_LM_HOST = 192.168.1.132

■ GSM_LM_PORT = 17146

■ GSM_ENABLE_LM_REGISTRATION = true

Installing NetBackup Agent - Solaris
The Solaris Local Manager Installation CD provides the installation script that is 
used to install the NetBackup Agent. If not already installed, the base package 
(SUNWbizanbase) will also be installed by the script. The following installation 
procedure assumes the SUNWbizanbase package has already been installed.

In addition, you may want to install the Host Agent package to enable collecting 
data for the Meta Database report.

Proceed as follows.

1. Open a terminal window on the desktop of the Solaris host.

2. Mount the installation CD in your CD-ROM drive.

For example:  

mount –o ro –F hsfs /dev/dsk/c0t6d0s0 /mnt
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Note – The device path used for the CDROM device may vary.

3. Change to the CD-ROM mount point. For example: 

cd /mnt/cdrom/cdrom0

4. Run the install script to obtain a list of available Sun StorageTek Business 
Analytics software packages to install.

./setup

5. Select the Veritas Backup Agent from the agents in the list and press Enter.

6. Type zero and press Enter to specify that you have completed the selection of 
agents to be installed.

7. Type the fully qualified directory path where the NetBackup software is installed 
and press Enter.

8. When prompted, type y and press Enter to review/modify the ‘advanced 
settings’ for the NetBackup Agent. As the installation script describes, all 
advanced settings have reasonable default values.

■ automatically restart this agent from the agent monitor - Type y and press 
Enter to have the agent monitored by the agent monitor or press Enter to not 
have the agent monitored (default).

■ netbackup agent collection period - Enter the NetBackup Agent report interval 
that specifies the time range (e.g., last 72 hours) for backup data reporting. Sun 
Microsystems recommends that you do not set this parameter to a value less 
than the default interval (72 hours). 

■ Enable Auto Registration – Turns agent auto registration on (default) or off.

■ Local Manager – Specify the IP address or host name of the Local Manager to 
be contacted for agent auto registration.

■ Local Manager Registration Port – Specifies the TCP port number the Local 
Manager uses for auto registration; the default port number is 17146.

■ Cache Refresh Interval - Specifies how long backup information remains in 
table cache. The default value is 14000 seconds.

■ Event Cache Duration - The default value is 14400 (same as 
CACHE_REFRESH_INTERVAL).

■ Command Execution Timeout - Specifies how long the agent will wait for the 
successful execution of a CLI command and the successful read of the CLI 
output. The default value is 600 seconds.

■ NetBackup Command Path - Specify the fully qualified path to the NetBackup 
software that provides the CLI commands. The default value is C:\Program 
Files\VERITAS\NetBackup.
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■ NetBackup Report Interval - Enter the NetBackup Agent report interval that 
specifies the time range (e.g., last 72 hours) for backup data reporting. Sun 
Microsystems recommends that you do not set this parameter to a value less 
than the default interval (72 hours). 

■ NetBackup VolMgr Install Path - Specify the fully qualified to the NetBackup 
Volume Manager. The default value is C:\Program Files\VERITAS\VolMgr.

■ Full path to NetBackup catalog directory - Enter the directory that will be the 
target of the cat_usage command. The default value is C:\Program\Files\
VERITAS\NetBackup\db\Images.

9. The installation will then prompt to start the agent after the installation.  Enter y 
to start the agent after the installation completes.

10. The installation of the NetBackup Agent will complete and the installation script 
returns control to the command line.  

Legato Agent Version 5.1
The following functional changes have been made to the Legato NetWorker Agent in 
Business Analytics 5.1:

■ Data collection is controlled by the CACHE_REFRESH_INTERVAL variable 
defined in the Legato section of the storability.ini file. 

■ The agent collects data required for the new gsa_backup_jobs object.

Note: The Legato Agent must be installed on the Legato NetWorker backup server.

NetWorker job reporting in Business Analytics 5.1 has the following limitations:
■ Clone jobs are not supported.
■ Retrieve jobs are not supported.
■ Client-side jobs are not supported (they are not reported on the backup server)
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Legato Agent Matrix

TABLE 4 Legato Agent Matrix

Feature Description

Support Prerequisites

Verify supported version of Legato 
NetWorker product

Sun StorageTek Support Matrix

Verify Ethernet connectivity to 
Backup Servers

ping <IP Address>

Agent Installation

Windows Windows Local Manager Installation CD (InstallShield)
Windows Administrator privileges

Solaris Solaris Local Manager Installation CD (installation script)
root user account privileges

Common Configuration Parameters • CACHE_REFRESH_INTERVAL- Specifies how often the 'table cache' 
should be refreshed. The default value is 14400 seconds.

• CMD_EXECUTION_TIMEOUT - Specifies how long the backup agent 
will wait for the successful execution of a CLI command and the 
successful read of the CLI output. The default value is 600 seconds.

Agent Parameters • LEGATO_HEADER_TERMINATOR - When parsing the messages log 
file, the string value specified by this entry indicates the start location 
for parsing each line within the file. If the string value is not found 
within the line being searched, the whole line is treated as an error 
string.

• LEGATO_MESSAGES_FILE - Specifies a fully qualified name to the 
Networker's messages log file, which the Legato Agent searches to 
extract failed backup jobs information.

• LEGATO_LOG_START_TIME - Specifies the ‘look back’ interval; the 
default value is 24 hours. This time interval is passed as a parameter 
to the mminfo command to query back the specified time interval for 
successful jobs. The format is defined in UNIX strftime() as follows: 

     %b %e %T %Y  OR in English: Mmm [d]d HH:MM:SS YYYY
• LEGATO_CATALOG_DIR - Specifies the fully qualified name of the 

Networker's catalog index file.
• NO_COLLECTION - Specifies blocking data collection for specified 

data collection groups or for all groups (ALL).
• NON_COLLECTION_DURATION - Specifies a time interval during 

which data collection for a data group or groups is blocked.
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Installing Legato Agent – Windows

1. Insert the Sun StorageTek Business Analytics Windows Local Manager CD into 
the CD-ROM drive.

2. Click Next on the Welcome menu to continue the installation.

3. Click Yes to accept the terms of the software license agreement.

4. Review/modify the User Name and Company Name and click Next.

5. Click the Legato Agent checkbox on the screen that lists agents for installation 
and click Next.

FIGURE 2 Select Features To Be Installed

6. Review the settings and click Next to continue with the installation.
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7. When the dialog box appears, specify where the required mminfo.exe program is 
located. You can click the Browse button to locate it. 

8. Specify whether or not to install the new version of the Configuration Tool, if 
prompted.

9. When the Configuration Tool is automatically launched, select File -> Edit -> 
Smart Agent Configuration.

10. Click the Legato Agent tab and review/modify the following settings

■ For Local Manager, specify the IP address or the host name of the Local 
Manager to be contacted for agent auto registration.

■ For Local Manager Registration Port, specify the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146.

■ "For Legato Header Terminator, specify the text string that marks the end of 
the syslog stamp and the start of real data. The default value is "[".

11. Click Show Advanced Settings and review/modify the following configuration 
parameters:

■ Enable Auto Registration turns agent auto registration on (default) or off.

■ Legato Networker Message File - Enter the fully qualified file name (e.g., c:\
Program Files\nsr\logs\messages) for the file that provides the list of 
messages contained within the Legato completion reports.

■ Command Execution Timeout - Specifies how long the agent waits for a 
command to complete execution.

■ Directory containing Legato binaries - Enter the full path to the folder where 
the Legato Networker software is installed.

■ Legato Agent Collection Interval - Enter the polling interval in seconds to scan 
for new completions of server backups in the Execution Interval column. This 
parameter is optional.  If not specified it defaults to one half hour (14400 
seconds).

■ Legato Index Directory - Enter the full path to the Legato index directory.

■ Legato Log Start Time - Specifies the time the agent looks back for backup data. 
There is no default value. If blank, the agent looks back 24 hours.

12. With “Save Configuration Settings” turned on (check mark), select File->Save 
and then close the storability.ini window.

13. Select File->Exit to close the Configuration Tool.

14. Use the Windows Services panel to start the Legato Agent before you test agent 
functionality.
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Installing the Legato Agent – Solaris
The installation script (setup) is used to install the Legato Agent on a Solaris server. 
The installation script will verify that the required base (SUNWbizanbase) package is 
already installed. If it is not installed, the script will automatically launch its 
installation before proceeding to that for the Legato Agent. 

1. Open a terminal window on the desktop of the Sun host.

2. Mount the installation CD in your CD-ROM drive.

3. Change to the mount CD-ROM directory. For example:

  cd /mnt/cdrom/cdrom0

4. Run the installation script and display a list of agents that may be installed.

./setup

5. Select the Legato Agent from themain installation 

6. Type zero and press Enter to specify that you have concluded selecting agents for 
installation.

7. Type the install path for the agent or press Enter to accept the default install path 
(/opt/storability).

8. Specify the following required information:

■ Local Manager - Enter the network resolvable host name or IP address of the 
Local Manager that the Legato Agent will contact for agent auto registration, if 
enabled.

■ Local Manager Port - Specify the TCP port number the Local Manager uses for 
agent auto registration. The default TCP port number is 17146.

■ Location of nsradmin - Specify the fully qualified path to directory where the 
nsradmin binary is located.

■ Command Execution Timeout - Specifies how long the agent waits for a 
command to complete.

■ Legato Catalog Directory - Specify the fully qualified path to the NetWorker 
index directory.

■ Legato Messages File - Specify the fully qualified path to the Legato NetWorker 
messages log.

■ Legato Log Start Time - Specifies how long the agent looks back for historical 
data. The agent looks back 24 hours if no value is specified.

■ Legato Header Terminator - Specify the text string that marks the end of the 
syslog stamp and the start of real data. The default value is "[".

■ Legato Command Path - Specifies the fully qualified path to the file containing 
commands used to gather client data.
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9. Type y and press Enter to review/modify the Advanced Settings:

■ Enabled Auto Registration – Turns agent auto registration on (default) or off.

■ Enter the MAXIMUM_CACHE_AGE (in seconds).

■ Enter the Data Collection Interval (in seconds).

10. Enter y to restart the agents after installation.

11. The installation will complete and return you to the command line.

Installing Legato Agent on HP-UX 
All currently supported HP-UX agents are provided as zipped tar archives with 
installation scripts. To install an agent, simply ensure that the archive  (legatoAgent-
hpux.tgz) and the install script (legatoAgent-install.sh) reside in the same location, 
and run the script. 

./legatoAgent-install.sh

HP-UX supports neither Rock Ridge nor Joliet extensions to the ISO 9660 filesystem 
specification. As a result, support for long filenames may not be available.

During the installation, the installer must specify the following information:

■ The fully qualified path to the nsradmin binary

■ The fully qualified path to the Networker index directory

■ The fully qualified path to the Networker messages log

■ Legato log start time

■ Table cache refresh interval (default value is 14400 seconds)

■ Timeout for execution of a CLI command (default value is 600 seconds)

■ Whether to re-start the agents after the install?

To configure agent auto registration on an HP-UX server, you can add the 
NetBackup Agent to a Local Manager Routing Agent configuration as a 
SUB_AGENT entry or manually add the required entries to the agent storability.ini 
file.  Sample storability.ini file entries appear below.

■ GSM_LM_HOST = 192.168.1.132

■ GSM_LM_PORT = 17146

■ GSM_ENABLE_LM_REGISTRATION = true
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Tivoli Storage Manager Version 5.1 
Agent 
The following sections describe the installation and configuration of the Sun 
StorageTek Business Analytics Tivoli Storage Manager (TSM) Agent. Currently, the 
TSM Agent must be installed on a supported Windows server. See also the Sun 
StorageTek Business Analytics Support Matrix.

The following functional changes have been made to the TSM Agent in Business 
Analytics 5.1:
■ The TSM agent no longer uses IBM's TSM ODBC driver.  Instead, it uses an 

external executable, odbc.exe. 
■ "Data collection is controlled by the CACHE_REFRESH_INTERVAL variable that 

is defined in the NetBackup section of the storability.ini file. 
■ The agent collects data required for the new gsa_backup_jobs object.
■ Supports the NO_COLLECTION configuration setting that specifies blocking data 

collection for specified data collection groups or for all groups (ALL).
■ Supports the NON_COLLECTION_DURATION parameter that specifies a time 

interval during which data collection for a data group or groups is blocked.

TSM Agent Matrix

TABLE 5 TSM Agent Matrix

Feature Description

Support Prerequisites

Verify supported version of TSM product

Verify Ethernet connectivity to Windows 
2000 server

ping <IP Address>

Verify supported version of TSM ODBC 
Driver

See the TSM ODBC System DSN Prerequisite 
section that follows

Verify customer-supplied login/password 
with query privileges or higher for each 
TSM database connection
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TSM ODBC System DSN Prerequisite
The procedure to create the required System Data Source Name is outlined as 
follows:

1. Select Start->Settings->Control Panel -> Administrative Tools from the Windows 
desktop.

2. Select ODBC Data Sources to launch the ODBC Data Source Administrator.

3. Click the System DSN tab.

4. Click Add and the Create Data Source screen appears.

Agent Installation

Windows 2000/2003 • Windows Local Manager Installation CD 
(InstallShield)

• Windows Administrator privileges

Configuration Parameters See required configuration parameters in the 
Installation section that follows.

TABLE 5 TSM Agent Matrix

Feature Description
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FIGURE 3 Create New Data Source for TSM ODBC Driver

5. Use the scroll bars to verify a supported version of the TSM ODBC Driver is 
installed, and select the TSM ODBC Driver for the data source you are creating. 
The Configure a Data Source screen appears.

6. Enter a descriptive name for the System DSN that will be used to connect to a 
TSM database server in the Data source name field.
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7. Enter the TCP/IP address to connect to the TSM database server in the TCP/IP 
address field.

FIGURE 4 Configure a TSM Data Source

Note – Sun StorageTek highly recommends that you use a third party ODBC query 
tool (e.g., QTADO) to verify the System DSN before you deploy it with a TSM Agent.

Installing the TSM Agent – Windows
The following section describes how to install and configure the TSM Agent on a 
Windows platform. 

1. Insert the Local Manager CD into the CD-ROM drive.

2. Click Next on the Welcome menu to continue the installation.

3. Click Yes to accept the terms of the software license agreement.

4. Review/modify the User Name and Company Name and click Next.

5. Click the TSM Agent checkbox on the screen that allows you to select agents for 
installation and click Next.
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FIGURE 5 Agent Selection Dialog

6. Review the settings and click Next to continue.

Note – Installation checks for an instance of the TSM ODBC driver. If one is not 
detected, a dialog box appears that asks the installer to specify whether or not to 
continue the installation.

7. Specify whether or not to install the new version of the Configuration Tool, if 
prompted.

8. When the Configuration Tool is automatically launched, select File -> Edit -> 
Smart Agent Configuration.
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9. Click the TSM Agent tab and click Add..

10. Review/modify the following variables:

■ DSN - The data source name that you configured when you created the System 
DSN 

■ TSM Server Prefix- Optional string to be pre-pended to the server name TSM 
returns for this DSN. For example, host_name_servername.

■ User ID - User name to log into the TSM database

■ Password – Password for the user to log into the database 

■ Period for Queries – Time interval (in seconds) that the agent should look back 
for historical queries. The default value is 86400 seconds (1 day).

11. For Local Manager, enter the network resolvable host name or IP address of the 
Local Manager to be contacted for agent auto registration.

12. For Local Manager Registration Port – Specifies the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146.

13. Click Show Advanced Settings to review/modify:

■ Enable Auto Registration - Turns agent auto registration on (default) or off.

■ Data Collection Interval (seconds) – Specifies how long agent data is cached; 
the default interval is 2400 seconds.

■ Enable Auto Registration - Turns agent auto registration on (default) or off.

■ Agent Command Timeout Interval (seconds) - Controls how long the agent 
will wait for a single SQL statement that is sent to the command line interface 
to return with data. The value is 600 seconds (10 minutes).

■ Cache Refresh Interval - Specifies the frequency to refresh the agent's cache; 
the default interval is 14400 seconds.

■ TSM_SERIALIZE_CACHE_UPDATE - This configuration setting controls 
whether or not the data object cache updates occur one-at-a-time (default) or in 
parallel. The agent will allow for the updates to each happen in their own 
thread concurrently (false) with other data object cache updates. However, be 
aware that while the TSM Agent can handle this, the TSM Server could be 
heavily taxed by this setting if the data load is large. As a result, it is 
recommended that you accept the default value (true).

■ TSM_LOCAL_DATE_FORMAT - Specifies the TSM local date format. The 
default value is Year/Month/Day/Time.

14. With “Save Configuration Settings” turned on (check mark), select File->Save 
and confirm saving changes to the storability.ini file.

15. Select File->Exit to close the Configuration Agent.

16. Use the Windows Services panel to start the Storability TSM Agent before you 
verify agent functionality. 
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Starting the agent will initiate a data collection. Depending on the size of your 
backup environment, this can utilize a significant amount of memory.

Verifying Backup Agent
Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to verify the 
Backup Agent functionality. This tool is installed as part of the Central Manager or 
Local Manager software installation in the Storability Local Manager Utilities folder. 
It represents the primary tool to verify agent functionality or troubleshoot agent 
problems. 

Proceed as follows:

1. Wait approximately 30 seconds after the particular Backup Agent (e..g., 
NetBackup Agent) has started to allow it to initialize before querying it with the 
Agent Diagnostic Tool.

a. In the Agent location window, enter the IP Address or network resolvable Host 
Name of the server where the agent is installed in the ip address/host name 
input box.

b. Select the backup agent (e.g., Storability NetBackup Agent) from the drop 
down list of service names.

c. Click the Get Object List button and you should receive a list of objects 
published by the agent. 

d. Check the agent configuration settings in the storability.ini file; collect the 
gsa_ini_control-2_0 object.

a. Select the gsa_backup_client_policy-2_2 object and verify that data is returned 
including IP Address, client, and policy.

a. Proceed to verify all other objects published by the agent. 

2. To verify the Backup Agent has registered successfully with its configured Local 
Manager:

a. In the Agent location window, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box.

b. Set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names). 

c. Click the Get Object List button and you should receive a list of objects 
published by the Routing Agent.

d. Select the gsa_agent_register table.
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e. Verify this collected object reports the Backup Agent in the “active_peer” field 
by IP address (where the agent is installed) and appropriate port number:

NetBackup Agent – TCP port number is 17133.

Legato Agent – TCP port number is 17149

TSM Agent – TCP port number is 17156

Verifying Management Console 
Functionality
The following procedure describes how the administrator verifies the Backup 
Agent’s reports in the Management Console. Refer to the Administration chapter to 
obtain information on the administrative menus you can access from the Tools pull 
down menu, including the Polling and Change Dashboard menus.

Note – Note: You must be assigned Backup Administrator privileges to have access 
to the Backup Exceptions, Meta Database Capacity, Real Time Events, Backup 
Exposure, and TSM Daily Administration reports. Refer to the User Administration 
section of the Administration documentation to obtain additional information.

1. Log in to the Management Console as an administrative user (e.g., gsmuser) 
whose view provides access to the desired assets (e.g., sites).

2. Verify that your customized Home Page includes the Backup Status Summary 
dashboard or the TSM Summary Report pane as appropriate (or use Change 
Dashboard to choose one).

3. Select Tools->Polling. In the Data Polling Schedule menu, locate appropriate 
Collection Type and Collection Metric polling schedules for the backup product. 
Business Analytics 5.1 segments data into six data collection groups: Config, 
Jobs, Media, Schedule, TSMOptional, and NetbackupOptional. 

4. Click the Collect Now for the first on-demand agent data request for a Collection 
Type and Collection Metric related to the Backup Agent.

5. Repeat the above step until you have collected all the desired data. Wait 
approximately thirty seconds between each on-demand agent data collection 
request.
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Note – The actual time it takes to collect backup information will vary depending 
on the size of the backup environment.

6. Close the Polling Schedules window.

7. Select Database Administration from the Tools menu.

8. Select Refresh Management Console Homepage cache and click Submit..

9. Use the Backup Status Summary pane for Veritas/Legato or the TSM Summary 
Report pane to determine if collected data is visible through the Management 
Console. It is normal for the Backup Status Summary pane to not display 
information if no failures occurred over the past 24 hours.

10. Close the browser session with the Management Console as the above steps 
complete verifying basic Management Console functionality.

Backup Agent Troubleshooting
1. Verify system/agent prerequisites – Refer to Sun StorageTek Business Analytics 

Support Matrix to verify the most recent support requirements for the Backup 
Agent.

2. Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to save the 
output for all the agent published objects if escalating a problem to Sun Technical 
Support.

a. Run the agent diagnostic tool from its installed program folder.

b. Enter the IP Address or Hostname of the server where the agent is installed 
and set the port by selecting the Backup Agent from the drop down list of 
service names.

c. Click the Get Object List button and you should receive a list of tables 
published by the Backup Agent. If unsuccessful, verify the Ethernet 
connectivity to the server running the Backup Agent and that the agent is 
running.

d. Select the alerts-3_1 table and examine the Description column for each 
reported alert.

e. Select File->Save All and the “This action will network fetch all objects 
published by the currently specified agent and save the data to a single file.” 
Message appears. 
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f. Click OK and the Save As dialog appears. 

g. Enter a meaningful file name and click OK to initiate the collection.

3. Review the Message Log – Review/collect the agent’s Message.log file that can 
contain information on startup errors, configuration errors, or errors regarding 
accessing data or parsing output.

For Windows:

■ Located by default in: <drive>:\Program Files\Storability\GSM\Agents\
Storability <Backup Agent> Agent folder.

■ Can enable debug level logging by appending LOG_SEVERITY=Debug to the 
Backup Agent section of the storability.ini file (if a Support representative 
requests it).

For Solaris:

■ The agents’ common Message.log file located by default in: 
/opt/storability/data.

■ Can enable debug level logging by appending LOG_SEVERITY=Debug to the 
Backup Agent section of the storability.ini file (if Sun Support requests it).

4. Verify Local Manager Registration - The configured Local Manager 
gsa_agent_register table should be reviewed to verify a registration type (STATIC 
or AUTO_NET) is reported for the backup agent. If static registration is being 
used and no agent registration is reported, verify the necessary SUB_AGENT 
entry has been added to the Routing Agent’s storability.ini file and restart the 
Routing Agent.

If agent auto registration is being used and no registration is reported in 
gsa_agent_register, proceed as follows:

 Routing Agent’s storability.ini file has “Activate Agent Registration” turned on.

 Backup Agent is configured for agent auto registration:

– Valid Local Manager IP address/host name

– Local Manager TCP port number is 17146 (default port number)

– Enable auto registration is turned on (true)

5. Review the Routing Agent Message Log – Review/collect the configured 
Routing Agent’s Message Log to check for errors related to Ethernet connectivity 
problems contacting the Backup Agent.

6. Confirm Polling Schedules – Using the Management Console’s Polling 
Schedules window, review/modify the existing Polling Schedules for the 
Collection Type and Backup product. Clicking the Job ID link on the Polling 
Schedules window opens the Add a New Polling Job window where changes can 
be made.
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FIGURE 6 Add a New Polling Job

7. Review Aggregator Message Log – Open the Aggregator’s Message Log in a text 
editor and validate that the Backup Tables are being requested and that rows are 
being inserted into the database.

The log contains two entries, TID (Transaction ID) and SID (Session ID), which 
can help you locate (e.g., Find) and view relevant logged entries. For scheduled 
polling requests, the TID will be equal to the Job ID in the Polling menu. Each SID 
is a unique identifier for a particular agent data collection session. For on-demand 
polling requests, the TID is a uniquely generated TID (not the Job ID) and SID, 
and the TID and SID will be equal to the same integer value. 

8. Check the assurent database – The assurent database is the data repository for 
your GSM application. For the Backup Agent, use any MS SQL Query interface, 
such as isql, to verify rows have been inserted into the Backup-related tables for 
the particular backup product.  Refer also to Table 2 - Populated Tables Matrix.
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9. Verify Management Console Functionality – As a final step in the agent 
troubleshooting procedure, minimally verify that the Backup Status Summary or 
TSM Summary Report dashboard pane works properly.

Upgrade Requirements
In order to take advantage of the new features described in this manual, it is 
necessary to upgrade to Business Analytics 5.1. At a minimum, the following 
components must be upgraded:

■ Central Manager database

■ Central Manager agents

■ Management console

■ All backup agents

Be aware that:

■ Business Analytics 5.1 will not collect data from earlier backup agents.

■ Business Analytics 5.0 will not collect data from 5.1 backup agents. 

■ As part of the database upgrade to Version 5.1, data will be moved from the 
legacy backup tables to the new jobs table for reporting.  

Upgrade Backup Agent 
To upgrade a Sun StorageTek Business Analytics Backup Agent, you perform the 
following procedure:

1. Uninstall the previously installed Backup Agent.

2. Upgrade by installing the latest Sun StorageTek Business Analytics Backup Agent.

Uninstall Backup Agent – InstallShield
1. Do one of the following:

■ Select Start->Program Files->Storability->Uninstall->Uninstall Local 
Manager     
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■ Start->Program Files->Storability->Uninstall->Uninstall <Backup Agent 
Name>.  The Storability Uninstall dialog appears.

2. Click the checkbox for the particular agent (e.g., NetBackup Agent).

3. Click Next>. The Question dialog appears.

4. Click Yes to confirm the uninstalling the agent. An uninstalling agent splash box 
appears as each selected agent is uninstalled.

5. When the InstallShield Wizard Complete dialog box appears, click Finish.

Uninstall Backup Agent – Solaris
1. Create a backup copy of the existing storability.ini file.

2. Mount the installation CD in the CD-ROM drive.

3. Change directory to the CD-ROM directory.

4. Type:

setup -u

5. Type the number of the agent to be uninstalled and press Enter.

6. Type zero and press Enter to specify that you have completed specifying agents to 
be uninstalled.

7. At the “do you want to remove this package” prompt, enter y and press Enter.

8. At the “do you want to continue the removal of the package?” prompt, type y and 
press Enter. The “Removal of Business Analytics <agent name>” agent was 
successful” message should appear to indicate the package was removed 
successfully.

Reinstall Backup Agent – Non-Solaris UNIX Host
The reinstallation procedure for all Business Analytics agents supported on non-
Solaris UNIX hosts, such as the NetBackup Agent on a HP-UX server, requires that 
the installer perform the following steps before running the agent’s installation 
script:

1. Make a backup copy of the existing agent configuration file (storability.ini).

2. Make a backup copy of the contents of /opt/storability/etc/agents.



37

3. Open the existing agent configuration file (storability.ini) in a system text editor.

4. Locate the configuration section for the agent to be reinstalled.

5. Delete all existing configuration settings for that Storability agent.

6. Save the modified agent configuration file.

7. Remove the existing /opt/storability/etc/agents directory.

At this point, you may reinstall the agent using the agent’s installation script.
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