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Introduction to Administration
This chapter explains the administrative menus of the Sun StorageTek Business 
Analytics Management Console. Your User ID must be defined with permissions to the 
administrative menus for you to have access to the Tools menu selections.

Note: With the acquisition of StorageTek, Sun Microsystems has re-branded and re-
named Global Storage Manager (GSM) as Sun StorageTek Analytics, a member of the 
Enterprise Storage Manager portfolio of software solutions. 

Administrative Functions Overview
The following table provides an overview of the administrative functions that can be 
accessed using the Tools pull-down menu.

Menus Administrative Functions
Dashboard 
Administration

• Create new dashboard or view, modify, or remove existing 
dashboards.

• Set the current dashboard.
Change Password • Change and confirm your new password.
View Administration • Create a new view, modify an existing view, or remove a 

view.
User Administration • Add, view, modify, or delete Sun StorageTek Business 

Analytics users, manage their assigned views and 
dashboards, or reset a user’s password. 

Policy Alerting • Add, modify, or delete policies based on user-specified alert 
thresholds or conditions.

Reporting 
Administration

• Perform backup reconciliation for jobs, run the backup 
reconciliation report, add backup reconciliation reasons to 
the database. 

• Configure TSM report parameters that include the start/end 
report dates. 

• Modify or delete scheduled reports.
• Maintain aliases for array IDs; switch World Wide Names 

(WWNs), and fabric WWNs.
• Maintain user-defined asset fields
• Maintain allocation forecast information.

Site/Local Manager 
Administration

• Create, list, modify, or delete sites or Local Managers.

Data Polling Schedule • Enable/disable, view, add, modify, or delete polling 
schedules for all Collection Types (e.g., Array) and 
Collection Metrics (e.g., Performance).

SRM Agent 
Configuration

• Configure the scan schedule, filters, and other 
miscellaneous configuration parameters for the SRM Agent. 

Application Status • Monitor agent status or agent alerts throughout your 
deployment.

• View the license report.
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Menus Administrative Functions
Database 
Administration

• Maintain table purge records.
• Refresh capacity allocation.
• Maintain database batch jobs.
• Refresh homepage cache.

Table 1 - Tools Pull Down Menu

Dashboard Administration
A dashboard is a set of panes on the Management Console home page. Dashboard 
Administration allows the user to view existing dashboards, set their current dashboard, 
as well as add, modify, or remove dashboards.

Change Dashboard
Change Dashboard allows you to choose your customized Management Console home 
page. 
Note: After a current dashboard is selected, it persists between Management Console 
login sessions until that dashboard is changed. The Manage Dashboards menus allow 
you to create, modify, and delete dashboards that can be selected as the current 
dashboard (or customized Home Page).

Proceed as follows:

1. Log in to the Management Console.

2. Select Dashboard Administration -> Change Dashboard from the Tools pull-
down menu. The Change Dashboard Selection window appears.

Figure 1 - Change Dashboard Selection

3. Change Dashboard Selection contains a table with radio boxes under the Select 
heading allowing you to select a dashboard as well as the Dashboard Name, 
Dashboard Type (private or public), and Description fields. The window also contains 
the Set as Current Dashboard and Close buttons. Clicking Close will close this 
window.
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4. To set the current dashboard, proceed as follows:

a. Use the radio box under the Select heading to choose the desired dashboard.

b. Click the Set as Current Dashboard button. The “Default Dashboard has been 
changed. Click the OK button to close this window and refresh the Home Page” 
dialog appears.

c.  Click OK and the customized Home Page will appear.

Manage Dashboards
Manage Dashboards allows you to create personalized dashboards (customized Home 
Pages) that may be selected as current by users.  You select the panes (i.e., Server, 
Array, Backup, Library, etc.) that will appear in the dashboard that you create.

Note: The dashboard panes are refreshed every four hours by default through a 
database batch job. However, the administrator can use the Refresh Homepage Cache 
functionality under Database Administration to manually refresh the cache tables 
whenever necessary. For example, using Refresh Homepage Cache would be useful after 
a “Collect Now” polling job request has occurred.

Proceed as follows:

1. Log in to the Management Console.

2. Select Dashboard Administration-> Manage Dashboards from the Tools pull-
down menu. The Manage Dashboards window appears. 

It contains a selection radio box and the dashboard Name, Description, and 
dashboard Type fields. It also contains the Remove Selected, Create New, and 
Close buttons. Clicking Close closes the Manage Dashboards window.

The checkbox next to the Dashboard Name heading is used to select all 
dashboards displayed in the table. You can click on either the Dashboard Name or 
Dashboard Type to select the table sort order.
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Figure 2 - Manage Dashboards

Add New Dashboard
3. To add a new dashboard, proceed as follows:

a. Click the Create New button and the Dashboard Administration: Create 
New Dashboard window appears.

Figure 3 - Dashboard Administration: Create New Dashboard

b. Type a meaningful name in the Name input box.
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c. Use the Dashboard Type pull-down list box to specify whether this dashboard 
will be available to just this user (private) or all Sun StorageTek Business 
Analytics users (public).

d. In the Components in the layout check boxes, use the check boxes to specify 
each type (Storage, Tape Library, etc.) of component to be displayed on the 
customized Home Page. A check mark in a checkbox enables that pane.

• Storage – Adds the Storage Allocation Overview pane.

• Network Attached Storage – Adds the NAS Device Overview Pane.

• Veritas/Legato Backup Products – Adds the Backup Summary Status 
pane.

• TSM Backup Product – Adds the TSM Summary pane.

• Tape Library – Adds the Tape Library Overview pane.

• Server – Add the Host Filesystem Utilization pane.

• Database – Adds the Database Management pane.

• Fabric – Adds the Fabric Utilization Overview pane.

• NAS Filesystems – Add the NAS Filesystem Overview pane. 

Note: The agent data that appears in a customized Management Console Home 
Page will depend on the actually deployed Smart Agents, the user’s assigned views, 
and when Sun StorageTek Business Analytics refreshes that pane. 

e. Click Save and the Manage Dashboards window will refresh with the new 
dashboard listed in its table.

Remove Selected Dashboards
Note: You must be the owner/creator of a public dashboard to have the security access 
rights necessary to remove it.

4. Using the checkboxes, specify the dashboard(s) that you want to remove or click the 
checkbox beside the Dashboard Name heading to select all the dashboards in the 
table.

Note: A Business Analytics user must be the owner or creator of a public dashboard 
to modify or remove that dashboard. 

5. Click the Remove Selected button. The “Are you sure you wish to remove the 
selected dashboards from the system? All component assignments to these 
dashboards will be deleted!” dialog appears.

Sun StorageTek Business Analytics Administration Page 9



Figure 4 - Remove Dashboards Confirmation Dialog

6. Click OK to confirm removing the dashboards and the Manage Dashboard window 
is refreshed. The selected dashboards will no longer appear in the table. Clicking 
Cancel cancels the removal and returns you to the Manage Dashboards window.

Change Password
To reset your password, proceed as follows:

1. From the Tools pull-down menu, select Change Password and the Change 
Password window is displayed. It provides input boxes that allow you to change 
and confirm a new password. Clicking Clear removes all characters you have 
typed in the input fields. Clicking Close closes the Change Password window.

2. Enter and confirm a new password in the New Password and Confirm Password 
fields, respectively.

3. Click Save. The “Your password has been successfully changed” dialog appears.

Figure 5 - Password Changed Dialog

4. Click OK to complete the procedure.

View Administration
A view is a collection of assets, or a collection of other views. The View Administration 
menus allow the administrator to manage the assets and which users have access to 
them. Report security is controlled by what view is assigned to the user. 

There are two view types: Asset View and Composite View. An Asset View is assigned 
any number of monitored assets. An asset is a physical device or application.  These 
include servers, arrays, switches, NAS devices, databases, and tape libraries.  A site is 
also considered an asset, and it provides visualization of all the resources within that site 
in the Sun StorageTek Business Analytics reports. A Composite view is comprised of one 
or more views.

Note: A Composite View cannot contain other Composite Views. It can only contain 
Asset Views.
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After you have added all the sites into the Sun StorageTek Business Analytics 
application, you should create an enterprise-level view that has the following 
characteristics:

• Is an Asset View (not Composite View).
• Contains all the sites in your entire infrastructure. 
• Is assigned to the overall administrator(s) at your company.

The Management Console’s Site/Local Manager Administration menus allow you to 
add all of your sites.

Proceed as follows:

1. Log in to the Management Console.
2. From the Tools pull-down menu, select View Administration and the Views 

Wizard window appears.

Figure 6 - Views Wizard

The Views Wizard allows you to:
• Create a view
• Modify an existing view
• Delete a view

Notes: Adding a particular asset category to a view enables the menu options for that 
category. Adding a site adds all the assets in that site and enables the associated menu 
options. Clicking Cancel cancels the operation and closes the Views Wizard. Clicking 
Close causes the home page to be redrawn with newly defined views accessible using 
the View selection pull down on the top right section of the home page.

Create Asset View
Sun StorageTek Business Analytics supports two view types: Assets View and Composite 
View. This section describes how to create an Asset View.
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1. In the Views Wizard, use the radio box to select Create New View and click 
Next>>. The Create View window appears.

2. Type a meaningful name for the view in the Name input box.
3. Use the View Type selection box to choose Asset View. An Asset View consists of 

physical assets, such as servers and arrays.
4. Optionally type descriptive text for the view in the Description box. The description 

may consist of up to 255 characters.

Figure 7 - Create Asset View 

5. Click Next>> to continue. The View Administration: Add Assets to View window 
appears. 

6. Click the down arrow beneath the “What type of asset do you wish to add to this 
view?” list box and select the type of asset (e.g. Arrays).

7. Click the List button.  The View Administration: Add Assets to View window is 
updated with a list of the available assets for the selected asset type. 

8. Sequentially view and then assign assets to your view:
• Sites – View/select sites from a table that contains the asset type (site), name, 

location, and description fields. Select the site(s) you want to assign to the view 
and then click Add to View. See Figure 8 – View Administration: Add Assets to 
View. If you add a site to a view, you are automatically adding all the assets in 
that site to the view. You do not need to add them individually.

• Arrays– View/select arrays from a table that contains the asset type (array), 
name, location, and description fields. Select the array(s) you want to assign to 
the view and then click Add to View. This activates the storage menus accessed 
through the Storage pull down menu.

• Hosts – View/select host servers from a table that contains the asset type 
(hosts), name, location, and description fields. Select the host(s) you want to 
assign to the view and then click Add to View. This activates the menus 
accessed through the Servers pull down menu.

• Backup Client and Policies - View/select backup clients.  Use the series of pull 
down list boxes to select (a) all sites or a particular site, (b) all backup (e.g., 
master server) or a particular server, and (c) all policies or a particular policy. 
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Click the List Clients list box to view a listing of clients that meet your specified 
selection criteria. Select the backup client(s) you want to assign to the view and 
then click Add to View. This enables the Backup Job Wizard and the TSM menus. 
Certain backup menu options are controlled by user privileges, as described in 
the subsequent User Administration section.

• Fabric Switches – View/select fabric switches from a table that contains the 
asset type (fabric switches), name, location, and description fields. Select the 
fabric switches you want to assign to the view and then click Add to View. This 
activates switch menu options accessed through the Fabrics pull down menu.

Figure 8 - Add Assets to View

• NAS devices - View/select NAS devices from a table that contains the asset type 
(NAS devices), name, location, and description fields. Select the NAS device(s) 
you want to assign to the view and then click Add to View. This activates the 
NAS menu options accessed through the Storage pull down menu.

• NAS Filesystem – View/select NAS file systems for a selected site and NAS 
server. Select the NAS file systems and then click Add to View. Note: Qtrees 
are not displayed in the list of filesystems. You can add only filesystems to the 
view and not qtrees. A qtree is similar in concept to a partition. It creates a 
subset of a volume to which a quota can be applied to limit its size. As a special 
case, a qtree can be the entire volume. If there are files and directories in a 
volume that do not belong to any qtrees, the filer considers them to be in qtree 
0. Qtree 0 can take on the same types of attributes as any other qtrees. 
Currently, be sure to add the NAS filesystems to an asset (not composite) view.

• Tape Libraries - View/select tape libraries from a table that contains the asset 
type (Tape Libraries), name, location, and description fields. Click the libraries 
you want to assign to the view and then click Add to View. This enables the 
tape library menus accessed through the Backup/Restore pull down menu.

• Databases - View/select databases from a table that contains the asset type 
(databases), name, location, and description fields. Click the database(s) you 
want to assign to the view and then click Add to View. This enables the 
database menu options.
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9. After you have selected the desired assets, click Add to View. The “<asset type> 
assets added successfully” message is displayed.

10.After you have completed assigning assets, click Next>> to continue or Finish to 
give users access to the view at a later time.  If you click Next>>, the View 
Administration: Manage Users window appears.  

11. The table contains checkboxes that allow adding currently unassigned users to the 
view. You can click the checkbox next to the User Name heading to select all users 
in the table.

Figure 9 – View Administration: Add Users to View

  
12.After you select one, several, or all users, click Add to View. If there are unassigned 

users, the table is updated with these users.
13.Click Next>> and the Create View – Summary window is displayed similar to the 

one shown below.
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Figure 10 - Create View - Summary

The Create View – Summary window contains the following summary-level 
information about the view:
• View “<view name>” created successfully
• Name – View name
• View Type – Asset View
• Description – Description of view, if defined
• Asset List table – Specifies asset type, name, location, and asset’s description
• User List table – Specifies the user name, first name, and last name

14.Click Finish>> and the Views Wizard window is displayed.
You can print this report as a record of your view configuration. 
At this point, if you select Close, the home page will be refreshed, ensuring that the 
new view appears in the Views pull down menu on the home page. If you select Cancel, 
the home page is not refreshed. Any change that you have made will be visible the next 
time the home page is refreshed.

Create Composite View
This section describes how to create a Composite View that consists of one or more 
Asset Views, which have already been defined in the Sun StorageTek Business Analytics 
application.
1. In the Views Wizard, use the radio box to select Create New View and click 

Next>>. The Create View window appears.
2. Type a meaningful name for the view in the Name input box.
3. Use the View Type selection box to choose creating a Composite View. 
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Figure 11 - Create View - Composite View

4. Click Next>> and the View Administration: Add Child Views to View window is 
displayed. The table lists all the current asset views in the table and contains 
checkboxes to allow their selection. The columns are described as follows:

• Asset Type – Is listed as “views” 

• Name – Name of asset view

• Location – Is listed as N/A (not applicable)

• Description – Description of asset view, if defined

5. Using the checkboxes, select the Asset Views you wish to add to the composite view 
and click Add to View. A checkmark in a checkbox selects that view.
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Figure 12 - Add Child Views to View <view name>

6. After you have completed assigning asset views, click Add to View.
7. The “Do you want to add selected assets to view?” dialogue appears. 

Figure 13 - Do you want to add selected assets to view?

8. Click OK to confirm adding the asset views to the Composite View or Cancel to 
cancel and return to the Add Child Views to View <view name> window.

9. Click Next>> to continue or Finish to give users access to the view at a later time. 
If you click Next>>, the View Administration: Add Users to View appears. Use 
this window to assign the Composite View to the desired users. The table lists the 
user name, first name, and last name of each user in the database.

10.Use the checkboxes to choose one, several, or all users and click Add to View. If 
some users were not selected, these users appear in the table.

11.Click Finish>> and the Views Wizard window is displayed.

Modify Asset View
When you modify an Asset View, you can add or remove asset(s) to/from that view as 
well as add or remove a user’s access to the view.

1. Select Modify Existing View on the View Wizards window. 
2. The Modify View Window appears. It contains a listing of views identified by the 

name, view type, and location fields. The View Type is either Asset or Composite.
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Figure 14 - Modify View

3. Using the radio box, choose the desired Asset View and click Next>>.
4. The View Administration: Manage Assets window appears.  This screen shows all 

the assets currently assigned to your view.

Figure 15 - View Administration: Manage Assets Administration: Manage 
Assets 

Add Assets
a. Click to display the View Administration: Add Assets to View window. 

b. Use a combination of the “What type of asset do you wish to add to this view?” 
list box and the List button to view/add assets to the view you are modifying. 
The system will only list assets not already assigned to the view.
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c. Select the desired assets to add and click Add to View. Click Next>> and the 
View Administration: Manage Users window appears.

d. Modify the list of users with access to the View and click Finish.

Remove Assets

a. Use the selection box to choose the assets to be removed.

b. Click Remove Assets. When prompted, click OK to confirm removing the assets 
from the view.

Modify Existing View – Composite View
When you modify a Composite View, you can add or remove child views to/from that 
view as well as add/remove users.

1. Select Modify Existing View on the View Wizards window. 
2. The Modify View Window appears. It contains a list of views identified by the name, 

view type, and location fields. The View Type is either Asset or Composite.
3. Using the radio box, choose the desired Composite View and click Next>>. The 

Manage Assets window is displayed for the selected Composite View.

Figure 16 - Manage Assets - Composite View

Add Child Views
a. Click Add Child Views to display the View Administration: Add Child Views 

to View window. 
b. Use the list box to select Child Views.
c. Click the List Child Views button. The View Administration: Add Child Views 

to View window is displayed. It contains a list of views not currently assigned to 
the view you are modifying.
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d. Select the desired child views and click Add to View.
e. Add additional child views or click Next>> and the Manage Users window 

appears.
f. Add/remove user’s access to the modified view and click Finish.

Remove Child Views
a. Use the selection box on the Manage Assets window to choose one or more child 

views to be removed.
b. Click the Remove Child Views button.
c. When prompted, click OK to confirm removing the child views.

Figure 17 - Remove Child Views

d. Click Next>> to display the Manage Users window that allows you to 
add/remove users assigned to the view, or click Finish>> to complete modifying 
the Composite View.

Delete a View
The Delete a View menu option enables the administrator to delete a view and all users’ 
access to that view. 
Note: If you delete the default view of a user, that user is automatically assigned a view 
since each user must be assigned at least view to view any data within the Sun 
StorageTek Business Analytics reports.

1. Use the radio box on the Views Wizard to select Delete a View.
2. Click Next>> and the Delete Views window is displayed.

Page 20 Sun StorageTek Business Analytics Administration



Figure 18 - Delete Views

3. Use the checkboxes to choose the view(s) to be deleted and click Finish>>. 
4. A confirmation pop up dialog appears after you click OK.

Figure 19 - Delete Views Confirmation

5. Click OK to confirm deleting the view(s) or click Cancel to cancel and return to the 
Delete Views window. 

User Administration
The Users Wizard allows the administrator to:

• View, add, modify, and delete users
• Assign views to users
• Reset passwords 

All users can change their own password.

Proceed as follows:

1. Log in to the Management Console.

2. Select User Administration from the Tools pull-down menu. The Users Wizard is 
displayed.
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Figure 20 - Users Wizard

Create New User
1. Use the radio box to select Create New User and click Next>>. The Add a User 

window is displayed. Be aware that:

• The new user will be asked to change the password upon first login.    

•  Fields in bold are required.

2. Enter the user’s first name, middle initial and last name.

3. Enter the e-mail address to which the username and password will be sent.

4. Enter the user’s phone number.

5. Enter the user name; this cannot contain spaces.

6. Use the Select View list box to choose a default view to be assigned to the user. 
You cannot add a user unless you assign the user a default view. If this is a 
Composite View, the user will also be able to see any Child Views that comprise the 
Composite View.

7. Use the Default Dashboard list box to choose a default dashboard to be assigned 
to the user.

8. For Allow to Manage Accounts, use the radio button to specify if the new user will 
be allowed access the User Administration and View Administration menus. If you 
enable this option, the user can manage any user, including the administrative users. 
As a result, this option should only be enabled for administrators.

9. For Additional Administration Rights, put a check in the check box to enable the 
Administration Right or leave it empty to not assign it to the user. 

The following table describes the menu selections associated with the various 
Administrative Rights.
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Administrative Right Available Menu Selections
All Users Dashboard Administration

Change Password
Allowed to manage user accounts Users Administration

Views Administration
Architecture Administration Site/Local Manager Administration

Data Polling Schedule
SRM Agent Configuration
Application Status 
Database Admin 

Report Administration Policy Alerting
All menu options under Reporting 
Administration
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Administrative Right Available Menu Selections
Backup Administration Backup administrator menus:

• Backup Exceptions
• Meta Database Capacity
• Real Time Events
• Backup Exposure
• TSM Daily Administration

Provisioning Menus Provisioning:
• Storage Provisioning Wizard
• View Storage Reservations

Table 2 - Tools Menu Security Options

10.Enter and confirm the password for the new user; it must consist of 6-10 
alphanumeric characters.

11.Click Next>> to continue. The Manage Views for User <user_name> window 
appears. It contains a table that identifies the views currently assigned to the user as 
well as a selection box to remove views, if desired. 

Note: You cannot delete the top-level, default view in the view hierarchy using the 
Manage Views for User window.

Figure 21 - Manage Views for User

12.Choose one of the following actions:

• Remove from List – Select the views to be removed and click Remove from 
List. A confirmation pop up dialog appears. 

• Asset List – View the Assets Allocated to the User <user_name> window. The 
asset type, name, location, and description are displayed for each assigned asset.

• Assign More – Add views to the user using the Add More Views to User button. 
This window contains a list of views identified by name, location, and description. 
The Add button enables you to add the views you select.
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13.Click Next>> and the Create User - Summary window appears. The window lists the 
following configuration details on the created user:

• User <user name> was created successfully – User was successfully added to 
the database.

• User name

• First name, middle initial, last name

• Phone (if optionally defined)

• Default view

• Default dashboard

• Allowed to manage users

• All additional administrative rights assigned

14.Click Finish and the Users Wizard window is displayed.

You can print this page as a record of the user’s privileges.

An email will be sent to the new user with their username and the assigned password. 
When the user logs into the Management Console for the first time, he/she will be 
prompted to change this password to a user-selected one.

Modify Existing User
This section describes how to modify an existing user. Proceed as follows:

1. From the Tools pull-down menu, select User Administration. The Users Wizard is 
displayed.

2. Select Modify Existing User and the Modify User window appears. It contains a 
selection box and identifies users by user name, first name, and last name.

3. Select the user and click Next>> to continue. The Modify a User window appears.

4. Modify the information in the fields (e-mail address or phone number, default view, 
default dashboard, for example). To change the user password, click the Change 
Password button.

5. By default, the Backup Administration parameter is not checked for upgraded users. 
The Administrator needs to assign administrative rights for those users that need 
them. Without this check box being checked, administrative options on the 
Backup/Restore pull-down menu will be suppressed. Refer to Table 2 to view these 
menu options.

6. Make the desired changes to the user and click Next>>. The Manage Views for User 
<user name> window is displayed. 

7. Perform one of the following actions:

• Remove from List – Select the views to be removed and click Remove from 
List. A confirmation pop up dialog appears. 

• Assign More – Add views to the user using the Add More Views to User window. 
It contains a selection box and a listing of views identified by name, location, and 
description. The Add button enables you to add the views you select.

Sun StorageTek Business Analytics Administration Page 25



• Asset List – View the Assets Allocated to the User <user_name> window. The 
asset type, name, location, and description are displayed for each assigned asset.

8. Click Next>> to continue. The Modify User – Summary window appears. 

Figure 22 - Modify User - Summary

9. Examine the user’s configuration information in the Modify User – Summary window 
to confirm your changes. 

10.Optionally click Print Friendly Page to print the information to a local or network 
printer as a record of this user’s privileges.

11.Click Finish and the Users Wizard is displayed.

Delete a User
Use the Delete a User menu option to remove a user’s access to the Sun StorageTek 
Business Analytics application.

1. From the Tools pull-down menu, select User Administration. The Users Wizard 
appears.

2. Use the radio button to select Delete a User. The Delete Users window is 
displayed. It identifies users by user name, first name, and last name. It does not 
include the logged in user in the table. 

3. Use the selection box to specify the user, users, or all users to be deleted and click 
Finish>>. 

4. The confirmation pop up dialog, shown below, appears. Click OK to confirm the 
action.
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Figure 23 - Confirm Deleting User

5. The Delete User: Status window appears with the “User(s) deleted successfully.” 
status message.

6. The Users Wizard is displayed.   

Policy Alerting
Policy Alerting allows the administrator to:

• View existing policies.
• Modify an existing policy.
• Use a policy template to add a new policy. 

Policy-based management utilizes the Storability Policy Agent and the Sun StorageTek 
Business Analytics database. The Policy Agent has a built-in SMTP client. You must be 
the policy owner to modify a particular policy, and a policy will only be executed if the 
owner has been assigned the asset through a view.

Note: An error message will display if you select Policy Alerting from the home page 
and the COM Agent (Management Console), Policy Agent, and the Scheduler Agent 
(Central Manager) are not running and registered.

The policy templates are briefly described as follows:
• Host Filesystem Alert - Alerts you when a filesystem is close to running out of 

space.
• Host Disk Failure - Alerts you when a physical device on a host (generally a disk 

drive or a LUN from the array) reports a degraded or failed status.
• Access Patterns - Alerts you when the amount of data accessed in a filesystem is 

above or below the defined threshold.
• Storage Allocation - Alerts you when an array is close to running out of space.
• NAS Capacity Alert - Alerts you when a NAS device is close to running out of 

space.
• NAS Quota – Alerts you when an activated hard or soft quota is nearly reached. 
• Fabric Port Status Change - Alerts you when a fabric port changes state.
• Fabric Port Failure - Alerts you when a fabric port goes offline.
• Database Table Rows - Alerts you when the number of rows in a database table 

exceeds the threshold.
• Database Space - Alerts you when a database is close to running out of space.
• Backup Failed Job Summary - Alerts you when a backup job fails for the defined 

servers.
• Backup Drive Status List - Alerts you when a tape drive's status changes to the 

defined value.   
• TSM Disk Pool Alert – Alerts you when a disk pool is getting full.
• NAS Filesystem Quota Alert – Alerts you when a hard and/or soft quota threshold 

is reached.
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• Agent Status Alert – Alerts you when an agent is not running when polled by the 
Routing Agent.

Policy Administration
1. Log in to the Management Console.
2. Select Policy Alerting under the Tools pull-down menu. The Policy 

Administration window is displayed similar to the one shown below.

Figure 24 - Policy Alerting

The window is divided into two tables: the Defined Policies table at the top and the 
Available Templates table beneath it. The Defined Policies table allows the 
administrator to view existing policy details. You can select the Name check box and 
click Delete to remove an existing policy. 

In the Available Templates table, you select the Name link to use the selected 
template to add a new policy to your Sun StorageTek Business Analytics application. 

Clicking Close closes the Policy Alerting window.

Add Policy 
1. From the Policy Administration window, click the desired link (e.g., Host 

Filesystem Alert) in the Available Templates table and the Add/Modify Policy 
window appears. This window displays the following non-modifiable parameters:

o Name – The name of the template
o Description – Description of that policy

o Owner – Administrative user who is creating the policy. This is the only Sun 
StorageTek Business Analytics user who can modify the policy after it is saved 
to the database.
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o View – The user’s current view.

Figure 25 - Add/Modify Policy Window (Host Filesystem Alert)

2. If applicable, specify the Alert Condition, which depends upon the selected 
template; blank is a wild card for “all”:
o Host Filesystem Alert: Host Name (=, LIKE) user-defined variable value
o Host Disk Failure: blank 

o Filesystem Access Patterns: Access Percentage (all) (=, >, <) user-defined value
o Storage Allocation: Used Percentage (*) (=, >, <) user-defined value

o NAS Capacity Alert: Used Percentage (*) (=, >, <) user-defined value
o Fabric Port Status Change: blank 

o Fabric Port Failure: blank 
o Database Table Rows: Row count (*) (=, >, <) user-defined variable value

o Backup Failed Job Summary: Backup Client (=, LIKE) user-defined value and 
Backup Policy (=, LIKE) user-defined value

o Backup Drive Status List: blank
o TSM Disk Pool Alert – TSM Server (=) (LIKE) optional parameter, Disk Pool (=) 

(LIKE) optional parameter, Percent Utilized (blank=all)>, <) user-defined 
required value

o NAS Filesystem Quota Alert – NAS Id (=, LIKE ), Hard Quota Utilization % (=, <, 
>), Soft Quota Utilization % (=, <, >)

o Agent Alert Status - Host Name (=, LIKE) user-defined variable value or ALL 
(blank); agent name = ALL (*) or specific agent name

3. Click the Change Schedule button and the Scheduler window appears. 
4. Use the radio button for the “Perform this job:” parameter to specify whether the 

schedule is to occur once or on a recurring basis. If you specify “on a recurring 
basis”, the window is refreshed with Frequency selections (every minute, hourly, 
daily, or weekly. 

5. Use the radio button to specify the frequency where:
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o Every Minute: The window is refreshed and allows you to specify the job will be 
performed every xx minutes.

o Hourly: Allows you to specify the job will be performed every xx hours.
o Daily: Allows you to specify the job will be performed every xx minutes.

o Weekly: Allows you to specify the job will be performed every xx weeks on the 
selected day of the week.

o Monthly: Allows you to specify the job will be performed every xx months on the 
selected day of the week or date (1-31) of the month.

6. Specify the start date for the schedule:
o Use the hour/minute list boxes to specify a minute of an hour.

o Click the Calendar icon and select a month and year
7. Click Save to save the scheduling information and return to the Add/Modify Policy 

window.
8. Click the Edit Email list button and the Email List window appears.
9. In Address Book, optionally type a fully qualified email address and click Add to 

add a user who is not a Sun StorageTek Business Analytics user to the email 
recipients.

10.  In Address, enable the check box for each user you want to add to the email 
recipients and click the Add Contact List>> button. The selected users appear in 
the Contact List box to the right of the Address list box.

11.Click OK to submit the contact list and return to the Add/Modify Policy window. 
12.Review/modify the “Enable the Policy” setting. By default, the policy is enabled 

(check mark) after it is saved. Remove the check mark if you want to save the policy 
but enable it at a latter time.

13.Review/modify the “Do not send empty email” setting. By default, the Policy Agent 
does not send an email every time it checks the policy condition. Remove the check 
mark if you want an empty email sent every time the agent checks the policy 
condition.

14.Click Save and the policy appears in the Defined Policies table in the Policy 
Administration window.

Modify Policy 
1. From the Policy Administration window, click the desired link policy listed in the 

Defined Policies table and the Add/Modify Policy window appears pre-filled with 
the existing alert condition, schedule, and contact list.

2. Modify the defined policy:
o Click the Change Schedule button to change how frequently or when it is 

performed.
o Click the Edit Email List button to edit an email address or to add/remove 

email recipients.
o Use the respective check boxes to change the status of the policy 

(enable/disable) and/or the sending empty email settings.
3. Click Save to submit the changes.

Delete Policy
1. From the Policy Administration window, select the check box for the existing 

policy to be removed from the database.
2. Click Delete. The Policy Administration window is refreshed and the selected policy 

no longer appears in the Defined Policies table. 
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Policy Email Alert
A sample Host Filesystem Alert is shown below.

Figure 26 - Sample Host Filesystem Alert

The top portion of the report shows the start time and end time for the database query 
that was executed to check the policy condition (Used Percentage>65%). The Host 
Name and Used Percentage parameters are defined in this particular policy. The table 
provides the row from the database table related to the policy condition.

Reporting Administration
The administrator uses the Reporting Administration menus to:

• Maintain backup reconciliation information in the database.
• Modify/delete user-defined scheduled reports.
• Add, modify, or delete aliases for Fabric WWNs, Switch WWNs, or Array IDs.
• Define manual host to HBA mapping for servers that don’t have a Host Agent.
• Define fields that are displayed in asset reports.
• Populate database tables with data used to forecast how much storage will be 

allocated to servers over a user-specified time period.

Backup Reconciliation
Backup Reconciliation enables you to search for backup jobs, select the backup jobs that 
need to be reconciled (those whose statuses need to be changed from success to fail or 
vice versa due to some reason), and to list all the previously reconciled jobs for SLA 
(Service Level Agreement) purposes. The report supports the Symantec NetBackup, 
Legato NetWorker, and Tivoli Storage Manager (TSM) backup applications.

You access Backup Reconciliation by selecting Tools->Reporting Administration -> 
Backup Reconciliation. 
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Figure 27 - Backup Reconciliation

This report allows you to view already reconciled jobs or all jobs and to specify search 
criteria such as the reconciled job status and reconcile reason. 

For the mandatory search criteria, proceed as follows:
• Click the respective calendar icon to specify the start date for extracting data. 
• Use the pull down list boxes to set the time of day for the start and end dates.
• Use the pull down list box to select the desired backup product, which will populate If 

the Site and Job Status drop down list boxes for the selected product.

To specify your selection criteria, use the one or more of the following pull down list 
boxes and click Search:
• Site – Select a site from the list.
• Master Server – Select a master server from the site-specific list.
• Policy – Select a policy from the list populated for your selected master server.
• Client – Select a backup client from the list populated by your selected master 

server and policy.
• Job Type – Select a job type that can be BACKUP, ARCHIVE, or RESTORE.
• Job Status – Select a job status that may be * (all), SUCCESS, FAILED, PARTIAL, 

MISSED, PENDING, IN ROGRESS, STARTED, ADMIN, or OTHER.
• Reconciled Job Status – Select a reconciled job status of * (all), FAILED, or 

SUCCESS.
• Show Reconciled Jobs – Put a check in the check box to have reconciled jobs 

extracted via the query or leave the check box blank to not extract these jobs.

After you click Search, the window refreshes to include a Reconcile button provided 
there was at least one job that matches the criteria. In addition, the refreshed window 
displays a table that lists the jobs that matched the selection criteria. Above the table 
the window contains informational text that indicates how many jobs (e.g., 87) matched 
the search criteria. 
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Figure 28 - Backup Reconciliation Matched Jobs

Using the check boxes beside the Server column, select the job(s) that you want to 
reconcile from success to fail or vice versa and click Reconcile. The Update Jobs For 
Backup Reconciliation dialog appears.

Figure 29 -Update Jobs For Backup Reconciliation

Proceed as follows:
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• For Reconcile Status, use the pull down list box to choose SUCCESS or FAILED. 
• For Reconcile Reason, use the pull down list box to select a predefined reason for 

the backup reconciliation or choose OTHER to allow specifying an ad-hoc 
reconcile reason.

• Optionally, type an ad-hoc reason for the backup reconciliation in the AD-HOC 
Reason field if there is not any suitable predefined reason for the backup 
reconciliation. This text box is only enabled if you have chosen “OTHER” in the 
Reconcile Reason field.

After you have specified information in the dialog, click Update to save the changes to 
the database and refresh the window. The information text is updated to indicate the 
number of jobs that were just successfully reconciled.

Figure 30 - Successfully Reconciled Jobs Information

Backup Reconciliation Report
The Backup Reconciliation report enables you to search and extract backup reconciliation 
information stored in the Business Analytics database. Select Tools->Reporting 
Administration-> Backup Reconciliation Report to access this report.

For the mandatory search criteria, proceed as follows:
• Click the respective calendar icon to specify the start date for extracting data. 
• Use the pull down list boxes to set the time of day for the start and end dates.
• Use the pull down list box to select the desired backup product, which will populate If 

the Site and Job Status drop down list boxes for the selected product.

To specify your selection criteria, use the one or more of the following pull down list 
boxes and click Search:
• Reconcile User – Select the user who created the backup reconciliation record or * 

(all).
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• Reconciled Job Status – Select a reconciled job status of * (all), FAILED, or 
SUCCESS.

• Reconcile Reasons - Select a predefined reason for the backup reconciliation or 
specify OTHER to allow entering text in the AD_HOC Reconcile Reason field.

• Ad-hoc Reasons - Type an ad-hoc reason for the backup reconciliation in the field 
as search criteria. This text box is only enabled if you have chosen “OTHER” in the 
Reconcile Reason field.

A sample report follows.

Figure 31 - Sample Backup Reconciliation Report

Backup Reconciliation Reason
Backup Reconciliation Reason enables you to enter reasons why backup reconciliation 
may occur for certain jobs. Select Tools -> Reporting Administration -> Backup 
Reconciliation Reason to access the Backup Reconciliation Reason window.

For existing reasons, the window contains a table that specifies the system-generated 
Reason ID and the Reason text. To add a new reconciliation reason, click the Add New 
Reason button beneath the table. After the Add New Reason window appears, type the 
reason for a backup reconciliation and click Save.
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Figure 32 - Add New Reason

After you click Save, the window is refreshed to display the new reason in the table. 
In addition, the informational text, “Reason has been added successfully”, appears 
beneath the table.

TSM Report Parameters
The TSM Reporting Module provides a TSM Daily Administration Report that gives a TSM 
Administrator a quick encapsulation of the state of affairs in his TSM environment over 
the last 24 hours.  This report includes various parameters for data such as a defined 
backup window, disk pool utilization and reclamation threshold. 

TSM Report Parameters allows you to modify the current parameters and, thereby, 
change the behavior of the report. You must have backup administration rights to access 
the TSM Report Parameters menu selection under Tools.

1. Select TSM Report Parameters under the Tools pull-down menu. The TSM Report 
Parameters window is displayed.
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Figure 33 - TSM Report Parameters

2. Modify any of the following General parameters:

•  Backup Window Start Time - This parameter is used to calculate the 
beginning of the backup window for the previous day.  For this parameter, only 
the time part is relevant.  For example, if the current date/time is 8/24/2004 
14:30 PM, using the default value (07:00 PM), the beginning of the backup 
window is 8/23/2004 19:00:00.  If set to NULL, the beginning of the backup 
window is 24 hours from the current moment (e.g. 8/23/2004 14:30:00).  Note 
that the default value is NULL meaning the default backup window is “now – 24 
hours” to “now”.

•  Backup Window End Time - This parameter is used to calculate the end of the 
backup window for the previous day.  For this parameter, only the time part is 
relevant.  For example, if the current date/time is 8/24/2004 14:30 PM, using 
the default value (07:00 AM), the end of the backup window is 8/24/2004 
07:00:00.  If set to NULL, the end of the backup window is the current moment 
(e.g. 8/24/2004 14:30:00).  Note that the default value is NULL meaning the 
default backup window is “now – 24 hours” to “now”.

3. Modify any of the following Disk Pools parameters:

• Disk Pool Warning Level and Disk Pool Error Percentage – These 
parameters control the status indicator next to the Disk Pool Count > XX % 
Utilized link on the TSM Daily Status report.  A status of “None” (with a green 
indicator) means that all disk pools are utilized.  A status of “Warning” 
(yellow) indicates at least one disk pool is at least Disk Pool Warning 
Percentage (e.g. 80%) but less than Disk Pool Error Percentage (e.g. 90%) 
utilized.  A status of “Error” (with a red indicator) indicates that at least one 
disk pool is greater than Disk Pool Error Percentage (e.g. 90%) utilized.  The 
count of the number of Disk Pools greater than or equal to the Disk Pool 
Warning Percentage for the site/server is displayed next to the 
red/green/yellow indicator.

•  Disk Volume Warning Percentage - This parameter controls the status 
indicator next to the Read Only/Offline Disk Pool Volumes link in the TSM Daily 
Status Report.  A status indicator of “Warning” (yellow) indicates that at least 
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one but less than the disk volume warning percentage (e.g., 10%) of the total 
volumes in any disk pool are either not “ONLINE” or not “READWRITE”.  A 
status indicator of “Error” (red) indicates that less than/equal to the disk 
volume warning percentage (e.g. 10 %) of the disk pool volumes in any disk 
pool are not “ONLINE” or not “READWRITE”.  A status indicator of “None” 
(green) means that all disk pool volumes are “ONLINE” and “READWRITE”.  

4. Modify any of the following Reclamation Process parameters that control the 
status indicator next to the Tape Volumes Reclaimable > XX % link on the TSM 
Daily Status report:

•  Reclamation Threshold – This threshold parameter (e.g. 65%) defines the 
threshold in which a certain percentage of data on a tape has expired and, 
thereby, makes it reclaimable.  

•  Reclamation Warning Percentage – This parameter controls the status 
indicator next to the Reclamation Failures link on the TSM Daily Admin Report. 
A status of “None” (green) means that all reclamation processes ran 
successfully.  A status of ”Warning” (yellow) means that at least one but less 
than the Reclamation Warning Percentage (e.g.10%) of all reclamation 
processes failed.  A status of “Error” means that greater than or equal to the 
Reclamation Warning Percentage (e.g.10%) of all reclamation processes that 
ran at the site failed. The count of the number of reclamation processes that 
failed for the site is displayed next to the red/green/yellow indicator.

•  Reclamation Warning Count and Reclamation Error Count - A status of 
“None” (green) indicates that no servers in the site have more than the 
Reclamation Warning Count e.g. 10) reclaimable tapes. A status of “Warning” 
(yellow) indicates at least one server in the site has more than Reclamation 
Warning Count (e.g. 10) reclaimable tapes but less than the Reclamation Error 
Count (e.g. 20) reclaimable tapes.  A status of “Error” (red) indicates at least 
one server in the site has more than Reclamation Error Count  (e.g. 20) 
reclaimable tapes.  

5. Modify any of the following Tape Drives/Tape Paths parameters:

•  Tape Drive Status Warning and Tape Fail Status Warning - These 
parameters control the status indicator next to the Tape Drives/Paths link on 
the main TSM Daily Status report.  A status of “Online” (green) indicates all 
servers in the site have no tape drives in an offline state.  A status of “Warning” 
(yellow) indicates at least one server in the site has at least one tape drive or 
path in an offline state but less than the Tape Drive Status Warming percentage 
(e.g.10%) and less than the Tape Fail Status Warning percentage of that 
server’s tape drives/paths are offline.  A status of “Error” (red) indicates at 
least one server in the site has greater than or equal to either the Tape Drive 
Status Warning percentage or the Tape Fail Status Warning percentage of its 
tape drives in an offline state.

6. Modify any of the following Suspect Tape Volumes parameters:

•  Suspect Tape Warning and Suspect Tape Errors - These parameters 
control the status indicator next to the Suspect Tapes link on the main TSM 
Daily Status report.  A status of green indicates all servers in the site have less 
than the Suspect Tape Warning percentage (e.g. 1%) of their tapes marked as 
suspect.  A status of red indicates at least one server in the site has greater 
than or equal to the Suspect Tape Errors percentage (e.g. 2%) of their tapes 
marked as suspect.  A status of yellow indicates at least one server in the site 

Page 38 Sun StorageTek Business Analytics Administration



has Suspect Tape Warning percentage (e.g. 1%) of their tapes marked as 
suspect, but less than the Suspect Tape Errors percentage (e.g. 2%).

Scheduled Reports
Scheduled Reports is an administrative function that allows the administrator to perform 
system-wide maintenance on user-defined scheduled reports. The Management 
Console’s Storability Report Scheduler runs as a Windows services, and it manages 
sending the URL to generate a report to designated email recipients. It uses an IP 
address (not a Domain Name) to perform this functionality.

1. From the Tools pull-down menu, select Reporting Administration->Scheduled 
Reports. The Scheduled Reports window is displayed with a list of scheduled 
reports in a tabular format. 

The window provides a selection box and identifies the Report Name, Start Time, and 
Recurrence for each scheduled report in the database.

Modify Scheduled Report
2. Click the Report Name link for the desired schedule. The Report Scheduling 

window opens with pre-filled fields from the existing scheduled report.

Figure 34 - Report Scheduling

3. Change any of the following attributes of the scheduled report:

• Report Name

• Start Time (hh:mm)

• Recurs (e.g., daily)

• Report Parameters

• SMTP Server
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• SMTP Port

• E-mail contacts (not in database)

• Report Destinations

• Report Memo

4. Click Save. A confirmation dialog appears.

Figure 35 - Delete Scheduled Report Confirmation

5. Click OK to save the scheduled report information to the database or Cancel to 
cancel the operation.

6. The Report Scheduling Completed window appears.

Delete Scheduled Report
7. Select the reports you want to delete using the check box beneath the Delete 

heading on the Report Scheduling screen.
8. Click the Delete Scheduled Reports button.
9. When the “This will delete the selected report(s). Are you sure?” dialog is displayed, 

click OK to confirm the operation. After you confirm the operation, all the selected 
reports are deleted and the screen is refreshed.

Maintain Aliases
An alias allows you to create a more meaningful name for an asset. The Maintain Aliases 
Wizard is used to add new aliases or modify/delete existing aliases (e.g., Switch WWN 
Alias, Fabric WWN Alias, or Array ID Alias) as well as to generate a report on existing 
aliases. Aliases are displayed instead of the WWN or Array ID in various Management 
Console reports in which these assets appear. 

Create New Alias 
Proceed as follows to add a new alias.

1. Select Reporting Administration-> Maintain Aliases from the Tools pull-down 
menu. The Maintain Aliases Wizard appears.
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Figure 36 - Maintain Aliases Wizard

2. Use the radio box to select Create New Alias and click Next>>. The Select Site 
and Asset Type window appears.

Figure 37 - Select Site and Asset Type

3. Use the selection list box underneath the “Select Site for which you would like to 
ADD Aliases:” heading to choose the desired site.

4. Use the selection list box beneath the Select the asset type for which you would like 
to ADD Aliases:” to select the asset type (Switch WWN, Fabric WWN, or Array ID).

5. Click Next>> and the Maintain Aliases Wizard: ADD Alias window is displayed. A 
sample window to add an Array ID alias appears below.
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Figure 38 - Maintain Aliases Wizard: Add Alias

6. Type the alias in the input field beneath the Alias heading and click Next>>.

7. The Maintain Aliases Wizard: ADD Alias Confirmation window appears. Click 
Finish>> to complete adding the alias, Back to change the alias, or Cancel to 
cancel.

8. Clicking Finish>> displays the Maintain Aliases Wizard: ADD Alias Status similar to 
the one that appears below.

Figure 39 - Maintain Aliases Wizard - Add Alias Status

10.Click Finish>> to return to the Maintain Aliases Wizard window.
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Modify Existing Alias
Proceed as follows to modify an existing alias.

1. Select Reporting Administration -> Maintain Aliases from the Tools pull-down 
menu.

2. Use the radio box to select Modify Existing Alias and click Next>>. The Maintain 
Aliases Wizard: Select Site and Asset Type window is displayed.

3. Use the selection list box underneath the “Select Site for which you would like to 
MODIFY Aliases:” heading to choose the desired site.

4. Use the selection list box beneath the Select the asset type for which you would like 
to MODIFY Aliases:” to select the asset type (Switch WWN, Fabric WWN, or Array 
ID).

5. Click Next>> and the Maintain Aliases Wizard: MODIFY Alias window appears.   

6. Using the input boxes beneath the Alias heading, modify the desired aliases.

7. Click Next>> and the Maintain Aliases Wizard: MODIFY Alias Confirmation window is 
displayed.     

8. Review the modify aliases and click Finish>>, click Back>> to make changes, or 
Cancel to cancel.   

9. Clicking Finish>> displays the Maintain Aliases Wizard: MODIFY Alias Status 
window. It shows the Local Manager ID, Array ID/Switch/WWN/Fabric WWN, Alias, 
and Alias Status (e.g., Entry Added). 

10.Click Finish>> and the Maintain Aliases Wizard window is displayed. 

Delete Alias
Proceed as follows to delete an existing alias.

1. Select Reporting Administration -> Maintain Aliases from the Tools pull-down 
menu.

2. Use the radio box to select Delete Alias and click Next>>. The Maintain Aliases 
Wizard: Select Site and Asset Type window is displayed.

3. Use the selection list box underneath the “Select Site for which you would like to 
DELETE Aliases:” heading to choose the desired site.

4. Use the selection list box beneath the Select the asset type for which you would like 
to DELETE Aliases:” to select the asset type (Switch WWN, Fabric WWN, or Array 
ID).

5. Click Next>> and the Maintain Aliases Wizard: DELETE Alias window appears.  

6.  Select, one, multiple, or all existing aliases and click Next>>. The Maintain Aliases 
Wizard: DELETE Alias Confirmation window is displayed.

7. Review the information and click Finish>>, Back>> to make changes, or Cancel to 
cancel.
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8. Clicking Finish>> displays the Maintain Aliases Wizard: DELETE Alias Status window 
is displayed.   

9. Using the input boxes beneath the Alias heading, modify the desired aliases.

10.Click Next>> and the Maintain Aliases Wizard: MODIFY Alias Confirmation window is 
displayed. It shows the Local Manager ID, Array ID/Switch/WWN/Fabric WWN, Alias, 
and Alias Status (e.g., Entry Deleted).   

11.Review the information and click Finish>> to display the Maintain Aliases Wizard 
window is displayed.  

Alias Report
Proceed as follows to generate and display the Alias Report.

1. Select Reporting Administration -> Maintain Aliases from the Tools pull-down 
menu.

2. Use the radio box to select Alias Report and click Next>>. The Maintain Aliases 
Wizard: Select Site and Asset Type window is displayed.

3. Use the selection list box underneath the “Select Site for which you would like to 
VIEW Aliases:” heading to choose the desired site.

4. Use the selection list box beneath the Select the asset type for which you would like 
to VIEW Aliases:” to select the asset type (all aliases, Switch WWN Alias, Fabric 
WWN Alias, or Array ID Alias).

5. Click Next>> and the Alias Report window is displayed.

Figure 40 - Alias Report

6. After you view the report, click Finish>> to return to the Maintain Aliases Wizard 
window.
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Manual Host to HBA Mapping
Follow the steps listed below to enter information for a server that is not running a Host 
Agent.

1. Select Reporting Administration -> Manual Host to HBA Mapping from the 
Tools pull-down menu. The Host/HBA Configuration (Step 1 of 3) screen 
appears.

2. Select the site and click OK. The Host/HBA Configuration (Step 2 of 3) window 
appears.

Figure 41 - Host/HBA Configuration (Step 2 of 3)

The table lists each Local Manager ID, WWN ID, WWN Alias, and IP Address for 
host HBAs in the database. The figure is for illustrative purposes only with many 
WWN Aliases already defined.

3. Define the WWN aliases and IP addresses for hosts and HBAs in the respective 
input fields.

4. Click Submit>.

5. Verify the information on changes displayed in the Host/HBA Configuration (Step 3 
of 3) window.

6. Click Add> or Back>> to make changes. 

7. Clicking Add> displays a table that shows the hosts/HBA mappings that were 
assigned.

8. Close the window.
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Define Fields for Asset Reports
User-Defined Fields allows the administrator to add their own asset information to 
provide more flexibility in tracking their assets. Some uses include:

• Track lease expiration dates
• Store Asset tag numbers, locations, etc.
• Store maintenance contract information
The administrator uses the Define Fields and the Data Entry menu selections to 
perform this task.

Define Fields
The administrator uses Define Fields to select an asset type (e.g., array) and define a 
new field regarding the selected asset type.
1. Select Database Administration-> User-Defined Fields from the Tools pull-

down menu. 
2. Select Define Fields and the Define Asset Fields wizard is displayed.
3. In the Step 1 of 4: Select an Asset window, use the drop down box with the list of 

asset types to select the desired asset type. These include arrays, hosts, switches, 
tape libraries, and NAS devices.

Figure 42 - Host/HBA Configuration (Step 2 of 3)

4. Click Next>> and the Step 2 of 4: Define Asset Fields window is displayed. As 
specified in the window, you may select and delete an existing field or create a new 
one.
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Figure 43 - Step 3 of 4: Define Asse Fields

5. To add a new asset field, click Create New Field.
6. Type a meaningful name in the Field Name input box.
7. Use the Field Type drop down box to choose text, number, or date as the data 

type for the user-defined field you are creating. 
In the screen below, an asset tag with a field type of number has been configured for 
arrays.

Figure 44 - Define Asset Field Example
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8. Click Next>> and the Step 3 of 4: Confirm Changes window is displayed. Examine 
the field name and field type information.

Figure 45 - Define Fields: Confirm Changes

9. Click Finish and a confirmation pop up box is displayed.

10.Click OK and the Step 4 of 4: Summary window appears, similar to the one shown 
below.

Figure 46 - Define Asset Summary

11.Click Finish to exit the wizard.
12. To delete an existing asset field, proceed as follows:

a. Select Reporting Administration-> Asset Management from the Tools pull-
down menu. 

b. Select Define Fields and the Define Asset Fields wizard is displayed.
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c. In the Step 1 of 4: Select an Asset window, use the drop down box with the list 
of asset types to select the asset type.

d. In the Step 2 of 4: Define Asset Fields window, use the select boxes to choose 
the asset field(s) to be deleted.

Figure 47 - Selecting Asset Field for Deletion

Note: Deleting an Asset Field will remove any data you have input into that field 
from the database. You can modify/delete fields by selecting the fields you wish 
to delete by checking the checkbox and/or updating the text in field(s).

e. In the Step 3 of 4: Confirm Changes window, examine the asset field you have 
chosen for deletion and click Next>> to continue.

f. Click OK in the “Do you want to save the changes” pop up dialog and the Step 4 
of 4: Summary window is displayed. It describes the actions that were taken, 
such as “Deletion: Deleted 1 Asset Fields successfully.” 

g. Click Finish to exit the wizard.

Data Entry
Data Entry enables the administrator to enter data into the user-defined fields you 
created for an asset.

1. Select Reporting Administration-> User Defined Fields from the Tools pull-
down menu. 

2. Select Data Entry and the Asset View window is displayed.
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Figure 48 - Asset View

3. Click on the asset for which you want to enter data. The defined fields for the 
selected asset appear. The screen below shows the array assets for which the user 
has authorization through their view.

Figure 49 - Data Entry: Arrays

4. In the data entry field for the selected asset, type the desired information and click 
Next>> to continue.  
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Figure 50 - Asset View: Confirm Changes

5. Examine your information and click Back<< if you want to change it or Finish to 
complete the data entry.

6. After you click Finish, a confirmation dialog box is displayed. 
7. Click OK to submit your changes to the database.
8. The Detail Summary window appears indicating “The changes have been saved.” 
9. Click Close to finish and the Home Page is displayed.   

Displaying User-Defined Fields
The Asset Management report provides access to the tabular device reports, which 
contain an Asset tab. In the Asset Management report, you can expand the tree in the 
navigation pane to choose the desired device. The Detailed Array Configuration 
report is shown below for a selected array.

Figure 51 - Detailed Array Configuration

By clicking the Asset tab, you display an Asset report similar to the one that follows.
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Figure 52 - Sample Array Asset Report

Maintain Allocation Forecast Report
The Maintain Allocation Forecast report allows the administrator to set allocation 
specifications used in the Trending and Forecasting report under Storage.
1. Select Reporting Administration->Maintain Allocation Forecasting report.
2. To auto-populate the report for a selected calendar year, select Auto-Populate Server 

Forecast and the Auto-Populate Server Forecast window appears.
3. Use the pull-down menu to select the desired calendar year and click Next to edit 

server forecasts or Finish. 

Figure 53 - Auto-Populate Server Forecasts

4. To edit server forecasts, click the Edit Server Forecasts button on the Auto-Populate 
Server Forecasts window. Note: You can proceed directly to this menu by selecting 
Reporting Administration->Maintain Server Forecasts->Edit Server Forecasts.
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5. Use the navigation pane on the Edit Server Forecasts window to select the desired 
site.

6. Expand the hosts and then select the desired host server whose forecast will be 
edited. You can change the following parameters:
• Growth rate
• Growth (GB)

Site/Local Manager Administration
A site consists of one or more Local Managers. Within menu security, site represents one 
type of asset that may be assigned to an Asset View. In addition, site is one licensed 
entity in the Sun StorageTek Business Analytics software license.

The Default Site and Default Local Manager are added to the Sun StorageTek Business 
Analytics application at installation time. Use Site/Local Manager Administration to 
modify the seed data or to add, modify, or delete other sites and Local Managers for 
your deployment.

Add a new Local Manager
1. From the Tools pull-down menu, select Site/Local Manager Administration. The 

Site and Local Manager Listing window is displayed.
2. Click Add New Local Manager and the Create Local Manager window is displayed.
3. Enter a meaningful name and short name for the Local Manager.
4. Enter the IP address of the server on which the Local Manager will be installed.
5. Use the radio list box to assign a site to the Local Manager.
6. Click Save. The “Are you sure you want to create this Local Manager” dialog appears.
7. Click OK to confirm adding the Local Manager and to return to the Site and Local 

Manager Listing window

Add New Site
Follow the procedure outlined below to add a new site.

1. From the Tools pull-down menu, select Site/Local Manager Administration. The 
Site and Local Manager Listing window is displayed, similar to the one that is 
shown below.

Figure 54 - Site and Local Manger Listing

2. Select Add New Site and the Create Site window appears. Note: Do not use 
special characters (e.g., &) in a site name. 

Sun StorageTek Business Analytics Administration Page 53



3. Enter a meaningful name in the Site Name input field.

4. Enter a description for the location in the Site Location input field.

5. Type the number of Local Managers you plan to deploy at the Site in the “Local 
Managers to add” field. Each Local Manager runs a unique instance of the Storability 
Routing Agent. This selection will generate a unique Routing ID to identify the Local 
Managers. You will need this Routing ID when you install the Local Managers. Refer 
to the Planning and Concepts chapter to obtain additional information on the 
concepts of Site and Local Manager.

6. Click Save.

7. When the pop up confirmation box appears, confirm adding the Site. The Add Local 
Managers to New Site [site name] window appears, similar to the one shown 
below.

Figure 55 - Sample Add Local Managers to New Site

9. Enter the Local Manager Name(s) and Short Name(s), which are used to refer to 
the Local Manager servers.

10. Enter the IP Address of the Local Manager.

11.Continue Steps 9 and 10 to add the number of Local Managers you previously 
specified. The window will provide the input boxes for these Local Managers.

12.Click Save. The Site/Local Manager Administration window contains a list of the 
Local Managers that you have defined beneath the Local Manager Name heading.

Note: You may export or print the Site and Local Manager Listing window to 
facilitate configuring the corresponding Local Manager/Routing ID when installing the 
Local Manager(s).

Modify/Delete Sites
Follow the procedure outlined below to modify or delete an existing Site.

1. From the Tools pull-down menu, select Site/Local Manager Administration. Your 
screen displays the Site and Local Manager Listing window.

2. Click the Site Name to be modified or deleted. The Modify/Delete Site window 
appears.
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3. Click Delete to remove the Site or change the desired information (e.g., Site 
Location) and then click Save.

4. The “Are you sure you want to update this Site?” dialog appears.

5. Click OK to confirm updating this site or Cancel to cancel the operation.

6. After you click OK, the Site and Local Manager Listing window is displayed.  

Modify/Delete Local Managers
Follow the procedure outlined below to modify or delete an existing Local Manager.

1. From the Tools pull-down menu, select Site/Local Manager Administration. The 
Site and Local Manager Listing window is displayed.

2. Click the Local Manager Name to be modified or deleted. The Modify/Delete 
Local Manager window appears.

3. Click Delete to remove the Local Manager or change the desired information (e.g., 
IP Address) and then click Save.

4. The “Are you sure you want to remove this Local Manager?” dialog appears.

5. Click OK to confirm updating this site or Cancel to cancel the operation.

6. After you click OK, the Site and Local Manager Listing window is displayed.  

Data Polling Schedule
Data Polling Schedule allows the administrator to:

• View existing polling (data collection) schedules.
• Execute on-demand data polling using an existing polling schedule
• Create a new polling schedule
• Delete an existing polling schedule
• Enable or disable a polling schedule

Data collection can be scheduled to occur once (on-demand) or on a repetitive basis 
(e.g. daily) for all sites or specified sites). The default schedules are configured for all 
sites. However, you can configure a polling schedule for a particular site or sites by:
• Modifying a default polling schedule from “All Sites” to the desired site(s).
• Adding a new polling schedule to the database.

The Data Polling Schedule window shows the schedule for each collection type and 
collection metric. During the Sun StorageTek Business Analytics Central Manager 
Database setup, a set of default polling schedules are created in the portal database. By 
clicking on a unique Job ID, the administrator can review/modify the schedule as well as 
enable or disable it. Business Analytics data polling schedules use Central Manager local 
time.
Note: An error message will display if you select Polling and the COM Agent 
(Management Console), Data Polling Agent (Central Manager), and Scheduler Agent 
(Central Manager) are not running and registered.
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Polling Schedules Window
1. Log in to the Management Console.
2. Select Data Polling Schedule under the Tools pull-down menu. The Polling 

Schedules window is displayed similar to the one shown below.

Figure 56 - Polling Schedules

The Polling Schedules window provides the following information on each polling 
schedule in the database:

• Job ID – Is a unique, system-generated identifier that persists until the schedule 
is removed from the database.

• Enabled – Shows whether (Yes/No) the polling schedule is enabled. The 
predefined polling schedules are all disabled when you first access the Polling 
menu.

• Site – Identifies the site(s) or specifies all sites. Effective with Sun StorageTek 
Business Analytics Version 5.1, the Aggregator will collect an object from one 
Routing ID (rid) at a time when the request is specified for “All Sites”. Each site is 
a logical collection of Routing IDs in the database.

• Collection Type – Specifies the type of agent published tables to be collected; 
may be General, Array, Backup, Database, Fabric, Host, NAS, SRM, or Library.

• Collection Metric – Depends on the collection type:
o General – Agent Version, Alerts

o Array – Allocation, Configuration, Performance
o Backup - Common – Meta Data, Configuration

o Backup – Common – Jobs, Events
o Backup – TSM – Devices, Media, Optional

o Backup – Veritas/Legato – Media
o Backup – Veritas – Real Time Events, Schedule
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o Database – Configuration, Performance
o Fabric – Configuration, Performance

o Host – Configuration, Filesystem, Logical VM (Volume Manager)
o NAS – Configuration, Filesystem, Logical VM

o SRM – Configuration, Statistics
o Library – Configuration, Jobs, Media, Statistics

o Fabric – Configuration, Performance 
o Performance – Statistics (used with Host Statistics Agent) 

o Data Aggregator – Statistics (used to collect Data Aggregator Agent 
data collection statistics)

• Schedule – Description of the frequency of data polling scheduled 

3. You may click the Collect Now button beside a particular polling schedule to request 
an immediate (on-demand) data collection for the specified collection type and 
collection metric. The collection type/metric does not have to be enabled to allow you 
to utilize the “Collect Now” function. 
Notes: Data collection may take some time to complete or impact to some extent 
system resources depending on the type/metric you have chosen. The dashboard 
panes are cached and, therefore, you must manually refresh a database pane to see 
data obtained through the “Collect Now”. Select Database Administration -> 
Refresh Homepage Cache to manually refresh the dashboard panes.

4. You may click any of the following headers to change the current sort order in the 
window: 
• Job ID
• Site
• Collection Type
• Collection Metric

5. You can select any of the following buttons at the bottom of the window:
• Enable – Enable selected (check mark) polling schedules
• Disable – Disable selected (check mark) polling schedules.
• Delete – Delete selected (check mark) polling schedules.
• Add New – Add a new polling schedule.

Add New Data Polling Schedule
1. Click the Add New Button and the Add New Polling Job window appears.
2. Specify the collection options:

• Click Connection Type and select the type (General, Array, Backup, etc.) of 
agent to collect data from.

• Click Connection Metric and select the agent data to be collected. 
• Select the desired site(s) or all sites in the Site list box or all Sites. Keep in mind 

the Data Aggregator collects from one rid (local manager) at a time when “All 
Sites” is chosen.

3. Click the Change Schedule button and the Scheduler window appears.
4. Use the radio boxes to specify whether this schedule will be executed once or on a 

re-occurring basis.
5. If you select reoccurring, the window refreshes with your choices for frequency. Use 

the radio boxes to select hourly, daily, weekly, or monthly.
6. Use the Hour/Minute pull-down list boxes to set the start time.
7. Use the Calendar icon to specify the start date.

Sun StorageTek Business Analytics Administration Page 57



8. Click Save and return to the Add New Polling Job window.
9. Optionally change the Collection Timeout for the selected Collection Type and 

Metric.  The default setting is 1200 seconds. The timeout will apply to all tables being 
collected with the given Collection Type and Metric.

Figure 57 - Add a New Polling Job

10.Click the Enable this job check box to enable the schedule and then click Save. The 
Polling window is refreshed and displays your new polling schedule. 

Modify Data Polling Schedule
1. Click the Job ID link and the Add a New Polling Job window opens.
2. In the Site Name box, choose the site(s) or all sites. Keep in mind the Data 

Aggregator collects from one rid (local manager) at a time when “All Sites” is chosen.
3. The “Enable this job” check box allows you to enable (check mark) or disable the job.
4. The “Collection Timeout” field enables you to adjust the data collection timeout for 

the given Collection Type and Metric. The default value is 1200 seconds.
5. Click the Change Schedule button and the Scheduler window appears.
6. Use the radio boxes to specify whether this schedule will be executed once or on a 

re-occurring basis.
7. If you select reoccurring, the window refreshes with your choices for frequency. Use 

the radio boxes to select hourly, daily, weekly, or monthly.
8. Use the Hour/Minute pull-down list boxes to set the start time.
9. Use the Calendar icon to specify the start date.
10.Optionally change the default Collection Timeout (1200 seconds).
11.Click Save and return to the Add New Polling Job window.
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Delete Polling Schedule
12.Click the check box beside each system-assigned Job ID to select the polling 

schedule(s) to be deleted.
13.Click the Delete button and confirm removing the selected polling schedules, when 

prompted. The polling schedules are removed from the database.

Enable/Disable Polling Schedule
The Disable button allows polling schedules to remain in the database but not be used 
during agent data collection. Once disabled, you use the Enable button to enable the 
polling schedule(s) and, thereby, have them used during scheduled agent data 
collection. You may use the Collect Now button to request an immediate (on-demand) 
data collection for the specified collection type and collection metric.
1. Select the polling schedule(s) to be enabled or disabled.
2. Click the Enable button to enable the polling schedule that you previously disabled, 

or click the Disable button to disable it.

SRM Agent Configuration
SRM Agent Configuration provides a graphical user interface to set up the configuration 
parameters for the SRM Agent configuration file for Windows or UNIX platforms. The 
SRM Agent configuration includes the following parameters:

• Scan Schedules – Schedule when the SRM agent runs.
• Filters – Define the types of data the SRM Agent scans and the data reported. Sun 

StorageTek Business Analytics includes filters for email archive files, unauthorized 
files, and user-specified files. 

• Remote Shares – Provide the security information that allows the SRM Agent to 
scan remote shares on Windows, UNIX, or both.

• Advanced Settings – Additional configuration settings such as the number of 
threads and caching location on disk.

The administrator can configure the following new SRM Agent Configuration filters:

• Email archive – Provides a list of email archives. The default SRM Agent 
configuration contains filters for .ost, .pst, .nsf, and .nst files for the Microsoft 
Exchange and Lotus Notes mail applications, respectively.

• Unauthorized files – Report on file types that are banned (e.g., .mp3) on your 
corporate network for reasons like content or size.

• User-defined file types – Report on any file types you specify. To add a user 
defined file type filter, it is mandatory to manually add the filter definition in the XML 
file (filter_def_srmComplete.xml) that contains a list of all filter definitions.

The Management Console’s Filesystem Details report provides access to the file-specific 
reports, where applicable.

Loading Configuration File
1. Select SRM Agent Configuration under the Tools pull-down menu. The SRM 

Agent: Load Configuration File window is displayed. 
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Figure 58 - SRM Agent Configuration: Load Configuration File

2. Use the radio boxes to choose the server platform, Windows or UNIX, where the SRM 
Agent Configuration File will be used. The config_srm.xml file requires remote share 
file scanning parameters to be entered slightly differently on UNIX and Windows 
platforms.  

The following options are not provided on the Advanced tab for UNIX file editing:
• Impersonating user details - user name, password, domain name
• Enable remote filesystem scan checkbox
• Remote shares to scan list
• Per Disk option from the 'scan type' combo box

3. Choose the configuration file to be loaded:
Default Configuration File
a. Click the Load Default Configuration button.
Local SRM Configuration File
b. Click Browse.
c. Navigate and select (highlight) a local SRM Configuration File. It is located by 

default in the folder: <drive>:\Program Files\Storability\GSM\Agents\SRM Agent 
on a Windows server. 

d. Click Open to upload the selected file to the Management Console server.
4. After the selected XML file is loaded, the SRM Agent Configuration window appears 

with the Scan Schedules tab enabled.

Scan Schedules Tab
The Scan Schedules tab provides the following elements:

• The Current Configuration list, which has the following fields:
o Check box to select any (or all) displayed schedules

o Schedule name field
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o Text description of the schedule

• Delete button that allows you to delete the selected schedule(s)
• Add New Schedule text box allowing you to specify the name for a new 

schedule
• Add button to display the Scheduler window used to define a scan schedule
• Scan on Start checkbox allowing you to enable/disable the scan on start option 

for the schedule.

• Disable All Schedule Scans checkbox allowing you to enable/disable all schedule 
scans

Add Scan Schedule
To add a new scan schedule, proceed as follows:
1. Click Add and the Scheduler window opens.
2. Choose the desired frequency: hourly, daily, weekly, or monthly. 

Hourly – Will launch file system scanning every xx hours starting at midnight.
Daily – Will refresh the window by adding the Starting At: pull-down list boxes. 
These allow you to set when (hh:mm) the scanning will be initiated. Beneath the list 
boxes, the message, “Job will be fired every 1 day(s) at hh:mm” is refreshed to 
match your settings.
Weekly – Will refresh the window by adding the Weekly Options. These provide 
radio boxes you use to choose the day(s) of the week (Sunday – Saturday) for file 
system scanning. Beneath the radio boxes, the message “Job will be fired every 
<day>, <day>,<day>, etc. at hh:mm” is refreshed to match your settings. 
Monthly - Will refresh the window by adding the Monthly Options. These add the 
“Perform this job every xx month(s) on: <day of week> or <Day> settings. Beneath 
the radio boxes, the message “Job will be fired every xx month(s) on Day xx at 
hh:mm” is refreshed to match your settings.

3. Click Save. 

There should be at least one schedule for the SRM agent to function properly. Do not 
include spaces in a schedule name.

Filters Tab
The Filters tab displays the following elements:

• Pre-Scan Filters – List of predefined filters controlling the agent’s behavior prior 
to file system scanning.

• Post-Scan Filters – List of pre-defined filters controlling the agent’s behavior 
after file system scanning is completed. These options allow you to perform post-
scan processing on the data before it is inserted in the database.

• Applied Filters – Combined list of filters selected for configuration by 
highlighting the pre/post scan filter and then clicking the >> button. If the 
default configuration file is loaded then all the post-scan filters are displayed in 
this list.

• Filter Description – Text box refreshes with descriptive text for a particular 
filter selected (highlighted) in the Applied Filters text box.

• Input Parameters – Defined parameters for a selected filter (Applied Filter text 
box). For example, %TEMP% may appear if the temporary_files filter is chosen.

• Set– Set the filter values for the selected filter. Filters values once set cannot be 
reset.
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• Reset – Clear the current filters and revert to the original filter values provided 
the filter values have not been set. 

Advanced Setting Tab
The Advanced Settings tab displays a window that allows you to define additional 
configuration settings for the SRM Agent configuration. These options are described as 
follows:

• Disk Cache Location – Enter a path for the agent’s disk caching (e.g., < drive 
>:\Program Files\Storability\GSM\Agents\Storability SRM Agent).

• Enable Disk Caching – Put a check in this check box to enable disk caching for 
the agent during scans. Otherwise, disk caching during scans is disabled.

• Handle Compressed Data – Put a check in this check box to - report 
compressed file size. Otherwise, the actual size of the file system will be 
reported.

• Enable remote file system scan – Put a check in this check box to enable 
remote file systems/shares to be scanned. Otherwise, remote file system 
scanning is disabled.

• Scan Type – Determines how multiple scans are processed. Valid values are 
sequential, per disk, or per file system for local disk and sequential or per file 
system for remote disk. 

• Maximum Number of Threads – Specify the maximum number of threads used 
by the SRM Agent during scans.

• Remote Command Configuration – Specify the user name and password that 
is used to initiate the SRM Agent remotely on a system.

• Impersonating User – Specify the user name, password, domain information 
that allows the agent to scan remote Windows shares. This textbox is enabled 
only when enable remote file system scan checkbox is enabled. Passwords are 
saved in plain ASCII text.

• Remote Shares to Scan – Use the Add and Delete buttons to define the 
remote shares to be scanned. The Add and Delete buttons for Remote Shares 
Scan will be enabled only when the enable remote file system scan checkbox is 
enabled.

As previously described, the Advanced tab provides slightly different options when you 
configure a config_srm.xml file for a UNIX platform, as shown below.
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Figure 59 - SRM Agent Configuration - Advanced Tab for UNIX

Saving Configuration
Each tab provides a Save button that allows you save a new SRM Agent Configuration. 
1. When you click Save, a confirmation message box appears. Clicking the OK button 

opens the File Download dialog box. It shows the default file name, file type (XML), 
and the IP address of the Management Console server. The Open and Save buttons 
allow you to open or save the file, respectively. Clicking Cancel returns you to the 
SRM Agent Configuration window and clicking More Info displays a Microsoft 
Internet Explorer Help facility.

2. Click Save and the Save As dialog box appears.
3. Use Save In to specify the desired destination location for the file.
4. Click Save to save the SRM Configuration file to that directory/folder. The default file 

name will need to be renamed to config_srm.xml before the file is used.

SRM User Interface Configuration File
The predefined filters file for the SRM Agent User Interface (UI) is named 
filter_def_srmComplete.xml, and the Document Type Definitions (DTD) file 
(filter_def_srm.dtd). Both files are located in the folder:

<drive>:\Program Files\Storability\GSM\Storability Management 
Console\Source\portalsource\storabilitypriv\srmui

on the Management Console.

The SRM Agent User Interface (UI) Filters module reads from the predefined or “canned” 
filters, and populates the filters tab. The Filters tab in the user interface contains pre-
scan filters, post-scan filters and table configuration elements, as described in the 
previous section.

The following sections provide examples that show how pre-scan filters, post-scan 
filters, and table configuration elements may be added to filter_def_srmComplete.xml 
file.
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File Structure 
In the xml file, filter_root is the root element. It will have all the canned filters listed 
under it. The name of the child of the root element is ‘filter’. There can be one (1) or 
more filter elements under filter_root.
The ‘filter’ has certain attributes which are necessary to populate the config_srm.xml 
file. These are contained in the Filters section and include:

• name
• action
• attribute
• operator
• expandEnv
• caseSensitive

The attribute "name" specifies the name of the attribute that the table is being applied 
to (e.g., rowsPerFileSystem of gsa_srm_largest_old_files). The caption attribute is the 
HTML description that will be seen in the UI (e.g., caption='Enter the size:'). The type 
attribute will be the HTML element that will be present in the UI, eg: if type='text', a 
text box will be shown.

The ‘filter’ also has tags under it like:
• applies_to_table - This element can occur only once. Its purpose is to apply 
• the filter to a specific table.
• filter_description – Will provide a detailed description of the filter. The content of 

this element will be read and pasted in the UI. You should enter the description in 
a single line.

• filter_input_param – There can be one or more of these tags under ‘filter’. This 
element will contain the input parameter for a particular canned filter. 

Example of Pre-scan Filter
Assume you want to prevent the agent from scanning a drive on a host. You can 
proceed as follows:

1. Create a <filter> </filter> xml tag. In the <filter> tag, add the following attributes: 
name, action, action, attribute, operator, expandEnv and caseSensitive. These are 
similar to the attributes present in the config_srm.xml file for filters. In our example, 
these are defined as:

<filter name='skip_c_drive' action='exclude' attribute='path' 
operator='eq' expandEnv='true' caseSensitive='false'>
</filter>

2. Populate the <applies_to_table> tag. Keep in mind that the applies_to_table tag 
can occur only once. Its purpose is to apply the filter to a specific table. The attribute 
type in this tag specifies whether the filter is pre-scan or post-scan. If the type is 
pre-scan, the value for this tag must be 'filters' (without the single quotation marks). 
In out example, the filter may be defined as:

<filter name='skip_c_drive' action='exclude' attribute='path' 
operator='eq' expandEnv='true' caseSensitive='false'>

<applies_to_table type='pre-scan'>
filters
</applies_to_table>
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</filter>
3. The <filter_description> tag is next specified. This tag is basically a short 

description of the filter that you are configuring. Keep in mind that the description 
must be entered in one line and can occur only once. In our example, the following 
<filter_description> tag is defined:

<filter name='skip_c_drive' action='exclude' attribute='path' 
operator='eq' expandEnv='true' caseSensitive='false'>
<applies_to_table type='pre-scan'>
filters
</applies_to_table>
<filter_description>
This filter will skip scanning a drive in the SRM Agent. Because of 
this filter, tables will not report any data for this filesystem.

</filter_description>
</filter>

4. The <filter_input_param> tag follows. There can be one or more of these tags. This 
tag is useful for configuring the input parameters for a particular canned filter. The 
attribute "name" will be the name of the attribute that the table is being applied to 
(e.g., rowsPerFileSystem of gsa_srm_largest_old_files). If a filter is being configured, 
the name attribute should be equal to "ignore". 

The "caption" attribute is the short HTML description that will be seen in the UI (e.g., 
caption='Enter the size:'). The "type" attribute will be the HTML element that will be 
present in the UI. For example, if you specify that type='text', a text box will be 
shown.

The value of the <filter_input_param> tag will be the default value of the filter that 
will be shown in the UI. In our example, it may be defined as follows:

In our case, the filter will now look like:

<filter name='skip_drive' action='exclude' attribute='path' 
operator='eq' expandEnv='true' caseSensitive='false'>
<applies_to_table type='pre-scan'> filters
</applies_to_table>
<filter_description>
This filter will skip scanning a drive in the SRM Agent. Because of 
this filter, tables will not report any data for this filesystem.
</filter_description>
<filter_input_param caption='Enter the name of the drive' 
name='ignore' type='text'> 
C:
</filter_input_param>
</filter>

Example of Post-scan Filter
Assume you want to report the Graphic Files that exist on a host server. The 
gsa_srm_usage_details table is used to report these files. 
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1. Create a <filter> </filter> xml tag. In the <filter> tag, add the following attributes: 
name, action, attribute, operator, expandEnv and caseSensitive. These are similar to 
the attributes present in the config_srm.xml file for filters. In this example, these 
may be defined as follows:

<filter name='Graphic_Files' action='include' attribute='path' `
operator='wildcardeq' expandEnv='true' caseSensitive='false'>

</filter>
2. Populate the <applies_to_table> tag. The <applies_to_table> tag can occur only 

once. Its purpose is to apply the filter to a specific table. The attribute type in this 
tag specifies whether the filter is pre-scan or post-scan. If the type is pre-scan, then 
the value for this tag must be ‘filters’. In this example, the filter may be defined as 
follows:

<filter name='Graphic_Files' action='include' attribute='path' 
operator='wildcardeq' expandEnv='true' caseSensitive='false'>
<applies_to_table type='post-scan'>

gsa_srm_usage_details
</applies_to_table>
</filter>

3. Define the <filter_description> tag. This tag is basically a short description of the 
filter that you are configuring. Keep in mind that the description must be entered in 
one line only and that this tag can occur only once. In this example, the filter may be 
defined as follows:

<filter name='Graphic_Files' action='include' attribute='path' 
operator='wildcardeq' expandEnv='true' caseSensitive='false'>

<applies_to_table type='post-scan'>
gsa_srm_usage_details

</applies_to_table>
<filter_description>

This filter will report all the graphic files on the host. The 
various graphic files can be: JPG, GIF, PSD, AI etc.

</filter_description>
</filter>

4.  Define the <filter_input_param> tag. There can be one or more of these tags. This 
tag is useful for configuring the input parameters for a particular canned filter. The 
attribute "name" will be the name of the attribute that the table is being applied 
to(e.g., rowsPerFileSystem of gsa_srm_largest_old_files). If a filter is being 
configured, then the "name" attribute should be equal to "ignore".  

The "caption" attribute is the short HTML description that will be seen in the UI 
(caption='Enter the size:'). The "type" attribute will be the HTML element that will be 
present in the UI. For example, if type='text', a text box will be shown.

The value of the <filter_input_param> tag will be the default value of the filter 
that will be shown in the UI. In this example, it may be defined as follows:

<filter name='Graphic_Files' action='include' attribute='path' 
operator='wildcardeq' expandEnv='true' caseSensitive='false'>

<applies_to_table type='post-scan'>
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gsa_srm_usage_details
</applies_to_table>
<filter_description>

This filter will report all the graphic files on the 
host. The various graphic files can be: JPG, GIF, PSD, AI etc. 
Please separate the types by a comma without spaces. For eg: 
*.jpg,*.gif,*.psd,*.ai

</filter_description>
<filter_input_param caption='Enter the extensions' 

name='ignore' type='text'> 
*.jpg,*.gif,*.psd,*.ai

</filter_input_param>
</filter>

Example of Configuring Table Elements
Assume you want to configure the gsa_srm_largest_files table. You can proceed as 
follows:
1. Create a <filter> </filter> xml tag. In the <filter> tag, add the following attributes: 

name (name of the filter), action, attribute, operator, expandEnv and caseSensitive: 
These are similar to the attributes present in the config_srm.xml file 
for filters. In this example, you might define the following tag:

<filter name='config_gsa_srm_largest_files' action='exclude' 
attribute='path' operator='eq' expandEnv='true' 
caseSensitive='false'>
</filter>

2. Populate the <applies_to_table> tag. The <applies_to_table> tag can occur only 
once. Its purpose is to apply the filter to a specific table. The attribute type in this 
tag specifies whether the filter is pre-scan or post-scan. If the type is pre-scan, the 
value for this tag must be filters. In this example, the tag may be defined as:

<filter name='config_gsa_srm_largest_files' action='exclude' 
attribute='path' operator='eq' expandEnv='true' 
caseSensitive='false'>

<applies_to_table type='post-scan'>
gsa_srm_largest_files

</applies_to_table>
</filter>

3.  Define the <filter_description> tag. This tag is basically a short description of the 
filter that you are trying to configure. Keep in mind that the description must be 
entered in one line only and this tag can occur only once. In this example, the filter 
may be defined as follows:

<filter name='config_gsa_srm_largest_files' action='exclude' 
attribute='path' operator='eq' expandEnv='true' caseSensitive='false'>

<applies_to_table type='post-scan'>
gsa_srm_largest_files

</applies_to_table>
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<filter_description>
This filter sets attributes for the Largest Files table. 

The first text box tells the agent to report only certain amount of 
files per FileSystem that it has scanned. The second text box tells the 
agent to consider only files which have size greater than this value. 
This value has to be in bytes.

</filter_description>
</filter>

4. Define The <filter_input_param> tag. There can be one or more of these tags. This 
tag is useful for configuring the input parameters for a particular canned filter. The 
attribute "name" will be the name of the attribute that the table is being applied to 
(e.g., rowsPerFileSystem of gsa_srm_largest_files). 
If a filter is being configured, the "name" attribute should be equal to "ignore". The 
"caption" attribute is the short HTML description that will be seen in the UI (e.g., 
caption='Enter the size:'). The "type" attribute will be the HTML element that will be 
present in the UI. For example, if type='text', a text box will be shown.

The value of the <filter_input_param> tag will be the default value of the filter 
that will be shown in the UI. In this example, it may be defined as:

<filter name='config_gsa_srm_largest_files' action='exclude' 
attribute='path' operator='eq' expandEnv='true' 
caseSensitive='false'>
<applies_to_table type='post-scan'>
gsa_srm_largest_files

</applies_to_table>
<filter_description>

This filter sets attributes for the Largest Files table. The first 
text box tells the agent to report only certain amount of files per 
FileSystem that it has scanned. The second text box tells the agent 
to consider only files which have size greater than this value. 
This value has to be in bytes.

</filter_description>
<filter_input_param caption='Enter rows to be reported per 

FileSystem' name='rowsPerFileSystem' type='text'> 
25

</filter_input_param>
<filter_input_param caption='Enter the File Size Threshold 

(in bytes)' name='fileSizeThreshold' type='text'> 
5242880

</filter_input_param>
</filter>

Sample Customized SRM User Interface Configuration File
The following filter_def_srmComplete.xml file listing consolidates the previous examples 
of configuring pre-scan filters, post-scan filters, and table elements.

<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE filter_root SYSTEM "filter_def_srm.dtd">
<filter_root>

<filter name='skip_drive' action='exclude' attribute='path' 
operator='eq' expandEnv='true' caseSensitive='false'>
Page 68 Sun StorageTek Business Analytics Administration



<applies_to_table type='pre-scan'>
filters

</applies_to_table>
<filter_description>

This filter will skip scanning a drive in the SRM Agent. 
Because of this filter, tables will not report any data for this 
filesystem.

</filter_description>
<filter_input_param caption='Enter the name of the drive' 

name='ignore' type='text'> 
C:

</filter_input_param>
</filter>
<filter name='Graphic_Files' action='include' attribute='path' 

operator='wildcardeq' expandEnv='true' caseSensitive='false'>
<applies_to_table type='post-scan'>

gsa_srm_usage_details
</applies_to_table>
<filter_description>

This filter will report all the graphic files on the 
host. The various graphic files can be: JPG, GIF, PSD, AI etc. Please 
separate the types by a comma without spaces. For eg: 
*.jpg,*.gif,*.psd,*.ai

</filter_description>
<filter_input_param caption='Enter the extensions' 

name='ignore' type='text'> 
*.jpg,*.gif,*.psd,*.ai

</filter_input_param>
</filter>
<filter name='config_gsa_srm_largest_files' action='exclude' 

attribute='path' operator='eq' expandEnv='true' caseSensitive='false'>
<applies_to_table type='post-scan'>

gsa_srm_largest_files
</applies_to_table>
<filter_description>

This filter sets attributes for the Largest Files table. 
The first text box tells the agent to report only certain amount of files 
per FileSystem that it has scanned. The second text box tells the agent to 
consider only files which have size greater than this value. This value 
has to be in bytes.

</filter_description>
<filter_input_param caption='Enter rows to be reported per 

FileSystem' name='rowsPerFileSystem' type='text'> 
25

Sun StorageTek Business Analytics Administration Page 69



</filter_input_param>
<filter_input_param caption='Enter the File Size Threshold (in 

bytes)' name='fileSizeThreshold' type='text'> 
5242880

</filter_input_param>
</filter>

</filter_root>

Application Status
The Administrator can access the following reports:
• Agent Status– View the status of agents running in the environment 
•  Agent Alerts – View the errors/alerts generated by the agents in the environment. 
• License Report – Verify the agents that your company is licensed to deploy as well 

as how many of these agents are currently in use.

Agent Status
The Agent Status report provides a listing of all agents in the environment whose tables 
have been collected by the Central Manager. The Central Manager collects a table, 
named the gsa_agent_version-2_0 (or gsa_agent_version) object, on a regular basis. 
The agent status is up (green) when data is successfully collected from the agent.

If the agent is not running or responding, the table is not collected and the agent status 
will be reported as down (red). In addition, the report shows the last time data was 
collected from the agent. 

1. Select Application Status under Tools.

2. Select Agent Status and the Agent Status report appears.

Note: It is a good practice to check this report daily so that you are aware of agent 
outages in a timely manner. The Sun StorageTek Business Analytics application 
continues to show devices on the Home Page for a few days after it stops collecting 
data. Thereafter, it will assume that the device no longer exists and stop displaying it.
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Figure 60 - Agent Status Report

The summary table at the top of the report shows the number of agents whose 
status is online or offline and the total number of agents in the environment. 
Beneath the summary table, the following information is displayed for each 
agent:

• Site Name

• Node name or IP address or server name on which the agent is running 
(i.e., from which data is collected)

• Agent Name

• Agent platform and version

• Status indicator (green specifies online; red specified offline status)

• Date/time last updated

If displayed, click the Node Name link and the Detailed Host Configuration 
and Utilization report is displayed is the server’s Host Agent is running.

To refresh the report:

3. Select whether or not to ignore entries in the table that have not been updated 
within the specified number of days. The default value is thirty (30) days.

4. Select a particular Site (or all Sites).

5. Click Refresh Report.
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Note: This report allows you to verify the agent is running. It does not indicate whether 
it is properly configured to collect all data.

Agent Alerts
Each Sun StorageTek Business Analytics agent publishes an Alerts object, which is used 
to generate the Agent Alerts report. Follow the procedure, described below, to display 
the logged alert messages generated by your agents. 

1. Select Application Status under Tools.

2. Select Agent Alerts and the Agent Alerts form appears.

3. Use the drop down box to select whether or not to ignore entries in the table that 
has not been updated within the specified number of days. The default value is one 
(1) day.

4. By enabling the checkboxes next to the Filter By heading, choose the criteria used 
to control the types of errors and alerts extracted from the table. The criteria consist 
of Site, Agent, IP Address, severity, error ID, and description.

Figure 61 - Agent Alerts Filter by Criteria

5. Use the Calendar to specify the start date.

6. Click Refresh Report and the following information appears in the report:

• Site Name

• IP address or server name on which the agent is running (i.e., from which data is 
collected)

• Agent Name

• Severity of alert

• Number of times alert generated

• Date/time alert last generated

• Error ID

• Description of alert event
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If displayed, click the Node Name link and the Detailed Host Configuration and 
Utilization report is displayed. 

License Report
The License Report allows the administrator to see how many smart agents they are 
licensed to deploy as well as how many agents are currently in use. The License Agent 
supports this report.

1. Log in to the Management Console.
2. Select Application Status.
3. Select License Report and the License Report appears.

The report provides the following information:

• License Report Header – Appearing at the top, left section of the report, it identifies 
the report name and the current date.

• Expiration – Consists of centered text that indicates the expiration of the license. 
The expiration date is displayed in mmmmmm dd, yyyy format.

If the Expiration date is less than 15 days away, the text consists of red, centered, 
bold text indicating the expiration date. For example:

Your license will expire on <date>.  

If the Expiration date has already been reached, the text consists of red, centered, 
bold text indicating the expiration date. For example:

Your license key expired on <date>

The License Alerts section contains a table with one line for each license violation 
detected. A sample table follows.

Item Violation
Host 
Agents

Number of Licensed Host Agents exceeded. 
License overrun of <number>.

SRM 
Agents

Number of Licensed SRM Agents exceeded. 
License overrun of <number>.

Table 3 – License Violations

The <number> variable reflects the difference between the number of licensed agents 
versus the number of deployed agents detected by the Central Manager. For example, if 
eight host agents are licensed but ten deployed agents are detected, the <number> will 
be 2.
The License Details section contains a table detailing how many items have been 
licensed, and how many items the Central Manager has detected as being deployed. The 
licensed items appear as follows:
• Sites
• Routing Agents
• Arrays
• Fabrics
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• Filers
• Hosts
• SRM
• Database applications
• Backup applications
• Tape Libraries
• Provisioning module

A sample table in the License Details section follows.

Item Licensed Currently Using
Sites 4 4
StorageTek Tape Libraries 
(ACSLS)

6 4

EMC Clariion arrays 5 5
Database applications 3 2
EMC Symmetrix arrays 12 11
SAN Fabrics (all vendors) 6 5

Item Licensed Currently Using
HDS arrays (using HiCommand) 3 3
Hosts (all vendors) 250 187
Network Appliances filers 4 2
Veritas NetBackup 4 4
Storability Routing Agent 10 4
SRM (file-level) agents 25 12
StorageTek tape libraries 
(SNMP)

3 3

Provisioning module 1 1

Table 4 - License Details

The License Details table will not include the following infrastructure agents:

• Scheduler Agent

• Data Polling Agent

• Data Aggregator Agent

• COM Agent (Management Console)

• License Agent

• Policy Agent

In addition, The License Details table will not include the following obsolete/non-licensed 
agents:

• LSC Agent
• Fabric Performance Agent
• Brocade Agent
• Brocade21 Agent
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• McData Agent
• Host Stats Agent
• Query Agent

Database Administration
The following sections describe the functions that you access under the Database 
Administration menu selection.

Configure Purge Table
Configure Purge Table allows an administrator to control how much historical data is 
maintained in specific, active tables in the database. It allows you to configure the 
frequency that data is exported from the table into a file and then purged from the 
original table.

Note: The system enforces a minimum time that data must be stored in each database 
table.

Add Tables to Purge Table Configuration
To set up the table purge configuration, proceed as described below.

1. Select Database Administration from the Tools pull-down menu.

2. Select Configure Purge Table and the Table Purge Configuration screen appears. 
Note: When you perform this operation for the first time, no tables are listed. 

3. Read carefully the instructions concerning the Purge Table utility.

4. Click Add New.

5. Click the Table Name pull-down menu to examine the tables that you can add to 
the configuration.

6. Use the Day Interval pull-down to specify the number of days to keep the table’s 
data.

7. Click Insert to add the table to the configuration.

8. Repeat Steps 5-7 until all the tables you want to include in the table purge 
configuration are listed.

9. The Scheduled Job (e.g., at1.job) added to the Windows Scheduler on the Central 
Manager is used to trigger the Table Purge for the specified tables. The only 
exception to this rule is the table gsa_alerts table, for which deletion of records is 
automatic when configuration data is entered.

To view/modify the table purge entries, proceed as follows:

a. Log on to the Windows server running the Sun StorageTek Business Analytics 
Central Manager using a user account that has administrator privileges.

b. Locate the file, splist.sql under folder <Storability install root>\GSM\Task. 
c. Uncomment the following lines to the end of the file: 

Sun StorageTek Business Analytics Administration Page 75



 exec gsa_sp_purge_table <table name in single quotes>

go

For example:

exec gsa_sp_purge_table 'gsa_alerts'

go

The next time the scheduled job is run, the records in the table will be deleted 
according to the retention period configured.

Update or Delete Purge Table Configuration
After you have set up the initial Table Purge Configuration, you can update or delete the 
configuration as follows:

1. Select Database Administration under the Tools pull-down menu. 

2. Select Configure Purge Table and the Table Purge Configuration screen 
appears.

3. Choose the table that you want to update or delete from the purge configuration.

4. To update its configuration, click the Update button and the Modify Purge 
Configuration screen appear.

5. Set the new desired interval and click Update.

6. To delete a table in the purge configuration, click the radio button beside the table 
name and click Delete. The confirmation dialog box appears.

7. Click OK to commit the changes.

Refresh Capacity Allocation
The Storage Capacity Allocation Overview pane on the Home Page is refreshed daily by 
default, whereas other data shown is refreshed on a more frequent basis. You use this 
menu to manually refresh the data that appears in the chart.

Proceed as follows to refresh the capacity allocation for a specified view:

1. Select Database Administration under the Tools pull-down menu. 

2. Select Refresh Cap. Allocation and the Refresh Capacity Allocation window 
appears.
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Figure 62 - Refresh Capacity Allocation

3. Click Submit. After the refresh query has executed, the following dialog is 
displayed.

Figure 63 - Refresh Query Completed

4. Click OK to complete the procedure.

DB Batch Job
Database (DB) Batch Job uses the Policy Agent to schedule and execute certain 
database batch jobs that update the dashboard panes on the home page.  The user 
interface is essentially the same as the one you use to configure policy alerting with the 
following exceptions:
• Database batch job administration does not utilize the SMTP email capabilities of the 

Policy Agent.
• Database batch job administration is provided to any Business Analytics user who 

has been assigned user administration rights, regardless of that user’s current view 
or user ID.

If an upgrade of a previous software release to Sun StorageTek Business Analytics 
Release 5.1 (or greater) has occurred, be aware that:
• All the DB Batch Jobs will have to be scheduled using the DB Batch Job menus.
• ETL process may have to be scheduled using the DB Batch Job menus if it was not 

already scheduled in the previously installed release.

Note: Configure Table Purge does not have a related database batch job.  It continues 
to use the entries in the SQL script file (splist.sql) to determine the number of rows that 
are eligible to be purged from the user-specified database tables.

The database batch job templates are described as follows:
• ETL data loading process – Executes the ETL (Extract, Transform, Load) data load 

that updates the tables (gst_*) in the assurent database. These tables are used 
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exclusively by the Storage Wizards. This database batch job allows you to specify the 
mode (0=Incremental; 1=Full) for the ETL process (gsr_main_proc_etl).
 Refer to the Sun StorageTek Application Programmer’s Guide for additional 
information on the ETL process.

Note: In previous releases of Business Analytics, the ETL process was configured 
under Policy Alerting. If the ETL process was not scheduled prior to an upgrade, it 
must be scheduled manually through the use of the DB Batch Job menu.

• NAS SRM Link Policy - Executes the stored procedure that links CIFS and NFS 
share information to SRM mount points. The SRM Agent can be optionally configured 
to scan remote CIFS shares and NFS mounts within its SRM Agent Configuration File 
(config_srm.xml). To view the data, click the Share Name link in NAS Tabular 
Report under the Share Configuration tab.

• Filesystem Forecast Data - Executes the stored procedure that builds the 
filesystem forecast data.

• Home Page Caching process – Executes the stored procedure that updates the 
cache tables related to the home page dashboard panes. This database batch job can 
reduce the time it takes for the Management Console home page to display after a 
user successfully logs in.

• Tape Library Utilization Data - Executes the stored procedure that builds the tape 
library utilization data.

• Tape Library Statistics Rollup - Executes the stored procedure that rolls up tape 
library statistics.

• Storage Util and Trend Data - Executes the stored procedure that rolls up storage 
utilization and trending data.

• Host Util and Trend Data - Executes the stored procedure that builds host 
utilization and trending data.

• SRM File-level Wizards Data - Executes the stored procedure that builds the file-
level SRM data for the SRM File Level Wizard.

Proceed as follows.
1. Select Database Administration-> DB Batch Jobs under the Tools pull-down 

menu.
2. In the top section of the window, the Scheduled DB Jobs table provides the following 

information on each scheduled database batch job schedule in the database:

• Name – Is the name of the database batch job.
• Alert Condition – Specifies the database job parameters, which depend upon 

the selected template. 
• Schedule – Displays the schedule that is enforced by the Policy Agent for the 

database batch job.
• Owner – Displays the non-modifiable owner (GSMuser) of the database batch 

job.
• Enabled – Shows whether the database batch job is enabled (check mark) or 

disabled (blank).
Add/Modify Database Batch Job Schedule
The Available DB Job Table allows you to view/modify a DB batch job schedule. To add 
or modify a database batch job, proceed as follows:

1. Click the link in the Name column to display the Add/Modify DB Job Schedule 
window. This window for the NAS SRM Link Policy is shown below.

Add/Modify DB Job Schedule 
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Figure 64 - Add/Modify Database Batch Job Schedule

2. If applicable, specify the job parameters that depend upon the selected template.
3. Click the Change Schedule button and the Scheduler window appears. 
4. Use the radio button for the “Perform this job:” parameter to specify whether the 

schedule is to occur once or on a recurring basis. If you specify “on a recurring 
basis”, the window is refreshed with Frequency selections (every minute, hourly, 
daily, or weekly. 

5. Use the radio button to specify the frequency where:
a. Every Minute: The window is refreshed and allows you to specify the job will 

be performed every xx minutes.
b. Hourly: Allows you to specify the job will be performed every xx hours.
c. Daily: Allows you to specify the job will be performed every xx days starting 

at the specified time of day.
d. Weekly: Allows you to specify the job will be performed every xx weeks on 

the selected day of the week.
e. Monthly: Allows you to specify the job will be performed every xx months 

on the selected day of the week or date (1-31) of the month.
6. Specify the start date for the schedule:

a. Use the hour/minute list boxes to specify a minute of an hour.
b. Click the Calendar icon and select a month and year

7. Click Save to save the scheduling information and return to the Add/Modify 
Database Batch Job Schedule window.

8. If desired, put a check mark in the “Enable this job” check box to enable the 
database batch job.

9. Click Save to save the database batch job to the database or Cancel to cancel.

Refresh Home Page Cache
All dashboards (e.g., Host Filesystem Utilization) have related cache tables. You can use 
Refresh Home Page Cache to manually refresh these cache tables. In large SAN 
environments, refreshing these cache tables can significantly expedite displaying the 
home page after you successfully log in. 
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Note: You must use “Refresh Home Page Cache” to see the data obtained after a 
“Collect Now” is performed or wait for the next refresh performed through the database 
batch job. By default, the database batch job that refreshes the home page cache runs 
every four hours.

1. Select Database Administration -> Refresh Home Page Cache from the Tools 
menu. The Refresh Homepage Cache menu appears. As the menu warns, refreshing 
the cache tables for the dashboards can take some time to execute.

2. Click Submit to manually run the SQL stored procedure that refreshes the home 
page cache tables. 

3. After this operation is successfully completed, the Refresh Homepage Cache 
Statistics window is displayed. It shows statistics related to refreshing the individual 
home page cache tables. 

Figure 65 - Refresh Homepage Cache Statistics

4. Click OK to close the Refresh Homepage Cache Statistics window.
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