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Preface

Oracle’s StorageTek Library Attach (LibAttach) for Windows Servers is a client 
application that enables Windows networks to use StorageTek’s storage 
libraries. LibAttach provides the connection between Windows and 
StorageTek ACSLS, StorageTek Library Manager (using the StorageTek ACS 
adapter), or StorageTek Library Station, through a TCP/IP network.

■ Related Documentation
The following list contains the names and order numbers of publications that 
provide additional information about the product. 

The online documentation is available at:

http://docs.sun.com/app/docs/prod/filename 

The following books provide more information about this software product:

• LibAttach Integrator’s Pack (available for LibAttach integrators only) 

■ Documentation Website

■ Third-Party Web Sites
Oracle is not responsible for the availability of third-party web sites mentioned 
in this document. Oracle does not endorse and is not responsible or liable for 
any content, advertising, products, or other materials that are available on or 
through such sites or resources. Oracle will not be responsible or liable for any 
actual or alleged damage or loss caused by or in connection with the use of or 
reliance on any such content, goods, or services that are available on or 
through such sites or resources. 

Function URL

Documentation 

Customer:

Employee: 

http://docs.sun.com 

http://docs.sfbay.sun.com/ 

http://docs.sun.com
http://docs.sfbay.sun.com/ 
https://spe.sun.com/spx/control/Login
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■ Oracle Welcomes Your Comments
Oracle is interested in improving its documentation and welcomes your 
comments and suggestions. Submit your comments by clicking the 
Feedback[+] link at: 

http://docs.sun.com 

Please include the title and part number of your document with your feedback: 

Book Title, part number 

http://docs.sun.com
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1Product Overview

StorageTek LibAttach for Windows Servers is a client application that enables 
Windows networks to use StorageTek’s storage libraries. LibAttach provides 
the connection between Windows and ACSLS, StorageTek Library Manager 
(using the StorageTek ACS adapter), or StorageTek Library Station, through a 
TCP/IP network.

■ LibAttach Benefits
LibAttach enables Windows networks to take advantage of the many 
mainframe-class storage solutions available with the StorageTek libraries. 
These storage solutions can provide the following benefits:

• Unattended network backups

• Centralized data storage and management

• Scaleability

• Data security and integrity

• Cost savings

• Firewall security

■ How LibAttach Works
LibAttach runs as a service on a Windows computer. Each Windows computer 
seeking connection to the StorageTek libraries must have a LibAttach license.

In order for a Windows application to communicate with LibAttach it must have 
been integrated with the Automated Cartridge System Application 
Programming Interface (ACSAPI). The ACSAPI is provided with the LibAttach 
Integrator’s Pack, a separate product. See the ACSAPI Programmer’s Guide 
for details.

LibAttach receives StorageTek library requests from Windows applications 
and translates them into Open Network Computing remote procedure call 
(ONC RPC) packets for transmission across the network to ACSLS or 
LibraryStation. ONC RPC is an industry-standard RPC implementation that 
can communicate with many versions of UNIX and Windows.

In turn, LibAttach receives acknowledgment and response messages from 
ACSLS and LibraryStation, and routes them to the appropriate Windows client 
application.
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2Installing LibAttach

This chapter provides information and procedures for:

• “Preparing for the Installation” on page 3

• “Installing LibAttach” on page 4

• “Click Cancel to abort the uninstall process.” on page 13

• “Starting the LibAttach Service” on page 13

■ Preparing for the Installation
Before beginning the LibAttach installation, you should:

• Check with your system administrator to gather the following information: 
servers that should be shut down and window applications that should be 
running.

• Verify that your computer meets the following hardware and software 
requirements:

Hardware and Software Requirements
Microprocessor • Intel 32-bit x86 (or compatible)

• Intel 64-bit ia64 (Itanium)
• AMD 64-bit (Opteron or Athlon64)
• Intel 64-bit EM64T

Operating Systems • Windows 2000 Server/Advanced 
Server with service pack 4

• Windows Server 2003 with service 
pack 2 32-bit x86

• Windows Server 2003 with service 
pack 2 64-bit ia64

• Windows Server 2003 with service 
pack 2 64-bit AMD64

• Windows Server 2008 32-bit x86
• Windows Server 2008 64-bit ia64
• Windows Server 2008 64-bit AMD64

Memory (RAM) Same requirements as operating system

Disk space 8 MB
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Note: Installing and running LibAttach on workstation-class operating 
systems is not supported. If you install and then run Configurator 
on a workstation, you receive a warning that your computer does 
not meet the minimum software requirements.

• Obtain either the host name or the IP address of the ACSLS or 
LibraryStation server.

• Verify that all programs using the LibAttach services are halted if this is a 
reinstallation. This is to prevent conflicts when the setup program stops 
LibAttach services.

• You must remove any prior version of LibAttach before installing LibAttach 
1.4.3.

• You can quit the installation at any time by clicking the Cancel button. To 
rerun the installation later, simply follow this procedure again from the 
beginning.

■ Installing LibAttach
1. Insert the Library Attach CD.

Note: A window appears if the system detects you are running in a 64-Bit 
environment. In this case, you select which version of LibAttach 
you wish to install (32-bit or 64-bit). Check with your IT department 
to verify the version you need; choosing the incorrect version 
results in your media application being unable to communicate with 
the library server. 

The LibAttach installation CD contains installation packages for the three 
architectures supported by LibAttach. 

Processors which support x86 are nearly all Intel and Intel-compatible 32-
bit processors (AMD and Cyrix). Processors which support ia64 are the 
Intel Itanium and Itanium2. Processors which support AMD64 are the AMD 
Athlon 64 family, AMD Opteron family, Intel Pentium 4 with EM64T, Intel 
Xeon with EM64T, and Intel Core 2 family.

The processors which can run 64-bit applications (either ia64 or AMD64) 
can also support running 32-bit x86 applications, either through emulation 
(on ia64) or natively (on AMD64).

Depending upon your installation, you may be running 32-bit applications 
on a 64-bit architecture. In this case, you must install the 32-bit version of 
LibAttach. In other words, the "bitness" of LibAttach must match the 
"bitness" of your media application.

After your selection the LibAttach 1.4.3 screen appears.

The setup program prepares the InstallShield. The Welcome screen 
appears.
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Figure 1.  Welcome Window 

In this example, you are installing LibAttach on a 32-bit x86 processor. 
This window should match the processor on which you are installing.

2. Read the Welcome message and click Next

A window similar to the following appears



Installing LibAttach

6 316137901 Revision AA

Figure 2.  Customer Information 

3. Enter your User Name, Organization, and Site ID.

You must enter a site ID before continuing. If you do not have a Site ID, 
enter 9999 to proceed.

4. Select the type of shortcut.

5. Click Next.

The following window appears.

Figure 3.  Configure LibAttach 
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Installing LibAttach

6. Enter the default library server host name or IP address. 

The Host Name contains the host name of the library server to which you 
want you client software to interface. This field can be either the name of 
the host or the IP address for the host. The name must match a valid 
machine on your network. The field is mandary, and may contain only one 
entry.

After clicking Next, the following window appears.
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Figure 4.  Server Information 

7. Click Next.

The following window appears.



Revision AA 316137901 9

Installing LibAttach

8. Click Next.

The following window appears.

Figure 5.  Choose Destination Location Window 
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Figure 6.  Custom Setup 

9. Select LibAttach Program and click Next.

The LibAttach packages and the SunRPC Portmapper is installed. 

You can only have one portmapper running.

Note: If you have a portmapper installed and want to use it for your 
connection, you must first:

a. Click the down arrow next to SunRPC Portmapper.

b. Select “This feature will be not be available” in the icon box.

An X will appear in the icon box next to SunRPC Portmapper. 
The SunRPC Portmapper will be disabled.

c. Select LibAttach Program.

Note: Click Help to display the description for the icons for this screen.

Click Space to change the disk space requirements.

A Ready to Install window displays the settings you have entered and 
chosen in the preceeding windows. 
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.

10. Confirm that the entries are correct, then click Install.

The following window appears.

Figure 7.  Ready to Install Window 
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The installation program copies the program executable files to your 
computer. No action is necessary.

The following window appears.

Figure 8.  Installation Status Bar 
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Starting the LibAttach Service

.

Note: The installation is now complete, but it is highly recommended that 
you now launch the Configurator.

11. To do this click in the Launch LibAttach Configurator box and click Finish.

Refer to “Using the Configurator” on page 17 for detailed information for 
setting up the Configurator.

Note: Click Cancel to abort the uninstall process.

■ Starting the LibAttach Service
During installation, the LibAttach service is configured to start up automatically 
when your computer is booted. There may be situations, however, where you 
need to start the service manually (for example, you have explicitly configured 
the service to start manually, or you have previously stopped the service 
manually). To do this:

1. Select Control Panel -> Administrative Tools -> Services.

The Services window appearss.

Figure 9.  Installation Complete Window 
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2. Right click on LibAttach, then click Start.

The service starts.

■ Uninstalling LibAttach
You may want to remove LibAttach if are no longer using it on your computer 
or if you want to change the directory where it is installed.

To do this:

1. Select Start -> All Programs -> Oracle -> LibAttach -> Uninstall LibAttach.

The following window appears.

2. Click Yes.

The following window appears.
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Uninstalling LibAttach

Note: Click Cancel to abort the uninstall process.
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3Using the Configurator

This chapter describes how to use the Configurator to set up your 
environment. Provided are procedures for:

• “Starting the Configurator” on page 17

• “Using the Configurator Menus” on page 18

• “Setting General Options” on page 20

• “Setting the Network Protocol” on page 22

• “Setting up Firewall Support” on page 22

• “Setting Up Multiple Library Servers” on page 25

• “Testing Server Settings” on page 29

• “Viewing Library Server Processes” on page 30

■ Starting the Configurator
You can start or access the configuration in one of two ways:

• When you launch the Configurator during installation.

• By clicking Start -> All Programs -> Oracle -> LibAttach 
Configurator

The following window appears:
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■ Using the Configurator Menus
The configurator is comprised of three drop down menus:

• Server

• Configuration

• Help

Using the Server Menu Options
The Server drop down menu provides the following selections:
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Using the Configurator Menus

Select:

• Server -> Add new server - to add a new server

• Server -> Delete a server - to delete an existing server

• Server - Set default server - to set a default server from a list of 
available servers

Using the Configuration Menu Options
The Configuration Menu drop down menu provides the following selections:

• Configuration -> Apply - to save changed settings

• Configuration -> Revert - to return to the previous configuration 
settings. You cannot do this if you have already applied changes

• Configuration -> Test - to test connectivity to the server and 
configuration
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• Configuration -> Information - to view LibAttach process 
information

The items on this menu change with the operation being performed. When 
viewing servers (not making changes), the Test and Information items are 
enabled. If the currently viewed server is altered in any way, or if a new server 
is being added, then the Test and Information items are disabled, and Apply 
and Revert are enabled.

Help Menu Choices
The Help drop down menu provides the following selections:

Select:

• Help -> Help - to view and print help about the Configurator.

• Help -> About - to view a statement regarding trademark and the 
LibAttach version number

■ Setting General Options
The Configurator allows you to set up the following options:

• Local address

• Library server host name

• Timeout value
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Setting General Options

• Retry value

To set general options:

1. Click Start->All Programs >Oracle >LibAttach > Configurator.

2. Enter your local address information.

This is a required field. Local address is a drop down menu, which is 
populated by a list of all addresses for all active network interfaces on the 
local server. You can select:

• Default to allow Windows to select the address for you. If default is 
selected, LibAttach attempts to match the network interface for 
communications with the defined library server. The interface that is 
the default is determined by the order as established in the Windows 
network control panel applet. This field is mandatory, and may contain 
only one entry. 

The default local address is “Default”.

• A specific address from the drop down menu for the service to use. 
The service then selects the appropriate network interface card (NIC) 
for the address. This allows you to specify which adapter to use to 
communicate with the ACSLS host.

For servers that participate in multiple networks, this field is very important. 
An improperly selected address in this field can prevent all 
communications to your library server. You may need to consult with your 
network administrator for help.

3. Enter your Library Server Host Name.

This contains the host name of the ACSLS (or other) host to which you 
wish to interface. The value of this field may be either the name of the host 
or the IP address for the host. If this field does not contain a valid address, 
LibAttach will attempt to find the IP address by doing a DNS lookup, or 
searching the hosts file on the machine on which it is installed. This field 
cannot be blank.

4. Enter the timeout value or accept the default.

The time out value is the time, in seconds, LibAttach should wait for a 
response to a request it has sent to ACSLS, Library Manager, or a Library 
Station. If LibAttach does not receive a response within the specified time, 
it resends the request, until the Retry count has been reached. 

5. Enter the retry value or accept the default.

The Retry value is the number of times LibAttach attempts to resend a 
request before discarding it. 

The values of Timeout and Retry should be set in conjunction with each 
other. The default values are adequate for most sites; however, in the 



Using the Configurator

22 316137901 Revision AA

situation of a remote ACSLS or LibStation server, or very slow or dirty 
network, these values may need to be adjusted. The messages may take 
the form:

csi_rconnect(): status: STATUS_NI_FAILURE; failed: connect()
Could not connect to remote host libserver.company.com:8020

The following should be taken into consideration when adjusting the 
values for Timeout and Retry:

• When changing values to timeout and retry values, make small 
adjustments to one parameter at a time in small increases.

• The product of timeout and retry should be kept as small as possible.

• You should try to make the values of timeout and retry approximately 
equal to those on the ACSLS server.

• You may need to increase retry and/or timeout values. If ACSLS is 
frequently unavailable, you may need to lower values of timeout and 
retry to prevent unnecessary retries.

6. Set up your network protocol.

■ Setting the Network Protocol
The Network Protocol check boxes specify the network transport that 
LibAttach is to use to send and receive requests and responses. 

1. Choose at least one protocol. 

Which ever protocol you select, you must ensure the server is configured 
to send and receive requests using the same protocol. If you check both 
protocols, LibAttach uses TCP. If you select:

• TCP - an acknowledgement is sent for each packet received. This 
increases reliability, but also increases network traffic. 

• UDP - an acknowledgement is not sent; packets are assumed to arrive 
correctly.

2. Set up firewall support.

■ Setting up Firewall Support
Check with you system administrator before setting up your firewall.

Overview
The Configurator allows you to set up firewall support by entering:

• Ports (starting port number and max number of ports)
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Setting up Firewall Support

Several singular ports, and a range of ports, must be opened on the 
firewall for communications between LibAttach and the Library Server. If 
you define more than one library server, each library server must have its 
own set of ports. There is currently no checking of static port settings 
among servers. 

- Port ranges

The range of ports must be opened on the firewall for communications 
between LibAttach and the Library Server. You may need to contact 
your network administrator for these values. 

The range of ports is required, because the interface between 
LibAttach and the library server is asynchronous. Each request to the 
library opens a new port, and each response back from the library 
server opens yet another port. Therefore, a typical transaction 
between LibAttach and the library server opens at least three ports. If 
the firewall also blocks return traffic, static ports may be defined for 
LibAttach to listen on for responses. 

- Ports assigned in a pool

There must be enough ports in the pool (defined as starting port plus 
max # of ports) to accommodate the level of activity for this server. As 
described above, a typical library server transaction consumes three 
ports. After a port has been consumed, it remains in a wait state for up 
to two minutes before becoming available again. The ports are 
consumed out of the pool in a circular manner, meaning least-recently 
used will be next used. This helps alleviate the problem, but on a very 
active server, it is possible that all the ports will be consumed, and all 
ports in the pool will end up in the wait state. When this happens, 
LibAttach will be unable to communicate with the library server. The 
symptom of this condition will appear as warning messages in the 
Windows event log. The messages take the form:

cl_ipc_xmit() [2263]: cannot bind to local static port 22022 (10048)

Where: The number 2263 is the ID number of the running 
LibAttach process responsible for communications with a library 
server. This number is important for determining which server 
connection is having trouble.

The solution is to increase the number of ports in the pool. An 
alternative to increasing the number of ports is to decrease the wait 
state time in Microsoft Windows. 

• Whether to restrict LibAttach to using only the pre-defined range of ports 
for its interprocess communications

• Library server host port

• If your firewall blocks return traffic from the library server, select:
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- TCP listening port

- UDP listening port

Setting Firewall Support
To turn on the firewall-secure option, enter the following information.

1. Enter the starting port number

This is the first port number opened on the firewall.

2. Enter the Max # of ports 

This is the number of ports that have been opened on the firewall. 
LibAttach uses ports from this pool in a circular manner.

3. Click to restrict interprocess communications to port range.

CAUTION: You would only select this option of restricting IPC ports to a 
port range if your system uses TCP port filtering. If you are 
not using TCP port filtering, it is highly recommended that 
you do not enable this setting, as it may interfere with the 
operation of your client application.

If you have enabled port filtering on this server, check this box to force 
LibAttach to use only the pre-defined range of ports for its interprocess 
communications. Then, you must open this range of ports in the Port 
filtering tab in the Network control panel. If in doubt, leave this box 
unchecked. 

if you have not entered a starting port and a max number of ports in the 
previous two fields, this box cannot be checked. Also, you many have to 
restart your media application for this setting to take effect.

4. Enter the Library Server Host Port 
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Setting Up Multiple Library Servers

If the firewall blocks RPC (this is quite common), the library server must be 
set up with a static port for communications from clients. For example, in 
ACSLS this is called the CSI Host Port, and is configured on the server. 
Enter that port number here. When this value is specified, LibAttach will 
not attempt any communications using UDP port 111. 

The following two fields are used if your firewall also blocks return traffic 
from the library server.

5. Enter the TCP Listening Port

This is the port number on which LibAttach listens for TCP responses from 
the Library serve This port must also be opened in the firewall. If TPC is 
unchecked in Network protocol, this field has no meaning.

6. Enter the UDP Listening Port

Enter the number of ports to which LibAttach will listen for UDP responses 
from the Library server. This port must also be opened in the firewall. If 
UDP is unchecked in Network protocol, this field has no meaning. 

Note: With most firewalls, UDP is disabled across all ports, in which case 
the UDP check box in Network protocol should be unchecked, and 
this field should be “0”.

To disable all firewall-related communication functions for the current 
library server, enter zeros in all the fields.

7. Click Configuration > Apply.

The following message appers.

8. Click Yes.

■ Setting Up Multiple Library Servers
LibAttach 1.4.3 provides the ability to simultaneously connect to and 
communicate with more than a single library server. Applications must be 
LibAttach 1.4.3-aware to support multiple library servers. Please contact your 
application software vendor for more information.
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This section discusses how to:

• Add a new library server

• Change an existing server

• Delete an existing server

• Set a new default server

Adding a New Server
To add a new server:

1. Click Server -> Add new server.

Figure 10.  Adding a new server 

The following window appears.
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Setting Up Multiple Library Servers

2. Enter your information in the appropriate fields. 

3. Click Configuration -> Apply.

You need to restart the LibAttach service. This is mildly disruptive and your 
client will lose connectivity to your defined library server(s) for a moment. 
Once the server has been successfully added, it will also be added to the 
Server menu. You may define up to a maximum of ten library servers. 
Once ten servers have been defined, the Add new server menu item is 
disabled.

Note: Click Configuration -> Revert to cancel the operation.
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Changing an Existing Server
To change an existing server:

1. Click Server and choose the server from the list of defined servers on 
the menu as shown in the following figure.

In this figure there are two servers currently defined, 
libserver.company.com and cirano.company.com. The check beside 
libserver.company.com indicates that this server is the one currently being 
viewed. If cirano.company.com were selected for viewing, the check 
mark would move to that server. 

2. Make any desired changes and click Configuration -> Apply. 

Note: Click Configuration -> Revert to undo all changes to this 
server. You can also abandon the changes by selecting a different 
server, or by exiting the program.

Deleting an Existing Server
To delete an existing server from a list of available servers:

1. Click Server and from the list of servers, select the server to be deleted.

1. Click Server -> Delete server at the delete window.

The following window appears.
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Testing Server Settings

2. Click Yes to delele. 

Note: The deletion cannot be undone, and you cannot delete the default 
server. If only the default server is defined, the Delete server menu 
item is disabled.

Setting a New Default Server
The initial default server is defined when you installed LibAttach. The default 
server is the server that is used by applications that are not LibAttach 1.4.3 
aware (they do not specify a server when issuing library commands).

To select a different server as the default:

1. Click Server and from the list of servers, select the server you want as 
the default.

2. After selecting the server, Click Server -> Set default server.

■ Testing Server Settings
After changes have been applied and the LibAttach server has been restarted 
you have the option of validating your settings and connectivity. To do this:
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1. Click Configuration -> Test.

2. If the test is successful, a confirmation message appears with the number 
of free cells and tape drives.

If not, you receive a failed message.

■ Viewing Library Server Processes
Each defined library server has its own dedicated LibAttach process. The 
maximum number of library servers that may be defined is ten, so the 
maximum number of LibAttachs processed is also ten. Each process 
consumes about 2.5 MB of memory and is assigned a process ID by 
Windows. If problems arise with a library server, you see messages in the 
Windows event log, and/or the LibAttach event logger, and its process ID. 

To view a library process:

1. Click Configuration -> Information.

The following window appears.
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Viewing Library Server Processes

In this example, two library servers have been defined, with process IDs of 
5056 and 2660. If you were receiving messages that alerted you to trouble 
from process 2660, you would know that LibAttach is having difficulties 
communicating with the server libserverser.company.com. You could then 
take appropriate corrective action. 

Process IDs change with each restart of the LibAttach service.
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4Using the Event Logger

The event logger is used to monitor communications between LibAttach and 
the library server (ACSLS, Library Station, or Library Manager) to which it is 
connected

This chapter provides information on:

• “Getting Started” on page 33

• “Using the Logger Menus” on page 35

• “Event Logging” on page 36

• “Tracing” on page 38

• “Decoding Trace Files” on page 40

• “Deleting an Existing File Name” on page 41

■ Getting Started
This section describes:

• What you need to do to set up your event logging as discussed on 
page 33.

• Using the event logger as discussed on page 33.

• Using the event logger menu options as discussed on pages 35 and 35.

Setting up your event log 
The first time you set up the event logger, you need to perform the following 
steps:

1. Start the event logger as discussed on page 33.

2. Start tracing as discussed on page 38.

3. Start the decoding of trace files as discussed on page 40.

Using the Event Logger
To start the LibAttach event logger:
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1. Click Start->All Programs->Oracle->LibAttach->Event Logger.

The main Event Logger window appears. 

The large empty block in the center is called the progress window, and this is 
where events appear. 

• The Help button generates on-line help. 

• The Exit button quits the program. 

You can also click File -> Exit. 

• The status bar appears below the Help and Exit buttons.
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Using the Logger Menus

■ Using the Logger Menus
The event logger is an exception logger, which means that only errors and 
other program anomalies will generate events.

The event logger is comprised of two drop down menus:

• File menu

• Edit menu

Using the File Menu Option
The File drop down menu provides the following selections:

• File -> Start Log... starts event logging.

• File -> Start Trace ... starts monitoring. 

Tracing monitors not only event logging, but captures every packet of 
information sent across the network to the library server. Using this 
function greatly aids in your diagnostic efforts.

• File -> End Trace ... stops monitoring.

• File -> Decode Trace ...translates the trace format from binary 
format to a readable format, such as a text file.

• File -> Exit stops event logging.

You can also do this by clicking the Exit button above the status bar.

Using the Edit Menu Option
The Edit drop down box provides the following selection:
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Selecting Edit -> Clear ... clears the display.

■ Event Logging
When you first start up the Event Logger, it is idle. To begin logging events:

1. Click File -> Start Log …  

The following window appears.

2. Enter a file name for the log file in the File name field. 

This log may be stored on any valid local or network file system. 

• If you choose a file that already exists, new events will be appended to 
this existing file. 

• If you do not want to append to the existing file:

a. You must right-click the existing file and choose Delete. 

b. After the file has been deleted, click Save. 

The status bar of the Event Logger window shows that logging has begun 
to the file you’ve just chosen.
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Event Logging

Once event logging had begun, the progress window remains empty until 
an event occurs. Remember, that the event logger is an exception logger 
and only errors and other program anomalies will generate events. 

The events appear in the progress window as shown in the following 
figure:

Note: The progress window can be cleared by clicking Edit -> Clear.

The construction of the message provides the following information:

• The first line contains:

- The date and time the message was generated.

- The source of the message (always SSI).

- The process ID that generated the message. 

• Each running LibAttach process responsible for communications with a 
library server is assigned a unique process ID by Windows. You can 
relate a process ID to a running LibAttach service, and a configured 
library server by using the Configurator. In this example the process ID 
is 3041.

• The next line contains the:

- Protocol (always ONC RPC)

- Internal function where the fault occurred. 
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- Status generated by the fault. 

- Additional information further detailing the fault. 

Note: Remember, a properly functioning LibAttach installation will not 
generate any errors.

Stopping the Event Logging
To stop logging, exit the program by either clicking the Exit button, or clicking 
File -> Exit.

■ Tracing
Tracing monitors not only event logging, but captures every packet of 
information sent across the network to the library server. Using this function 
greatly aids in your diagnostic efforts. 

• Servers 

When you start tracing, all servers that have been defined begin 
tracing. If the server(s) is busy there will be a vast amount of trace 
information. You can see which server is generating trace information 
by identifying the process ID located on the first line of each trace 
message. You can then relate a process ID to a running LibAttach 
service, and to a configured library server by running the Configurator.

• API Trace - LibAttach and a client application

LibAttach also includes the ability to trace transactions between itself 
and a client application. Whenever tracing is active, all client 
application accesses are logged to the file you choose when you 
started tracing. This file is approximately 1/6th the size of the regular 
trace file. This file can help diagnose disconnects and other difficulties 
between LibAttach and a client application. API requests can be 
generated by any number of client applications, but only one trace file 
can be created. This file is a plain text file which means no decoding is 
necessary. 

Starting Tracing
To start tracing using the Event Logger:

1. Click File -> Start Trace … 

The following window appears.
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Tracing

2. Enter a file name for the trace file in the File name field and click Save. 

This file can be stored on any valid local or network file system. If you 
choose a file that already exists, new trace information is appended to the 
existing file. The status bar of the window shows that tracing has begun to 
the file you chose. The trace log contains more information than the event 
log.

The following message appears:

3. Make your selection.

Trace log information appears in a window similar to the following:
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Stopping Tracing
Tracing can be stopped at any time by clicking File -> End Trace.

■ Decoding Trace Files
The trace files are binary in format. To translate them into readable form:

1. Click File -> Decode Trace … 

2. Select the trace file (that was previously created) to be decoded.

3. Choose a text file name to contain the decoded trace information.

The decode process begins immediately as shown in the following figure.

You can cancel decoding at any time by clicking Cancel. 

4. Click OK to view the decoded message in the trace.

When done, the decoded trace will be shown in the Windows notepad, as 
shown in the following figure. In this example the process ID is 1712.

Note: Very large trace decodes cannot be viewed in notepad, and must 
be viewed with another text editor, such as Microsoft Word
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Deleting an Existing File Name

In this example the process ID is 1712. 

Note: You can use the Configurator application to relate a process ID to a 
running LibAttach service and to a configured library server.

■ Deleting an Existing File Name
You can choose to delete an existing log or trace file name by performing the 
following steps:

1. Access your log file or trace file.

2. Right-click the file name.

3. Select Delete.

4. Click Yes at the confirmation message.
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ARegistry Updates

This appendix describes the changes to the Windows Registry made by 
LibAttach.

■ Subkey Location
The Registry entries used and updated by LibAttach are found in the 
HKEY_LOCAL_MACHINE\Software\Oracle. Each defined server then 
creates a subkey.

■ How the Registry is Updated
The keys and value entries are created and set during LibAttach installation, 
specifically by the data you enter in the Configure LibAttach screen.

To change most of the value entries you can either rerun the installation (the 
preferred method) or use the Registry editor, REGEDT32.

■ Configurator Screen
The following table shows which Registry value entries are set by which 
parameters on the Configurator LibAttach screen.

Registry Value Entry Screen Parameter
CSI_CONNECT_AGETIME N/A — does not appear on screen

CSI_HOSTNAME ACSLS or LibraryStation host 
name

CSI_RETRY_TIMEOUT Timeout

CSI_RETRY_TRIES Retry count

CSI_TCP_RPCSERVICE RPC Protocols: TCP/IP

CSI_UDP_RPCSERVICE RPC Protocols: UDP

RestartCount N/A — does not appear on screen

SocketName N/A — does not appear on screen

TraceValue N/A — does not appear on screen

Type N/A — does not appear on screen

FixedPortForTCP TCP listening port
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Note: A 0 (zero) value indicates previous behavior or that firewall 
configuration is off.

The Registry values not found on the Configurator LibAttach window are 
described below. Normally, these values should be left at their defaults and not 
changed through the Registry editor.

Connect age time
When LibAttach receives a request from an application, it strips the IPC 
header from the request and stores it in a queue before attaching a new IPC 
header and forwarding the request. 

This parameter specifies how many seconds LibAttach should keep the IPC 
header in its queue waiting for a response from ACSLS or LibraryStation 
before discarding the header.

Use the following guidelines when setting this parameter:

• LibAttach’s Connect age time value must be greater than the product of 
the timeout and retry count values set for the ACSLS or LibraryStation 
server. Likewise, the connect age time value for ACSLS or LibraryStation 
must be greater than the product of the Timeout and Retry count values 
set for LibAttach.

• The Connect age time value should not be set higher than necessary. 
Increasing the value of this field unnecessarily delays the ability of 
LibAttach to detect network or ACSLS/LibraryStation server failures.

Restart count
The number of times spawned processes are restarted if they are abnormally 
terminated.

This parameter is not used by LibAttach.

Socket name
The socket on which LibAttach listens for requests from applications. An 
application must send requests to this socket in order for LibAttach to receive 
them.

FixedPortFor UDP UDP listening port

FixedPortsCurrent N/A

FixedPortsMAX Max number of ports

FixedPortsStart Starting port

Registry Value Entry Screen Parameter
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Configurator Screen

Normally this value should be left at the default.

Trace value
This value is set by the toggle_trace command. “0” indicates that packet 
tracing is turned off; “1” indicates that tracing is turned on. See “Using the 
Event Logger” on page 33 for detailed information.

Type
The LibAttach component ID. This value is used in the IPC packet to identify 
LibAttach as the originator of a request. This information is used by ACSLS 
and LibraryStation.

CAUTION: This value should never be changed from the default.
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BTroubleshooting

If you encounter a problem with the LibAttach software, you can take several 
simple steps to help isolate and possibly solve the problem yourself. This 
chapter details these steps. We recommend you work through the steps in this 
chapter before calling software support.

Even if you cannot solve the problem yourself, these steps will help you gather 
the information software support needs to address the problem most 
efficiently.

■ ACS Not Responding to Submitted Commands
If you are unable to submit commands to an ACSLS host, follow the steps 
below.

1. Determine the network configuration. To do this, identify and write down 
the following host names:

• The LibAttach server

• The ACS server (the server on which the ACSLS, StorageTek Library 
Manager, or Library Station software is installed)

• The host to which the tape drive is connected

2. On the LibAttach server, bring up the Services window and verify that the 
StorageTek LibAttach and SunRPC Portmapper services are running.

If either service is not running you need to start it before proceeding.

3. Verify that the LibAttach server can communicate with the ACSLS or 
LibraryStation server. To do this, issue the following command from a 
Command Prompt or MS-DOS console window on the LibAttach server:

ping acs_host 

where acs_host is the ACSLS or LibraryStation host name you identified 
in Step 1.

If the server does not respond, you need to establish the network 
connection before proceeding.

4. Display network interface parameters for the LibAttach server, including 
the IP and MAC addresses. To do this, issue the following command from 
a Command Prompt or MS-DOS console window on the LibAttach server:

ipconfig /all 
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If any of the parameters are incorrect, you need correct them before 
proceeding.

5. Display message routing information for messages travelling between the 
LibAttach and ACS servers. To do this, issue the following command from 
a Command Prompt or MS-DOS console window on the LibAttach server:

tracert acs_host 

where acs_host is the ACSLS or LibraryStation host name you identified 
in Step 1.

If you notice any problems, you need to correct them before proceeding.

6. Check the Windows event log for LibAttach messages. To do this, double-
click the “Event Viewer” in the “Administrative Tools” group.

Upon successful start-up, LibAttach makes at least three entries in the 
event log:

1. svc_main – LibAttach service initialized

2. svc_main – LibAttach ready

3. csi_main – SSI ready (one per defined server)

The SunRPC Portmapper also writes one entry to the log on a 
successful start-up:

The service was started. 

CAUTION: All of these entries should be preceded by the blue circle -I 
“Information” icon. If you find any LibAttach messages with 
yellow “warning” or red “failure” icons, a serious error occurred 
within LibAttach. Contact StorageTek software support.

Hint: Refer to your Windows documentation for help using the Windows 
Event Viewer.
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Glossary

A
ACS — See automated cartridge system.

ACS event logger (ACSEL) — The 
software component that receives messages 
from other ACSLS components and writes 
them to an event log.

ACS library manager (ACSLM) — The 
software component that validates and 
routes library requests and responses.

ACS library software (ACSLS) — 
Manages ACS library contents and controls 
ACS library hardware to mount and 
dismount cartridges on ACS cartridge 
drives.

address — In a data communications 
network, the symbolic identifier used to route 
messages to a terminal or node. An address 
depends on the types of telecommunications 
or networking protocols being used.

automated cartridge system (ACS) — The 
library subsystem consisting of one LMU, 
and one to 24 Lessens connected to that 
LMU.

automated library — See library.

B
browse — To look through a list of 
directories, files, or computers.

C
click — To quickly press and release a 
mouse button.

client — A computer that accesses shared 
network resources provided by another 
computer (the server). See also server.

client system interface (CSI) — The 
software component, resident on the server 
system, that translates and routes 
messages between the ACS library 
manager and LibAttach.

control path — Allows client applications to 
gain access to tape cartridges by interacting 
with ACSLS.

CSI — See client system interface.

CSI variables — Environment variables 
defined on the server system and used to 
define various options to fine-tune 
communications between LibAttach and the 
CSI.

D
data path — Allows client applications to 
read and write data to a cartridge.

device driver — A program that enables a 
piece of hardware (device) to communicate 
with the computer’s operating system.

domain name system (DNS) — The 
Internet naming system that orders a 
sequence of names to identify host sites. 
Names are ordered in a hierarchy, from 
specific to general, separated by periods. 
Some domains in the Internet are .com 
(commercial), .edu (educational), .gov (U.S. 
Government), and .mil (U.S. military).

double-click — To rapidly press and 
release a mouse button twice without 
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moving the mouse. Double-clicking carries 
out an action, such as starting an 
application.

E
environment variable — A UNIX feature 
used to customize features and functions of 
the operating environment.

event — A significant occurrence in the 
system or an application that requires users 
to be notified or an entry to be added to a 
log.

event log — A file, maintained by the 
ACSEL, that contains messages describing 
library and ACSLS events.

event logger — See ACS event logger.

H
host — A computer that is attached to a 
network.

host name — The identifying name given to 
a computer.

I
internet — Used as a descriptive term, a 
collection of interconnected packet-
switching networks.

Internet — Used as a formal name, a 
worldwide collection of networks that are 
interconnected and not administered by any 
single authority. Internet networks 
communicate using TCP/IP.

internet protocol (IP) — A protocol that 
defines a common layer over networks so 
that a packet of information can move 
across different networks to reach its final 
destination.

IP address — A unique number that 
identifies each host in a network.

L
LAN — See local area network.
LibAttach — A software component, 
resident on a Windows NT client system, 
that translates and routes messages 
between client applications and the CSI.

library — A library is composed of one or 
more ACSs, attached 4480 cartridge drives, 
volumes in the ACSs, and the ACSLS 
software that controls and manages the 
ACSs.

local area network (LAN) — A computer 
network in which any component in the 
network can access any other component. 
The network covers a physically limited 
area. This is the type of interface between 
an LMU and attached LSMs.

N
network adapter — Equipment that 
provides an electrical and logical interface 
between a network and specific attached 
equipment.

network interface (NI) — An interface 
between the server system and the client 
systems that maintains network connections 
and controls the exchange of messages. 
The NI is resident on the server system and 
each client system.

node — A device at a physical location on a 
network that performs a control function and 
influences the flow of data in the network. 
Can also refer to the points of connection in 
the links of a network.

O
ONC — Open Network Computing.

Open Systems Interconnection (OSI) — A 
software architecture model of the 
International Organization for 
Standardization. The OSI model provides 
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standards for the interconnection of data 
processing systems.

P
packet — A group of information in a fixed 
format that is transmitted as a unit over 
communications lines.

path — The location of a file within the 
directory tree.

protocol — A set of agreed-upon rules and 
conventions governing the formats and 
processes used in data communications. 
Protocols control the exchange of 
information between systems, including the 
format, timing, and error control of 
transmissions on a network.

R
RPC — Remote Procedure Call. A 
message-passing facility that allows a 
distributed application to call services 
available on various computers in a network.

Registry — A Windows NT database 
containing information about a computer’s 
configuration.

S
server — A computer that provides a 
network service, such as disk storage or file 
transfer. See also client.

server system — In Nearline operations, 
the part of the library that is the residence for 
ACSLS or LibraryStation. The server system 
acts as an interface between a library and 
client systems.

service — In Windows NT, a process that 
performs a specific system function and 
often provides an application programming 
interface (API) for other processes to call. 
Windows NT services are RPC-enabled, 

meaning their API routines can be called 
from remote computers.

T
TCP/IP (transmission control protocol/
internet protocol) — An Internet standard 
protocol that enables communication 
between the same or different computers on 
a network. The transmission control protocol 
is connection-oriented; it monitors the 
correct transfer of data between computers. 
The Internet protocol is stream-oriented; it 
breaks data into packets and sends them to 
a network within the Internet.

U
UDP (user datagram protocol) — A 
protocol at the same layer as TCP that does 
not acknowledge transmission. UDP is 
therefore unreliable.

UNIX — An operating system originally 
developed by Bell Laboratories (now UNIX 
Systems Laboratories, Inc.) and used by a 
variety of computer systems.
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L
LibAttach

how it works, 1
LibAttach service

function of, 1
installing, 4
socket name, 44
starting, 13

Library Servers
setting up multiple, 25

N
Network Protocol, 22

R
Registry

LibAttach subkey location, 43
LibAttach value entries, 43
See also configuration parameters
updating, 43

requirements See system requirements
restart count parameter, 44
RPC (used by LibAttach), 1

S
screens

InstallShield Wizard Complete, 13
Services, 13

Server
adding new, 26
changing existing, 28
deleting existing, 28
setting default, 29
setting new default server, 29
testing settings, 29
viewing server configuration, 30

Services screen, 13
Setting Default Server, 29
Setting up Firewall Support, 22
socket name parameter, 44
software requirements, 3
starting

LibAttach service, 13

system requirements, 3

T
Testing Server Settings, 29
trace value parameter, 45
Tracing

decoding trace files, 40
starting, 38
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type parameter, 45
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