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Preface

This guide is intended primarily for SL3000 library system administrators and 
operators. It can also be used by Sun StorageTek Partners and support representatives. 

Most of the information pertains to the library hardware, the StorageTek Library 
Console, and related operations. For specific drive information or for client application 
software commands, see the appropriate drive or software documentation.

Organization

Chapter 1 SL3000 Introduction. Overview of the Sun StorageTek SL3000 modular library system 
features and functions. 

Chapter 2 StorageTek Library Console. Topics and procedures for installing and using the 
SL Console graphical user interface. 

Chapter 3 SL3000 Automated Library Operations. Topics and procedures for using the 
SL Console to configure, manage, and monitor the SL3000 library in automated mode. 

Chapter 4 Licensing. Topics, procedures, and screen reference for installing and managing 
SL3000 feature licenses. 

Chapter 5 Capacity on Demand. Topics, procedures, and screen reference for installing and 
managing SL3000 licensed capacity.

Chapter 6 Library Partitioning. Topics, procedures, and screen reference for installing and 
managing SL3000 library partitions.

Chapter 7 SL Console Diagnostics and Utilities. Topics and procedures for using the 
SL Console to perform diagnostic and utility functions on the SL3000 library. 

Chapter 8 Manual Operations. Topics and procedures for safely using the SL3000 library in 
manual mode. 

Appendix A Library Resource Addresses. Reference information regarding storage cell, CAP, and 
drive addressing used with the SL3000 library. 

Appendix B Wall Diagrams. Detailed diagrams of storage cell, CAP, and drive layouts. 
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Alert Messages
Alert messages call your attention to information that is especially important or that 
has a unique relationship to the main text or graphic.

Note – A note provides additional information that is of special interest. A note might 
point out exceptions to rules or procedures. 

Caution – A caution informs the reader of conditions that might result in damage to 
hardware, corruption of data, corruption of application software, or long-term health 
problems in people. A caution always precedes the information to which it pertains.

Warning – Possible Physical Injury.  A warning alerts the reader to conditions 
that might result in injury or death. A warning always precedes the information 
to which it pertains.

Appendix C Cartridge Handling. Reference information on labeling and using cartridges in the 
SL3000 library. 

Appendix D Web-launched SL Console Server. Topics and procedures for installing and 
configuring the Web-launched SL Console server. 

Index Alphabetical list of topics in this manual.
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Conventions
Typographical conventions highlight special words, phrases, and actions in this 
publication.

Item Example Description of Convention

Buttons MENU Font and capitalization follows label 
on product

Commands Mode Select Initial cap

Document titles System Assurance Guide Italic font

Emphasis not or must Italic font

File names fsc.txt Monospace font

Hypertext links Figure 2-1 on page 2-5 Blue (prints black in hardcopy 
publications)

Indicators Open Font and capitalization follows label 
on product

Jumper names TERMPWR All uppercase

Keyboard keys <Y> 
<Enter> or 
<Ctrl+Alt+Delete>

Font and capitalization follows label 
on product; enclosed within angle 
brackets

Menu names Configuration Menu Capitalization follows label on 
product

Parameters and variables Device = xx Italic font

Path names c:/mydirectory Monospace font

Port or connector names SER1 Font and capitalization follows label 
on product; otherwise, all uppercase

Positions for circuit breakers, 
jumpers, and switches

ON Font and capitalization follows label 
on product; otherwise, all uppercase

Screen text (including screen 
captures, screen messages, 
and user input)

downloading Monospace font

Switch names Power Font and capitalization follows label 
on product

URLs http://www.sun.com Blue (prints black in hardcopy 
publications)
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Related Documentation

SL3000 Modular Library Publications Part Number

Systems Assurance Guide 3161941xx

SNMP Guide for SL3000 Libraries 3161945xx

Tape Drive Documentation Part Number

Hewlett Packard Ultrium Tape Drive Manual CD included with drive 

IBM Ultrium Tape Drive Manual CD included with drive

T10000 Tape Drive Installation Manual 96173

T10000 Tape Drive Service Manual 96175

T10000 Virtual Operator’s Panel User’s Guide (for Service Representatives) 96180

T9840 Tape Drive User’s Reference Manual 95739

T9x40 Tape Drive Installation Manual 95879

T9x40 Tape Drive Service Reference Manual 95740

Tape Management Software Publications Part Number

Automated Cartridge System Library Software (ACSLS) 

ACSLS System Administrator’s Guide 3134648xx

ACSLS Messages 3134649xx

ACSLS Quick Reference 3134650xx

Host Software Component (HSC) MVS Publications

HSC Operator’s Guide 3125311xx

HSC Messages and Codes Guide 3125313xx

Publications Link

SunSolve or docs.sun.com
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Additional Information
Sun Microsystems, Inc. (Sun) offers several methods for you to obtain additional 
information. 

Sun’s external Web Site 
Sun’s external Web site provides marketing, product, event, corporate, and service 
information. The external Web site is accessible to anyone with a Web browser and an 
Internet connection.

The URL is: http://www.sun.com 

The URL for Sun StorageTek brand-specific information is: 

http://www.sun.com/storagetek 

SunSolve and Helpful Links
SunSolve and the Sun links below are Web sites that enable members to search from 
technical documentation, downloads, patches, features, articles, and the Sun Systems 
Handbook.

■ Library firmware and SL Console code downloads:

http://http://www.sun.com/download/index.jsp 

■ Drivers: http://www.sun.com/download/index.jsp 

■ Documentation (customer): http://docs.sun.com/app/docs 

■ General product information:

http://www.sun.com/storagetek/products.jsp 

■ SunSolve External site: http://sunsolve.sun.com 

■ Sun System Handbook (customer):

http://sunsolve.sun.com/handbook_pub/validateUser.do?target=
index 

■ Sun Learning Services—Training: http://www.sun.com/training 

Partners Site
TheSun StorageTek Partners site is for partners with a StorageTek Partner Agreement. 
This site provides information about products, services, customer support, upcoming 
events, training programs, and sales tools to support StorageTek Partners. Access to 
this site is restricted. On the Partners Login page, Sun employees nd current partners 
who do not have access can request a login ID and password, and prospective partners 
can apply to become StorageTek resellers. 

http://www.sun.com/partners 
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CHAPTER 1

SL3000 Introduction 

The SL3000 is the latest addition to the Sun StorageTek modular library family, which 
includes the SL500 and SL8500 modular library systems. 

FIGURE 1-1 SL3000 Modular Library System

This chapter introduces you to the SL3000 library and its components and 
configurations, including the following topics:

■ “SL3000 Features” on page 2

■ “Modular Design” on page 3

■ “Base Module” on page 7

■ “Drive Expansion Module” on page 10

■ “Cartridge Expansion Module” on page 13

■ “Parking Expansion Module” on page 14

■ “Tape Drives” on page 15

■ “Cartridge Access Ports” on page 17

■ “Robotics Units” on page 18

■ “Power Options” on page 20

■ “Cooling” on page 21

■ “Interfaces” on page 22

■ “Library Management Software” on page 26

■ “Operating Modes” on page 28
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SL3000 Features 
The SL3000 library offers customers the benefits of: 

■ Scalability in storage capacity from 200 to 5821 storage cells 

■ Performance from 1 to 56 tape drives 

■ Support of a variety of tape drives

■ Any cartridge, Any slot™ support of mixed-media 

■ Heterogeneous attachments using standard interfaces 

■ Multiple library management software options and programs 

The SL3000 was designed to: 

■ Address medium to large open systems and entry-level mainframe markets. 

■ Occupy a standard datacenter footprint with measurements of approximately: 

■ Height: 198 cm (78 in.), 

■ Depth: 124 cm (48.8 in.), 

■ Length: varies from 91.5 cm (36 in.) with one module, to 478 cm (188 in.) with six 
modules 
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Modular Design 
The SL3000 library provides a modular design, which allows customers to meet the 
demands of a rapidly growing and constantly changing environment. 

Modules 
There are four types of modules in an SL3000 library. The Base Module is the only one 
that is required. 

■ Base Module—one only 

■ Drive expansion module (DEM)—one only, attached directly to the left side of the 
Base Module 

■ Cartridge expansion module (CEM)—up to eight total, with up to four on the left 
side of the Base Module (and optional DEM) and up to four on the right

■ Parking expansion module (PEM)—installed always in pairs, one on each end of the 
library configuration 

The modules consist of walls, columns, and rows that house cartridge storage cells, 
tape drives, cartridge access ports (CAPs), and robotics units (TallBots). 

CenterLine Technology
The SL3000 modular design uses CenterLine technology to help balance the work load 
and improve the performance of the library. The left side of the Base Module serves as 
the centerline. You can add other modules to the left and right of the Base Module. 
Columns to the right of the centerline have positive (+) numbers, while columns to the 
left have negative (–) numbers. 

FIGURE 1-2 on page 4 shows the library centerline and some possible module 
configurations, including: 
■ Base module only 

■ Base module and drive expansion module (DEM) 

■ Addition of cartridge expansion modules (CEMs) and parking expansion modules 
(PEMs) s 
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FIGURE 1-2 Library Configurations Around CenterLine 

Base Module Configurations Base and Drive Expansion Module Configurations
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Any cartridge, Any slot™ Technology
Mixed-media storage cells are used to hold the cartridges. This allows the SL3000 
library to support the Sun StorageTek Any cartridge, Any slot technology and accept a 
variety of media types without reconfiguring the library. 

Cartridges lie flat and are placed in the storage cells with hub down and parallel to the 
floor. To prevent slippage, cartridges are held in place by internal retainer clips. 

Physical Capacities 
The SL3000 is scalable, with physical storage capacities from 200 to 5821 storage cells. 
In addition, the Capacity on Demand feature allows you to pay for only the capacity 
you actually use and expand capacity with minimal disruption to library operations. 

See Chapter 5, “Capacity on Demand” on page 151 for details about installing and 
managing library storage capacity. 

See TABLE 1-1 on page 6 for detailed physical capacities for each module type. To 
calculate the total accessible physical storage cells for a configuration, start with the 
standard configuration cell count, outlined with a heavy border, and then make the 
appropriate adjustments for options and positioning. Following are some examples:

■ Base Module with operator’s panel, a module installed on the right, and three total 
drive arrays: 

320 + 0 + 13 – 55 – 60 = 218 

■ DEM, a module installed on the left, window arrays, a CAP, and four drive arrays: 

410 + 88 + 23 – 77 – 66 – 72 – 78 = 228

■ CEM installed to the left of CenterLine, a module installed on the left, and a CAP:

516 + 104 – 78 = 542

■ PEMs (always installed in pairs), one with a CAP, one without:

308 + 312 – 78 = 542 

Optional Fire/Smoke Detection
Access ports in the ceilings of the modules are provided for optional fire suppression or 
smoke detection equipment. Installation and maintenance of this equipment must be 
arranged by the customer.
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TABLE 1-1 Accessible Physical Cell Count Per Module

Standalone 
or 

Position-
Independent

Adjacent Module
Installed on the:

Module Options Right Left
Total 
Count

Base Module

Standard (with viewing window), 
standalone

320

+13 +88

With operator’s panel +0

With window storage arrays +23

With second drive array -55 -66

With third drive array -60 -72

Drive Expansion Module (DEM)

Standard (with viewing window 
and no CAP)

— 410 +88

With window storage arrays — +23

With CAP — -77

With second drive array — -55 -66

With third drive array — -60 -72

With fourth drive array — -65 -78

Cartridge Expansion Module (CEM)

Standard (no CAP), to the left of 
CenterLine 

516 +0 +104

Standard (no CAP), to the right of 
CenterLine 

620 +0 +0

With CAP -78

Parking Expansion Module (PEM)

Standard (no CAP), to the left of 
CenterLine

— 308

Standard (no CAP), to the right of 
CenterLine

— 312

With CAP — -78

Total accessible storage cell count 
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Base Module 
The Base Module provides both cartridge storage and a minimum of eight tape drives. 
This module includes the power configurations, robotics, electronic modules, cartridge 
access port, cartridge storage cells, tape drives, and operator controls. It centralizes the 
infrastructure for all other modules in the library. 

One and only one Base Module is required for every library installation.

FIGURE 1-3 Base Module—Front View

Configurations Capacity 

8 drives 
16 drives 
24 drives 

8 drives, CAP 
16 drives, CAP 
24 drives, CAP 

See TABLE 1-1 
on page 6 

8 drives, CAP, and Operator panel/Window 
16 drives, CAP, and Operator panel/Window 
24 drives, CAP, and Operator panel/Window 

Dimensions Measurement 

Height 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width  76.76 cm (30.22 in.) without covers1

91.5 cm (36 in.) with covers 

Depth 121.9 cm (48 in.) without handles
124 cm (49 in.) with handles 

Weight 265 kg (584 lb) frame only 

Service clearance 

Both doors open 

Front: 46 cm (18 in.) 
Rear: 81 cm (32 in.) 
262 cm (103 inches) 

Side clearance2 Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.) 

Notes: 
1. When additional modules are installed, the covers are 

removed from the Base Module and replaced on the ends of 
the last module in the string. 

2. Required to install or remove the sides covers; they swing out 
and lift off of brackets. 
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The front of the Base Module includes the following components: 

■ Single, 26-cartridge, dual-magazine cartridge access port (CAP) 

■ Service door for library access 

■ Front panel with three LEDs: Library Active, Service Required, and Wait. 

■ Standard viewing window, which can be replaced by either of the following options:

■ Touch-screen operator panel 

■ Cartridge storage cells

The Base Module can hold up to 24 tape drives in any combination that the library 
supports—see “Tape Drives” on page 15 for a list and description. The minimum 
configuration includes one drive bay that can hold from one to eight drives. Two 
additional drive bays can be added to accommodate either 8 or 16 more drives, for a 
maximum of 24 drives. 

Note – Adding a drive bay displaces approximately 55 to 72 additional storage cells, 
depending on the library configuration. See TABLE 1-1 on page 6 for the exact number. 

See FIGURE 1-4 on page 9 for a rear view of the Base Module. The rear door allows 
access to the following:

■ Electronics control module (ECM) 

■ Power distribution units (PDUs) 

■ DC power supplies 

■ Tape drives 

■ Two one-unit rack spaces (1 unit = 44.5 mm [1.75 in.]) for vertically mounting 
auxiliary equipment, such as Ethernet switches 

Note – The Base Module does not contain any general-purpose 19-inch rack space. 

See FIGURE B-1, “Base Module Walls” on page 410 for a detailed diagram of the wall 
layout. 
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FIGURE 1-4 Base Module—Rear View Drawing 

Description 

Robotics DC power supplies 
■ DCPS 1 and 2 or 3 

First drive bay (top)
The first drive bay is standard.
Drive bays are added from the top, 
down.  
 
 

Second drive bay (center) 

 
 
 

Third drive bay (bottom) 

Electronics control module 

HBC and HBT cards 
MPU2 Fibre Channel card (not 
shown)
Two cPCI power supplies 
Two cooling fans 
Two power switches (N+1 and 2N)

AC power distribution units (up to 
two)

■ PDU 1 and PDU 2 

Drive DC power supplies (up to eight) 
■ DCPS 4 through 11 
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Drive Expansion Module 
The optional Drive Expansion Module (DEM) provides the library with additional tape 
drives and cartridge storage capacity. One DEM can be included in a library 
installation, always to the left of the Base Module. 

FIGURE 1-5 Drive Expansion Module—Front View

Configurations Capacity 

8 drives 
16 drives 
24 drives 
32 drives 

8 drives, CAP 
16 drives, CAP 
24 drives, CAP 
32 drives, CAP 

See TABLE 1-1 
on page 6 

8 drives, CAP, and Operator panel/Window 
16 drives, CAP, and Operator panel/Window 
24 drives, CAP, and Operator panel/Window 
32 drives, CAP, and Operator panel/Window 

Dimensions1 Measurement 

Height 197 cm (77.625 in.) to 
200 cm (78.63 in.)

Width 
DEM only
Base and DEM 

 
76.76 cm (30.22 in.) 
168.2 cm (66.22 in.) with covers 2

Depth 121.9 cm (48 in.) without handles
124 cm (49 in.) with handles 

Weight 265 kg (584 lb) frame only 

Service clearance 

Both doors open 

Front: 46 cm (18 in.) 
Rear: 81 cm (32 in.) 
262 cm (103 inches) 

Side clearance3 Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.) 

Notes: 
1. The dimensions of the DEM are the same as the Base module. 
2. When additional modules are installed, the covers are 

removed from the Base Module and replaced on the ends of 
the last module in the string. 

3. Required to install or remove the sides covers; they swing out 
and lift off of brackets. 
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The front of the DEM includes space for the following components: 

■ Service door for library access (standard) 

■ Front panel with three LEDs: Library Active, Service Required, and Wait 

■ Optional 26-cartridge, dual-magazine cartridge access port (CAP) 

■ Standard viewing window, which can be replaced by either of the following options:

■ Touch-screen operator panel, if not already in the Base Module 

■ Cartridge storage cells

The DEM comes standard with drive slots to support up to eight tape drives. DEM 
drive slots can optionally be increased, in increments of eight, to a maximum of 32. 

Note – Adding a drive bay displaces approximately 55 to 78 additional storage cells, 
depending on the library configuration. See TABLE 1-1 on page 6 for the exact number. 

There is an additional power system integral to the DEM to support the additional tape 
drives. 

See FIGURE 1-6 on page 12 for a rear view of the DEM. The rear door allows access to 
the following:

■ Tape drives 

■ Drive DC power supplies

■ AC power distribution units (PDUs)

See FIGURE B-2, “Drive Expansion Module Walls” on page 411 for a detailed diagram 
of the wall layout. 
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FIGURE 1-6 Drive Expansion Module—Rear View Drawing 

Description 

 
 
First drive bay (top) 
The first drive bay is standard. 

Drive bays are added from the 
top, down. 

Second drive bay 
 
 
 
 
 

Third drive bay 
 
 
 

Fourth drive bay 
 
 
 

AC Power distribution units (up 
to two) 

■ PDU 3 and PDU 4 

Drive DC power supplies (up to 
eight) 

■ DCPS 15 through 22 
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Cartridge Expansion Module 
The optional Cartridge Expansion Module (CEM) provides additional storage cell 
capacity and growth. No tape drives are in this module. A maximum of eight CEMs are 
supported in a single library.

The following considerations will maximize library efficiency: 

■ As a best practice, CEMs should be alternated on either side of the Base Module 
and optional DEM, with the initial CEM installed directly to the right of the Base 
Module. This decreases the amount of robotics travel and provides the best use 
of cartridge storage cells. 

■ If redundant TallBots are installed, the two outside CEMs are converted to parking 
extension modules (PEMs). This provides areas for theTallBots to get out of the way 
of one another. 

Each CEM adds up to 620 data cartridge physical storage cells. The capacity varies 
depending on the direction of growth (left or right) and the presence of a CAP. 

See FIGURE B-3, “Cartridge Expansion Module Walls” on page 412 for a detailed 
diagram of the wall layout. 

FIGURE 1-7 Cartridge Expansion Module with Base Module 

         Base Module     |               CEM

Configuration  
(next to Base with 24 drives) Capacity 

CEM (expanded left) 
CEM with optional CAP (left) See TABLE 1-1 

on page 6 
CEM (expanded right) 
CEM with optional CAP (right) 

Dimensions Measurement

Height 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width 76.75 cm (30.22 in.) without 
covers1

Cover adds 7.62 cm (3 in.) 

Depth 80 cm (31.5 in.) 

Weight 175 kg (385 lb) frame only

Side clearance2 Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.) 

Service clearance, 
front and rear 

None required 

Notes: 
1. When additional modules are installed, the covers 

are removed from the Base Module and replaced on 
the ends of the last module in the string. 

2. Required to install or remove the sides covers; they 
swing out and lift off of brackets. 



Parking Expansion Module

14 SL3000 User’s Guide • April 2008 Revision: A • 316194401

Parking Expansion Module 
The optional Parking Expansion Modules (PEMs) provide additional storage cell 
capacity and growth, as well as space for defective TallBots to be “parked” for service. 
The parking space makes the three outer-most columns of storage cells on the front and 
rear walls inaccessible. The inaccessible cells can be left out of the module, or they can 
be installed to allow later conversion of the PEM to a CEM. PEMs do not include tape 
drives. 

PEMs are only used with redundant TallBots, and they are always installed in pairs. 
They must be the last modules on the right and left sides of the library string. 

See FIGURE B-4, “Parking Expansion Module Walls” on page 413 for a detailed 
diagram of the wall layout. 

FIGURE 1-8 Parking Expansion Module 

Configuration Capacity 

PEM (expanded left) 308 cells
PEM (expanded right) 312 cells 
CAP –78 cells
Always installed in pairs for the redundant 
TallBot feature. 

620 

See TABLE 1-1 
on page 6 

Dimensions1 Measurement

Height: 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width: 76.75 cm (30.22 in.) without covers
77.5 cm (30.5 in.) with covers

Depth: 80 cm (31.5 in.) 

Weight: 103.4 kg (277 lb) frame only

Side cover2 
Side clearance3 Cooling: 5 cm (2 in.) 

Installation: 91 cm (36 in.) 

Service clearance 
front and rear 

None required

Notes: 
1. The dimensions of the PEM are the same as the cartridge 

expansion module. 
2. When additional modules are installed, the covers are 

removed from the Base Module and replaced on the ends of 
the last module in the string. 

3. Required to install or remove the sides covers; they swing out 
and lift off of brackets. 
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Tape Drives 
See TABLE 1-2 for the tape drives, data path interfaces, and media types supported 
by the SL3000 library. 

You can install up to 56 drives within one library, as follows:

■ Up to 24 in the Base Module

■ Up to 32 in a DEM 

The actual number of drives varies, depending on the AC power option and the 
media types. See TABLE 1-3 for details. 

TABLE 1-2 Supported Tape Drives 

Vendor Drive Type Interface Type Media

Sun 
StorageTek1

T9840C 
T9840D (encryption 
capable) 

Fibre Channel
FICON
ESCON

9840 
VolSafe capable

Sun StorageTek T10000A (encryption 
capable) 

2 Gb/4 Gb  
Fibre Channel 
FICON

T0000 Standard, Sport, 
and VolSafe 

HP LTO 3 
LTO 4 (encryption 
capable) 

Fibre Channel LTO 3
LTO 4 
WORM (LT) 
LTO 2 (read-only)4

IBM LTO 3 
LTO 4 

Fibre Channel LTO 3 
LTO 4 
WORM (LT) 
LTO 2 (read-only)2

Notes:
1. Sun StorageTek T9840 drives, models A & B, and T9940 drives, models A & B, are not 

supported.
2. LTO 2 media is supported for backward compatibility of LTO products (data migration).

TABLE 1-3 Power Options and Number of Drives

110–127 PDU 220–240 PDU

Base Module DEM Base Module DEM

T9840 12 14 24 32

T10000 13 16 24 32

LTO 3, 4 24 32 24 32

Mixed media varies any intermix
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Drive Trays 
In the SL3000, a single, universal drive tray accommodates all types of tape drives and 
interfaces. The SL3000 drive trays have two layers, as follows: 

■ The power supply and connections are on the top. 

■ The tape drive is under the power supply. 

Each drive tray slides into an eight-drive bay. 

Internal power supply cards and cabling are unique, depending on the drive type and 
interface within the drive tray. Cabling to the drive itself is out of the rear of the drive 
tray and library, then routed through the strain relief system. Both floor and ceiling 
cabling access is allowed. 

FIGURE 1-9 Drive Tray 

Measurements 

Height:  16.5 cm (6.5 in.)

Width:   16.5 cm (6.5 in.)

Depth:  45 cm (18.5 in.)
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Cartridge Access Ports 
The cartridge access port (CAP) is a vertically-mounted, rotating cylinder with two 
removable 13-slot magazines (26 cells total). CAPs are used to enter or eject 
cartridges from the library. 

The Base Module comes with one CAP as a standard feature. Optionally, one CAP can 
be installed in each expansion module, up to a maximum of ten CAPs for the library. 

Each CAP has its own set of controls, consisting of a small keypad and indicators. The 
CAP and its magazines rotate as a single unit. 

See “CAP Operations” on page 65 for details about using CAPs. 

FIGURE 1-10 Cartridge Access Port

1. Cartridge access ports 
2. Blank covers 

When a CAP is not installed, a blank cover is installed. This can always be upgraded in the future to include 
a CAP. 

3. Keypad and indicator user interface. 

1 2 1 2

3
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Robotics Units 
The robotics unit in an SL3000 library is called a TallBot. Each library can have either 
one (standard) or two (redundant) TallBots. 

TallBots are responsible for the movement and cataloging—or audit—of cartridges 
throughout the library. 

TallBot measurements are:

■ Width: 30 cm (11.84 in.)

■ Depth: 39 cm (15.36 in.)

■ Weight: 8.6 kg (19 lb)

FIGURE 1-11 TallBot 
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TallBots are driven along two rails on the rear wall of the library—one rail at the top 
and one attached to the floor. 

Two copper strips are inserted into the top rail to provide both power and signal paths 
for TallBot operation. 

■ Power comes from +48 VDC, 1200 Watt, load-sharing power supplies. 

■ Signals are received and transmitted between the TallBots and the library controller. 

■ A Rail Power Enable module is installed as a safety circuit for rail power.

Handling of the cartridges by the TallBots include: 

■ Retrieving cartridges from a CAP

■ Inserting cartridges into a CAP

■ Inserting and retrieving cartridges to and from storage cells 

■ Mounts and dismounts of cartridges to and from tape drives 

TallBots contain a laser bar code scanner that: 

■ Reads the configuration blocks in each module during library initialization. See 
FIGURE B-5 “Configuration Block” on page 414 for an example. 

■ Targets on cartridge storage/CAP cells and tape drives. Targets have the following 
shape, similar to the letter “N”: 

|\|

■ Identifies volume IDs (volids) of cartridges during: 

■ CAP entries

■ Audits

The TallBot reads cartridge volids during audits and CAP enters only. Each 
cartridge’s assigned location is stored in the library controller database, and the 
TallBot uses that location to retrieve the cartridge. 

Redundant (Dual) TallBots 
Redundant TallBots are offered as a high availability option. This affords:

■ A speed increase for library operations

■ A backup TallBot in case one should fail

This option requires PEMs at each end of the library. A defective TallBot will take itself 
offline and may move, or can be pushed, into one of the PEMs, allowing the library to 
continue operations with one TallBot until time can be scheduled to replace the 
defective TallBot. 

The requirements for redundant TallBot operation are:

■ A 240 VAC, 2N power configuration 

■ PEMs on each end of the library 

■ Dual TallBot license 
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Power Options 

AC Power Configurations 
The following AC power source options are available:

■ Limited features: 110 VAC, 50/60 Hz, at 20 Amps (range: 100–127 VAC, 50–60 Hz, 
16 Amps) 

■ Full features: 220 VAC, 50/60 Hz, at 30 Amps (range: 200–240 VAC, 50–60 Hz, 
24 Amps) 

Power Distribution Units (PDUs) are located at the rear of the Base Module and 
optional DEM. 

Power Redundancy
The SL3000 provides full redundancy for tape drives, robotics units, and electronics. 
The following redundancy options are available: 

■ N+1—One AC PDU, with one extra DC power supply for DC power redundancy. 
This is the standard power configuration for the SL3000. This configuration requires 
at least a 20 Amp circuit breaker at the customer’s branch service panel. 

■ 2N—Two PDUs for AC redundancy; each PDU has a set of DC power supplies 
(N DC power supplies). This configuration requires a second, separate customer 
power source. 

■ 2N+1—Two PDUs for AC redundancy; each PDU has extra DC power supplies for 
N+1 redundancy for each PDU. The second PDU does not have N+1 for the TallBot. 

DC Power  
Load sharing 1200 Watt DC power supplies are required for distribution of +48 VDC 
for TallBot and tape drive operation. The number of DC power supplies required 
depends on the power configuration and total number of drives in the library. 

A Rail Power Enable module is also installed as a safety circuit for rail power. Two 
cPCI power supplies (200 Watts each) distribute power to the Electronics Control 
Module. These power supplies are located below the HBT card—two on the left for 
N+1, or one on each side for 2N. 
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Cooling 
Cooling within the SL3000 is divided into three areas: 

■ Library electronics 

■ Tape drives 

■ DC power supplies 

Library Electronics 
There are two fans located to the right of the electronics control module that provide 
cooling for the electronics in the library. Air is drawn from the floor and sides of the 
library and flows through the fans to the rear of the library. 

■ These fans are monitored by the HBC card for proper operation. 

■ An amber Fault indicator is on the fan assembly to indicate a failure. 

While there are two dedicated fans, one fan is sufficient to provide adequate cooling for 
the library/electronics. Nevertheless, since the fans can be replaced without interfering 
with library operations, it is best to replace a defective fan when it is detected. 

Tape Drives
Each tape drive tray contains one or two fans for drive cooling. 

Power for the fans is supplied through the tape drives power converter card. Air is 
drawn from the front of the drive and flows through the fan to the rear of the 
drive/library. 

DC Power Supplies
Each 1200 Watt DC power supply contains a fan that pulls air from the front of the 
library, through the rear of the supply, and out the rear of the library. 
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Interfaces 
The SL3000 library supports the following types of interfaces: 
■ Library Control Path—Transfers library management commands, such as cartridge 

mounts and dismounts, between the host and the library components. No host data 
is present on this interface. 

■ Data Path—Transfers data between the host and the tape drives. 

■ Command Line Interface—Allows a Sun support representative to configure and 
diagnose the library.

■ SNMP—Allows system administrators to query the library and receive information 
about potential problems. 

■ SL Console—Allows library operators and administrators to configure and manage 
the library from a graphical user interface. 

Library Control Path 

Note – When a new library is integrated into a network, it is strongly recommended 
that the system/network administrator work closely with a Sun StorageTek 
representative to define the configuration. 

The control path provides for the transfer of library management commands between 
the host and the library. The SL3000 supports the following host connection types 
for the control path: 
■ TCP/IP Interface—TCP/IP protocol using Ethernet 10/100 Base-T and CAT-5 cables 

■ FC-SCSI Interface—Small Computer System Interface (SCSI) protocol and command 
set over a physical Fibre Channel interface 

A non-partitioned library can use only one interface type—either FC-SCSI or TCP/IP. 
Using the optional Partitioning feature, a library can connect to multiple hosts over a 
combination of the two interface types. See Chapter 6, “Library Partitioning” on page 
193 for details. 

Library addressing depends on the host connection type: 
■ TCP/IP hosts use a panel, row, column (PRC) numbering scheme. 
■ FC-SCSI hosts use a sequential element numbering scheme, with each element 

type (storage cells, tape drives, and CAPs) having its own sequential range. 

See Appendix A, “Library Resource Addresses” on page 391 for full details. 

TCP/IP Interface
The TCP/IP interface type uses the TCP/IP protocol over an Ethernet physical 
interface, (CAT-5, Ethernet, 10/100 BaseT cable). This interface enables either of the 
following host platforms to connect to and communicate with the library: 
■ Open system platforms with ACSLS (see “Automated Cartridge System Library 

Software (ACSLS)” on page 27 for details). 
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■ Enterprise-level mainframes with HSC (see “Host Software Component” on page 26 
for details). 

The library controller coordinates all component operations within the library and 
provides the interface connection with the host. 

Connections

There are two separate Ethernet connections on the library controller card for host-
to-library communications. 
■ Port 2A provides the Dual TCP/IP connection—this is an optional, licensed 

feature that provides built-in redundancy. 
■ Port 2B provides the primary host connection—this is the standard connection 

for SL3000 libraries.

Both ports comply with the Institute of Electrical and Electronics Engineers 
standard–IEEE 802.3–for Ethernet networks. Both ports are capable of auto-
negotiating the following functions: 
■ Method of transmission   

■ Half-duplex: Transmits data in just one direction at a time 

■ Full-duplex: Transmits data in two directions simultaneously 

■ Speed of the transmission 

■ 10Base-T: 10 megabits per second (Mbps)

■ 100Base-T: 100 megabits per second (Mbps)   

Network

Because the SL3000 is installed on a network, it is preferable that library activity be 
isolated from regular network traffic. Therefore, the following distinct networks are 
present: 

■ Public network—handling all customer-attached networking for the public system 
controller ports, such as:

■ Internet access 

■ Library-to-host commands 

■ Private network—handling all internal library networking for the private system 
controller ports, such as:

■ CAPs

■ Drive control path 

■ Local operator panel 

Note – A private network connection between the library and host management 
software, using an Ethernet hub or switch, is recommended for maximum throughput 
and minimum resource contention. 

If a shared network is required, these actions can help with the communication 
between the host and the library: 

■ Directly connect the library to a switch. 

■ Place the library on its own subnet. 
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■ Use a managed switch that can:

■ Set priorities on ports to give the host and library higher priority.

■ Provide dedicated bandwidth between the host and the library.

■ Create a VLAN between the host and the library. 

■ Use a virtual private network (VPN) to insulate host-to-library traffic. 

Sun StorageTek’s 9300 Control Path Adapter provides the hardware connection for 
mainframe hosts. This interface adapter is installed on the mainframe and converts data 
on the Ethernet network to compatible Host Library Interface (HLI) commands. 

FC-SCSI Interface
The FC-SCSI interface type uses the SCSI command set over a physical Fibre 
Channel connection. The Sun StorageTek implementation of Fibre Channel 
conforms to the following standards: 
■ American National Standards Institute (ANSI) 

■ National Committee for Information Technology Standards (NCITS) 

Applications supporting the SCSI-3 protocol are required for FC-SCSI hosts. 

The recommended Fibre Channel topology for the SL3000 is switched fabric. A 
switched fabric provides dynamic interconnections between nodes, and multiple, 
simultaneous Fibre Channel connections for the network.

If the SL3000 is connected to a Fibre Channel switch or fabric-capable host, it 
automatically configures itself as a switched topology and can support up to 16 million 
ports logged into the fabric. 

See the SL3000 Interface Reference Manual (PN 3161952xx) for complete information. 
This manual contains information about the SCSI command set, plus information 
about Fibre Channel operations, command implementations, topologies, cables, 
and connectors. 

Note – While the SL3000 supports the arbitrated loop topology, this topology is 
not recommended.

Note – The SL3000 does not support forcing arbitrated loop connection by setting Hard 
ALPAs (Arbitrated Loop Physical Addresses). 

Data Path
The data path, which is separate and distinct from the library control path supports the 
transfer of data between the host and the tape drive. Host data paths to the tape drives 
can be Fibre Channel, FICON, or ESCON, depending on the operational characteristics 
of the drive type. See “Tape Drives” on page 15 for details. 
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Command Line Interface 
The SL3000 command line interface (CLI) is a library interface for trained and 
qualified Sun support representatives only. This interface allows support 
representative to configure and diagnose problems with the library. 

Note – Customers do not have access to the CLI interface. 

SNMP
Simple Network Management Protocol (SNMP) allows system administrators and 
network managers to monitor and receive library status information, including the 
following: 

■ Operational state of the library (such as microcode level, serial number, 
online/offline status)

■ Status of the CAPs (such as open, closed, number of cells)

■ Library elements (number of TallBots, storage cells, CAPs) 

■ Number of storage cells and media types in the library 

■ Number and types of tape drives installed in the library

Note – By default, the SNMP agent is turned off and must be activated by your Sun 
support representative through the command line interface (CLI). 

The SL3000 supports the following SNMP versions: 

■ SNMPv2c—For machine status queries; the information transmitted is not secure.

■ SNMPv3—For Sun Confidential: Internal Use Only information, since it supports 
encryption and strong user identification. SNMPv3, therefore, is the preferred 
protocol for proprietary data.

Note – See the SL3000 SNMP Guide (PN 3161945xx) for detailed information 
concerning SNMP and the setup procedures.

SL Console
The StorageTek Library Console (SL Console) is a Java-based software application that 
provides a graphical user interface (GUI) for monitoring and managing the StorageTek 
SL3000 library. See Chapter 2, “StorageTek Library Console” on page 31 for complete 
details. 



Library Management Software

26 SL3000 User’s Guide • April 2008 Revision: A • 316194401

Library Management Software
Library management software components control the library to perform activities such 
as mounts and dismounts, enters and ejects. They also manage their own cartridge 
databases, containing volume location and attribute information. 

Sun offers several software components depending on the platform, connection type, 
and operating system. These include the following: 

■ ACSLS

■ HSC (MVS)—using a TCP/IP interface only

■ Direct-attach SCSI—using a Fibre Channel interface only

■ ExLM 

■ ExHPDM 

■ ExPR

■ VSM 

■ VTL 

Note – See the appropriate library management software documentation for the 
version levels required to support the SL3000. 

Note – LibraryStation is not supported for the SL3000. 

Nearline Control Solutions
The SL3000 supports the following Sun Nearline Control Solutions (NCS) software 
products.

■ Host Software Component

■ Storage Management Component

■ Sun StorageTek HTTP Server

Host Software Component 
When an SL3000 library is connected to an MVS host, the host must run a version of 
Sun StorageTek’s Host Software Component (HSC) along with the Storage 
Management Component (SMC).

Together, Sun StorageTek’s HSC and SMC perform the following functions:

■ Influence allocations

■ Intercept mount and dismount messages

■ Receive host requests and translate them into library control commands

HSC resides within the MVS host, but is invisible to the actual operating system.
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Storage Management Component
Storage Management Component (SMC) is the interface between IBM’s OS/390 and 
z/OS operating systems and a Sun StorageTek library. SMC performs the allocation 
processing, message handling, and SMS processing for the NCS solution. SMC resides 
on the MVS host system with HSC, or on a remote system using the Sun StorageTek 
HTTP server to communicate with the HSC. SMC communicates with HSC to 
determine policies, volume locations, and drive ownership.

Note – SMC is a required NCS component.

Sun StorageTek HTTP Server
Sun StorageTek’s HTTP Server for OS/390 and z/OS optionally provides the 
middleware to allow communication between the SMC (client) and a remote HSC 
subsystem (server). The HTTP server executes as a separate subsystem on the MVS host 
where the remote HSC subsystem resides. 

Automated Cartridge System Library Software 
(ACSLS)
The ACSLS software manages library contents and controls library hardware for the 
mounting and dismounting of cartridges. 

ACSLS provides library management services, such as cartridge tracking, pooling, 
reports, and library control. It maintains a database that tracks data volume names and 
their current locations in the libraries. 
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Operating Modes
Four modes of operation are possible for the SL3000:

■ Automated Mode 

■ Manual Mode

■ Maintenance Mode

■ Degraded Mode

Automated Mode 
When in automated mode of operation, the library automatically mounts and 
dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

■ Mounting and dismounting cartridges
■ Entering and ejecting cartridges through the CAP
■ Logging library events
■ Drive cleaning 

See Chapter 3, “SL3000 Automated Library Operations” on page 61 for complete 
details. 

Manual Mode
Manual mode of operation occurs when the library is unavailable for system use and 
human intervention is required. An example of this situation would be when a library 
experiences an unrecoverable error, making automated mounts and dismounts 
impossible.

Another example would be where a library component cannot perform a mount to a 
drive for a particularly important job request. In this case, the library may require a 
person to enter a library, locate the cartridge, and manually mount it into the requested 
drive. 

Warning – Possible Physical Injury.  Anyone entering the library must be 
advised of the safety procedures required of them. 

See Chapter 8, “Manual Operations” on page 377 for complete details. 

Maintenance Mode
In the case of a failure in a non-redundant library component (for example, a single 
TallBot for the entire library), the library is said to be “unavailable” to the system. In 
this case, the entire library must be placed offline until the repair is accomplished.
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After the defective component has been repaired or replaced, the library can be placed 
in maintenance mode while verification tests are performed. 

Degraded Mode
When in degraded mode, the library is still operational and online, but its operational 
efficiency is degraded due to a failing component. Examples of degraded mode are: 

■ In a redundant TallBot configuration, one TallBot has failed; the other TallBot has 
assumed all mount and dismount operations for the entire library.

■ A single tape drive has experienced a failure and must be replaced.
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CHAPTER 2

StorageTek Library Console 

Introduction 
The StorageTek Library Console (SL Console) is a Java-based software application that 
provides a graphical user interface (GUI) for monitoring and managing the StorageTek 
SL3000 library. 

Following are some of the activities you can perform with the SL Console:

■ Manage available library storage capacity

■ Manage and configure library partitions (optional feature)

■ View and modify status and properties of the library and associated devices (drives, 
CAP, robots, and elevators)

■ Perform an audit on all or part of the library

■ Perform a self-test on the library or an associated device

■ Perform a diagnostic move (exercise a robot)

■ Locate a cartridge

■ Move a cartridge from one location to another

■ Display library event logs

■ Display error explanations 

■ Download new library firmware while the library is in operation

■ Display context-sensitive help 

SL Console Modes
Depending on your needs, you can run the SL Console in any of the following modes. 
For details and procedures, see: 

■ “Local Operator Panel” on page 37 

■ “Standalone SL Console” on page 39

■ “Web-launched SL Console” on page 46 
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SL Console Security 
Security features built into the SL Console control both user authentication and user 
authorization. The security features include:

■ User IDs – User IDs control user authentication. Each user must have a valid, active 
user ID and password to log in to the SL Console.

■ Access permissions – Access permissions control user authorization. Each user ID is 
assigned a set of access permissions, which determine the types of requests the user 
can submit through the SL Console. For example, in order to modify the system 
properties of a drive, a user must log in with a user ID that has the proper access 
permissions.

When you log in to the SL Console with a valid user ID, password, and library name, 
the system authenticates your identity and then authorizes your access to the various 
SL Console functions. 

User IDs
To log in to the SL Console, you must have a valid, active user ID. Each user ID must be 
assigned a password.

There are a fixed set of user IDs at a site. The user IDs include admin (customer 
administrator), service (Sun Customer Services Engineer), and oem (third-party field 
service technician). When you log in successfully, the SL Console displays your user ID 
in the status bar of the screen.

Only one user at a time can be logged in to the local operator panel, but any number of 
users can connect to an SL3000 library through the standalone SL Console or Web-
launched SL Console. 

Activation Password 
Before any users at your site can use the SL Console for the first time, your SL3000 
administrator must activate the “admin” userid with a special activation password. 
Your Sun support representative provides your administrator with the activation 
password, which is valid for one-time use only. 

After logging in with the activation password, the administrator must change the 
admin user ID password to ensure system security. 

For details about this process, see the StorageTek SL3000 Installation Guide. 
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▼ Log in to the SL Console
Login procedures depend on the SL Console mode being used. For detailed 
instructions, see the following topics:

■ “Log in to the Local Operator Panel” on page 38

■ “Log in to the Standalone SL Console” on page 45

■ “Log in to the Web-launched SL Console Using a Browser or Command Line” on 
page 47

■ “Log in to the Web-launched SL Console Using an Icon” on page 53

Note – The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet available, 
in which case you need to exit and log in again at a later time. Additionally, if an audit 
is performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up-to-date and accurate. 

▼ Log Off the SL Console

Note – Before you log off, make sure all operations for the current SL Console session 
have completed (for example, code loads, audits, diagnostic moves). 

1. From any SL Console screen, select Tools > Log Off.

2. In the Confirm popup, do one of the following:

■ Click Cancel to remain logged in to the SL Console.

■ Click OK to terminate the current SL Console session. 

The Login screen appears. 

3. Click Exit to close the SL Console.

▼ Change a User Password 
1. Select Tools > User Mgmt.

2. On the User tree, expand the Permanent folder. 

3. Click the user account you want to modify. 

4. Complete the following fields: Current Password, New Password, and 
Retype Password. 

5. Click Modify.
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SL Console Screen Display 
The following figure and table explain the components of the SL Console screen. 

Component Name Description

1 Menu bar—includes the 
Tools Menu and the 
Help Menu 

Tools menu provides access to System Detail, Reports, 
Monitors, Utilities, Partitioning, User Management, and 
Log off functions. 
Help menu provides access to the table of contents of the help 
system. It also identifies the version of the SL Console in use.

2 Title bar Displays the title of the current screen. 

3 Function tabs Identifies the available functions for a screen. 

4 Options bar Location of buttons related to the screen (for example, Apply, 
Refresh, Print). Always includes the SL Console Help button 
(?). See “Synchronizing the Display With the Controller 
Database” on page 35 for details on using the Apply and 
Refresh buttons. 

1 2 43

5

78 6

9
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Synchronizing the Display With the Controller 
Database
When you first bring up an SL Console screen, the display reflects the most recently 
saved data from the library controller database. If you use the screen to modify the 
library contents or configuration, your changes do not update the controller database 
until you commit your changes by clicking the Apply button. Multiple users can access 
the library at the same time, using the SL Console, command line interface, and various 
host applications to make their own changes to the library contents and configuration. 
If other users make changes and apply them to the controller database, you will not see 
these changes until you click Apply or Refresh on your screen. Therefore, the display 
you see on the SL Console may not reflect the actual saved library configuration at a 
given point in time.

For these reasons, if you are making major modifications to the library 
configuration—adding modules, defining partitions, etc.—it is important that you 
coordinate these changes with other library users. Failure to do so could result in 
conflicts within the controller database. 

5 Work area Location of the screen data. 

6 Library health indicator Identifies the library to which the SL Console is connected, 
and displays a graphical representation of the library health. 

7 UserID indicator Displays the user ID currently logged in to the SL Console.

8 Server communication 
health indicator

Displays a graphical heartbeat monitor indicating the state of 
server communication health.

9 Device tree Lists the devices included in the library.

Component Name Description
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Modifying the Screen Layout 

Note – This feature is available starting with SL Console version FRS_3.30. It is 
available on selected screens only. 

You can modify the layout and display of selected SL Console screens as follows. 

TABLE 2-1 Screen Display Modifications

Display Option Instructions

Sort the display by any 
column

Click the heading of the column you want to sort by. Initially 
the sort will be in ascending order. Click the heading again to 
switch between ascending and descending order.

Arrange the columns in 
any order

Click and drag a column heading horizontally to any position 
in the heading row. 

Resize the columns Click the border of the column heading and drag it left or 
right to change the column width. 
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Local Operator Panel 
The local operator panel is an optional feature of the SL3000 which is built in to the 
Base Module. It enables you to run most of the SL Console application directly at the 
library from a flat-screen display with a touch-screen interface. 

The local operator panel has the following features:

■ 12.1-inch flat-panel display, resident within the Base Module of the library

■ Touch-screen interface, allowing alphanumeric data entry; pen and stylus available 

■ No keyboard or mouse option

LEDs located directly below the local operator panel provide the following status 
information:

■ LIB ACTIVE—Library processor is working. 

■ WAIT—Library firmware is loading. 

■ SVC REQ—Library is rebooting. 

▼ Enter Data Using the Keypad 
1. Click on the keyboard icon associated with the desired field.

A popup containing a graphical keyboard and display area appears. 

2. Click the graphical keys necessary to enter the desired data.

3. Click Enter to save your entry. 

The popup is closed and the data is displayed in the associated field.

▼ Modify Data Using the Keypad 
1. Use the navigational keys to position the cursor next to the characters to be modified.

The existing text remains on the display, but is changed to normal text.

2. Click the navigational, editing, and text keys to make the desired changes.

3. Click Enter to save the changes or Cancel to restore the original text to the field. 
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▼ Log in to the Local Operator Panel 

Note – Only one user at a time can log in to the local operator panel. 

Note – If the touch-screen panel is blank, touch the screen anywhere to activate the 
Login screen. 

1. Use the keypad to enter your login information (see “Enter Data Using the Keypad” 
on page 37 for detailed instructions). 

User ID: SLC_login  
Password: password 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

Note – The user ID you use determines the screens you can access. See “SL Console 
Security” on page 32. 

2. Click Log on. 
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Standalone SL Console 
The standalone SL Console is a standard feature of the SL3000 library. It enables you to 
run the SL Console application remotely from a PC or workstation that has a network 
connection to the SL3000 library. Using the standalone SL Console you can connect to 
any SL3000 library for which you have a valid user ID. 

Security Considerations
The SL Console application interfaces with the primary library interface (PLI) over a 
security software layer (SSL). The SSL provides a secure communication path between 
the library and the customer’s operator panel; this prevents an unauthorized network 
user from monitoring library activity.

Installation Requirements
You can install the standalone SL Console on a computer meeting the following 
requirements:  

The standalone SL Console software is available for download at the following Sun 
Microsystems, Inc. sites:

Note – You must have a valid login ID and password for the download site you are 
using. Contact your Sun support representative for assistance. 

Platform Solaris 9—SPARC
Solaris 10—SPARC
Windows 2003 Server—32 bit
Windows XP Client—32 bit
Windows Vista—32 bit

Other Ethernet connection to the SL3000 library

User Location Name URL

Sun Customers Sun Download Center http://www.sun.com/download/ind
ex.jsp

Sun Partners 
and OEMs

Sun Partner Exchange https://spe.sun.com/spx/control
/Login 
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Standalone SL Console Installation

Note – Your StorageTek CSE may have performed these procedures for you during 
library installation.

To install the standalone SL Console on your PC or workstation, you must use the 
following procedures:

1. “Download and Initiate the Standalone SL Console Installer from the Sun 
Downloade Site” on page 40. 

2. “Install the Standalone SL Console” on page 40. 

▼ Download and Initiate the Standalone SL Console Installer 
from the Sun Downloade Site
Use this procedure to download the standalone SL Console installer program and 
initiate it on your PC or workstation. 

Note – You must have a valid login ID and password for the download site you are 
using. Contact your Sun support representative for assistance. 

1. Start a Web browser on your PC or workstation. 

2. In the Address or Location Bar, enter the URL of the appropriate Sun download site. 
See“Installation Requirements” on page 39 for details. 

3. Log in to the Sun download site using your assigned login ID and password.

4. Navigate to the standalone SL Console installer file. 

5. Select the SL Console code level you want.

6. Select the appropriate installer file for your platform:

■ Microsoft Windows: SLConsoleWindowsSTK.exe 

■ Sun Solaris: SLConsoleSolarisSTK.bin 

7. Save the file to your PC or workstation. 

8. Double-click the SL Console installer file icon on your PC or workstation to start the 
installation. 

9. To complete the installation, see “Install the Standalone SL Console” on page 40. 

▼ Install the Standalone SL Console 
Use this procedure to install the standalone SL Console on your PC or workstation. 
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1. Start the installer program according to the instructions in “Download and Initiate the 
Standalone SL Console Installer from the Sun Downloade Site” on page 40. 

The License Agreement screen appears. 

2. Review the information, and click I accept. 

The Introduction screen appears.
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3. Review the information, and click Next. 

The Choose Install Folder screen appears. 

4. Enter the location where you want to install the file, and click Next.

The Choose Shortcut Folder screen appears. 

5. Enter the location where you want to create the shortcut icon, and click Next. 
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Note – On Solaris, the default location for shortcuts is the user’s home directory. 
However, shortcuts cannot be created in /, which is the root user’s home, so if you are 
installing on a Solaris platform as root you must choose something other than the 
default location. In this case, it is recommended that you choose /usr/bin or a similar 
location. 

The Pre-Installation Summary screen appears.

6. Review the information, and click Install. 

The installation begins, and the Installing SL Console screen appears. 



Standalone SL Console

44 SL3000 User’s Guide • April 2008 Revision: A • 316194401

7. When the installation finishes, the Install Complete screen appears. 

8. Review the information and click Done to exit the installation program. 
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▼ Log in to the Standalone SL Console 

Note – Using the standalone SL Console you can connect to any library for which you 
have a valid user ID. 

1. Start the SL Console application on your PC or workstation by doing either of the 
following:

■ Double-click the SL Console icon on the desktop.

■ Select Start > RunSLConsole or Launch > RunSLConsole 

The SL Console starts and the Login screen appears. 

2. Enter your login information.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

■ library_ID is the library to which you want to connect, expressed in either of the 
following ways:

■ IP address of the SL3000 library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the SL3000 library

Note – The user ID you use determines the screens you can access. See “SL Console 
Security” on page 32. 

3. Click Log on. 

Standalone SL Console Updates 

Note – Before you can install a new version of the standalone SL Console, you must 
uninstall the previous version. See your PC or workstation documentation for detailed 
instructions. Running multiple versions of the SL Console on the same PC or 
workstation can cause problems such as inconsistent data on reports. 

Once you have uninstalled the previous version of the SL Console, see “Standalone 
SL Console Installation” on page 40 for detailed instructions on upgrading the software. 
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Web-launched SL Console
The Web-launched SL Console is a standard feature of the SL3000 and is included on a 
CD shipped with each library. It enables the SL Console to be installed on a centralized 
Web server. Individual clients can then use a supported Web browser to download the 
Web-launched SL Console. Using the Web-launched SL Console you can connect to any 
SL3000 library for which you have a valid user ID.

The Web-launched SL Console is delivered to clients as a Java Web Start process, which 
executes outside the browser. 

Security Considerations
The Web-launched SL Console software is digitally signed, which guarantees that it has 
been issued by Sun Microsystems, Inc. and has not been altered or corrupted since it 
was created. As a Java Web Start process, the Web-launched SL Console includes the 
security features provided by the Java 2 platform.

The customer is responsible for implementing all appropriate additional security 
systems, including firewalls, user access, etc.

Client Requirements
You can download the Web-launched SL Console to clients meeting the following 
requirements:  

Web-launched SL Console Updates
Updates to the Web-launched SL Console only need to be installed on the centralized 
Web server. Once the updates are installed on the server, they are downloaded 
automatically to all clients whenever the application is started on the client. 

Platform Solaris 9—SPARC (Firefox 2.x)
Solaris 10—SPARC (Firefox 2.x)
Windows 2000—32 bit (IE 5, IE 5.5, Firefox 2.x)
Windows XP—32 bit (IE 6, IE 7, Firefox 2.x)
Windows Vista—32 bit (IE 7, Firefox 2.x)

Other ■ Java 1.5 Plug-in (the browser will install this 
automatically if it is not present already)

■ Ethernet connection to the SL3000 library
■ Ethernet connection to the Web-launched SL Console 

server 
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Starting the Web-launched SL Console on a Client
You can use either of the following methods to start and log in to the Web-launched 
SL Console on a client: 

■ From a command line (Solaris only) or supported browser. See “Log in to the Web-
launched SL Console Using a Browser or Command Line” on page 47. 

■ By double-clicking the slc.jnlp icon on your client. In order to use this method 
from a client, you must use the browser method at least once and save the 
slc.jnlp file locally. See “Log in to the Web-launched SL Console Using an Icon” 
on page 53. 

▼ Log in to the Web-launched SL Console Using a 
Browser or Command Line 

Note – Before you perform this activity, you must obtain the DNS alias or IP address 
of the SL Console server. Depending on how your Web-launched SL Console server has 
been set up, it may be accessible only by IP address. See your SL3000 administrator for 
assistance. 

Note – The command line option is available on Solaris platforms only. 

On Windows 2000, you may need to install a Java plugin for your Web browser before 
performing this procedure. You can download the plugin from the following location: 
http://java.sun.com/products/archive/j2se/5.0_04/index.html 

On Solaris platforms, it is easier to log in to the Web-launched SL Console using the 
command line. If you prefer to log in using a Web browser, however, you need to 
download a recent version of the Firefox Web browser from the following location:  
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0
.9/contrib/solaris_tarball/firefox-2.0.0.9.en-US.solaris8-sparc-
gtk1.tar.bz2 

1. Choose your login method:

■ Command line—available on Solaris only. Proceed to Step 2. 

■ Web browser—available on either Windows or Solaris. Proceed to Step 3. 

2. Open a terminal window, and type the following command:

javaws http://server_ID/opel/slc.jnlp 

where:

■ server_ID is either of the following:

■ IP address of the SL Console server (in nnn.nnn.nnn.nnn format)

■ DNS alias of the SL Console server

■ opel is the name (context root) of the Web-launched SL Console application on the 
server. 

Proceed to Step 4. 
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3. Start a supported Web browser on your client PC or workstation (see “Client 
Requirements” on page 46 for a list of supported browsers), and in the Location Bar 
or Address field, enter the URL of the SL Console Web Start application: 

http://server_ID/opel

where:

■ server_ID is either of the following:

■ IP address of the SL Console server (in nnn.nnn.nnn.nnn format)

■ DNS alias of the SL Console server

■ opel is the name (context root) of the Web-launched SL Console application on the 
server. 

Note – You can bookmark this URL for future logins. 

4. The SL Console Launch screen appears. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 
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5. The Opening slc.jnlp popup appears. 

Complete the popup as follows:

a. Specify the action you want to take with the slc.jnlp file:

■ Click the Open with Java(TM) Web Start Launcher radio button if you want to 
start the SL Console directly. 

■ Click the Save to Disk radio button if you want to save the slc.jnlp file to your 
client and log in to the SL Console later. See “Log in to the Web-launched 
SL Console Using an Icon” on page 53 for login instructions. 

b. Optionally click the “Do this automatically for files like this from now on” 
checkbox. If you make this selection, this popup will not appear during future 
logins. 

c. Click OK. 
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6. If this is the first time you are running the Web-launched SL Console, a security 
warning popup appears. 

Complete the popup as follows:

a. Verify that the Publisher is Sun Microsystems, Inc. 

b. Optionally click the “Always trust content from the publisher” checkbox. If you 
make this selection, this popup will not appear during future logins. 

c. Click Yes.



Web-launched SL Console

316194401 • Revision: A Chapter 2 StorageTek Library Console 51

7. If this is the first time you are running the Web-launched SL Console, the License 
Agreement popup appears. 

Scroll down to read the complete license agreement. Click, “I accept the terms of the 
License Agreement”, and then click OK.
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8. The SL Console Login screen appears. 

Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

■ library_ID is the library to which you want to connect, expressed in either of the 
following ways:

■ IP address of the SL3000 library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the SL3000 library 
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▼ Log in to the Web-launched SL Console Using an 
Icon

Note – In order to perform this activity, you must first save the Web-launched 
SL Console slc.jnlp file to your client. See “Log in to the Web-launched SL Console 
Using a Browser or Command Line” on page 47 for details. 

1. Double-click the slc.jnlp desktop icon on your client. 

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 

■ IP address of the SL3000 library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the SL3000 library 
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2. The SL Console Launch screen appears. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 

3. If this is the first time you are running the Web-launched SL Console, a security 
warning popup appears. 

Complete the popup as follows:

a. Verify that the Publisher is Sun Microsystems, Inc. 
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b. Optionally click the “Always trust content from the publisher” checkbox. If you 
make this selection, this popup will not appear during future logins. 

c. Click Yes.

4. If this is the first time you are running the Web-launched SL Console, the License 
Agreement popup appears. 

Scroll down to read the complete license agreement. Click, “I accept the terms of the 
License Agreement”, and then click OK.
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5. The SL Console Login screen appears. 

Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

■ library_ID is the library to which you want to connect, expressed in either of the 
following ways:

■ IP address of the SL3000 library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the SL3000    library 
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SL Console Reports 
The SL Console reports provide information on the library and its associated devices 
(for example, drives, robots, and CAPs), events, and tape cartridges. You can use the 
library reports to monitor library activity and identify potential problems. In addition 
to displaying the reports on-screen, you can save the report data to a file, which you 
can then print or include in e-mail. 

All report output is a static display of information sent from the library controller at the 
time the report is generated. The SL Console does not update the information 
dynamically unless you explicitly select the Update button on the Options bar.

Note – Running multiple instances of the standalone SL Console or Web-launched 
SL Console on the same PC or workstation can cause problems such as inconsistent 
data on reports. It is recommended that only one user at a time produce SL Console 
reports on a PC or workstation, unless all instances of the SL Console are the same 
version.

Report Types
The SL Console provides the following types of reports:

■ Log—detailed system event logs

■ Status Detail—details on the status of the library and associated devices, such as 
CAPs, drives, and robots

■ Status Summary—summary information on the status of the library and associated 
devices

■ Version—details about library hardware and software versions

▼ Generate a Report 
1. Select Tools > Reports.

2. On the report tree, expand the folder containing the report you want to generate 
(Log, Status Detail, Status Summary, or Version). 

3. Click the name of the report you want to generate.

4. The current report data is displayed. 

Report Options Bar
The Options bar on each report allows you to perform the following functions:

■ Search the report for a specified text string

■ Update the report with current data

■ Save the data to a file
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▼ Search the report for a specified text string
1. Click Search. 

2. In the Search Text box, enter the text string you want to search for. The entry is case-
sensitive. Wildcards are not supported. 

3. Click Search.

All occurrences of the string are highlighted. 

▼ Update the report with current data
1. Click Update. 

The screen display is refreshed with current data from the library controller. 

▼ Save the data to a file
1. Click Save. 

2. In the Save In pull-down menu, select a folder.

3. In the File Name box, enter the file name to which you want to save the data.

4. In the Files of Type pull-down menu, select the format in which you want to save the 
data (HTML, Text, or XML). 

5. Click Save.

Note – If the file exists already, the system prompts you to verify that you want to 
replace it.

Once saved, you can print the file or include it in e-mail. This may be useful for 
communicating about issues with your Sun service representative. 
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SL Console Help  
The SL Console Help displays information for SL3000 library operators, system 
programmers, system administrators, and service representatives. 

Note – The information relates specifically to the SL Console only. For information 
about library hardware, tape drives, or host software, see the appropriate product 
publication.

Following is a sample SL Console Help screen. 

▼ Access the SL Console Help 
You can display the SL Console Help from any SL Console screen. Use either of the 
following methods: 

■ To display context-sensitive help for the current SL Console screen, click the ? button 
in the Options bar. 

■ To display general help information, click Help > Contents in the Menu bar. 

Help Navigation
The left panel of the SL Console Help screen displays either of the following:

■ Table of contents (TOC)—An outline of topics and subtopics

■ Index—A list of terms and topics, in alphabetical order

The right panel displays the Help topic itself. 
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The top of the SL Console Help screen includes the following navigation buttons. 

Tips for Using the SL Console Help
■ You can minimize, maximize, or resize the Help screen to accommodate your needs.

■ You can resize the left and right panels of the Help screen by clicking the border 
between them and dragging it left or right. 

■ Most topics include a Related Topics button at the bottom of the page. Click on this 
button to display and navigate to help topics containing related information. 

Button Action

 Back Retraces your steps, going backward one topic at a time. 

 Forward Retraces your steps, going forward one topic at a time. 

 Print Displays the Print popup, which allows you to print one or 
more topics:
■ To print the current topic, click the Print button.
■ To print a different topic, click the topic title in the 

SL Console Help table of contents, and click the Print button.
■ To print more than one topic, highlight the topics in the 

SL Console Help table of contents by pressing Shift-Click or 
Ctrl-Click, and then click the Print button. 

 Print Setup Displays the Page Setup popup, which allows you to modify 
your print page layout.

 TOC Displays the SL Console Help table of contents. 

 Index Displays the SL Console Help index. 
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CHAPTER 3

SL3000 Automated Library 
Operations

Automated Mode of Operation
When in automated mode of operation, the library automatically mounts and 
dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

■ Mounting and dismounting cartridges

■ Entering and ejecting cartridges through the CAP

■ Logging library events

■ Drive cleaning 

Cartridge Mount and Dismount Activities
The primary function of the library is the automated mounting and dismounting of 
cartridges. Host mount and dismount commands are accepted by the library controller 
and translated into robotic commands that are performed by the TallBots. 

Mount Sequence
A simplified mount sequence involves the following steps:

1. A host requests that a specific volume serial number (VOLID) be mounted in a drive.

2. The library controller transmits to the host that the VOLID is located within the 
library and a drive is available to satisfy the mount request.

3. The library assumes responsibility for the mount.

4. The host command is translated by the library controller into motion commands for 
the TallBot.

5. The cartridge is taken from its slot and placed in the drive.

6. The library returns status to the host that the mount operation is completed.
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7. The drive performs the read/write activity directed by the host.

Dismount Sequence
A simplified dismount sequence involves the following steps:

1. A host requests that a specific VOLID be dismounted from a drive.

2. The library controller transmits to the host that the VOLID is located in the drive and 
the library is available to satisfy the dismount request.

3. The library assumes responsibility for the dismount.

4. The host command is translated by the library controller into mechanical commands 
for the TallBot.

5. The cartridge is taken from the drive and placed into its home slot.

6. The library returns status to the host that the dismount operation is completed.

Determining When the Library is Not in Automated 
Mode 
The library is not in automated mode when it is not able to accept host requests. The 
following conditions indicate that the library is not in automated mode:

■ A library access door is open. 

■ The TallBot does not automatically mount and dismount cartridges. 

■ The device tree in the SL Console indicates that there is a problem with the library.
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Library and Device Status
The SL Console screen displays health indicators for each of the following devices:

■ Library 

■ Drives

■ CAPs

■ Power supplies

■ Robots (TallBots) 

The following table describes the health monitor indicators. 

Indicator Description

1 Comm 
Status

Current status of the communication channel between the SL Console and 
the library controller. Possible icons are:

Normal communications. The heartbeat monitor flashes 
periodically when the SL Console is communicating normally 
with the library controller. 

A warning. This icon appears when the server response takes 
longer than 10 seconds.

21 3

4
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Communications Failures
If the SL Console loses communication with the library controller, after about 30–60 
seconds, the heartbeat monitor turns gray, then red, and the following error message 
appears:
Heartbeat message not received from the library controller.

You must log off from the SL Console and then log on again to restore communication.

Viewing Library Information
The System Details > Library menu provides options for viewing and modifying 
library information, such as library configuration and status and drive auto cleaning 
configuration. For complete details, see the following topics:

■ “Library Management Tasks” on page 76

■ “Drive Cleaning Tasks” on page 112

An error. This icon appears when the server response takes 
longer than 30 seconds. 

2 Userid Userid currently logged in to the SL Console. 

3 Library Library to which the SL Console is connected, and a graphical 
representation of the current health of the library and its devices. Possible 
icons are:

All library devices are functioning normally. 

A warning. One or more devices in the library is offline or 
operating in a degraded state. 

An error. One or more devices in the library has experienced a 
failure. 

4 Device 
health 
icon

Current status of the indicator device. When the library indicator shows a 
warning or error, use this indicator to determine which devices are 
experiencing abnormal conditions. 

Indicator Description
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CAP Operations
CAPs (cartridge access ports) allow a library operator to enter or eject cartridges to or 
from the library while the library is in automated mode. One CAP is always present in 
the base module. Optionally, the drive expansion module and cartridge expansion 
module can also each have one CAP. 

Each CAP contains two removable 13-slot magazines, allowing for a total of 26 
cartridges to be imported or exported at one time through each CAP.

Note – You can use the CAPs only when the library is in automated mode.

CAP Open Sequence
Opening a CAP involves the following steps:

1. A host issues a command to unlock the CAP. 

2. The CAP status is updated to “unlocked.”

3. The library operator presses the CAP button on the key pad.

4. The CAP status is updated to “open.”

5. The CAP motor is activated, and the CAP rotates outward to expose the magazines.

CAP Close Sequence
Closing a CAP involves the following steps:

1. The library operator presses the CAP button on the key pad. 

2. The CAP motor is activated, and the CAP rotates inward to close the CAP.

3. The CAP is status is updated to “closed” and “locked.”

4. The TallBot audits all CAP slots.

Auto Enter Mode
CAP auto enter mode allows a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request. When a CAP is in auto enter mode 
it is unlocked by default, and its LED is lit. The CAP is locked only when it is being 
used to enter or eject cartridges. 

To place a CAP in auto enter mode, you must enter the appropriate system command 
to unlock the CAP 
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To initiate an enter operation using an automatic CAP, you only need to press the CAP 
Open button on the key pad. To initiate an eject operation, however, you must enter an 
explicit eject request. 

Auto enter mode does not affect CAP operations for ejecting cartridges, so you must 
still issue an explicit eject command to eject cartridges through a CAP in auto enter 
mode.

Manual CAP Mode 
Manual mode is the most secure method of CAP operations. 

When in manual mode, a CAP is locked by default and its LED is not lit. To initiate an 
enter or eject operation using a manual CAP, you must enter an explicit enter or eject 
request before pressing the CAP Open button on the key pad. 

Using CAPS in a Partitioned Library

Note – This topic applies to partitioned libraries only. See “Configuring Library 
Partitions” on page 34 for details about defining library partitions. 

A CAP is a shared library resource—that is, it can be used by all partitions in the 
library. 

A CAP can be used by only one partition at a time. While a partition is using a CAP for 
enters or ejects, the CAP is reserved to that partition and unavailable to all others. 

In order for a partition to reserve a CAP, all of the following conditions must be met:

■ The CAP must be available—that is, not reserved by any other partition. 

■ The CAP must be empty.

■ The CAP must be closed and locked.

When a partition reserves a CAP, the library sends “CAP opened” and “CAP closed” 
messages only to the host holding the reservation. 

When a host attempts to reserve a CAP already reserved by another partition, the 
library sends a message to the requesting host identifying the partition ID and host ID 
holding the reservation. 



Cartridge Management

316194401 • Revision: A Chapter 3 SL3000 Automated Library Operations 67

Cartridge Management 
All library cartridges must have a readable external label. See Appendix C, “Cartridge 
Handling” on page 417 for details. 

Non-labeled cartridges are not supported and cannot be entered through the CAP. If 
you place a non-labeled cartridge in a CAP, the TallBot leaves it there and you must 
remove it from the CAP. 

If you place a non-labeled cartridge into a storage cell manually, the TallBot leaves it 
there during a hardware audit and does not attempt to place another cartridge into the 
slot. During a software audit, however, the TallBot places the cartridge in the CAP for 
ejection from the library. 

Entering Cartridges
You can enter up to 26 cartridges one time through each CAP.

Before entering a cartridge into the library, you must verify that it is labeled properly. 
Insert each cartridge in a CAP slot so that the customer label (if present) is facing you, 
the hub gear is facing down, and the VOLID label is facing you. Cartridges may be 
placed in any CAP slot, in any order; the TallBot audits all CAP slots when the CAP 
door is closed. 

Note – The CAP design prevents you from placing a T9x40 or T10000 cartridge in the 
CAP, upside-down. It does not, however, prevent you from placing an LTO cartridge in 
the CAP upside-down. 

The TallBot’s bar-code scanner reads cartridge VOLIDs only during enter operations, 
since the VOLIDs are new and must be added to the library controller database. The 
TallBot does not need to read cartridge VOLIDs during ejects. 

When a cartridge is entered into the library, it is assigned a home cell by the library 
controller or mounted on a drive, depending on the reason why it was entered. The 
location of a stored cartridge is recorded in the library controller database, using the 
library internal address format (see “Library Internal Address” on page 393). The 
location is also transmitted to the host for inclusion in the host’s cartridge database.

Ejecting Cartridges
You can eject up to 26 cartridges at one time through each CAP.

To eject a cartridge, you must specify the VOLID of the cartridge you want to remove 
from the library. The TallBot moves to the storage location indicated in the library 
controller database, removes the cartridge from the slot, and places the cartridge in a 
CAP slot. After the CAP is opened, the cartridge and its location are deleted from the 
library controller database and the host database. 
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Note – The TallBot does not read cartridge VOLIDs during eject operations. 

Locating Cartridges
The SL Console allows you to display the library internal address of any cartridge. You 
can locate a cartridge based on any of the following criteria:

■ VOLID

■ Library internal address

■ HLI-PRC address 

This utility is especially useful when you need to perform a manual mount of a 
cartridge. The library management software (for example, HSC or ACSLS) provides the 
VOLID and the HLI-PRC or FC-SCSI address of the cartridge and the drive bay address 
of an available drive. Before you enter the library, write down the VOLID, cartridge 
location, and the drive slot location. 

Recovery Moves 
Using the recovery move diagnostic function, you can move a cartridge from a source 
location (CAP, storage cell, or drive) to a destination (CAP or storage cell only). For 
example:

■ You can return a cartridge to its original location from a CAP cell, drive, or another 
storage cell location. 

■ You can eject a cleaning or diagnostic cartridge that has expired.

■ You can enter a new cleaning or diagnostic cartridge and move it to a reserved 
storage cell. 

Before moving any cartridge, it is helpful to generate a cartridge summary report which 
lists the contents of library storage cells. This report helps you determine which storage 
cells are available for use. 
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Drives
You can install up to 56 drives within one library, as follows:

■ Up to 24 in the Base Module

■ Up to 32 in a drive expansion module (DEM)

See “Tape Drives” on page 15 for a list of supported tape drives. 

Drive Identification
The library uses the following addressing schemes for each library drive:

■ Library internal address—For all drives. Assigned by the library controller based on 
the library, rail, column, side, and row location of the drive. 

■ HLI-PRC address (Host LMU Interface-Panel, Row, Column)—For TCP/IP host 
connections only. Assigned by host applications. 

■ Host SCSI element address—For FC-SCSI host connections only. Assigned by host 
applications. 

■ Drive bay address—For all drives. Assigned by the library controller based on the 
physical slot in which the drive is installed. 

■ dynamic World Wide Name—For Fibre Channel connections only. Assigned by the 
library controller, according to the slot into which the drive is installed. 

See Appendix A, “Library Resource Addresses” on page 391 for details on drive 
identification and addressing schemes. 

Drive States
A drive can be in either of the following states:

■ Online—The drive is available for read/write operations.

■ Offline—The drive is not available for read/write operations. 
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Drive Cleaning 
The library tape drives require periodic cleaning to prevent read and write errors. The 
library supports two methods of drive cleaning:

■ Automatic Cleaning 

■ Manual Cleaning 

Cleaning Cartridges

Note – You must use cleaning cartridges whose media types are compatible with the 
drive types in the library. 

Cleaning cartridges have a limited life span. Refer to your tape drive publications to 
determine the maximum usage count, or threshold, for each type of cleaning cartridge.

When you enter a cleaning cartridge into the library, the library controller considers the 
cartridge to be new and sets the usage count to zero. It is therefore important to enter 
only new cleaning cartridges into the library. 

Whenever a cleaning cartridge is used to clean a drive, its usage count is incremented. 
When a cleaning cartridge’s usage count exceeds its threshold, the cartridge must be 
replaced. 

You can use the SL Console to display the status of a cleaning cartridge at any time. 
The following statuses are possible:

■ OK—The cartridge is still within the threshold.

■ Warning—The cartridge has reached the threshold.

■ Expired—The cartridge has exceeded the threshold.

Ejecting Expired Cleaning Cartridges 
You must use care when ejecting expired cleaning cartridges from the library. If you 
move an expired cleaning cartridge to a CAP and open the CAP, you must remove the 
cartridge. If you close the CAP without removing the cleaning cartridge first, the 
TallBot will re-enter the expired cartridge into the library, and the library controller 
will reset the usage count to zero. 

Automatic Cleaning 

Note – The SL3000 manages automatic cleaning only for drives controlled by FC-SCSI 
hosts. HSC and ACSLS manage automatic cleaning for the drives they manage. See the 
HSC and ACSLS documentation for details about how they manage automatic drive 
cleaning. 
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The automatic cleaning function (or “auto clean”) is available for the SL3000. However, 
current firmware does not support the following functionality:

■ Automatic importing of cleaning cartridges through the CAP and placement of these 
tapes within the reserved cells dedicated for cleaning and disgnostic cartridges. 

■ Automatic exporting of expired cleaning cartridges through the CAP. 

The SL Console allows you to set up and monitor cleaning cartridges that are entered 
into the library. Alternately, you may prefer to monitor the cleaning function through 
your host software. In this case, the auto-clean function is ignored. 

When auto clean is enabled, the library controller automatically initiates a cleaning 
operation whenever a drive requires cleaning. The TallBot retrieves an appropriate 
cleaning cartridge (based on drive type) from the system slots, mounts the cartridge 
onto the drive, and returns the cartridge to its assigned slot after cleaning is complete.

Manual Cleaning 

Note – Manual drive cleaning is initiated through the library management software. 
Refer to the ACSLS or HSC documentation for command syntax.

If auto clean is disabled, you must initiate drive clean operations manually. To verify 
whether a drive needs cleaning, you can use the SL Console to display a drive’s 
cleaning status and the date when it was last cleaned. 

Even if auto clean is enabled, you may want to clean a drive before it is due. Therefore, 
you can initiate a manual clean at any time. 

To locate the correct type of cleaning cartridge for a particular drive, you can use the 
SL Console to generate a cartridge summary and drive details report. 
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TallBots 
The library TallBot moves cartridges throughout the library storage slots, tape drives, 
and CAPs. It also performs audits of the library. 

The TallBot is included with the Base Module and is accessible from the front of the 
rack. The three main components of the TallBot are:

■ X table assembly—Provides 180-degree lateral motion. 

■ Z drive assembly—Provides vertical motion. 

■ Hand assembly—Includes the following components:

■ Grippers to carry cartridges. 

■ Laser bar-code scanner to calibrate position and read cartridge labels. 

■ Proximity sensor to detect empty storage cells and unlabeled cartridges. 

See “Robot and Power Supply Monitoring Tasks” on page 122 for details about 
displaying and managing TallBot status and other information. 
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Power Supplies
The SL3000 provides full redundancy for tape drives, robotics units, and electronics. 
The following redundancy options are available: 

■ N+1 

■ 2N 

■ 2N+1 

The following power source options are available:

■ 120–127 VAC, single phase

■ 200–240 VAC, single phase

See “Power Options” on page 20 for additional details. 
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Host Interface Type
The SL3000 supports the following control path interface options: 

■ HLI (TCP/IP)—TCP/IP protocol using Ethernet 10/100 Base-T and CAT-5 cables 

■ FC-SCSI—SCSI-3 protocol and command set over a physical Fibre Channel interface

See “Library Control Path” on page 22 for details. 

Non-Partitioned Libraries
In non-partitioned libraries, all hosts must use the same interface type to connect to the 
library. 

You can display the interface type on the System Detail > Status > General screen. 

You can change the interface type through the Select Active Cells > Select Active Cells 
screen. 

Partitioned Libraries
In partitioned libraries, both the FC-SCSI and HLI host interface types can be used; 
each partition must use one or the other. When you create a new partition, you specify 
which interface type it uses. All hosts within a partition use the same interface type. 

For complete details, see “Host-Partition Connections” on page 195. 
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Automated Operation Tasks 
Library automated operation tasks are divided into the following categories:

■ “Library Management Tasks” on page 76

■ “CAP Management Tasks” on page 91

■ “Cartridge Management Tasks” on page 97

■ “Drive Management Tasks” on page 106

■ “Drive Cleaning Tasks” on page 112

■ “Robot and Power Supply Monitoring Tasks” on page 122
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Library Management Tasks

Task Page

Display Library Status 77

Display HLI Port Status 78

Display Library Configuration Information 79

Display Library Controller Properties 81

Display Drive Controller Properties 81

Change the Library Interface Type (Non-Partitioned Libraries) 82

Display a Library Report 84

Search a Library Report 86

Save Library Report Data to a File 89
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▼ Display Library Status 
View the current operational state of the library. These values are updated whenever 
there is host activity, background operations, or operator activity.

Note – This information is also available through Reports > Library Details. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Status tab, and then the General tab.

The screen displays the current status of the library. 
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▼ Display HLI Port Status 
Use this procedure to display the current status of all host LMU interface (HLI) ports 
on the library. Information includes the local TCP/IP socket, local IP, connection status, 
port status, transmission sent and received from the time of connection.

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Status tab, and then the HLI tab. 

The screen displays the current status and activity of all HLI ports on the library. 
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▼ Display Library Configuration Information 
Use this procedure to display the physical, mechanical, and logical configuration of the 
library. Some of the information can is set up automatically during library initialization, 
while other information can be defined by the user. 

Note – This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Properties tab, and then the General tab.

The screen displays detailed information about the library. 
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▼ Display Library Controller Properties 
View details of the library controller, including the serial number and firmware 
versions.

Note – This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Properties tab, and then the Library Controller tab.
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▼ Display Drive Controller Properties 
View details of the drive controller, including the serial number and firmware versions.

Note – This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Properties tab, and then the Drive Controller tab.



Library Management Tasks

82 SL3000 User’s Guide • April 2008 Revision: A • 316194401

▼ Change the Library Interface Type (Non-
Partitioned Libraries)
Use this procedure to change the interface type that all hosts use to connect to the 
library. 

Note – This procedure applies to non-partitioned libraries only. To change interface 
types in a partitioned library, see “Modify the Interface Type of a Host-Partition 
Connection” on page 230. 

1. Select Tools > Select Active Cells. 

The Module Map screen appears.

2. Click the Select Active Cells tab.

The Select Active Cells screen appears, displaying the interface type currently assigned 
to the library.
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3. In the Interface Type pull-down, select the interface type you want to assign. Click 
Apply. 

The Confirm Apply popup appears. 

4. Click Yes to update the library controller database. 

The Commit Success popup appears. 

5. Click OK to return to the Select Active Cells screen. 

The new interface type is active immediately; the library does not need to be rebooted. 
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▼ Display a Library Report 
Use this procedure to display library reports available from the Tools > Reports menu. 
Additionally, if you want to search the report data or save it to a file, see the following 
procedures:

■ “Search a Library Report” on page 86 

■ “Save Library Report Data to a File” on page 89

Additional reports are available from the following menus:

■ Tools > Partitions

■ Tools > Select Active Cells 

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.
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3. Click the report you want to display. 

The specified report is displayed. 
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▼ Search a Library Report 
Use this procedure to search a library report for a specified text string. This procedure 
can be performed on any of the library report screens.

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report is displayed. All report screens include the Search button on the 
Options Bar. 
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4. Click Search. 

The Search Text popup appears. 

5. Enter the text string you want to search for, and click Search. 

Note – The search is case-sensitive, and wildcards are not supported. 

6. The Search Results popup appears, displaying the number of occurrences of the text 
string. All instances of the text string in the report are highlighted. 
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7. Click OK to dismiss the popup. 
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▼ Save Library Report Data to a File
Use this procedure to display a library report and save the data to a text (.txt) file. 
This procedure can be performed from any of the library report screens.

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report is displayed. All report screens include the Save button on the 
Options Bar. 
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4. Click Save. 

The Save popup appears. 

5. Browse to the directory where you want to save the file. In the File Name field, you 
can accept the default entry or enter a different file name. 

6. Click Save. 

The data is saved to the specified file. 
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CAP Management Tasks

Task Page

Display CAP Summary Information 92

Display Current CAP Status 93

Display CAP Properties 94

Unlock and Open a CAP 95

Close and Lock a CAP 96
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▼ Display CAP Summary Information
Use this procedure to display summary information for all CAPs in the library. 

Note – This information is also available through Reports > CAP Summary. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Click the CAP folder on the device tree.

The screen lists the library CAPs and their locations.    
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▼ Display Current CAP Status 
Use this procedure to display the current operational state of a CAP. 

Note – This information is also available through Reports > CAP Details. See “Display 
a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to display. 

3. Click Status.

The screen displays the current status of the selected CAP. 
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▼ Display CAP Properties
Use this procedure to display static CAP information, including the serial number and 
number of cells. 

Note – This information is also available through Reports > CAP Details. See “Display 
a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to display. 

3. Click Properties. 

The CAP Properties screen appears. 
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▼ Unlock and Open a CAP 
1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

3. Click the Access tab. 

The Access screen appears.

4. In the Locked pull-down, click false. Click the Apply button. 

The Confirm popup appears. 

5. Click OK.

The CAP unlocks, and the CAP button light turns on.

6. On the library control panel,  push the CAP Open button on the CAP. 

The CAP rotates outward so you can add or remove cartridges. 
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▼ Close and Lock a CAP 
Normally when you close a CAP, it locks automatically. Use this procedure when you 
need to lock a CAP manually. 

1. Push the CAP Open button on the CAP. 

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

The CAP rotates inward. The TallBot audits the cells for cartridges. 

2. Select Tools > Diagnostics. 

3. Expand the CAP Folder, and click the CAP you want to modify. 

4. Click the Access tab. 

The Access screen appears.

5. In the Locked field, click true. Click the Apply button. 

The CAP locks, and the CAP button light turns off. 
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Cartridge Management Tasks

Task Page

Enter Cartridges Through a CAP 98

Eject Cartridges Through a CAP 99

List Library Cartridges 100

Locate a Cartridge by VOLID 101

Locate a Cartridge by Address 102

Move a Cartridge 104
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▼ Enter Cartridges Through a CAP
Use this procedure to enter cartridges into the library through a CAP. 

Note – This procedure applies to non-partitioned libraries. For partitioned libraries, 
see “Enter Cartridges Into a Partition” on page 247. 

1. Initiate the enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

Note – If the CAP is in auto enter mode, you can skip this step and proceed directly to 
Step 2. 

2. Push the CAP button to open the CAP. 

The CAP door opens. 

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

3. Place the cartridges in the CAP.

Insert the cartridges so that the customer label (if present) is facing up, the hub gear is 
facing down, and the VOLID label is facing you. 

You can enter the cartridges directly into the magazines while the magazines are in the 
CAP; or you can remove the magazines from the CAP, insert cartridges into the 
magazines, and then replace the cartridge-filled magazines into the CAP.

Note – Cartridges may be placed in any CAP slot, in any order; the TallBot audits all 
CAP slots when the CAP door closes.

Caution – Possible Media Damage. While cartridges that do not contain external labels 
or are placed upside-down can be entered, this is not advisable. It presents problems 
when an audit is performed. Likewise, cartridges that contain unreadable or damaged 
labels should not be entered. 

4. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

5. The TallBot audits the CAP and then moves the cartridges from the CAP to storage 
slots within the appropriate partition. 

When all cartridges have been moved from the CAP, the library recognizes that the 
CAP is empty and the CAP is returned to its default state. 
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▼ Eject Cartridges Through a CAP 
Use this procedure to eject cartridges from the library through a CAP. 

Note – This procedure applies to non-partitioned libraries. For partitioned libraries, 
see “Eject Cartridges From a Partition” on page 248. 

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

You must specify the volids of the cartridges you want to remove from the library.

2. The TallBot locates the cartridges and places them into one or more available CAPs.

3. Push the CAP button to open the CAP. 

The CAP door opens. 

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

4. Remove the cartridges from the CAP.

You can remove the cartridges directly from the magazines while the magazines are in 
the CAP; or you can take the magazines out of the CAP, remove the cartridges from the 
magazines, and then replace the empty magazines in the CAP.

5. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

If more cartridges need to be exported, the TallBot continues filling the necessary CAPs. 
Wait until the CAP door is unlocked and repeat Step 3 through Step 5. 

The eject operation ends automatically when all specified cartridges have been ejected. 

6. The TallBot audits the CAP to verify that it is empty.

The CAP is then returned to its default state. 
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▼ List Library Cartridges
Use this procedure to display information about all library cartridges, including their 
volids, locations, and media types. 

1. Select Tools > Reports. 

All library report options are listed in the navigation bar. 

2. Expand the Status Summary folder.

All Status Summary reports are listed. 

3. Click Cartridge Summary. 

The Cartridge Summary report is displayed. 

4. If you want to search the report data or save it to a file, see the following procedures:

■ “Search a Library Report” on page 86 

■ “Save Library Report Data to a File” on page 89
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▼ Locate a Cartridge by VOLID
Use this procedure to locate a cartridge based on its volume ID. 

1. Select Tools > Diagnostics.

2. Click the Library folder on the device tree.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click VOLID. 

5. Enter the VOLID, Requester, and Cartridge Type. 

Note – You can use wildcards in the VOLID field. 

6. Click Search. 

The screen displays all cartridges meeting the search criteria. 
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▼ Locate a Cartridge by Address
Use this procedure to locate a cartridge based on its location. The location can be in any 
of the following formats:

■ Library internal address

■ HLI-PRC address (HLI hosts only)

■ FC-SCSI address (SCSI-FC hosts only) 

1. Select Tools > Diagnostics.

2. Select the Library folder on the device tree.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click Location. 

5. In the Location pull-down, select the method you want to use for matching the 
location parameters.

6. In the Location field, enter the location parameters you want to search by. 

You must use a format that corresponds to the Requester, specified in the next step. For 
example:

■ Use the library internal address format if the Requester is “default”.

■ Use the HLI-PRC address if the Requester is an HLI host.

■ Use the FC-SCSI address if the Requester is an FC-SCSI host. 

Note – You cannot use wildcards in this field. 

7. In the Requester pull-down, select the host that is requesting the search. 
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8. Click the Search button. 

The screen displays all locations meeting the search criteria. 

9. To see details about a cartridge or to view a location mapping, click the ... button in 
the Details column. 

The Location Details screen appears. 

10.Click Close to dismiss the popup. 
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▼ Move a Cartridge
Use this procedure to move a cartridge from one location to another within the library. 

Note – This procedure updates the cartridge’s location in the library controller 
database, but not in the host database. Therefore after performing this procedure, you 
must perform an audit from the host software to update the host database. Failure to 
do so will cause future mount requests from the host software to fail. 

Caution – Use caution when performing this procedure in partitioned libraries. You 
could inadvertently move a cartridge from one partition to another, allowing the new 
partition to overwrite data on the cartridge. 

1. Select Tools > Diagnostics. 

2. Select the RcvrMove tab. 

3. Define the source location parameters by first selecting the Mode (Location or 
Volume ID).

To move a cartridge by the location address:

a. Select the Mode as location.

b. Select Type (CAP, Cell, or Drive) from the pull-down menu. 

c. Select the Module, Row, and Column address from the pull-down menus. 

To move the cartridge by volume ID:

a. Select the Mode as VOLID.

b. Type the volume ID of the cartridge to move. 

4. Select the destination location parameters:

a. Select Type (CAP or Storage Cell) from the pull-down menu. 

b. Select the Module, Row, and Column address from the pull-down menus. 

Caution – If the library is partitioned, make sure to keep the cartridge in the same 
partition it is currently allocated to. Moving a cartridge to a cell allocated to a different 
partition could result in a host treating the cartridge as scratch and overwriting the 
data. Moving the cartridge to an unallocated cell will result in the cartridge being 
inaccessible to all hosts. 

5. Click the Start tab from the top right corner of the screen.

Note – If the destination location is a drive, you can only move a cartridge from a CAP 
or a reserved slot. Also, a recovery move cannot be performed if the destination 
location is full.

6. Upon completion of the move, the system displays the Successful move dialog. Click 
OK.
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7. To update the new cartridge location in the host database, initiate a library audit 
from the host software. See the appropriate tape management software 
documentation for the procedures and commands.



Drive Management Tasks

106 SL3000 User’s Guide • April 2008 Revision: A • 316194401

Drive Management Tasks

Task Page

Display Drive Summary Information 107

Display Drive Status 108

Display Drive Properties 109

Display Drive VOP 110

Display Drive Tray Status 111
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▼ Display Drive Summary Information
Use this procedure to display summary information for all drives in the library. 

If you need to perform a manual mount to a drive, this procedure displays a mapping 
of all addresses for each library drive:

■ Hardware (drive bay)

■ Firmware (internal address)

■ Host software (HLI-PRC address)

Note – This information is also available through Reports > Drive Summary. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Click the Drive folder on the device tree.

The screen lists the library drives and displays their locations. The internal address, 
drive bay, and HLI-PRC address are detailed. 
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▼ Display Drive Status 
Use this procedure to display the current operational state of a drive. 

Note – This information is also available through Reports > Drive Details. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Status.

The screen displays the current status of the selected drive. 
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▼ Display Drive Properties 
View detailed drive configuration information, including the drive type and serial 
number and port configuration.

Note – This information is also available through Reports > Drive Details. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Properties. 
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▼ Display Drive VOP

Note – This procedure is for T10000 drives only. 

Use this procedure to display the Virtual Operator Panel (VOP) for T10000 drives. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Display.

The drive VOP screen appears. 
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▼ Display Drive Tray Status
Use this procedure to display the current status of a drive tray. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click DriveTray.

The Status screen appears. 
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Drive Cleaning Tasks

Note – The drive cleaning tasks apply only to drives managed by FC-SCSI attached 
hosts. They do not apply to drives managed by HSC or ACSLS. 

Task Page

Configure Drive Auto Clean 113

Enter Cleaning or Diagnostic Cartridges 115

Eject Cleaning or Diagnostic Cartridges 117

Display Cleaning Cartridges 119

Display Drive Cleaning Status 120

Clean a Drive Manually 121



Drive Cleaning Tasks

316194401 • Revision: A Chapter 3 SL3000 Automated Library Operations 113

▼ Configure Drive Auto Clean
Use this procedure to enable or disable the drive auto clean feature. If the library is 
partitioned, auto clean can be enabled or disabled for individual partitions. 

Note – This procedure applies only to drives that are not managed by HSC or ACSLS. 
See the HSC and ACSLS documentation for details about how they manage automatic 
cleaning operations. 

1. Select Tools > System Detail, and select the library folder on the device tree.

2. Click Auto Clean and then Configure.

The Configure Auto Clean screen appears. 

3. Complete the Auto Clean Configuration section as follows:

■ Non-partitioned libraries—Select “enable” in the Partition 1 (Or None) popup. You 
can leave all other partition popups as is. 

■ Partitioned libraries—Select “enable” for each partition you want to configure for 
auto-clean. Select “disable” for each partition you want to configure for manual 
drive cleaning. 

4. In the Auto Clean Configuration section, specify the warning thresholds for each 
cartridge type.
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5. Click Apply.
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▼ Enter Cleaning or Diagnostic Cartridges
Use this procedure to enter new cleaning or diagnostic cartridges to the library through 
a CAP. 

Note – This procedure applies to non-partitioned libraries only.  

Before beginning this procedure, verify that all the following conditions are met:

■ The required number of reserved cells are empty. 

■ The CAP Prevent/Allow state is set to Allow (see your SCSI Reference Manual for 
syntax).

■ The CAP does not contain any data cartridges. 

Note – If the CAP is in auto enter mode, you can proceed directly to Step 5. 

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, click the CAP you want to use, and click the Access tab. 

The Access screen appears.
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3. In the Locked pull-down, click false. Click the Apply button. 

The Confirm popup appears. 

4. Click OK.

The library controller unlocks the CAP door and the CAP Open LED is turned on.

5. Push the CAP button to open the CAP. 

The CAP door opens. 

6. Place the cleaning or diagnostic cartridges in the CAP.

7. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

8. Manually move each cartridge to a reserved cell. See “Move a Cartridge” on 
page 104for detailed instructions. 

When all cartridges have been moved from the CAP, the library recognizes that the 
CAP is empty and the CAP is returned to its default state. 

Note – To display a list of cleaning and diagnostic cartridges in the reserved slots, see 
“Display Cleaning Cartridges” on page 119. 
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▼ Eject Cleaning or Diagnostic Cartridges
Use this procedure to eject expired cleaning or diagnostic cartridges through the CAP.

Note – This procedure applies to non-partitioned libraries only.  

Note – Before beginning this procedure, verify that all slots are empty in the CAP you 
want to use.

1. Manually move each diagnostic or cleaning cartridge you want to eject, from a 
reserved cell to a CAP. See “Move a Cartridge” on page 104 for detailed instructions. 

Note – To display a list of cleaning and diagnostic cartridges in the reserved slots, see 
“Display Cleaning Cartridges” on page 119. 

2. Select Tools > Diagnostics. 

3. Expand the CAP Folder, click the CAP you want to use, and click the Access tab. 

The Access screen appears.
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4. In the Locked pull-down, click false. Click the Apply button. 

The Confirm popup appears. 

5. Click OK.

The library controller unlocks the CAP door and the CAP Open LED is turned on.

6. Push the CAP button to open the CAP. 

The CAP door opens. 

7. Remove all the cartridges from the CAP.

You must use care when ejecting expired cleaning cartridges from the library. If you 
move an expired cleaning cartridge to a CAP and open the CAP, you must remove the 
cartridge. If you close the CAP without removing the cleaning cartridge first, the 
TallBot will re-enter the expired cartridge into the library, and the library controller 
will reset the usage count to zero. 

8. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

9. The TallBot audits the CAP to verify that it is empty.

The CAP is then returned to its default state. 
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▼ Display Cleaning Cartridges
1. Select Tools > System Detail, and select the library folder on the device tree.

2. Click Auto Clean and then Cleaning Cartridges.

The list displays the following details for each cleaning cartridge:

■ Cartridge location (system slots)

■ VOLID 

■ Usage Count 

■ Status (OK, warning, expired)

■ Cartridge Type (for example, LTO, SDLT)
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▼ Display Drive Cleaning Status 
Use this procedure to display the current cleaning status of a drive. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and select the drive you want to display. 

3. Click Status.

The screen displays the following cleaning details:

■ Drive needs cleaning

■ Drive Last Cleaned or Drive Last Autocleaned

Note – You can schedule manual drive cleaning by monitoring the “Drive needs 
cleaning” status. 
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▼ Clean a Drive Manually
Use this procedure to clean a drive. The SL3000 does not offer a dedicated manual 
drive cleaning function. Essentially, you must perform a manual mount of a cleaning 
cartridge on the drive. 

You can initiate a manual clean at any time, even if the drive is not due for cleaning. 

1. Display a list of cleaning cartridges. See “Display Cleaning Cartridges” on page 119 
for detailed instructions. 

Your library could contain more than one type of drive. So verify that the reserved cells 
have the appropriate cleaning cartridges for the drive being cleaned. 

2. Manually move a cleaning cartridge from a reserved cell to the drive that needs 
cleaning. See “Move a Cartridge” on page 104 for detailed instructions. 

3. Display the status of the cleaning operation on the Drive Clean Status Console. See 
“Display Drive Cleaning Status” on page 120 for detailed instructions. 

4. When the cleaning operation is complete, move the cleaning cartridge from the drive 
back to a reserved cell. See “Move a Cartridge” on page 104 for detailed instructions.
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Robot and Power Supply Monitoring 
Tasks

Task Page

Display Robot Summary Information 123

Display Robot Status 124

Display Robot Properties 125

Display Power Supply Summary Information 126

Display Power Supply Detail 127
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▼ Display Robot Summary Information
Use this procedure to display summary information for all TallBots in the library. 

Note – This information is also available through Reports > Robot Summary. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Click the Robot folder on the device tree.

The Robot Data screen appears. 
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▼ Display Robot Status 
Use this procedure to display the current operational state of a TallBot. 

Note – This information is also available through Reports > Robot Details. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to display. 

3. Click Status.

The screen displays the current status of the selected TallBot. 
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▼ Display Robot Properties 
View detailed TallBot configuration information, including the serial number and 
current firmware levels.

Note – This information is also available through Reports > Robot Details. See 
“Display a Library Report” on page 84 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to display. 

3. Click Properties. 

The Robot Properties screen appears. 
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▼ Display Power Supply Summary Information
The Power Supply Data screen displays summary information for all power supplies in 
the library. You can use this screen to monitor the status of the power supplies. 

By default, the display is sorted by power supply internal address. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 36. 

1. Select Tools > System Detail.

2. On the Library tree, click the Power Supply Folder.

3. The Power Supply Data screen is displayed. 
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▼ Display Power Supply Detail
The Power Supply Status screen displays detailed information for a selected power 
supply. You can use this screen to determine whether the power supply is in need of 
maintenance or replacement. 

1. Select Tools > System Detail.

2. On the Library tree, expand the Power Supply Folder.

3. Click the power supply you want to display.

4. The Power Supply Status screen is displayed. 
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CHAPTER 4

Licensing

The licensing utility allows you to install selected optional features on the SL3000 
library. 

License Key File
A license key file can be delivered to you in the following ways:

■ Via e-mail from Sun Microsystems, Inc.

■ Installed by your Sun support representative

The license key file is a digitally signed Java Archive (.jar) file containing one or more 
license keys for features you have purchased. In order to ensure that features are 
installed on the correct library, the license key file includes the serial number of the 
target library and can only be installed on that library. 

All licensed SL3000 features you have purchased for a library are included in a single 
license key file. 

Caution – When you install a new license key file, it overlays any previously installed 
license on the library. Therefore, it is essential that you verify the contents of a new 
license key file before installing it, in order to ensure that it contains all features you 
have purchased over the life of the library. If it does not contain all the features you 
have purchased, when you install the new file you could potentially remove features 
that have previously been installed on the library. If a license key file is inaccurate in 
any way, you should request a new one from your Sun support representative. 
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License Expirations

Note – Most SL3000 licenses do not expire. The only license that expires is “Service.” 

For licenses that expire, it is important to manage the expirations in order to prevent 
unintended loss of library features and function.

You can use the License Management > Current License screen to display the 
expiration dates and time remaining. 

In addition, when a license is close to expiring, the library controller sends messages to 
the SL Console Event Log. You can use the Tools > Reports menu option to display the 
messages.  For example, if a Service license is due to expire within 30 days, an 
information message is sent every 12 hrs, and if the Service license has less than 10 days 
remaining, a warning message is sent every 12 hours. 
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Licensing Tasks 
This section provides detailed instructions for all tasks involved in installing and 
managing library feature licenses. 

License Installation Process
Following is a summary of the license installation process. Optionally, you can choose 
to have this process done by your Sun support representative. 

1. You purchase one or more features for a specific Sun StorageTek library from Sun 
Microsystems, Inc. 

2. Sun sends you an e-mail with an attached license key file. 

3. You download the license key file to a system accessible to the SL Console session.

4. You use the SL Console to display and verify the contents of the license key file. 

5. You use the SL Console to install the license key file on the target library. 

6. See the following topics for detailed information about implementing specific 
licensed features:

■ “Capacity on Demand” on page 151

■ “Library Partitioning” on page 193

Licensing Task Summary

Task Page

Receive a New License Key File 132

Display and Verify New License Contents 133

Install a New License on a Target Library 136

Display Current Library License 139
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▼ Receive a New License Key File
Use this procedure to receive a license key file, which licenses features for a specific 
Sun StorageTek library. 

Note – This procedure is not performed at the SL Console. 

1. Purchase one or more features from Sun Microsystems, Inc. 

See your Sun support representative for assistance. 

2. Receive the license key file from Sun, via e-mail. 

Following is a sample of the e-mail header: 
Subject:     SL3000 License Key CR6636975 
Date:     Wed, 05 Dec 2007 19:24:41 -0700 (MST) 
From:     siks-devoffshore@sun.com

3. Download the license key file to a system accessible to the SL Console session.

Use the standard method for saving E-mail attachments. 
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▼ Display and Verify New License Contents
Use this procedure to display a new license key file before installing it on a target 
library. 

Prior to performing this procedure, you must download a new license key file to a 
system accessible to the SL Console session. See “Receive a New License Key File” on 
page 132. 

1. Use the SL Console to log in to the target library. 

See “Log in to the SL Console” on page 33 for details. 

2. Select Tools > License Management, and click the Install License tab. 

The Install License screen appears.
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3. In the File Name field, enter the full path of the license key file you want to display, 
and press Enter. Optionally, you can click Browse and navigate to the file location. 

The License File details appear in the lower part of the screen. 

Note – If the library serial number in the specified license key file does not match the 
serial number of the library you are logged in to, a warning appears and the license key 
file detail is not displayed. 
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4. Review the license key file details, and then click Compare. 

The Compare Licenses popup appears. 

5. Review the license information.

Note – Changes that will be installed by the new license key file, such as expiration 
date changes or features that will be removed, are highlighted in red. 

If there are problems with the new file, contact your Sun support representative to 
resolve the problems before installing the file on the target library. 

Caution – There is no license “rollback” function to restore removed features once a 
new license key file is installed. 

6. Click OK to dismiss the popup. 
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▼ Install a New License on a Target Library
Use this procedure to install a new license key file on a target library. 

Prior to performing this procedure, you must download a new license key file to a 
system accessible to the SL Console session. See “Receive a New License Key File” on 
page 132. 

1. Use the SL Console to log in to the target library. 

See “Log in to the SL Console” on page 33 for details. 

2. Select Tools > License Management, and click the Install License tab. 

The Install License screen appears.

3. In the File Name field, enter the full path of the license key file you want to install, 
and press Enter. Optionally, you can click Browse and navigate to the file location.

The License File details appear in the lower part of the screen. 
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Note – If the library serial number in the specified license key file does not match the 
serial number of the library you are logged in to, a warning appears and the license key 
file detail is not displayed. 

4. Review the license key file details, and then click Install in the Options Bar. 

The License Installation Warning popup appears.

5. Review the Features to be Installed and verify that the new license key file is 
accurate. 

Note – Changes that will be installed by the new license key file, such as expiration 
date changes or features that will be removed, are highlighted in red. 

If there are problems with the new file, click No to cancel the installation. Contact your 
Sun support representative to resolve the problems before continuing with the 
installation. 

Caution – There is no license “rollback” function to restore removed features once a 
new license key file is installed. 

6. If the new license key file is accurate, click Yes to begin installing it on the target 
library. 

7. The library controller verifies the license key file and proceeds as follows:

■ If there are no problems, the features included in the file are installed. 
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■ If the new license key file is older than the one currently installed on the library, the 
following popup appears and the new license is not installed. 

8. Depending on the features included in the license key file, you may need to perform 
additional tasks in order to use the new features. 

■ See “Increasing Licensed Capacity” on page 154 and “Decreasing Licensed Capacity” 
on page 155 for special considerations that apply when you install a license key file 
that changes the licensed capacity of the library.

■ See “Installing the Partitioning Feature” on page 194 for special considerations that 
apply when you install a license key file with the Partitioning feature. 
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▼ Display Current Library License 
Use this procedure to display the features currently installed on the library you are 
logged in to. 

1. Select Tools > License Management, and click the Current License tab. 

The Current License screen appears, listing the currently installed features. 
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Licensing Screen Reference
This section includes detailed descriptions of all SL Console licensing screens, arranged 
by screen navigation path. For example, License Management—Install License— 
Compare indicates the screen accessed by clicking Tools and then License 
Management from the Menu Bar, and then clicking the Install License tab, and then 
the Compare button. 

Note – You can access the licensing screens only from the standalone SL Console or the 
Web-launched SL Console. They are not available on the local operator panel. 

Screen Page

License Management > Current License 141

License Management > Install License 143

License Management > Install License—Compare 146

License Management > Install License—Install 148
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License Management > Current License

Sample Screen

Description
Displays the contents of the license key file currently installed on the library you are 
logged in to. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Screen Fields
Feature 

Display only.

Name of the feature installed on the library. 

Expiration 

Display only.
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Number of days until the feature is due to expire or has expired. If there is no 
expiration date, the field displays “noExpiration.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity on Demand 
feature, this field displays the total capacity the license provides. Depending on the 
feature, the field may be blank. 

Time Remaining

Display only.

Amount of time remaining until the expiration of the feature. If there is no 
expiration date, the field is blank. 

Buttons
Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 

See Also
■ License Management > Install License 
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License Management > Install License

Sample Screen

Description
Allows you to display the contents of a new license key file. 

Also includes buttons that allow you to initiate any of the following activities:

■ Compare the new license key file with the one currently installed on the library. 

■ Install the new license key file on the library. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Screen Fields
File Name

Required.
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Enter the full path of the license key file you want to install on the library. 
Optionally, you can click Browse and navigate to the file location. The file must be 
located on a system accessible to the SL Console session, and the serial number 
specified in the file must match the serial number of the library you are logged in to. 

Product

Display only.

Type of library the license key file is for. For example, SL3000, SL8500, SL500. 

Serial Number

Display only.

Serial number of the library the license key file is for. This entry must match the 
serial number of the library you are logged in to in order for the license key file to be 
valid for this library. 

Generated On

Display only.

Date when the license key file was created. 

Comment Line 1

Display only.

Optional comment concerning the license key file, from Sun Microsystems, Inc. 

Comment Line 2

Display only.

Optional comment concerning the license key file, from Sun Microsystems, Inc. 

Feature

Display only.

Name of a feature included in the license key file.

Expiration

Display only.

Number of days until the feature is due to expire. If there is no expiration date, the 
field displays “noExpiration.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, this 
field displays the total amount of storage capacity the license provides. Depending 
on the feature, the field may be blank. 

Buttons
Install

Click to install the displayed license key file on the library you are logged in to. The 
License Management > Install License—Install popup appears. 

Browse

Click to navigate to the license key file you want to display and install.
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Note – If the library serial number in the specified license key file does not match the 
serial number of the library you are logged in to, a warning appears and the license key 
file detail is not displayed. 

Compare

Click to compare the new license key file with the one currently installed on the 
library. The License Management > Install License—Compare popup appears. 

? (Help) 

Click to display online help for the screen. 

See Also
■ License Management > Current License 

■ License Management > Install License—Compare 

■ License Management > Install License—Install 
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License Management > Install License—Compare 

Sample Screen

Description
Allows you to compare the following sets of license information: 

■ Features currently installed on the library you are logged in to. 

■ Features included in the new license key file you have specified in the License 
Management > Install License screen. 

Note – Changes that will be installed by the new license key file, such as expiration 
date changes or features that will be removed, are highlighted in red. 

This screen is a popup that appears when you click Compare on the License 
Management > Install License screen. 

Screen Fields
Current Features

Display only.

List of features, expiration dates, and values for all features currently installed on the 
library you are logged in to. 



Licensing Screen Reference

316194401 • Revision: A Chapter 4 Licensing 147

Features to be Installed

Display only.

List of features, expiration dates, and values for all features included in the specified 
new license key file. Changes that will be installed by the new license key file, such 
as expiration date changes or features that will be removed, are highlighted in red. 

Buttons
OK

Click to dismiss the popup and return to the previous screen. 

See Also
■ License Management > Install License 

■ License Management > Install License—Install 
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License Management > Install License—Install 

Sample Screen

Description
Allows you to compare the following sets of license information: 

■ Features currently installed on the library you are logged in to. 

■ Features included in the new license key file you have specified in the License 
Management > Install License screen. 

Warning messages are displayed if installation of the new license key file will result in 
features being removed from the library. 

After comparing the license information, you can install the new license key file on the 
library by clicking the Yes button. 

Caution – It is recommended that you carefully verify the accuracy of the new license 
key file before installing it, as there is no “rollback” function to restore removed 
features. 

This screen is a popup that appears when you click Install on the License 
Management > Install License screen. 
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Depending on the features included in the license key file, you may need to perform 
additional tasks in order to use the new features.

■ See “Increasing Licensed Capacity” on page 154 and “Decreasing Licensed Capacity” 
on page 155 for special considerations that apply when you install a license key file 
that changes the licensed capacity of the library.

■ See “Installing the Partitioning Feature” on page 194 for special considerations that 
apply when you install a license key file with the Partitioning feature. 

Screen Fields
Current Features

Display only.

List of features, expiration dates, and values for all features currently installed on the 
library you are logged in to. 

Features to be Installed

Display only.

List of features, expiration dates, and values for all features included in the specified 
new license key file. Warning messages are displayed if installation of the license 
key file will result in features being removed from the library. 

Buttons
Yes

Click to install the specified license key file on the library. The library controller 
verifies the validity of the license key file and installs it. 

No 

Click to cancel the update and return to the previous screen. 

See Also
■ License Management > Install License 

■ License Management > Install License—Compare 
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CHAPTER 5

Capacity on Demand

The SL3000 library includes RealTimeGrowth™ and Capacity on Demand features. 
RealTimeGrowth allows you to install physical storage capacity beyond your current 
needs. Capacity on Demand separates physical from licensed capacity and allows you 
to pay only for the capacity you need. Then as your needs grow, you can expand 
storage capacity with minimal disruption to library operations. To activate additional 
capacity, you need only purchase and install a license key file for the new capacity.

Note – Library storage capacity must be installed through the SL3000 licensing utility. 
See Chapter 4, “Licensing” for details. 

Note – This feature controls cartridge storage cells only. All installed CAPs and tape 
drives are active by default. 

Capacity on Demand Features and 
Restrictions
This section describes important features and restrictions of Capacity on Demand that 
will help you to plan for and use the feature in your SL3000 library. 

■ The minimum licensed capacity is 200 storage cells.

■ The maximum licensed capacity is equal to the physical capacity of the library, 
which is 5821 cells. 

■ You can purchase additional licensed capacity in increments of 1, 100, 200, 500, or 
1000 cells. 

■ Installation of additional licensed capacity results in minimal disruption to library 
operations. Once verified by the library controller, the additional storage cells are 
available immediately; you do not need to reboot the library. The library temporarily 
drops all host connections, but the hosts reconnect automatically. 

■ A library’s current licensed storage capacity is equal to the capacity specified in the 
most recently installed license key file. 
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Terminology
The following terms are used to describe library capacity management:

■ Physical or installed capacity—The number of storage cells physically present in the 
library.

■ Licensed capacity—The number of storage cells the library is licensed to use. This 
cannot exceed the installed capacity. 

■ Active capacity—The number of licensed storage cells that are activated for use. By 
default, this is the same as the licensed capacity. You can optionally de-activate 
selected storage cells, making this less than the licensed capacity. 

■ Active storage region—A rectangular area of storage cells that are activated for use. 
An active storage region can be as small as a single storage cell or as large as the 
total licensed capacity for the library. 

■ Active cell—A storage cell that is activated for use. Only activated cells can be used 
for cartridge storage.

■ Inactive cell—A storage cell that is explicitly de-activated and therefore cannot be 
used for cartridge storage. 

■ Selected cell—A storage cell that is not currently active, but will be activated 
automatically by the library controller when licensed capacity is increased. 

Active Storage Region Configuration
Active storage regions can be assigned automatically by the library controller or 
manually by the user. Automatic assignment by the controller provides balanced 
growth of library modules.

Individual storage cells can be in either of the following states:

■ Active—The cell can be used for cartridge storage. 

■ Inactive—The cell has been de-activated, and therefore cannot be used for cartridge 
storage. You can monitor the cell on library displays and reports, but requests to 
move cartridges to the cell are rejected by the library controller. 

■ Selected—The cell is not currently active, but will be activated automatically by the 
library controller when licensed capacity is increased. This state applies to non-
partitioned libraries only. 

Only active storage cells can be used for tape cartridge storage. Inactive storage cells 
cannot be used for cartridge storage, nor can they be accessed by any hosts. 
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Cell Activation Rules
The library controller uses the following rules when adding cells to active storage 
regions:

■ Cell activation starts in the left upper rear of the active storage region and moves to 
the right lower front. 

■ All cells within a column are activated from top to bottom before moving to the next 
column. 

■ Columns within a panel are activated from left to right. 

Non-Partitioned Libraries
Within a non-partitioned library, the library controller automatically selects all physical 
cells, but only activates a number of cells up to the total licensed capacity of the library. 
Selected cells that cannot be activated due to licensed capacity limits remain selected 
and will be activated automatically whenever additional licensed capacity is installed.

When activating cells, the library controller begins at the back of the library, starting 
with the left-most module and working to the right. Then it moves to the front of the 
library, starting with the left-most module and working to the right. 

To optimize cartridge placement, you can optionally designate active storage regions in 
the library, within which the library controller applies the rules above. 

Partitioned Libraries
In partitioned libraries, the total number of storage cells allocated to all library 
partitions cannot exceed the licensed capacity of the library.

In partitioned libraries, there is no default active storage region. You must explicitly 
assign storage cells to partitions, thereby configuring the active storage regions for each 
partition. See “Partitioning Process” on page 206 for details. 

When placing cartridges in storage cells, the library controller applies the predefined 
cell activation rules separately to each partition. See “Cell Activation Rules” on 
page 153 for details. 

De-activating Storage Capacity 
You can optionally reduce the size of an active storage region by de-activating 
designated storage cells. A warning message is displayed if cartridges will be orphaned 
due to the capacity reduction.
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Orphaned Cartridges in Non-Partitioned Libraries

Note – For a discussion of orphaned cartridges in partitioned libraries, see “Orphaned 
Cartridges in Partitioned Libraries” on page 204. 

In non-partitioned libraries, an orphaned cartridge is a cartridge located in an inactive 
storage cells. Orphaned cartridges are inaccessible to all hosts. 

A cartridge can become orphaned for a variety of reasons. Following are some possible 
causes:

■ Active storage capacity has been reduced.

■ The cartridge has been moved to an inactive or inaccessible cell through manual 
intervention. 

If the SL Console identifies an orphaned cartridge, it displays a warning message. You 
can then use the following tools to help you resolve and disposition the orphaned 
cartridge:

■ Generate a report of orphaned cartridges. 

■ Perform an audit of the library. 

■ Perform a recovery move on a cartridge. 

For detailed instructions on checking for and resolving orphaned cartridges, see the 
following procedures:

■ “Display an Active Storage Region Report” on page 166

■ “Commit Active Storage Region Changes” on page 163

Increasing Licensed Capacity
The following special considerations apply after you successfully install a capacity 
license providing additional capacity. See Chapter 4, “Licensing” on page 129 for 
details on installing license key files. 

■ The new library capacity is equal to the capacity specified in the most recently 
installed license key file. 

■ You do not need to reboot the library in order to begin using the new capacity, but 
you must configure all affected library host applications to recognize the new 
capacity. See “Host Notification of Capacity Changes” on page 155 for details. 

■ If the new licensed capacity exceeds the physical capacity, a warning is displayed. 
No corrective action is necessary. 

■ If the library is not partitioned, the library controller automatically activates cells 
that have not been explicitly de-activated by the user previously. In this case, no user 
intervention is required to make the new licensed capacity available. If cells have 
been de-activated, however, you may need to manually select cells in order to start 
using the additional capacity. 

■ If the library is partitioned, all new capacity is added as unallocated cells. You must 
allocate new storage cells to partitions manually in order to start using the cells; see 
“Design a Partition” on page 215 for details. 
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Decreasing Licensed Capacity
The following special considerations apply after you successfully install a capacity 
license resulting in reduced capacity. See Chapter 4, “Licensing” on page 129 for details 
on installing license key files.

Note – Installing reduced capacity is an exceptional situation; be sure this is what you 
really want to do before installing the license key file. 

■ A warning appears if cartridges are orphaned as a result of the reduced capacity. 

■ For non-partitioned libraries:

■ The new, reduced capacity takes effect immediately. 

■ The library controller de-activates cells in reverse order of their activation—the 
cells activated most recently are de-activated first. 

■ For partitioned libraries:

■ If the total number of cells allocated to all partitions exceeds the new licensed 
capacity, the library is automatically taken offline. You must manually de-allocate 
cells from partitions so the total allocation does not exceed the new licensed 
capacity.

■ If the total number of cells allocated to all partitions is still less than the new 
licensed capacity, the new reduced capacity takes effect immediately with no 
change to the partition allocations. The library continues operations without 
interruption. 

Host Notification of Capacity Changes 
When storage capacity is added or removed, the library controller notifies all affected 
hosts according to their interface requirements: 

■ FC-SCSI hosts are notified by a LUN reset request. The host must re-audit the library 
to determine the specific configuration changes.

■ HLI hosts are notified through an asynchronous message. The host can then request 
the new configuration from the library controller.

See the appropriate tape management software documentation for detailed procedures 
and commands.

Caution – For the following reasons, it is recommended that you make the library 
unavailable to other users before applying your active storage region changes.  
 
There is no real-time validation of storage region boundaries against the library 
controller database; therefore if you do not make the library unavailable and other 
users are performing cartridge movements or library configuration changes, 
configuration conflicts may arise. See “Synchronizing the Display With the Controller 
Database” on page 35 for details.  
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The library temporarily drops all connections to HSC or ACSLS hosts when active 
storage regions changes are applied. The hosts will automatically reconnect, but 
multiple error messages will be displayed, and cartridge management tasks in progress 
may fail. 
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Capacity Management Tasks 
This section provides detailed instructions for all tasks involved in implementing and 
managing active storage capacity in the library. 

Storage Capacity Installation Process
Following is a summary of the process used to install new library storage capacity. 

1. You purchase and install a capacity license for the library. See “License Installation 
Process” on page 131 for details. 

2. The new licensed capacity is available immediately. You do not need to re-boot the 
library. 

3. In non-partitioned libraries, by default, all newly activated cells are immediately 
available for use. Proceed as follows:

■ If you want to use the default storage region configuration assigned by the library 
controller, you must configure all affected library host applications to recognize 
the new storage regions. See “Host Notification of Capacity Changes” on page 155 
for details. 

■ If you want to modify the storage region configuration from the default, see 
“Define Active Storage Regions” on page 160. 

4. In partitioned libraries, all newly activated cells are added as “unallocated,” and are 
therefore not available for use. You must manually allocate the new cells to 
partitions. See “Partitioning Process” on page 206 for detailed instructions. 

SL Console Active Storage Region Workspace
The Select Active Cells screens, and all associated popups, give you a dynamic 
workspace to customize your licensed capacity configuration. All licensed capacity 
configuration information is automatically saved to the active storage region workspace 
in SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among active storage region views and leave and return to the 
Select Active Cells screens any number of times without losing your configuration 
changes.

Information in the SL Console active storage region workspace is committed to the 
library controller database only through the Apply button on the 
Select Active Cells > Select Active Cells screen. The information is lost if any one of the 
following occurs before you have committed your updates: 

■ You actively log off the SL Console session.

■ The SL Console session times out or the connection to the library is lost. 

■ You actively refresh the active storage region workspace from the current library 
controller database. This is done through the Refresh button on the 
Select Active Cells screens. 
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Caution – For the following reasons, it is recommended that you make the library 
unavailable to other users before applying your active storage region changes.  
 
There is no real-time validation of storage region boundaries against the library 
controller database; therefore if you do not make the library unavailable and other 
users are performing cartridge movements or library configuration changes, 
configuration conflicts may arise. See “Synchronizing the Display With the Controller 
Database” on page 35 for details.  
 
The library temporarily drops all connections to HSC or ACSLS hosts when active 
storage regions changes are applied. The hosts will automatically reconnect, but 
multiple error messages will be displayed, and cartridge management tasks in progress 
may fail. 
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Capacity Management Tasks

Note – The following tasks apply to non-partitioned libraries only. For detailed 
instructions on configuring storage regions for partitioned libraries, see “Partitioning 
Process” on page 206. 

Task Page

Define Active Storage Regions 160

Commit Active Storage Region Changes 163

Display an Active Storage Region Report 166

Print Active Storage Region Report Data 168

Save Active Storage Region Report Data 169
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▼ Define Active Storage Regions 

Note – See “License Installation Process” on page 131 for information about installing 
licensed capacity. 

When you install additional licensed capacity, the library controller automatically 
activates the number of storage cells equal to the licensed capacity. It uses a set of 
internal rules when choosing the actual cells to activate. See “Active Storage Region 
Configuration” on page 152 for details. 

Use this procedure only if you want to do one of the following:

■ Customize the active storage regions so they are different from the default 
configuration assigned by the library controller. For example, you can configure 
active storage cells so that cartridges are concentrated around the drives and the 
ends of the library are left for future growth. 

■ De-activate storage cells, so the total number of active storage cells is less than the 
licensed capacity. 

■ De-select storage cells, so these cells will not be automatically activated when the 
library’s licensed capacity is increased. 

Note – If you want to use the default storage region configuration defined by the 
library controller, you do not need to use this procedure. 
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1. Select Tools > Select Active Cells. 

The Module Map screen appears.

2. Click the module for which you want to define the active storage regions. 

3. Click the Select Active Cells tab.

The Select Active Cells screen appears, displaying the current configuration of the 
module you have selected.
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Note – The first time you display this screen, the number of selected cells is equal to 
the physical capacity of the library, and the number of active cells is equal to the 
library’s total licensed capacity. 

Note – Click the Move Left or Move Right buttons to display a module directly 
adjacent to the one currently displayed. 

4. Choose the Select by method, and click either the Add or Remove radio button.

5. Use the library map to select the storage cells you want to activate or de-activate. 

Note – See “Select Active Cells > Select Active Cells” on page 173 for detailed 
instructions on using the library map. 

Your capacity configuration changes are saved to the SL Console active storage region 
workspace for the duration of this login session. You can make additional 
modifications and leave and return to the Select Active Cells screens any number of 
times without losing your changes.

6. When you are done making changes, proceed to “Commit Active Storage Region 
Changes” on page 163 to verify and commit your changes. 
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▼ Commit Active Storage Region Changes 
Use this procedure to verify and commit active storage region configuration changes 
you have made on the Select Active Cells screen. This procedure warns you of the 
following possible errors:

■ The library has orphaned cartridges. See “Orphaned Cartridges in Non-Partitioned 
Libraries” on page 154 for details.

■ Cells will be made inaccessible to library hosts. 

Caution – For the following reasons, it is recommended that you make the library 
unavailable to other users before applying your active storage region changes.  
 
There is no real-time validation of storage region boundaries against the library 
controller database; therefore if you do not make the library unavailable and other 
users are performing cartridge movements or library configuration changes, 
configuration conflicts may arise. See “Synchronizing the Display With the Controller 
Database” on page 35 for details.  
 
The library temporarily drops all connections to HSC or ACSLS hosts when active 
storage regions changes are applied. The hosts will automatically reconnect, but 
multiple error messages will be displayed, and cartridge management tasks in progress 
may fail. 

1. Perform the steps in “Define Active Storage Regions” on page 160. 

The changes you have made are displayed on the Select Active Cells screen. 

2. In the Options Bar, click Apply. 

The boundaries of the active storage regions are verified, including the locations of all 
tape cartridges. 
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Note – This verification is performed only on the active storage region configuration 
defined in the Select Active Cells screens. It does not verify active storage regions 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made changes to active storage 
regions. 

The Confirm Apply popup appears, indicating whether there are any orphaned 
cartridges or other problems in the active storage region configuration. 

3. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed views of 
the warning messages. 

4. Optionally, in the expanded view of the warning messages you can do the following:

■ Click Print to print the detailed message data.

■ Click Save to File to save the detailed message data to a comma-separated file. 

5. Proceed as follows:
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■ Click No to cancel the update. 

The library controller database is not updated, but all changes you have made are 
retained on the Select Active Cells screen. 

■ Click Yes to make the following updates to the library controller database and 
proceed to Step 6. 

■ White cells with a “dog-eared” left corner are made inactive.

■ Purple cells without a “dog-eared” left corner are made active, up to the total 
licensed capacity of the library. Purple cells that cannot be activated due to 
licensed capacity limits will remain purple and will be activated automatically 
whenever additional licensed capacity is installed. 

■ All other cells are left unchanged. 

The Commit Success popup appears. 

6. Click OK to return to the Select Active Cells screen. 

All newly activated cells are immediately available for use; the library does not need to 
be rebooted. 

7. All affected library host applications must now be configured to recognize these 
updates. See the appropriate tape management software documentation for the 
procedures and commands.
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▼ Display an Active Storage Region Report 
Use this procedure to display the following active storage region reports:

■ Cartridge Cell and Media Summary—Displays a detailed list of all library resources 
and their status (active or inactive).

■ Orphaned Cartridge Report—Displays a detailed list of all orphaned cartridges.

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes to the library controller, the data in these reports will differ 
from data shown on Select Active Cells screen. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.
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2. In the pull-down menu, select the report you want to display. 

The screen is updated with current data from the library controller database. 

3. If you want to print the report data or save it to a file, see the following procedures:

■ “Print Active Storage Region Report Data” on page 168

■ “Save Active Storage Region Report Data” on page 169 
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▼ Print Active Storage Region Report Data
Use this procedure to print an active storage region report. This procedure can be 
performed from any of the active storage region report screens. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Print. 

The Print popup appears. 

4. Complete the print popup, and click Print. 

The report is printed to the selected printer. 
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▼ Save Active Storage Region Report Data
Use this procedure to save active storage region report data to a comma-separated file 
(.csv format). You can use a variety of spreadsheet applications to view the file. This 
procedure can be performed from any of the active storage region report screens. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Save to File.

The Save popup appears. 

4. Browse to the directory where you want to save the file, and enter the file name. 

5. Click Save. 

The data is saved to the specified file. 
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Active Storage Region Screen Reference
This section includes detailed descriptions of all SL Console active storage region 
screens, arranged by screen navigation path. For example, 
Select Active Cells—Select Active Cells—Confirm Apply indicates the screen accessed 
by clicking Tools and then Select Active Cells from the Menu Bar, and then clicking 
the Select Active Cells tab, and then the Confirm Apply button. 

Note – These screens are available for non-partitioned libraries only. See “Partition 
Screen Reference” on page 252 for the screens used in managing capacity in partitioned 
libraries. 

Note – Only the Select Active Cells—Current Active Cells screen is available on the 
local operator panel. The remaining screens can be accessed only from the standalone 
SL Console or the Web-launched SL Console.

Note – The Select Active Cells screen, and all associated popups, give you a dynamic 
workspace to design active storage regions. All active cell information is automatically 
saved to the storage region workspace in SL Console memory and retained for the 
duration of your SL Console session. This allows you to make modifications and leave 
and return to the Select Active Cells screens any number of times without losing your 
changes. 

Caution – Information in the SL Console active storage region workspace is saved to 
the library controller database only through the Apply button. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Apply button, you will lose any active storage region changes you 
have made through the Select Active Cells screens and all associated popups. 

Screen Page

Select Active Cells > Module Map 171

Select Active Cells > Select Active Cells 173

Select Active Cells > Select Active Cells—Confirm Apply 179

Select Active Cells—View Reports—Cartridge Cell and Media 
Summary

184

Select Active Cells—View Reports—Orphaned Cartridge Report 187

Select Active Cells—Current Active Cells 190



Active Storage Region Screen Reference

316194401 • Revision: A Chapter 5 Capacity on Demand 171

Select Active Cells > Module Map

Sample Screen

Description
Allows you to select the library module for which you want to activate or de-activate 
cells for cartridge storage. 

Screen Fields
Select a module from the map below 

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

Click the module for which you want to select storage cells, then click the 
Select Active Cells tab. 
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Buttons
? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Select Active Cells 
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Select Active Cells > Select Active Cells

Sample Screen

Description

Note – If you want to use the default active storage region configuration defined by 
the library controller, you do not need to use this screen. 

Allows you to define active library storage regions by selecting the storage cells you 
want to activate or de-activate for use. This allows you to configure active storage cells 
so that cartridges are concentrated around the drives, and the ends of the library are 
left for future growth.

You can activate any number of cells up to the total licensed capacity of the library. 
Selected cells that cannot be activated due to licensed capacity limits will remain 
selected and will be activated automatically whenever additional licensed capacity is 
installed. 

You can use any of the following methods to select storage cells (see “Library Map” on 
page 176 for detailed instructions): 
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■ Select individual cells or groups of cells 

■ Select an entire column within a library module 

■ Select a side within a library module (front or back) 

■ Select an entire library module 

■ Select all cells within the library 

Caution – De-activating storage cells can result in orphaned cartridges and 
inaccessible data. See “Orphaned Cartridges in Non-Partitioned Libraries” on page 154 
for details. 

Note – You can select storage cells only; installed CAPs and tape drives are always 
active. 

Note – The Select Active Cells screen, and all associated popups, give you a dynamic 
workspace to design active storage regions. All active cell information is automatically 
saved to the storage region workspace in SL Console memory and retained for the 
duration of your SL Console session. This allows you to make modifications and leave 
and return to the Select Active Cells screens any number of times without losing your 
changes. 

Caution – Information in the SL Console active storage region workspace is saved to 
the library controller database only through the Apply button. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Apply button, you will lose any active storage region changes you 
have made through the Select Active Cells screens and all associated popups. 

Screen Fields
Select by

Required.

Indicates the method you want to use for selecting storage cells to activate or de-
activate. Options are:

■ Cell—Select individual or rectangular groups of cells.

■ Column—Select all cells within a column. 

■ Side—Select all cells within one side of a library module. 

■ Module—Select all cells within a library module. 

■ Library—Select all cells within the library. 

Note – You must select either Add or Remove. 

Add 

Required.
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Indicates you want to add cells to the active storage region. You will only be able to 
click inactive cells on the library map. 

Remove

Required.

Indicates you want to remove cells from the active storage region. You will only be 
able to click active or selected cells on the library map. 

Current Library Totals

Capacity

Display only.

Total licensed storage capacity of the library. 

Active Cells

Display only.

Total number of storage cells that have been activated for use in the library 
controller database. This cannot be greater than the licensed Capacity. 

Selection Totals 

Selected Cells 

Display only.

Total number of selected and active cells. This can be greater than the licensed 
Capacity. 

Unselected Cells 

Display only.

Total number of de-selected and inactive cells. 

Note – Selected Cells + Unselected Cells = library physical capacity

% Capacity Used 

Display only.

Percentage of total licensed capacity that has been selected for use (cannot be greater 
than 100%). Calculated as:

Selected Cells / (licensed) Capacity 

Interface Type 

Required.

Type of interface to be used for the library host connection. Options are:

■ HLI

■ FC-SCSI 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 
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Note – For additional details about modifying this field, see “Change the Library 
Interface Type (Non-Partitioned Libraries)” on page 82. 

Legend 

Legend for the library map. The state of each library resource (storage cell, tape drive, 
or CAP cell) is indicated as follows: 

■ Not Accessible (white and x-ed out). Resource is not accessible to any host. 
Following are some possible reasons:

■ Storage cells have been configured for diagnostic cartridges. 

■ Drive bay has no installed drive. 

■ CAP has been configured for storage, not CAP operations. 

■ Inactive (white). Storage cell is not selected. 

■ If the cell also has a “dog-eared” left corner, it is currently activated for use in the 
library controller database and you have selected this cell to be removed from the 
active storage region. The cell will be made inactive in the library controller 
database when you click the Apply button.

■ If the cell does not have a “dog-eared” left corner, it is currently inactive in the 
library controller database. There will be no change to the cell’s status in the 
library controller database when you click the Apply button. 

■ Active (“dog-eared” left corner). Indicates the status of the storage cell in the library 
controller database:

■ Cells with a “dog-eared” left corner are currently active. 

■ Cells with no “dog-eared” left corner are currently inactive. 

■ Selected (purple). Storage cell is selected. Cells can be selected automatically by the 
library controller or manually by the user. 

■ If the cell also has a “dog-eared” left corner, it is currently activated for use in the 
library controller database. There will be no change to the cell’s status in the 
library controller database when you click the Apply button.

■ If the cell does not have a “dog-eared” left corner, it is currently inactive in the 
library controller database and you have selected this cell to be added to the 
active storage region. When you click the Apply button, the cell will be made 
active in the library controller database, up to the total licensed capacity of the 
library. Purple cells that cannot be activated due to licensed capacity limits will 
remain purple and will be activated automatically whenever additional licensed 
capacity is installed. 

■ No Activation Needed (brown). Resource cannot be selected on this screen because it 
is active by default; applies to all CAP cells and tape drives. 

■ Cartridge (cartridge icon). Resource contains a tape cartridge. 

■ Drive slots with installed drives are outlined with a thick border. Empty drive slots 
have a narrow border. 

Library Map 
Graphical representation of the current library configuration. Initial display for the 
current SL Console login session is from the library controller database, then the 
display reflects your modifications. The display includes the following information:



Active Storage Region Screen Reference

316194401 • Revision: A Chapter 5 Capacity on Demand 177

■ Type of module currently displayed (base module, drive expansion module, 
access expansion module, parking expansion module.) 

■ Numeric module ID (1–12)

■ Location of all resources (storage cells, tape drives, CAP cells) within the library 

Note – Move the cursor over any resource to display a tooltip of detailed information 
about the cell or drive, whether it is active in the library controller database, whether it 
is currently selected on the screen, and the identity of any resident cartridge. 

Use the library map to modify the boundaries of the active storage capacity areas. 
Depending on whether you have clicked the Add or Remove radio button, cells you 
click will be selected or de-selected. 

Depending on your choice in the Select by field, you can perform any of the 
following actions. 

■ Select by cell—Select individual or groups of resources. Active storage cells do 
not need to be adjacent to one another. 

- To select an individual storage cell, double-click it.

- To select a rectangular group of storage cells, click the cell at one corner of the 
rectangle, and then click the cell diagonally opposite. 

■ Select by column—Select an entire column within the module. Columns of active 
cells do not need to be adjacent to one another. Click any storage cell within the 
column you want to select. 

■ Select by side—Select all storage cells within an entire module side. Active sides 
do not need to be adjacent to one another. Click any storage cell within the side 
you want to select. 

■ Select by module—Select all storage cells within a module. Active modules do not 
need to be adjacent to one another. Click any storage cell within the module you 
want to select. 

■ Select the library—Select all storage cells in the library. Click any storage cell in 
the library. 

Buttons
Move Left 

Click to display the library module directly to the left of the one currently displayed. 
This button is grayed out if there is no module to the left. 

Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 

Apply 

Click to update the library controller database with the current settings from the 
screen. The Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the active storage region configuration. 

Note – This button is grayed out if you have not made any changes to the 
Select Active Cells screen since the last update. 
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The status of the cells will be updated in the library controller database, as follows: 

■ White cells with a “dog-eared” left corner are made inactive.

■ Purple cells without a “dog-eared” left corner are made active, up to the total 
licensed capacity of the library. Purple cells that cannot be activated due to 
licensed capacity limits will remain purple and will be activated automatically 
whenever additional licensed capacity is installed. 

■ All other cells are left unchanged. 

Refresh

Click to refresh the screen with current data from the library controller database. All 
unapplied active storage region changes you have made during this SL Console 
login session will be discarded. The Cell Selection Refresh popup appears, 
prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Module Map 

■ Select Active Cells > Select Active Cells—Confirm Apply 

■ Select Active Cells—Current Active Cells 
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Select Active Cells > Select Active Cells—Confirm 
Apply

Sample Screen

Description
Displays a list of configuration errors in the defined active storage regions. This screen 
is a popup that appears when you click Apply on the 
Select Active Cells > Select Active Cells screen. 

After viewing the error messages, you can commit all data from the Select Active Cells 
screen to the library controller database by clicking the Yes button. 

Possible errors include:

■ The library has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” on page 204 for details.

■ Storage cells have been removed from the library. 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the library 
controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 
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Screen Fields
Warnings found

Display only.

Summary error messages regarding the storage region configuration. 

Library 

Display only.

Library number where the orphaned cartridge is located. This is always “1”. 

Rail 

Display only.

Rail number where the orphaned cartridge is located. This is always “1”. 

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Cause for Orphaned State

Display only.

Reason why the cartridge has been identified as orphaned. Options include:

■ Just Activated 

■ Inactive Media 

Vol Ser 

Display only.

Volume serial number (volid) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Some possible options are:

■ Media was found in an inactive cell. 

■ Inactive cell with media was just activated. 

Buttons
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Note – To display the Print and Save to File buttons, you may need to scroll down 
within the inner window. 

Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Yes

Click to confirm that you want to update the library controller database with the 
current settings from the Select Active Cells. The status of the cells are updated in 
the library controller database, as follows: 

■ White cells with a “dog-eared” left corner are made inactive.

■ Purple cells without a “dog-eared” left corner are made active, up to the total 
licensed capacity of the library. Purple cells that cannot be activated due to 
licensed capacity limits will remain purple and will be activated automatically 
whenever additional licensed capacity is installed. 

■ All other cells are left unchanged. 

No

Click to cancel the update. The library controller database is not updated, but the 
current settings on the Select Active Cells are retained. 

Details 

Click to toggle between the expanded and collapsed views of the warning message 
display. 

See Also
■ Select Active Cells > Select Active Cells 
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Select Active Cells—Reports

Sample Screen

Description
Allows you to select one of the following active storage region reports:

■ Cartridge Cell and Media Summary

■ Orphaned Cartridge Report

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes through the Apply button, the data in these reports will differ 
from data shown on the Select Active Cells screen. 

Screen Fields
Please select a report to display

Required.
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Click the report you want to display. The drop-down menu lists all available active 
storage region reports. 

Buttons
Apply 

Click to update the library controller database with the current settings from the 
screen. The Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the active storage region configuration. 

Note – This button is grayed out if you have not made any changes to the 
Select Active Cells screen since the last update. 

Refresh

Click to refresh the screen with current data from the library controller database. All 
unapplied active storage region changes you have made during this SL Console 
login session will be discarded. The Cell Selection Refresh popup appears, 
prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Select Active Cells 

■ Select Active Cells—View Reports—Cartridge Cell and Media Summary 

■ Select Active Cells—View Reports—Orphaned Cartridge Report 



Active Storage Region Screen Reference

184 SL3000 User’s Guide • April 2008 Revision: A • 316194401

Select Active Cells—View Reports—Cartridge Cell 
and Media Summary

Sample Screen

Description
Displays detailed information about all library resources (storage cells, tape drives, and 
CAP cells) and any stored cartridges.

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes to the library controller, the data in these reports will differ 
from data shown on Select Active Cells screen. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields
Library 

Display only.

Library number where the library resource is located. This is always “1”. 

Rail 

Display only.

Rail number where the library resource is located. This is always “1”. 

Column

Display only.

Column number where the library resource is located. Column location is referenced 
from the left edge of the Base Module. “+1” is to the right; “-1” is to the left.

Side

Display only.

Module side where the library resource is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the library resource is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Element Type

Display only.

Type of library resource. Options are:

■ CAP
■ CELL
■ DRIVE

Vol Ser 

Display only.

Volume serial number (volid) of the cartridge resident in the library resource, if 
applicable. 

Cell Status

Display only.

Capacity status of the library resource. Applies to storage cells only. Options are:

■ Active—Cell is activated for use and can be used for cartridge storage. 

■ Inactive—Cell is not activated for use and cannot be used for cartridge storage. 

Buttons
Print

Click to print the report on a selected printer.
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Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells—Reports

■ Select Active Cells—View Reports—Orphaned Cartridge Report
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Select Active Cells—View Reports—Orphaned 
Cartridge Report 

Sample Screen

Description
Displays the locations and volume serial numbers (volids) of all orphaned cartridges in 
the library. Also identifies why the cartridge is orphaned. 

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes to the library controller, the data in these reports will differ 
from data shown on Select Active Cells screen. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields
Library 

Display only.

Library number where the orphaned cartridge is located. This is always “1”. 

Rail 

Display only.

Rail number where the orphaned cartridge is located. This is always “1”. 

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Vol Ser 

Display only.

Volume serial number (volid) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Some possible options are:

■ Media was found in an inactive cell. 

■ Inactive cell with media was just activated. 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 
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See Also
■ Select Active Cells—Reports 

■ Select Active Cells—View Reports—Orphaned Cartridge Report 
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Select Active Cells—Current Active Cells

Sample Screen

Description
Displays current active library storage regions. Shows which storage cells are currently 
active, inactive, or selected for activation.

This is the only Select Active Cells screen that is available on the local operator panel.

Note – This screen is display only. 

Screen Fields
For detailed descriptions of the screen fields, see 
“Select Active Cells > Select Active Cells” on page 173. 
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Buttons
Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Select Active Cells 
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6

Library Partitioning

Note – Library partitioning is a licensed feature which must be installed through the 
SL3000 licensing utility. See Chapter Chapter 4, “Licensing” for details. 

Library partitioning allows sections of the SL3000 library to be assigned for exclusive 
use by specified hosts. For example, you can configure one group of storage cells and 
drives to be used only for Veritas operations, and another group to be used only for 
Tivoli operations. This allows you to configure an SL3000 library for applications 
running on multiple operating systems. 

Partitioning Features and Restrictions
This section describes important features and restrictions of library partitioning that 
will help you to configure and use partitioning in your SL3000 library. 

■ You can configure up to eight partitions within an SL3000 library. 

■ A partition can be as small as a single storage cell or tape drive, or a whole CAP. 
Cells and drives within a partition do not need to be adjacent. 

■ Storage cells and tape drives allocated to a partition can be used only by the hosts 
assigned to that partition. Hosts assigned to other partitions cannot access the 
contents of these cells and drives. See “Storage Cells and Drives” on page 199 for 
details. 

■ Storage cells and drives not allocated to any partition cannot be accessed by any 
hosts. For example, you might leave an area of cells unallocated, in preparation for 
future partitioning. 

■ Host-partition connections can use either the FC-SCSI or HLI (TCP/IP) interface. 

■ Whole CAPs can be allocated for exclusive use by one partition, or they can be 
shared by multiple partitions. See “Partition and CAPs” on page 200 for details.

■ CAPs can only be shared by partitions with the same host interface type. That is, 
FC-SCSI and HLI partitions cannot share the same CAP. 
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Enabling and Disabling Partitioning
In order for you to use partitions in a library, the partitioning feature must be installed 
through the licensing utility. See Chapter 4, “Licensing”  on page 129 for details. 

A library with partitioning enabled can be in either of the following states: 

■ Partitioned—The library has at least one user-defined partition with a valid partition 
ID. 

■ Non-partitioned—The library has no user-defined partitions. A non-partitioned 
library behaves in the same manner as a library that does not have partitioning 
enabled; that is all active storage cells, drives, and CAPs are accessible to all hosts. 

To disable partitioning on a library, you must first delete all partitions. The library state 
will then change to “non-partitioned.” 

Partition Planning
The partitioning feature offers great flexibility in the use of your library. It also requires 
careful planning, a thorough knowledge of library wall and storage cell mapping, and 
expertise in configuring and administering host software applications. There must be 
clear communication among all parties involved, including system programmers and 
administrators, library operators, and your Sun service representative. 

Before creating partitions, you must plan the storage area that is needed for resident 
tape cartridges and anticipate the number of required free cells. You must understand 
the boundaries of each partition and the host ownership relationships. You must verify 
that all tape drives and cartridges have been moved to the proper locations, according 
to the planned  assignments.   

Installing the Partitioning Feature
The following special considerations apply after you successfully install the 
Partitioning feature on a previously non-partitioned library. 

■ You can begin creating partitions immediately; you do not need to reboot the library 
first.

■ Until you create at least one partition, the library remains in a non-partitioned state; 
that is all licensed storage cells, drives, and CAPs are accessible to all hosts. 

Allocated Storage Capacity
In partitioned libraries, the total number of storage cells allocated to all library 
partitions cannot exceed the licensed capacity of the library. 
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In partitioned libraries, there is no default active storage region. You must explicitly 
assign storage cells to partitions, thereby configuring the active storage regions for each 
partition. See “Partitioning Process” on page 206 for details. 

When assigning cartridges to storage cells, the library controller applies the predefined 
cell selection rules separately to each partition. See “Cell Activation Rules” on page 153 
for details. 

Partition Configurations
You must use the standalone SL Console or Web-launched SL Console to configure 
library partitions; the partitioning screens are not available on the local operator panel. 

To configure a partition, you must define the following information: 

■ Partition Summary Information

■ Host-Partition Connections

■ Partition Boundaries

For detailed instructions on defining library partitions, see “Partitioning Process” on 
page 206. 

Partition Summary Information
 Partition summary information includes the partition ID, name, and host-partition 
connection type (HLI or FC-SCSI). Partition IDs must be unique and can range from 1–
8. 

Host-Partition Connections
Host-partition connections identify the hosts that are able to access a partition. Each 
partition appears to the host as a separate library. A host can control one or more 
partitions. In addition, it is possible for more than one host to control a single FC-SCSI 
partition, but it is recommended that you exercise caution in implementing this 
configuration, as some host applications may not allow for resource sharing. 

HLI Host-Partition Connections

An HLI (Host Library Interface) partition can have up to 16 assigned hosts. You define 
the HLI host-partition connection configuration through the library management 
software (ACSLS or HSC). Therefore there are no SL Console screens to display or 
maintain this information. See the appropriate tape management software 
documentation for details. 

FC-SCSI Host-Partition Connections

An FC-SCSI partition can have one or more host-partition connections. The host-
partition connection configuration is user-defined and consists of the following 
information: 

■ World Wide Port Name of the FC-SCSI host bus adapter 
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■ Port number of the library Fibre Channel card 

■ Logical unit number (LUN) of the partition on the host 

See “Configure a Host-Partition Connection” on page 213 for detailed instructions on 
defining this information. 

Partition Boundaries
Partition boundaries identify the storage cells, drives, and CAPs that are part of each 
partition. Only unallocated cells can be added to a partition, and only allocated cells 
can be removed. 

You can define partition boundaries in any of the following ways:

■ Select individual cells or rectangular groups of cells to add or remove from a 
partition. Cells or cell groups do not have to be contiguous.

■ Select a module column to add or remove from a partition. Columns do not have to 
be contiguous. 

■ Select an entire module side (front or back) to add or remove from a partition. Sides 
do not have to be contiguous. 

■ Select an entire module to add or remove from a partition. Modules do not have to 
be contiguous. 

Note – It is possible to have partitions with no allocated resources. 

Partitions and Library Resources

Library Resource Addresses 
Resource addresses uniquely identify each resource (storage cells, drives, and CAPs) 
within the library. The SL3000 library and attached hosts use the following addressing 
schemes: 

■ Library Internal Address

■ Host FC-SCSI Element Address

■ HLI-PRC Address

Each partition appears to a host as a separate library; this is reflected in the partition 
address. 
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Library Internal Address
The library internal address is used by the SL3000 library controller and the SL Console 
device tree to identify the physical location of each resource. The addressing scheme 
used by the SL3000 is a five-digit, comma-separated value, specifying the library, rail, 
column, side, and row, as viewed from the front of the library, facing the drive bays. 

The format of the SL3000 library internal address is l,r,c,s,w where:

■ l = library or partition number; this value is always “1”. 

■ r = rail number; this value is always “1”.

■ c = column number. Column numbering is referenced from the left edge of the Base 
Module, as you face the inside back wall, as follows:

■ Numbering is static, allowing modules to be added without renumbering existing 
columns. 

■ Columns within and to the right of the Base Module are numbered positively (+), 
in ascending sequence from left to right. 

■ Columns to the left of the Base Module are numbered negatively (-), in 
descending sequence from right to left. 

■ Base Module panels are always “1” to “6”. 

■ DEM panels (if present) are always “-1” to “-6”.

■ If there is no DEM and a CEM is to the left of the Base Module, then columns 
“-1” to “-6” are skipped and the CEM is assigned columns “-7” to “-12”. 

■ CEM columns to the right of the Base Module start with “7”. 

■ AEM columns are numbered as if a DEM and four CEMS are installed to the left 
and four CEMs are installed to the right of the Base Module

■ s = side. Back wall = 1; front wall = 2.

■ w = row number. Numbered consecutively from the top, down. Valid values are 1–
52, with row 1 at the top. 

Host FC-SCSI Element Address
The FC-SCSI element address is used by hosts with an FC-SCSI connection to the 
SL3000 library to uniquely identify each library resource available to the host. 

FC-SCSI element numbering uses a single integer to identify each library resource. 
FC-SCSI element numbering within partitioned libraries is continuous for each 
partition, even if cell locations for the partition are not adjacent. FC-SCSI element 
addresses for a partition start at the lowest module, row, and column within the 
partition, then proceed by row until the end of the column, then increment by column 
until the end of the module. 

When additional resources are allocated to an existing FC-SCSI partition, the original 
resources are not renumbered. This helps to minimize disruption to the FC-SCSI host.  

FC-SCSI Element Address Examples

If a library’s base and storage expansion modules are allocated to Partition 1 and the 
drive module is allocated to Partition 2, FC-SCSI element numbering is as follows:

■ Numbering for Partition 1 begins at the first available slot in the base module and 
continues through the last available cell in the storage module cell. 



Partitions and Library Resources

198 SL3000 User’s Guide • April 2008 Revision: A • 316194401

■ Numbering for Partition 2 begins with the first available slot in the drive module 
PRC Address and ends with the last available cell in that module. 

HLI-PRC Address
The HLI-PRC (Host Library Interface-Panel, Row, Column) address is used by hosts 
with an HLI connection to the SL3000 library, including ACSLS and HSC. The HLI-PRC 
address uniquely identifies each library resource accessible to the host and is assigned 
by the host software.

The HLI-PRC address is an eight-digit value specifying the library, panel, row, and 
column where the resource is located. The format is ll:pp:rr:cc, where:

■ ll = Library number; this value is always “00”. 

■ pp = Panel number. Numbering is relative to the Base Module, as follows:

■ Base Module panels are always “12” and “13”. 

■ Modules to the left of the Base Module are numbered in descending sequence, 
starting with “11”; modules to the right are numbered in ascending sequence, 
starting with “14”. 

■ Rear walls are assigned even numbers; front walls are assigned odd numbers. 

■ DEM panels (if present) are always “10” and “11”.

■ If there is no DEM and a CEM is to the left of the Base Module, then panels “10” 
and “11” are skipped and the CEM is assigned panels “8” and “9”. This allows 
you to add a DEM to the left of the Base Module at a later date without 
renumbering modules. 

■ rr = Row number within the panel. Numbered consecutively from the top, down. 
Valid values are 0–51, with row 0 at the top. 

■ cc = Column number within the panel. Numbered consecutively from left to right, 
starting at the front of the module. Each panel has a maximum of six columns; 
therefore, valid column values are 0–5. 

HLI CAP numbering

Library CAP numbers are assigned by module, from left to right: 

■ Base Module CAP = 6

■ DEM CAP = 5

■ CAPs in CEMs to the left of the Base Module = 1–4

■ CAPs in CEMs to the right of the Base Module = 7–10

■ AEM CAP to the left of the Base Module = 0

■ AEM CAP to the right of the Base Module = 11

CAPs contain a single column of cells with 26 rows; cells are numbered 0–25. 

The AEM contains a bulk load CAP with 234 cells arranged in six columns. Column 
numbering starts at the rear wall and runs left to right (columns 0–2); then proceeds to 
the front wall and runs left to right (columns 3–5). 
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Storage Cells and Drives 
All storage cells, tape drives, and cartridges allocated to a partition are owned 
exclusively by the assigned host and cannot be accessed by other hosts. For example, if 
a group of tape drives is allocated to a partition, only the host assigned to that partition 
can use those drives. 

Storage cells and drives that are not allocated to any partition cannot be accessed at all. 
For example, you can leave an area of cells unallocated in preparation for a planned 
future partition. 

On the SL Console screens and reports, storage cells and drives appear in any of the 
following states:

■ Allocated—Assigned to the current partition. 

■ Unallocated (or Unassigned)—Not assigned to any partition; available to be assigned 
to any current partition. 

■ Unavailable—Assigned to another partition. 

■ Not accessible—Not available for host operations; for example, cells reserved for 
diagnostic cartridges, cells that are physically blocked, and cells that are inactive. 

Note – TallBots are shared resources and cannot be allocated exclusively to a partition. 

To display partition assignments for storage cells and drives, see 
“Partitions—Reports—Cartridge Cell and Media Summary” on page 295. 
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Partition and CAPs

Note – The SL3000 does not support common CAPs, split CAPs, or the allocation of 
individual CAP cells to a partition. These features are available for the SL500 only. 

When configuring CAPs, you must plan carefully for anticipated CAP usage. A 
partition can only use the CAPs explicitly allocated to it. There is no “common” CAP in 
the SL3000. 

When you allocate a CAP to a partition, all cells in the CAP are allocated as a whole. It 
is not possible to allocate or de-allocate individual cells within a CAP. There is no 
“split” CAP in the SL3000. 

CAP Allocations
All CAPs in a partitioned library are unallocated by default. You allocate CAPs to 
partitions through the Partitions—Design (Step 3b) screen. CAP allocations can take 
either of the following forms:

■ Dedicated—The CAP is allocated for the exclusive use of one partition.

■ Shared—The CAP is allocated for the use of more than one specified partition. See 
“Shared CAPs” for details. 

Once a CAP is allocated, it becomes either an FC-SCSI CAP or an HLI CAP, depending 
on the host interface type of the first partition to which it is allocated. For example, if 
you allocate a previously unallocated CAP to a partition with an FC-SCSI interface, the 
CAP becomes an FC-SCSI CAP. Subsequent allocations of the CAP can be to other 
FC-SCSI partitions only. To change the CAP from FC-SCSI to HLI, you must first de-
allocate the CAP from all FC-SCSI partitions, and then allocate the CAP to an HLI 
partition.

Note – CAP allocations are not required; it is possible to have partitions with no 
allocated CAP. 

Note – Because FC-SCSI host applications typically do not use CAP reservations, it is 
recommended that you dedicate at least one CAP to each FC-SCSI partition whenever 
possible. This allows each partition to operate independently from the others and 
allows you to avoid the resource contention issues that can arise through shared CAPs. 
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Shared CAPs
Because a library can have more partitions than CAPs, it may be necessary to share 
CAPs among partitions. Only partitions with the same host interface type can share a 
CAP. For example, any number of FC-SCSI partitions can share a group of one or more 
CAPs, and any number of HLI partitions can share a different group of CAPs, but HLI 
and FC-SCSI partitions cannot both share any of the same CAPs. 

For ease of management, it is recommended that you keep shared CAP groupings 
together for all partitions they are allocated to. For example, if you allocate CAPs A and 
B to one partition, and another partition also needs access to A or B, you should 
allocate both CAPs, not just one of them, to the second partition. 

Note – You must carefully manage shared CAP usage among FC-SCSI hosts in order to 
avoid contention. See “CAP Operations” on page 201 for details. 

CAP Auto Enter Mode 
CAP auto enter mode allows a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request and without an explicit reservation 
from a host application. Auto enter mode is available for CAPs that have been 
dedicated to a partition. CAPs in auto enter mode are left unlocked. 

Auto enter mode is managed by the host applications. See the appropriate tape 
management software documentation for details. 

CAP Operations 
A CAP can be used by only one partition at a time for enters and ejects. A partition can 
take ownership of a CAP in any of the following ways:

■ The CAP is dedicated to one partition. In this case the partition always has exclusive 
ownership of the CAP.

■ A host application reserves the CAP prior to an enter or eject operation. This 
typically applies to HLI host applications only. See “CAP Reservations” on page 202 
for details. 

■ The user explicitly associates the partition to the CAP. This applies to shared 
FC-SCSI CAPs only. See “Shared FC-SCSI CAP Associations” on page 204 for details. 

■ A partition places a cartridge in the CAP. If none of the conditions above apply, the 
first partition to place a cartridge in the CAP as part of an export operation takes 
ownership of the CAP until the export is completed and the CAP is closed and 
empty.

While a partition has ownership of a CAP, the CAP is reserved exclusively to that 
partition and unavailable to all others. 
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CAP States
A CAP must be unlocked in order for you to open it to insert or remove cartridges. 
When a CAP is unlocked, the light on the CAP button is turned on. 

When you close a CAP, the TallBot performs an audit to determine whether there are 
cartridges present. During the audit the CAP is locked and the light on the CAP button 
is turned off. Once the audit is completed, the CAP is returned to its default state. 

The following table describes the default states of the various types of CAPs within a 
partitioned library. 

CAP Reservations
Both FC-SCSI and HLI hosts can make use of CAP reservations. CAP reservations give 
a partition exclusive ownership of a shared CAP for the duration of an enter or eject 
operation. When the operation is finished, the host application must release the 
reservation to make the CAP available to other partitions sharing the CAP. No other 
partitions can access the CAP until the first one has terminated the operation and 
released the reservation. 

For a partition to reserve a CAP, the CAP must be unreserved (applies to shared CAPs 
only), empty, and closed. 

HLI CAP Reservations 
HLI host applications use a strict reservation scheme to manage CAP usage among host 
clients, and therefore always reserve a CAP before unlocking it or moving a cartridge to 
it. When an HLI host application attempts to reserve a CAP already reserved by 
another partition, the library controller sends a message to the requesting host 
identifying the partition ID and host ID holding the reservation. 

Type of CAP Default State

Default CAP 
Button Light 
Condition Comment

HLI—dedicated or 
shared 

Locked Off Host reservation unlocks the 
CAP and turns the light on. 
See “CAP Reservations” on 
page 202 for details. 

HLI—auto enter 
mode

Unlocked On

FC-SCSI—dedicated Unlocked On

FC-SCSI—shared Locked Off Partition-CAP association 
unlocks the CAP and turns 
the light on. See “Shared 
FC-SCSI CAP Associations” 
on page 204 for details.
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Releasing CAP Reservations 

In normal operations, a CAP reservation for an ACSLS or HSC host is released in the 
following ways:

■ Enter operations—After all cartridges have been successfully entered into the 
library, the host explicitly terminates the enter command. The library controller 
releases the CAP after verifying that the CAP is closed and empty. 

■ Eject operations—After all cartridges have been successfully ejected, the host 
automatically terminates the eject operation. The library controller releases the CAP 
after verifying that the CAP is closed and empty. 

If for some reason a CAP reservation is not released as described above, the CAP will 
be unavailable to all other partitions, and cartridges belonging to the first partition may 
remain in the CAP. In this case, it is recommended that you terminate the enter or eject 
from the host holding the reservation. This ensures a normal release of the CAP 
reservation. 

Note – See the ACSLS or HSC documentation for details about terminating enters and 
ejects. 

Overriding CAP Reservations 

In some cases, you may not be able to access the host holding a reservation and 
therefore cannot perform a normal release of the CAP. This may be because the host 
has terminated or because you lack physical access or security authorization to issue 
commands to the host. In these cases, you can override (unreserve) the CAP reservation 
manually. See “Overriding a CAP Reservation” on page 80 for the detailed procedure. 

Note – Use extreme care when using the SL Console to override a CAP reservation. If 
you do not complete the procedure, the CAP could be left unavailable to all partitions, 
and/or cartridges assigned to one partition could be entered into another partition.

Note – You can use the SL Console to override a CAP reservation only in a partitioned 
library. If a library is not partitioned, CAP reservations must always be released 
through ACSLS or HSC. 

FC-SCSI CAP Reservations 
Most FC-SCSI host applications do not use CAP reservations. FC-SCSI host applications 
typically assume sole ownership of a CAP and therefore do not coordinate CAP sharing 
well. To avoid contention among partitions for a shared CAP, you can manually 
associate a partition to a CAP. See “Shared FC-SCSI CAP Associations” for details. 
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Shared FC-SCSI CAP Associations 
If a FC-SCSI partition shares CAPs with other partitions, it is recommended that you 
manually associate the partition to its CAPs prior to initiating an enter or eject 
operation. See “Associate an FC-SCSI Partition to Its Shared CAPs” on page 245 for the 
detailed procedure.

A partition-CAP association gives a partition exclusive ownership of its shared CAPs, 
similar to a CAP reservation. This ensures that cartridges are always entered into the 
correct partition and prevents other partitions from taking ownership of a shared CAP 
that is already in use. 

The following rules apply when making partition-CAP associations:

■ You can associate only one partition at a time to a CAP. 

■ Selecting a partition causes all its allocated CAPs to be associated to it at once; you 
cannot select individual CAPs to be associated to the partition. 

■ You can select multiple partitions at once, as long as the selected partitions do not 
share any CAPs with one another. 

■ Partition-CAP associations remain active until you explicitly remove them; the 
associations are not automatically removed when the enter or eject operation 
completes. 

■ Partition-CAP associations are removed during library reboots, power cycles, library 
door open/close operations, or CAP initializations 

■ Partition-CAP associations are removed if the CAP becomes allocated to a different 
partition through the Design (Step 3b) screen. 

■ If a partition-CAP association is removed while the CAP is open or has cartridges in 
it, the CAP ownership will be changed to the “default” requester and the CAP will 
be unavailable to all partitions. You must empty and close the CAP before it can be 
associated to any partitions. 

Orphaned Cartridges in Partitioned Libraries

Note – For a discussion of orphaned cartridges in non-partitioned libraries, see 
“Orphaned Cartridges in Non-Partitioned Libraries” on page 154. 

In partitioned libraries, an orphaned cartridge is a cartridge located in an unallocated 
cell or drive (that is, a cell or drive not allocated to any defined partition). 

Caution – If a host encounters an orphaned cartridge it might treat the cartridge as 
scratch and overwrite the data. Therefore, it is very important to disposition orphaned 
cartridges properly. 

A cartridge can become orphaned for a variety of reasons. Following are some possible 
causes:

■ Partition boundaries have changed.

■ A partition has been deleted. 

■ The cartridge has been moved to an unallocated or inaccessible cell through manual 
intervention. 
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If the SL Console identifies an orphaned cartridge, it displays a warning message. You 
can then use the following tools to help you resolve and disposition the orphaned 
cartridge:

■ Generate a report of orphaned cartridges. 

■ Perform an audit of the library. 

■ Perform a recovery move on a cartridge. 

For detailed instructions on checking for and resolving orphaned cartridges, see the 
following procedures:

■ “Verify Partition Configurations” on page 218

■ “Resolve Orphaned Cartridges” on page 221

■ “Commit Partition Configuration Changes” on page 222
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Partitioning Process

Note – Library partitioning is a licensed feature which must be installed through the 
SL3000 licensing utility. See Chapter Chapter 4, “Licensing” for details. 

Partition Configuration Process
When configuring library partitions for the first time, it is recommended that you use 
the library partition screens in the following sequence: 

1. Instructions (Step 1)—Review summary instructions for the partition configuration 
process. 

2. Summary (Step 2)—Display summary partition configuration and host-partition 
connection information. Optionally access other screens to perform the following 
tasks:

■ Add Partition

■ Modify Partition

■ Delete Partition

Note – The following tasks are available for FC-SCSI host-partition connections only. 

■ Add Connection

■ Modify Connection

■ Delete Connection

3. Module Map (Step 3a)—Select the library module for which you want to design 
detailed partition boundaries. 

4. Design (Step 3b)—Display and optionally modify detailed partition boundary 
information. Optionally access other screens to perform the following tasks:

■ Verify Partition Configurations 

■ Refresh the display with current data from the library controller database

5. Commit (Step 4)—Commit all changes made in the Summary(2) and Design (3b) 
screens, and all associated popups, to the library controller database. Optionally 
access other screens to perform the following task: 

■ Refresh the display with current data from the library controller database

You can use the Reports screen at any time to display, and optionally save or print, 
partition configuration information from the library controller database. 
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SL Console Partition Workspace
The partition Summary (Step 2) and Design (Step 3b) screens, and all associated 
popups, give you a dynamic workspace to design your library partitions. All partition 
configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes.

Information in the SL Console partition workspace is committed to the library 
controller database only through the Commit (Step 4) screen. The information is lost if 
any one of the following occurs before you have committed your updates: 

■ You actively log off the SL Console session.

■ The SL Console session times out or the connection to the library is lost. 

■ You actively refresh the SL Console workspace from the current library controller 
database. This is done through the Refresh button on the Summary (Step 2) and 
Design (Step 3b) screens. 

Caution – For the following reasons, it is recommended that you make the library 
unavailable to other users before committing your partition workspace changes. 
 
There is no real-time validation of partition boundaries against the library controller 
database; therefore if you do not make the library unavailable and other users are 
performing cartridge movements or library configuration changes, configuration 
conflicts may arise. See “Synchronizing the Display With the Controller Database” on 
page 35 for details.  
 
The library temporarily drops all connections to HSC or ACSLS hosts when partition 
configurations changes are committed. The hosts will automatically reconnect, but 
multiple error messages will be displayed, and cartridge management tasks in progress 
may fail.
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Partitioning Task Summary
Partitioning tasks are divided into the following categories:

■ “Partition Configuration Tasks” on page 209

■ “Partition Management Tasks” on page 225

■ “Partition Report Tasks” on page 239

■ “CAP Operation Tasks” on page 244
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Partition Configuration Tasks

Task Page

Review Partitioning Instructions 210

Create a Partition 211

Configure a Host-Partition Connection (FC-SCSI partitions only) 213

Design a Partition 215

Verify Partition Configurations 218

Resolve Orphaned Cartridges 221

Commit Partition Configuration Changes 222
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▼ Review Partitioning Instructions
Use this procedure to review the partitioning process. 

1. Select Tools > Partitions.

The first time you make this selection during an SL Console login session, the 
Instructions (Step 1) screen appears automatically. 

2. Review the instructions on the screen before proceeding with other partitioning 
tasks. 
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▼ Create a Partition 
Use this procedure to create a new library partition and assign its storage capacity. You 
can create up to eight partitions, with IDs from 1–8. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab. 

The Summary (Step 2) screen appears.

2. Click Add Partition. 

The Add Partition popup appears. 

3. Select the Partition ID you want to add, and enter the Name, Capacity, and Interface 
Type. 

Note – Partition IDs do not need to be contiguous. For example, you can create 
partition 2 and partition 4, with no partitions 1 or 3. 
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4. Click OK. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 218 and “Commit Partition 
Configuration Changes” on page 222. 
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▼ Configure a Host-Partition Connection

Note – This procedure applies to FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details. 

Use this procedure to configure the connection between a host and a selected partition. 
You must perform this procedure in order for the partition to be accessible by the host.

Each partition can have up to nine host connections, each with a unique LUN. Also, 
each host can connect to multiple partitions. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. Click the partition to which you want to add a host connection

Note – If you select an HLI partition, all the buttons in the Details section of the screen 
are grayed out. 
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3. Click Add Connection. 

The Add Connection popup appears. 

4. Enter the Initiator (WWPN) and LUN. 

Note – Each initiator connected to the library must have one library partition assigned 
to LUN 0. When you verify or commit partition configuration changes, the SL Console 
will notify you if an initiator does not meet this requirement. 

5. Click OK. 
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▼ Design a Partition 
Use this procedure to add or remove library resources (storage cells, tape drives, and 
CAPs) from a partition. 

Note – Library resources can be allocated to only one partition at a time. If you want to 
add resources to a partition but the resources are already allocated to another partition, 
you must first remove the resources from the assigned partition, and then add them to 
the new partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module for which you want to design a partition. 
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4. Click the Design (Step 3b) tab.

The Design (Step 3b) screen appears, displaying the current configuration of the 
module you have selected.

5. In the Partition pull-down menu, select the partition you want to configure. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

Note – Click the Move Left or Move Right buttons to display a module directly 
adjacent to the one currently displayed. 

6. Choose the Select by method, and click either the Add or Remove radio button.

7. Use the library map to select the resources you want to add or remove. 
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Note – See “Partitions—Design (Step 3b)” on page 275 for detailed instructions on 
using the library map. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 218 and “Commit Partition 
Configuration Changes” on page 222. 
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▼ Verify Partition Configurations 
Use this procedure to verify partition configuration changes you have made during this 
SL Console login session. This procedure warns you of the following possible errors:

■ A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” on page 204 for details.

■ Library resources have been removed from a partition. 

■ A host connected to the library does not have a partition assigned to LUN 0. 

■ The library’s licensed capacity is oversubscribed; that is total partition allocations 
exceed licensed capacity.

Note – This procedure verifies only one partition at a time. If you need to verify 
multiple partitions, you must repeat this procedure separately for each partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module for which you want to verify a partition. 

The module is highlighted on the screen. 
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4. Click the Design (Step 3b) tab.

The Design (Step 3b) screen appears, displaying the current configuration of the 
module you have selected.

5. In the Partition pull-down menu, select the partition you want to verify. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

6. In the Options Bar, click Verify. 

The boundaries of the selected partition are verified, including the locations of all tape 
cartridges. 

Note – This verification is performed on the current partition configuration in the 
SL Console partition workspace only. It does not verify current partition boundaries 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made partition changes. 

The Verify Results popup appears, indicating whether there are any orphaned 
cartridges, oversubscribed storage capacity, or other errors in the current partition 
configuration. 

Note – If library capacity is oversubscribed (that is, total partition allocations exceed 
licensed capacity), before you can proceed to “Commit Partition Configuration 
Changes” on page 222, you must remove storage cells from partition allocations to 
bring the total allocated cells within the library’s licensed capacity. 
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7. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed views of 
the warning messages. 

8. Optionally, in the expanded view of the warning messages you can do the following:

■ Click Print to print the detailed message data.

■ Click Save to save the detailed message data to a comma-separated file. 

9. Click OK to dismiss the Verify Results popup and return to the Design (Step 3b) 
screen. 

Note – It is recommended that you follow the “Resolve Orphaned Cartridges” on 
page 221 procedure before committing your changes to the library controller database. 
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▼ Resolve Orphaned Cartridges
If the SL Console identifies an orphaned cartridge, it displays a warning message. You 
should resolve and disposition all orphaned cartridges before proceeding to “Commit 
Partition Configuration Changes” on page 222. 

You can performing any of the following actions to resolve orphaned cartridges: 

■ Print a report of orphaned cartridges. 

■ Perform an audit of the library. 

■ Perform a recovery move on an orphaned cartridge. 
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▼ Commit Partition Configuration Changes 

Caution – This procedure updates the library controller database with all partition 
configuration changes you have made during this SL Console session. Failure to use 
this procedure before logging out of the current SL Console session will cause all your 
library configuration changes to be lost.

Caution – For the following reasons, it is recommended that you make the library 
unavailable to other users before committing your partition workspace changes. 
 
There is no real-time validation of partition boundaries against the library controller 
database; therefore if you do not make the library unavailable and other users are 
performing cartridge movements or library configuration changes, configuration 
conflicts may arise. See “Synchronizing the Display With the Controller Database” on 
page 35 for details.  
 
The library temporarily drops all connections to HSC or ACSLS hosts when partition 
configurations changes are committed. The hosts will automatically reconnect, but 
multiple error messages will be displayed, and cartridge management tasks in progress 
may fail.

Note – It is recommended that you follow the Resolve Orphaned Cartridges procedure 
before performing this procedure. 

Note – You cannot perform this procedure if current library capacity is oversubscribed 
(that is, total partition allocations exceed licensed capacity). The Apply button is grayed 
out, and before you can proceed, you must remove storage cells from partition 
allocations to bring the total allocated cells within the library’s licensed capacity.

1. Vary the library offline to ACSLS and HSC. 

See the appropriate tape management software documentation for the procedures and 
commands.

2. Select Tools > Partitions, and click the Commit (Step 4) tab.

The Commit (Step 4) screen appears.

3. In the Options Bar, click Apply. 

The boundaries of the selected partition are verified, including the locations of all tape 
cartridges. 
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Note – This verification is performed on the current partition configuration in the 
SL Console partition workspace only. It does not verify current partition boundaries 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made partition changes. 

The Confirm Apply popup appears, indicating whether there are any orphaned 
cartridges or other problems in the current partition configuration. 

4. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed views of 
the warning messages. 

5. Optionally, in the expanded view of the warning messages you can do the following:

■ Click Print to print the detailed message data.

■ Click Save to save the detailed message data to a comma-separated file. 

6. Proceed as follows:
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■ Click No to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

■ Click Yes to update the library controller database.

The Commit Success popup appears. 

Click OK to return to the Commit (Step 4) screen. 

7. All affected library host applications must now be configured to recognize these 
updates. See the appropriate tape management software documentation for the 
procedures and commands. 
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Partition Management Tasks

Task Page

Modify Partition Summary Information 226

Delete a Partition 228

Modify the Interface Type of a Host-Partition Connection 230

Modify FC-SCSI Host-Partition Connection Detail 232

Delete a FC-SCSI Host-Partition Connection 234

Refresh the SL Console Partition Workspace 236

Reallocate Library Resources 237

Make a Hardware Change to a Partitioned Library 238
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▼ Modify Partition Summary Information
Use this procedure to change the name or allocated storage capacity of an existing 
partition. 

Note – To change the host-partition connection type (HLI or FC-SCSI), see “Modify the 
Interface Type of a Host-Partition Connection” on page 230. 

Note – You cannot change the partition ID. To assign a different Partition ID, you must 
delete the old partition and create a new one with the new ID. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, select the partition you want to modify. 

3. Click Modify Partition.

The Modify a Partition popup appears.

4. Enter the changes you want to make. 
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5. Click OK to confirm the changes. 
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▼ Delete a Partition
Use this procedure to delete a partition from the library. The following changes are 
made to library partition configuration:

■ All resources allocated to the partition are marked available. 

■ All host connections for the partition are deleted. 

■ The partition ID is deleted. 

Caution – Deleting partitions can result in orphaned cartridges and data that could be 
lost. See “Orphaned Cartridges in Partitioned Libraries” on page 204 for details. 

Note – Deleting all partitions from the library causes the library state to change to 
“non-partitioned. ” All active storage cells, drives, and CAPs will be accessible to all 
hosts.

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, click the partition you want to remove.

3. Click Delete Partition.

A confirmation popup appears.

4. Click OK to confirm the deletion. 

■ If partitions still remain in the library, proceed to Step 7. 
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■ If no partitions remain, the Select Library Interface Type popup appears. 

5. Select the library interface type you want to assign for all host connections to the 
library. Options are:

■ HLI

■ FC-SCSI

6. Click OK to confirm the change. 

7. The updates are made as follows:

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 218 and “Commit Partition 
Configuration Changes” on page 222. 

If there are no partitions remaining in the library, when you commit the updates the 
library state will change to “non-partitioned”. 
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▼ Modify the Interface Type of a Host-Partition 
Connection 
Use this procedure to change the host-partition connection type of an existing partition. 
You should use this procedure with caution, due to the following possible effects:

■ Changing the interface type can result in the loss of active host connections. 

■ Changing the interface type from FC-SCSI to HLI can result in the loss of FC-SCSI 
connection detail. 

■ Because CAPs cannot be shared across partition types, changing the interface type 
can result in the loss of existing shared CAP assignments. Dedicated CAP 
assignments are not affected. 

Note – To change the name or allocated storage capacity of an existing partition, see 
“Modify Partition Summary Information” on page 226. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, click the partition you want to modify. 
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3. Click Modify Partition.

The Modify a Partition popup appears.

4. In the Interface Type pull-down, select the interface type you want to assign. Click 
OK.

5. The SL Console checks the current partition configuration in the SL Console 
workspace. If the partition has shared CAP allocations or, in the case of FC-SCSI 
partitions, host-partition connection detail, warning popups will appear. Following 
are sample popups that may appear. 

■ Changing from HLI to FC-SCSI:

■ Changing from FC-SCSI to HLI:

6. Click Yes to confirm the change. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 218 and “Commit Partition 
Configuration Changes” on page 222. 
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▼ Modify FC-SCSI Host-Partition Connection Detail

Note – This procedure applies to FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details. 

Use this procedure to modify the host World Wide Port Name or LUN number of the 
library for a host-partition connection. 

Note – You cannot modify the target port number for the library; it is always “0”. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Summary section of the screen, click the partition for which you want to 
modify a connection. 

3. In the Connections section, click the host-partition connection you want to modify. 
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Note – If you select an HLI partition, all the buttons in the Details section of the screen 
are grayed out. 

4. Click Modify Connection.

The Modify a Connection popup appears.

5. Enter the changes you want to make. 

6. Click OK to confirm the changes. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 218 and “Commit Partition 
Configuration Changes” on page 222. 
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▼ Delete a FC-SCSI Host-Partition Connection 

Note – This procedure applies to FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details. 

Use this procedure to delete a host-partition connection. After you perform this 
procedure, the host will no longer be able to access the partition. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Summary section of the screen, click the partition for which you want to 
delete a connection. 

Note – If you select an HLI partition, all the buttons in the Details section of the screen 
are grayed out. 

3. In the Connections section, click the host-partition connection you want to delete.
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4. Click Delete Connection.

A confirmation popup appears.

5. Click OK to confirm the deletion. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 218 and “Commit Partition 
Configuration Changes” on page 222. 
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▼ Refresh the SL Console Partition Workspace
Use this procedure to refresh the SL Console partition workspace with current data 
from the library controller database. The current data includes all updates that other 
users have made to the library controller database during your login session, through 
the command line interface, other SL Console sessions, or host applications. 

Note – After you complete this procedure, all uncommitted partition changes you have 
made during this SL Console login session are discarded. 

1. Select Tools > Partitions.

2. Click one of the following tabs:

■ Summary (Step 2) 

■ Design (Step 3b)

The selected screen appears.

3. In the Options Bar, click Refresh. 

The Partition Refresh popup appears.

4. Click Yes to confirm the refresh. 

All partition screen data is updated with current data from the library controller 
database. 
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▼ Reallocate Library Resources 
Reallocating library resources (storage cells, tape drives, CAPs, or cartridges) from one 
partition to another is done through the Design (Step 3b) screen. You must use the 
following two-step process: 

1. Remove the resource from the partition it is currently allocated to.

2. Allocate the resource to a different partition. 

See “Design a Partition” on page 215 for detailed instructions.

Caution – Reallocating resources can result in orphaned cartridges and data that could 
be lost. See “Orphaned Cartridges in Partitioned Libraries” on page 204 for details. 
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▼ Make a Hardware Change to a Partitioned Library
Some library hardware changes, such as adding expansion modules, adding a second 
robot, or adding CAP cells, may require the removal of all or part of an existing 
partitioned module. Use the following process to make such hardware changes without 
losing partitioning information for the sections of the library that are unchanged. 

Caution – Failure to follow this procedure could result in the loss of library partition 
configuration information after a hardware change. 

1. De-allocate all library resources (storage cells, CAPs, and drives) that will be 
removed as part of the hardware change from the partitions they are currently 
allocated to. 

See “Design a Partition” on page 215 for detailed instructions.

2. Power down the library. 

See “Power Down the Library” on page 385 for detailed instructions. 

3. Install the hardware change.

4. Power up the library. 

See “Power Up the Library” on page 386 for detailed instructions. 

All partition allocations for the unchanged parts of the library remain in effect.

5. Allocate the library resources that have been added due to the hardware change. 

See “Design a Partition” on page 215 for detailed instructions.

Caution – Reallocating resources can result in orphaned cartridges and data that could 
be lost. See “Orphaned Cartridges in Partitioned Libraries” on page 204 for details. 
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Partition Report Tasks

Task Page

Display a Partition Report 240

Print Partition Report Data 242

Save Partition Report Data 243
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▼ Display a Partition Report 
Use this procedure to display any of the following partition reports:

■ Cartridge Cell and Media Summary—Displays a detailed list of all resource partition 
assignments.

■ Host Connections Summary—Displays detailed host-partition connection 
information for all partitions.

■ Orphaned Cartridge Report—Displays a detailed list of all orphaned cartridges.

■ Partition Details—Displays detailed information for a selected partition.

■ Partition Summary—Displays summary information for all partitions.

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.
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2. In the pull-down menu, select the report you want to display. 

The screen is updated with current data from the library controller database. 

3. If you want to print the report data or save it to a file, see the following procedures:

■ “Print Partition Report Data” on page 242

■ “Save Partition Report Data” on page 243 
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▼ Print Partition Report Data
Use this procedure to print a partition report. This procedure can be performed from 
any of the partition report screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Print. 

The Print popup appears. 

4. Complete the print popup, and click Print. 

The report is printed to the selected printer. 
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▼ Save Partition Report Data
Use this procedure to save partition report data to a comma-separated file (.csv 
format). You can use a variety of spreadsheet applications to view the file. This 
procedure can be performed from any of the partition report screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Save to File.

The Save popup appears. 

4. Browse to the directory where you want to save the file, and enter the file name. 

5. Click Save. 

The data is saved to the specified file. 



CAP Operation Tasks

244 SL3000 User’s Guide • April 2008 Revision: A • 316194401

CAP Operation Tasks 

Task Page

Associate an FC-SCSI Partition to Its Shared CAPs 245

Enter Cartridges Into a Partition 247

Eject Cartridges From a Partition 248

Remove a Partition-CAP Association 249

Override a CAP Reservation 250



CAP Operation Tasks

316194401 • Revision: A Chapter 6 Library Partitioning 245

▼ Associate an FC-SCSI Partition to Its Shared CAPs
Use this procedure to associate an FC-SCSI partition to its shared CAPs. You must use 
this procedure prior to entering or ejecting cartridges from an FC-SCSI partition if 
BOTH of the following conditions are true:

■ The partition shares one or more CAPs with other partitions, and 

■ the FC-SCSI host application does not use CAP reservations and prevent/allow 
commands.

Note – This procedure should not be used for HLI partitions because HLI host 
applications always use CAP reservations. If you use this procedure for HLI partitions, 
the CAP will be made unavailable to ACSLS and HSC hosts. 

Note – This procedure is not necessary for dedicated FC-SCSI CAPs because a partition 
always has ownership of its dedicated CAPs. 

This procedure gives the partition exclusive ownership of its shared CAPs until you 
explicitly remove the association. See “Remove a Partition-CAP Association” on 
page 249 for details. 

1. Select Tools > Shared CAP Assignment. 

The Shared CAP Assignment screen appears.

2. Click the checkbox of the partitions into which you want to enter cartridges. See 
“Shared CAP Assignment” on page 312 for details on these screen fields. 
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3. Click Apply. 

The CAP Confirm popup appears. 

4. Click OK. 

5. Perform the enter or eject operation. See one of the following procedures for details:

■ “Enter Cartridges Into a Partition” on page 247

■ “Eject Cartridges From a Partition” on page 248
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▼ Enter Cartridges Into a Partition
Use this procedure to enter cartridges into one or more partitions. Partitions can use 
only the CAPs allocated to them. 

Note – If you are entering cartridges into an FC-SCSI partition that has one or more 
shared CAPs and the host application does not use CAP reservations and 
prevent/allow commands, you must associate the partition to its CAPs before 
beginning this procedure. See “Associate an FC-SCSI Partition to Its Shared CAPs” on 
page 245. Failure to do this may cause the CAP to remain locked and may prevent the 
partition from acquiring ownership of the CAP. 

1. Initiate the enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

2. Push the CAP button to open the CAP. 

The CAP door opens. 

3. Place the cartridges in the CAP.

4. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

5. The TallBot audits the CAP and then moves the cartridges from the CAP to storage 
slots within the appropriate partition. 

The CAP light may come back on after the audit is complete. When all cartridges have 
been moved from the CAP, the library recognizes that the CAP is empty. 

6. The CAP reservation is released, as follows:

■ If you initiated this procedure from an HLI host or an FC-SCSI host that uses CAP 
reservations, the host removes the reservation, making the CAP available to other 
partitions. 

■ If prior to performing this procedure you performed a manual partition-CAP 
association, you can now remove the association if the partition is finished with the 
CAP. See “Remove a Partition-CAP Association” on page 249 for details. 

■ If the FC-SCSI partition uses a dedicated CAP, the CAP remains unlocked and 
reserved to the partition. 



CAP Operation Tasks

248 SL3000 User’s Guide • April 2008 Revision: A • 316194401

▼ Eject Cartridges From a Partition
Use this procedure to eject cartridges from a partitioned library. Partitions can use only 
the CAPs allocated to them. 

Note – If you are ejecting cartridges from an FC-SCSI partition that has one or more 
shared CAPs and the host application does not use CAP reservations, you must 
associate the partition to its CAPs before beginning this procedure. See “Associate an 
FC-SCSI Partition to Its Shared CAPs” on page 245. Failure to do this may cause the 
CAP to remain locked and may prevent the partition from acquiring ownership of the 
CAP. 

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

2. The TallBot places the cartridges into one or more CAPs assigned to the host. 

3. Push the CAP button to open the CAP. 

The CAP door opens. 

4. Remove the cartridges from the CAP.

5. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

6. The TallBot audits the CAP to verify that it is empty.

The CAP light may come back on after the audit is complete.

7. The CAP reservation is released, as follows:

■ If you initiated this procedure from an HLI host or an FC-SCSI host that uses CAP 
reservations, the host removes the reservation, making the CAP available to other 
partitions. 

■ If prior to performing this procedure you performed a manual partition-CAP 
association, you can now remove the association if the partition is finished with the 
CAP. See “Remove a Partition-CAP Association” on page 249 for details. 

■ If the FC-SCSI partition uses a dedicated CAP, the CAP remains unlocked and 
reserved to the partition. 
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▼ Remove a Partition-CAP Association
Use this procedure after completing an enter or eject operation if you have previously 
associated the partition to its shared CAPs. This procedure removes the partition-CAP 
associations previously set, making the shared CAPs available to other partitions. 

1. Select Tools > Shared CAP Assignment. 

The Shared CAP Assignment screen appears.

2. Clear the checkbox of the partitions with the CAP associations. See 
“Shared CAP Assignment” on page 312 for details on these screen fields. 

3. Click Apply. 

The CAP Confirm popup appears. 

4. Click OK. 
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▼ Override a CAP Reservation
Use this procedure when a partition has reserved a shared CAP but the reservation 
cannot be released through the ACSLS or HSC host. 

Note – This topic applies to partitioned libraries only. If a library is not partitioned, 
CAP reservations must always be released through ACSLS or HSC. See the ACSLS or 
HSC documentation for details.

Note – You must follow all steps in this procedure. If you do not complete the 
procedure, the CAP could be left unavailable to all partitions, and/or cartridges 
assigned to one partition could be entered into another partition. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, and click the CAP whose reservation you want to override 
(unreserve). 

3. Click the Unreserve tab.

The Unreserve screen appears, identifying the partition that has reserved the CAP.



CAP Operation Tasks

316194401 • Revision: A Chapter 6 Library Partitioning 251

4. Click Apply to override the reservation.

The Unreserve Confirm popup appears, indicating “This will remove the reservation 
from the designated host...” 

■ Click OK to continue with the override operation. The library removes the CAP 
reservation and sets the CAP user to “default,” which makes the CAP unavailable to 
all partitions.

■ Click Cancel to cancel the override operation and return to Step 3. 

5. If the CAP is locked, unlock it at the SL Console. See “Unlock and Open a CAP” on 
page 95 for the detailed procedure. 

6. Push the CAP button to open the CAP. 

■ If it is empty, proceed to Step 8. 

■ If it contains cartridges, remove them all. 

7. Label the cartridges with the partition ID displayed in Step 3. 

8. Push the CAP button to close the CAP. 

The CAP closes and locks automatically, and the CAP button light turns off.

The library audits the CAP to verify that it is empty. It then sets the CAP status to 
“unreserved,” which makes the CAP available to all partitions it is allocated to. 

Note – You might need to refresh the CAP display to see the new CAP status. 

9. Contact a person responsible for managing the removed cartridges to determine their 
disposition. If they are to be re-entered into the library, they must be entered into the 
correct partition. 
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Partition Screen Reference
This section includes detailed descriptions of all SL Console partition screens, arranged 
by screen navigation path. For example, 
Partitions—Summary (Step 2)—Add Connection indicates the screen accessed by 
clicking Tools and then Partitions from the Menu Bar, and then clicking the Summary 
(Step 2) tab, and then the Add Connection button. 

Note – Only the Partitions—Current Partition Definitions screen is available on the 
local operator panel. The remaining screens can be accessed only from the standalone 
SL Console or the Web-launched SL Console.

Partition Screens are organized into the following categories:

■ “Partition Summary Screens” on page 253

■ “Partition Design and Commit Screens” on page 272

■ “Partition Report Screens” on page 292

■ “Partition CAP Operation Screens” on page 311

Note – The partition Summary (Step 2) and Design (Step 3b) screens, and all 
associated popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 
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Partition Summary Screens

Partitions—Instructions (Step 1)

Partitions—Summary (Step 2)

Partitions—Summary (Step 2)—Add Connection

Partitions—Summary (Step 2)—Delete Connection

Partitions—Summary (Step 2)—Modify Connection

Partitions—Summary (Step 2)—Add Partition

Partitions—Summary (Step 2)—Delete Partition

Partitions—Summary (Step 2)—Modify Partition
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Partitions—Instructions (Step 1)

Sample Screen

Description
Displays instructions for using the partition screens.

Note – This screen appears automatically the first time you select Tools > Partitions 
during an SL Console login session. 

Screen Fields
None

Buttons
? (Help) 

Click to display online help for the screen. 
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See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4) 

■ Partitions—Reports 
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Partitions—Summary (Step 2)

Sample Screen

Description
Displays summary information for the library and, optionally, a selected partition. 

Also includes buttons that allow you to initiate any of the following activities:

■ Add a new partition 

■ Delete a partition from the library

■ Modify partition summary information 

Note – The following buttons are available for FC-SCSI host-partition connections 
only. HLI host-partition connections are configured through the host library 
management software (HSC or ACSLS), not through the SL Console. See the HSC or 
ACSLS documentation for details. 

■ Add a new host-partition connection

■ Delete a host-partition connection

■ Modify the configuration of a host-partition connection
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Screen Fields

Partition Summary

Partition Number

Display only.

ID assigned to the partition. IDs can range from 1–8.

Allocated Storage Cells

Display only.

Total number of storage cells allocated to this partition. 

Allocated Drive Bays

Display only.

Total number of tape drives allocated to this partition. 

Allocated CAPs 

Display only.

Total number of CAPs allocated to this partition; this number represents whole 
CAPs, not individual CAP cells. 

Allocated CAP Cells

Display only.

Total number of individual CAP cells allocated to this partition. 

% Allocated Licensed Capacity 

Display only.

Percentage of the library’s licensed capacity that has been allocated to this partition. 
Calculated as:

(partition) Allocated Storage Cells / (total library) Licensed Capacity 

Details for Partition n 

Note – The following fields display host-partition connection information for the 
partition currently selected in the Partition Summary table. 

Name

Display only.

Name assigned to the selected partition. 

Interface Type 

Display only.

Type of interface assigned to the selected host-partition connection. Options are:

■ HLI

■ FC-SCSI
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Note – The following fields are available for FC-SCSI host-partition connections only. 

Initiator (WWPN) 

Display only.

World Wide Port Name of the FC-SCSI host bus adapter (HBA). 

Target Port 

Display only.

Port number of the SL3000 library controller. This entry is always “0”. 

LUN

Display only.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. 

TOTAL LIBRARY RESOURCES

Storage Cells  

Display only.

Total physical capacity of the library.

Drive Bays  

Display only.

Total number of tape drives in the library.

CAPs 

Display only.

Total number of CAPs in the library.

CAP cells

Display only.

Total number of CAP cells in the library.

Licensed Capacity 

Display only.

Total licensed storage capacity of the library. 

RESOURCES ALLOCATED

Storage Cells  

Display only.

Total number of storage cells allocated to all library partitions in the 
Design (Step 3b) screen. 

Drive Bays  

Display only.

Total number of tape drives allocated to all library partitions.
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CAPs 

Display only.

Total number of CAPs allocated to all library partitions.

CAP cells

Display only.

Total number of CAP cells allocated to all library partitions.

Licensed Capacity 

Display only.

Total licensed storage capacity assigned to all library partitions through the 
Add Partition or Modify Partition screen. 

RESOURCES  UNALLOCATED

Storage Cells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays  

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAPs 

Display only.

Total number of CAPs in the library that are not allocated to any library partition.

CAP cells

Display only.

Total number of CAP cells in the library that are not allocated to any partition.

Licensed Capacity 

Display only.

Total licensed storage capacity not assigned to any library partition through the 
Add Partition or Modify Partition screen. Calculated as:

(total library) Licensed Capacity – (allocated) Licensed Capacity 

Buttons
Refresh 

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help)

Click to display online help for the screen. 
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Add Partition

Click to add a new partition. The Partitions—Summary (Step 2)—Add Partition 
popup appears. 

Delete Partition

Click to delete the currently selected partition. The Partitions—Summary 
(Step 2)—Delete Partition popup appears. 

Modify Partition

Click to modify summary information for the currently selected partition. The 
Partitions—Summary (Step 2)—Modify Partition popup appears. 

Note – The following buttons are available for FC-SCSI host-partition connections 
only. 

Add Connection

Click to add a new host connection to the currently selected partition. The 
Partitions—Summary (Step 2)—Add Connection popup appears. 

Delete Connection

Click to delete the currently selected host-partition connection. The 
Partitions—Summary (Step 2)—Delete Connection popup appears.

Modify Connection

Click to modify the configuration of the currently selected host-partition connection. 
The Partitions—Summary (Step 2)—Modify Connection popup appears.

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Summary (Step 2)—Add Partition 

■ Partitions—Summary (Step 2)—Delete Partition 

■ Partitions—Summary (Step 2)—Modify Partition 

■ Partitions—Summary (Step 2)—Add Connection 

■ Partitions—Summary (Step 2)—Delete Connection 

■ Partitions—Summary (Step 2)—Modify Connection 

■ Partitions—Module Map (Step 3a) 

■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4) 

■ Partitions—Reports 
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Partitions—Summary (Step 2)—Add Connection

Sample Screen

Description
Allows you to configure the connection between a host and the selected partition. Each 
partition can have up to nine host-partition connections, each one having a unique 
LUN. 

Note – This screen is available for FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details.

This screen is a popup that appears when you click Add Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Connections n 

Display only.

Partition ID of the selected partition. 

Initiator (WWPN)

Required.

World Wide Port Name of the FC-SCSI host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 
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Target Port

Display only.

Port number of the SL3000 library controller. This entry is always “0”. 

LUN

Required.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. You can create up to nine unique LUNs per partition. 

Note – Each initiator connected to the library must have one library partition assigned 
to LUN 0. When you verify or commit partition configuration changes, the SL Console 
will notify you if an initiator does not meet this requirement. 

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Delete Connection

Sample Screen

Description
Allows you to delete the selected host-partition connection. 

Note – This screen is available for FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details.

This screen is a popup that appears when you click Delete Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
None

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 
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See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Modify Connection

Sample Screen

Description
Allows you to modify the configuration of the selected host-partition connection. 

Note – This screen is available for FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details.

This screen is a popup that appears when you click Modify Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Connections n 

Display only.

Partition ID of the selected partition. 

Initiator (WWPN)

World Wide Port Name of the FC-SCSI host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 
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Target Port

Display only.

Port number of the SL3000 library controller. This entry is always “0”. 

LUN

Required.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. 

Note – Each initiator connected to the library must have one library partition assigned 
to LUN 0. When you verify or commit partition configuration changes, the SL Console 
will notify you if an initiator does not meet this requirement. 

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Add Partition 

Sample Screen

Description
Allows you to add a new partition. You can create up to eight partitions, with IDs 
ranging from 1–8. 

This screen is a popup that appears when you click Add Partition on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Select a Partition ID

Required.

Partition ID you want to add. Options are 1–8. 

The drop-down menu displays all available IDs; the default is the next available ID 
in numerical order. 

Name 

Optional.

Name you want to assign to the partition. 

0–60 ASCII characters. 

Interface Type 

Required.

Type of interface to be used for this host-partition connection. Options are:

■ HLI

■ FC-SCSI 
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Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Delete Partition

Sample Screen

Description
Allows you to confirm that you want to delete the specified partition. All information 
for the partition—including host-partition connections, partition boundaries, and 
partition ID—are deleted from the SL Console partition workspace. 

This screen is a popup that appears when you click Delete Partition on the 
Partitions—Summary (Step 2). 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
None

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Modify Partition

Sample Screen

Description
Allows you to modify the name or host-partition connection type assigned to the 
selected partition. 

This screen is a popup that appears when you click Modify Partition on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Modify Partition n 

Display only.

ID of the partition you want to modify. 

Name 

Name you want to assign to the partition. 

0–60 ASCII characters. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

Interface Type 

Type of interface to be used for this host-partition connection. Options are:

■ HLI

■ FC-SCSI 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 
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Note – Changing the interface type can result in the loss of active host connections and 
shared CAP allocations. See “Modify the Interface Type of a Host-Partition 
Connection” on page 230 for details. 

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partition Design and Commit Screens

Partitions—Design (Step 3b)

Partitions—Design (Step 3b)—Verify Results

Partitions—Commit (Step 4)

Partitions—Commit (Step 4)—Confirm Apply

Partitions—Current Partition Definitions
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Partitions—Module Map (Step 3a)

Sample Screen

Description
Allows you to select the library module for which you want to define partition 
boundaries. 

Screen Fields
Select a module from the map below 

Required.

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

Click the module for which you want to design a partition, then click the 
Design (Step 3b) tab. 
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Buttons
? (Help)

Click to display online help for the screen. 

See Also
■ Partitions—Design (Step 3b) 
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Partitions—Design (Step 3b)

Sample Screen

Description
Allows you to define partition boundaries by selecting the resources (storage cells, tape 
drives, or CAPs) you want to include in the partition. You can use any of the following 
methods to add or remove resources from a partition (see “Library Map” on page 279 
for detailed instructions): 

■ Select individual cells or groups of cells 

■ Select an entire column within a library module (top to bottom) 

■ Select a side within a library module (front or back) 

■ Select an entire library module

Note – This screen is available only if partitions have been defined for the library 
through the Partitions—Summary (Step 2)—Add Partition screen. 
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Caution – Changing partition boundaries can result in orphaned cartridges and data 
that could be lost. See “Orphaned Cartridges in Partitioned Libraries” on page 204 for 
details. 

Note – The partition Summary (Step 2) and Design (Step 3b) screens, and all 
associated popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Partition

Required.

Partition to which you want to add or remove resources (storage cells, tape drives, 
or CAPs). 

The drop-down menu displays all valid partition IDs for the library. It also identified 
their host interface type (FC-SCSI or HLI). If no partition IDs have been defined, the 
menu is blank. 

Note – When you select a partition, the screen is automatically updated to display data 
for that partition from the SL Console partition workspace. 

Select by

Required.

Indicates the method you want to use for defining partition boundaries. Options are:

■ Cell—Select individual or rectangular groups of resources.

■ Column—Select all resources within a column. 

■ Side—Select all resources, except the CAP, within one side of a library module. 

■ Module—Select all resources, except the CAP, within a library module. 

Note – You must select either Add or Remove. 

Add 

Required.
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Indicates you want to add resources to the partition. You will only be able to click 
unallocated resources on the library map. 

Remove

Required.

Indicates you want to remove resources from the partition. You will only be able to 
click allocated resources on the library map. 

Allocated to Partition n 

Note – The data in these fields is automatically updated from the SL Console partition 
workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells allocated to the selected partition, based on the 
currently defined partition boundaries. 

Drive Bays

Display only.

Total number of tape drives allocated to the selected partition, based on the 
currently defined partition boundaries. 

CAP Cells

Display only.

Total number of CAP cells allocated to the selected partition, based on the currently 
defined partition boundaries. 

Unallocated in Library 

Note – The data in these fields is automatically updated from the SL Console partition 
workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAP Cells

Display only.

Total number of CAP cells in the library that are not allocated to any partition.
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Licensed Capacity 

Note – This field appears only if the library has unallocated licensed capacity. If 
allocations exceed licensed capacity (an oversubscription situation), the 
Oversubscription field appears. 

Display only.

Total licensed capacity of the library that is not allocated to any partition. Calculated 
as:

Total licensed capacity – Total allocated storage cells 

Oversubscription 

Note – This field appears only if allocations exceed licensed capacity (an 
oversubscription situation). If the library has unallocated licensed capacity, the 
Licensed Capacity field appears. 

Display only.

Total licensed capacity of the library that has been exceeded through partition 
allocations. Calculated as:

Total allocated storage cells – Total licensed capacity 

You must remove the excess allocations before you can commit your changes 
through the Commit (Step 4) screen. 

Legend 
Legend for the library map. The state of each library resource (storage cell, tape 
drive, or CAP cell) is indicated as follows: 

■ Not Accessible (white and x-ed out). Resource is not accessible to any partition. 
Following are some possible reasons:

- Storage cells have been configured for diagnostic cartridges. 

- Storage cells are not included in the library’s licensed capacity. 

■ Unallocated. Resource is currently not allocated to any partition and therefore 
available to the selected partition. 

■ Partition n (gold). Resource is allocated to the selected partition, partition n. 

■ Other Partitions (red). Resource is allocated to another partition and therefore 
NOT available to the selected partition. 

■ Shared CAP (gray background). CAP has been assigned to at least one partition. 
The host interface type assigned to the CAP (HLI or SCSI) is displayed.

■ Cartridge (cartridge icon). Resource contains a tape cartridge. 

■ Drive slots with installed drives are outlined with a thick border. Empty drive 
slots have a narrow border. 
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Library Map 
Graphical representation of the current library configuration. Initial display for the 
current SL Console login session is from the library controller database, then the 
display reflects data from the SL Console partition workspace as you modify 
partition configurations. The display includes the following information:

■ Type of module currently displayed (base module, drive expansion module, 
parking expansion module) 

■ Numeric module ID (1–12)

■ Location of all resources (storage cells, tape drives, CAP cells) within the library 

■ Partition-host connection type of a shared CAP 

Note – Move the cursor over any resource to display a tooltip of detailed information 
about the cell or drive, its partition assignment, and the identity of any resident 
cartridge. 

Note – If no partition IDs have been defined, the library map is display only.

Use the library map to modify the boundaries of the selected partition. Depending 
on whether you have clicked the Add or Remove radio button, all selected resources 
are either added to or removed from the partition. 

Depending on your choice in the Select by field, you can perform any of the 
following actions. 

■ Select by cell—Select individual or groups of resources. Resources in a partition 
do not need to be adjacent to one another. 

- To select an individual resource, double-click it.

- To select a rectangular group of resources, click the cell or drive at one corner 
of the rectangle, and then click the cell or drive diagonally opposite. 

■ Select by column—Select an entire column within the module. Columns in a 
partition do not need to be adjacent to one another. To select a column, click any 
resource within the column. 

■ Select by side—Select an entire side within a module, except the CAP. Sides in a 
partition do not need to be adjacent to one another. To select one side of a library 
module, click any resource in that side. 

■ Select by module—Select an entire module, except the CAP. Modules in a 
partition do not have to be adjacent to one another. To select a library module, 
click any resource in that module. 

Buttons
Move Left 

Click to display the library module directly to the left of the one currently displayed. 
This button is grayed out if there is no module to the left. 

Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 



Partition Design and Commit Screens

280 SL3000 User’s Guide • April 2008 Revision: A • 316194401

Verify 

Click to verify partition configuration changes you have made during this 
SL Console login session. The Tools > Partitions—Design (Step 3b)—Verify Results 
popup appears, indicating whether there are any orphaned cartridges or other errors 
in the current partition configuration.

Note – This procedure verifies only one partition at a time. If you need to verify 
multiple partitions, you must repeat this procedure separately for each partition. 

Note – This verification is performed on the current partition configuration in the 
SL Console partition workspace only. It does not verify current partition boundaries 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made partition changes. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Module Map (Step 3a)

■ Partitions—Design (Step 3b)—Verify Results 

■ Partitions—Commit (Step 4) 

■ Partitions—Current Partition Definitions 

■ Partitions—Reports 
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Partitions—Design (Step 3b)—Verify Results

Sample Screen

Description
Displays a list of configuration errors in the current SL Console partition workspace. 

This screen is a popup that appears when you click Verify Results on the 
Partitions—Design (Step 3b) screen. 

Possible errors include:

■ A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” for details.

■ Library resources have been removed from a partition. 

■ A host-partition connection does not have a partition assigned to LUN 0 (applies to 
FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the library 
controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 
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Note – The partition Summary (Step 2) and Design (Step 3b) screens, and all 
associated popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields

Note – The screen fields are the same as those displayed in the Partitions—Commit 
(Step 4)—Confirm Apply popup. 

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The library is oversubscribed. Please unallocate nnn storage cells. 

Display only.

Indicates that the total partition allocations currently exceed the library’s licensed 
capacity. nnn is the number of cells you must remove from partition allocations. The 
Apply button on the Commit (Step 4) screen remains deactivated until the total 
allocated cells is within the library’s licensed capacity. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. This error applies to FC-SCSI host-partition 
connections only. 

The following orphaned cartridges were found

Display only.
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Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the cartridge, 
cartridge volume serial number (volid), and probable causes and explanations why 
the cartridge is orphaned. 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

OK

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning message 
display. 

See Also
■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4)—Confirm Apply 
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Partitions—Commit (Step 4)

Sample Screen

Description
Allows you to commit all data from the current SL Console partition workspace to the 
library controller database. The following data will be committed for all partitions: 

■ Partition summary information 

■ Host-partition connection configuration information 

■ Partition boundary details 

Caution – For the following reasons, it is recommended that you make the library 
unavailable to other users before committing your partition workspace changes. 
 
There is no real-time validation of partition boundaries against the library controller 
database; therefore if you do not make the library unavailable and other users are 
performing cartridge movements or library configuration changes, configuration 
conflicts may arise. See “Synchronizing the Display With the Controller Database” on 
page 35 for details.  
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The library temporarily drops all connections to HSC or ACSLS hosts when partition 
configurations changes are committed. The hosts will automatically reconnect, but 
multiple error messages will be displayed, and cartridge management tasks in progress 
may fail.

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Caution – It is recommended that you follow the Resolve Orphaned Cartridges 
procedure before using this screen. 

Caution – This screen updates the library controller database with all partition 
configuration changes you have made during this SL Console session. Failure to use 
this screen before logging out of the current SL Console session will cause all your 
library configuration changes to be lost.

Screen Fields
None 

Buttons
Apply

Click to update the library controller database with the current settings from the 
SL Console partition workspace. The Tools > Partitions—Commit 
(Step 4)—Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the current partition configuration. 

Note – This button is grayed out if total partition allocations currently exceed the 
library’s licensed capacity. To activate the button, you must remove storage cells from 
partition allocations to bring the total allocated cells within the library’s licensed 
capacity.

Note – This button is grayed out if you have not made any changes to the SL Console 
partition workspace since the last commit. 

? (Help) 

Click to display online help for the screen. 
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See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Design (Step 3b) 

■ Partitions—Design (Step 3b)—Verify Results 

■ Partitions—Commit (Step 4)—Confirm Apply 

■ Partitions—Reports 
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Partitions—Commit (Step 4)—Confirm Apply

Sample Screen

Description
Displays a list of configuration errors in the current SL Console partition workspace. 
This screen is a popup that appears when you click Apply on the 
Partitions—Commit (Step 4) screen. 

After viewing the error messages, you can commit all data in the SL Console partition 
workspace to the library controller database by clicking the Yes button. 

Possible errors include:

■ A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” for details.

■ Library resources have been removed from a partition. 

■ A host-partition connection does not have a partition assigned to LUN 0 (applies to 
FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the library 
controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 
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Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields

Note – The screen fields are the same as those displayed in the Partitions—Design 
(Step 3b)—Verify Results popup. 

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The library is oversubscribed. Please unallocate nnn storage cells. 

Display only.

Indicates that the total partition allocations currently exceed the library’s licensed 
capacity. nnn is the number of cells you must remove from partition allocations. The 
Apply button on the Commit (Step 4) screen remains deactivated until the total 
allocated cells is within the library’s licensed capacity. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. This error applies to FC-SCSI host-partition 
connections only. 

The following orphaned cartridges were found

Display only.

Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the cartridge, 
cartridge volume serial number (volid), and probable causes and explanations why 
the cartridge is orphaned. 

Buttons
Print

Click to print the report on a selected printer.
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Save 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Yes

Click to confirm that you want to update the library controller database with the 
current settings from the SL Console workspace. 

No

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning message 
display. 

See Also
■ Partitions—Commit (Step 4) 

■ Partitions—Design (Step 3b)—Verify Results 
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Partitions—Current Partition Definitions

Sample Screen

Description
Displays current partition boundaries and allocations. This is the only Partitions screen 
that is available on the local operator panel.

Note – This screen is display only. 

Screen Fields
For detailed descriptions of the screen fields, see “Partitions—Design (Step 3b)” on 
page 275. 
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Buttons
Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Design (Step 3b) 
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Partition Report Screens

Partitions—Reports

Partitions—Reports—Cartridge Cell and Media Summary

Partitions—Reports—Host Connections Summary

Partitions—Reports—Orphaned Cartridge Report

Partitions—Reports—Partition Details

Partitions—Reports—Partition Summary
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Partitions—Reports

Sample Screen

Description
Allows you to select one of the following library partition reports:

■ Cartridge Cell and Media Summary

■ Host Connections Summary

■ Orphaned Cartridge Report

■ Partition Details

■ Partition Summary

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 
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Screen Fields
Please select a report to display

Required.

Click the report you want to display. The drop-down menu lists all available library 
partition reports. 

Buttons
Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4) 

■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Cartridge Cell and Media 
Summary

Sample Screen

Description
Displays detailed information about all library resources (storage cells, tape drives, and 
CAP cells) and any stored cartridges.

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields
Library 

Display only.

Library number where the library resource is located. This is always “1”. 

Rail 

Display only.

Rail number where the library resource is located. This is always “1”. 

Column

Display only.

Column number where the library resource is located. Column location is referenced 
from the left edge of the Base Module. “+1” is to the right; “-1” is to the left.

Side

Display only.

Module side where the library resource is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the library resource is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Partition ID

Display only.

Partition ID to which the library resource is allocated, if applicable. 

Partition Name

Display only.

Name of the partition to which the library resource is allocated, if applicable. If the 
library has no defined partitions, “Non-Partitioned Library” is displayed. 

Element Type

Display only.

Type of library resource. Options are:

■ CAP
■ CELL
■ DRIVE

Vol Ser 

Display only.

Volume serial number (volid) of the cartridge resident in the library resource, if 
applicable. 

Cell Status

Display only.

Capacity status of the library resource. Applies to storage cells only. Options are:

■ Active—Cell is activated for use based on assigned capacity; can be used for 
cartridge storage. 
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■ Inactive—Cell is not activated for use; cannot be used for cartridge storage. 

Buttons
Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Host Connections Summary

Sample Screen

Description
Displays detailed information about all host-partition connections for the library. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields

Partitions

Note – The screen fields in this section also appear on the 
Partitions—Reports—Partition Summary report.

Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition. 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

■ HLI 

■ FC-SCSI 

Storage Cells 

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of tape cartridges resident in the partition’s storage cells. 

% Storage Cells w/ Media

Display only.

Percentage of storage cells containing tape cartridges. Calculated as Media in 
Storage Cells / Storage Cells. 

Drive Bays 

Display only.

Total number of drive bays allocated to the partition. 

CAP Cells 

Display only.

Total number of CAP cells allocated to the partition. 

Total Media 

Display only.

Total number of tape cartridges resident in the partition; includes cartridges in 
storage cells, CAPs, and drives assigned to the partition. 
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Active Cells

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Host Connections

Initiator WWPN

Display only.

World Wide Port Name of an FC-SCSI host bus adapter (HBA) with a connection to 
the partition. 

Library Controller Port

Display only.

Port number of the SL3000 library controller on the host. This entry is always “0”.

LUN

Display only.

Logical unit number of the library partition on the host.

Partition ID 

Display only.

Partition ID to which the host has a connection. 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Orphaned Cartridge Report 

Sample Screen

Description
Displays the locations and volume serial numbers (volids) of all orphaned cartridges in 
the library. Also identifies why the cartridge is orphaned. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields
Library 

Display only.

Library number where the orphaned cartridge is located. This is always “1”. 

Rail 

Display only.

Rail number where the orphaned cartridge is located. This is always “1”. 

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Vol Ser 

Display only.

Volume serial number (volid) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Because this report is produced from the library controller database, the only option 
is:

■ Unreachable from any host 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 
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Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Partition Details

Sample Screen

Description
Displays detailed information for a selected partition. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 
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You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields
Partition Name

Display only.

Name of the partition. 

Partition ID

Display only.

ID of the partition (1–8). 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

■ HLI 

■ FC-SCSI 

Assigned Cells 

Display only.

Total number of storage cells allocated to the partition.

Available Cells 

Display only.

Total number of storage cells in the library available for allocation to the partition.

Occupied Cells 

Display only.

Total number of storage cells in the partition with tape cartridges present.

Active (Capacity Licensed) Cells 

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Assigned Drive Bays 

Display only.

Total number of drive bays allocated to the partition.

Available Drive Bays 

Display only.

Total number of drive bays in the library available for allocation to the partition.

Occupied Drives 

Display only.

Total number of installed tape drives in the partition with tape cartridges present.



Partition Report Screens

306 SL3000 User’s Guide • April 2008 Revision: A • 316194401

Assigned CAP cells 

Display only.

Total number of CAP cells allocated to the partition through dedicated or shared 
CAPs. 

Available CAP cells

Display only.

Total number of CAP cells in the library available for allocation to the partition. This 
number includes all CAP cells in the following:

■ CAPs not allocated to any partition. 

■ CAPs not currently allocated to this partition, but allocated to other partitions 
with the same host interface type as this one. 

This number excludes all CAP cells in the following:. 

■ CAPs currently allocated to this partition.

■ CAPs allocated to partitions with a different host interface type. 

Occupied CAP cells

Display only.

Total number of storage cells in the partition with tape cartridges present.

% Cell Capacity (Assigned Cells/Total Cells) 

Display only.

Percentage of storage cells in the library allocated to this partition. Calculated as:

Number of cells allocated to the partition / Total physical capacity of the library 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 
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■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Partition Summary

Sample Screen

Description
Displays summary information for all partitions in the library. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 36 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields

Note – These screen fields also appear on the Partitions—Reports—Host Connections 
Summary report.

Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition. 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

■ HLI 

■ FC-SCSI 

Storage Cells 

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of tape cartridges resident in the partition’s storage cells. 

% Storage Cells w/ Media

Display only.

Percentage of storage cells containing tape cartridges. Calculated as Media in 
Storage Cells / Storage Cells. 

Drive Bays 

Display only.

Total number of drive bays allocated to the partition. 

CAP Cells 

Display only.

Total number of CAP cells allocated to the partition. 

Total Media 

Display only.

Total number of tape cartridges resident in the partition; includes cartridges in 
storage cells, CAPs, and drives assigned to the partition. 

Active Cells

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 
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Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Details 
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Partition CAP Operation Screens

Shared CAP Assignment

Diagnostics > CAP—Unreserve
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Shared CAP Assignment 

Sample Screen

Description
Allows you to perform partition-CAP associations prior to using a shared FC-SCSI CAP 
to enter or eject cartridges to or from a partition. Partition-CAP associations reserve the 
CAP for the exclusive use of the selected partition for the duration of the enter or eject 
operation. 

Note – This screen is not available if the library has no shared FC-SCSI CAPs. 
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The following rules apply when using this screen:

■ You need to use this screen for shared FC-SCSI CAPs only. 

■ You do not need to use this screen for dedicated CAPs because a partition always 
has ownership of its dedicated CAPs. 

■ You do not need to use this screen for HLI partitions because HLI host applications 
always use CAP reservations. 

■ You can associate only one partition at a time to a CAP. 

■ Selecting a partition causes all its allocated CAPs to be associated to it at once; you 
cannot select individual CAPs to be associated to the partition. 

■ You can select multiple partitions at once, as long as the selected partitions do not 
share any CAPs with one another. 

■ Partition-CAP associations remain active until you explicitly remove them; the 
associations are not automatically removed when the enter or eject operation 
completes. 

■ Partition-CAP associations are removed during library reboots, power cycles, library 
door open/close operations, or CAP initializations 

■ Partition-CAP associations are removed if the CAP becomes allocated to a different 
partition through the Design (Step 3b) screen. 

■ If a partition-CAP association is removed while the CAP is open or has cartridges in 
it, the CAP ownership will be changed to the “default” requester and the CAP will 
be unavailable to all partitions. You must empty and close the CAP before it can be 
associated to any partitions. 

See “Enter Cartridges Into a Partition” on page 247 and “Eject Cartridges From a 
Partition” on page 248 for complete details on using this screen in conjunction with the 
CAP Open button. 

Screen Fields
Select

Select one or more partitions for which you want to enter or eject cartridges, as 
follows: 

■ Click the checkbox to select the partition; the screen is updated as follows:

- All CAPs allocated to that partition are marked with the partition number on 
the module map.

- All other partitions sharing CAPs with that partition are grayed out. 

■ Clear the checkbox to de-select the partition. 

Partitions that are grayed out cannot be selected. A partition may be grayed out for 
any of the following reasons: 

■ No CAPs have been allocated to the partition.

■ The partition has an HLI host-connection type. 

■ The CAP is currently in use by another partition that shares the CAP.

■ The CAP is currently in use by the “default” user (library operator). 

Partition Name

Display only.

Name assigned to the partition. 
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Partition ID

Display only.

ID assigned to the partition. IDs can range from 1–8.

Connection Type 

Display only.

Type of interface assigned to the host-partition connection. Options are:

■ HLI

■ FC-SCSI

Library module map 

Display only.

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

The CAP allocations for each partition are indicated, as follows: 

■ An “X” in a library module column indicates the CAP in that module is allocated 
to the partition in that row.

■ No “X” in a library module column indicates the CAP in that module is not 
allocated to the partition in that row. 

Buttons
Apply

Click to update the library controller database with the current settings from this 
screen. The CAP Confirm popup appears, prompting you to confirm the update. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Design (Step 3b) 
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Diagnostics > CAP—Unreserve

Sample Screen

Description
Allows you to override a CAP reservation that has been initiated by a host. This causes 
the library controller to remove the CAP reservation and set the CAP user to “default,” 
which makes the CAP unavailable to all partitions. 

After overriding the reservation you will need to open the CAP and remove any 
cartridges. After you close the CAP, the library controller will lock and audit the CAP 
to verify that it is empty. It will then set the CAP status to “unreserved,” which makes 
the CAP available to all partitions.

Note – For FC-SCSI CAPs, overriding a CAP reservation breaks any partition-CAP 
association, even if the CAP is dedicated to the FC-SCSI partition. You must explicitly 
associate the partition to the CAP again before the partition can use the CAP.

See “Override a CAP Reservation” on page 250 for the detailed procedure. 
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Screen Fields
CAP CAP_id is status. 

Display only.

Status of the selected CAP. Possible options are:

■ reserved by host_name—A CAP operation has been initiated by the specified 
host; you can use this screen to unreserve the CAP.

■ reserved by default—A CAP operation has been initiated at the SL Console; 
you cannot use this screen to unreserve the CAP. 

■ not reserved—The CAP is not reserved; you do not need to unreserve the 
CAP. 

Module containing selected CAP is displayed below

Display only.

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

The CAP you have selected is marked by an arrow. 

Buttons
Apply

Click to override the host CAP reservation. The CAP Confirm popup appears, 
prompting you to confirm the update. 

Note – This button is active only if the CAP status is “reserved by host_name”. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Shared CAP Assignment
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CHAPTER 7

SL Console Diagnostics and Utilities

Library Events
The library controller continually monitors library operations and logs all events. 
Events are stored under three headings:

■ Communication events—Includes host-to-library, library-to-library, and library-to-
drive communications. 

■ Error event—Each error event is assigned a four-digit (hexadecimal) action code. 

■ Warning events—Indicate a loss of performance or conditions that may be indicative 
of future, fatal errors. 

Event Monitors
You or your Sun support representative can use the SL Console monitors to review 
library events. The following information can help to diagnose the cause of the event: 

■ Date/time stamp—Identifies when the event occurred. 

■ Action codes—Identifies the command that was issued, such as “load drive”.

■ Result codes—Identifies the result of the requested action. 

■ Known service plan (KSP) diagnosis—Identifies the mechanism or component 
responsible for the task or fault. 

Note – There is no option to clear the event log.
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Library Self-Tests 
The self-test diagnostic utility is intended to help diagnose basic problems with library 
operations and can be run whenever necessary. 

Note – The library self-test routines are non-disruptive.  

Library self-tests involve the following process:

1. Checks the communication path between the library controller, drives, and TallBot. 

2. Performs get and put operations to check the health of the TallBot, and CAP. This 
includes get and put operations from a reserved slot to a random empty:

■ Storage slot 

■ CAP slot

■ Corner slot

3. Performs a library audit. 

4. Performs mount and dismount of diagnostic cartridges for all the drives installed in 
the library.

Note – The self-test will not start unless a diagnostic cartridge is found in the reserved 
slots.

Note – The self-test is repeated for each drive type if a compatible diagnostic cartridge 
is found in the system slots. If a diagnostic cartridge is not found for a drive type, the 
mount/dismount operation is skipped for the drive.
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Library Firmware Upgrades
The library firmware resides on the library controller. The initial firmware is installed 
at the factory. When new firmware is released, you must use the code load utility to 
upgrade the firmware on the library and associated devices (CAP and TallBot). 

Note – Library firmware does not contain drive code upgrades.   

Firmware Download Sites
The SL3000 library firmware package is a .jar (Java Archive) file. is available for 
download at the following Sun Microsystems, Inc. sites:

Note – You must have a valid login ID and password for the download site you are 
using. Contact your Sun support representative for assistance. 

Firmware Installation Process
The process for loading firmware code on the library controller is as follows: 

1. Locate the firmware upgrade package (.jar file) on the appropriate Sun download 
site. See “Firmware Download Sites” on page 319, above. 

2. Download the code to a folder on your local PC or workstation. 

3. Download the firmware package from your PC to the library controller. This process 
also unpacks the package after downloading to make it ready for activation. See 
“Download Code to the Library Controller” on page 335. 

4. Activate the downloaded code on the library controller. See “Activate Code” on 
page 336. 

5. Reboot the library to make the code operational. See “Reboot the Library” on 
page 334. 

User Location Name URL

Sun Customers Sun Download Center http://www.sun.com/download/ind
ex.jsp

Sun Partners 
and OEMs

Sun Partner Exchange https://spe.sun.com/spx/control
/Login 
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Audits 
An audit is the process of reading and cataloging cartridges within a library, or 
verifying the locations of cartridges. The library controller maintains a cartridge 
database that contains the following information for all the cartridges in the library:

■ Volume serial numbers (VOLID or VOLSER) 

■ Current location (in library internal address format)

■ Verified status (true or false)

The library audits all cartridge locations in the storage and reserved areas at the 
following times:

■ After one or both access doors have been opened and closed. 

■ An audit request is made through the SL Console. 

■ A host request to audit the library is entered. 

You can use the SL Console to perform the following types of audits:

■ Physical Audit 

■ Verified Audit

Caution – System-level problems may occur if a host’s cartridge record does not match 
what is in the library controller cartridge database. 

Physical Audit
In a physical audit, the TallBot visits cartridge locations and verifies the VOLID of 
resident cartridges, and the library controller updates the cartridge database. This audit 
changes the “verified” status of the cartridge locations to “True.” Audit times vary 
according to the size of the library.

The library performs a physical audit at the following times. 

■ Automatically when a library access door has been opened and closed. This is 
always a full audit of the entire library. 

■ When initiated manually from the SL Console. There are two types of manually 
initiated physical audits:

■ Entire library audit—The TallBot visits all cells (storage, CAP, and drive), catalogs 
the VOLIDs and locations, and updates the library controller cartridge database. 
This audit is a background process and so does not interrupt online library 
operations. See “Audit the Entire Library” on page 341 for details. 

■ Specific range audit—The TallBot visits only a specific range of slots (storage, 
CAP, and drive) and updates the library controller cartridge database. The audit 
information is displayed on the SL Console while the audit is performed. See 
“Audit a Range of Cells” on page 343 for details.
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Verified Audit
A verified audit validates the status of a specific cartridge location or range of locations 
(including CAP and drives) in the cartridge database. If a cartridge address has a 
verified status of “false” then a physical audit of that location is performed and the 
cartridge database is updated. The progress of the audit is displayed in the Audit 
Console section of the SL Console. See “Perform a Verified Audit” on page 345 for 
details. 
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Robot Diagnostic Moves
Diagnostic moves are used to monitor or diagnose a problem with a TallBot. The move 
can be performed with or without cartridges. 

Successful diagnostic moves do not rearrange the cartridges in the storage cells; 
cartridges are returned to their original locations after the diagnostic move is 
completed. However, some diagnostic move failures can cause cartridges to be left in 
new locations. 

A diagnostic move involves the following elements:

■ Target Address Range

■ Pool Address Range

■ Move Access Order

■ Robot Selection

Target Address Range 
The target address range defines the location parameters in a library within which the 
get operation is performed in a diagnostic move. There are two types of access orders 
for a target address:

■ “Sequential Access Order” on page 323 

■ “Random Access Order” on page 323 

Following are valid target address types:

■ Storage cells—Reserves all the storage locations as the target range

■ CAP—Reserves the slots in the as the target/pool range.

■ Drive and Storage cells—Reserves all the drives and storage cells as the target/pool 
range.

■ System cells—Reserves the locations (reserved slots) containing the cleaning or 
diagnostic cartridges as the target/pool range. 

■ All—Reserves all storage cells, CAP and Drives as target/pool range.

Note – Selecting the Storage, CAP, drive, system, or All option does reserve all the 
associated locations as the target range. However, only the location currently being 
accessed by the TallBot for a get/put operation is unavailable to the host.

Pool Address Range
The pool address range locations are used to supply cartridges required for diagnostic 
moves to and from the target address range. A pool address is also used in a get 
operation if a target address does not contain a cartridge. There is no specified access 
order within the pool address range. The pool address ranges does not include drive 
locations.
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Note – The pool address ranges cannot contain drive locations.

Move Access Order

Sequential Access Order
In a sequential access order diagnostic move, the TallBot performs a get operation 
starting with the first location in the target address ranges and then continues visiting 
the locations sequentially through the range until it completes the requested number of 
moves. 

Note – If you choose not to move cartridges the get/put operations are not performed. 
The TallBot just positions itself at the target and pool addresses.

Random Access Order
In a random access order diagnostic move, the TallBot randomly picks a location in the 
target address range to get a cartridge. The TallBot can also visit the same location in 
the in the target address range multiple times to get a cartridge. The random access 
routine ends after the requested number of moves is complete. 

If you choose not to move cartridges the get/put operations are not performed. The 
TallBot just positions itself at the target and pool addresses. 

Robot Selection
The TallBot for the diagnostic move is selected based on the minimum and maximum 
ranges you set for the target and pool addresses. 

Diagnostic Move Control Functions
The following options are available to manage the moves currently open:

To Select Menu Option Notes

Start  File > Start Sequence

Pause  File > Pause Sequence Stops all diagnostic moves, but 
maintains the current location in the 
access order.

Stop   File > Stop Sequence Stops a running or paused exerciser.

Resume File > Start Sequence Resumes a paused exerciser starting 
with the last known location in the 
target address range.
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Note – If multiple diagnostic moves are open, then each move has its own monitor 
screen.

Clear the messages 
displayed in the monitor 
window

File > Clear Output Window Erases the previous message lines and 
continues to fill the screen with new 
messages.

Spool Spool File > Start Spooling Directs the move output to a file.

Stop spooling the exerciser 
output to a file

Spool File > Stop Spooling Stops directing the move output to the 
spool file.

To Select Menu Option Notes
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Diagnostic and Utility Tasks 
Library diagnostic and utility tasks are divided into the following categories:

■ “Event Monitor Tasks” on page 326

■ “Library Utility Tasks” on page 332

■ “Audit Tasks” on page 340

■ “CAP Utility Tasks” on page 347

■ “Drive Utility Tasks” on page 353

■ “TallBot Utility Tasks” on page 359
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Event Monitor Tasks

Task Page

Display an Event Monitor 327

Display Multiple Monitors 328

List a Device Status Code 329

List a Result Code 331
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▼ Display an Event Monitor
Event monitor information is dynamically updated depending upon occurrence of the 
selected events. The information sent during an e-mail, print, save, or spool operation 
reflects the data (and format) shown on-screen at the time the operation is requested. 

Note – Event monitors are useful tools for root cause analysis of errors. If the library is 
experiencing reproducible errors, you can open an event monitor and spool all events 
to a file to capture the data. Later, you can send the file to your Sun support 
representative for analysis. 

Note – To monitor multiple events, see “Display Multiple Monitors” on page 328.

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder. 

The library monitors you have access to are displayed. 

3. Click the event monitor you want to use, and then click Open from the Options Bar. 

The system displays the associated data collected for the event.

4. Use these options to manage the information displayed on the screen for the event 
selected:

5.  To close a monitor, click the X in the upper right corner of the window. 

6. To spool the event data to a file, do the following:

a. Select Spool File > Start Spooling.

b. In the Save popup, click Save in Folder and then type a file name.

c. Click Save.

d. To stop spooling, select Spool File > Stop Spooling.

To Select

Pause the continuous display of data related to the event 
selected

Monitor > Pause

Resume displaying the events Monitor > Resume

Permanently stop the continuous display of data related to the 
event selected

Monitor > Stop

Clar the event monitor display Monitor > Clear
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▼ Display Multiple Monitors
You can open and manage multiple event monitors using these selections from the 
Options Bar:

To Select

Custom arrange the open monitors on screen Window > 
Arrange

Arrange the event monitor windows horizontally Window > Tile 
Horizontal

Arrange the event monitor windows vertically Window > Tile 
Vertical

Stack the event monitors Window > 
Cascade
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▼ List a Device Status Code
Use this procedure to list device status codes and their descriptions.  

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click Device Status. 

5. Complete the Device Status field, as follows:

■ To search for a specific device status code, enter the complete code; wildcards or 
partial codes are not accepted. 

■ To list all device status codes, click the List All checkbox. 
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6. Click Search in the Options Bar. 

The screen lists the specified device status codes and their descriptions. 
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▼ List a Result Code
Use this procedure to list result codes and their descriptions.  

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click Result Code. 

5. Complete the Result Code field, as follows:

■ To search for a code, enter the complete code; wildcards or partial codes are not 
accepted. 

■ To list all codes, click the List All checkbox. 



Library Utility Tasks

332 SL3000 User’s Guide • April 2008 Revision: A • 316194401

Library Utility Tasks

Task Page

Perform a Library Self-Test 333

Reboot the Library 334

Download Code to the Library Controller 335

Activate Code 336

Transfer the Library MIB File 338
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▼ Perform a Library Self-Test 

Note – The proper diagnostic cartridges for library drives must be present in the 
library. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the SelfTest tab.

Note – The self-test screen displays a Mode field with two options: disruptive and non-
disruptive. At present, only the non-disruptive option is valid. 

4. Click the Run tab from the Options Bar.

During the self-test the SL Console window displays the status of the various 
diagnostics being performed.



Library Utility Tasks

334 SL3000 User’s Guide • April 2008 Revision: A • 316194401

▼ Reboot the Library
Use this procedure to reboot the library. This process involves reloading the firmware 
from flash memory and restarting the library controller.

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click Reboot in the Options Bar.

The Reboot Confirm popup appears. 

4. Click OK. 

5. Click OK to continue. 

The library controller reboots the library, and the Reboot Success popup appears. 

6. Click OK to dismiss the popup. 

7. Vary the library online. See “Vary the Library Online” on page 383 for details. 
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▼ Download Code to the Library Controller
1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Load Code tab. 

4. Click the Browse button to locate, select the folder and file name containing the 
firmware package (.jar file) on your PC, and then click Open.

5. Click the Load button from the Options Bar.

6. Click OK to confirm the download. 

Note – The download process could take up to five minutes. The SL Console indicates 
the progress of the file transfer from the PC to the library controller.

Note – After the downloading, the system unpacks the package. 

7. After the package is successfully unpacked, you can activate the code immediately, 
or you can wait until a later time. See “Activate Code” on page 336 for detailed 
instructions.
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▼ Activate Code
Activating the code makes the code residing in the library controller ready for 
operation 

1. Select Tools > Diagnostics, 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Activate Code tab.

4. Click the Target on the pull-down menu.

Note – Target refers to firmware package (.jar file) containing the SL3000 library 
code.

5. Click the code to activate from the Available Versions section. 

Note – The version prefixed with an “*” is the code currently active. You can not select 
this code again to activate.

6. Click the Activate button in the Options Bar.

Note – The activate code process could take up to ten minutes to complete.

Caution – POTENTIAL INTERNAL FILE CORRUPTION. Do not reboot any devices in 
the library or execute any operations on the library while code is being activated.

7. Click OK to continue.

Note – The Activate Console screen displays the status of the code activation process. 
The code you just activated is listed in the available versions section, marked with an 
“*”. The unpacked version and previously activated versions of the code are also listed 
(without the “*”) . 

8. The system prompts you to reboot the library. Click OK to reboot the library.

9. Click OK to terminate the SL Console session.

10.In the logon screen, click Exit to close the application. 
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11.Wait for the library to complete the initialization before you log in to the SL Console 
again.

Note – The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet available, 
in which case you need to exit and log in again at a later time. Additionally, if an audit 
is performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up-to-date and accurate. 
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▼ Transfer the Library MIB File
Use this procedure to copy the public SNMP management information base (MIB) file 
to a specified location on your local PC or workstation. The file is saved as a text file. 
You can e-mail the file to your Sun support representative to help diagnose problems 
with the library. 

1. Select Tools > Diagnostics, 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the TransferFile tab. 

The MIB file transfer screen appears. 
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4. Click Transfer. 

The Save popup appears. 

5. Browse to the directory where you want to save the file, and enter the file name in 
the File Name field. Be sure to give it a .txt suffix. 

6. Click Save. 

The data is saved to the specified file, and the Transferred Successful popup appears. 

7. Click OK to dismiss the popup. 
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Audit Tasks

Task Page

Audit the Entire Library 341

Audit a Range of Cells 343

Perform a Verified Audit 345
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▼ Audit the Entire Library
During this audit the TallBot visits all the cartridge slots, catalogs the VOLIDs and 
locations, and updates the library controller database. 

Note – Although this audit is a background process and does not interrupt library 
operations, it does require sharing of TallBot resources. Therefore, it is not 
recommended that you run this audit during peak activity periods. 

Note – You cannot stop this audit once it has initiated. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.
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3. Click the Audit tab.

The Library Audit screen appears. 

4. In the Entire Library field, click Yes. Then click the Audit button in the Options Bar.

A confirmation popup appears. 

5. Click OK to perform the audit as a background process or Cancel to cancel the audit.

Note – Once you click OK, you cannot stop the audit; it will run until completion. 

6. You can view the Cartridge Summary report after a few hours for the latest cartridge 
locations and VOLIDs. See “Display a Library Report” on page 84 for details.
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▼ Audit a Range of Cells
During this audit the TallBot visits only a specific range of cartridge slots (including the 
cap and drives) and updates the library controller database.

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Audit tab.

The Library Audit screen appears. 

4. In the Entire Library field, click No. In the Physical Audit field, click Yes. In the 
Verified Audit field, click No.
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5. In the Start Address and End Address fields, select the device types you want to 
audit and the starting and ending library internal address locations. See “Library 
Internal Address” on page 393 for a detailed explanation of this address format. 

6. Click the Audit button in the Options Bar.

A confirmation popup appears. 

7. Click OK to perform the audit as a background process or Cancel to cancel the audit.

Note – Once you click OK, you cannot stop the audit; it will run until completion. 

8. The Audit Console section displays the progress of the audit. 

Note – You can also view the Cartridge Summary report for the latest cartridge 
locations and VOLIDs. See “Display a Library Report” on page 84 for details.
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▼ Perform a Verified Audit
A verified audit validates the status of a specific cartridge location or a range of 
locations (including CAP and drives) in the library controller database. If a cartridge 
address has a verified status of “false” then a physical audit of that location is 
performed and the library controller database is updated. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Audit tab.

The Library Audit screen appears. 

4. In the Entire Library field, click No. In the Verified Audit field, click No. In the 
Virtual Audit field, click Yes. 
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5. In the Start Address and End Address fields, select the device types you want to 
audit and the starting and ending library internal address locations. See “Library 
Internal Address” on page 393 for a detailed explanation of this address format. 

6. Click the Audit button in the Options Bar.

The Audit Console section displays the progress of the audit. 
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CAP Utility Tasks

Task Page

Perform a CAP Self-Test 348

Vary a CAP Offline 349

Vary a CAP Online 351
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▼ Perform a CAP Self-Test 

Note – At present, the CAP self-tests perform the same routines as the library self-test. 
Specific CAP self-tests will be available at a later date.

1. Select Tools > Diagnostics.

2. Expand the CAP folder, and click the CAP you want to test. 

3. Click the SelfTest tab.

4. In the Mode pull-down menu, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed message 
appears when the test finishes. 
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▼ Vary a CAP Offline 
Use this procedure to vary a CAP offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

3. Click the Status tab.

The screen displays the current status of the CAP. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the CAP are completed, and then the CAP status is changed, as 
follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 
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■ Access State: Offline
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▼ Vary a CAP Online 
Use this procedure to vary a CAP online through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go online; the error 
condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

3. Click the Status tab.

The screen displays the current status of the CAP. 

4. In the Transition Request field, click Bring online. Click Apply. 

The CAP status is updated, as follows:
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■ Health State: ok

■ Device State: Ready

■ Access State: Online
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Drive Utility Tasks

Task Page

Perform a Drive Self-Test 354

Vary a Drive Offline 355

Vary a Drive Online 357
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▼ Perform a Drive Self-Test 
1. Select Tools > Diagnostics.

2. Expand the Drive Folder, and click the drive you want to test. 

3. Click the SelfTest tab.

4. In the Mode pull-down, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed message 
appears when the test finishes. 
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▼ Vary a Drive Offline 
Use this procedure to vary a drive offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The screen displays the current status of the drive. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the drive are completed, and then the drive status is changed, 
as follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 
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■ Access State: Offline
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▼ Vary a Drive Online 
Use this procedure to vary a drive online through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go online; the error 
condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The screen displays the current status of the drive. 

4. In the Transition Request field, click Bring online. Click Apply. 

The drive status is updated, as follows:
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■ Health State: ok

■ Device State: Ready

■ Access State: Online
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TallBot Utility Tasks

Task Page

Perform a TallBot Self-Test 360

Vary a TallBot Offline 361

Vary a TallBot Online 363

Define a Diagnostic Move 365

Start a Diagnostic Move 369

Manage Diagnostic Moves 371

Monitor and Control Diagnostic Moves 373

Verify the Status of an Open Move 375
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▼ Perform a TallBot Self-Test 

Note – To perform a TallBot self-test, diagnostic cartridges must be available in the 
library. 

1. Select Tools > Diagnostics.

2. Expand the Robot Folder, and click the robot you want to test. 

3. Click the SelfTest tab.

4. In the Mode pull-down, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed message 
appears when the test finishes. 
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▼ Vary a TallBot Offline 
Use this procedure to vary a TallBot offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the TallBot you want to modify. 

3. Click the Status tab.

The screen displays the current status of the TallBot. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the TallBot are completed, and then the TallBot status is 
changed, as follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 
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■ Access State: Offline

5. The TallBot is moved to the end of the rail and is not usable by the library. If the 
library is using the redundant TallBot feature, the second TallBot will take all 
requests. 
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▼ Vary a TallBot Online 
Use this procedure to vary a TallBot online through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go online; the error 
condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the TallBot you want to modify. 

3. Click the Status tab.

The screen displays the current status of the TallBot. 

4. In the Transition Request field, click Bring Online. Click Apply. 

The drive status is updated, as follows:
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■ Health State: ok

■ Device State: Ready

■ Access State: Online
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▼ Define a Diagnostic Move 
Multiple diagnostic move routines can be set up and run simultaneously, as long as the 
target and pool address ranges do not overlap.  

Note – This procedure requires sharing of TallBot resources; therefore, it is not 
recommended that you run it during peak activity periods. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.
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4. In the Defined Sequence section, click Add.

The TARGET Sequence screen appears. 

5. In the Selection Mode field, select the type of cells you want to diagnose. 

6. In the Minimum Address and Maximum Address fields, select the Column, Side, 
and Row of the minimum and maximum target addresses. 

7. Click Next.

The SOURCE Sequence screen appears. 
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a. Select the appropriate target address type and then click Next. See “Target 
Address Range” on page 322. 

8. To define the parameters for the pool address range:

a. Select the appropriate pool address type.

b. Click Next to proceed further or Previous to modify the target address range.

The Sequence Name screen appears. 

9. Define the following:

■ Name of the diagnostic move

■ Move Count (specify a number between 1 and 5000)

■ Access order (Sequential or Random)

■ Move Type (Robot and Cartridge or Robot Only) 
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10.Click Previous to go back one screen and modify the target or pool address range or 
Finish to complete the setup.

The Diagnostic Move Manage screen appears. The diagnostic sequence you have just 
defined is listed in the Defined Sequences section. 
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▼ Start a Diagnostic Move
1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.

4. From the Defined Sequences section click a diagnostic move and then click Open. 
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5. A monitor window pops up with options to perform the following functions:

To Select Menu Option Notes

Start  File > Start Sequence

Pause  File > Pause Sequence Stops all diagnostic moves, but 
maintains the current location in the 
access order.

Stop   File > Stop Sequence Stops a running or paused move.

Resume File > Start Sequence Resumes a paused move starting with 
the last known location in the target 
address range.

Clear the messages 
displayed in the monitor 
window

File > Clear Output Window Erases the previous message lines and 
continues to fill the screen with new 
messages.

Spool Spool File > Start Spooling Directs the move output to a file.

Stop spooling the move 
output to a file

Spool File > Stop Spooling Stops directing the move output to the 
spool file.
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▼ Manage Diagnostic Moves
The diagnostic move provides options to create and manage get/put operations. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.
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4. From the Defined Sequences section, select any of the following options:

5. To save the definition of an exerciser to a file: 

a. Click Save from the Options Bar. 

b. In the Save popup, click Save in folder and then type a file name. 

c. Select the appropriate file format (HTML, Text, or XML) and then click Save.

Note – If the file exists, confirm to replace the existing file.

Note – After saving the move definitions to a file, you can remove it from the 
SL Console and restore it at a later time for a different library.

6. To restore a diagnostic move previously saved and removed:

a. Click Restore from the Options Bar.

b. Click the appropriate folder and filename of the move. 

c. Click Open. 

7. To manage the diagnostic moves currently open, see “Diagnostic Move Control 
Functions” on page 323.

To Select Option Notes

Define a diagnostic move Add

Start a diagnostic move Open Multiple diagnostic moves may be 
open at a time so long as the target 
and pool address ranges setup for the 
moves do not overlap.

Remove a diagnostic move Remove This diagnostic move routine must not 
be open.

Modify options for a 
diagnostic move

Modify This diagnostic move routine must not 
be open or if open must be in a 
“Stopped” state.

Copy an existing diagnostic 
move

Copy Copy a diagnostic move definition, 
make changes if necessary, and assign 
a different name.
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▼ Monitor and Control Diagnostic Moves
You can open and monitor one or more moves. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.

4. From the Defined Sequences section click a move and then click Open. 

Note – You can have multiple moves open at a time so long as the target and pool 
address ranges setup for the moves do not overlap.
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5. Perform the above step to open multiple moves from the defined list. 

Note – A monitor window is displayed for each move you select.

6. From each control window select File > Start to start the move. 

The monitor window for each open move has the following status indicators:

Status Indicators Description Valid Values

State Current execution state of the move Running, pausing, paused, 
stopping, stopped

Health Current health state of the move OK, warning, error

Completed moves Number of moves completed in the 
requested move count 

Spooling Status Indicates if the move output is being 
spooled or not

True, False
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▼ Verify the Status of an Open Move
1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.

4. Highlight the move from the list in the Defined Sequences section. 

The Status section of the screen displays the state, completed moves, and the number of 
sequences currently running.

The Selected Monitor Console section displays the status of the diagnostic moves for 
the move selected from the list.
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CHAPTER 8

Manual Operations

When in manual mode of operation, the library is unavailable for host access. This may 
be because the library has experienced an unrecoverable error or a library component 
requires service or installation. When the library is in this mode, cartridge mounts and 
dismounts require human intervention. 

Library Safety
Thoroughly review the safety precautions in this section before attempting to enter the 
library. It is essential that you follow proper safety procedures at all times. 

General Safety Precautions

Warning – Possible Physical Injury.  To prevent accidental closure of the access 
door while someone is in the library, it is recommended that when you unlock 
the access door, you lock it open and retain the key on your person. 

Before entering the library, be sure you: 

■ Know the location of the emergency door unlocking mechanisms. See “SL3000 Door 
Interlocks” on page 378.

■ Leave the access door open whenever working inside the library. There is a switch 
on each door frame that disconnects DC power and signal lines to the library’s 
motors when an access door is opened. See “SL3000 Servo Power Interrupt” on 
page 378.

■ Know the location of the mechanical door releases. See “Mechanical Door Releases” 
on page 379. 

■ Know the physical restrictions. See “Physical Restrictions” on page 379. 
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SL3000 Door Interlocks
Door safety interlocks are located behind the front access doors of the Base Module and 
DEM. To open either access door, an access key is required. 

Door safety interlocks are constantly monitored by the library controller. During 
normal operation, if an access door is opened an Emergency Robotics Stop condition is 
initiated and all library motors are immediately disabled. This prevents motors from 
operating while a library door is open. If the library is varied offline, opening the access 
door disconnects DC voltages to the rails and the power bus. 

The door switches are also monitored when the library is powered off. A battery 
supplies power for the circuitry to detect a door opening/closing event while the 
library is powered off.

When a Base Module and DEM are connected together, opening an access door to 
either module automatically suspends operations within the entire library (the two 
door switches are connected in series).

SL3000 Servo Power Interrupt
An additional safety feature is the servo power interrupt (SPI). If the library controller 
detects that a library motor is out-of-range, it will generate an SPI to turn off drive 
voltage to the faulty motor. This prevents a servo runaway condition until the cause of 
the problem can be determined. 
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Mechanical Door Releases
Each lock handle on the access doors of the Base Module and DEM includes a 
mechanical release which is painted yellow (see FIGURE 8-1.) This release serves as a 
safeguard in case a person is inside the library and the access door is accidentally 
closed and locked. When you push the release, it unlocks and opens the door. 

FIGURE 8-1 Mechanical Door Release 

Interior Lighting
The interior of the library is always illuminated by white LEDs on the ceiling. 

Physical Restrictions
The library does not allow much free room for movement. You must be mindful of the 
restricted space at all times. 

■ Be careful not to snag your clothing on the plastic arrays that house the cartridges 
(only 0.4 m [18 in.] of aisle clearance).

■ Be careful not to bump your head or body against the arrays. 

■ To gain access to a cartridge, you may have to move a TallBot, in which case you 
must avoid damaging the TallBot’s electronic components. 

■ If you are loading or unloading a cartridge manually, your hands must remain clear of 
the drive’s mechanical and electronic load components.
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Manual Operation Tasks

Task Page

Vary the Library Offline 381

Vary the Library Online 381

Power Down the Library 381

Power Up the Library 381

Open the Library Access Door 381

Close and Lock the Library Access Door 389
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▼ Vary the Library Offline 
Use this procedure to vary the library offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

You may need to use this procedure at the following times:

■ Before powering down the library

■ Before opening a library access door

■ When the library is inoperative and requires maintenance 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 355 for details. 

2. Select Tools > System Detail.

3. Click the Library folder on the device tree.
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4. Click the Status tab, and then the General tab.

The current status of the library is displayed. 

5. In the Transition Request field, click Take offline. Click Apply.

All outstanding library jobs are completed, and then the library status is changed, as 
follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

■ Access State: Offline 
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▼ Vary the Library Online 
Use this procedure to vary the library offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Status tab, and then the General tab.

The screen displays the current status of the library. 

4. In the Transition Request field, click Bring online. 

5. Click Apply. 

The library status is updated, as follows:

■ Health State: ok

■ Device State: Ready
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■ Access State: Online

6. If applicable, vary the library online to ACSLS and HSC hosts. See the ACSLS and 
HSC documentation for detailed procedures. 
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▼ Power Down the Library
Use this procedure to power down the library. 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 355 for details. 

2. Vary the library offline. 

See “Vary the Library Offline” on page 381 for details. 

3. Open the rear doors of the Base Module and DEM (if present). 

4. Turn off the power enable switches. 

5. If necessary, turn off the circuit breakers on the PDUs. 
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▼ Power Up the Library
Use this procedure to power up the library. If the access doors have been opened and 
closed, a full audit of the library will be performed. 

1. Open the rear doors of the Base Module and DEM (if present). 

2. If necessary, turn on the circuit breakers on the PDUs. 

3. Turn on the power enable switches. 

4. The library goes through the initialization sequence, as follows:

Note – The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet available, 
in which case you need to exit and log in again at a later time. Additionally, if an audit 
is performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up-to-date and accurate. 

1. Library controller code is activated.

2. The library controller performs electronic discovery of library components:

a. Determines the AC power configuration (N+1 or 2N). 

b. Verifies tape drive controller function. 

c. Checks optional functions (for example, a local operator panel). 

d. Establishes communication and configuration of the TallBot controller. 

e. Polls all tape drives and determines their locations. 

f. Queries all CAPs:

- If a CAP door is fully open, the door will be left open. 

- If the state of a CAP door is undetermined, it is updated to closed and locked.

3. The TallBot performs the physical discovery process:

a. The TallBot sweeps the entire library to determine the library size. 

b. The TallBot scans the module identification block in each module. 

c. Depending on this information, the library is auto configured. 

4. If one of the access doors was opened and closed, a library audit will begin, as 
follows: 

a. The TallBot targets on each column of arrays (from the top, down). 

b. The TallBot scans up each column, recording the VOLIDs of all cartridges. 

c. The location of each VOLID is recorded in the library controller database. 

d. Storage cells without cartridges are flagged as empty.

e. If a cartridge is found in a CAP, the CAP is closed and locked. 



Manual Operation Tasks

316194401 • Revision: A Chapter 8 Manual Operations 387

Note – This audit does not update the host cartridge databases. See the appropriate 
tape management software documentation for details about updating the host 
databases. 

5. xThe library comes to a Ready state.

5. Vary the library online.

See “Vary the Library Online” on page 383 for detailed instructions. 
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▼ Open the Library Access Door 
Use this procedure to open the main doors of the library. 

Warning – Possible Physical Injury.  To prevent accidental closure of the access 
door while someone is in the library, it is recommended that when you unlock 
the access door, you lock it open and retain the key on your person. 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 355 for details. 

2. Vary the library offline. 

See “Vary the Library Offline” on page 381 for details. 

3. Insert the key into the door lock, and turn the key, to unlock the door. 

4. Pull up on the door latch to release it, and open the door.

5. Turn the key in the lock, to lock the door open. This will prevent the door from 
being closed while someone is in the library. 

6. Remove the key from the lock and keep it with you. 
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▼ Close and Lock the Library Access Door 
Use this procedure to close and lock the main doors of the library. 

1. Verify that there are no loose items in the library.

2. If the access doors were locked open, insert the key into the door lock, and turn the 
key, to unlock the door. 

3. Push the door closed and make sure it latches securely. 

4. Turn the key in the lock, to lock the door closed.

5. Remove the key from the lock and keep it in a safe place. 

6. If the library has been powered down, power it up. 

See “Power Up the Library” on page 386 for details. 

Note – Because the access doors have been opened, the library will go through a full 
audit. 
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APPENDIX A

Library Resource Addresses 

This appendix describes the following library addressing schemes: 

■ Library Internal Address—Used by the library controller.

■ HLI-PRC Locations—Used by hosts with TCP/IP connections to the library.

■ FC-SCSI Element Locations—Used by hosts with FC-SCSI connections to the library. 

■ Drive Hardware Numbers—Physical array slot into which a drive is installed. 

■ Drive Dynamic World-Wide Names—Automatically generated by the library 
controller for installed drives. 

These schemes are used to locate all library resources, including:

■ Cartridge storage cells

■ Tape drive slots

■ Installed drives 

■ System/reserved cells

■ CAP cells 

CenterLine Technology 
The SL3000 modular design uses CenterLine technology to help balance the work load 
and improve performance of the library. The left side of the Base Module—which is the 
only required module—serves as the centerline. You can add other modules to the left 
and right of the Base Module. Columns to the right of the centerline have positive (+) 
numbers, while columns to the left have negative (–) numbers. 
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FIGURE A-1 Centerline and Column Addressing 

Center Line

Negative (–) Numbered Columns Positive (+) Numbered Columns 

 Drives -4,    -3,    -2,     -1 1,     2,     3,     4 

Cartridges -12, -11, -10, -9, -8, -7 -6, -5, -4, -3, -2, -1  1,  2,  3,  4,  5,  6 7,  8,  9,  10, 11, 12
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Library Internal Address

Storage Cells
There are five components to the SL3000 library internal addressing scheme: 

1. Library number: always “1.” 

2. Rail number: always “1.”

3. Column number: the horizontal location. This is referenced from the left edge (as 
you face the inside back wall) of the Base Module. From this point, columns are 
numbered as positive (+), consecutively, from left to right, throughout all modules 
connected to the right side of the Base Module. 

Conversely, if a module is attached to the left of the Base Module, column locations 
are numbered as minus (–), consecutively, from right to left, throughout all modules 
connected to the left side of the Base Module.

4. Side: the back wall = 1, the front wall = 2.

5. Row: the vertical position, as referenced from the top cell in the column. Cartridge 
storage cells are numbered from 1–52. 

For the first (top) row of drives, they are numbered as Columns 1–4, Row 1. For the 
second row, they are numbered as Columns 1—4, Row 2 and so on. However, refer to 
TABLE A-1 on page 394 to see that drives displace four drive columns, but cartridge 
arrays displace six columns. 

Library Internal Address Example—Base Module
As an example of using the library internal addressing scheme, refer to TABLE A-1 on 
page 394, drive hardware number 13 would be 1, 1, +4, 1, 4, as follows: 

1. Library number = 1 

2. Rail number = 1

3. Column number = +4

4. Side = 1

5. Row = 4
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TABLE A-1 Base Module—Rear Wall Locations (viewed from the front of the library) 

Row          +1          +2          +3          +4

   +1       Drive 4       Drive 3       Drive 2       Drive 1

   +2       Drive 8       Drive 7       Drive 6       Drive 5

   +3       Drive 12       Drive 11       Drive 10       Drive 9

   +4       Drive 16       Drive 15       Drive 14       Drive 13

         +1          +2          +3          +4          +5          +6

+24 Storage cells Storage 
cells 

Storage cells Storage cells Storage cells Storage cells 

  ~

+35

+36 Storage cells Storage 
cells 

Storage cells Storage cells Storage cells Storage cells 

  ~

+48

+49 
  ~

    No array Top 2 = 
Drop off

4-cell  
Diagnostic/ 
Cleaning

4-cell ID 4-cell 
Diagnostic/ 
Cleaning

4-cell 
Diagnostic/ 
Cleaning

+52 Bottom = 
Swap

Note: Perspective is from the front of the library.
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As a second example, the location for the two drop-off cells on this wall are...

1. Library number = 1

2. Rail number = 1

3. Column number = +2

4. Side = 1

5. Rows = 49 and 50

...which translates to 1, 1, +2, 1, 49 and 1, 1, +2, 1, 50.

Library Internal Address Example—DEM
See TABLE A-2 on page 396 for drive hardware number 27. As an example of using the 
library internal addressing scheme, this drive location would be... 

1. Library number = 1

2. Rail number = 1

3. Column number = -3

4. Side = 1

5. Row = 1

...which translates to 1, 1, -3, 1, 1.

As a second example, the location for the four-cell array that can contain diagnostic 
cartridges on this wall are...

1. Library number = 1

2. Rail number = 1

3. Column number = -4

4. Side = 1

5. Rows = 49 through 52

...which translates to 1, 1, -4, 1, 49 through 1, 1, -4, 1, 52.
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System/Reserved Cells 
A total of two cells are reserved within the Base Module only for drop-off locations and 
one cell is reserved as a swap cell. All remaining system cells can be used for diagnostic 
or cleaning cartridges; these are listed in TABLE A-3 on page 397.

There are a total of 12 cells for diagnostic or cleaning cartridges in the Base Module; 
there are a total of 12 or 15 cells for diagnostic or cleaning cartridges in the DEM. These 
are also listed in TABLE A-3 on page 397.

TABLE A-2 Drive Expansion Module—Rear Wall Locations (viewed from the front of the library) 

         -4          -3          -2          -1
Ro
w

      Drive 28       Drive 27       Drive 
26

      Drive 25    1

      Drive 32       Drive 31       Drive 
30

      Drive 29    2

         -6          -5          -4          -3          -2          -1

Storage 
cells

Storage 
cells

Storage 
cells

Storage 
cells

Storage cells Storage cells    13

   ~

   23

Storage 
cells

Storage 
cells

Storage 
cells

Storage 
cells

Storage cells Storage cells    24

   ~

   35

Storage 
cells 

Storage 
cells 

Storage 
cells 

Storage 
cells 

Storage cells Storage cells    36

   ~

   48

    No array Top 2 = 
Drop off

4-cell  
Diagnostic/ 
Cleaning

4-cell ID 4-cell 
Diagnostic/ 
Cleaning

4-cell 
Diagnostic/ 
Cleaning

   49 
   ~

Bottom = 
Swap

   52

Note: Perspective is from the front of the library.
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There are no reserved cells in a CEM or PEM.

CAP Cells 
Cell locations within the CAPs follow a similar notation scheme as other locations 
within the library: 

1. Library number: (always “1”)

2. Rail number: (always “1”)

3. Column number: the horizontal location. This is referenced from the left edge (as 
you face the inside front) of the Base Module. From this point, columns are 
numbered as positive (+), consecutively, from left-to-right, throughout all modules 
connected to the right side of the Base Module. 

Conversely, if a module is attached to the left of the Base Module, column locations 
are numbered as minus (-), consecutively, from right to left, throughout all modules.

4. Side: (always “2” [front wall]).

5. Row: the vertical position, as referenced from the top cell in the column. Cells are 
numbered from 1—13 for the top magazine and 14—26 for the lower magazine. 
Magazine handles are located at the tops of each CAP magazine. 

Note – The magazine handle is not counted as a cell.

Library Internal Address Examples—CAP Cells
The fourth CAP cell down in a Base Module would be... 

1. Library number = 1

2. Rail number = 1

TABLE A-3 Reserved Cells 

Cell Locations Module Type Use Location

1, 1, 2, 1, 49—50 Base module Drop off cells (Reserved)
Back wall of the Base 
Module 

1, 1, -4, 1, 49—50
DEM Cleaning/Diagnostics 

Cartridges
Back wall of the DEM 

1, 1, 2, 1, 51 Base module Swap cell (Reserved)
Back wall of the Base 
Module 

1, 1, -5, 1, 51 DEM Cleaning/Diagnostics Cartridges Back wall of the DEM 

1, 1, 5, 1, 49—52 
1, 1, 6, 1, 49—52

Base module Cleaning/Diagnostics Cartridges 
Back wall of the Base 
Module 

1, 1, -1, 1, 49—52 
1, 1, -2, 1, 49—52

DEM Cleaning/Diagnostics Cartridges Back wall of the DEM 

 Note: Do not place data cartridges in a reserved cell. These cells are masked from the customer’s 
database (that is, an online TallBot will never go to these cells).



Library Internal Address

398 SL3000 User’s Guide • April 2008 Revision: A • 316194401

3. Column number = +5

4. Side = 2

5. Row = 4

...which translates to 1, 1, +5, 2, 4.

The sixth CAP cell down in a DEM would be...

1. Library number = 1

2. Rail number = 1

3. Column number = -2

4. Side = 2

5. Row = 6

...which translates to 1, 1, -2, 2, 6.
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HLI-PRC Locations

Storage Cells
The host library interface-panel, row, column (HLI-PRC) location (address) is an 
eight-digit, comma-separated value (LL, PP, RR, CC) representing LSM, Panel, Row, 
Column. This addressing scheme is used by HLI clients, including ACSLS and HSC, to 
represent cartridge storage cells accessible to those HLI clients. 

Note – The SL3000 library internal address identifies the physical location of the 
cartridge in the library and the HLI-PRC refers to the address assigned by the host 
software.

The cell location appears in the following format: 

where, 

LL: LSM number (always “00”)  
PP: Panel (relative to the Base Module—descending numbers on the left and ascending 
numbers to the right; even numbers = rear walls, odd numbers = front walls)

■ Base Module = panels 12 & 13

■ DEM added to the left = panels 10 & 11

Note – Exception: If a CEM is added to the left of a Base Module instead of a DEM, 
that module’s panel numbering will be 8 & 9 (see “HLI-PRC Storage Cell 
Locations—Example Three” on page 401). This allows for a DEM to be installed at a 
later date without the necessity of re-numbering the modules.

■ module added to the right = panels 14 & 15

Note – RR: Row in the panel (a number from 0—51)  
Note the difference here. Library internal address rows begin with “1” and HLI-PRC 
rows begin with “0.”

CC: Column in the row (numbered left to right, from the front of the module)

Note – CC: Columns in the panel (a number from 0—5. 
Note the difference here. Library internal address columns begin with “1” and 
HLI-PRC rows begin with “0.”

      L       L       P       P       R       R       C       C
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HLI-PRC Storage Cell Locations—Example One
For an example of how this numbering scheme is formulated, refer to TABLE A-4. 

In example one, the library is composed of two modules. The cell location of a cartridge 
on the rear wall of the Base Module at Column 5, Row 24, would translate to the 
following: 

LL = 00, PP = 12, RR = 24, CC = 05; or 00, 12, 24, 05 

HLI-PRC Storage Cell Locations—Example Two
Adding a module to the left of the library described in Example One illustrates the “left 
descending” numbering scheme. Refer to TABLE A-5 to see how this works. 

In this example, a CEM has been added to the left of the DEM. Its panels are now 
numbered 8 and 9. Add another module to the left of this library and its panels become 
6 & 7. 

Conversely, adding a module to the right of the Base Module would make that 
module’s panel numbers 14 & 15, and so forth. 

TABLE A-4 Host Library Interface Cell Locations—Example One

                Drive Expansion Module                       Base Module

Rear Wall = Panel 10 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 11 Front Wall = Panel 13

Note: Perspective is from the front of the library.

TABLE A-5 Host Library Interface Cell Locations—Example Two

Cartridge Expansion Module   Drive Expansion Module               Base Module

Rear Wall = Panel 
8

Rear Wall = Panel 10 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 
9

Front Wall = Panel 11 Front Wall = Panel 13

Note: Perspective is from the front of the library.
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HLI-PRC Storage Cell Locations—Example Three
For an exception to continuous panel numbering, a third example is presented in 
TABLE A-6. In this library, two CEMs have been added to the left of a Base Module. 
Notice that, without a DEM, panel numbering to the left of the Base Module is now 8 & 
9, instead of 10 & 11.

This illustrates:

■ The one exception to the consecutive panel numbering scheme

■ That if a DEM is installed in the future, no panel numbering will change for the 
existing modules

Note – This numbering scheme benefits customers greatly since adding a module does 
not require any change to their existing panel configurations.

Although the host tape management software follows a five-digit numbering scheme 
like that in the SL3000 address, there are significant differences in cell designations, 
CAP behavior, and other operational considerations as described below.

If you need to locate a cartridge’s HLI-PRC location, see “Locate a Cartridge by 
VOLID” on page 101. This procedure displays the cartridge information in both library 
internal address and HLI-PRC address formats. 

TABLE A-6 Host Library Interface Cell Locations—Example Three

Cartridge Expansion Module Cartridge Expansion Module               Base Module

Rear Wall = Panel 
6

Rear Wall = Panel 8 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 
7

Front Wall = Panel 9 Front Wall = Panel 13

Note: Perspective is from the front of the library.
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Drive Slots
For the drives, HLI-PRC locations are different from the notation you will see with 
cartridge storage cells. TABLE A-7 illustrates how this numbering scheme works, as 
viewed from the rear of the library. 

■ The standard numbers correspond with the physical numbering of the drives.

■ The superscript numbers (in bold) correspond with the HLI-PRC (Row) locations.

■ HLI-PRC numbering is sequential from right-to-left—from 0 to 3—for the first (top) 
row of the first module.

■ HLI-PRC sequential numbering scheme restarts, right-to-left—from 0 to 3—in the 
next module.

■ The Column number is always 0.

HLI-PRC Drive Locations—Example One
Drives use drive numbers in place of row and column locations. The drive number is 
assigned to the position taken by a cell’s row, and the position taken by a cell’s column 
is always “00”. For example, tape drive hardware number 20 is equivalent to this HLI-
PRC location:

Library = 00

Panel = 12

Drive = 16

Column = 00

TABLE A-7 Host Library Interface Tape Drive Locations

                                     Base Module                               Drive Expansion Module

                                   Rear Panel =12                                    Rear Panel = 10

        13         22         31         40         253         262         271         280

        57         66         75         84         297         306         315         324

        911         1010         119         128         3311         3410         359         368

        1315         1414         1513         1612         3715         3814         3913         4012

        1719         1818         1917         2016         4119         4218         4317         4416

        2123         2222         2321         2420         4523         4622         4721         4820

        4927         5026         5125         5224

        5331         5430         5529         5628

Notes: Perspective is from the rear of the library. 
      The superscript numbers (in bold) represent the HLI-PRC locations (which translate into the 
Row number).
      The standard number notation represents the drive hardware number. 
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HLI-PRC Drive Locations—Example Two
As a second example, going from an HLI-PRC location to a hardware location, tape 
drive 00, 10, 25, 00 is equivalent to tape drive hardware number 51.

CAP Cells 
CAP HLI-PRC locations are different from the notation used for cartridge storage cells. 
CAPs use CAP numbers in place of panel numbers, and CAP cells are always located at 
column 00, rows 00–25. Following is the detailed structure: 

Library = always 00

CAP = 01–10  

Row = 00–25

Column = always 00

To locate a cartridge’s HLI-PRC location, see “Locate a Cartridge by VOLID” on 
page 101. This procedure displays the cartridge information in both library internal 
address and HLI-PRC address formats. 
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FC-SCSI Element Locations
Since the SL3000 also offers a Fibre Channel control (library) interface, you must be 
aware of the cartridge/CAP/drive numbering according to FC-SCSI elements. 

TABLE A-8 on page 405 represents FC-SCSI element locations for the back walls of a 
library that has: 

■ Four modules

■ 166 licensed cartridge storage cells 
■ 36 tape drives 

TABLE A-9 on page 406 represents FC-SCSI elements for the front walls of the same 
library.

Note – Both tables below list the FC-SCSI elements for a native, non-partitioned 
library.
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TABLE A-8 and TABLE A-9 are examples only, presented for you to note that FC-SCSI 
element numbering is: 

■ For storage elements—top-to-bottom, left-to-right, beginning at the back wall (as 
viewed from the front, numbered 2000) and continuing with the same scheme at the 
front walls (as viewed from the front of the library. 

■ For CAP elements (import/export elements)—top-to-bottom, left-to-right, beginning 
with element number 10 at the left-most module’s CAP

■ Tape drives (data transfer elements)— left-to-right, top-to-bottom, beginning at the 
center line of the Base Module (element 1000) and continuing at the DEM. 

A vacant drive slot will not be included in the sequence. 

TABLE A-8 FC-SCSI Element Locations—Back Walls (as viewed from the front)) 

Cartridge 
Expansion 
Module

                Drive Expansion 
Module  
                         (Center Line) 

                    Base Module  
                   (Center Line)  Cartridge 

Expansion 
Module

2000 2010 1022 1023 1024 1025 1000 1001 1002 1003 2060 2070

2001 2011 1026 Empt
y

1027 1028 1004 1005 1006 1007 2061 2071

2002 2012 1029 1030 Empt
y

1031 1008 1009 1010 1011 2062 2072

2003 2013 1032 1033 1034 1035 1012 1013 1014 1015 2063 2073

2004 2014 2020 2026 2032 2038 1016 Empt
y

1017 1018 2064 2074

2005 2015 2021 2027 2033 2039 1019 1020 1021 Empt
y

2065 2075

2006 2016 2022 2028 2034 2040 2044 2048 2052 2056 2066 2076

2007 2017 2023 2029 2035 2041 2045 2049 2053 2057 2067 2077

2008 2018 2024 2030 2036 2042 2046 2050 2054 2058 2068 2078

2009 2019 2025 2031 2037 2043 2047 2051 2055 2059 2069 2079

Notes: Tape drives begin numbering from the center line (left wall of the Base Module).
            Empty tape drive slots are not counted.
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TABLE A-9 represents FC-SCSI element locations for the front walls of the same library, 
viewed through the front. 

TABLE A-9 FC-SCSI Element Locations—Front Walls (as viewed from the front) 

Cartridge 
Expansion 
Module

                Drive Expansion 
Module  
                         (Center Line) 

                       Base Module  
                      (Center Line) Cartridge 

Expansion 
Module

2080 2090 2100 2107   (CAP) 10 2123 2130   (CAP) 36 2146 2156

2081 2091 2101 2108              2124 2131               2147 2157

2082 2092 2102 2109               2125 2132               2148 2158

2083 2093 2103 2110             ~ 2126 2133             ~ 2149 2159

2084 2094 2104 2111               2127 2134               2150 2160

2085 2095  
 Doo
r 
 Latc
h

2112                
 Doo
r 
 Latc
h

2135               2151 2161

2086 2096 2113               35 2136              51 2152 2162

2087 2097 2114 2117 2120 2137 2140 2143 2153 2163

2088 2098 2105 2115 2118 2121 2128 2138 2141 2144 2154 2164

2089 2099 2106 2116 2119 2122 2129 2139 2142 2155 2155 2165

Notes: Perspective is looking through the front of the library. 
             Cartridge storage cell locations are consecutive, skipping locations for the door latches.
             CAP cells are unique and sequential, from the left-to-right, as viewed through the front of the 
library
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Drive Hardware Numbers
The hardware number of a drive is strictly internal to the library, defined by the 
electrical wiring to the drive slot. These numbers are printed on decals on the interior 
of the rear doors of the library modules.

TABLE A-10 illustrates this numbering scheme for the Base Module, as viewed from the 
rear of the module. TABLE A-11 on page 408 illustrates the numbering for the DEM.

TABLE A-10 Base Module Tape Drive Numbering—Hardware 

Array 
Number Drive Trays

1 Drive 1 Drive 2 Drive 3 Drive 4

Drive 5 Drive 6 Drive 7 Drive 8

Array 
Number Drive Trays

2 Drive 9 Drive 10 Drive 11 Drive 12

Drive 13 Drive 14 Drive 15 Drive 16

Array 
Number Drive Trays

3 Drive 17 Drive 18 Drive 19 Drive 20

Drive 21 Drive 22 Drive 23 Drive 24

Note – Numbers shown are referenced from the rear of the Base Module.
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Drive Dynamic World-Wide Names
Drive dynamic World-Wide Names (dWWN), or Fibre Channel addresses, are 
automatically generated by the library controller during library initialization. dWWNs 
are assigned to library drive slots rather than devices. If a drive is replaced, the new 
drive receives the same name as the one it replaced, thereby eliminating the need for 
system re-configuration There are three World Wide Names reserved for each drive 
slot: Node, Port A, and Port B.

Note – The dWWN feature is usually enabled at installation time. The library and tape 
drives all must have firmware that supports the dynamic World Wide Naming feature. 
When dWWN is enabled, all drives must be at the proper firmware level. If a drive has 
down-level firmware, it remains in the “configuring” state and is unavailable for host 
use.

TABLE A-11 Drive Expansion Module Tape Drive Numbering—Hardware

Array 
Number Drive Trays

1 Drive 25 Drive 26 Drive 27 Drive 28

Drive 29 Drive 30 Drive 31 Drive 32

Array 
Number Drive Trays

2 Drive 33 Drive 34 Drive 35 Drive 36

Drive 37 Drive 38 Drive 39 Drive 40

Array 
Number Drive Trays

3 Drive 41 Drive 42 Drive 43 Drive 44

Drive 45 Drive 46 Drive 47 Drive 48

  Array 
Number                                                    Drive Trays

            4 Drive 49 Drive 50 Drive 51 Drive 52

Drive 53 Drive 54 Drive 55 Drive 56

Note – Numbers shown are referenced from the rear of the DEM.
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APPENDIX B

Wall Diagrams 

This appendix provides diagrams and tables detailing the following:

■ “Base Module Walls” on page 410

■ “Drive Expansion Module Walls” on page 411

■ “Cartridge Expansion Module Walls” on page 412

■ “Parking Expansion Module Walls” on page 413

■ “Configuration Block” on page 414

■ “Row Numbering” on page 415

■ “Reserved/System Cells” on page 416
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Note – The light gray cells are not accessible unless an adjacent module is installed on 
that side. 

FIGURE B-1 Base Module Walls 

Base Module 

Fr
on

t 
W

al
l 

 ■ 140 data cartridge 
cells

■ With 26-cell CAP 
■ With operator panel 

or window

■ 163 data cartridge 
cells 

■ With 26-cell CAP 
■ With window 

cartridge array

R
ea

r 
W

al
l 

■ 8 tape drive slots 
■ 180 data cartridges 

■ 16 tape drive slots 
■ 125 data cartridges 

■ 24 tape drive slots 
■ 65 data cartridges 
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Note – The light gray cells are not accessible unless an adjacent module is installed on 
that side. 

FIGURE B-2 Drive Expansion Module Walls 

Drive Expansion Module 
Fr

on
t 

W
al

l 

■ 253 cartridge cells 
■ With window 

cartridge array 
■ No CAP

■ 230 cartridge cells 
■ With operator panel 

or window 
■ No CAP 

■ 176 cartridge cells 
■ With 26-cell CAP 
■ With window 

cartridge array 

■ 153 cartridge cells 
■ With 26-cell CAP 
■ With operator panel 

or window 

R
ea

r 
W

al
l 

■ 8 tape drive slots 
■ 180 data cartridges 

■ 16 tape drive slots 
■ 125 data cartridges 

■ 24 tape drive slots 
■ 65 data cartridges 

■ 32 tape drive slots 
■ 0 data cartridges 
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Note – The light gray cells are not accessible unless an adjacent module is installed on 
that side. 

FIGURE B-3 Cartridge Expansion Module Walls 

Left Cartridge Expansion Module 

Front Wall 
■ 260 cartridge cells 

Front Wall 
■ 182 cartridge cells
■ With 26-cell CAP 

Rear Wall 
■ 256 cartridge cells

Right Cartridge Expansion Module 

Rear Wall 
■ 308 cartridge cells 

Front Wall 
■ 234 cartridge cells 
■ With 26-cell CAP 

Front Wall 
■ 312 cartridge cells 
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Note – Six columns of arrays—three rear-wall and three front-wall—on both the left 
and right sides—are not accessible to allow for a defective robotics unit. 

FIGURE B-4 Parking Expansion Module Walls 

Left Parking Expansion Module 

Front Wall 
■ 156 cartridge cells 

Rear Wall 
■ 152 cartridge cells 

Right Parking Expansion Module 

Rear Wall 
■ 156 cartridge cells 

Front Wall 
■ 156 cartridge cells 
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Configuration Block
Each module in the SL3000 library has a configuration block on the lower rear wall in 
column 4, rows 49, 50, 51, and 52. This block identifies the: 

■ Type of module 

■ Back wall configuration 

■ Front wall configuration 

■ Options for that module

During library initialization, the robotic assembly visits this configuration block to 
determine the configuration of the module.

FIGURE B-5 Configuration Block 

Module types: 

■ Base Module 
■ DEM 
■ CEM 

■ PEM
■ AEM 

Back wall configuration: 

Target 

Front wall configuration: 

Options: 

■ Local operator 
panel 

■ Window 
■ Cartridge arrays

I   I\I   I
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Row Numbering 
FIGURE B-6 Row Numbering 

Example 1  
Base Module 

Example 2  
CEM 

Rows indicate the vertical location of a cartridge 
or tape drive.

Rows are always positive numbers. 

Storage cell rows are numbered from the top (1) 
to bottom (52). 
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Reserved/System Cells 
Both the Base Module and the Drive Expansion Module have special slots on the lower 
rear wall. These slots provide special functions for the library and tape drives. 

FIGURE B-7 shows an example of these slots: 

1. Swap slots (2) in column 2, rows 49 and 50.

2. Diagnostic slot (1) in column 2, row 51. 

3. Diagnostic slot (4) in column 3, rows 49, 50, 51, and 52. 

4. Configuration block in column 4, rows 49, 50, 51, and 52.

5. Cleaning cartridges (4) in column 5, rows 49, 50, 51, and 52. 

6. Cleaning cartridges (4) in column 6, rows 49, 50, 51, and 52. 

FIGURE B-7 Reserved Slots 

Swap
Diagnostic

Diagnostic Configu-
ration 
Block

Cleaning Cleaning

Target



316194401 • Revision: A 417

APPENDIX C

Cartridge Handling 

This appendix provides information on labeling and handling tape cartridges used in 
Sun StorageTek libraries. 

Valid Cartridge Labels 
Library cartridges must be labeled with a valid external label. Several standard Code 39 
bar code labels are supported by the library: 

For T9840 and T10000 cartridges—labels supplied by Trioptic (engineered Data 
Products/Colorflex) or Tricode (American Eagle/Writeline). Both versions require a 
separate Media ID character.

Note – Unlabeled cartridges are not supported. See “Unlabeled Cartridges” on 
page 419.

Sun StorageTek Tape Drives and Cartridges
Cartridge labels for Sun StorageTek T9840 (models C and D) and T10000 tape drives are 
listed in TABLE C-1. These tape drives also support encryption. 

TABLE C-1 Sun StorageTek Cartridge Codes 

Media ID Type of Cartridge

VOLSER + R T9840 data cartridge

VOLSER + R (Green background) T9840C VolSafe data cartridge

VOLSER + R (Purple background) T9840D VolSafe data cartridge

CLN (blank space) VOLSER + U T9840 cleaning cartridge

CLN (blank space) VOLSER + Y T9840D cleaning cartridge (Note: The 
T9840D has a unique cleaning cartridge.)

DG (blank space) VOLSER + R T9840 diagnostic cartridge 

VOLSER + T1 T10000 data cartridge
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LTO Tape Drives and Cartridges

Note – LTO technology was developed by IBM, Hewlett-Packard, and Seagate 
(Certance). LTO is an “open format’ technology, which means that users have multiple 
sources of product and media. 

LTO cartridge labels have eight characters. The last two characters are the media ID 
(L3, L4, LT or LU). CLN or DG are the first characters on the cleaning or diagnostic 
labels. LTO 4 tape drives also support encryption. 

DG (blank space) VOLSER + T1 T10000 diagnostic cartridge

CLN (blank space) VOLSER + CT T10000 cleaning cartridge

VOLSER + TS T10000 (sport) data cartridge

DG (blank space) VOLSER + TS T10000 (sport) diagnostic cartridge

CLN (blank space) VOLSER + CT T10000 (sport) cleaning cartridge

TABLE C-2 LTO Cartridge Codes  

Media ID Type of Cartridge

L3 Generation 3 data cartridge

L4 Generation 4 data cartridge

LT Write once read many times (WORM), 400 GB
This feature prevents the user from altering or erasing information from the 
tape. For more information, go to your vendor Web site and do a search on 
WORM. 

LU Write once read many times (WORM), 800 GB

CLN (blank space) 
+ CU

Universal cleaning cartridge
Sun recommends using the CLN + CU universal label instead of a vendor-
unique label (CLN + C1 for Hewlett-Packard or CLN + C2 for IBM).

DG (blank space) + 
VOLSER

Diagnostic cartridge (apply a DG label to a blank data cartridge to be used for 
library diagnostic tests) 

Note – For backward compatibility, Generation 2 (L2) data cartridges are supported 
for read-only operations only. 

TABLE C-1 Sun StorageTek Cartridge Codes 

Media ID Type of Cartridge
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Proper Cartridge Insertion
A cartridge must be inserted in a storage cell, CAP cell, or drive with the bar code on 
the bottom, and the VOLID readable from right to left. The cartridge hub must always 
be down. 

Unreadable Cartridges
Cartridges may be identified as unreadable for the following reasons:

■ Unlabeled Cartridges

■ Upside-Down Cartridges

HSC and ACSLS automatically eject unreadable cartridges from the library. FC-SCSI 
hosts may not; an unreadable cartridge may be moved automatically to a CAP during 
library initialization. 

Note – If a large number of cartridges are reported as unreadable, you may suspect a 
faulty TallBot camera or scanner. This could result in a large number of cartridges 
mistakenly ejected from the library. 

Unlabeled Cartridges
Cartridges without external labels are not fully supported in the SL3000. Unlabeled 
cartridges will not be mounted on drives; however, they can be moved between CAPs 
and storage cells. 

■ If an unlabeled cartridge is placed in a CAP, the TallBot will leave the cartridge 
there. The cartridge’s disposition depends on the host software. 

■ If an unlabeled cartridge is placed in a library storage cell, during an audit the 
cartridge will be reported as “unreadable, invalid media type.” Depending on the 
host software, the cartridge may not be recognized by the host, or it may be ejected 
through the CAP. 

Upside-Down Cartridges
Insertion of upside-down cartridges should never be attempted, especially for Sun 
StorageTek cartridges. How the library handles this situation depends upon the 
cartridge type.
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Sun StorageTek Cartridges

Caution – Upside-down Sun StorageTek cartridges do not fit in library storage cells 
and may cause damage to the cartridge and the TallBot.

■ If a Sun StorageTek cartridge is placed upside-down in a CAP magazine, the CAP 
will not be able to close. 

■ If a Sun StorageTek cartridge is placed upside-down in a library storage cell, the 
cartridge will extend from the storage cell may and damage the TallBot. 

LTO Cartridges
■ If an LTO cartridge is placed upside-down in a CAP magazine, the TallBot will leave 

the cartridge there. The cartridge’s disposition depends on the host software. 

■ If an LTO cartridge is placed upside-down in a library storage cell, during an audit 
the cartridge will be reported as “unreadable, invalid media type.” Depending on 
the host software, the cartridge may not be recognized by the host, or it may be 
ejected through the CAP. 
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APPENDIX D

Web-launched SL Console Server

The Web-launched SL Console is a standard feature of the SL3000 and is included on a 
CD shipped with each library. It enables the SL Console to be installed on a centralized 
Web server. Individual clients can then use a supported Web browser to download and 
log in to the Web-launched SL Console. 

The Web-launched SL Console is deployed as a Java WebARchive (.war) file. 

Security Considerations
The customer is responsible for implementing all appropriate security systems, 
including firewalls, user access, etc. 

Server Requirements
You can deploy the Web-launched SL Console on any Web server that is compliant 
with the J2EE (Java 2 Platform, Enterprise Edition) platform. It is recommended that 
you use the Java System Web Server. 

Note – All procedures in this document assume you are using the Java System Web 
Server. 
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Server Installation and Management
Installation and management of the Web-launched SL Console server involves the 
following procedures:

■ “Download the Java System Web Server” on page 422

■ “Install the Sun Java System Web Server” on page 426

■ “Log in to the Java System Web Server Administration Console” on page 430

■ “Install and Deploy the Web-launched SL Console” on page 433

■ “Start the Web-launched SL Console” on page 439

■ “Update the Web-launched SL Console” on page 441

▼ Download the Java System Web Server
Use this procedure to download the Java System Web Server, if it is not already 
installed on your server. 

Note – This procedure requires you to have a Sun Online Account username and 
password. 

1. Open a Web browser, and in the Location Bar or Address field enter the URL of the 
Sun Web Servers page:

http://www.sun.com/download/index.jsp?cat=Web%20%26%20Proxy%20Servers&tab=3&subcat=Web%20Servers 

2. On the Web Servers page, click the Web Server link that corresponds to your server 
platform. 



Server Installation and Management

316194401 • Revision: A Appendix D Web-launched SL Console Server 423

3. On the Sun Java System Web Server screen (this will vary according to your selection 
in the previous step), scroll down to verify the list of supported platforms, and click 
Download. 

4. In the Sun Download Center Login screen, enter your Username and Password, and 
click Login.
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Note – If you do not already have an account, click Register Now and follow the 
instructions to create one. 

5. In the Sun Download Center screen, make the following selections:

■ Click the Accept License Agreement radio button.
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■ Click the Sun Java System Web Server link that corresponds to your server 
platform.

6. In the popup, click Save to Disk, to save the compressed archive file to a directory of 
your choice, and click OK. 

Note – This process may take several minutes.

7. Use the appropriate extraction utility (for example, gunzip, pkunzip) to extract the 
Sun Java System Web Server files to a directory of your choice. 
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▼ Install the Sun Java System Web Server 
Use this procedure to install the Java System Web Server, if it is not already installed on 
your server. 

1. In the directory where you have extracted the Sun Java System Web Server files, 
double-click or execute from a command line the setup file (setup or setup.exe, 
depending on your platform). 

If you are installing on a Solaris platform, you may need to invoke root or sudo 
permissions, depending on the directory you are installing to. If so, use the following 
steps:

a. cd extraction_directory

where extraction_directory is the directory to which you extracted the compressed 
Java Web Server files. 

b. xhost + 

c. sudo ./setup 

2. On the Welcome screen, click Next. 
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3. On the Software License Agreement screen, click the Yes radio button, and click 
Next. 

4. On the Select Installation Directory screen, specify the directory where you want the 
Web Server installed, and click Next.
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5. On the Type of Installation screen, click Express, and click Next.

6. On the Administration Server Settings screen, specify a secure password for the 
admin user, and click Next. 
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7. On the Ready to Install screen, review the installation information and click Install 
Now. 

The installation begins, and screen with a progress bar is displayed. 

8. On the Installation Complete screen, review the information and write down the 
Administration Console URL specified in #2 under “Next Steps. You will need this 
in the next procedure. 

9. Click Finish to exit the setup program. 
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▼ Log in to the Java System Web Server 
Administration Console

1. Start the Sun Java System Web Server, if it is not already running: 

■ On Windows—Click Start > All Programs > Sun Microsystems >Web Server 7.0 > 
Start Administration Server. 

■ On Solaris—Open a terminal window, and type the following:

sudo /opt/webserver7/admin-server/bin/startserv 

Note – Wait several minutes for the server to start. 

2. Open a Web browser, and in the Location Bar or Address field enter the URL you 
wrote down at the end of the previous procedure (“Install the Sun Java System Web 
Server”). This will start the Admin Console. 

3. In the popup, accept the server certificate, and click OK. 
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4. In the Web browser where you opened the Admin Console URL, enter the admin 
User Name and Password, and click Log in. 
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5. The Common Tasks screen appears. 
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▼ Install and Deploy the Web-launched SL Console 

Note – Before you perform this activity, you must obtain the Web-launched 
SL Console installation CD. 

1. On the server, insert the Web-launched SL Console installation CD in the CD drive. 

2. Log in to the Sun Java System Web Server administration console. See “Log in to the 
Java System Web Server Administration Console” on page 430 for details. 

3. On the Common Tasks screen, click Add Web Application.

4. On the Add Web Application screen, make the following entries:

■ Web Application Location: Click the Browse button and browse to the location of 
the opel.war file on the installation CD. 

■ URI: Type /opel

■ Leave all other fields as the defaults. 
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■ Click OK. 
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5. On the Web Applications screen, click Save.
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6. On the updated Web Applications screen, click the Deployment Pending link in the 
upper-right corner. 

7. On the Configuration Deployment screen, click Deploy. 
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8. On the Results screen, click Close. 
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9. The Web Applications screen displays a message that the application has been added 
successfully. 

You can click the Home button in the upper-right corner to return to the Common 
Tasks screen. 
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▼ Start the Web-launched SL Console 
1. Log in to the Sun Java System Web Server administration console. See “Log in to the 

Java System Web Server Administration Console” on page 430 for details. 

2. On the Common Tasks screen, click Start/Stop Instances. 
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3. On the Configuration Instances screen, click the checkbox next to the local instance 
of the Web-launched SL Console server, and click Start. 

The Web-launched SL Console application instances are started, and screen with a 
progress bar is displayed. 

4. On the Results screen, click Close. 
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▼ Update the Web-launched SL Console 
You can update the Web-launched SL Console while it is running. Updates are 
automatically propagated to the clients when they retrieve the Web-launched 
SL Console application from the server. 

Note – Before you perform this activity, you must obtain the Web-launched 
SL Console update CD. 

1. On the server, insert the Web-launched SL Console update CD in the CD drive. 

2. Log in to the Sun Java System Web Server administration console. See “Log in to the 
Java System Web Server Administration Console” on page 430 for details. 

3. On the Common Tasks screen, click Edit Virtual Server.
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4. On the General Properties screen, click the Web Applications tab.

5. On the Web Applications screen, click the checkbox next to the /opel URI, and click 
Update.

6. On the Update Web Application screen, make the following entries:
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■ Web Application Location: Click the Browse button and browse to the location of 
the opel.war file on the update CD. 

■ Leave all other fields as the defaults. 

■ Click OK. 

The server update begins, and screen with a progress bar is displayed. 
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7. On the Web Applications screen, click the Deployment Pending link in the upper 
right corner. 

8. On the Configuration Deployment screen, click Deploy. 

The deployment begins, and screen with a progress bar is displayed. 
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9. In the Results screen, click Close to return to the Web Applications screen. 
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Common Problems and Solutions
This section describes solutions to some common problems with the installation and 
maintenance of the Java System Web Server. 

Windows 2000 Sun Java System Web Server 

Installation Errors

Windows MSVCP60.dll Error 
If you are installing on a Windows 2000 platform that does not include the Microsoft 
Visual C v6 runtime DLL, MSVCP60.dll, during installation you will see errors similar 
to the following:
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The Web server installation log will include errors similar to the following:

▼ Remedy for Windows MSVCP60.dll Error 
Use this procedure to solve the Windows MSVCP60.dll error. 

1. Perform a Web search for the following string:

msvcp60.dll download 

2. Download the DLL file to the /winnt/system32 directory. 

3. Delete the directory where you partially installed the Java System Web Server on the 
failed installation.

4. Repeat the Java System Web Server installation from the beginning.

The installation should complete successfully with no recurrence of the error. 
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▼ Solaris 9 & 10 Sun Java System Web Server 

Installation Errors

Java Home Error
If you cannot start the server instance and you see errors claiming your HotSpot start 
failed and your JVM could not be found, you need to change the Java Home 
configuration of your Sun Java System Web Server. 

▼ Remedy for Solaris Java Home Error 
Use this procedure to solve the Java Home error. 

1. Log in to the Sun Java System Web Server administration console. See “Log in to the 
Java System Web Server Administration Console” on page 430 for details. 

2. Select Home > Common Tasks. 

3. Under Configuration Tasks, click Edit Java Settings. 
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4. In Java Home, enter the directory where your JDK/JRE is installed. For example:

/usr/java 

Note – You may also need to change permissions on the top-level directory where you 
installed the Sun Java System Web Server. In order for a non-root user to start a server 
instance, the user must be able to write to the server directory. For example, if you 
installed the server to the top-level directory /opt/webserver7, the user starting the 
server instance must be able to write to this directory and the https-server_name 
directory beneath it. For additional information see the Sun Java System Web Server 
site. 
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