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Chapter 1
Overview

Welcome to the IStream Customizer User Guide. 

This User Guidecontains overviews, step-by-step procedures and descriptions of 
the screens and fields.

This chapter describes:

• Document Conventions on page 8

• IStream Customizer on page 9

• IStream Customizer Terms on page 10

• IStream Document Manager Documentation on page 12

• Using the Online Help on page 14

• Contacting Skywire Software for Help on page 17
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Document Conventions

Tips, Notes, Important Notes and Warnings

Tip: A Tip provides a better way to use the software.

Note: A Note contains special information and reminders.

Important: An Important note contains significant information about the use and 
understanding of the software.

Warning: A Warning contains critical information that if ignored, may cause errors or result 
in the loss of information.

Other Document Conventions
• Window names, buttons, tabs and other screen entities are in bold, for 

example: Click Next.

• Paths, URLs and code samples use the Courier font, for example:  
C:\Windows

• Some sections contain links to other Related Topics.
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IStream Customizer

IStream Customizer helps modify your document to include changes in the text 
that apply for specified periods of time or to specific documents or generations of 
documents. These changes are regenerated as a new document during the time the 
wordings are in effect, but are not incorporated back into the model document on 
which the changed document was based.

IStream Customizer is useful where there is a need to customize documents in a 
very controlled way and retain those customizations during subsequent document 
regenerations.

IStream Customizer is an optional add-on to IStream Document Manager, which 
also includes:

• an IStream Document Management System (DMS), which manages 
documents and versions to help you establish workflow processes

• IStream Author, which helps users construct, edit and manage model 
documents and sections that are used to produce complex contracts, policies 
and correspondence

• IStream InfoConnector, which keeps track of multiple InfoSources so that 
you can take advantage of on-site business knowledge in more than one data 
source

• IStream Assembly Server, which is the document generation application 
that assembles complex documents based on model documents
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IStream Customizer Terms

The following list of basic terms is used throughout IStream Customizer:

• Model Document on page 10

• IStream Document Overview on page 10

• Tagged Text Blocks on page 10

• Tag Names on page 11

• Custom Wording on page 11

• Wording Names on page 11

Model Document
A model document is a document created in Author that may contain tagged text 
blocks. (See Tagged Text Blocks on page 10.) It may contain all possible standard 
wording for a policy, a contract or any other type of document. It is used to 
generate an IStream document, which can be customized in IStream Customizer.

IStream Document Overview
An IStream document:

• is a generated document based on a model document.

• is created by generating a document from an IStream Document Manager 
client application (such as Author) and saving the generated document

• contains only the standard wording that applies based on data selected from 
the database, such as a policy for an individual policy holder

• can contain tagged text blocks that can be customized in IStream 
Customizer

Tagged Text Blocks
A tagged text block is a block of text and variables placed between a TEXT TAG 
NAME …ENDTEXT rule in Author, the document-authoring tool in IStream 
Document Manager. IStream Document Manager treats all text and formatting 
codes within this rule as literal text, and inserts the text into a document. Tagged 
text blocks indicate to IStream Customizer those text blocks that may be 
customized for this particular document.

Note: Do not use variables within text boxes contained inside tagged text blocks, 
because these variables cannot be customized in IStream Customizer.

Example: TEXT TAG MyFirstTag
This contract is effective 30 days after the policy is approved.
ENDTEXT
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Tag Names
Each tagged text block has a tag name. These help identify each unique tagged 
text block. To modify the document, you apply changes (called custom wordings) 
to the tagged text block. In the example below, MySecondTag is the tag name.

Note: Tag names cannot be more than 64 characters long.

Example: TEXT TAG MySecondTag
Your premium payment is now due.
ENDTEXT

Custom Wording 
Custom wordings are changes applied to a tagged text block in an IStream 
document. The process of applying custom wordings is called customization. 
Custom wordings are applied to sections of the document using tagged text 
blocks. Custom wordings can be applied to a document at the page, paragraph, 
line or word level.

Note: You cannot use IStream Customizer to customize an IStream chart or graph. 

Wording Names
Each custom wording has a wording name to identify it. This name helps you to 
locate the custom wording in IStream Customizer to change the text or properties 
of the custom wording. For more information on custom wording properties, see 
Custom Wordings Properties on page 48.

Note: Wording names cannot be more than 64 characters long  
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IStream Document Manager Documentation

IStream Document Manager includes the following documents and online help 
files. If you need a copy of any of these documents, please contact your system or 
product administrator.

General Documentation
• The IStream Document Manager Release Notes include general product 

information, product enhancements and new features, supported platforms 
and third-party software, assorted considerations, and known issues and 
limitations.

• The IStream Document Manager ReadMe file describes the contents of the 
installation CD.

• IStream Document ManagerThe IStream Document Manager Glossary 
contains definitions of commonly used IStream terms.

User Guides and Online Help
• The IStream Assembler Online Help describes how to generate documents 

from sections and model documents.

•        The IStream Assembler Add-in for Microsoft Word Online Help 
describes how to perform certain IStream Assembler functions directly 
within Microsoft Word.

• The IStream Author User Guide describes how to create, edit, and test 
sections or model documents.

• The IStream Author Add-in for Microsoft Word Online Help describes how 
to perform certain IStream Author functions directly within Microsoft Word.

• The IStream Customizer User Guide describes how to modify the content of 
generated documents so that the changes will be applied during subsequent 
document generations. 

• The IStream Document Manager DMS Guide for IStream and Model 
Documents describes how to edit and work with IStream sections and model 
documents using the DMS user interface.

• The DMS Plug-in for Author Online Help describes how to access DMS 
functionality in IStream Author.

• The IStream InfoConnector Online Help describes how to set up and 
configure IStream InfoSources.

Advanced Guides
• The IStream Document Manager Guide for New Installations explains how 

to complete a new installation of IStream Document Manager. It includes 
system requirements and detailed installation and configuration information.
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• The IStream Document Manager Upgrade Installation Guide explains how 
to upgrade an existing installation of IStream Document Manager. It 
includes system requirements and detailed installation and configuration 
information.

• The IStream Document Manager Message Reference Guide contains lists of 
error, log and SDK messages from the various IStream components. It is for 
technical users who need additional information about the various IStream 
messages they receive.

• The IStream Document Manager Technical Guide is for system 
administrators and technical support staff who configure IStream Document 
Manager and set up links between it and their company’s database. This 
guide is also for those who set up and maintain security groups and 
operators in the system, and who install, optimize, maintain and 
troubleshoot IStream Document Manager. It also describes installing and 
configuring IStream XML InfoSources for interactive and batch generation.

• If you have purchased the IStream Toolkit, the IStream Assembler and 
Extensibility Toolkit Guides are installed onto your system. (You can view 
these guides from the Start > All Programs > IStream menu.)

These guides contain detailed descriptions of the components in the IStream 
Toolkit, or SDK. They are for technical users who need to integrate IStream 
components with their own or other third party applications.

In addition to the toolkit guides, the IStream Toolkit SDK Samples Guide 
gives an overview of the toolkit samples. The samples are working 
examples that can help you develop custom applications.

For more information about the toolkit, see the IStream Document Manager 
Toolkit ReadMe.
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Using the Online Help

This section describes how to use the Online Help and includes information about:

• The Contents of the Online Help on page 14

• Searching the Help on page 14

• Using the Help Index on page 15

• Using the Help Table of Contents on page 15

• Navigating the Help on page 15

• Printing a Help Topic on page 16

The Contents of the Online Help
The Online Help contains the same contents as the related PDF document, but in 
an online Help format.

To open the Online Help, click the Help menu.

The Help is divided into two frames:

• the left frame displays the navigation tools: Contents, Index and Search

• the right frame contains the contents of each Help topic

There are different ways to find a Help topic:

• Searching the Help on page 14

• Using the Help Index on page 15

• Using the Help Table of Contents on page 15

• Navigating the Help on page 15

Searching the Help
You can search the entire Help contents to find a specific topic.

Method: Search the Help

1. In the left pane of the Help, click the Search tab.
2. Enter the word(s) you want to search for, then click Go! or press Enter.
3. A list of Help topics is displayed in descending order by Rank. The Rank 

indicates how many times the word(s) you searched for appears in a Help 
topic. It can help indicate how relevant the topic may be in your search.

Tip: Use specific words in your search, for example: model document. Avoid using 
plurals, for example, “sections,” because this may limit your search results.
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Using the Help Index
The Help Index contains a listing of all the Help topics in alphabetical order.

Method: Use the Help Index

1. In the left pane of the Help, click the Index tab.
2. Click the letter that corresponds to the topic you are searching for. You 

cannot select a letter that is greyed out, because it contains no index entries.
3. A list of all index entries beginning with the letter you selected is displayed.
4. Scroll to the index entry of the topic you are searching for.
5. Click the topic to view its contents in the main body of the Help.

Using the Help Table of Contents
When you open the Help, the Contents are displayed. The Contents contain main 
topics and their subtopics.

Each main topic appears as a book icon:

Each subtopic appears as a page icon:

Subtopics can also appear as book icons. In other words, books can appear within 
other books.

You can open a book by clicking a book icon or the text next to the book icon. 
This will expand the book and display the topics within that book. 

To close an open book, click the book icon. The book “collapses”, hiding the 
topics within the book.

Tip: When a Help topic is displayed, you can click the “Show in Contents” button to 
open the corresponding book that contains the displayed Help topic:

Navigating the Help
To go to the next or previous Help topic in the Contents, use the Next and 
Previous buttons in the right pane of the Help:

To go to the next or previous topic that you have viewed, use the Forward and 
Back buttons in your Web Browser.
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Printing a Help Topic
You can print a Help topic in case you want to refer to it later.

Method: Print a Help topic

1. Click the Print icon in the upper-right corner of the Help:

2. The Print dialog box is displayed.
3. Click Print to print the Help topic. 
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Contacting Skywire Software for Help

Customer Support hours are 8:00 A.M. to 8:00 P.M. (Eastern Time), Monday 
through Friday. Outside of these hours, send us a detailed e-mail message and you 
will be contacted during regular business hours. Please provide detailed 
information, as described in the Support Checklist.

Contact Information

Support Checklist
When contacting Skywire Software Customer Support, please provide the 
following information:

• Your name, company name, e-mail address, and phone number

• Version numbers of all your Skywire Software products

• Name and version of the network software

• Windows version, including any installed Service Packs

• Microsoft .NET Framework version

• DMS version, including any installed Service Packs (if applicable)

• Microsoft Word version (if applicable)

• Database vendor and version (if applicable)

• Error messages and the circumstances of their occurrence

• A full description of the problem:

• What happened? What were the sequence of events that preceded the 
problem?

• In which screen or window did the problem occur?

• Was the problem the result of pressing a key?

• Did the screen freeze? What functions of the software are affected?

• How many people are affected?

Mail: Customer Support
Skywire Software
19 Allstate Parkway, Suite 400
Markham, Ontario, L3R 5A4

Phone: 1-905-513-7466

Fax: 1-905-513-1684

Email: directsupport@skywiresoftware.com

Web: www.skywiresoftware.com
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Chapter 2
Getting Started

This chapter describes:

• Opening IStream Customizer on page 20

• Viewing the IStream Customizer Screen on page 21

• Viewing IStream Document Properties on page 29

• Setting IStream Customizer Options on page 30

• Working with Documents in IStream Document Manager on page 35
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Opening IStream Customizer

There are several ways to open IStream Customizer. 

Method: Open IStream Customizer

• Click Start > Programs > IStream > Customizer.

• From IStream Document Manager, click the Customize link for the IStream 
document

Note: You cannot run multiple instances of IStream Customizer on the same system.

Note: When you first log in to Windows, an IStream Customizer cleanup utility briefly 
appears in a DOS window.

Warning: When using IStream Customizer on Windows XP, ensure that you use the 
Windows Classic style appearance so that you can highlight tags correctly.

Method: Change Windows XP display settings to Classic style

1. Right-click a blank area of your desktop, and select Properties.
2. From the Themes tab, select Windows Classic.
3. Click OK.
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Viewing the IStream Customizer Screen

The IStream Customizer screen consists of two windows. The left window 
contains the Tag View tab to display the tag hierarchy, and the Message Log tab 
to display messages which occur during generation or customization. The right 
window, or the Word window, displays the IStream document. Both windows can 
be resized and repositioned within the IStream Customizer main window.

The windows described in this section are:

• The Word Window on page 21

• The Tag View Window on page 23

• The Message Log Window on page 27

• Viewing IStream Document Properties on page 29

Note: Livelink menu functionality (installed with the Livelink Explorer module) is not 
supported.

The Word Window 
The Word window displays Microsoft Word with the IStream document 
containing the tagged text blocks. Tagged text blocks are the customizable parts of 
an IStream document.

Important: Do not use the Word Outline view when working with documents.

See also: Opening an IStream Document on page 2.
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Importing Custom Wordings from Other Documents
When opening a customizable document that does not already have custom 
wordings, you will be asked if you want to import custom wordings from another 
IStream document. This allows you to create a new variation of a customized 
document without having to redefine all of the custom wordings.

You can import custom wordings from another IStream document that is based on 
the same model document as the document that you are opening.

Method: Import custom wordings from another IStream document

1. Select File > Open.
2. Select the file without custom wordings you want to open, then click Open.

A prompt appears to ask if you want to import custom wordings from 
another document.

3. Click Yes. 

The Open dialog opens.
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4. Select a document (based on the same model document as the document 
selected in step 2) to import custom wordings from, then click Open.

When custom wordings are imported, the information for the custom 
wordings appears in the Tag View.

5. If your QuickGen default is set to Auto (see QuickGen Tab on page 34), a 
QuickGen will automatically be performed. The changes for the imported 
custom wordings will be reflected in the tag view and within the document.

If your QuickGen default is set to Prompt, a message appears asking if you 
want to perform a QuickGen.

• If you choose Yes, a QuickGen will be performed. The changes for the 
imported custom wordings will be shown in the tag view and within the 
document.

• If you choose No, the imported custom wording information will only 
be reflected in the tag view.

 (For more information, see QuickGen on page 73).

You can now work with the customizable document.

The Tag View Window
IStream Customizer displays the Wording Names and Tag Names in your 
document in the Tag View. Once a generated document is open in IStream 
Customizer, click the Tag View tab. IStream Customizer displays all the Tag 
Names and Wording Names associated with the generated document in the Word 
window.



GETTING STARTED

24 ISTREAM CUSTOMIZER VERSION 6.2 USER GUIDE

IStream Customizer does not display the Tag Names and Wording Names in the 
document unless the document was previously generated with both the Include 
Tag Information and Include Custom Wordings options selected in Options > 
Generation.

To learn more about generation modes, see Selecting the Generation Mode on 
page 39. 

Identifying Tags
A “pencil” symbol appears on folders that contain customized tags:

A dotted square next to a tag icon represents a newly created tag:

When you open the CLG file again, the dotted tag icon is replaced by a regular tag 
icon:

Expanding and Collapsing the Tag View
You can expand the Tag View to see the Tag Names, Wording Names, and other 
properties associated with the custom wordings.
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Method: Expanding and collapsing tags

1. Open a generated IStream document in the Word window as described in 
Opening an IStream Document on page 63.

2. Click the Tag View in the left window on the IStream Customizer screen.

IStream Customizer displays the model document name (*.CMS) and 
section names (*.CDS) in the Tag View.

• Click the plus (+) sign next to the document name to expand the Tag 
View.

IStream Customizer displays all the Tag Names and their associated 
Wording Names.

• Click the minus (-) sign next to the document name to collapse the Tag 
View. 

• To expand and collapse all items in the tree view, use the Expand All 
and Collapse All functions in the Customizer menu, or use the 
following two buttons in the toolbar:

 

Changing the Tag View Display
By default, when viewing a generated document, tags appear in the tree view 
nested under their respective master sections (.CMS) or subsections (.CDS) 

You can also display the tags listed by their tag name, followed on the same line 
by their section name, in the following format: tag name:section name

This view allows you to more easily navigate the tree.

Method: Display tags listed by tag name and section name

1. From the Customizer menu, select Options > General.
2. Select the Hide section nodes in the tag tree checkbox.
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3. Restart IStream Customizer for this change to take effect.

When you reopen the .CLG file in IStream Customizer, each tag name will 
appear in the tag tree on its own line, followed by a colon, and the section 
name.

Note: To display tags using the method in previous versions, leave Hide section nodes 
in the tag tree cleared. (This is the default setting.) The tags will be displayed in 
the previous “nested” format.
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Icons in the Tag View
IStream Customizer displays icons next to the Wording Names in the Tag View 
to indicate what is happening to the custom wording and the tagged text blocks in 
the document. The following table describes each icon. By default, the icons are 
gray. If a custom wording is opened in the Word window, the icons become red.

The Message Log Window
The Message Log not only displays all the messages sent out by the Assembly 
Server during generation, but it also shows you everything that is happening while 
you are working in IStream Customizer. To view the Message Log, click the 
Message Log tab in the Tag View window.

Note: The size of the Message Log View is limited to 64 KB.

The following screenshot shows messages from both IStream Assembler and 
IStream Customizer. The messages prefixed with “>” are from IStream Assembler 
and the messages without a “>” prefix are from IStream Customizer.

Icon Description

text to be inserted before the tagged text block

text to be inserted after the tagged text block

text to replace the tagged text block

tagged text block to be deleted

the custom wording is applied (check mark on icon)

a folder containing a custom wordings/tags
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Printing the Message Log
You can print the Message Log while you are working in IStream Customizer. 
However when you exit IStream Customizer, everything in the Message Log is 
deleted.

Method: Print the Message Log

1. Make sure your cursor is in the Message Log window.
2. Select File > Print. 

Notepad displays the Message Log and prints the log.
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Viewing IStream Document Properties

You can view basic information about the document opened in IStream 
Customizer.

Method: Display IStream document properties

1. Open a document in IStream Customizer.
2. Select File > Properties.

The IStream Customizer Document Properties dialog opens.

The dialog displays:

• the name of the IStream Customizer document’s Master Section

• Produced Through: how the document was produced 

• whether the document is Customizable

• Wording Number – the number of wordings in the document

• the Generation Test Date for the document: see Setting the Generation 
Test Date on page 6 for instructions on using the Generation Test Date.

3. Click OK to close the window.
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Setting IStream Customizer Options

Use the Customizer Options to set options and functions. 

Method: Display the Options dialog

• Select Customizer > Options.

The Options dialog opens. This dialog includes the following tabs:

• General Tab on page 30

• Repository Tab on page 31

• Custom Wording Tab on page 31

• Wording Template Tab on page 33

• Generation Tab on page 33

• QuickGen Tab on page 34

General Tab
Use the General tab to:

• select a word processor for printing the IStream Customizer log

• enable or disable the importing of custom wordings

• show or hide orphaned tags

• hide selection nodes in the tag tree

• prompt to add a password to a PDF

Method: Set the General options

1. Do one of the following steps:

• Click the Browse button to search for and select a word processor to use 
for printing the IStream Customizer log.

• Select Enable importing custom wording to allow IStream 
Customizer to import custom wordings from other documents as 
follows:

• if selected, you are asked if you want to import custom wordings 
when you open a document that does not already have custom 
wordings applied

• if not selected, you are not asked if you want to import custom 
wordings
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• Select Show orphaned tags to display orphaned wordings. Clear this 
checkbox to hide these wordings. See Orphaned Custom Wordings on 
page 58 for more information.

• Select Hide section nodes in the tag tree to display tags listed by tag 
name and section name. For details, see Changing the Tag View Display 
on page 25.

• Select Prompt to add password to PDF to apply a password that users 
will need to enter to open the generated PDF.

2. Click Apply to save the settings.
3. Click OK to close the Options dialog.

Repository Tab
Use the Repository tab to select the default repository to use with IStream 
Customizer.

Note: If the CLG files you want to work with are stored on a file system, you will need 
to ensure that you have configured an InfoSource to point to this file system’s 
location.

Method: Set the Repository options

1. Click the Browse button to select a repository to use with IStream 
Customizer.

Information about the repository displays in the Type, Location, and 
Description fields.

2. Click Apply to apply the settings.
3. Click OK to close the Options dialog.

Custom Wording Tab
Use the Custom Wording tab to:

• select the colors that applied wordings and tagged text are displayed in

• configure the Microsoft Word Track Changes feature

Method: Set the Custom Wording options

1. From the Applied Wording Color drop-down list, select a color.

Applied Wordings appear in the selected color.
2. From the Tagged Text Color drop-down list, select a color.

Tagged Text appears in the selected color.
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3. To hide the Custom Wording Properties dialog that appears when adding a 
new wording, clear the Show property dialog when adding a new 
wording check box. (By default, this check box is selected.)

When this check box is cleared, the Custom Wording Properties will no 
longer appear when you add a new wording. Instead, a new wording will 
automatically be added with default properties. (See Creating Custom 
Wordings on page 52 for details.)

4. Configure your Track Changes settings. (For details, see for Track Changes 
Options on page 32.)

5. Click Apply to save your settings.
6. Click OK to close the Options dialog.

Warning: If your IStream Customizer document uses its own color to mark a word or 
paragraph, the colors on the Custom Wording tab will overwrite your document 
colors within the current IStream Customizer session.

Track Changes Options
The following table indicates the Track Changes options you need to select or 
clear so that tracked changes will appear for:

• existing wordings (wordings that are already in the document) and

• new wordings (wordings that you add later to the document)

Setting Color Options for Macros and QuickGen
If a macro is used with QuickGen, you should set the Custom Wording > 
Applied Wording Color and Tagged Text Color options to Auto. If different 
colors are used, these colors will be saved into your document. 

Track Changes Options Existing Wordings New Wordings

Check:
• Enable Track Changes
    - and -
• Existing wordings will be opened 

with Track Changes on

displayed with tracked 
changes visible

displayed with tracked 
changes visible

Check:
• Enable Track Changes
    - and -
• Existing wordings will be opened 

with their last saved Track 
Changes settings

displayed based on their 
last Track Changes settings 
(tracked changes may or 
may not appear)

displayed with tracked 
changes visible

Uncheck:
• Enable Track Changes

displayed based on their 
last Track Changes settings 
(tracked changes may or 
may not appear)

displayed with track 
changes off
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If your prefer to use the different colors for editing, you have several options:

• if you change the Applied Wording Color and Tagged Text Color options 
to Auto before running the macro, the colors will not be saved in the 
document

• you can include an additional macro to Select All and change the text color 
as required

Note: If you print in black and white only, the colors are irrelevant.

Wording Template Tab
Use the Wording Template tab to select the template that you want to apply to 
your new wordings, or to reload your wording after attaching a new template.

Method: Set the wording template options

1. Select Use the template of the open IStream Customizer document to 
apply the template of the IStream Customizer document that is currently 
open to your new wordings.

Alternatively, select Use the following template, then Browse to a specific 
template to apply to your new wordings.

2. If you have a custom toolbar saved in your template, and want to use this 
toolbar while editing your wordings, select Reload wording after 
attaching a new template.

If you select this field, the wording will be reloaded and the custom toolbar 
appears when you apply the main document template to the wording that 
you are opening.

(You are prompted to apply the main document template to the wording that 
you are opening only when the template of your wording document is 
different than that in the main IStream Customizer document.) Note that you 
will not see any difference when you create a new wording with the 
template.

By default, this field is cleared to improve performance. 
3. When you are done making your changes, click OK to save these settings.

Generation Tab
Use the Generation tab to identify which information is included in the 
customized document. You can include or exclude both Tag Information and 
Custom Wordings. The options you select here determine what actions can be 
performed on the generated document later.

See Selecting the Generation Mode on page 39 for details about the combinations 
of settings.
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Method: Set the Generation options

1. Select the Include Tag Information checkbox to have tag information 
included in the generated document.

Note: If you do not select this option, your newly generated document cannot be 
customized further.
2. Select the Include Custom Wordings checkbox to include custom 

wordings in the generated document during the next generation. We 
strongly recommend that you select this option.

3. Click Apply to apply the settings.
4. Click OK to close the Options dialog.

QuickGen Tab
Use the QuickGen tab to choose the default setting for the QuickGen function. 
QuickGen allows you to see the changes made to custom wordings in the 
document without having to perform a full generation. (See QuickGen on page 
73.)

Method: Modify the QuickGen default setting

1. Select a QuickGen option:

• Auto – each time you save and close a wording window, a QuickGen is 
performed; all saved changes to custom wordings are immediately 
applied and displayed in the CLG document in the Word Window.

• Prompt – each time you save and close a wording window, a prompt is 
displayed asking you if you want to perform a QuickGen

• Manual – a QuickGen will be performed only if you manually choose 
to do so from the Customizer menu or QuickGen button on the IStream 
Customizer toolbar

2. Click Apply to apply the settings.
3. Click OK to close the Options dialog.
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Working with Documents in IStream Document 
Manager

To allow other users to customize documents saved in IStream Document 
Manager, permission for customization needs to be set for each customizable 
document. See Setting Document Permissions on page 35 for more information.

When working with customizable documents in IStream Document Manager, you 
can open IStream Customizer directly from the document in the DMS. Opening 
Customizable Documents from IStream Document Manager on page 36 explains 
how to open customizable documents directly from IStream Document Manager.

Setting Document Permissions
To allow users to customize IStream Customizer documents from the DMS, you 
need to set the Customize and Generate permissions for the documents. You can 
assign permission for customization and generation to all the users on your 
system, or you can limit the number of users able to customize the document.

Note: Documents within a folder will automatically have the same permissions as the 
folder.

Method: Set document permissions

1. Log in to IStream Document Manager.
2. Navigate to the document to set permissions for.
3. Click the Functions button.
4. Select Functions > Permissions.

The document’s Permission page opens.
5. Click a user in the list at the left to set permissions for the user.

The Permissions options for the user display.
6. Do one of the following steps:

• To assign permissions to all users, click Public Access in the list of 
users at the left of the screen, then click Generate and Customize in the 
Permissions list.

- OR -

• To assign permissions to specific users, click a user in the list of users at 
the left of the screen, then click Generate and Customize in the 
Permissions list.

7. Click Update to save the changes.
8. To assign permissions to another user, click a user in the list of users at the 

left of the screen. Assign permissions to the user, then click Update to save 
the changes.
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9. Click Done to return to the document in IStream Document Manager.

The specified users now have permission to customize the document from 
IStream Document Manager.

Opening Customizable Documents from IStream 
Document Manager
You can open IStream Customizer from within IStream Document Manager. To 
do this, you must have permission to customize the document. See Setting 
Document Permissions on page 35 for instructions.

Method: Customize a document using IStream Document Manager

1. Log in to IStream Document Manager.
2. Navigate to the document you want to open.
3. Click the Customize link next to the document name.

The document opens in IStream Customizer.
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Chapter 3
Tagged Text Blocks

This chapter describes:

• Tagged Text Blocks on page 38

• Preparing to Work with Tagged Text Blocks on page 39

• Using Color to Distinguish a Tagged Text Block on page 41

• Locating a Tag or Tagged Text Block on page 42
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Tagged Text Blocks

A tagged text block is a block of text placed between a TEXT TAG NAME … 
ENDTEXT rule. You apply custom wordings to a tagged text block to make 
changes to a document. These changes customize the document for a specific 
purpose.

Some typical uses of tagged text blocks are:

• specifying the terms in an insurance policy

• changing document or form names

• changing the date on a document

• changing wordings or clauses

• removing, adding, or replacing text or paragraphs

Tag Limitations
• An IStream document can have a maximum of 16,000 tags, including 

applied custom wording items. However, performance may be affected as 
the number of tags in the IStream document increases.

• IStream Customizer does not support tags from sections that have been 
included using the pipe (|) or double-pipe (||) syntax.
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Preparing to Work with Tagged Text Blocks

Before you can work with tagged text blocks in a generated document, you need 
to confirm that the document is customizable, or that custom wordings can be 
created for the document:

1. Select Customizer > Options > Generation and ensure that Include Tag 
Information and Include Custom Wordings are both selected.

2. Generate the document.

If the document opened in IStream Customizer has already been generated with 
both these Generation mode options selected, then it is ready to be customized 
now.

An IStream document that is ready for customization lists tag and wording names 
in the tag view.

Selecting the Generation Mode 
Assembler uses generation modes to control what information to include in the 
document during generation.

To customize a document in IStream Customizer, the tag information must be 
included during document generation. To include tag information you select a 
Generation Mode that includes tag information. 

To view the Generation Modes currently selected, select Customizer > Options 
and click the Generation tab.

You can include or exclude Tag Information, Custom Wordings or both. The 
following sections describe each combination of settings:

Include Tag Information and Custom Wordings
This is the default generation mode. IStream Customizer will create a new 
document that includes all of the tag information and custom wordings in the 
document. You must use this mode if you want to apply additional custom 
wordings later. 

Include Tag Information Only
The generated document will contain only the tag information, and not the custom 
wording text. While you can create custom wordings in the generated document in 
IStream Customizer because the tag information is still available, you cannot 
apply them during document regeneration.

Include Custom Wordings Only
A generated document is created using the most recent custom wordings. 
However, because no tag information is included in the generation, you cannot 
add more custom wordings without first changing the generation mode and 
regenerating the document.
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Exclude Tag Information and Custom Wordings
The generated document will contain no tag information or custom wordings. The 
generated document will therefore look like the original IStream document. You 
cannot add any custom wordings to the generated document without changing the 
generation mode and regenerating the document.

Generating a Document
Once you confirm that both the Tag Information and Custom Wordings 
Generation Mode options are selected, you need to regenerate the IStream 
document.

When you perform a generation, all information for the document is updated from 
the database.

Method: Regenerate a document in IStream Customizer

1. Select Customizer > Regenerate, or click the Regenerate  button.

IStream Customizer automatically begins regenerating the document. To 
view what is happening during the regeneration process, click the Message 
Log tab in the left pane. The new IStream document opens as soon as the 
regeneration process is complete.

2. Select File > Save, or click the Save button to save your regenerated 
IStream document. Filenames for IStream documents can have a maximum 
of 64 characters.

Note: You can also perform a QuickGen to quickly see the changes you have made to 
custom wordings as they will appear within your document. This process, unlike 
full generation, does not update the values in the document from the database. The 
QuickGen function overrides selections made for the Generation Mode. (See 
Selecting the Generation Mode on page 39.) It assumes that both the Include Tag 
Information and Include Custom Wordings options are selected.

Related Topic
• QuickGen on page 73
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Using Color to Distinguish a Tagged Text Block

You can use color to identify tagged text blocks and custom wordings in your 
document. This makes it easier to distinguish them from other text. You choose 
the color you prefer by selecting Customizer > Options. 

Note: To ensure that the font, size, and color of your text appears correctly, the 
formatting information must be explicitly applied to all text between a 
TEXT...ENDTEXT rule. This is particularly important when you apply color to 
distinguish a tagged text block. If you just accept the default text properties of the 
document template, all subsequent text will appear with that color.

Method: Apply color to a document

1. Open a generated document in IStream Customizer.
2. Select Customizer > Options.
3. Click the Custom Wording tab.
4. Select the color for your custom wording from the Applied Wording Color 

drop-down list. 
5. Select the color for your tagged text block from the Tagged Text Color drop 

down list.
6. Click Apply.

IStream Customizer applies the colors to your document in the Word 
Window.

7. Click OK to save your changes.

Note: If a macro is used in conjunction with QuickGen, see Setting Color Options for 
Macros and QuickGen on page 32 for additional steps.
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Locating a Tag or Tagged Text Block

You need to locate tags and tagged text blocks to add custom wordings to your 
IStream document. You can a locate a tag in the following ways:

• by Retrieving a Tag

• by Highlighting a Tag

• by Using the Navigation Buttons

Retrieving a Tag
Retrieve Tag helps you locate a Tag Name in the Tag View. In large documents, 
you sometimes may not be able to see the Tag Name when your cursor is in the 
tagged text block in the Word window. You can use Retrieve Tag to highlight the 
corresponding tag in the Tag View.

Method: Retrieve a Tag Name

1. Place your cursor in the tagged text block in the generated document.

2. Select Customizer > Retrieve Tag, or click the Retrieve Tag button .

IStream Customizer automatically highlights the matching Tag Name in the 
Tag View.

Highlighting a Tag
Highlight Tag lets you find a tagged text block in the Word window when you are 
in the Tag View. It is particularly useful in large documents. You can use 
Highlight Tag to highlight the corresponding tagged text block in the Word 
window.

Method: Highlight a tag

1. Place your cursor on the Tag Name in the Tag View.
2. Select Customizer > Highlight Tag.

IStream Customizer highlights the matching tagged text block in the Word 
window.
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Using the Navigation Buttons
The IStream Customizer toolbar has four buttons that help you navigate the Tag 
Names and tagged text blocks. 

To use these buttons, place your cursor in the Tag View, then select one of the 
options to move your cursor down or up in the Tag View, highlighting the 
matching tagged text block in the generated document.

The navigation buttons are: 

Button Action

moves the cursor to the first Tag Name in the Tag View

moves the cursor to the last Tag Name in the Tag View

moves the cursor up one Tag Name in the Tag View

moves the cursor down one Tag Name in the Tag View
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Chapter 4
Custom Wordings

This chapter describes:

• Understanding Custom Wordings on page 46

• Viewing Custom Wording Properties on page 47

• Custom Wordings Properties on page 48

• Working with Custom Wordings on page 52
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Understanding Custom Wordings

Custom wordings are changes applied to a generated document. The process of 
applying custom wordings is called customization.

Custom wordings are applied to sections of a document called tagged text blocks. 
For more information, see Tagged Text Blocks on page 38.

Custom wordings can be added to a document at the page, paragraph, line or word 
level. They do not affect the formatting of the existing document, except the 
pagination when text is added or removed.

Note: The more wordings an IStream document has, the longer it will take to regenerate.
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Viewing Custom Wording Properties

Before you can view or change the properties of a custom wording, the generated 
document must be open and have custom wordings.

Method: View custom wording properties

1. In the Tag View, click the Wording Name of the custom wording you want 
to view, or click within the applied custom wording’s text in the IStream 
document in the Word window.

2. Do one of the following steps:

• Select Wording > Wording Properties.

- OR -

• In the Tag View, right-click the custom wording you want to view and 
select Wording Properties from the pop-up menu.

The Custom Wording Properties dialog box opens, displaying all 
properties attached to the custom wording.

For descriptions of these properties, see Custom Wordings Properties on 
page 48.

3. Click OK to close the Custom Wording Properties dialog box.
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Custom Wordings Properties

The Custom Wording Properties are:

• Section Name on page 48

• Tag Name on page 48

• Wording Name on page 48

• Description on page 48

• Customization Modes on page 48

• Disable Wording on page 49

• Effective Dates on page 49

• Termination Dates on page 50

To view or edit the Custom Wording Properties, see Viewing Custom Wording 
Properties on page 47.

Section Name
Section Name is the name of the section of the model document that the IStream 
document was generated from. IStream Customizer enters this name 
automatically.

Tag Name
Tag Name is a name given to a tagged text block when the document is created in 
Author. You can see a list of all the Tag Names in the Tag View. Tag names 
cannot be more than 64 characters long.

Wording Name
Wording Name is the name that you give to the custom wording you create. The 
Wording Name appears in the Tag View below the Tag Name with which it is 
associated. Wording Names apply only to the generated document and can also 
be the same as the Tag Name. It cannot be more than 64 characters long.

Description
A Description includes any information that may be useful in identifying or 
explaining a custom wording. It cannot have more than 32,768 characters.

Customization Modes 
Customization Modes are the types of changes that you can make to a tagged text 
block. There are four types:

• Before inserts a custom wording before the tagged text block

• After inserts the custom wording after the tagged text block
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• Replace replaces the tagged text block with a custom wording

• Delete removes the tagged text block

Replace and Delete are mutually exclusive modes and therefore only one can be 
applied within the effective time period.

An icon indicating the applied customization mode appears next to the Wording 
Name in the Tag View.

Disable Wording
If you select the Disable Wording option, IStream Customizer will exclude the 
custom wording regardless of the document’s Effective Date. This lets you create 
custom wordings for a future use, so that you can compare the current document 
with how it will look with the custom wording.

IStream Customizer grays out the Wording Name of the disabled custom 
wording in the Tag View.

When the Disable Wording option is cleared, IStream Customizer includes the 
custom wording in the document during regeneration or QuickGen.

Effective and Termination Dates
This section describes:

• Effective Dates on page 49

• Termination Dates on page 50

• Changing the Effective or Termination Dates on page 50

• Effective and Termination Date Overlap on page 51

Effective Dates
The Effective Date is the starting date of the custom wording. Each custom 
wording must have an Effective Date that is no later than the Termination Dates 
applied to the custom wording. The default date is the current system date.

IStream Customizer compares the custom wording Effective Date to the 
Generation Test Date, which is a date you can specify to test customizations. 
This comparison tells Assembler when to start including the customizations in the 
generated document. For more information on the Generation Test Date, see 
Setting the Generation Test Date on page 67.

For details on how to change the Effective Date, see Changing the Effective or 
Termination Dates on page 50.

Important: Ensure that your Effective and Termination Dates do not overlap. (See Effective 
and Termination Date Overlap on page 51.)
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Termination Dates
The Termination Date is the end date of the custom wording. IStream Customizer 
will stop including the customization in the document on this date. Click Clear to 
remove any date from this field.

If the custom wording does not have a Termination Date, IStream Customizer 
will continue to include the customization indefinitely. A custom wording’s 
Termination Date should follow its Effective Date.

For details on how to change the Effective Date, see Changing the Effective or 
Termination Dates on page 50.

Changing the Effective or Termination Dates
You can change the Effective Date if the custom wording should be in effect 
sooner or later than originally planned.

You can also change the Termination Date if the custom wording should be in 
effect for a longer or shorter amount of time than originally planned.

Method: Change the dates of custom wordings

1. In the Custom Wording Properties dialog box, click the arrow next to the 
Effective Date or Termination Date to open the drop-down calendar.

2. Select a date from the drop-down calendar:

a. Use the  and  arrows to select a month.

b. Click a date to select it.

If you do not enter a date, the Effective Date will be the current system date.
3. Click OK to save the changes.
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Note: A prompt displays if the Effective and Termination dates of another custom 
wording in the tag overlap with the selected Effective and Termination dates. For 
more information, see Effective and Termination Date Overlap on page 51.

Effective and Termination Date Overlap
If you have more than one occurrence of a specific type of custom wording for a 
tag, the Effective and Termination Dates for those custom wordings cannot 
overlap. However, overlap may be allowed between different types of custom 
wordings in a tag.

The following table indicates when overlapping dates are allowed:

Customization Mode of 
Custom Wording 1

Customization Mode of 
Custom Wording 2

Overlapping 
Allowed?

Before Before No

Before After Yes

Before Replace Yes

Before Delete Yes

After After No

After Replace Yes

After Delete Yes

Replace Replace No

Replace Delete No

Delete Delete No
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Working with Custom Wordings

This section describes the functions you can perform with custom wordings:

• Creating Custom Wordings on page 52

• Using QuickGen on page 54

• Removing a Custom Wording on page 54

• Editing Custom Wordings on page 54

• Text and Formatting in Custom Wordings on page 55

• Saving Custom Wordings on page 56

• Closing Custom Wordings on page 56

• Copying Custom Wordings on page 57

• Orphaned Custom Wordings on page 58

Creating Custom Wordings

Method: Create new custom wordings

1. Open a document in IStream Customizer.
2. Select the Tag Name from the Tag View of the tagged text block you want 

to customize, or click within the tagged text in the body of the document.

3. Select Wording > Add Wording, or click  on the toolbar.

The Custom Wording Properties dialog box opens if you have configured 
IStream Customizer to display it. See Set the Custom Wording options on 
page 31.
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Note: If you click outside of a text tag in your IStream document and try to apply a 
wording, IStream Customizer will apply the wording to the last tag in your 
document by default.
4. If you have configured IStream Customizer to display the Custom Wording 

Properties dialog, then complete the following fields:

• Wording Name (this cannot be more than 64 characters)

• Effective Date

• Termination Date (optional)

• Description (optional).

See Custom Wordings Properties on page 48 for more information on 
Custom Wording properties.

If you have configured IStream Customizer not to display the Wording 
Properties dialog, a new wording will automatically be added with the 
following default properties:

• a Wording Name comprised of the Tag Name followed by a digit

• a Customization Mode of Replace

• an Effective Date equal to the current date

• a blank Termination Date and a blank Description

Note: If a Replace wording already exists and is within the Effective Date and 
Termination Date range of the new wording, a message will be displayed 
indicating there is a conflict. To resolve this, you will need to check the properties 
of the existing wording.
5. Select a Customization Mode. (See Customization Modes on page 48 for 

more information on customization modes.)
6. Click OK to exit the Custom Wording Properties dialog box.



CUSTOM WORDINGS

54 ISTREAM CUSTOMIZER VERSION 6.2 USER GUIDE

IStream Customizer automatically opens Word if you selected the Before, 
After or Replace Customization Mode.

If you select Delete, the Word window does not open. Text from the original 
tagged text block will not appear during QuickGen and will be deleted 
during regeneration.

7. Enter the new custom wording in the Word window that opens if you select 
Before, After or Replace.

Using QuickGen
After creating one or more custom wordings, you can use QuickGen to view what 
the document will look like with the wordings included. For more information, 
see QuickGen on page 73.

Applying a Custom Wording
You can apply one or more custom wordings by regenerating the document. See 
Generating a Document on page 40.

Removing a Custom Wording
If you created a custom wording by mistake, you can remove it.

Method: Remove a custom wording

1. Click a Wording Name in the Tag View, or click within the wording that 
you want to remove in the body of the document.

2. Select Wording > Remove Wording.

You are asked if you want to permanently delete the custom wording.
3. Click Yes.

IStream Customizer removes the wording from Tag View.

Editing Custom Wordings
IStream Customizer allows you to edit custom wordings. However, you should 
not edit variables or expressions (information that appears between <  > angle 
brackets). This may create invalid variables or expressions, causing errors when 
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you regenerate or QuickGen the document. You must also avoid adding headers 
and footers to a custom wording.

Method: Edit a custom wording

1. With your IStream document open, select the custom wording in the tree 
view, or click within the wording in the body of the document.

2. Click  to open the selected wording.

Note: If you did not select a wording properly, an error message displays. If you see this 
message, make sure that you have selected a wording, and then try again.
3. Edit the wording in the Word window.
4. Select Wording > Close Wording from the Wording menu.

Text and Formatting in Custom Wordings
Formatting applied to text in a custom wording may affect the text following the 
custom wording. For example, if you format text in a custom wording to be bold 
and italic, the text following the wording may inherit the bold and italic setting, 
even though it is not formatted this way in the model document.

To prevent this, select the last paragraph marker (¶) at the end of the custom 
wording and apply the formatting that should follow the custom wording to the 
paragraph marker. Text following the marker should inherit the formatting 
assigned to the paragraph marker.

Formatting Example
In the following example, the paragraph marks (¶) are displayed for reference. 
The line “this text should be bold and italic” is a custom wording that will be 
edited in IStream Customizer. In this example, the custom wording should be bold 
and italic, but the text following should be plain text.

In the following custom wording,¶
this text should be bold and italic¶
but this text should be plain.¶

The output for this example will incorrectly be:

In the following custom wording,¶
this text should be bold and italic¶
but this text should be plain.¶

To fix this, select the very last paragraph marker in the custom wording. Apply the 
formatting for the text that follows the custom wording to the paragraph marker. 

In this example, you would select the paragraph marker at the end of:

this text should be bold and italic¶
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and apply the formatting that should apply to the text following the custom 
wording to the paragraph marker. Text following the marker will inherit the 
formatting assigned to the paragraph marker.

Saving Custom Wordings
Saving custom wordings includes the custom wordings in the document when it is 
QuickGen’d or regenerated. You do not need to regenerate the document to save 
newly created or changed custom wordings. You can choose to save a single 
custom wording or all the custom wordings you have created since the last time 
you regenerated the document.

Note: IStream Customizer automatically saves the custom wording properties when you 
click OK in Wording Properties.

Saving a Single Custom Wording

Method: Save a single custom wording

1. Select the custom wording by clicking in the Word window containing the 
custom wording.

2. Select Save Wording from the Wording menu or click .

IStream Customizer automatically saves the custom wording.

Saving All New Custom Wordings
To save all the custom wordings that have been created since the document was 
last regenerated, select Wording > Save All Wordings. IStream Customizer 
saves all new custom wordings.

Closing Custom Wordings
When you close the Word window containing the custom wording, IStream 
Customizer checks if there have been any changes since the wording was last 
saved. If there are, IStream Customizer prompts you to save the most recent 
changes before you close.

Note: If your QuickGen default is set to Auto, you are prompted to close all custom 
wording windows so that a QuickGen can be performed. If your QuickGen default 
is set to Prompt, you are asked if you want to perform a QuickGen. For more 
information, see QuickGen on page 73.

Method: Close a custom wording

1. Select the custom wording by clicking in the Word window containing the 
custom wording.
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2. Complete any of the following steps:

• Click the close button [X] in the upper right corner of the Word window.

• Select Wording > Close Wording.

• Click the Close Wording button  in the toolbar. 

IStream Customizer checks if there have been any changes since the 
wording was last saved. If there are, you are asked if you want to save your 
most recent changes.

3. Click Yes to save the custom wording.

Copying Custom Wordings
IStream Customizer lets you copy text from one custom wording to another, and 
from one document to another. 

Method: Copy custom wordings in IStream Customizer

1. Open the custom wording you want to copy.
2. Highlight the text to be copied.
3. Select Edit > Copy.
4. Open the destination custom wording.
5. Select Edit > Paste.

IStream Customizer copies the text from the original custom wording to the 
destination custom wording.

Method: Copy a custom wording from one document to another

1. Copy the custom wording.
2. Close the document you are copying from.
3. Open the document to which you are copying the custom wording.
4. Paste the custom wording into this document.
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Orphaned Custom Wordings
Orphaning occurs when the tagged text block associated with a custom wording 
does not exist. There are four reasons why this may happen. The following table 
lists the reasons, and suggested resolutions.

IStream Customizer can be set to display or hide orphaned custom wordings in the 
Tag View. For details, see Setting IStream Customizer Options on page 30.

When the IStream Customizer options are set to display orphaned wordings, 
orphaned wordings are displayed in the Tag View with this icon: .

To open an orphaned custom wording:

• double-click the Wording Name in the Tag View

• select Wording > Open Custom Wording

• click  on the toolbar

Setting the Orphaned Custom Wording Options
You can set up IStream Customizer so that orphaned custom wordings are 
displayed or hidden from the Tag View.

When orphaned tags are set to show, orphaned tags in the document are displayed 
in the Tag View.

Reason for orphaned 
custom wording Suggested resolution

The name of the tagged text block 
associated with the custom wording was 
changed in Author.

Resolve the difference in Author or 
IStream Customizer.

The tagged text block associated with 
the custom wording was removed in 
Author.

Remove the custom wording.

The tagged text block associated with 
the custom wording was not included 
because of a condition created by IF 
statements.

Do nothing. This is an acceptable 
orphan.

IStream Customizer’s option to include 
tag information during regeneration was 
disabled.

Enable Include Tag Information in 
the Generation options. For more 
information on Generation Modes, 
see Selecting the Generation Mode 
on page 39.
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When orphaned tags are set to not show, orphaned tags in the document are not 
displayed in the Tag View.

Method: Set the orphaned tag options

1. Select Customizer > Options.
2. Select or clear the Show orphaned tags checkbox as required.
3. Click OK.
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Chapter 5
Customized Documents

This chapter describes:

• Understanding Customized Documents on page 62

• Opening an IStream Document on page 63

• Locating a Tag Name on page 64

• Adding a Custom Wording on page 65

• Saving the IStream Document on page 66

• Setting the Generation Test Date on page 67

• Regenerating a Document on page 68

• Printing a Customized Document on page 69

• Viewing a PDF of a Generated Document on page 70

• Closing a Document on page 71
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Understanding Customized Documents

A customized document is an IStream document that has custom wordings 
applied it when you regenerate the document. You can also perform a QuickGen 
which allows you to see any saved custom wordings as they are created. (For 
more information, see QuickGen on page 73.)
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Opening an IStream Document

Note: You can open any IStream document in the Word window within IStream 
Customizer. If the CLG files you want to work with are stored on a file system, 
you will need to ensure that you have configured an InfoSource to point to this file 
system’s location.

Note: Opening an IStream document from the DMS locks it to prevent other users from 
modifying it until you have completed working with it.

Method: Open a document in IStream Customizer

1. Select File > Open.

You are directed to the default repository (where generated documents are 
stored).

2. Select the file you want to open, then click Open.

If the document does not already have custom wordings, you will be asked if 
you want to import custom wordings from another document.

3. To import custom wordings from another IStream document that already has 
custom wordings defined, click Yes. See Importing Custom Wordings from 
Other Documents on page 22 for instructions on importing custom 
wordings.

To open the selected document without importing custom wordings, click 
No.
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Locating a Tag Name

To add a custom wording to the generated document, you must first be able to 
locate the Tag Name for it. See Locating a Tag or Tagged Text Block on page 42 
for ways to locate a Tag Name.
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Adding a Custom Wording

When you select Add Wording while your cursor is positioned on the Word pane, 
the Retrieve Tag process runs, and the relevant tag is automatically selected in the 
Word pane. This reduces the need to display the Tag View. Closing the Tag View 
gives additional space to view the document.

After you locate a Tag Name you can add a custom wording. See Creating 
Custom Wordings on page 52 for more information.
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Saving the IStream Document

Once you finish adding custom wordings, you must save your IStream document.

Method: Save an IStream document

• Select File > Save or click the Save button on the toolbar. Filenames for 
IStream documents can contain a maximum of 64 characters.

Please note:

Tip: IStream Customizer does not assign a new name to the document unless you select 
File > Save As.
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Setting the Generation Test Date

If your document contains custom wordings or document sections with different 
Effective Dates, you can use the Generation Test Date to ensure the custom 
wordings work properly.

For example, you may have a document where some custom wordings will not 
come into effect until several months from now. To test the document, set the 
Generation Test Date to the Effective Date for the custom wordings. When you 
regenerate it, the custom wordings will function as if they have been activated.

Generation Test Dates are not supported with QuickGen. For more information 
about QuickGen, see QuickGen on page 73.

Method: Set the Generation Test Date

1. Select File > Properties.

The IStream Document Properties dialog opens.

2. Click Generation Test Date.

3. Select a date from the drop down calender, using the  and  arrows 
to select a month. Click a date to select it. If you do not enter a date, the 
Generation Test Date is the current system date.

4. Click OK to exit the IStream Document Properties dialog.

When you regenerate your document, your custom wordings will act 
according to the Generation Test Date you selected. If the selected date is 
on the Effective Date or within the Effective Date range of a custom 
wording, the wording will be included in the generated document.
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Regenerating a Document

Regenerating a document automatically applies all new and existing custom 
wordings. 

Before regenerating a document, you can use the QuickGen feature to view any 
custom wordings you have created and saved. For more information, see 
QuickGen on page 73.

Note: If the Track Changes feature is enabled in Word, you need to accept all changes 
after modifying any expressions, before you regenerate the document using either 
QuickGen or full generation.

During regeneration all custom wordings are applied if: 

• the Disable Wording option has not been applied

• they have a valid Effective Date and may have a valid Termination Date, 
or

• they are relevant to the tagged text blocks being generated.

Note: When an IStream document is being customized, if the model document it 
originated from is changed in IStream Author, the changes will not be applied to 
the CLG file until IStream Customizer is restarted and the document is 
regenerated.

Note: If your IStream document was edited in IStream Customizer and contains custom 
wordings, when you Export CLG to PDF, the PDF created will not be 
regeneratable.

If there are no Tag Names after you have regenerated the document, check if the 
document is customizable: see Preparing to Work with Tagged Text Blocks on 
page 39.

Note that the more wordings you have in an IStream document, the longer it will 
take to regenerate.

For more information, see Generating a Document on page 40.
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Printing a Customized Document

Once the document is regenerated and includes the customizations, you can print 
it.

Method: Print a customized document

1. Ensure that the cursor is in the Word window.
2. Select File> Print.

The document prints.
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Viewing a PDF of a Generated Document

You can view a .CLG document in PDF format from IStream Customizer. You 
will need a PDF viewer (such as Adobe Reader).

Method: View a PDF of a .CLG file

1. Ensure a .CLG file is open in IStream Customizer.

2. Select File > View PDF, or click the View PDF button  on the toolbar.

IStream Customizer generates a PDF of the .CLG file, and the PDF opens in 
your PDF viewer. Within the viewer, you can save the PDF if you want to 
refer to it later.
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Closing a Document

When you close a document, IStream Customizer checks if the document or 
custom wordings have been changed since the document was last modified.

Method: Close a document in IStream Customizer

1. Select File > Close.

IStream Customizer checks if there have been any changes to the document. 
If not, IStream Customizer closes your document. If there have been 
changes, you are asked if you want to save the changes to the IStream 
document. 

2. Click Yes to save the document.

IStream Customizer saves and closes your document. 

Note: After you close a document, it is unlocked in the DMS and other users can 
customize it.
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Chapter 6
QuickGen

This chapter describes:

• QuickGen on page 74

• Using QuickGen on page 75



QUICKGEN

74 ISTREAM CUSTOMIZER VERSION 6.2 USER GUIDE

QuickGen

You can use the QuickGen function in IStream Customizer to immediately view 
changes you have made to a document by adding, editing or removing custom 
wordings.

QuickGen is similar to a generation but is faster because it does not need IStream 
Customizer to connect to the database to retrieve variable values: see Customized 
Documents on page 61.

Comparing QuickGen and Full Generation
The following table summarizes the differences between QuickGen and full 
regeneration.

Warning: If the database or variables within the model document have changed, these 
changes will not be reflected in the QuickGen results. If you add new variables or 
coding expressions in a custom wording, they cannot be processed by QuickGen 
and an error appears in the message log and within the context of the document. 
To incorporate these new variables and coding expressions into the document, you 
must do a full regeneration.

Unsupported Date Features
QuickGen always uses the current system date to determine which wordings to 
include. Because of this, the following features are not supported in QuickGen:

• Generation Test Dates – for more information, see Setting the Generation 
Test Date on page 67

• the EFFECTDATE variable in model documents created with IStream Author

Therefore, if you need to use these features, use the full generation method 
instead.

Process QuickGen Full Regeneration

Updates variable information from the 
database or XML file.

No Yes

Model document changes are incorporated in 
the customizable document.

No Yes

Custom wording information is saved in the 
background.

Yes Yes

Wording information is not saved into the 
document until the IStream document is 
saved.

Yes Yes
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Using QuickGen

This section describes how a QuickGen is performed based on your QuickGen 
default settings, and describes:

• Automatic QuickGen on page 75

• Prompt for QuickGen on page 75

• Manual QuickGen on page 77

• QuickGen and Open Wording Windows on page 77

Modifying the QuickGen Default Setting on page 77

Note: If the Track Changes feature is enabled in Word, you need to accept all changes 
after modifying any expressions, before you regenerate the document using either 
QuickGen or full generation.

Automatic QuickGen
If the default QuickGen setting on your computer is Auto, a QuickGen is 
performed when you:

• import custom wordings

• save and close a custom wording window

• delete a wording

• change the properties of a wording

All new and saved changes are immediately applied and displayed in the CLG 
document open in the Word Window: see Viewing the IStream Customizer Screen 
on page 21.

Important: For QuickGen to work, the generated document (CLG file) in use must have been 
generated with the QuickGen setting enabled. This setting is always used when 
generating locally with IStream Customizer, but your system administrator must 
ensure that this setting is also enabled on the Assembly Server and Publisher 
Workers.

Prompt for QuickGen
If the default QuickGen setting on your computer is Prompt, a prompt is 
displayed asking you if you want to perform a QuickGen when you:

• import custom wordings

• save and close a custom wording window

• delete a wording

• change the properties of a wording.

Click Yes and all new and saved changes are immediately applied and displayed 
in the CLG document open in the Word Window: see Viewing the IStream 
Customizer Screen on page 21.



QUICKGEN

76 ISTREAM CUSTOMIZER VERSION 6.2 USER GUIDE

Click No and the custom wording window is closed and no changes are displayed.
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Manual QuickGen
You can choose to perform a QuickGen manually any time. 

Method: Perform a manual QuickGen

Do either of the following actions:

• select QuickGen on the Customizer menu

• click the QuickGen toolbar button 

If there are multiple custom wording windows open, they are closed: see 
QuickGen and Open Wording Windows on page 77.

The Log View is displayed, showing the progress of the QuickGen.

When the QuickGen has been completed successfully, the Outline Explorer will 
change from the Log View to the Tag View and all new or saved changes are 
immediately applied and displayed in the CLG document open in the Word 
Window: see Viewing the IStream Customizer Screen on page 21.

If the QuickGen is unsuccessful, an error appears in the log view.

QuickGen and Open Wording Windows
If multiple custom wording windows are open and you have selected to perform a 
QuickGen, a prompt is displayed advising that all wording windows must be 
closed before performing a QuickGen.

IStream Customizer will ask whether you want to save the changes to each open 
custom wording. Select Yes or No to determine which wordings to save. Once all 
custom wordings have been closed, a QuickGen will be performed as requested.

Modifying the QuickGen Default Setting
The default setting for QuickGen is chosen when IStream Customizer is installed. 
(For more information about this setting, see the IStream Document Manager 
Installation Guide). However, you can change this setting anytime by using the 
QuickGen tab in IStream Customizer options. For more information, see 
QuickGen Tab on page 34.
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Chapter 7
Model Documents

This chapter provides tips for creating model documents in Author for use with 
IStream Customizer, and describes tag names and variables.
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Tag Names in Model Documents

To allow customizations, a model document must have a tag name, or tag, 
associated with any text blocks you want to customize. Tag names identify the 
tagged text blocks.

Example: Here is an example of a tagged text block:
TEXT TAG Alter
In case of accidental death, the benefit payable is doubled.
ENDTEXT
INITIALIZE CLASS
TEXT TAG "Alter" + class_no
For class <class_no> there is an additional paragraph.
ENDTEXT
DEFINE CLASS_NO CLASS_NO+1
NEXT

The tag names you would see in the Tag View are

• “Alter”

• “Alter1” (first class)

• “Alter2” (second class), and so on. 

Note: Tag names cannot be more than 64 characters long.

Using a Variable as a Tag Name
The following example shows how you can use a VARIABLE as TAG name:

Example: DEFINE variable "tag123"
TEXT TAG <variable>
....
ENDTEXT

This can be useful if you want to create a unique series of TAGs. If you have a TAG 
inside a loop, then each resulting paragraph will have the same TAG in 
Customizer. If you want each paragraph to have a unique TAG in Customizer, you 
can add a variable to the TAG name. 

Example: DEFINE Count 1
DO WHILE Count < 10
TEXT TAG <count>

The number is <count>...

ENDTEXT
DEFINE Count Count +1
ENDDO

This will create nine paragraphs, each with a unique TAG.
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Note: When an IStream document is being customized, if the model document it 
originated from is changed in IStream Author, the changes will not be applied to 
the CLG file until IStream Customizer is restarted and the document is 
regenerated.
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Appendix A
Server and User Information

This chapter describes:

• Displaying Server Information on page 84

• Displaying User Information on page 85
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Displaying Server Information

You can display information about the IStream Assembly Server, including its 
name and port number.

Method: Display server information

• Select Customizer > Server Info.

The Assembly Server Machine Information dialog opens.

• The Server Address is the name of the Assembly Server.

• The Server Port is the port number of the Assembly Server.

The following table specifies the server to which IStream Customizer submits the 
requests for generation when you click Regenerate, depending on the values you 
enter in these two fields: 

Please note 
• You can generate from IStream Customizer using local generation if it is 

available (if Author workstation is installed on the same client system), or 
remote generation if the Assembly Server is installed on a server.

• IStream Customizer must be shut down and restarted when you change the 
Assembly Server information.

Server Address Server Port Result

local 4300 the locally installed IStream Assembler 
will generate the documents

an IP address or 
a host name

4300 the documents will be generated on a 
remote server
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Displaying User Information

In the User Information dialog box, you can set the default values for the user ID 
and password, and the proxy ID and password. These credentials are used if 
IStream Customizer was launched, for example, as a standalone application from 
a client system. If IStream Customizer is started from the DMS, then the DMS 
passes user and proxy credentials, and these are in effect instead of the default 
credentials set in IStream Customizer.

User information is passed by IStream Customizer to other IStream components. 
Assembler compares the components to verify the user credentials and 
permissions to use model documents and their sections, or access any other data 
or information needed during the document generation.

Method: Display the User Information

• Select Customizer > User Info.

The User Information dialog opens.
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Appendix B
Frequently Asked Questions

This section contains various frequently asked questions about IStream 
Customizer.
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Can I have multiple custom wordings for one tagged text block?
Yes, however it is important to remember that Replace and Delete are mutually 
exclusive and therefore only one of them can be associated with the tag text block 
in a time period.

Why does the Wording Name does not appear in the regenerated 
document after creating a custom wording?
Check these points:

Has the default Generation Mode been selected?

1. Select Customizer > Options.
2. Click the Generation Mode tab.
3. Check if the document is being generated with both tag info and 

customizations.

Is the Disable Wording option selected? 

If it is, remove the Disable Wording option. See Disable Wording on page 49.

Does the effective time period include today's date? 

If not:

1. Open the Custom Wordings Properties dialog.
2. Change the Effective Date or Termination Date.

or

Change the effective period to include today’s date.

For more information about these fields, see Custom Wordings Properties on page 
48.

Is the custom wording associated with the tags of the model document being 
generated? 

If not, ensure that the custom wording is attached to the correct tagged text block.

How can I tell if the block of text I want to work with is a tagged text 
block?
1. In the Word window, place your cursor at the point in the document where 

you want to make changes.
2. Select Customizer > Retrieve Tag, or click the Retrieve Tag button.

If the text is tagged, the tag name will be highlighted.

You can also use the IStream Customizer Options to apply color to the text 
blocks to distinguish them from other text or custom wordings.
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If I apply three modes of customization to a text block, (for example: 
before, after, and delete) will I orphan the custom wordings that are 
being inserted before and after the delete tagged text block?
No, the original tag is still listed in the Tag View and therefore the new custom 
wordings have a reference.

How do you highlight a tagged text block?
You can highlight a tagged text block by clicking the Tag Name in the Tag View. 
As you scroll through the Tag View, the corresponding tagged text blocks become 
highlighted. You can also click a Tag Name and select Customizer > Highlight 
Tag.

Why is the QuickGen button grayed out after opening an IStream 
document in IStream Customizer?
QuickGen requires that a customized document be updated to include additional 
information in the file. This occurs as part of the document assembly process or 
when performing a full generation when the document is first opened in IStream 
Customizer. See your system administrator for additional information.

Note: When the document is generated for the first time, the two checkboxes in the 
Options > Generation screen must be selected:

1. Select Customizer > Options.
2. Click the Generation tab and ensure that the following check boxes are 

selected:

• Include Tag Information

• Include Custom Wordings
3. Perform a full regeneration.

The QuickGen button will be enabled.

Why are the tags in the Tag View not highlighted?
When using IStream Customizer on Windows XP, ensure that you use the 
Windows Classic style appearance to be able to highlight tags correctly. See 
Change Windows XP display settings to Classic style on page 20.
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Appendix C
Running Macros

This appendix describes how to run Microsoft Word macros within IStream 
Customizer.
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Running Microsoft Word Macros

You can run Microsoft Word macros within IStream Customizer to make changes 
to a generated document, such as updating a table of contents

A generated document is normally protected, preventing you from making 
changes other than through custom wordings. By using macros, you can 
unprotect, modify, and then re-protect the generated document.

Note: Before using a macro to update your document, you need to perform any required 
QuickGens or full regenerations, or the changes will be lost during the generation 
process.

If you have applied tag or wording colors in IStream Customizer and made 
modifications using this feature, the color will be saved as part of the 
modification.

You use the Protect and Unprotect methods to enable your custom Microsoft 
Word macro code to change the IStream generated document.

Warning: You should not use tag and wording colors when using Protect and Unprotect.

Unprotect
The Unprotect macro removes the protection from the currently active IStream 
document in IStream Customizer that was protected either by IStream Customizer 
or by calling the Protect method. Once an IStream document in IStream 
Customizer is unprotected, it must be protected again so that IStream Customizer 
can work properly.

Note: Unprotect cannot unprotect a document that was protected with a custom 
password.

You should use Unprotect inside a Microsoft Word macro.

Protect
The Protect macro protects the currently active IStream document in IStream 
Customizer.

The document that is being protected can only be unprotected by IStream 
Customizer or by calling the Unprotect method.

Note: You should use Protect inside a Microsoft Word macro.

Macro Example
dim cmzUtil
set cmzUtil = CreateObject("Customizer.Preview")

cmzUtil.unprotect
'{do custom processing}
cmzUtil.protect
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set cmzUtil = nothing
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INDEX

A
applied wording, selecting color for, 31
applying

custom wordings, 54
customization modes to text blocks, 89

C
classic style Windows display, 20
closing custom wordings, 56
closing documents, 71
collapsing tag list in tag view, 24
color, using to distinguish text types, 41
contacting Skywire Software for help, 17
custom template, 33
custom wordings

adding, 52, 65
applying, 54
closing, 56
color, using to distinguish, 41
copying text to another, 57
definition, 11
description, 48
disabling custom wordings, 49
editing, 54
effective date

changing, 50
overview, 49

headers and footers in, 55
icons

after, 27
applied, 27
before, 27
delete, 27
replace, 27

importing, 22
naming, 48
orphaned, 58
orphaned, options, 58
overview, 62
properties, 47

changing, 48
customization mode, 48
description as property of, 48
disable wording, 49
effective date, 49
hiding, 32
overview, 48
section name, 48
tag name, 48

termination date, 50
wording name, 48

removing from documents, 54
saving, 56
saving all, 56
saving single, 56
termination date, setting, 50
text and formatting, 55
types, 48

see also customization mode
customizable

description, 39
documents from DMS, opening, 36

customization mode
after, 48
applying multiple, 89
before, 48
delete, 49
description, 48
icons showing modes in tag view, 49
replace, 49

customizing
documents, opening, 36
model documents, 79

D
dates, avoiding overlap, 51
default repository, selecting, 31
deleting tagged text blocks, 49
description, as property in custom wordings, 48
display settings, 20
DMS, 9
document conventions, 8
documentation, IStream Document Manager, 12
documents

closing, 71
confirming addition of custom wordings, 39
customizing, 36
generating customized, 61
generation engine, assembly, 9
IStream

importing wordings, 22
locating tagged text blocks, 42
management system (DMS), 9
model

definition, 10
section name, 48
use in Customizer, 48

printing customized, 69
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regenerating an IStream, 40
setting permissions, 35

dotted square with tag icon, 24

E
EFFECTDATE and QuickGen, 74
effective dates

avoiding overlap, 51
description, 49
for custom wording, changing, 50
setting for custom wording, 49

expanding tag list in tag view, 24

F
filenames for IStream documents, maximum, 66
footers in custom wording, 55
formatting

example, 55
in custom wordings, 55

G
general tab, 30
generate button, using to regenerate, 40
generated document, viewing PDF of, 70
generation

mode, selecting, 39
test date, setting, 67
test dates and QuickGen, 74

H
headers in custom wording, 55
help, contacting Skywire Software, 17
help, online

see online help
highlighting tags, 42

I
icons

custom wording in tag view, 49
importing wordings, 22
index, using in online help, 15
IStream

Assembler
generating documents locally, 84
server description, 9

Author, 9
InfoConnector, 9

IStream documents
locating tagged text blocks in, 42
maximum filename length, 66
opening, 63
overview, 10
properties, viewing, 29

regenerating, 40

L
Livelink menus, 21
locating tags in Customizer, 42
log, word processor for printing, 30

M
macros

protect, 92
setting color options, 32
unprotect, 92

maximum filename length, 66
menus, Livelink, 21
message log

description, 27
printing, 28
viewing, 27
window, 27

model documents
customizing, 79
definition, 10
from IStream Author, 81
section name, 48

multiple wordings in tagged text block, 88

N
navigation buttons, 43

O
online help

index, using, 15
navigating, 15
printing topics, 16
searching, 14
table of contents, using, 15
using, 14

opening
IStream Customizer, 20
IStream documents, 63

options
applied wording color, 31
general tab, 30
IStream Customizer, 30
tagged text color, 31
word processor for printing log, 30
wording template tab, 33

orphaned custom wordings, 58
options, 58

overlap, avoiding in dates, 51

P
PDF, viewing of generated document, 70
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pencil symbol on folder, 24
printing

customized documents, 69
message log, 28

protect, 92

Q
QuickGen

automatic, 75
EFFECTDATE, 74
generation test dates, 74
icon greyed out, 89
introduction, 74
macros, 32
manual, 77
modifying default settings, 77
open wording windows, 77
prompt for, 75
tab, 34
using, 75
vs. full generation, 74

R
regenerating documents, 68
removing custom wordings from documents, 54
replacing tagged text blocks with custom wording, 49
repository, selecting default, 31
retrieving tags in custom wordings, 42

S
saving

all custom wordings, 56
custom wordings, 56
generated documents, 66
IStream documents, 66
single custom wordings, 56

screens, Customizer, 21
searching the online help, 14
server information, Assembly, 84
setting Customizer options, 30
Skywire Software, contacting for help, 17
support checklist, 17

T
table of contents, using in online help, 15
tagged text block

color, using to distinguish, 41
definition, 10
description, 38
highlighting, 89
identifying, 88
locating in Word window, 42
multiple wordings in, 88

tag name, identifying, 11
tagged text, selecting color for, 31
tags

customized, 24
highlighting tagged text block, 42
identifying, 24
information, 39
limitations, 38
name

creating in author, 80
description, 48
locating in tag view, 42
text blocks, 11
using variables as, 80

new, 24
not highlighted in tag view, 89
retrieving tag names in tag view, 42
tag view window, 23
view

changing display of, 25
collapsing tag list in, 24
description, 23
expanding tag list in, 24
icons for custom wording changes, 49
locating tag names in, 64

technical support, 17
template, Wording, 33
termination dates

avoiding overlap, 51
description, 50

text
in custom wordings, 55
tag name...endtext rule, use in Customizer, 38

track changes, configuring, 32

U
unprotect, 92
user information, 85

V
variables, using as tag names, 80
viewing

IStream document properties, 29
tags in Customizer, 24

W
Windows display settings, 20
Word

as main word processor, 21
locating tagged text blocks, 42
viewing in Customizer, 21
window, 21

word processor for printing log, 30
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wordings
custom, see custom wordings
deleting tagged text blocks, 49
inserting text

after tagged text blocks, 48
before tagged text blocks, 48

name
definition, 11
description, 48
identifying, 11
not appearing, 88

replacing tagged text blocks, 49
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