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Introduction

This guide provides instructions for installing and updating Oracle BPM 10.3.

Document Scope and Audience
This guide is written for system administrators and users who need to install Oracle BPM or apply updates
to an existing installation. It provides information about requirements, supported platforms and installation
procedures.

This guide covers Oracle BPM Studio and Oracle BPM Enterprise.

About Oracle BPM Enterprise

To install Oracle BPM Enterprise, you should have strong knowledge of the platform and operating system
used for the installation.

This guide provides the information and procedures for installing the Oracle BPM software on your system.
You must follow additional configuration procedures to have a fully functional Oracle BPM Enterprise
environment. Refer to the Configuration Guide and Administration Guide for information on configuring and
administering an Oracle BPM Enterprise installation.

Oracle Documentation and Resources
This section describes other documentation, resources, support, and training information provided byOracle.

The table below lists a number of Oracle Documentation and Resources which will help you get started with
Oracle BPM.

DescriptionResource

The complete Oracle BPM 10.3 product documentation is available at
http://download.oracle.com/docs/cd/E13154_01/bpm/docs65/index.html.

Oracle BPM Documentation

The official BPM product page is available at
http://www.oracle.com/technology/products/bpm/index.html and provides news,
data sheets and useful links.

Oracle BPM Product Page

You can download the latest version of Oracle BPM from
http://www.oracle.com/technology/software/products/ias/bea_main.html.

Oracle BPM Download Page

To access online help:Online Help

• In BPM Studio, select Help ➤ Help Contents to access the complete
Oracle BPM Studio help. Context help is also available by pressing the
F1 key, or by selecting Help ➤ Dynamic Help from the menu.

• In BPMWorkSpace, click onHelp in the title bar, or click on the help icon
( ) in the title bar of any panel for help about that panel.

The Oracle Technology Network features articles, blogs, and newsgroups
which will help you make the most out of Oracle products.

Oracle Technology Network
(OTN)

http://www.oracle.com/technology/index.html
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DescriptionResource

Visit theUserGroups to collaboratewith peers and viewupcomingmeetings.User Groups

At Oracle forums: http://forums.oracle.com/forums/forum.jspa?forumID=560

If you cannot resolve an issue using the above resources, Oracle Technical
Support is happy to assist.

http://www.oracle.com/support/index.html

Technical Support
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Installation Prerequisites

Before you run the Oracle BPM installer, you should complete the following steps.

1. Read the product ReleaseNotes for information on compatibility issues, knownproblems, andworkarounds
that might affect how you proceed with your installation.

2. Provision host computers and configure software dependencies for your deployment.
3. If you are integrating Oracle BPM with the AquaLogic User Interaction suite, see Support for AquaLogic

Interaction on page 10 for specific requirements.

Supported Operating Systems and JVMs
This section lists the operating systems and Java Virtual Machines supported by Oracle BPM.

TheWindows and Linux versions of Oracle BPM for 32-bit architectures include a JVM (JavaVirtualMachine).
For all other versions, you must install a compatible JVM before installing Oracle BPM.

The following tables show the supported combinations of Operating Systems, architecture and Java Virtual
Machines for each component.

Oracle BPM Studio

Supported JVMsArchitectureOperating System

Sun 1.5.0_11+ (included) or 1.6x86-32Windows Vista and XP SP2

Sun 1.5.0_11+ or 1.6x86-64

Sun 1.5.0_11+ (included) or 1.6x86-32Red Hat Enterprise Linux 4 and 5

Sun 1.5.0_11+ or 1.6x86-64Red Hat Enterprise Linux 5

Sun 1.5.0_11+ (included) or 1.6x86-32Novel SUSE Linux 9 and 10

Sun 1.5.0_11+ or 1.6x86-64

Oracle BPM Enterprise (all editions)

Supported JVMsArchitectureOperating System

Sun 1.5.0_11+ (included) or 1.6, JRockitx86-32Windows 2008 and 2003 SP1

Sun 1.5.0_11+ or 1.6, JRockitx86-64

Sun 1.5.0_11+ (included) or 1.6, JRockitx86-32Oracle Enterprise Linux 4 and 5, Redhat
Linux 4 and 5, Novell Suse Linux 9 and 10 Sun 1.5.0_11+ or 1.6, JRockitx86-64

Sun 1.5.0_11+ or 1.6 (32 or 64 bits), JRockit
64 bits

Sparc 64Solaris 10

HP 1.5 64 bitsIA-64 (Itanium)HP-UX 11i v3

HP 1.5PA-RISCHP-UX 11i v3

IBM 1.5 and 1.6 SR2PowerPCAIX 5.3
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Supported Virtualization Systems
Oracle BPM Enterprise supports virtualization systems in several architectures.

The following systems are supported:

• Oracle VM
• VMWare ESX
• Microsoft Windows Virtual Server
• Solaris 10 Containers (Zones) *
• AIX Dynamic Logical Partitioning (LPAR) *

* Denotes configurations where there is a parallel, non-virtualized system requirement for full support. We will answer
support questions through normal channels for customers running systems under these virtualization configurations,
but should we be unable to replicate an issue on a non-virtualized platform, and the issue is not otherwise known, the
customer will be requested to reproduce the problem on a parallel, non-virtualized system.

Database Requirements
All Oracle BPM Enterprise editions require a relational database to store directory information and process
execution engine data. Oracle BPM Studio uses a built-in database and does not have this requirement.

The following database systems are supported:

• Oracle 10g and 11g
• Oracle 10g and 11g with RAC (Real Application Clusters)
• Microsoft SQL Server 2005
• DB2 UDB 8.1 and 9.1
• Sybase 15.0

Database Drivers

You do not need to provide the JDBC database drivers for the databases above. All Oracle BPM Enterprise
editions include certified JDBC drivers in the installation. You do not need to install them manually.

Note that Oracle WebLogic also includes the required JDBC drivers.

IBMWebSphere does not include the required JDBC drivers. The drivers in the Oracle BPM installation can
be manually installed in WebSphere. See the BPM Configuration Guide for further information.

Microsoft SQL Server and XA Transactions

Support for distributed transactions, also referred to as XA, is not enabled by default with Microsoft SQL
Server. In order to enable JDBC distributed transactions, you must install Microsoft SQL Server JDBC XA
stored procedures. To do this, follow the instructions found in the Installing Stored Procedures for JTA section
within theMS SQL Server Driver topic of the Oracle WebLogic Server Documentation.

DB2 and Character Sets

Oracle BPM uses Unicode in order to support multiple languages.

If you are using a DB2 database, make sure it is configured for Unicode, using either the UTF-8 or UTF-16
character encoding.

No special configuration is needed for Oracle and Microsoft SQL Server databases. In these cases, Oracle
BPM explicitly defines its table column types to use Unicode.
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Sybase and Page size

If using Sybase, you must define a page size of at least 4K to support Oracle BPM. The default page size on
Sybase is 2K. If your database instance uses pages smaller that 4K, create a new Sybase instance with a page
size of 4K (or bigger). Sybase provides utilities to migrate data between servers of different page sizes.

If you try to create the Oracle BPM schema database with a page size smaller than required, you may get the
error messages like the following when creating Oracle BPM databases:
fuego.directory.exception.CouldNotCreateSchemaException:
      Could not create schema at [jdbc:sybase:Tds:vmsybase.fuegolabs.com:5000].

      600 is the maximum allowable size of an index.
      Composite index specified is 1020 bytes.

Hardware Requirements
This section summarizes the hardware requirements for Oracle BPM.

The following table presents minimum recommended configurations intended for development or simple
low-volume production configurations.

For sizing informationwithmore complex configurations, such as clusters,WebLogic support, high numbers
of concurrent users, or different processor architectures, consult with Oracle BPM Professional Services.

RequirementConfiguration

Recommended:Studio

• 2 GB RAM or more
• 4 GB or greater free disk space
• 1.8 GHz or faster Pentium Core Duo CPU or similar

Minimum:

• 1 GB RAM
• 2.5 GB or greater free disk space
• 1.5 GHz Pentium M CPU or similar

Recommended:

For high-volume deployment (more than 500 concurrent users), consult
with Oracle BPM Professional Services.

Enterprise

For testing and low volume deployment (up to 500 concurrent users):

• 4 GB RAM or more
• 5 GB or greater free disk space
• 2.0 GHz or faster Pentium Dual-Core Xeon CPU or similar

Minimum (testing only):

• 2 GB RAM
• 3 GB or greater free disk space
• 1.5 GHz Pentium M CPU or similar
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Supported Directory Services
Oracle BPM Enterprise can access directory information from a directory service, or can handle its own
directory information in a database. This section lists the supported directory services.

Note: Remember that even if you use a directory service, a database is always required for Oracle
BPM-specific organization information such as roles and business parameters. SeeDatabase Requirements
on page 7 for the list of databases which can be used.

The following directory services are officially supported:

• Sun ONE System Directory Server 5.2
• MS Active Directory 2003
• AquaLogic Interaction LDAP service

Supported Application Servers
This section lists the application servers supported by Oracle BPM Enterprise.

Enterprise Standalone

The following versions are supported for all Enterprise applications except Process Administrator, which
runs only in the built-in Tomcat Servlet/JSP container:

• Tomcat Servlet/JSP Container 5.5.15 (included with Oracle BPM Enterprise)
• Oracle WebLogic Server 10.0.0 and above

Enterprise for Oracle WebLogic

The following versions are supported for all Enterprise applications except Process Administrator, which
runs only in the built-in Tomcat Servlet/JSP Container:

• Oracle WebLogic Server 10.0.0 and above.

Oracle BPM Engine can be deployed to the Advanced and Premium editions of WebLogic Server. Oracle
WebLogic Express is not supported.

Supported Web Browsers
A web browser is required to use the Web application components of Oracle BPM, such as WorkSpace and
Process Administrator.

The following web browsers have been tested and are officially supported by Oracle BPM.

On Microsoft Windows:

• Microsoft Internet Explorer 7.0
• Mozilla Firefox 2.0

On Linux:

• Mozilla Firefox 2.0

On Apple Mac OS X
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• Apple Safari 3.0
• Mozilla Firefox 2.0 and 3.0

Required Plug-ins

Some Oracle BPMWorkSpace functionality requires the Adobe Flash Plugin installed in your browser.

Other considerations

You must disable the Pop-up Window blocker feature of your browser.

Use a screen resolution of 1024 x 768 pixels or higher.

Support for AquaLogic Interaction
Oracle BPM Enterprise supports integration with AquaLogic Interaction. Specific ALI product versions are
required.

The following components are required for configuring Oracle BPM with ALI integration:

• AquaLogic Interaction version 6.5 or above
• AquaLogic Interaction Collaboration version 4.5 or above

You also need to enable the LDAP service component of ALI to provide directory connectivity toOracle BPM.
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Studio Installation

Before installing Oracle BPM Studio make sure your system complies with all the prerequisites.

In general, Studio can be installed on Windows XP/Vista or Linux with no special requirements. However,
before installing Studio, verify compliance with the following:

• Installation Prerequisites on page 6
• Hardware Requirements on page 8
• Supported Operating Systems and JVMs on page 6

Studio does not require an external database or application server.

Applying Maintenance Packs and Patches

If you are updating an existing installation of Oracle BPM Studio see Updating Oracle BPM on page 18.

Installing Studio
This section describes the steps required to install Oracle BPM Studio from a graphical user interface.

To install Oracle BPM Studio from a text-based console refer to Installing from a Text Console on page 17.

To install Oracle BPM Studio:

1. Obtain the installation file from the Oracle downloads page, and download Oracle BPM Studio 10.3 for
your platform.

2. Execute the installation file.
The installation programwill prepare to proceed with the installation, and display the Introduction page
of the installation utility.

3. At the Introduction page, clickNext.
The Choose Install Folderwill appear.

4. In the Choose Install Folder, enter the path or select a folder where you will install Studio. If you've
entered a path but wish to use the installer's default, click on Restore Default Folder to obtain it. Click
Next to proceed.
We recommend using the default folder path whenever possible.
The Pre-Installation Summary page appears.

5. Verify the settings shown in the summary. If you need to make any changes, click Previous to go to the
page where you need to make the change. Once you are ready to proceed, click Install.
The installation is performed.

Oracle BPM Studio is now installed in your system.

General Studio Installation Notes
This section contains information to help you avoid common problems when running Studio.
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Web Application Ports

By default, Oracle BPM Studio 10.3 uses port 8585 for web applications such as WorkSpace, and Oracle BPM
Enterprise uses port 8686 to avoid conflict. Thismeans you can run Studio and Enterprise on the samemachine
at the same time with the default configuration.

If you are running older versions of Oracle BPM, or any other application which uses the same port numbers
a conflict can occur.

To change the port number used by Studio follow these steps:

1. In Studio, in the Project Navigator, right-click on the project you will run and select Engine Preferences

( ) from the context menu.
2. In the Category list, select Engine.
3. In theGeneral tab of the Engine properties, set the port in theWorkSpace Port field. Make sure the value

does not conflict with other service ports in your system.
4. You must do this for each project you will run from Studio.

You may list the ports being used in your system at the command line. Use netstat -a under Windows
and netstat -l under Linux.

Studio Installation Notes for Linux
This section provides additional information for running Studio under Linux.

Launching Studio

To start Studio from the command line execute the file <ORABPM_HOME>/eclipse/eclipse.

Additional Installation Steps

Depending on your Linux Distribution and version, you might need to complete the following additional
steps to have a fully functional installation of Oracle BPM Studio:

• You need to haveMozilla Firefox (version 2.0 or above) installed in your system. You must set the
environment variableMOZILLA_FIVE_HOME to your Firefox installation directory. In addition, you
may need to prepend this same directory to the LD_LIBRARY_PATH variable. Example, from a bash shell:

  export MOZILLA_FIVE_HOME=/usr/lib/firefox
  export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME:$LD_LIBRARY_PATH

Studio Installation Notes for Mac OS X
This section provides additional information for managing Studio under Mac OS/X.

Uninstalling Studio from Mac OS X

To uninstall Studio in a Mac OS X system, use the uninstall utility provided. To run it, click on
UninstallStudio in the /Applications/OraBPMStudioHome/UninstallerData folder.
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Changing JVM used by Studio
You may change the Java runtime environment used by Oracle BPM Studio after installation.

See Supported Operating Systems and JVMs on page 6 for a list of supported Java Virtual Machines on each
environment.

To change the Java runtime used by Oracle BPM Studio:

1. Open configuration file <ORABPM_HOME>/eclipse/eclipse.iniwith a text editor.

Example contents of eclipse.ini:
-showsplash
fuego.eclipse.studio
-vmargs
-Xms128m
-Xmx512m

-Dfuego.fstudio=true
-DprodMode=preProduction
-Dbea.home=c:\OraBPMStudioHome\..
-Djava.endorsed.dirs=""
-Dsun.lang.ClassLoader.allowArraySyntax=true
-Dfuego.studio.engine.java.options=-Dsun.lang.ClassLoader.allowArraySyntax=true
-XX:PermSize=64M
-XX:MaxPermSize=128M
-Xbootclasspath/a:/bea/OraBPMStudioHome/eclipse/jre/lib/ext/tools.jar 

2. Insert two lines at the top of the file: one containing the text -vm and one containing the full path to the
java command of your Java runtime.
Example, add the following two lines:
-vm
C:\Java\JDK\1.6\bin\javaw.exe

3. Modify existing lines referring to other Java runtime environments.

Example, change the following line:

-Xbootclasspath/a:C:\OraBPMStudioHome\eclipse\jre\lib\ext\tools.jar  

to:

-Xbootclasspath/a:C:\Java\JDK\1.6\lib\ext\tools.jar

Example modified contents of eclipse.ini:
-vm
C:\Java\JDK\1.6\bin\javaw.exe
-showsplash
fuego.eclipse.studio
-vmargs
-Xms128m
-Xmx512m

-Dfuego.fstudio=true
-DprodMode=preProduction
-Dbea.home=c:\OraBPMStudioHome\..
-Djava.endorsed.dirs=""
-Dsun.lang.ClassLoader.allowArraySyntax=true
-Dfuego.studio.engine.java.options=-Dsun.lang.ClassLoader.allowArraySyntax=true
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-XX:PermSize=64M
-XX:MaxPermSize=128M
-Xbootclasspath/a:C:\Java\JDK\1.6\lib\ext\tools.jar
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Enterprise Installation

Before installing Oracle BPM Enterprise make sure your environment complies with all the prerequisites.

Before installing Enterprise, you should check compliance with the following:

• Installation Prerequisites on page 6
• Hardware Requirements on page 8
• Supported Operating Systems and JVMs on page 6
• Database Requirements on page 7
• Supported Application Servers on page 9
• Supported Web Browsers on page 9

Applying Maintenance Packs and Patches

If you are updating an existing installation of Oracle BPM Enterprise see Updating Oracle BPM on page 18.

Installing Enterprise
This section describes the steps required to install any edition of Oracle BPM Enterprise from a graphical
user interface.

To install Oracle BPM Enterprise from a text-based console refer to Installing from a Text Console on page 17.

To install any Oracle BPM Enterprise:

1. Obtain the installation file from the Oracle downloads page, and download your desired edition of Oracle
BPM Enterprise 10.3 for your platform.

2. Execute the installation file.

Note: To use an already installed Java VM, specify the full path to the java command passing the
LAX_VM parameter to the installer. Youmust always specify the location to an existing Java installation
if a JVM is not included with the installer. Example:

OracleBPMEnterpriseSA103000_sol.bin LAX_VM /usr/jdk1.5/bin/java

The installation programproceedswith the installation anddisplays the Introductionpage of the installation
utility.

3. At the Introduction page, clickNext.
The Choose Install Folder appears.

4. In theChoose Install Folder, enter the path or select a folder where youwill install Enterprise. If you have
entered a path but wish to use the Installer's default, click on Restore Default Folder to obtain it. Click
Next to proceed.
Oracle recommends using the default folder path whenever possible, as this will help simplify support.
In Windows or 32-bit Linux, the Pre-Installation Summary page appears, and you should go to step 7.
Otherwise, the Choose J2SE 1.5 SDK page appears.

5. In theChoose J2SE 1.5 SDK page, select the Java 1.5 SDK installed in your system that youwant Enterprise
to use. The installer lists those SDKs that it has detected. If you wish to specify a JDK that is not on the
list, you can click on Search for Others for an automatic search, or on Choose Another... to look for the
SDK manually. When you have selected the Java SDK that you want, clickNext.
The Pre-Installation Summary page appears.
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6. Verify the settings shown in the summary. If you need to make any changes, click Previous to go to the
page where you need to make the change. Once you are ready to proceed, click Install.
The installation is performed. Once it has finished, the Install Complete page appears.

7. In the Install Complete page, you can choose to exit the installer, to launch the Admin Center program,
or to launch the Configuration Wizard. If you exit, you can run the Admin Center at a later time. You can
also execute the Configuration Wizard from Admin Center.
In all cases, the installation utility will exit.

Enterprise is now installed in your system

See the Configuration Guide and Administration Guide for information on configuring and administering an
Oracle BPM Enterprise installation.

Changing JVM used by Oracle BPM Enterprise
You may change the Java runtime environment used by Oracle BPM Enterprise after installation.

See Supported Operating Systems and JVMs on page 6 for a list of supported Java Virtual Machines on each
environment.

To change the Java runtime used by Oracle BPM Enterprise:

1. Modify all *.lax configuration files located at <ORABPM_HOME>/bin.

You must change the lines containing property lax.nl.current.vm to specify the new path to your
desired Java VM executable. Example:

...
lax.nl.current.vm=/usr/jdk1.6/bin/java
...

Tip: On Unix systems, you can automate this change with the following sed command. On the
following example, change $ORABPM_HOMEwith the full path to your Oracle BPM installation and
/usr/jdk1.6/bin/javawith the full path to your Java command:

cd $ORABPM_HOME/bin
sed -i 's#current\.vm=.*$#current\.vm=/usr/jdk1.6/bin/java#g' *.lax

2. Modify the sdk.properties configuration file located at <ORABPM_HOME>/bin.

You must change the line containing property sdk.home to specify the new path to your desired Java
VM installation directory. Example:

...
sdk.home=/usr/jdk1.6
...

Tip: On Unix systems, you can automate this change with the following sed command. On the
following example, change $ORABPM_HOMEwith the full path to your Oracle BPM installation and
/usr/jdk1.6with the full path to your Java installation directory:

cd $ORABPM_HOME/bin
sed -i 's#sdk\.home=.*$#sdk\.home=/usr/jdk1.6#g' sdk.properties
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Installing from a Text Console

You can run the Oracle BPM Studio and Enterprise installers on a text-based console, without a graphical
user interface.

Text-based Interactive Installation

To use text-mode installation, run the Oracle BPM installer with the -i console argument. Use this option
on Unix systems where you don't have access to a graphical environment. Example:

 OracleBPMEnterpriseSA103000_sol.bin -i console

You can also specify the location to the JVM passing the LAX_VM argument to the installer. You must always
specify the location to an existing Java installation if a JVM is not included with the installer. Example:

 OracleBPMEnterpriseSA103000_sol.bin -i console LAX_VM /usr/jdk1.5/bin/java

Non-interactive Installation (Silent mode)

To simplify installation on multiple machines, you can run the Oracle BPM installer in silentmode, which
does not require any user interaction.

To use non-interactive installation, run the Oracle BPM installer with the
-DUSER_INSTALL_DIR="/path/to/dir" and -i silent arguments, where /path/to/dir is the full
path to the directory where you want to install the product. Example:

 OracleBPMEnterpriseSA103000_sol.bin 
-DUSER_INSTALL_DIR="/usr/OraBPMEnterpriseHome" -i silent

You can also specify the location to the JVM passing the LAX_VM argument to the installer. You must always
specify the location to an existing Java installation if a JVM is not included with the installer. Example:

 OracleBPMEnterpriseSA103000_sol.bin 
-DUSER_INSTALL_DIR="/usr/OraBPMEnterpriseHome" -i silent LAX_VM 
/usr/jdk1.5/bin/java
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Updating Oracle BPM

Oracle BPM updates are available in two forms: maintenance packs and patches.

Maintenance Packs

Each maintenance pack is numbered, and the number of the Maintenance Pack corresponds to the Oracle
BPM revision number. Maintenance Pack 1 is known as MP1, Maintenance Pack 2 is known as MP2, and so
on. For Oracle BPM 10.3, the software version that corresponds to each of these Maintenance Packs is 10.3.1,
10.3.2, and so on.

Youmust always apply amaintenance pack to the immediately previous version of the product. For example,
you can apply MP3 to Oracle BPM 10.3.2, but not to 10.3.1.

Patches

Patches are usually smaller than maintenance packs, and are released whenever an important issue must be
corrected as soon as possible. Patches are cumulative within a given maintenance pack, so there is always
one current patch for a given maintenance pack, and you do not need to install previous patches.

Updating Studio
Follow this procedure to apply maintenance packs and patches to Oracle BPM Studio.

You initiate the Studio update procedure from within the Studio application.

Before updating Studio, check which version you currently have. On the main menu, click Help ➤ About
Oracle BPM Studio .

To update Studio:

1. In Studio, save all your changes using File ➤ Save All ( )
2. In the main menu, click File ➤ Updates > Studio Local Update

Studio displays a dialog box indicating that Studio will close in order to execute the update, and asks if
you want to continue.

3. Click Yes.
Studio closes and theOpen dialog box is displayed.

4. Specify the update (.upd) file and clickOpen.
The update process runs. When the update procedure is complete, Studio will restart.

5. Verify that Studio is not at the expected revision by clicking Help ➤ About Oracle BPM Studio .

Updating Enterprise
Follow this procedure to apply maintenance packs or patches to Oracle BPM Enterprise.

You perform the Enterprise update procedure from Admin Center.

Before updating Enterprise, check which version and edition you currently have. On the upper right corner
of the main window, click About .

To update Enterprise:
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1. You cannot update Enterprise while BPMWeb Applications are running. If the BPMWeb Applications
are running, click Stop BPMWeb Applications ( ).

Note: If any process execution engines are running, you must also stop them in order to perform the
upgrade. First stop the engines fromProcess Administrator, and then stop theWebApplications from
Admin Center.

Note: If the updater service is running, you must also stop this service. In the Windows Services
console, this is called the Oracle BPM 10.3 DatawareHouse Service. In UNIX you must execute the
following command:
<ORABPM_HOME>/bin/oraclebpmwarehouse.sh stop

Where <ORABPM_HOME> is the folder where Enterprise is located.

2. In the Admin Center main window, click Configuration ( ).
The Configuration dialog box will appear.

3. Click the rightmost tab, Service Pack Updates. You may need to click on the right arrow button so this
tab comes into view.

4. Click Local Update. If this button is disabled, you need to stop the BPMWeb Applications.
TheOpen dialog box is displayed.

5. Specify the update (.upd) file and clickOpen.
The update process runs, and Admin Center automatically restarts for the update to take effect.

6. If you have deployed Oracle BPM to an application server, you must generate new .war or .ear files for
the applications and re-deploy. For further information, see the Enterprise Configuration Guide.

Once the update is complete, you may have to perform additional steps, particularly if you have deployed
to an application server. These steps, if required, are described in the Release Notes.

Updating from a Text Console
You can apply patches and maintenance packs to Oracle BPM Studio and Enterprise using scripts.

To apply a product patch ormaintenance packwithout a graphical user interface, you canwrite an Ant script
using task <updateProduct> provided by Oracle BPM.

Refer to theOracle BPM Ant tasks reference for more details on how to use BPM tasks with Ant in general and
details on the <updateProduct> task in particular.
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