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Installation Introduction
Oracle's Hyperion® Financial Management – System 9 is a comprehensive, Web-based
application that delivers global collection, financial consolidation, reporting, and analysis in one
highly scalable solution.

For hardware and software requirements and a list of product port numbers, see the Hyperion
Installation Start Here.

Financial Management is designed to operate as a multitier system. A Financial Management
configuration contains three logical tiers: a database tier, application/Web server tier (also
referred to as the middle tier), and client tier.

l The database tier contains the relational database and all Financial Management data and
metadata. Supported databases include Microsoft SQL Server, Oracle, and IBM DB2.

l The application/Web server tier, or middle tier, contains the domain intelligence and
connections to the relational database, application server, and Web server. You access the
Web-enabled portions in this tier.

l The client tier provides the user interface and the ability to communicate with the application
tier. You can display data and metadata and enter data. Financial Management has a thin
Web-client architecture so that basic users require only a supported browser on a client
computer. No processing or business rules occur on the client. The client is offered through
Web servers or through a Windows client installed on the local computer.

Financial Management Components

Shared Services
Features enabled by Oracle's Hyperion® Shared Services:
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l User provisioning

l External authentication definition

l Metadata synchronization

l Data synchronization

l Task flow management

The Hyperion Security Administration Guide describes user-provisioning functionality and
external authentication definition. All other Shared Services functionality is described in the
administrator’s and user’s guides for the products that implement it.

Workspace
You access Financial Management on the Web through the Oracle's Hyperion® Workspace.
Workspace provides the user interface for viewing and interacting with content created using
financial applications and Oracle's Hyperion® Reporting and Analysis – System 9 authoring
studios:

l Consolidation application tasks

l Planning application tasks

l Financial reporting for scheduled or on-demand highly formatted financial and operational
reporting from many data sources

l High performance multidimensional modeling, analysis, and reporting

l Interactive reporting for ad hoc relational queries, self-service reporting and dashboards
against ODBC data sources

l Production reporting for high volume enterprise-wide reporting

l Web analysis for interactive ad hoc analysis, presentation, and reporting of
multidimensional data

Performance Management Architect
Oracle's Enterprise Performance Management Architect is a component of Financial
Management and Oracle's Hyperion® Planning – System 9 that enables administrators to
manage, create, and deploy Hyperion Applications within one interface. It can be installed as
part of the Financial Management setup program.

If you do not choose to install Performance Management Architect, you use Classic Application
Administration to run Financial Management. Classic Application Administration is
automatically installed as part of the installation process.

Performance Management Architect requires:

l A separate database

l Microsoft Internet Information Services (IIS)

l ASP.NET 2.0
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l Use of a Java application server

l Dimension Editor and Application Creator security roles

The Dimension Editor creates and manages import profiles for dimension creation, as well as
creating and managing dimensions manually within the Performance Management Architect
user interface or the Classic Application Administration option. This role is required to access
Classic Application Administration options for Financial Management and Planning using Web
navigation.

The Application Creator can create applications but can change only the dimensions to which
they have access permissions. This role is required for Financial Management andPlanning users
to be able to navigate to their product's Classic Application Administration options on the Web.
The Financial Management Application Creator can create Consolidation applications and
Generic applications. To create applications on either the Web or the Desktop, the user must
also be a member of the Application Creators group specified in the Financial Management
Configuration Utility.

For more information on requirements, see the Hyperion Installation Start Here.

The Oracle's Hyperion® Configuration Utility™ is used to register Performance Management
Architect with Shared Services, configure the database, and deploy to an application server.

Note: This is a functional diagram and does not represent the number of servers needed for a
deployment.

Performance Management Architect features include:

l Dimension Library—A centralized location to manage dimensions and dimension
properties. You can use the Dimension Library to:

m Create dimension import profiles—enabling dimension updates from both flat files and
relational database interface tables

m Add, delete, and modify dimension members

m Modify dimension and member properties

l Application Library—A summary of Application Views that have been created and/or
deployed. Application Views contain dimensions and dimension attributes that are designed
to meet specific requirements for application needs. You can use the Application Library to:

m Create Views based on dimension sets

m Manage Application Views in one centralized location

m View the data flow between Application Views

m Migrate Application Views to different servers

m Deploy Application Views

l Data Synchronization—Enables data synchronization within Hyperion applications. You
can use the Data Synchronizer to:

m Create data movement synchronizations between Hyperion applications. For example,
an administrator can synchronize data between two Financial Management
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applications; two Planning applications, and between one Financial Management and
a Planning application

m Create data mappings for reuse

m Create flat file and interface table mappings to import data into Hyperion applications

l Application Upgrade—Enables administrators to upgrade from previous releases.

l Job Console—Provides a summary of Dimension Library and Application View activities,
including imports, deployments, and data synchronizations.

For help on tasks performed in Performance Management Architect, see the Hyperion Enterprise
Performance Management Architect Administrator’s Guide and online help.

Smart View
Oracle's Hyperion® Smart View for Office provides a common Microsoft Office interface for
Financial Management, Planning, Oracle's Hyperion® Essbase® – System 9, and Oracle's
Hyperion® Financial Reporting – System 9. Using menu-driven options in Microsoft Office,
you can import data and images from Hyperion products into Microsoft Office components
such as Excel, Word, and PowerPoint. In addition, you can work with Financial Management
functions and data forms.

Financial Reporting
Financial Reporting enables you to create highly formatted reports that combine text, data grids,
charts, graphs, and images. In addition to providing complete control over layouts, formatting,
fonts, and colors, it provides powerful business analytics, such as conditional suppression and
automatic calculations, that can be used to focus and filter reports. A repository of reusable
report components simplifies the process of building and maintaining complex reports.

DIM Adapter for Financial Management
The Oracle's Hyperion® Data Integration Management Adapter for Financial Management
enables you to retrieve and write data for Financial Management and transfer application data
to an external target. It is sold separately and is not included as part of the core Financial
Management package.

Application Link
Oracle's Hyperion® Application Link is a suite of application integration services that integrates
external source data with Hyperion's business analysis software. It is purchased separately. You
can use it to load data values, accounts, entities, and custom dimensions from flat files or ODBC-
compliant databases into Financial Management.
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FDM
Oracle's Hyperion® Financial Data Quality Management is a packaged solution for finance users
that includes a guided Web-based workflow user interface for leveraging standardized financial
data management processes, a data preparation server for integrating and validating financial
data from any source system, and prepackaged adapters for Financial Management to reduce
data integration costs and data mapping complexities. It is sold separately and is not included
as part of the core Financial Management package.

Hyperion License Compliance
Hyperion no longer ships or requires Oracle's Hyperion® License Server™ (or standalone license
files) for use with Hyperion products.

To ensure compliance with your license agreement, Hyperion recommends that you implement
an auditing process. In addition, during product configuration with Hyperion Configuration
Utility, you activate only the features you purchased. For more information, see “Hyperion
License Compliance” in Hyperion Installation Start Here.

Financial Management Configurations
Financial Management can be configured in various ways. Server specifications depend on
factors such as number of users, business process, size, design, and complexity of your
applications. Hyperion recommends that you contact Hyperion Consulting Services for
assistance in planning your deployment.

You can install Financial Management to one or more Financial Management application
servers, and install Financial Management Web server components to one or more Financial
Management Web servers. You should install the Performance Management Architect
Dimension server component to one Dimension server. For information on Performance
Management Architect, see “Performance Management Architect” on page 10.

Using Application Server Clusters
Financial Management uses N-Tier architecture to deploy mission critical consolidations and
reporting applications to hundreds and even thousands of users. Load balancing is used to
support large numbers of concurrent users. In general, load balancing is a way of dividing
concurrent usage as equally as possible across a cluster of machines. To end users, the machines
in a cluster seem to be one machine but, behind the scenes, the system assigns users to various
servers to help distribute the load.

There are two types of automatic load balancing: session level and request level. With session
level load balancing, the user performs all operations from logon to logoff on one application
server, but may perform the operations of another session on another machine. Usually, this
type of load balancing is used for applications that must maintain state throughout a user’s
session. Financial Management falls into this classification.
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Load balancing can be achieved through the Financial Management clustering feature. The
administrator configures a cluster to include Financial Management application servers. During
logon, the user selects the cluster name. Using a random approach, Financial Management logs
users on the application servers defined in the cluster, thereby spreading the users across the
available servers. Financial Management generates a random number by using time
(milliseconds) as a parameter and logs each user on the appropriate server. Using milliseconds
helps guarantee random assignments if users log on at the same time.

If any server fails, the cluster is automatically notified and the failed server is removed from the
list of available servers. Any users logged on to the failed server must log on again, using the
cluster. Users are automatically assigned to available servers. It is possible to have a server that
is not part of the cluster but is synchronized with the other application servers in the cluster.
Thus a dedicated reports or consolidation server can be used with servers that are part of the
cluster. Clustering applies only to the Financial Management application server and does not
apply to the Web server or Database server tiers.

End-user load balancing is a way of distributing concurrent usage as evenly as possible across
multiple servers. If you use multiple application servers, you can specify a cluster of application
servers through which to distribute the user load. For example, you can create an application
server cluster named Marketing_Servers and add application servers Mkt1, Mkt2, Mkt3, and
Mkt4 to the cluster. You can add or remove servers from an application server cluster as needed.

In random load balancing, requests are randomly routed to servers. Random load balancing is
commonly used for homogeneous cluster deployments such as Financial Management. In
random load balancing, users are distributed evenly, thus all servers in a cluster should have
similar configurations to prevent unpredictable performance. If one machine in a cluster has
significantly less processing power than other machines in the cluster, random load balancing
gives the less powerful machine as many requests as it gives more powerful machines.

The client computer stores a list of the available servers in the local registry. Upon logon, the
computer randomly selects a server and attempts to log on. If the selected server has a problem,
it is removed from the local list, and the client computer randomly picks another server. After
the client computer connects to a server, it asks the server to which it is connected for an updated
list of servers. The client computer updates its local registry with the new list in preparation for
the next logon request.

Web-based operations occur similarly, except that the registry is maintained on the Web server
and updated after each user logon. By using the registry to store available server information,
the Web server avoids relying on a central server to process all logons.

You set up application server clusters using the configuration utility.
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2
Creating Financial Management

Databases
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Financial Management uses the relational database to store all of its data. Before you can create
applications, you must install relational database software and create and configure an Financial
Management database.

Performance Management Architect also requires that you create a separate Performance
Management Architect database, and a database if you use Interface Tables (optional).

For database requirements, see the Hyperion Installation Start Here.

During Financial Management configuration, you specify the maximum number of relational
database connections used by each application. See “Database Connection Pooling” on page
24.

When you create databases, record the usernames and passwords that you assign so that you can
refer to them when running the configuration utility.

General guidelines for creating relational databases are listed in this table:

Table 1 Database Requirements

Database
Requirement

Recommendation

Database
tablespace size

l 100 MB for applications with 5,000 or fewer total members

l 200 MB for applications with 15,000 or fewer total members

Note: You can readjust the size of the system table database to match the size of the application.
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Basic privileges Database users must be assigned privileges to add, modify, and delete these database objects:

l tables

l indexes

l views

l procedures

l roles/authorities

l sequences

l triggers

In addition, users must be granted a role that assigns unlimited tablespaces. For Oracle databases specifically, users
must be assigned the RESOURCE role also.

Creating Oracle Databases
The Oracle Universal Installer guides you through the installation and configuration of your
Oracle database server. See the Oracle Administrator’s Guide.

Oracle database guidelines:

l For Financial Management and Performance Management Architect, the database
administrator should create a tablespace and an Oracle user with tablespace privileges. The
user administers the Financial Management repository. See basic privileges in Table 1.

Note: Using an existing user and tablespace is not recommended.

l If you are using FDM, it should not be in the same Oracle instance as Financial Management.

l You must install the Oracle client on the Financial Management application server. If you
use Performance Management Architect, you must also install it on the Performance
Management Architect Dimension Server.

When you configure the server, you need this information:

l The name or IP address of the computer on which Oracle is installed

l The TCP port on which Oracle is listening (if not the default port 1521)

l The Oracle service name or SID where the tablespace resides

l The name of the Oracle user with rights to connect to and create tables in the Oracle instance

l The password of the Oracle user with rights to connect to and create tables in the Oracle
instance

Creating Microsoft SQL Server Databases
For instructions on installing Microsoft SQL Server, see Microsoft’s SQL Server installation
documentation. For information on creating databases, see the Microsoft SQL Server Creating
and Maintaining Databases Guide.
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The database administrator should create a database and a user with rights to the database. For
basic privileges, see Table 1.

Note: When you set the Security properties for the database, make sure that you select this
Authentication option: “SQL Server and Windows”.

When you configure the application server, you need this database information:

l The name or IP address of the computer on which SQL Server is installed

l The TCP port on which SQL Server is listening (if not the default port 1433)

l The name of the database created for Financial Management

l The name and password of the SQL Server user with db_owner rights to the database

Creating IBM DB2 Databases
The IBM DB2 Universal Database Library is on a CD or DVD provided by IBM. For information
on installing and configuring databases, see the IBM DB2 Administration Guide: Planning and
IBM DB2 Administration Guide: Implementation.

Note: When installing DB2, clear the OLAP Starter Kit option.

Creating IBM DB2 Databases for Financial Management
Use the IBM DB2 Client Configuration Assistant to set up a database alias that enables Financial
Management to connect to the database.

Select these options:

l Register this Database for ODBC

l As a System Data Source

Note these guidelines:

l When you create the DB2 database, be sure to use Unicode Transformation Format (UTF-8)
codeset.

l Create a database and a DB2 user for administering the Financial Management repository.
For basic privileges, see Table 1.

l Minimum tablespace requirements:

m Data tablespace: 8K page size

m User Temporary Tablespace: 8K page size

l You must install the IBM DB2 client on the Financial Management application server.

When you configure your application server, you need this information:

l The name or IP address of the computer on which DB2 is installed
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l The TCP port for the DB2 instance (if not the default port of 50000)

l The name of the database on which the Financial Management DB2 user resides

l The name and password of the DB2 user with rights to connect to and create tables in the
Financial Management database instance on DB2

Creating IBM DB2 Databases for Performance Management
Architect
If you use an IBM DB2 database for Performance Management Architect, DB2 9 Runtime Client
and DB2 .NET Data Provider 9.1.0.2 must be installed on the Performance Management
Architect Dimension server. See “Installing DB2 v9 Runtime Client and DB2 .NET Data Provider
for Performance Management Architect” on page 19.

To create a DB2 database:

l Create the Performance Management Architect database in a local directory

l Create a bufferpool to hold the system temporary tablespace that temporarily stores data
during sort and collate operations

l Create the system temporary tablespace

Creating the Performance Management Architect Database
When you create the DB2 database in a local directory, be sure to use the Unicode
Transformation Format (UTF-8) codeset.

Setting Up a Bufferpool and System Temporary Tablespace
The system temporary tablespace and its corresponding bufferpool (bpmapool) are required by
Performance Management Architect. The following SQL script creates the required bufferpool
and tablespace.

Example
CREATE BUFFERPOOL bpmapool IMMEDIATE SIZE 250 PAGESIZE 32K

CREATE  SYSTEM TEMPORARY TABLESPACE bpmabigtemp PAGESIZE 32K MANAGED BY SYSTEM USING ('C:
\DB2\Database\bpmabigtemp')
EXTENTSIZE 16 OVERHEAD 12.67 PREFETCHSIZE 16 TRANSFERRATE 0.18 BUFFERPOOL bpmapool

If you are using a DB2 database for Performance Management Architect, a tablespace is created
during database configuration in the Configuration Utility. The database administrator must
ensure that the user who logs on to the Performance Management Architect relational database
has CREATE access to the bufferpool and tablespace and CREATE VIEW privileges.
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Installing DB2 v9 Runtime Client and DB2 .NET Data Provider for
Performance Management Architect
To use a DB2 database with Performance Management Architect, follow these requirements:

l Install DB2 v9 Runtime Client and DB2 .NET Data Provider on the Dimension Server
machine. (DB2.NET Data Provider is installed as part of the DB2 v9 Runtime Client
installation.)

l Ensure that your DB2 database is installed on a different computer, and not the Performance
Management Architect Dimension Server machine where the DB2 9 Runtime Client will be
installed.

DB2 9 Runtime Client Setup for Performance Management Architect

You must install DB2 9 Runtime Client to ensure that Performance Management Architect
services communicate with a DB2 database.

l If the Performance Management Architect computer has DB2 9 Runtime Client installed,
verify that an entry exists in the Global Assembly Cache. See “Verifying DB2 9 Runtime
Client for Existing Installations” on page 19.

l If the Performance Management Architect computer does not have the DB2 9 Runtime
Client installed, you must install it. See “Installing DB2 9 Runtime Client for Performance
Management Architect” on page 20.

Verifying DB2 9 Runtime Client for Existing Installations

ä To verify the Global Assembly Cache entry:

1 Click Start > Run.

2 Enter c:\windows\assembly and click OK.

3 Scroll down the resulting list and locate IBM.Data.DB2 9.0.0.2.

4 Right-click IBM.Data.DB2 9.0.0.2 and select Properties.

5 Click Version— at the top it should display File Version: 9.1.0.2 or greater.

Tip: You can also verify that the version 9 Runtime Client is installed if the following path
and file exist: C:\PROGRAM FILES\IBM\SQLLIB\BIN
\NETF20\IBM.DATA.DB2.DLL or C:\PROGRAM FILES\IBM\SQLLIB_01\BIN
\NETF20\IBM.DATA.DB2.DLL.

To install the Runtime Client, see “Installing DB2 9 Runtime Client for Performance
Management Architect” on page 20.

If you see this version or newer, the setup is complete, and nothing needs to be installed.
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Installing DB2 9 Runtime Client for Performance Management Architect

ä To install DB2 9 Runtime Client:

1 Download DB2 9 Runtime Client using the following URL. (You must be a registered IBM user.)

http://www-306.ibm.com/software/data/db2/v9/index_download.html

2 In Next Steps, near the bottom of the page, click DB2 Client.

3 Click Sign in and enter your IBM ID and Password.

4 Select the driver based on your operating system and language preference, and click Continue.

5 Select choices for the radio button questions, and click I Agree.

6 Click I Confirm and select a download option:

l Download Using HTTP

l Download Director

The file size for db2_v9_en_US_setup.exe is 23 MB.

7 Click Download Now and save to a location on the computer where Performance Management Architect
services are installed.

8 Double-click db2_v9_en_US_setup.exe to execute.

Note: When you install the DB2 9 Runtime Client, it automatically detects an existing client
and enables you to upgrade the existing version or add a new version copy to preserve
the existing version. You should select the second option to ensure that existing
applications or software that use the older Runtime Client are not affected.

9 Accept the defaults and complete the installation.

Configuring DB2.Net Data Provider for Performance Management Architect

After you complete the Runtime Client installation you must configure DB2.Net Data Provider.

ä To configure DB2.Net Data Provider:

1 Select Start > Programs > IBM DB2 > Configure DB2 .NET Data Provider.

This entry is added to the Global Assembly Cache automatically: c:\windows\assembly.
The entry is listed as IBM.Data.DB2.

A version is listed next to the name, however, you should verify the File Version, not the
version listed next to the name.

2 To verify the file version, right-click the item and select Properties. Click Version and verify the File
Version number listed at the top of the tab.

The file version should be 9.1.0.2 or greater.
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Creating Data Link (UDL) Files 
A universal data link (.udl) file provides a connection between a database server and an
application server. You must create a.udl file for Financial Management.

ä To create a data link (.udl) file:

1 From Windows Explorer, select the folder in which to store the file.

Note: You should store the file in a directory other than the Financial Management
installation directory, so that you can retain the file if you uninstall Financial
Management.

2 Select File > New > Text Document.

A file named New Text Document.txt is displayed.

3 Rename the file, removing all spaces, and changing its file extension to .udl, for example,
hfm.udl.

4 When asked to confirm changing the file extension, click Yes.

5 Configure the .udl file.

See these topics:

l “Configuring the Data Link for Oracle” on page 21

l “Configuring the Data Link for Microsoft SQL Server” on page 22

l “Configuring the Data Link for IBM DB2 ” on page 23

Configuring the Data Link for Oracle
The data link specifies the database server name and other database-related information, such
as the username and password of a user with full access rights to the database server.

For Oracle, Financial Management requires the Oracle OLE DB Provider. You can download
and obtain information about the Oracle DB Provider from the Oracle Web site.

ä To download Oracle OLE DB Provider:

1 Using a Web browser, go to www.oracle.com.

2 Click the Downloads link.

3 From the Technologies, Utilities, and Drivers section, select Oracle Provider for OLE DB.

4 Select the file to download, and follow the screen prompts.

ä To configure the data link for Oracle:

1 From Windows Explorer, double-click the UDL file that you created.

The Data Link Properties box is displayed.

2 On the Provider tab, from the OLE DB Providers list, select Oracle Provider for OLE DB.
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3 Click Next.

4 On the Connection tab:

a. Enter the server name <Oracle Global Database Name>.

b. Enter a username and password.

Note: Ensure that the user is granted privileges to create, update, and delete tables. See
“Creating Oracle Databases” on page 16.

5 Select Allow saving password.

6 Select the database to which you want to connect.

7 Click Test Connection.

8 On the Test Connection Succeeded box, click OK.

9 Click OK to save the connection and close the dialog box.

Configuring the Data Link for Microsoft SQL Server
The data link specifies the database server name and other database-related information, such
as the username and password of a user with full access rights to the database server.

ä To configure the data link for Microsoft SQL Server:

1 From Windows Explorer, double-click the UDL file that you created.

The Data Link Properties dialog box is displayed.

2 On the Provider tab, from the OLE DB Providers list, select Microsoft OLE DB Provider for SQL Server.

3 Click Next.

4 On the Connection tab:

a. Enter the server name, which is the computer hosting the relational database.

b. Select Use a Specific User Name and Password.

c. Enter a username and password for a user with full access rights to the database.

Note: You can use the default username sa. If you use the default name, leave the
password text box blank, and select Blank Password. If you do not want to use
the default username, you must enter the name of a user other than the default
user who has full access rights. Ensure that this user is granted privileges to create,
update, and delete tables. See “Creating Microsoft SQL Server Databases” on page
16.

d. Select Allow Saving Password.

5 Select the database to which you want to connect.

6 Click Test Connection.

7 On the Test Connection Succeeded box, click OK.
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8 Click OK to save the connection, and close the dialog box.

9 Right-click the UDL file, and select Open to set the selected UDL file as the system data link file.

Configuring the Data Link for IBM DB2 
The data link specifies the database server name and other database-related information, such
as the username and password of a user with full access rights to the database server.

ä To configure the data link for IBM DB2:

1 From Windows Explorer, double-click the UDL file that you created.

The Data Link Properties box is displayed.

2 On the Provider tab, from the OLE DB Providers list, select IBM OLE DB Provider for DB2 Servers.

3 Click Next.

4 On the Connection tab:

a. Select Use data source name option.

This option selects the data source name that you established during the IBM DB2
installation.

Note: If the data source name is not displayed in the list, go to the Client Configuration
Assistant, Database Properties box, and select As a system data source.

b. Enter a username and password.

Note: Ensure that the user is granted privileges to create, update, and delete tables. See
“Creating IBM DB2 Databases” on page 17.

5 Select Allow saving password.

6 Click Test Connection.

7 On the Test Connection Succeeded box, click OK.

8 Click OK to save the connection and close the dialog box.

9 Right-click the UDL file and select Open to set the UDL file as the system data link file.

Encrypting UDL Files
Financial Management provides a utility to encrypt the UDL file used by the application server
to communicate with the database. Based on the UDL file extension, Financial Management
detects whether the file is encrypted. If the file extension is .UDL, the system assumes that the
file is not encrypted. If the file extension is .hfmudl, the system assumes that the file is encrypted.

To encrypt the UDL file, you use the EncryptHFMUDL utility located in the
FinancialManagement/Server directory.
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ä To encrypt the UDL file:

1 Do one of these tasks to access the MS-DOS command prompt:

l Select Start > Programs > Accessories > Command Prompt.

l Select Start > Run, and type cmd.

2 Enter encrypthfmudl hfm.udl hfm.hfmudl

where hfmUDL. is the location and name of your original UDL file, and hfm.hfmUDL. is the
location for the encrypted UDL file.

Note: The encrypted UDL file extension must be .hfmudl. After encrypting the file, you can
delete the original unencrypted file.

ä To decrypt the UDL file:

1 Do one of these tasks to access the MS-DOS command prompt:

l Select Start > Programs > Accessories > Command Prompt.

l Select Start > Run, and type cmd.

2 Enter encrypthfmudl hfm.hfmudl hfm.udl /u.

where hfm.hfmudl. is the location for the encrypted UDL file, and hfm.udl is the location for
the decrypted UDL file.

Database Connection Pooling
Financial Management utilizes connection pooling in communicating with the database.
Connection pooling enables more efficient database utilization and does not require each user
to be set up in the relational repository.

When you configure Financial Management, the Financial Management Configuration Utility
enables you to specify the number of pooled database connections. The number of connections
that you specify in the configuration utility is the maximum number of pooled connections
consumed by an application. The pool starts with eight connections. If after a certain number
of attempts, the pool is unable to service a request for an additional connection, it adds eight
more connections. The system continues adding blocks of eight connections until it reaches the
maximum number of connections defined in the utility. If the system needs an additional
connection beyond this limit, a temporary connection is created to service the request, which is
closed after the task is complete.

The system also creates additional connection pools that are reserved for system use and are not
used for user activity. The system-use pools are divided into these connection types:

l A pool of nine connections per application is reserved for system activity.

l A pool of eight connections per application is reserved for error handling.

l A pool of eight connections per application server is created for user logon activities. The
user logon pool can grow by four to the system-defined maximum value of 16 connections.
Connections required above the maximum are temporary.
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In general, there are 25 connections dedicated to system-level activities: eight connections
reserved for each application server, and 17 connections reserved for each application.

Connection use is dependent on the activity type. Users with Read access, which are the majority
of users in an application, generally use one or no connections. Users with Write access can
consume more connections, as they write to the database. The number of connections consumed
by a user with Write access, for example, a consolidator, depends on the application server
hardware and quantity of data being written. In general, users with Write access may use five to
ten connections.

Financial Management opens the defined number of connections when an application is first
opened. The connections are then available for subsequent users of the system. If a user process
requests a connection and all connections are in use, the system polls the connection pool for a
short time, waiting for a connection to become available. If no connection is available, the system
creates eight connections and adds them to the pool. The connection pool is limited to the total
that you define in the configuration utility.

Connections are application specific. The default pool is created only after an application is
opened. However, connections are not released on an application basis. They are released on an
application server basis; thus all connections are not released until the application server has no
Financial Management users accessing any application.

Financial Management also supports Extended Analytics, which enables extracting data to a
relational database for use with other systems, such as Analytic Services. The extract process has
a dedicated connection pool that is created when a star schema is created. The default pool is 16
temporary connections that are destroyed when the processing is complete.

Example 1
Three applications on one application server, default maximum connection pooling is used (40
connections)

l Application A is logged on - 8 connections (plus system)

l Application B is logged on - 8 connections (plus system)

l Application C is logged on - 8 connections (plus system)

l System connections: 59 (8 plus 17 per application)

l Total connections: 83

Note: Total connections could grow by 96 if all application connection pools expand to the
system maximum as defined in the configuration utility (default is 40).

l Application B is logged off (no users)

l Total connections: 83

l All users log off all applications

l Total connections: 0
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Example 2
One application on two application servers, default maximum connection pooling is used (40
connections)

l Application A is logged on (server 1) - 8 connections (plus system)

l Application A is logged on (server 2) - 8 connections (plus system)

l System connections: 50 (8 plus 17 per application per application server)

l Total connections: 66

l Application A (server 2) is logged off (no users)

l Total connections: 33

l All users log off all applications

l Total connections: 0

At times, connectivity between the application server and the database server might be lost due
to network issues, for example. If the system detects that a connection is no longer valid, it
attempts to recreate the connection.

Deleting applications also consumes the default number of pooled connections. Before deleting
an application, Financial Management opens the application to verify security access, consuming
the default number of connections. After security is validated, the system deletes the application.
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The Financial Management setup program installs the files needed to run Financial Management
and Performance Management Architect. Before installing Financial Management, you must
complete these steps:

l Install and configure Shared Services.

l Configure external authentication through Shared Services.

For instructions, see the Hyperion Shared Services Installation Guide.

If you use a separate application server and client workstation, you must install Financial
Management on each computer.

If you install Financial Management on one computer, you can install the Server and Client
components simultaneously with the Custom installation option.

Installing Microsoft Internet Information Services
To use Financial Management on the Web, you must install Microsoft Internet Information
Services (IIS) on the Web Server. If you use a separate, dedicated computer to run the Financial
Management Web server components, you must install IIS on that computer.

To use Performance Management Architect, you must have IIS 6.0 or 5.0 installed on the
Dimension Server.

The IIS version depends on whether you are using Windows 2000 Server or Windows 2003:
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l For Windows 2000 Server, IIS 5.0 is provided.

l For Windows 2003, IIS 6.0 is provided.

For IIS 6.0, you must enable these components:

m Active Server Pages (ASP)

m ASP.NET 2.0

Verifying the IIS Installation

ä To verify the IIS installation:

1 Select Start > Programs > Administrative Tools > Component Services, and double-click Services, or
from Windows 2003, select Start > Settings > Control Panel > Administrative Tools > Services.

2 Check to see that the IIS services are running:

a. Select IIS Admin Service, and, if it is not started, click Start.

b. Select World Wide Web Publishing Service, and if it is not started, click Start.

c. If you did not see the services for IIS, make sure that IIS is installed.

i. In Control Panel, select Add/Remove Programs.

ii. Under Windows Components, select Application Server and look for Internet
Information Services (IIS).

iii. Install IIS if it is not already installed.

About Hyperion Home
When multiple Hyperion products are installed on one computer, common internal and third-
party product components are installed to a central location, called Hyperion Home. The
Hyperion Home location is defined in the system environment variable called
HYPERION_HOME.

Hyperion Home Location
The default location for Hyperion Home is C:\Hyperion. When you install, the installer
searches for the HYPERION_HOME environment variable on the computer to which you are
installing.

If the Hyperion Home location was previously defined for another Hyperion product, the
installation uses that location and it cannot be changed through the installer.

If the current installation is the first Hyperion installation on the computer, you can specify the
location during installation.

28 Installing Financial Management and Performance Management Architect Server Components



Changing the Hyperion Home Location
After Hyperion Home is defined through the product installation, you can run a migration utility
to change the Hyperion Home location.

The migration utility moves the files installed in Hyperion Home to the new location and updates
the value of the HYPERION_HOME environment variable.

Hyperion Home Migration Utility is provided with the Shared Services installation.

Note: For an Apache Tomcat 5.0.28 Windows installation, you can install the Shared Services
server as a Windows service. If you select this option, the Shared Services server is launched
automatically by the service and runs in the background. However, if you change the
HYPERION_HOME location, the Windows service does not automatically start. This
problem occurs because the registry entries for the Windows service retain the old path
information. To solve this problem, you must manually update the location of the
Windows service.

ä To change the Hyperion Home location:

1 Launch the migration utility by selecting Start > Programs > Hyperion > Foundation Services> Home
Migration Utility, or by double-clicking the run.exe file from <HYPERION_HOME>\common
\utilities\HyperionHomeTool\9.3.1\bin.

2 Step through the screens, and when prompted, enter the Hyperion Home location or click Browse to
navigate to the preferred location.

Do not choose a HYPERION_HOME location that contains a space character. For example, C:
\Program Files is not acceptable.

Installation Files and Directories 
The Financial Management installation program installs files needed to run Financial
Management, Performance Management Architect, and common components used by multiple
Hyperion products. Performance Management Architect is a component of the Financial
Management installation. If you choose to use Classic Application Administration instead of
Performance Management Architect, Classic Application Administration is automatically
installed with Financial Management.

Note: The installation program contains these three files: media.inf, setup.exe, and
suite.jar, which must be in the same directory for the installation program to run.

What Happens During Installation
By default, the Financial Management and Performance Management Architect installation
program performs these operations:

l Creates installation directories
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l Copies Financial Management software files to the directory specified during the installation

l If Performance Management Architect is selected for installation, copies software files to the
Performance Management Architect installation directory, creates the virtual directory in
IIS, installs .NET Framework 2.0 if not installed, and installs C++ Runtime libraries.

l Copies common components to the HYPERION_HOME directory that you specify

l Installs the Java Runtime Environment (JRE) version

Directories and Files Installed
The setup program installs Financial Management files in one directory, internal components
and third-party products in another directory, and Performance Management Architect files in
a separate directory.

l Financial Management software files are installed in the directory specified during
installation (for example, <drive>:\Hyperion\FinancialManagement). Files required
for the Performance Management Architect Dimension Server and Data Synchronization
Server application server deployment are installed in an AppServer directory, and files
required for the Dimension Server are installed in the Server directory.

l Additional internal components and third-party products are installed in <drive>:
\HYPERION_HOME\common.

Files Installed in the Performance Management Architect Directory
If you install Performance Management Architect, its components are installed in the directory
that you specify during installation. The default location is <drive>:\Hyperion\BPMA.

Table 2  Files Installed in the BPMA Directory

Directory Contents

AppServer Files required for Java application server deployment for Dimension server and Data Synchronization server

Common Shared libraries for Performance Management Architect

Server SQL files required for relational database configuration

docs Hyperion Enterprise Performance Management Architect Administrator’s Guide

Files Installed in the HYPERION_HOME Directory
Various files are installed in the HYPERION_HOME\common directory by a default installation of
Shared Services. Some common components, and thus some files and folders, are optional and
may not be installed.
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Table 3 Common Component Folders Created in the Common Directory

Directory Contents

appServers Application server files

CLS License services APIs

config Hyperion Configuration Utility files

CSS Files to support Hyperion external authentication

Docs Product documentation files

EssbaseJavaAPI Java driver used when embedding Essbase in other applications

EssbaseRTC Essbase runtime client used when embedding Essbase in other applications

httpServers Apache Web server files

HyperionLookandFeel Installer user interface files

JakartaCommons Common development library files

JavaMail Files to support sending e-mail using Java

JCE JCE files for encryption, key generation and agreement, and MAC

JDBC JDBC files

JRE Java Runtime Environment files

lib common internal library files

loggers Files for external authentication logging

ODBC ODBC drivers

Opatch Oracle patching tool files; for future use

PERL Scripting language files

SAP SAP files

Shared Services Supporting services for Shared Services

utilities Utilities to change the location of Hyperion Home and export, import, or validate provisioning data

validation Not used in this release

velocity Not used in this release

XML Common XML components
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Installing Financial Management
Use this procedure to install Financial Management Application and Web Server components.

ä To install Financial Management on the application server:

1 Ensure that Shared Services is installed and configured in the environment. See the Hyperion Shared
Services Installation Guide.

2 Navigate to the directory for the installation program, select File > Run or Start > Run and enter Drive:
\folder\Setup.exe, where Drive and folder are the installation program location.

3 Select the installation process language, and click OK.

4 Review the Welcome box and click Next.

5 From the list of countries, select the location from which you are installing, and click Next.

6 Read the license agreement, select I AGREE and click Next.

7 Click Next to accept the default installation path for HYPERION_HOME, or click Browse and navigate to
another directory, and click Next.

The default directory is C:\Hyperion.

Ensure that the directory name does not contain spaces. You can enter only English
alphanumeric characters and these special characters: dash (-), underscore (_), backslash
(\), forward slash (/), dot (.), colon (:). The colon character (:) is supported only for Windows
platforms to specify the drive (for example, c:\).

Note: If the installation program detects a HYPERION_HOME directory, Directory Name
and Browse are not selectable.

Note: If a Java Virtual Machine (JVM) version is detected in the Hyperion Home location,
a warning message is displayed. Shut down products using JVM and click OK to
continue.

8 Click Next to accept the default installation directory or click Browse to select another directory, and
click Next.

The default directory is C:\Hyperion\FinancialManagement.

Ensure that the directory name does not contain spaces. You can enter only English
alphanumeric characters and these special characters: dash (-), underscore (_), backslash
(\), forward slash (/), dot (.), colon (:). The colon character (:) is supported only for Windows
platforms to specify the drive (for example, c:\).

9 From Setup Type, select Custom, and click Next.

10 Select components to install, and clear components that you do not want to install.

l To install all Client, Application Server, and Web components, select Hyperion
Financial Management — System 9 and Hyperion Enterprise Performance
Management Architect.

To install specific components, select:
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l Client

Install all components for a full client installation, including the Win32 Client, Analytic
Data Model (ADM) Client, and Sample Applications.

l Application Server

Install all files required for the application server.

l Web

Install all components to access Financial Management through the Internet.

m Web Server

Install Web Server components on this computer. You can, if you want, install the
Web Server components later on another computer.

m Smart View Provider

Install the Smart View provider on the Web server. For information on installing
Smart View on the client tier, see “Installing Smart View ” on page 38. For
information on using Smart View, see the Hyperion Smart View for Office User
Guide or Online Help installed with Smart View.

Note: SmartView requires the use of Microsoft .NET Framework 2.0. When you
select this component, if you do not have .NET Framework 2.0 installed, the
system will install it as part of the installation process. If you do not want to
install SmartView, you can choose to continue the installation without
installing it.

l Consultant Utilities

Install Financial Management additional utilities.

l Oracle Hyperion EPM Architect

Note: To use Performance Management Architect, install both of these components.
The system detects if these components have previously been installed on this
computer, for example, during a Planning installation, in which case you do not
need to reinstall them.

m Application Server

Installs the Dimension Server, Data Synchronization Server, and files required for
Interface Datasources.

m Web Server

Installs Performance Management Architect Web tier.

Note: To use Performance Management Architect, you must have installed a Java
application server. For a list of supported Java application servers, see the Hyperion
Installation Start Here.
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Performance Management Architect requires the use of Microsoft .NET Framework 2.0.
During the Performance Management Architect Application Server installation, if .NET
Framework 2.0 is not detected, you are prompted to install it. Select Install Microsoft .Net
Framework 2.0 and continue to have .NET 2.0 automatically installed.

11 Review the component summary information, and click Next to continue the installation, or Back to
change settings.

If you do not have Microsoft Data Access Component (MDAC) installed on the application
server, the system installs it automatically at this point. The MDAC installation process can
be time-consuming, and requires that you reboot your computer.

12 If system files were detected that needed to be updated during installation, a status message is
displayed. Click Next to continue.

For a list of updated files, check the install log, installLog.txt, at the root of the directory
in which you installed Financial Management. If Windows File Protection is enabled,
download the Windows update to obtain the latest version of the files.

13 When you receive the message that the installation is complete, click Next.

14 If prompted, select whether to restart your computer at this time, and click Finish.

15 Run the configuration utility. See Chapter 5, “Configuring and Setting Up Financial Management”.

It is recommended that you reboot your computer before starting configuration.

Installing Only Web Server Components
If you run Web server components on the application server, you can install the components
during a Custom installation.

If you need to install the Financial Management Web server components on an additional
application server or on the server that is running Microsoft Internet Information Server (IIS),
during the installation process, you can install only the Web Server components.

ä To install only the Financial Management Web server components:

1 Start the Financial Management installation.

See “Installing Financial Management” on page 32.

2 From Setup Type, select Custom, and click Next.

3 From Component Selection, select Web Server.

Note: Clear components that you do not want to install. If you clear a component that is
already installed on the computer, the component is removed from the computer.

4 Select a destination folder for the files, and click Next.

5 Review the current settings, and click Next to continue the installation, or Back to change settings.

6 If prompted, select whether to restart your computer at this time, and click Finish.
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Installing Only the Analytic Data Model (ADM) Driver
If you use Financial Management with Financial Reporting, Oracle's Hyperion® Web Analysis
– System 9, or Oracle's Hyperion® Application Builder J2EE, you must install the Analytic Data
Model (ADM) driver components. You can install only the ADM components using the
following procedure. This process installs the files needed for ADM integration with Financial
Management. By default, the ADM driver, HsvADMDriver.dll, is installed in Drive:\Hyperion
\FinancialManagement\Client.

ä To install only the ADM components:

1 Start the Financial Management installation.

See “Installing Financial Management” on page 32.

2 From Setup Type, select Custom, and click Next.

3 From Component Selection, select ADM Client.

Note: Clear components that you do not want to install. If you clear a component that is
already installed on the computer, the component is removed from the computer.

4 Select a destination folder for the files, and click Next.

5 Review the component settings, and click Next to continue the installation or Back to change settings.

6 If prompted, select whether to restart your computer at this time, and click Finish.

Installing the HFM Software Development ToolKit
The HFM Software Development ToolKit is a guide for programmers who are responsible for
using the Web object model to customize Financial Management.

ä To install the Software Development Toolkit:

1 Navigate to the installation program directory, select File > Run or Start > Run and enter Drive:\folder
\Setup.exe, where Drive and folder are the installation program location.

2 From the the directory in which you downloaded the ToolKit, double-click HFM_SDK.exe.

3 Review the Welcome box and click Next.

4 Select a destination folder for the files, and click Next.

5 Click Finish.

6 After you install the Toolkit, navigate to the installation directory, and open Readme.html.
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Performing Silent Installations of Financial
Management 
If you want to install Financial Management on multiple computers and use the same options
for each installation, you can use a silent mode installation process. Silent installations automate
the installation process so that you can install Financial Management without manually
specifying settings during each installation.

To run a silent installation, you record your installation settings in a response file for the first
computer and then run the response file to apply the settings for other computers.

Creating the Response File
The response file is a recording of the Financial Management installation program and contains
the system-specific information that you are prompted to enter during installation, including
the bean ID keys and their values.

ä To create the response file:

1 Ensure that JDK version 1.3.1 or later is installed on your computer.

2 Create a blank text file to use as the response file.

3 Navigate to the directory that contains the product installer (setup.exe).

4 Open the command prompt and enter:

setup.exe -options-record <responsefilename>

The Financial Management installation program is launched.

5 As you step through the installation, enter the values to use as the defaults in the response file.

The values are recorded in the response file. You can modify the response file if you want
to change the options.

6 After the installation, open the response file in a text editor. Confirm that the bean ID keys and values
are correct, or modify as required. Save the file.

Running the Silent Installation
You can silently install Financial Management by running the response file.

ä To run the silent installation:

1 Copy the response file and the Financial Management installation files to the location of the computer
on which you are installing.

2 Open the command prompt and enter: setup.exe -options <responsefilename> -silent

The installation runs in the background, and Financial Management is installed with the
settings of the original installation.
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The client is offered through Web servers or through a Win32 client installed on the local
computer. Requirements at the client level are minimal, as no processing or business rules are
performed on the client. For client requirements, see the Hyperion Installation Start Here.

Installing Financial Management on the Client
The installation program installs files needed to run Financial Management and common
components used by multiple Hyperion products.

The Typical installation for client installations does not install server components. If you need
to install server components, see Chapter 3, “Installing Financial Management and Performance
Management Architect Server Components”.

Note: The installation program contains these three files: media.inf, setup.exe, and
suite.jar, which must be in the same directory for the installation program to run.

ä To install Financial Management on the client tier:

1 Ensure that Shared Services is installed and configured in the environment. See the Hyperion Shared
Services Installation Guide.

2 Navigate to the directory for the installation program, select File > Run or Start > Run and enter Drive:
\folder\Setup.exe, where Drive and folder are the installation program location.

3 Select the installation process language, and click OK.

4 Review the Welcome box and click Next.

5 From the list of countries, select the location from which you are installing, and click Next.

6 Read the license agreement, select I AGREE and click Next.

7 Click Next to accept the default installation path for HYPERION_HOME, or click Browse and navigate to
another directory, and click Next.

Installing Financial Management on the Client 37



Ensure that the directory name does not contain spaces. You can enter only English
alphanumeric characters and these special characters: dash (-), underscore (_), backslash
(\), forward slash (/), dot (.), colon (:). The colon character (:) is supported only for Windows
platforms to specify the drive (for example, c:\).

Note: If the installation program detects a HYPERION_HOME directory , Directory Name
and Browse are not selectable.

8 Click Next to accept the default installation directory, or click Browse to select another directory, and
click Next.

9 From Setup Type, select Typical, and click Next.

10 From Component Selection, select the components to install, and clear components that you do not
want to install.

11 For a Typical installation, you can install these components:

l Win32 Client

Install all components for the Windows 32 client desktop.

l ADM Client

Install Analytic Data Model (ADM) if you use Financial Management with Financial
Reporting, Web Analysis, or Oracle's Hyperion® Application Builder J2EE. ADM is the
connectivity component between Hyperion data sources. You can also install ADM later
on another computer.

l Sample Applications

Select this option to install sample applications.

12 Click Next to accept the default installation directory, or click Browse to select another directory, and
click Next.

13 Review the component settings, and click Next to continue the installation or Back to change settings.

14 If prompted, select whether to restart your computer at this time, and click Finish.

15 Run the configuration utility.

See Chapter 5, “Configuring and Setting Up Financial Management”.

Installing Smart View 
Smart View provides a common Microsoft Office interface for Financial Management, Planning,
Hyperion® System™ 9 BI+™ Essbase Analytics™, and Reporting and Analysis modules. Using
menu-driven options in Microsoft Office, you can import data and images from Hyperion
products into Microsoft Office components such as Excel, Word, and PowerPoint, and work
with Financial Management functions.

The Financial Management Setup program places the installer for Smart View in this location:

<drive>:\Hyperion\FinancialManagement\Web\HFMOfficeProvider.
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The SmartView installer is named SmartView.exe. You can distribute the installer to your
users using several methods, for example, by e-mail or by a URL. You can also create a public
task list with a SmartView link to the installer and specify a security group for add-in users. Users
in the specified security group can click the link and run the installation. For information on
creating a task list, see the Hyperion Financial Management — System 9 User’s Guide.

After Smart View is installed, users must create a connection to Financial Management using
the SmartView Connection Manager.

For instructions on using Smart View, see the Hyperion Smart View for Office User Guide or
Online Help installed with Smart View.

ä To install Smart View on the client tier:

1 Navigate to the Smart View installation file location specified by your administrator.

2 Double-click the SmartView.exe file to run the installation and click Next.

3 Install Smart View to the default path, C:\Hyperion\SmartView, or click Change to install to
another directory, and click Next.

4 Click Install.

5 Click Finish to exit the installation wizard.

The next time that you open Microsoft Excel, Word, or PowerPoint, a Hyperion menu is added
to the menu bar.

Note: Before you uninstall Smart View, you must exit all Microsoft Office applications. When
you uninstall Smart View, several registry items remain on your computer to preserve
your Smart View login and user preference information. These files are in the
HKEY_CURRENT_USER\Software\Hyperion Solutions folder and are called Hyperion
SmartViewConnections, Login, and Preferences.

Verifying Communications Between the Application
Server and Client
After setting up the application server and the client workstation, you must make sure that
communications between the server and client are working properly.

Verify these items:

l Ensure that the user logged on the application server has administrative rights to the
Windows server.

l Ensure that Distributed Component Object Model (DCOM) configuration is enabled on
the application server. The Default Authentication level must be set to None on the client
workstation to enable Financial Management components to communicate with other
Hyperion products.

l To confirm communications between the application server and the client, you must register
the application server at the client workstation.
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You run the Hyperion Configuration Utility to configure Hyperion products. After running the
Hyperion Configuration Utility, you must run the Financial Management Configuration Utility,
which enables you to perform these tasks:

l Configure application servers

l Set up application server clusters

l Register and unregister application server clusters

l Configure Web servers

l Set up links to Related Content

l Configure Smart View

Whenever you install or reinstall Financial Management, you must run the Financial
Management configuration utility.
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Hyperion Configuration Utility
Hyperion Configuration Utility is a common tool that installs automatically with Hyperion
products. Although you must use it to set up new products that you install, it also enables you
to reconfigure existing products and upgraded products. Configuration involves these tasks:

l Product option activation— To comply with your license agreement, select the product
features that you are authorized to use.

l Shared Services registration—To use Shared Services to provision and share users among
Hyperion product applications.

l Relational database configuration—To store and retrieve application data in a database
repository.

l Application server deployment—To deploy the application automatically, or partially, to
an application server.

l Shared Services deregistration—To deregister products fromShared Services before
upgrading or uninstalling these products.

For information about the order of configuration tasks, acceptable characters, and resolving
configuration issues, see:

l ???

l ???

l ???

Task Sequence
Hyperion recommends that you configure products separately and perform all configuration
tasks. However, you can configure products simultaneously performing all, or specific,
configuration tasks.

Restricted Characters
Only enter alphanumeric, dash (-), dot (.) , underscores (_), and tildes (~) during configuration.
Tildes are only supported on Microsoft Windows. All other characters are not supported.

Troubleshooting
Terminating configuration for one product does not stop the configuration of other products.
All configuration warnings and errors are logged as follows:

If you encounter errors, perform these tasks:

l Configure products individually.
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l See the Hyperion Installation and Configuration Troubleshooting Guide for information about
configuration checks, debugging using logs, troubleshooting methodology, and solutions
to common configuration issues.

Satisfying Initial Requirements
If you are using Hyperion Configuration Utility for the first time, perform these tasks:

Table 4 Configuration Requirements

Task Reference

Satisfy system and product-
specific requirements.

“System Requirements” and “Planning Hyperion Installations” in the Hyperion Installation Start Here

Gather the information you need
to configure products.

“Hyperion Configuration Utility Worksheets” in the Hyperion Installation Start Here

Install, configure, and start the
Shared Services server.

Hyperion Shared Services Installation Guide

Configuring Product Upgrades
You can use Hyperion Configuration Utility to configure and reconfigure supported product
upgrades. Note the following:

l If you upgraded Shared Services, configure it before configuring other products.

l Configure upgraded products individually.

l Deploy to the same database you used when you configured the previous product release.

If you do not want to use Shared Services with the products you are upgrading, select Shared
Services Deregistration during configuration

Configuring Financial Management
Run Hyperion Configuration Utility on the computer hosting the products to configure or
reconfigure.

ä To configure Financial Management:

1 Launch Hyperion Configuration Utility as follows:

l At the end of installation by selecting Launch Hyperion Configuration Utility on the
last panel.

l Using one of these methods:

2 Select the language in which to configure and click Next.

3 On the Welcome page, click Next.
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4 Select the products and the tasks to perform, then click Next.

Task Sequence for Financial Management
Select these tasks to configure Financial Management:

l Register Financial Management with Shared Services

l Run the Financial Management Configuration Utility. See “Using the Financial
Management Configuration Utility” on page 44.

l If you are using Performance Management Architect, configure the Financial Management
Product Instance. See Chapter 6, “Configuring and Setting Up Performance Management
Architect”.

Registering with Shared Services
By default, the user you specify during registration is pre-provisioned as admin. This enables
you to log on toShared Services after configuration using admin/password, to create and
provision users.

ä To register Financial Management with Shared Services:

1 Specify Shared Services server information:

Table 5 Shared Services Registration

Field Description

Server Name The name of the computer where the Shared Services server is installed.

Caution! Do not specify an IP address, especially in DHCP environments, or enter restricted characters.

Port The default or custom Shared Services server port number.

User The username of the Shared Services Administrator.

Password the password of the Shared Services Administrator.

SSL Select to use Secure Sockets Layer for encryption. See the Hyperion Product SSL Configuration Guide.

2 Click Next.

Using the Financial Management Configuration Utility

The Financial Management Configuration task launches the Financial Management
Configuration Utility. The Financial Management Configuration Utility is a wizard that enables
you to enter server security information and create database links when you run it on the
application server, register servers and create virtual Web directories when you run it on the
Web server, set up links to related content, and configure Smart View for Office.
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The tabs that display in the configuration utility depend on the components that you are
configuring. For example, the Application Server and Application Server Cluster tabs pertain to
an Application Server installation. The Server/Cluster Registration tab pertains to the Client
installation. The Web Server, Related Content, and Smart View Provider tabs pertain to a Web
Server installation.

The Financial Management Configuration Utility, HFMConfigure.exe, is installed in the
following default directory when you install Financial Management:

C:\HYPERION_HOME.\FinancialManagement\Client.

ä To use the Financial Management configuration utility:

1 Use one of these methods to start the configuration utility:

l Launch it from the Hyperion Configuration Utility.

l Select Start > Programs > Hyperion > Financial Management > Server and Web
Configuration.

2 Enter information on each tab and click Apply to save your changes before moving to the next tab.

Note: If you click Cancel and move to another tab before applying changes, the system
prompts you with a message that changes have not been applied. You can click Yes
to save the changes, or No to exit the utility without saving changes.

3 When you finish entering information for each tab, click OK to save your changes and close the utility.

Configuring Application Servers
You use the Financial Management Configuration Utility to configure application servers. 

Setting DCOM User Information
The configuration utility enables you to configure Distributed Component Object Model
(DCOM) security.

Note: You must run the configuration utility as a Domain or Local Administrator to configure
the DCOM user.

The Financial Management application server is built using DCOM technology. DCOM enables
network-based component interaction and enables process sharing across a network.

All Financial Management application server processes are run under an administrator identity
(the specified Windows admin user), so no other administrator is required to log on the
application server to start the application server processes.

You must specify the Windows administrator under whose identity the application server
processes are launched.
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After you enter the Windows administrator information, the system performs these steps:

l Creates the Windows admin user (DCOM user) if the user does not exist. The user must be
part of the server domain to access Financial Management tasks and application elements.

l Adds the user to the local Administrators group

Note: The Financial Management administrator user or group must be a member of the
local Administrators group on each application server.

l Assigns these local security policies to the admin user: “Act as part of the operating system”
and “Log on as a batch job” . These local security rights must be enabled for users on each
Financial Management application server.

l Sets the “DCOM Run as” identity for all Financial Management application processes

l Sets DCOM Launch permissions for users

ä To specify the DCOM user information:

1 From the Financial Management Configuration Utility, select the Application Server tab.

2 For DCOM User Info, enter the domain and username.

If a username is not specified, security settings are retained from the previous configuration
(if applicable).

Note these limitations for the domain and username:

l A username cannot duplicate any other user or group name of the computer being
administered. A username can contain up to 20 uppercase and lowercase letters. A
username cannot consist solely of periods ( . ) and spaces and cannot contain these
special characters: " ‘ / \ [ ] : ; | = , + * ? < > &

l Do not use a single quotation mark ( ‘ ) in a username. A user with a single quotation
mark in the username cannot log on to Financial Management.

l You cannot use an IP address as a domain name when you configure the user account.

3 Enter the user password.

Note: The password can contain up to 14 characters. The system does not verify the
password, so ensure that the password that you use is valid.

4 Re-enter the password.

The Password and Confirm Password boxes are case-sensitive.

Note: If the entries that you make require changing the local security policy on the system,
you must log off and log on again to commit the changes.

Specifying Application Security Groups
You must specify the Financial Management Application Creator Group and Administrator
Group. Only the users in the Application Creator Group can create Financial Management
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applications. Only the users in the Administrator Group can access administrative tasks. The
Administrator Group must be a group that has already been defined in Shared Services.

If you do not specify the Administrator Group, the DCOM user will have access to system
administrative tasks.

Note: If you are using Financial Management or Performance Management Architect on the
Web, you need additional security roles. See “Performance Management Architect” on
page 10.

ä To specify the Application Creator Group and Administrator Group:

1 Ensure that the Shared Services server is started.

2 From the Financial Management Configuration Utility, select the Application Server tab.

3 In the Application Security section, enter the Creator Group name, or leave the default setting of
Everyone, and in the Administrator Group box, enter the Administrator Group name.

Setting the Working Folder and Database Link
You must specify the Financial Management Application Server Working folder, the database
link file, and the number of pooled database connections.

If you choose, you can also specify the database tablespaces in which data tables and indexes are
created.

ä To specify the folder and database link information:

1 From the Financial Management Configuration Utility, select the Application Server tab.

2 In the Working Folder and Database Link section, enter or browse to the path for the Server Working
Folder.

The Server Working folder stores system-generated files, such as reports. The default Server
Working Folder location is: <drive>:\Hyperion\FinancialManagement\Server
Working Folder.

Note: When you use multiple application servers, each server should have its own working
folder. Application servers should not share working folders as temporary files might
be overwritten.

3 Enter or browse to the database link (UDL) file name that you created when you set up the database.

If you do not have a UDL file, you must create one. For instructions, see “Creating Data
Link (UDL) Files ” on page 21.

A database link (UDL) provides a connection between an application server and a database
server. It specifies the database server name and other database-related information, such
as the username and password of a user with full access rights to the database server. You
must create a UDL file for each application server to access applications.
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4 Optional: To specify the database tablespaces in which the Financial Management data tables and

indexes are created, click  next to Data Tablespace or Index Tablespace; select the location for the
data tables, the indexes, or both, and click OK.

If you do not specify a tablespace, the default tablespace is used.

Note: For IBM DB2 Database Managed Space (DMS), or for SQL and Oracle databases, you
can specify a tablespace for the data table and a tablespace for the index. For IBM DB2
System Managed Space (SMS), you can specify only a data tablespace, which is used
for both the data table and the index. You cannot specify a separate tablespace for the
index.

5 Enter the number of maximum pooled relational database connections for the application, or use the
default setting of 40.

See “Database Connection Pooling” on page 24

Note: Financial Management requires approximately 25 relational database connections
per application in addition to the number that you specify in the Relational Database
Support dialog box.

Enabling Multiple Server Support
If you use multiple application servers, you can set them up in clusters so that they are
synchronized to communicate with each other. A cluster is a group of one or more application
servers. To use application server clusters, you must enable Multiple Server support.

If you do not want to enable Multiple Server support, you can skip this topic.

You can control the amount of time between when users make changes to data or to an
application and when the changes are visible to users who are accessing the data or application
from another application server.

If you use multiple application servers connected to one database server, you must make sure
that the system clocks on the application servers are synchronized. If the clocks are not
synchronized, the data being viewed might not be current.

Note: The synchronization between Financial Management application servers is based on
system time. Changing the clock can affect this. For the time change to and from Daylight
Savings Time, Hyperion recommends that you stop the servers before the time change,
and then restart them afterwards.  

To enable access to an application from multiple application servers, all application servers must
have this setup:

l Multi-server support enabled.

l Access to the same data link (UDL file).
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l Access to the same data link (UDL file) for Extended Analytics. See “Specifying DSN
Information for Extended Analytics (Optional)” on page 49.

ä To enable multiple server support:

1 From the Financial Management Configuration Utility, select the Application Server tab.

2 In the Multi Server Support section, select Enable Multi Server Support.

3 For Maximum Application Server Delay (Seconds), enter the time interval between when a change is
made to an application and when the change is visible to users accessing the application through
another application server.

4 For Maximum Data Synchronization Delay (Seconds), enter the time interval between when a change is
made to data and when the change is visible to users accessing the data through another application
server.

Tip: If these text boxes are grayed out, deselect and then reselect them to adjust the settings.

Specifying DSN Information for Extended Analytics (Optional)
The Extended Analytics feature enables you to use Hyperion System 9 BI+™ Oracle's Hyperion®
Essbase® – System 9™ to analyze data and produce reports. You use a data source name (DSN)
to specify the relational database destination for Extended Analytics. You must specify the data
source name and path. You can add, remove, or modify data source names as needed.

If you do not want to specify Data Source Name (DSN) information for Extended Analytics,
you can skip this topic. You must click Apply before moving to the next tab.

You should not use the relational database and UDL file for Extended Analytics that you use for
your Financial Management applications. You should create a database for the exported star
schema and data, and a UDL file that points to the database.

Note: When you use multiple servers with the Extended Analytics feature, you must enable
multiple server support on each application server, and you must set up each application
server so that these elements are the same on all servers: Clock setting, Data source, and
UDL file.

For information on using Extended Analytics, see the Hyperion Financial Management — System
9 Administrator's Guide.

ä To add a data source name:

1 From the Financial Management Configuration Utility, select the Application Server tab.

2 In the DSN Info section, click Add DSN.

3 For DSN Name, enter the data source name.

4 For DSN Path, enter or browse for the data source path.
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5 Optional: To specify the database tablespaces in which the Financial Management data tables and
indexes are created:

a. Click  (next to the Data Tablespace field), and select the data table location.

b. Click OK.

c. Click  (next to the Index Tablespace field), and select the index location.

Note: For Oracle and IBM DB2 SMS, you can specify only a data tablespace; index
tablespaces are not used.

d. Click OK.

6 Click OK.

ä To modify a data source name:

1 Select Application Server.

2 In the DSN Info section, select the DSN.

3 Click Modify and change the name.

ä To remove a data source name:

1 Select Application Server.

2 In the DSN Info section, select the DSN.

3 Click Remove DSN.

4 Click Apply .

Configuring Application Server Clusters 
An application server cluster is a set of application servers running the same application.
Clustered application servers provide load balancing and failover capability, and enable the
servers to be transparently maintained while applications remain available for users.

Note: To use application server clusters, you must enable multiple server support.

ä To set up application server clusters:

1 From the Financial Management Configuration Utility, select the Application Server Clusters tab.

2 For Cluster Name, enter an application server cluster name.

l To add a cluster or server, click Add, enter the name, and click OK.

l To remove a cluster or server, select the name, and click Remove.

3 Specify the names of the application servers that participate in the cluster:

l To add servers to a cluster, click Add Server, enter the server name, and click OK.
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l To remove servers from a cluster, select the server name, and click Remove Server.

Enabling Remote Activation (DCOM Limits for 2003 and XP)
If you use Windows 2003 Service Pack 1 or Windows XP Service Pack 2, you might experience
problems starting Financial Management remotely as an Anonymous User. If you are using
these, the button will be active if the settings are not correct to run Financial Management.

Note: If you use Windows 2000, this button is not displayed.

Hyperion recommends that if the button is active for your computer, you should click it to
enable the Financial Management Server to be started remotely.

ä To enable remote activation for Windows 2003 SP1 or Windows XP SP2:

1 From the Financial Management Configuration Utility, select the Application Server Clusters tab.

2 From DCOM Limits, click Configure Limits.

3 Click Apply to apply the changes.

The system displays a message that limits have been enabled.

Completing Server/Cluster Registration
You must register your server or cluster before you can access applications.

If you register one of the servers in a cluster, the system registers all of the servers in that cluster.
For example, you create an application server cluster named Marketing_Servers with application
servers Mkt1, Mkt2, Mkt3, and Mkt4. You can enter Mkt1 as the server to be registered, and the
system registers all of the servers in that cluster.

If you run the configuration utility from an admin account, the configuration utility creates the
HKeyLocalMachine/Software/Hyperion Solutions registry key so that you can register
server clusters. If you are not running the configuration utility from an admin account, you
might encounter problems when registering servers. In this case, in the registry, you should
manually assign Read/Write access rights to HKeyLocalMachine/Software for the user who
is registering the servers.

When you specify an individual server name from the servers in the cluster, the entire cluster is
registered. If there is only one application server in the server cluster, you must enter the server
name.

ä To register an application server cluster:

1 From the Financial Management Configuration Utility, select the Server/Cluster Registration tab.

2 Enter the server name that you are registering.

The application server name is used to obtain application server cluster information.
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3 Select one of these options:

l Use Automatic Load Balancing - to register the server cluster that was created in the
Application Server Clusters tab.

l Use One Server Only - to specify that only one server be used instead of a cluster

4 Click Add.

Tip: If you need to unregister a server or cluster, select it from the list and click Remove.

Enabling DCOM
From the Financial Management Configuration Utility, you can enable DCOM for the entire
computer. Enabling DCOM makes possible the launching of servers and connecting to objects
by remote clients for the machine. It also sets the DCOM Default Authentication level to None
for the computer. The Enable DCOM step is required for Financial Management client
components to communicate with Financial Management application server components when
the application server is on a different computer. It also makes it possible for the Financial
Management client and application server computers to be on different domains.

ä To enable DCOM:

1 From the Financial Management Configuration Utility, select the Server and Cluster Registration tab.

2 Click Enable DCOM.

Note: This button is grayed out if previously configured.

3 Click Apply.

Configuring Web Servers
You use the Financial Management Configuration Utility to configure Web servers.

You must register an application server on the Web server machine for users to be able to connect
to the application server through the Web. See “Completing Server/Cluster Registration” on
page 51.

Specifying Web Directories
You must create a virtual directory on the Financial Management Web server for the Financial
Management Web components to be accessible to Web users. You specify the Web installation
directory and the directory URL.

ä To create Web directories:

1 From the Financial Management Configuration Utility, select the Web Server tab.
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2 For Web Server Installation Directory, enter or browse to the path for the Financial Management Web
installation directory.

Note: The default location is the directory in which the Web components were installed,
for example: C:\Hyperion\FinancialManagement\Web\HFM.

3 For Virtual Directory, enter the virtual directory name, for example: HFM.

Specifying the File Transfer Directory
You must create a file transfer directory for load and extract log files and temporary files. When
you specify the file transfer directory, the system performs these steps:

l Creates the file transfer directory, if it does not exist

l Assigns the IIS users Windows permissions of Read, Write, and Execute

ä To specify the File Transfer Directory, browse to the path for the folder for the load, extract,
and log files, or use the default location; for example: C:\Hyperion
\FinancialManagement\Web\HFM\FileTransfer

Note: The File Transfer directory should be located outside of the virtual directory. If it is located
under the virtual directory, you should set No Execute rights on the File Transfer
directory.

Setting Upload File Size and Buffer Size
If you use IIS 6.0, you can use the Financial Management Configuration Utility to set the ASP
file size properties for loading and extracting files on the Web. Hyperion recommends that you
use the default file size properties unless you experience problems during loading and extracting.
However, if you load or extract huge files and send large amounts of data to the browser and
experience errors, you can change the file size settings.

For example, if you load large files, you might receive a 403 error message if the maximum upload
file size is set too low. In this case, you must increase the maximum file size. You enter the file
size in bytes, so if you expect to load files of 200 megabytes, you change the setting for maximum
upload file size to 200,000,000 bytes.

ä To set the ASP upload file size and buffer size:

1 From the Web Server tab, in the Max Upload File Size box, enter a maximum size for loading Web files.

2 For Response Buffer Size, enter a maximum size for extracting Web files.

If you run IIS 5.0 Isolation mode in IIS 6.0 on Windows 2003, after you create Web directories
and set ASP properties, you must manually set two additional IIS properties for the application
protection and authentication level.
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Specifying the Alert SMTP Server
You can use e-mail alerts for intercompany transactions, intercompany matching reports, and
during the process control review process to highlight key events or data changes in the system.
E-mail alerts are sent using standard Simple Mail Transfer Protocol (SMTP) protocol. To enable
e-mail alerts, you must specify the SMTP server name. For information on using alerts, see the
Hyperion Financial Management — System 9 User’s Guide.

ä To specify the Alert SMTP server:

1 From the Financial Management Configuration Utility, select the Web Server tab.

2 For Alert SMTP Server, enter the SMTP server name.

Specifying Links for Other Hyperion Applications

Note: If you do not want to access other Hyperion applications, you can skip this topic. Before
moving to the next tab or closing the utility, click Apply.

You can launch other Hyperion products from Financial Management and access other
Hyperion applications without having to supply login information. You must specify the URL
for each application that you want to access.

ä To specify URLs for other Hyperion applications:

1 From the Financial Management Configuration Utility, select the Web Server tab.

2 In the Application Links section, enter the URL for the Hyperion application that you want to access.

The URL is case-sensitive.

The Shared Services URL is the URL for the Web Server link (not your application server).

To drill through from Web data grids to FDM, use this URL:

http://<machine-name>/HyperionFDM/AuthorizedPages/

IntersectionSummaryByLocation.aspx

For information on Oracle's Hyperion® Financial Data Quality Management drill through,
see the Hyperion Financial Management — System 9 User's Guide.

Setting Web Server DCOM User Information
If you are installing only the Web Server components, you must specify the DCOM user
information on the Web Server tab.

ä To set DCOM user information:

1 From the Financial Management Configuration Utility, select the Web Server tab.

2 Enter the Domain, username, and user password, and confirm the password.
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Note: The Password and Confirm Password boxes are case-sensitive.

3 Click Apply.

Configuring Related Content
You can link from Financial Management to related content in other applications, such as
Financial Reporting and Web Analysis. The Related Content feature enables you to include
reports, views, and folders from other applications directly within Financial Management on
the Web.

ä To link to related content in another application:

1 From the Financial Management Configuration Utility, select the Related Content tab.

2 Enter the URL to the related content resource server.

Note: The Workspace URL is http://<workspace_server>:19000/workspace/
browse/listXML. To obtain the URL for other products, see that product's
documentation.

3 Click Add to add the URL to your URL list or Remove to remove a URL.

Note: After adding or removing a URL, you must close and reopen the Resource Server
dialog box to see your changes.

4 Click Apply.

Configuring the Smart View Provider
The Smart View component enables you to use Smart View and is supplied as part of the Financial
Management installation. If you did not select the Smart View component when you ran the
installation, you can rerun the installation process and install it.

ä To configure Smart View:

1 From the Financial Management Configuration Utility, select the Smart View Provider tab.

2 For Web Session Timeout, enter the Web session timeout value in minutes.

Note: The default session timeout is 20 minutes. You should set the timeout option to a
length of time appropriate for your Smart View sessions.

3 In the Installation Folder box, enter the location in which the SmartView component was installed or
use the default location.

Note: The default location is C:\Hyperion\FinancialManagement\Web
\HFMOfficeProvider.
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4 For Virtual Directory Name, enter the virtual directory name for Smart View or use the default virtual
directory.

The default directory name is HFMOfficeProvider.

5 Optional: For Deployment, select an option:

l Always force client to upgrade to upgrade to the latest add-in version to ensure that the
client and server versions are compatible

l Always warn when client version is newer to warn of a newer add-in version

6 Optional: For Proxy Server Timeout, if you use a proxy server between the Web server and client, select
Enable connection keep alive, and set a time interval in seconds for the connection.

7 Click OK to save the changes and close the Financial Management Configuration Utility.

Product Instance Configuration
If you are using Performance Management Architect, you must complete additional
configuration tasks, including Product Instance Configuration. See the procedures in Chapter 6,
“Configuring and Setting Up Performance Management Architect”.

If you are not using Performance Management Architect, skip this task.

Reconfiguring Products
Hyperion Configuration Utility enables you to reconfigure products to incorporate changes in
your environment such as a different application server.

To reconfigure, launch Hyperion Configuration Utility on the computer hosting the product,
and follow the procedures in this chapter.

Note: If you reconfigure a database, restart the application server afterward.

Completing Hyperion Configuration Utility
Configuration time depends on the products and tasks you selected. Progress is recorded in
configtool.log as follows:

When configuration finishes, the status of each task is displayed.

If configuration is successful, perform any required post-configuration tasks and start the
product.

If errors display, perform these tasks:

l Configure products individually and perform tasks separately.

l See the Hyperion Installation and Configuration Troubleshooting Guide  for information
about resolving configuration issues.
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6
Configuring and Setting Up
Performance Management

Architect

In This Chapter

Task Sequence for Performance Management Architect .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .57

Registering with Shared Services ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .58

Configuring the Database ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .58

Deploying Performance Management Architect to an Application Server .. . . . . . . . . . . . . . . . . . . . . . . . . . .60

Configuring Interface Datasources (Optional) .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .62

Financial Management Product Instance Configuration... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .63

Follow this sequence to configure Performance Management Architect for the first time.

Note: Before starting the configuration process, ensure that you have installed the application
server that you plan to use for Performance Management Architect Web server and Data
Synchronization server.

If you are using Classic Application Administration, skip this chapter.

Task Sequence for Performance Management
Architect
These are the tasks required to configure Performance Management Architect:

l Register with Shared Services

l Deploy to an Application Server

l Configure Database

l Interface Datasource Configuration (Optional). Interface tables are database tables used to
import data and metadata from external systems into Performance Management Architect.
To understand use of the Interface Datasource Configuration option in the Hyperion
Configuration Utility, see the Hyperion Enterprise Performance Management Architect
Administrator’s Guide. This option is not required to install Performance Management
Architect and can be done at a later time.
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All input for Shared Services registration, database configuration, and application server
deployment is gathered by Hyperion Configuration Utility and configuration for these tasks
occurs once at the end.

Registering with Shared Services

ä To register with Shared Services:

1 Specify Shared Services server information:

By default, the user you specify during registration is pre-provisioned as admin. This enables
you to log on toShared Services after configuration using admin/password, to create and
provision users.

Table 6 Shared Services Registration

Field Description

Server Name The name of the computer where the Shared Services server is installed.

Caution! Do not specify an IP address, especially in DHCP environments, or enter restricted characters.

Port The default or custom Shared Services server port number.

User The username of the Shared Services Administrator.

Password the password of the Shared Services Administrator.

SSL Select to use Secure Sockets Layer for encryption. See the Hyperion Product SSL Configuration Guide.

2 Click Next.

Configuring the Database
The Performance Management Architect database is used for the Dimension server. When you
configure Hyperion products to use a database, Hyperion Configuration Utility ensures that the
database is connected and is a supported database type.

For simplicity, Hyperion recommends that you use the same, or the default, database name
(hypdb), username (hypuser), and password for all products that you install.

If you changed a database-owner password in your relational database, you must change it in
the Hyperion Configuration Utility. See ???.

If you change the Shared Services administrator password, you must rerun the Configure
Database task. If you do not, the Process Manager service will fail to start.

You can use Windows Authentication for SQL Server connections if you use Microsoft SQL
Server database. See “Microsoft SQL Server Windows Authentication” on page 59.
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ä To configure the Performance Management Architect database:

1 From the list of supported databases, select the database and click Next.

Note: Oracle 10g can be selected for a 10.1.0.5 or a 10.2.0.2 database.

Note: If you are using a DB2 database for Performance Management Architect, DB2.NET
Data Provider is required. See “Creating IBM DB2 Databases” on page 17.

2 Specify database information:

Table 7 Database Configuration

Field Description

Server Name of the computer or server hosting the database.

Port Server port number on which the database listens.

Product Name of each product and its installation location.

Database or SID (Oracle
only)

Database name or the Oracle system identification (database instance). Do not use restricted characters.

Username The name of the database owner.

Password The password of the database owner.

Note: If this changes, reconfigure as described in the Hyperion Installation Start Here.

Data Tablespace
(Oracle)

Name of an existing tablespace used to create tables. The data tablespace is the logical portion of the
database used to allocate storage for table data.

Index Tablespace
(Oracle)

Name of an existing tablespace used to create database indexes. The index tablespace is the logical
portion of the database used to allocate storage for index data.

3 Click Next  after viewing configuration status.

4 Click Next.

Microsoft SQL Server Windows Authentication

ä To set up Windows authentication for a SQL Server connection:

1 Set up SQL Server with your NT login user:

2 Ensure that your NT domain user is assigned to the SQL Server database (for example, hub).

3 Grant the NT domain user full access permissions to the database.

4 From the configuration task list, select Configure Database.

5 From the database list, select SQL Server.

6 Specify all database information except for Username and Password.
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Deploying Performance Management Architect to an
Application Server
Performance Management Architect application server deployment involves two components:
the Performance Management Architect server (BPMWebTier) and the Data Synchronization
server (BPMDataSynchronizer).

Deploying to the Application Server
You can deploy multiple products to one application server, in a single profile (WebSphere) or
domain (WebLogic 9.1.x). The application server must be installed on the same computer as
the products.

For simplicity, Hyperion recommends that you use the same application server, and domain or
profile.

ä To deploy Performance Management Architect to an application server:

1 Select the application server that you are using and select Automatic as the deployment type, and click
Next.

Note:

For manual deployment, see Appendix B, “Manually Deploying Performance Management
Architect to an Application Server”.

2 In the Application Server dialog box, specify application server information:

Table 8  Deployment

Field Description

Location Path to the application server installation directory:

l WebSphere Base:

l WebSphere Express:

l WebLogic 8.1.x:

l WebLogic 9.1.x:

Deploy as a service Selected by default to register the web application as a Windows service listed in Windows Control Panel.
See “Startup Dependencies” in the Hyperion Installation Start Here.

Profile (WebSphere) Name of the profile where you access the application. By default, all applications deploy to the same
profile. To change the profile name, see ???.

Domain (WebLogic) Default name of the domain where you access the application. For WebLogic 9.1.x, all applications deploy
to the same domain. To change the domain name, see ???.
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Field Description

BEA Home (WebLogic) Path to the BEA Home directory (e.g.,)

Username and
Password (WebLogic)

WebLogic administrator username and password used to log on.

Note: If such a user doesn't exist, the information you enter creates a user.

Component Products being deployed. Some products display as components.

Server Name Name of the server where you will access the product.

Port To change the default port, enter a unique port number that does not exceed 1025 to avoid conflicts with
third-party port assignments. See “Ports” in the Hyperion Installation Start Here.

3 Click Next.

If you installed the Performance Management Architect Web Server component during
installation, continue with the next steps. These steps prompt you to specify the location of
the Performance Management Architect Dimension Server and Data Synchronization server
to enable communication with the Web server.

4 Accept the defaults for Dimension server details, or make a change if necessary (for example, if IIS is
on a port other than 80 or the server is on a different machine), and click Next.

Note: Hyperion recommends that you accept the default connection details.

Table 9 Dimension Server Fields

Field Instruction

Server Name Enter a server name.

Port Enter the port for the server.

SSL Select if you are using Secure Sockets Layer (SSL).

Maximum connections Enter the maximum number of simultaneous connections to the server.

Maximum idle connections Enter the maximum number of idle connections in the pool. If the number of idle connections exceed
this limit, the connection is closed.

Maximum wait time Enter the connection timeout in milliseconds for idle connections. If a connection is idle for longer than
the specified time, the connection is closed.

5 Accept the defaults for the Data Synchronization server details, or make changes if necessary, and click
Next.

Note: Hyperion recommends that you accept the default connection details.
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Table 10 Data Synchronization Server Fields

Field Instruction

Server Name Enter a server name.

Port Enter the port for the server.

SSL Select if you are using Secure Sockets Layer (SSL).

Maximum connections Enter the maximum number of simultaneous connections to the server.

Maximum idle connections Enter the maximum number of idle connections in the pool. If the number of idle connections exceed
this limit, the connection is closed.

Maximum wait time Enter the connection timeout in milliseconds for idle connections. If a connection is idle for longer than
the specified time, the connection is closed.

6 For Performance Management Architect Web Server details, if you are using Secure Sockets Layer (SSL),
change the port number to your SSL port number, select SSL, and click Next.

What Happens During Deployment  

WebSphere and WebLogic 9.1.x

Hyperion Configuration Utility deploys each application to the same WebSphere profile or
WebLogic domain. The profile or domain is created when the first application is deployed. Each
application runs in a separate JVM.

Hyperion Configuration Utility deploys the application to:

Under this directory, the bin directory contains start and stop scripts for all deployed
applications. For each application, there is also a setCustomParams<Product>.bat file or a
shell script where JAVA_OPTIONS can be changed when starting using start scripts.

To change the default profile or domain directory, modify the deployment directory parameter
in the weblogic.properties or websphere.properties in:

Note: It is not recommended to change other parameters in this file.

WebLogic 8.1.x

Deploying to a single domain for WebLogic 8.1.x is not supported. For WebLogic 8.1.x, Hyperion
Configuration Utility deploys the application to:

Configuring Interface Datasources (Optional)
Interface tables are database tables used to import data and metadata from external systems into
Performance Management Architect. To understand use of the Interface Datasource
Configuration option in the Hyperion Configuration Utility, see the Hyperion Enterprise
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Performance Management Architect Administrator’s Guide. This option is not required to install
Performance Management Architect and can be done at a later time.

Financial Management Product Instance Configuration
To complete the configuration of Financial Management and Performance Management
Architect, you must perform the Product Instance Configuration task.

This task creates the Financial Management instance that is needed for deploying applications
in Performance Management Architect. A Financial Management instance specifies the
environment that you are using for deploying applications in Performance Management
Architect. An instance is composed of a Web server with the application servers or clusters
registered to it that communicate to one database. For example, a Consolidation instance could
be composed of the Web server and the application servers or clusters used for consolidation
that all communicate to one database.

You must run this task from the Web server.

Creating an Instance
Use this procedure to create an instance. After you create the instance, it must be registered with
Shared Services.

Note: You create an instance from the Configuration Utility on the Web server. By default, the
system displays the name of the Web server from which you are running the Configuration
Utility.

ä To enter the instance information:

1 From the list of products to configure, select Financial Management.

2 From the list of tasks, select Financial Management Product Instance Configuration and click Next.

3 Complete this information:

Table 11 Financial Management Instance Fields

Field Instruction

Instance Name Enter a name for the instance.

Web Server Host This must be a local machine name. By default, this displays the name of the Financial Management Web
server from which you are running the Hyperion Configuration Utility. You can use the default value, or if
you use SSL, you must enter a fully qualified domain name.

Virtual Directory Name Specify the name of the virtual directory that you created in IIS when you installed Financial Management,
or use the default name of HFM.

Port Specify the port for the Web server, or use the default setting of 80.

SSL Select if you are using Secure Sockets Layer (SSL).
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Field Instruction

Select which clusters
and servers you want in
this instance

Select a cluster or server. This list is automatically populated with the names of the servers and clusters
associated with this instance.

4 At the prompt to return to the product selection panel, click No and click Next.

5 Click Finish.

Editing an Instance
If you have created an instance and deployed applications from Performance Management
Architect, if you change your server or cluster information, you must edit the instance. For
example, if you add or remove a server from a cluster, add or remove a cluster, or change a cluster
name, you must edit the instance information to be able to access the deployed applications.

ä To edit an instance:

1 From the Web server, re-run the Hyperion Configuration Utility and select HFM Performance Management
Architect Configuration.

2 Select the instance and edit the instance information as needed.

3 Click Next to continue with the configuration utility.

4 Log in to Performance Management Architect and from the Application Library, right-click on each
application for which the instance changed, and select Reregister.

5 Restart Workspace and Reporting and Analysis services.

Note: You will not see the applications for which you changed the instance until you restart.
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7
Post-Configuration Tasks
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Installing and Configuring Workspace
Before you can use Financial Management or Performance Management Architect, you must
install and configure Workspace, which is part of Oracle's Hyperion® Reporting and Analysis –
System 9 installation. You must install the Workspace Services and UI Services components. An
important part of configuring Workspace is to enable the Web Server Plug-in. See the Hyperion
Reporting and Analysis — System 9 Installation Guide.

After you complete Workspace configuration, you must grant security rights using the Shared
Services User Management Console.

Installing Financial Reporting
When you install Workspace, you can install Financial Reporting. See the Hyperion Reporting
and Analysis — System 9 Installation Guide.

If you use Financial Management with Financial Reporting, you must install the Analytic Data
Model (ADM) driver components. If you did not previously install ADM, you can install it by
running the Financial Management installation and selecting only the ADM components.

If you use Financial Management and Financial Reporting on different domains, you must set
the DCOM authentication on the Financial Management client computer to None to ensure
communication between them. See ???
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Note: Financial Reporting can use Apache Web server for the Web server; however, Apache and
Microsoft IIS use the same port. If you run Financial Management and Financial
Reporting on the same computer, you must use IIS as the Web server.

Configuring Settings for IIS 5.0 Isolation Mode
(Optional)
Before you install Financial Management, you install and configure IIS. However, if you run IIS
5.0 Isolation mode in IIS 6.0 on Windows 2003, after you run the configuration utility and create
your Web directories, you must manually set two additional IIS properties for the Application
Protection and Authentication Level.

ä To set the properties for IIS 5.0 Isolation mode:

1 Select Start > Programs > Administrative Tools > Internet Services Manager.

2 Expand Internet Information Services and its subdirectories, and right-click the virtual directory for
Financial Management, for example, HFM and select Properties.

3 On the Virtual Directory tab, from the list for Application Protection, change the setting to High (Isolated).

4 Close Internet Services Manager.

5 Select Start > Programs > Administrative Tools > Component Services.

6 Expand the folders, and select COM+ Applications.

7 Select the Financial ManagementWeb site, for example, IIS (Default Web Site//Root/HFM).

8 Right-click the Web site and select Properties.

9 On the Security tab, from the list in theAuthentication Level for Calls, change the setting to None.

Completing Shared Services Tasks
After you configure Financial Management and Performance Management Architect, you must
grant other users security rights and complete additional tasks using the User Management
Console. See the Hyperion Security Administration Guide.

1. Create a project using the User Management Console.

2. Assign roles for Shared Services user management.

3. Assign global roles of Application Creator and Dimension Editor to use Performance
Management Architect or Classic Application Administration.
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Verifying Performance Management Architect
Installation

Note: If you are using Classic Application Administration, skip this section.

ä To verify that you can log on to Performance Management Architect:

1 Ensure that Shared Services and Workspace are running.

2 Ensure that IIS is running.

3 Start the Dimension server by doing one of the following:

l From the Services panel, start Hyperion BPM Architect Process Manager.

Note: Starting the Process Manager service automatically starts these services: Hyperion
System 9 BPM Architect Engine Manager, Hyperion System 9 BPM Architect
Event Manager, and Hyperion System 9 BPM Architect Job Manager.

l Select Start > Programs > Hyperion > BPM Architect > Start Hyperion S9 Dimension
Server.

Note: If you have difficulty starting the Dimension server, you might need to change the
timeout setting. See “Starting and Stopping Performance Management Architect
Dimension Server ” on page 68.

4 Start the Performance Management Architect application server by doing one of these tasks:

l From the Services panel, start Hyperion S9 BPMA Web ATS5 (for Tomcat); Hyperion
S9 BPMA Web WLS<version> (for WebLogic); or Hyperion S9 BPMA Web
WAS<version> (for WebSphere) .

l Select Start > Programs > Hyperion > BPM Architect > Start Server BPM Architect.

5 Open your Web browser and access Performance Management Architect through Workspace
(http://<Web Server>:<port>/workspace/) where <Web Server> is the Web server
machine hostname and <port> is the Web server listen port; for example, 19000 if using the Apache
instance bundled with BI+.

6 Enter your system user name and password and click Log On.

Note: If you have difficulty accessing Performance Management Architect, see
“Performance Management Architect Access Issues” on page 97 in the
Troubleshooting section.

7 In Workspace, select Navigate > Administer > Dimension Library.

8 Verify that you can log on to Financial Management.

9 Follow the procedures in the Hyperion Enterprise Performance Management Architect Administrator’s
Guide to import dimensions and create an application view.
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Starting and Stopping Performance Management
Architect Dimension Server
You can start and stop the Performance Management Architect Dimension server from the Start
menu or through the Services panel.

ä To start or stop the Dimension server:

Do one of these tasks:

l Select Start > Programs > Hyperion BPM Architect > Start (Stop) Hyperion S9 Dimension
Server.

l From the Services panel, start Hyperion System 9 BPM Architect Process Manager.

If you experience a problem with starting up the service for the Dimension server (Process
Manager), you can change the timeout setting. The default timeout setting for startup of the
Dimension server is 180 seconds.

ä To increase the timeout setting for startup of Dimension Server:

1. Open the BPMA_Server_Config.xml file. This file is located in %HYPERION_HOME%\BPMA
\AppServer\DimensionServer\ServerEngine\bin.

2. Search for DimensionServerStartupTimeout under Config > ProcessManager and
change the value of the timeout (in seconds).

Starting and Stopping Performance Management
Architect Application Server
You can start and stop the Performance Management Architect application server using the
Services panel, the Start menu, or a command. The location of the command depends on which
Java application server you are using.

ä To start or stop the Performance Management Architect application server:

Do one of these tasks:

l From the Services panel, start Hyperion S9 BPMA Web ATS5 (for Tomcat); Hyperion S9
BPMA Web WLS<version> (for WebLogic); or Hyperion S9 BPMA Web WAS<version>
(for WebSphere).

l Select Start > Programs > Hyperion > BPM Architect > Start (Stop) Server BPM
Architect.

l On the computer hosting your Java application server, locate the start or stop server
command.
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Table 12 Location Example for StartBPMAWebServer and StopBPMAWeb Server Commands

If you are using: Go to the following directory (for example) Execute This Command

Tomcat <drive>:\Hyperion\ BPMA\AppServer
\InstalledApps\Tomcat\5.0.
28\BPMAWebServer

Double-click startBPMAWebServer.bat or
stopBPMAWebServer.bat

WebLogic <drive>:\Hyperion\ BPMA\AppServer
\InstalledApps\WebLogic\<version>
\BPMAWebServer\bin

Double-click startBPMAWebTier.cmd or
stopBPMAWebTier.cmd

WebSphere <drive>:\hyperion\ BPMA\AppServer
\InstalledApps\Websphere\<version>
\BPMAWebServer\bin

Double-click startBPMAWebServer.bat or
stopBPMAWebServer.bat

Starting and Stopping Performance Management
Architect Data Synchronizer Server
The Data Synchronizer server must be started to use data movement capabilities of Performance
Management Architect. However, it is not needed to verify the installation, or log into
Workspace. See the Hyperion Enterprise Performance Management Architect Administrator’s
Guide for more information about using the Data Synchronization features.

You can start and stop the Data Synchronizer server from the Services panel, the Start menu, or
by using a command. The location of the command depends on which Java application server
you are using.

ä To start or stop the Data Synchronizer server:

Do one of the following:

l From the Services panel, start Hyperion S9 BPMA DataSync ATS5 (for Tomcat); Hyperion
S9 BPMA DataSync WLS<version> (for WebLogic); or Hyperion S9 BPMA DataSync
WAS<version> (for WebSphere).

l Select Start > Programs > Hyperion BPM Architect > Start (Stop) Server BPMA Data
Synchronizer.

l On the computer hosting your Java application server, locate the start or stop server
command.

Table 13 Location Example for StartBPMAWebServer and StopBPMAWeb Server Commands

If you are using: Go to the following directory (for example) Execute This Command

Tomcat <drive>:\Hyperion\ BPMA\AppServer
\InstalledApps\Tomcat\5.0.
28\BPMADataSync

Double-click startBPMADataSynchronizer.bat  or
stopBPMADataSynchronizer.bat

WebLogic <drive:\Hyperion\ BPMA\AppServer
\InstalledApps\WebLogic\<version>
\BPMADataSync

Double-click startBPMADataSynchronizer.cmd  or
stopBPMADataSynchronizer.cmd
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If you are using: Go to the following directory (for example) Execute This Command

WebSphere <drive>:\hyperion\ BPMA\AppServer
\InstalledApps\Websphere\<version>
\BPMADataSync\bin

Double-click startBPMADataSynchronizer.bat  or
stopBPMADataSynchronizer.bat

Using Sample Files
Financial Management provides sample application files that you can use to populate a test
application.

For instructions on creating applications, see the Hyperion Financial Management — System 9
Administrator's Guide. If you are using Performance Management Architect, see the Hyperion
Enterprise Performance Management Architect Administrator’s Guide.

If you installed the Sample Applications component from the Typical or Custom installation
process, the files are in the directory in which you installed Financial Management.

Note: By default, the sample applications are installed in C:\Hyperion
\FinancialManagement\Sample Apps.

If you did not install the sample files, you can obtain them by reinstalling Financial Management
and selecting the Sample Applications component. See “Installing Financial Management” on
page 32.

When you create a test application, you can load files from the Sample Apps directory. The
directory includes sample security, metadata, data, rules, and journal files; report definitions,
data grids; and Web Data Entry form scripts. Sample files are provided for the Comma, Simple
and Statutory applications. Instructions for loading the sample files are included in the
Documentation folder of each application.

Table 14 Application File Types

Sample File Contents

Member List (.lst) Dimension member lists

Metadata (.ads)

(.xml) for Classic Application Administration

Metadata

Data (.dat) Applicable scenarios and years with data

Rules (.rle) Rules used to run logic on the data in the application

Journals (.jlf) Sample journal and template file formats

Data Explorer (.hde) Explore Data grids

System Report (.rpt) System reports for Explore Data, Journals, or Intercompany Reports
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Sample File Contents

Web Data Grid files (*.xml) Web data grids

Web Data Entry Forms (.wdf) Web Data Entry Form scripts

Task List (.xml) Task List
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8
Uninstalling Financial

Management
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Uninstalling Prior Releases
If you are using a previous Financial Management — System 9 release, you do not need to
uninstall before installing this release.

If you are using a release prior to System 9, you must uninstall it before installing this release.

Before you uninstall, stop all activities and processes connected to the Financial Management
servers

The uninstall process does not remove IIS virtual directories, so after uninstalling Financial
Management, you must open IIS and manually remove the directories. The uninstall process
also may not remove all common components in the <Hyperion_Home>\Common directory
because other Hyperion products may be using them. You can manually remove components
that you are not using for other products.

If Financial Management is registered with Shared Services, deregister it before uninstalling.

After uninstalling Financial Management or shared components, restart your computer.

ä To uninstall Financial Management:

1 Deregister Financial Management from Shared Services:

a. Start the Hyperion Configuration Utility.

b. Select Financial Management and click Next.

c. Select Shared Services Deregistration and click Next.

d. Enter the Shared Services administrator password and click Next.

2 Use one of these methods to uninstall:

l Navigate to the Uninstall directory in the Financial Management directory, and click
UninstallFinancialManagement.exe.

l Select Start > Settings > Control Panel > Add/Remove Programs, select Hyperion
Financial Management, and click Remove.
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Note: If you have both Financial Management and Planning installed, Performance
Management Architect can be uninstalled only by the product that installed it
originally.

3 After the uninstall process is complete, restart your computer.

4 Remove files remaining in the installation directory.

5 Manually remove IIS virtual directories that you created that point to physical directories removed by
the uninstall.

6 Ensure that all references to Financial Management in the registry are removed.

Uninstalling Shared Components
To uninstall shared components such as Shared Services, see the Hyperion Shared Services
Installation Guide.
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Upgrading Overview
Use these steps to upgrade from a prior release. Detailed procedures are provided in the following
sections.

Upgrade Tasks Reference

Review system requirements for this release. Hyperion Installation Start Here

Install or upgrade Shared Services:

1. Back up your Shared Services relational database and Open LDAP repository.

2. Install Shared Services and configure the Shared Services Application Server and
RDBMS.

Note: Ensure that the database that you are using for Shared Services is installed and
operational before installing Shared Services.

Hyperion Shared Services Installation Guide

Configure the Shared Services external authentication provider. Hyperion Shared Services Installation Guide

Save your application data to the relational database and back up your relational
database.

RDBMS guide

Back up applications. “Backing Up Applications” on page 76

Uninstall prior Financial Management releases if needed (for pre-System 9 versions). “Uninstalling Prior Releases” on page 73

Install Financial Management (Performance Management Architect optional). “Installing Financial Management” on page
79
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Upgrade Tasks Reference

Configure Financial Management and Performance Management Architect (if installed)
using the Hyperion Configuration Utility.

Note: TheShared Services server must be running when you perform this step.

Chapter 5, “Configuring and Setting Up
Financial Management”

Complete post-configuration tasks:

1. Install and configure Workspace. Optionally install Financial Reporting.

2. Complete Shared Services tasks in the User Management Console:

l Create a project in Shared Services.

l Assign roles for Shared Services user management.

l Assign global roles of Application Creator and Dimension Editor to use
Performance Management Architect or Classic Application Administration. See
the Hyperion Security Administration Guide.

l Verify installation.

1. For Workspace installation and
configuration, see the Hyperion Reporting
and Analsysis — System 9 Installation
Guide.

2. For Shared Services tasks, see the
Hyperion Security Administration Guide.

3. To verify the installation, see “Verifying
Performance Management Architect
Installation” on page 67.

Upgrade applications using the HFM Schema Upgrade utility, and the Performance
Management Architect Application Upgrade if you use Performance Management
Architect.

“Using the Schema Upgrade Utility” on page
84 and “Upgrading Applications in
Performance Management Architect” on page
86.

Optional: Install the DIM Adapter for Financial Management or Application Link adapter
for Financial Management.

Chapter 10, “Installing Additional Hyperion
Products”

If you use Smart View, install Smart View on the client tier. “Installing Smart View ” on page 38

Backing Up Applications
You can use Financial Management applications by running an upgrade utility to update them.
If you plan to keep applications, you should make backup copies before you uninstall Financial
Management.

To make backup copies of applications, extract and save application files. For instructions on
extracting files, see the Hyperion Financial Management — System 9 Administrator’s Guide.

Extract and save these application file types to the Temp directory on the application server:

l Security files (*.sec)

l Metadata files (*.xml or *.app)

l Member Lists files (*.lst)

l Rules files (*.rle)

l Data files (*.dat) - all applicable scenarios and years with data

l Journals files (*.jlf) - all applicable scenarios and years with journal data

Back up all of these files:

l Data Explorer grid files (*.hde)

l Web data grid files (*.xml)

l Web Data Entry Form files (*.wdf or *.grd)
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l System Report files (*.rpt, *.xml, or *.html)

Backing Up Database Information
In general, all application and user data is stored in the relational database. To preserve
application integrity, perform standard backup and restoration procedures as dictated by the
RDBMS vendor. Some configuration files and registry settings reside on other servers, however
the files and settings are easily re-created in case of loss and do not hamper application integrity.

The following table shows the Financial Management components and recommended backup
procedures.

Table 15 Recommended Backup Procedures

Component Data Stored Backup Restore
Restore
Order

Supported RDBMS All application data Periodic complete database
backup using the RDBMS tools
available, and regular backups
of the transaction log

Restore from last dump
and roll in transaction
logs

First

Financial Management
Primary Server

Registry settings, .UDL file, Report
style sheets for system reports (.
xsl)

Standard incremental file
backups

Standard full restore Second

Financial Management
secondary servers

Registry settings, .UDL file, report
style sheet for system reports (.
xsl)

Standard incremental file
backups

Standard full restore Third

Financial Management
Web server

Registry settings Standard incremental file
backups

Standard full restore Fourth

Win32 Client
workstations

Win32 grid definitions if HFM
Windows client installed

Standard incremental file
backups

Standard full restore Last

When you perform a periodic complete backup using the database procedures recommended
by the vendor, to insure database integrity, you must place the RDBMS in single-user mode. Use
of single-user mode temporarily disconnects the application servers from the relational database.

Before you restore a database, stop these services:

l Application servers (Financial Management servers)

l Financial Management server processes:

m HsxServer.exe

m HsvDataSource.exe (Stop all instances of this process.)

When you end processes, all user connections are dropped. After completing the restore
procedure, restart the stopped services. Users can then re-connect.
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Verifying MDAC Version on the Application Server
Before you uninstall Financial Management, you must verify that the Microsoft Data Access
Component (MDAC) version running on the application server is MDAC 2.7.1 or higher. If you
are using Windows 2003, MDAC 2.8 is required. The MDAC file name is msado15.dll and is
located in the Program Files\Common Files\System\ado directory.

Note: If your system does not have MDAC installed, Financial Management installs it during
the installation process.

ä To verify the MDAC version:

1 Select Start > Search > For Files or Folders, type msado15.dll, and click Search Now.

2 Right-click the file and click Properties.

3 Select Version .

4 Click Product Version, and ensure that it is 2.7.1 or higher.

5 Click OK.

Uninstalling Prior Releases
If you are using a previous Financial Management — System 9 release, you do not need to
uninstall before installing this release.

If you are using a release prior to System 9, you must uninstall it before installing this release.

Before you uninstall, stop all activities and processes connected to the Financial Management
servers.

The uninstall process does not automatically remove virtual directories from IIS, so after you
uninstall Financial Management, you must open IIS and manually remove the directories. The
uninstall process also may not remove all common components in the <Hyperion_Home>
\Common directory because other Hyperion products may be using them. You can manually
remove components that you are not using for other products.

If Financial Management is registered with Shared Services, deregister it before uninstalling.

After you uninstall Financial Management or shared components, restart your computer.

ä To uninstall Financial Management:

1 Deregister Financial Management from Shared Services:

a. Start the Hyperion Configuration Utility.

b. Select Financial Management and click Next.

c. Select Shared Services Deregistration and click Next.

d. Enter the password and click Next.

2 Use one of these uninstall methods:
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l Navigate to the Uninstall directory in the Financial Management directory, and click
UninstallFinancialManagement.exe.

l Select Start > Settings > Control Panel > Add/Remove Programs, select Hyperion
Financial Management, and click Remove.

Note: If you have both Financial Management and Planning installed, Performance
Management Architect can be uninstalled only by the product that installed it
originally.

3 After the uninstall process is complete, restart your computer.

4 Remove files remaining in the installation directory.

5 Manually remove virtual directories that you created that point to physical directories removed by the
uninstall.

6 Make sure that all references to Hyperion Financial Management in the registry are removed.

Installing Financial Management
If you use a separate application server and client workstation, you must install Financial
Management on each computer. If you install Financial Management on one computer, you can
install the Server and Client components simultaneously with the Custom installation option.

Installing Financial Management Server Components
You can install Financial Management Application and Web Server components simultaneously.

ä To install Financial Management on the application server:

1 Ensure that Shared Services is installed and configured in the environment. See the Hyperion Shared
Services Installation Guide.

2 Navigate to the directory for the installation program, select File > Run or Start > Run and enter Drive:
\folder\Setup.exe, where Drive and folder are the installation program location.

3 Select the installation process language, and click OK.

4 Review the Welcome box and click Next.

5 From the list of countries, select the location from which you are installing, and click Next.

6 Read the license agreement, select I AGREE and click Next.

7 Click Next to accept the default installation path for HYPERION_HOME, or click Browse and navigate to
another directory, and click Next.

The default directory is C:\Hyperion.

Ensure that the directory name does not contain spaces. You can enter only English
alphanumeric characters and these special characters: dash (-), underscore (_), backslash
(\), forward slash (/), dot (.), colon (:). The colon character (:) is supported only for Windows
platforms to specify the drive (for example, c:\).

Installing Financial Management 79



Note: If the installation program detects a HYPERION_HOME directory, Directory Name
and Browse are not selectable.

Note: If a Java Virtual Machine (JVM) version is detected in the Hyperion Home location,
a warning message is displayed. Shut down products using JVM and click OK to
continue.

8 Click Next to accept the default installation directory or click Browse to select another directory, and
click Next.

The default directory is C:\Hyperion\FinancialManagement.

Ensure that the directory name does not contain spaces. You can enter only English
alphanumeric characters and these special characters: dash (-), underscore (_), backslash
(\), forward slash (/), dot (.), colon (:). The colon character (:) is supported only for Windows
platforms to specify the drive (for example, c:\).

9 From Setup Type, select Custom, and click Next.

10 Select components to install, and clear components that you do not want to install.

l To install all Client, Application Server, and Web components, select Hyperion
Financial Management — System 9  and Oracle Hyperion EPM Architect.

To install specific components, select:

l Client

Install all components for a full client installation, including the Win32 Client, Analytic
Data Model (ADM) Client, and Sample Applications.

l Application Server

Install all files required for the application server.

l Web

Install all components to access Financial Management through the Internet.

m Web Server

Install Web Server components on this computer. You can, if you want, install the
Web Server components later on another computer.

m Smart View Provider

Install the Smart View provider on the Web server. For information on installing
Smart View on the client tier, see “Installing Smart View ” on page 38. For
information on using Smart View, see the Hyperion Smart View for Office User
Guide or Online Help installed with Oracle's Hyperion® Smart View for Office.

Note: SmartView requires the use of Microsoft .NET Framework 2.0. When you
select this component, if you do not have .NET Framework 2.0 installed, the
system will install it as part of the installation process. If you do not want to
install SmartView, you can choose to continue the installation without
installing it.
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l Consultant Utilities

Install additional utilities for Financial Management.

l Oracle Hyperion EPM Architect

Note: To use Performance Management Architect, install both of these components.
The system detects if these components have previously been installed on this
computer, for example, during a Oracle's Hyperion® Planning – System 9
installation, in which case you do not need to reinstall them.

m Application Server

Installs the Dimension Server, Data Synchronization Server, and files required for
Interface Datasources.

m Web Server

Installs the Performance Management Architect Web tier.

Note: To use Performance Management Architect, you must have installed a Java
application server. For a list of supported Java application servers, see the Hyperion
Installation Start Here.

Performance Management Architect requires the use of Microsoft .NET Framework 2.0.
During the Performance Management Architect Application Server installation, if .NET
Framework 2.0 is not detected, you are prompted to install it. Select Install Microsoft .Net
Framework 2.0 and continue to have .NET 2.0 automatically installed

11 Review the component summary information, and click Next to continue the installation, or Back to
change settings.

If you do not have Microsoft Data Access Component (MDAC) installed on the application
server, the system installs it automatically at this point. The MDAC installation process can
be time-consuming, and requires that you reboot your computer.

12 If system files were detected that needed to be updated during installation, a status message is
displayed. Click Next to continue.

For a list of updated files, check the install log, installLog.txt, at the root of the directory
in which you installed Financial Management. If Windows File Protection is enabled,
download the Windows update to obtain the latest version of the files.

13 When you receive the message that the installation is complete, click Next.

14 If prompted, select whether to restart your computer at this time, and click Finish.

15 Run the configuration utility. See Chapter 5, “Configuring and Setting Up Financial Management”.
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Installing Financial Management on the Client
The installation program installs files needed to run Financial Management and common
components that are used by multiple Hyperion products.

The Typical installation does not install server components. If you need to install server
components, see Chapter 3, “Installing Financial Management and Performance Management
Architect Server Components”.

Note: The installation program contains these three files: media.inf, setup.exe, and
suite.jar, which must be in the same directory for the installation program to run.

ä To install Financial Management on the client tier:

1 Ensure that Shared Services is installed and configured in the environment. See the Hyperion Shared
Services Installation Guide.

2 Navigate to the directory for the installation program, select File > Run or Start > Run and enter Drive:
\folder\Setup.exe, where Drive and folder are the installation program location.

3 Select the installation process language, and click OK.

4 Review the Welcome dialog box and click Next.

5 From the list of countries, select the location from which you are installing, and click Next.

6 Read the license agreement, select I AGREE and click Next.

7 Click Next to accept the default installation path for HYPERION_HOME, or click Browse and navigate to
another directory, and click Next.

Note: Ensure that the Hyperion Home directory name does not contain spaces. If the
installation program detects a HYPERION_HOME directory, Directory Name and
Browse are not selectable.

8 Click Next to accept the default installation directory or click Browse to select another directory, and
click Next.

9 From Setup Type, select Typical, and click Next.

10 From Component Selection, select the components to install, and clear components that you do not
want to install.

11 For a Typical installation, you can install these components:

l Win32 Client

Install all components for the Windows 32 client desktop.

l ADM Client

Install Analytic Data Model (ADM) if you use Financial Management with Financial
Reporting, Oracle's Hyperion® Web Analysis – System 9, or Application Builder. ADM
is the connectivity component between Hyperion data sources. You can also install
ADM later on another machine.
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l Sample Applications

Select this option to install sample applications.

12 Click Next to accept the default installation directory, or click Browse to select another directory, and
click Next.

13 Review the component settings, and click Next to continue the installation or Back to change settings.

14 If prompted, select whether to restart your computer at this time, and click Finish.

15 Run the configuration utility.

See Chapter 5, “Configuring and Setting Up Financial Management”.

Upgrading Applications from Prior Releases
If you want to use applications from prior releases, you must upgrade the applications using the
HFM Schema Upgrade utility. You use this utility to upgrade previous System 9 Financial
Management applications, as well as applications prior to System 9.

Note: Migrations of pre-9.2 releases to 9.3.1 must apply the updated Schema Upgrade utility
provided in Financial Management Release 9.3.1.4.0.2.

If you are using Performance Management Architect, you then upgrade the converted
applications in Performance Management Architect. See “Upgrading Applications in
Performance Management Architect” on page 86.

The Schema Upgrade utility is installed in the Server directory when you install Financial
Management, and it runs on the application server. The utility requires that Financial
Management is configured Shared Services. It converts any database table that does not meet
the current release specifications. This accounts for changes in metadata, data types, and other
changes that optimize or enhance Financial Management. It also migrates security users and
their roles from the prior release to Shared Services. This is handled by the migration utility that
is executed by the Schema Upgrade utility, which analyzes the current security settings and
extracts a security load file used to load Financial Management users and their roles to Shared
Services.

When you run the utility, based on your settings, the Schema Upgrade utility sequentially
upgrades one application at a time. If it is determined that security needs to be migrated, the
migration utility is launched on the first instance and used for subsequent applications. Before
you upgrade, you need to know the Shared Services URL, the Financial Management project to
which you want to migrate, the Web URL used for security administration, and an administrator
name and password. It converts the tables and migrates the users from your Financial
Management application to Shared Services for all applications.

The Schema Upgrade utility assigns these roles to all Financial Management Application
Administrators when an application is upgraded:

l Dimension Editor

l Application Creator

Upgrading Applications from Prior Releases 83



l Financial Management Application Creator

These roles are required to access both Performance Management Architect and Classic
Application Administration. See “Performance Management Architect” on page 10.

Note: The Load System role that enables users to load metadata is not automatically assigned.
For information on assigning roles, see the Hyperion Security Administration Guide.

Using the Schema Upgrade Utility
Before you use the Schema Upgrade utility, you must complete these tasks:

l Shared Services must be installed, configured and running, and you must create a project.
Financial Management must be registered in Shared Services, which configures external
authentication.

l You must configure Financial Management, including setting DCOM, creating a UDL file,
and registering the application server, and you must have an available Financial Management
Web server.

Note: The upgrade utility assumes that the decimal character is a period (.). If you use
another character, such as a comma (,), you must change the decimal character setting
in the RDBMS to a period, and after running the utility, change it back. Web data
grids that you created in prior releases with Java applets are supported after you
upgrade, however, data grids that you created using HTML in prior releases are not
supported or viewable after you run the upgrade utility.

When you use the Schema Upgrade utility, all applications for the current database are upgraded
simultaneously, and the upgrading options apply to all applications. You cannot upgrade only
one application.

You can choose how to handle errors that occur during the upgrading process. For example,
you can set the process to halt when an error occurs so that you can view it immediately, or to
ignore errors and continue upgrading, and view the errors later.

You can create an error log to check results after the upgrade. If an error log exists, you can
choose to truncate the log on startup to clear the contents, or back up the log.

If you are upgrading an application from a prior release, during the upgrading process, the system
stores security load files used in the user migration in your system Temp directory, so you can
also review that directory for results. The security filenames are
HFMSecurityFile_<application name>_<month-date-year>.sec. It is recommended after
completing the upgrading process that you manually extract the security files from each
application to save for backup and future reference.

Users are validated during the upgrading process, so users who no longer exist in external security
do not load. After upgrading, you can view results in the log file in the system Temp directory.
The log file is named HFMSecurityFile_<application name>_<month-date-year>.log.
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Note: The utility recognizes the security files based on the application name and month, date,
and year. If for any reason the upgrading process fails and you restart it on a different day,
you must manually adjust and reload the files.

ä To upgrade applications:

1 Navigate to the Financial Management installation directory, and locate the Server directory, for
example:

C:\Hyperion\FinancialManagement\Server.

2 From the Server directory, double-click the Upgrade utility file, HFM Schema Upgrade.exe.

3 From the SchemaUpgrade window, click Connect to connect to the Financial Management database.

All applications with the defined database are displayed in the Available Applications section.

4 For Error Handling, select an option:

l Halt on Any Error

l Ignore Errors and Continue

5 For Log File Name, enter an upgrade error log name.

Note: You can save the log file in any directory that you choose.

6 For Logging Options, select an option:

l To clear the log contents, select Truncate Existing Log on Startup.

l To save the log, select Backup Existing Log.

7 Click Upgrade.

The system prompts you with a reminder to back up your database and the option to
postpone the upgrade so that you can do the backup.

8 From the system warning that all applications will be converted, click Yes to continue.

When the application tables are upgraded, the security tables are extracted as load files and
reloaded. This process may take several minutes based on the size of the security files and
the number of users, groups, and roles. When the utility reaches the security tables for the
first application, if it detects that users need to be migrated, the User Migration dialog box
is displayed.

9 From User Migration, enter the information to provision the application and click OK:

a. For User Management URL, enter the URL that you use for Shared Services, for example,
http://<Shared Services server>:58080/interop.

b. For User Management Project, enter the name of the project that you created.

c. For Financial Management Web Server URL for Security Administration, enter the
Financial Management Web server name.

d. For Administrator Logon, enter the domain, username, and password. The user must
be a Shared Services administrator.
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Note: After you specify this information the first time, the system uses it to upgrade
subsequent applications.

10 When you receive the Processing Complete message, click OK.

11 Optional: To view the error log after upgrading, click View Log.

12 Click Close.

Upgrading Applications in Performance Management
Architect
If you are using Performance Management Architect, after you convert applications using the
Schema Upgrade utility, you run the Application Upgrade for Performance Management
Architect.

Note: If you are not using Performance Management Architect, you work with applications
using Classic Application Administration. If you upgrade an application created in Classic
Application Administration to Performance Management Architect, you cannot return
to working with that application in Classic Application Administration.

ä To run the application upgrade:

1 From the Workspace, select Navigate > Administer > Application Upgrade.

2 Review the Welcome screen, and click Next.

3 The Upgrade Summary page displays the applications to which the user has access to upgrade (this
information is provided from the Shared Services server. If an application cannot be upgraded, an
explanation is provided.)

4 On the Select Applications page, add applications that you want to upgrade to the Applications to
Upgrade list and click Next.

5 Review the summary of applications to upgrade, and click Next to execute the upgrade.

6 Click Finish to view the upgrade process in the Job Console.

7 Open the Application Library to confirm that the applications are in Performance Management Architect.

8 Navigate to Dimension Library and review the dimensions that were added to Performance Management
Architect.

9 Open the application.

About Configuring Product Upgrades
Use Hyperion Configuration Utility to configure products when they are upgraded from a
previous Hyperion release. Hyperion Configuration Utility determines (and the product
selection page indicates) whether the products installed on the computer are new or upgraded.
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All configuration tasks are available for upgraded products; however, for upgraded products
configured for relational databases, the database configuration page is read-only except for the
password. You can configure only one upgraded product at a time because each product may
be configured for a different database. Similarly, you cannot configure new products and
upgraded products simultaneously.

If you are upgrading Shared Services and other Hyperion products, upgrade Shared Services
first. You must reregister products with Shared Services.

Note: Hyperion Configuration Utility is backward compatible with previous Hyperion releases
and can be used to configure products for previous releases.
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After installing Financial Management and verifying that you can create and connect to
applications, you can install Financial Reporting, and the DIM Adapter for Financial
Management or Application Link adapter.

Installing Reporting and Analysis
Install Oracle's Hyperion® Financial Reporting – System 9 if you did not install it when you
installed and configured Workspace. See the Hyperion Reporting and Analysis — System 9
Installation Guide.

Installing Data Integration Management Adapters
After you install and configure Oracle's Hyperion® Data Integration Management, you can
install and configure adapters that enable you to retrieve and write data for other Hyperion
products:

To use the DIM Adapter for Financial Management, you first must install and configure
Financial Management.

Note: The DIM Adapter for Financial Management requires the Financial Management client
to be installed on the same computer. If the Financial Management application servers
are installed on a separate machine, DCOM must be enabled. The Enable DCOM option
can be found on the Server/Cluster Registration tab of the Financial Management
configuration utility. See “Enabling DCOM” on page 52.

Each adapter includes online help that provides instructions for using the adapter.

You must have administrative privileges on any computer where you install the adapter. The
adapter installer provides two options:
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l Typical—Install all adapter components

l Custom—Install the components that you select:

m Client Plug-in—Enables you to configure source and target definitions for the Hyperion
application in Designer.

Client Plug-in should be installed on the same computer as PowerCenter Client.

m Repository Server Plug-in— Enables you to register the adapter in a repository.

m Server Plug-in— Enables you to execute workflows.

The installer sets environment and system variables:

l HFMCONNECTORPATH is set to Installation Folder\HFMConnector.

l PATH is updated with the Installation Folder\HFMConnector\lib folder.

Note: When you install the client and server components of any Data Integration Management
adapter on one computer, you must install both components in the same location.

ä To install a Data Integration Management adapter:

1 From the installation DVD or the directory where you downloaded the adapter installer, click
setupwin32Platform.exe.

2 On the adapter installer Welcome screen, click Next.

3 Select a country for the installation, and click Next.

4 On the license agreement screen, select I AGREE, and click Next.

Note: You must select I AGREE to continue with the installation.

5 Click Next to accept the Hyperion Home directory.

6 Select a setup type, and click Next.

7 If you selected the Custom setup option in the preceding step, select components to install, and click
Next.

8 Verify the installation summary, and click Next.

Tip: You can click Back to change installation choices.

Installing Adapters in Silent Mode
When you install a Data Integration Management adapter in silent mode, the installer retrieves
the installation properties that are saved in a response file instead of displaying screens where
you enter these properties. Silent mode is often used for performing installations remotely. You
can create the response file from a template before you perform an installation, or you can create
the file during an installation for use in subsequent silent-mode installations.
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ä To install an adapter in silent mode, run this command:

InstallerFile -silent -options ResponseFile

where InstallerFile is a platform-specific installation program (such as
setupwin32.exe for an installation on a Windows platform or setupSolaris.bin for a
Solaris platform) and ResponseFile is the property file containing the parameters required
for the installation.

Installing Adapters in Console Mode
When you run the installer for an adapter in console mode, you select input from a series of
menus that are displayed.

ä To install an adapter in console mode, run this command:

InstallerFile -console

where InstallerFile is a platform-specific installation program (such as
setupSolaris.bin for a Solaris platform).

Configuring Adapters
After installing Data Integration Management adapters, you must configure them on the
computers hosting the PowerCenter Server, Client, and Repository Server components of Data
Integration Management.

You can perform these tasks on Windows computers where PowerCenter Client is installed.

Note: Adapter configuration is not done with the Hyperion Configuration Utility.

Registering Adapters with a Repository
If you install the Repository Server Plug-in or Server Plug-in component of Data Integration
Management adapter, you must register the adapter with the repository. This registration is not
required if you install only the Client Plug-in.

ä To register a Data Integration Management adapter with a repository:

1 Ensure that Data Integration Management Repository Server is running:

a. From the Windows Control Panel, select Administrative Tools.

b. Select Services.

c. In the Services window, check the status of Hyperion S9 Data Integration Management
Repository Server.

d. Unless the status is “Started,” click Start (in the upper left of the window).

Note: Keep the Services window open for the next step.
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2 Stop Data Integration Management Server, if it is running:

a. In the Services window, check the status of Hyperion S9 Data Integration Management
Server.

b. If the status is “Started,” click Stop (in the upper left of the window).

3 Connect to the Repository Server host computer:

a. Select Start > Programs > Hyperion > Data Integration Management > Informatica
PowerCenter 7.1.4 - Client > Repository Server Administration Console.

b. In Repository Server Administration Console, right-click the name of the Repository
Server host computer, and select Connect.

c. Enter your password for the host computer, and click OK.

4 Under the Repository Server host computer name, click Available packages.

5 Right-click DIM Adapter for Financial Management.xml, and select Register.

6 Enter the repository administrator user name and password, and click OK.

Note: By default, both the user name and the password are Administrator if you are using
Informatica native authentication. If you are using Shared Services authentication,
the default user name and password are admin and password, respectively.

7 When a message that the registration succeeded is displayed, click OK.

8 Repeat steps 6 through step 8 for each adapter to be registered.

Note: For more information, see “Registering and Unregistering Repository Plug-ins” in
the Informatica PowerCenter Repository Guide.

Configuring Hyperion Application Connections
After you configure an adapter, you must configure an application connection in Workflow
Manager before you can extract data from sources or write data into targets. When configuring
application connections, you specify attributes that Data Integration Management Server uses
to connect to a database during a Data Integration Management session. The application
connections that you define in Workflow Manager are saved in Data Integration Management
Repository.

ä To configure application connections:

1 Ensure that Data Integration Management Repository Server is running:

a. From the Control Panel, select Administrative Tools.

b. Select Servers.

c. In the Services window, check the status of Hyperion S9 Data Integration Management
Repository Server.

d. Unless the status is “Started,” click Start (in the upper left of the window).

2 Start the repository:
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a. Select Start > Programs > Hyperion > Data Integration Management > Informatica
PowerCenter 7.1.4 - Client > Repository Server Administration Console.

b. In Repository Server Administration Console, right-click the name of the Repository
Server host computer and select Connect.

c. Enter your password for the host computer, and click OK.

d. In the Repositories directory, double-click the repository name.

e. Click Start (on the left).

3 Select Start > Programs > Hyperion Data Integration Management > Informatica PowerCenter 7.1.4 -
Client > Workflow Manager.

4 In Workflow Manager, connect to the repository:

a. In the Repository Navigator panel, double-click the repository name.

b. Enter the repository administrator's user name and password, and click Connect.

5 Select Connections > Application.

6 Click New.

7 Select the connection for the adapter that you are configuring, and click OK.

8 Enter the requested information, and click OK:

The information requested depends on the Hyperion application. It can include these items:

l Name—A name for the connection

l User Name—Your user name for the Hyperion application

l Password—Your password for the repository, for example, your password for Financial
Management

l URL—The Hyperion product application URL that you want to use

l Host or ServerHost—The name of the Hyperion product server host computer, for
example, the name of the Financial Management server host computer

l Port—The port number used by the application

See Hyperion System 9 Installation Start Here for information about ports.

l Cluster —The name of the registered cluster where the application runs

Application Connection Browser lists the new application connection.

Tip: You can edit or delete an application connection by selecting it in the list in Application
Connection Browser and clicking Edit or Delete.

Configuring JVM Options

ä To configure JVM options:

1 Start Informatica Server Setup by selecting Start > Programs > Hyperion Data Integration Management
> Informatica PowerCenter 7.1.4 – Server > Informatica Server Setup.
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2 With Configure Informatica Service selected, click Continue.

3 Select the JVM Options tab.

4 In VM Location, enter the fully qualified path to the jvm.dll file in your JAVA_HOME directory, and
click OK.

Uninstalling Adapters

ä To uninstall a Data Integration Management adapter:

1 Start the adapter installer: Uninstall.exe.

2 On the uninstaller Welcome screen, click Next.

3 Ensure that all PowerCenter Client applications are selected, and click Next.

4 On the uninstallation summary screen, click Next.

5 When the summary screen says that the uninstallation has succeeded, click Finish.

6 Optional: Remove the adapter from a repository:

a. Open Data Integration Management Repository Server Administration Console by
selecting Start > Programs > Hyperion Data Integration Management > Informatica
PowerCenter 7.1.4–Client > Repository Server Administration Console.

b. Select the repository in which the adapter is registered.

c. Stop the repository if it is running.

d. Click Repository > Registered packages and select the Oracle's Hyperion® Data
Integration Management Adapter for Financial Management—HFM.xml adapter file.

e. Click Unregister.

f. In Remove Repository plug-in, enter the repository user name and password, and click
OK.

The Output window displays the status of the plug-in uninstallation.

Note: Repeat step 6 to remove the adapter from additional repositories.

Uninstalling Adapters in Silent Mode
When you uninstall a Oracle's Hyperion® Data Integration Management adapter in silent mode,
the installer retrieves the uninstallation options that are saved in a response file instead of
displaying screens where you enter these properties. Silent mode is often used for performing
uninstallations remotely. You can create the response file from a template before you perform
an uninstallation, or you can create the file during an uninstallation for use in subsequent silent-
mode uninstallations.

ä To uninstall an adapter in silent mode, run this command:

UninstallerFile -silent -options ResponseFile
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The uninstaller file is in the Uninstall subdirectory of the adapter installation directory.

Uninstalling Adapters in Console Mode
When you run the uninstaller for an adapter in console mode, you select input from a series of
menus that are displayed.

ä To uninstall an adapter in console mode, run this command:

UninstallerFile -console

The uninstaller file is in the Uninstall subdirectory of the adapter installation directory.

Installing the Application Link Adapter
Application Link is an application integration product with a graphical user interface that makes
it easy to create seamless integration from your source system into Financial Management. You
can use Application Link to load data values, accounts, entities, and custom dimensions from a
flat file or ODBC-compliant database into Financial Management. Application Link includes
the Hyperion Translation Manager wizard, to map your source data to Financial Management
equivalents.

For Oracle's Hyperion® Application Link 9.0, use the 9.2.1 adapter.

Updating Financial Management Adapter 9.2.1
To use the adapter, see the Hyperion Financial Management — System 9 Adapter User’s Guide.

If you uninstall a previous version of the adapter before installing this release, ensure that the
HsvHALClasses.jar file is deleted.

ä To update the adapter:

1 Download the hfmad921_Windows.zip file and unzip the files in to a temporary folder.

2 Double-click the setup executable file, setup_vbis_win32.exe.

Note: This utility may take several minutes to load.

3 From Welcome to Vignette V7 Business Integration Studio, click Next.

4 From Adapter Library Selection, select the adapter and do one of these steps:

l If the status is displayed as Compatible or Upgrade, click Next.

l If the status is displayed as Incompatible, cancel the installation and review the
installation log in your <vbis install dir>\vbis\logs directory.

The log file name is vbis_install_<date – timestamp>.log.

5 From Install Preview, verify that the Financial Management adapter library is displayed in the list, and
click Next.
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6 When Installation Summary is displayed, click Finish.
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This appendix describes troubleshooting procedures for Financial Management and
Performance Management Architect installation and configuration.

Note: If you experience problems installing or running Shared Services, see the Hyperion Shared
Services Installation Guide.

Financial Management and Performance Management
Architect Configuration Issues

Error Message or Problem Solution

Errors occur during
configuration

1. Review the Hyperion Configuration Utility log file that contains configuration errors and warning messages
in a central location: <HYPERION_HOME>\common\config\logs\configtool.log.

2. As a troubleshooting measure, perform configuration tasks individually for one module at a time.

Performance Management Architect Access Issues

Error Message or
Problem

Solution

Performance
Management
Architect
installation failed

This could be the result of a Microsoft .NET Framework 2.0 error during its automatic installation in Performance
Management Architect. Install Microsoft .NET Framework 2.0 manually, and then rerun the installation.
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Trouble logging on
to Performance
Management
Architect

Verify that the ASP.NET version is 2.0.50727.

Security rights issue
when logging on to
Performance
Management
Architect

The Application Creator and Dimension Editor security roles must be assigned to use Performance Management
Architect. See the Shared Services\Global Roles section of the Hyperion Security Administration Guide.

Logon to Workspace
fails

See the Hyperion Reporting and Analysis — System 9 Installation Guide.

You receive an
Authentication error
when you are logged
in to the Workspace
and try to access a
Financial
Management
application or
Performance
Management
Architect feature.

l You might need to be provisioned for the application. See the Hyperion Security Administration Guide.

l Your token or session might have timed out. Log off, then log on to start a new session.

l A problem may exist with the Financial Management Web Server or Application Server. Check that they are
running with no problems.

Dimension Library
does not display in
Performance
Management
Architect.

Verify that you have the proper Performance Management Architect roles. You must have the Dimension Editor and
Application Creator security roles to access the Dimension Library. See the Shared Services\Global Roles section
of theHyperion Security Administration Guide.

After you are assigned the Dimension Editor role, log off and log back on to Performance Management Architect.

Performance
Management
Architect tasks do
not display.

Check the following:

l Verify that the Shared Services server is started, and if not, start it. See the Hyperion Shared Services Installation
Guide.

l Verify that Workspace services are started. See the Hyperion Reporting and Analysis — System 9 Installation
Guide.

l Verify that you can access Workspace. Use this URL: http://<Web Server>:<port>/workspace/
where <Web Server> is the Web server machine hostname and <port> is the Web server listen port; for
example, 19000 if using the Apache instance configured with BI+.

l Verify that you have configured the Workspace proxy server plug-in for your Application Server. Use this URL:
http(s)://<workspace_server>:<workspace_port>/awb/conf/AwbConfig.xml,  where
<Web Server> is the Web server machine hostname and <port> is the Web server listen port; for example,
19000 if using the Apache instance configured with BI+.

If you can access this, the proxy server is configured. If this does not work, configure it. See the Hyperion
Reporting and Analysis — System 9 Installation Guide.

You receive an error
when trying to run
Data
Synchronizations in
Performance
Management
Architect.

Make sure that the Hyperion FM-DME Listener service is started.

This service is installed automatically during the Financial Management installation and is required to run
Performance Management Architect data synchronizations. If the service is stopped, the DME Web Service is not
able to communicate with all Financial Management instances on the server.
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Performance Management Architect Dimension Library
or Application Library Access
If you cannot access a Performance Management Architect task, verify that you can access each
component separately to locate the source of the communication error.

Error Message or Problem Solution

Server was unable to
process request. No
connection could be made
because the target
machine actively refused it
(org.apache.axis.AxisFault)

Dimension Server is not running. Start the Dimension Server and retry logging in.

Communication errors or
internal server errors occur.

Possible solutions:

1. Check this URL:

http(s)://<workspace_server>:<workspace_port>/awb/conf/
AwbConfig.xml.

2. If this step fails, check this URL:

http(s)://<bpma_server>:<bmpa_port>/awb/conf/AwbConfig.xml

3. If this step works, then Performance Management Architect is not correctly enabled in Workspace.
Reconfigure Workspace.

4. If this step does not work (error is 404), then the Performance Management Architect Web Server is not
started.

Errors on the Performance
Management Architect
Dimension Server.

Possible solutions:

l Use this URL:

http(s)://<local_machine_name>/hyperion-bpma-server/Sessions.
asmx.

If you see a Sessions page displayed, then IIS is correctly configured. If there is any error in IIS, check
the Event Log to determine the problems. Check the System and Application Log to see if anything was
logged by ASP.NET, IIS, or DCOM, and fix the errors. A possible cause is incorrect privileges for the user
for the TEMP directory.

l Check the Event Logs from sources starting with HyS9BPMA. Possible causes are communication errors
with Oracle's Hyperion® Shared Services, or the database.

l The ASPNET user may not have access to certain folders. If the Event Log displays any security related
errors, assign rights to the ASPNET user.

1. From the command prompt, go to this directory: C:\Windows\Microsoft.NET\Framework
\v2.0.50727.

2. Type run aspnet_regiis.exe-ga.

Errors accessing the
Performance Management
Architect Dimension Server
Web services.

l Verify the logs to check subcode and Win32 code. If subcode is 2, and Win32 code is 1260, the problem
is related to Web Service Extensions. In IIS, Web Service Extensions, make sure that the ASP.NET 2.0.
50727 Web Service Extension status is Allowed.

l If SiteMinder is installed, remove the wildcard mapping:

1. From the hyperion-bpma-server virtual directory, click Properties, and click Configuration.

2. Remove any values in the wildcard mapping section.
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Error opening the
Performance Management
Architect Dimension
Library.

Verify that DCOMCNFG permissions are set properly in Windows 2003. To set DCOM Config permissions:

1. Select Start > Run, and enter DCOMCNFG .

2. Expand Component Services > Computers > My Computer > DCOM Config.

3. Scroll to IIS Admin Service, right-click Properties and select the Security tab.

4. From Launch and Activation, select Customize and click Edit.

5. Click Add and add Network Service.

6. Select Allow for all permissions.

7. Click OK to close the dialog boxes.

8. Restart IIS and all Web servers.

IIS is not started on the
Performance Management
Architect Dimension Server.

From Control Panel > Administrative Tools > Services, start World Wide Web Publishing Service if not already
started.

Performance Management
Architect services are not
started.

Start the Performance Management Architect Process Manager service if not already started.

Check that these services start:

l Engine Manager

l Event Manager

l Job Manager

Financial Management Access

Error Message or Problem Solution

You cannot access
Financial Management
through the Workspace.

1. Test access to the Workspace. Use this URL: http://<Web Server>:<port>/workspace/ where
<Web Server> is the Web server machine hostname and <port> is the Web server listen port; for
example, 19000 if using the Apache instance configured with BI+.

2. If Step 1 does not work, verify that you have configured the Workspace proxy server plug-in. If it is
configured, test that you can access Financial Management directly.

If you cannot access
Financial Management
through the Oracle's
Hyperion® Workspace,
verify that you can access
Financial Management
directly.

Use this URL:

http://<server_URL>/<aliasdir>/

where <aliasdir> is the name of the alias virtual directory that you created for Financial Management on the
Web.

If this does not work, there is a problem with the installation or configuration. Check the Financial Management
installation log in the root of the directory in which you installed Financial Management.
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You cannot log on to
Financial Management.

This might be due to a security access issue. Check the following:

l Financial Management is installed and configured.

l IIS is started, and a virtual directory for Financial Management was created.

l In IIS, verify the settings for authentication. You can use Anonymous Authentication or Web
Authentication, depending on your security policies.

To check the authentication method:

1. Start IIS and expand Default Web Site.

2. Right-click the folder for Web authentication, for example, the Financial Management folder for the
Web, and select Properties.

3. Select Directory Security.

4. Verify that either Anonymous Access or Web Authentication has been properly configured.

You cannot log on to the
Financial Management
Client through a proxy
server.

Make sure that proxy authentication is properly configured. See Microsoft Internet Explorer and Netscape
help for procedures.

Connection Troubleshooting
The following table and procedures describe troubleshooting connection issues.

Error Message or
Problem

Solution

Connection fails for
Financial Management.

If the DCOM launching user is set to a local machine account, domain users cannot log on to some modules.
For example, if a user logs on to a workstation with a user ID on Domain A, and logs on to Financial Management
with a user ID on Domain B (or any domain that Domain B can access), when the user attempts to connect
to a Financial Management server on Domain B, the connection might fail. To resolve the problem, do one of
these procedures:

l Set up a one-way trust relationship from Domain B (Financial Management Server) to Domain A (Financial
Management Client). This method is recommended as the best workaround.

l Set the DCOM Default Authentication Level to None on the client. However, note that by turning off the
DCOM authentication on the client, DCOM authentication is turned off for all the DCOM applications on
the client.

When the computer is
restarted, Financial
Management installation
fails.

Check the Remote Procedure Call service in Windows.

1. Select Start > Programs > Administrative Tools > Services or for Windows 2003, select Start > Settings
> Control Panel > Administrative Tools > Services.

2. Check the Remote Procedure Call (RPC) Locator, which is set to Manual by default. Select the service,
click Start, and restart the computer.

You cannot connect to the
database.

Configure the UDL file. See:

l “Configuring the Data Link for Microsoft SQL Server” on page 22.

l “Configuring the Data Link for Oracle” on page 21.

l “Configuring the Data Link for IBM DB2 ” on page 23.
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You cannot connect to
SQL Server.

l Windows authentication may have been used instead of Microsoft SQL Server authentication. Hyperion
recommends using SQL Server authentication.

l The system may be using the Microsoft SQL Server default setting to connect to the database using named
pipes instead of TCP/IP.

See “Verifying Microsoft SQL Server Authentication Settings” on page 103.

SQL Server: Test
connection failed
because of an error in
initializing provider. Client
unable to establish
connection.

A problem may exist with the Microsoft SQL Server connection and the UDL file. See “Creating Data Link (UDL)
Files ” on page 21.

Establishing the SQL Server Connection Using TCP/IP
If you use Microsoft SQL Server 2005, it disables TCP/IP connections to the database by default.
You need to enable these connections before running the Hyperion Configuration Utility.

ä To establish the SQL Server connection using TCP/IP:

1 Select Start > Settings > Control Panel.

2 Select Administrative Tools, and double-click Data Sources (ODBC).

3 Click Add.

4 In the list of drivers, highlight SQL Server, and click Finish.

5 Enter a data source name, description, the data server name for the SQL Server to which to connect,
and click Next.

6 Select this authentication option: With SQL Server authentication using a login ID and password entered
by the user.

7 Click Client Configuration, select TCP/IP (if not selected), and click OK.

8 For Connect to SQL Server , enter the login ID and password, and click Next.

9 Change the default database to the Oracle's Hyperion® Financial Management – System 9 database.

10 Click Next, and click Finish.

11 Click Test Data Source.

12 When you receive the success message, click OK, and click OK to close the dialog box.

13 Click OK to close the ODBC Administrator dialog box.

14 Create and configure the data link (.udl).

See “Creating Data Link (UDL) Files ” on page 21.
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Verifying Data Link Connection Settings

ä To verify data link connection settings:

1 In Data Link Properties, select the Connection tab.

2 Ensure that Use a specific user name and password is selected.

Verifying Microsoft SQL Server Authentication Settings

ä To verify the Microsoft SQL Server authentication setting:

1 Select Start > Programs > Microsoft SQL Server > Enterprise Manager.

2 Expand the list of Microsoft SQL Servers.

3 Right-click the database server name, and select Properties.

4 Select the Security tab.

5 Ensure that this Authentication option is selected: SQL Server and Windows.

6 Click OK.
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About Manual Configuration
The procedures in this appendix should be followed to manually deploy the Performance
Management Architect Web Tier server and Data Synchronization server to WebLogic or
WebSphere on a Windows machine. First install Performance Management Architect, and then
use the Oracle's Hyperion® Configuration Utility™ to select the manual option for deployment
to an application server.

Note: 19091 is the default port for Performance Management Architect Web Tier and 19101 is
the default for Data Synchronizer.

The required files (awb.war and DataSync.war are placed in this location:

<HYPERION_HOME>\BPMA\AppServer\InstallableApps\

For detailed information on manually deploying to your Web application server, refer to your
vendor’s administrator’s guide.

Manually Deploying Performance Management
Architect into WebLogic 9.1

ä To manually deploy Performance Management Architect into WebLogic 9.1:

1 Install Performance Management Architect on a Windows computer.
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2 In WebLogic, create the Performance Management Architect domain by using the WebLogic
Configuration Wizard:

a. Run config.cmd from this directory: <drive>:\<BEA_HOME>\common\bin.

b. In the WebLogic Configuration wizard, select Create a new WebLogic Domain. Then
click Next.

c. In Select Domain Source, select Generate a domain configured automatically to support
the following BEA products. Then click Next.

d. In Configure Administrator Username and Password, enter the user name and user
password. Then click Next.

e. In Configure Server Start Mode and JDK, in the left panel, select Production mode. In
the right panel, under BEA Supplied JDKs, select JRockit SDK 1.5.0_04. Then click
Next.

f. In Customize Environment and Services Settings, select Yes and click Next.

g. In Configure the Administration Server:

i. For Name, enter a server name (Hyperion defaults to BPMAServer).

ii. For the Listen address, keep the default option (All localhost addresses).

iii. In Listen port, enter an unused port number (BPMA defaults to 19091 for AWB
and 19101 for DataSync).

iv. Click Next.

h. In Configure Managed Servers, click Next.

i. In Configure Machines, click Next.

j. In Review WebLogic Domain, verify the Domain summary. Then click Next.

k. Create the WebLogic domain:

i. In Domain Name, enter a valid name (Performance Management Architect defaults
to bpma_domain).

ii. In Domain Location, enter the location (Performance Management Architect
defaults to <drive>:\bea\user_projects\domains)

iii. Click Create.

l. Once Domain creation is successful, select Start Admin Server , and click Done. This
launches the Performance Management Architect domain server created in WebLogic.

3 In the Deploying to an Application Server task in the Configuration Utility, select your Web application
server and the Manual option.

4 Deploy Performance Management Architect to Weblogic.

a. Extract the awb.war and DataSync.war contents to <HYPERION_HOME>\BPMA
\AppServer\InstalledApps\WebLogic\9.1\BPMAWebServer\awb. The
awb.war and DataSync.war can be found in <HYPERION_HOME>\BPMA\AppServer
\InstallableApps\.

b. Start the server by selecting: Start > Programs > BEA Products > User Projects >
<BPMA_DOMAIN> > Start Admin Server for weblogic server domain.
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c. Start the WebLogic Administration console by selecting Start > Programs > BEA
Products > User Projects > <BPMA_DOMAIN> > Admin Server Console or in a Web
browser, entering the URL such as http:\\<server>:<port>/console where
<server> is the machine where WebLogic is running and <port> is the BPM Architect
domain port (19091).

d. Enter the username and password that you created earlier and click Log In.

e. From the Change Center panel, select Lock and Edit.

Note: This is required to install and deploy but is not required once the install and
deploy is done.

f. From the left panel of the Administration Console, select Deployments.

g. In the right pane, from Summary of Deployments > Deployments, select Install.

h. In the Install Application Assistant, browse to <HYPERION_HOME>\BPMA\AppServer
\InstalledApps\WebLogic\9.1\BPMAWebServer\awb. Then click Next.

i. Once the file loads (this may take a while), from Choose targeting style, select Install
this deployment as an application. Then click Next.

j. Select I will make the deployment accessible from the following location. Then browse
to the location (<HYPERION_HOME\BPMA\AppServer\InstalledApps\WebLogic
\9.1\BPMAWebServer\awb). Then select Next.

k. In Additional configuration, select whether you want to see the deployment
configuration settings.

l. Verify the deployment summary and click Finish.

m. After the configuration loads (this may take a while), click Save from the Overview tab.

n. After the Settings updated successfully message is displayed, select Activate Changes.

o. From the Domain structure panel in the left pane, select Deployments.

p. In the Summary of Deployments panel, check that the state is “Prepared.”

q. Select the application. Then select Start > Servicing all request.

r. In Start Deployments, select Yes.

s. In the Summary of Deployments panel, check that the state is “Active.”

5 The application is ready to launch. Test by accessing the URL: http://<web server>:<port>/
awb where <web server> is the Web server machine hostname and <port> is the Web server listen
port, for example 19091.

6 Repeat these steps to deploy Performance Management Architect Data Synchronization server to
WebLogic.

Manually Deploying Performance Management Architect into WebLogic 9.1 107



Manually Deploying Performance Management
Architect into WebLogic 8.1.4

ä To manually deploy and configure Performance Management Architect into WebLogic
8.1.4:

1 Install Performance Management Architect on a Windows computer.

2 In WebLogic, create the Performance Management Architect domain by using the WebLogic
Configuration Wizard:

a. Run config.cmd from this directory: <drive>:\<BEA_HOME>\common\bin.

b. Select Create a new WebLogic domain and click Next.

c. Select Configuration Template > Templates, highlight Basic Weblogic Server
Domain, and click Next.

d. Select Custom from the Express or Custom Configuration option, and click Next.

e. In Configure Administration Server:

i. For Name, enter a server name (Hyperion defaults to BPMAServer).

ii. For the Listen address, select localhost.

iii. In Listen port, enter an unused port number (Defaults to 19091 for AWB or 19101
for DataSync).

iv. If you want to enable SSL, select Configure SSL.

v. Click Next.

f. In Configure Managed Servers, Clusters and Machines Options, click Next.

g. In Database (JDBC) Options, click Next.

h. In Messaging (JMS) Options, click Next.

i. In Configure Administrative Username and Password, enter a user name, password
and confirm the password. Then click Next.

j. In Configure Windows Options, click Next.

k. In Build Start Menu Entries, enter a name and argument. For example,
BPMArchitect, then click Next.

l. Under Configure Server Start Mode and Java SDK, select Production Mode. .

m. Under Create Weblogic Configuration:

i. Click Browse to identify the folder in which to create the Performance Management
Architect domain.

ii. In Configuration Name, enter the domain name (Performance Management
Architect defaults to BPMADomain)

iii. Click Create.

n. After Domain creation is successful, select Start Admin Server , and click Done. This
launches the Performance Management Architect domain server created in WebLogic.
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3 In the Deploying to an Application Server task in the Configuration Utility, select your Web application
server and the Manual option.

4 DeployPerformance Management Architect to Weblogic.

a. Extract the awb.war contents from <HYPERION_HOME>\BPMA\AppServer
\InstallableApps\to <HYPERION_HOME>\BPMA\AppServer\InstalledApps
\WebLogic\8.1\BPMAWebServer\awb.

b. Start the WebLogic server you just created. For example, <WL_HOME>
\user_projects\domains\<USER_DOMAIN>\startWebLogic.cmd or by selecting
Start > Programs > BEA WebLogic Platform 8.1.

c. Enter the username and password that you created earlier and click Log In.

d. From the left panel of the Administration Console, select Deployments > Web
Applications Modules.

e. In the right pane, select Deploy a new Web Application Module.

f. Browse to select the location of the exploded war file.

g. Select Target Module.

h. Review the choices.

i. Under Identity, enter a name for the application (for example, bpma).

j. Select Deploy.

k. Verify the deployment status by waiting until it displays Available. The application is
now ready.

5 Repeat these steps to deploy the Data Synchronization server to WebLogic.

Manually Deploying Performance Management
Architect into WebSphere 6.0.2.11

ä To manually deploy Performance Management Architect into WebSphere 6.0.2.11:

1 Install Performance Management Architect on a Windows computer.

2 Create a Profile

a. Launch the Create Profile Wizard (Start > Programs > IBM WebSphere > Application
Server v6 > Profile creation wizard). Then select Next.

b. Enter a profile name. For example: BPMArchitect

c. Select the profile directory or leave the default. Then click Next.

d. The port value assignment is displayed. Click Next.

e. In Windows Service Definition, select whether to run the application as a Windows
service. If you are running as a service, select Log on as a specified user account. Then
click Next.

f. Review the profile summary, then click Next to create the new profile.
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g. Once the profile creation results is displayed, click Finish.

3 Create a virtual host by accessing the WebSphere Admin Console.

a. Select Environment > Virtual Hosts > New and specify a name for the virtual host (for
example, BPMAVirtualHost).

b. Click Apply, OK, and Save.

c. In the Additional Properties section, select Host Aliases.

i. On the Host Aliases page, click New.

ii. Specify a hostname or IP address of your server in Host Name or enter * to allow
listening on all IP addresses for the machine. .

iii. Specify the HTTP port that client machines will use to access BPM Architect (for
example, 19091 for BPM Architect Web Tier and 19101 for Data Synchronizer).

iv. Click Apply, OK, and Save.

4 In the Deploying to an Application Server task in the Configuration Utility, select your Web application
server and the Manual option.

5 Deploy Performance Management Architect:

a. From the WebSphere Admin console, select Applications > Install New Application.

b. Enter the full server path to the awb.war file (<HYPERION_HOME>\BPMA\AppServer
\InstallableApps\awb.war.

c. Select Generate Default Bindings.

d. Select do not override existing bindings.

e. Select do not user default virtual host name for Web modules. Then click Next.

f. Click Continue to acknowledge application security warnings.

g. Specify a name for the Web application (for example: awb)

h. Select the appropriate module to server for awb. Select check box for awb module.

i. Select Apply, then select Next.

j. In Map Virtual Hosts for Web modules, select the Virtual host from the drop-down list
(for example, default_host). Then select the check box for the Web module awb.

k. Verify the summary, then click Finish to start the deployment. Due to the size of the
Performance Management Architect application, this may take several minutes to
complete. Do not interrupt the deployment process.

l. When the deployment is successful, select Save to Master Configuration.

m. Select Save.

n. Restart the application server.

6 Repeat these steps for the Data Synchronization server.
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Manually Deploying Performance Management
Architect into WebSphere 5.1.1.7

ä To manually deploy Performance Management Architect into WebSphere 5.1.1.7:

1 Install Performance Management Architect on a Windows computer.

2 Log in to the WebSphere Admin Console and create an application server:

a. Select Servers > Application Servers  and in the right pane select New.

b. In Server, enter a server name (for example, bpma). Then click Next, then Finish.

c. In the left pane, select Servers > Application Servers.

d. In the right pane, select the server created in step 2b, and in the additional properties
section, select Web Container > HTTP Transport. Make a note of the assigned HTTP
and HTTPS (SSL) port numbers, changing if needed.

e. In the left pane, select Environment > Virtual Hosts.

f. In the right pane, open the default_host.

g. In the Additional Properties section, select Host Aliases. Then click New.

i. Assign a value to the Host Name field depending on your needs: .

1. To allow a host to connect to the selected http transports, enter an asterisk (*)
in this field.

2. To limit access to a host, such as your Web Server machine, enter the host's
name or IP address.

ii. Specify the HTTP port that client machines will use to access Performance
Management Architect (for example, 19091 for Performance Management
Architect Web Tier or 19101 for Data Synchronizer).

iii. Click Apply, OK, and Save to Master Configuration.

3 In the Deploying to an Application Server task in the Configuration Utility, select your Web application
server and the Manual option.

4 Create the Oracle's Enterprise Performance Management Architect application.

a. Select Applications > Install New Application.

b. Browse to the location of the awb.war file.

If you installed to the default location, the file is located at <<HYPERION_HOME>\BPMA
\AppServer\InstallableApps\.

c. Specify application context root: awb.

d. Click Next

e. Select Generate Default Bindings .

f. Select do not use default virtual host name for Web modules. Then click Next.

g. Change the Application Name to awb. Then click Next.
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h. In Map modules to application servers, under modules, select the module named
awb.

i. Under Clusters and Servers, select the server named awb

j. Click Apply and then Next.

k. Review the summary, then click Finish.

l. Save to master configuration.

5 Repeat these steps to manually deploy and configure the Data Synchronization server.
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