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1 What’s New in This Release  
 

 

What’s New in Siebel Retail Finance Banking Application 
Administration Guide, Version 2007.1 
Table 1 lists changes in this version of the documentation to support version 2007.1 of the software. 

Table 1. What’s New in Siebel Retail Finance Banking Application Administration Guide, Version 2007.1 

Topic Description 

“Updating Bond Redemption Values” on page 23 The URL for updating bond redemption values has 
changed to 
ftp://ftp.publicdebt.treas.gov/SB200706.ASC. 

Chapter 3, “Administering Internet Banking” This chapter has been added to cover administration 
of Oracle’s Siebel Retail Finance Internet Banking 
application. 

Chapter 4, “Configuring Integration of CRC 
Components” 

This chapter has been added to cover the 
configuration tasks required for integrating Siebel 
Retail Finance and Siebel Financial Services, to 
enable the Siebel Retail Finance CRC components. 
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2 Administering Branch Teller  
 

 

This chapter describes the administration functionality provided for Oracle’s Siebel Retail Finance 
Branch Teller application. Branch Teller administration operations are executed in the Siebel Retail 
Finance Administrator, which is accessed at http://<ServerName>:<PortNumber>/branchadmin. 

This chapter includes the following topics: 

 Administering Branches 

 Administering the Calendar 

 Administering Utilities 

 Administering Users and Their Entitlements 

 Administering User Groups 

 Administering Roles 

 Administering Privileges 

 Administering Limits 

 Administering Passwords 

 Administering the Bond Table 

 Administering Fees 

 Administering Negotiable Instruments 

 Administering Currency Transaction Reports 

 Administering Branch Teller Database Tables 

Administering Branches 
You use the Branch Maintenance operations to set up the branches in your system and maintain the 
details of the branches.  

Adding a Branch 
When you add a branch to the system, you enter the details of the branch. 

To add a branch 

1 Navigate to the Branch Maintenance > Add New Branch Details screen (Fast Tran 11). 

2 Complete the necessary fields.  
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The required fields are described in the following table. 

Field Comment 

Branch Code Type the branch code. If the branch corresponding to the 
branch code you entered has already been set up on the 
system, an error is displayed. 

Branch Name Type the name of the branch. 

Processing Mode Select AM or AM/PM, to determine whether or not the 
branch switches the transaction processing date to the 
next business day during a calendar day. 

Address Line 1  Type the first line of the branch’s address.  

Address Line 2 Type the second line of the branch’s address.  

Phone Number Type the telephone number of the branch. 

3 Click Submit. 

Maintaining Branch Details 
After you have set up the branches in your system, you can search for branches by branch code, 
branch name, or postal code, and then maintain the details of branches.  You can change all of the 
details for a branch, except the branch code. 

To maintain branch details 

1 Navigate to the Branch Maintenance > Branch Search screen (Fast Tran 12). 

2 Select Branch Code, Branch Name, or Zip/Postal Code, and type the appropriate branch code, 
branch name, or postal code. 

3 Click Search.  

4 Select a branch from the search results. 

5 Click Amend Branch Details. 

6 Change the branch details as required.  

7 Click Submit. 

Administering the Calendar 
You use the Calendar Maintenance operation to set up your system calendar with the dates when the 
bank is closed due to weekends, holidays, or other reasons. 

You can only open a branch on dates that are designated as open dates in the calendar. When you 
open a branch, Branch Teller uses the calendar to determine the correct processing date.  
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Setting Up the Calendar 
You add dates to the calendar to indicate when the bank is closed. You can add dates in the following 
ways: 

 By specifying that the bank is closed on a particular day of the week, for example, Sunday. 

 By specifying a particular date. 

 By specifying a range of dates. 

Branch Teller maintains the calendar for the current year and the following four years. 

To set up a calendar 

1 Navigate to the Branch Maintenance > Maintain Calendar screen (Fast Tran 21). 

2 Specify dates in one of the following ways: 

 Click Dates and select a day of the week. This day of the week is then a closed date for the 
five-year period.  

 Click the radio button and type a date in the Date field, or double-click a date from the popup 
calendar. 

 Click the radio button and type a date in the From Date and To Date fields, or double-click the 
dates from the popup calendars. 

3 Type the reason why the bank is closed in the Description field. 

4 Click New to add the date or dates to the calendar. 

5 Repeat steps 2 through 4 for all dates that you need to add to the calendar. 

Updating the Calendar 
You can delete from the calendar the dates when the bank is closed, and you can update the 
descriptions of those closed dates. 

To update a calendar 

1 Navigate to the Branch Maintenance > Maintain Calendar screen (Fast Tran 21). 

2 Specify dates in one of the following ways and then click Query: 

 Click Dates and select a day of the week.  

 Click the radio button and type a date in the Date field, or double-click a date from the popup 
calendar. 

 Click the radio button and type a date in the From Date and To Date fields, or double-click the 
dates from the popup calendars. 

The dates that you selected, together with their descriptions are displayed in the Calendar 
Search Results table. 
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3 To update the description of a date, select the date in the results table, edit the description, and 
click Update. 

4 To delete a date or set of dates, select the dates in the results table and click Delete. 

Administering Utilities 
You use the Utility Maintenance operations to set up the utilities in your system, and maintain the 
details of the utilities.  

Adding a Utility 
When you add a utility, you enter the details of the utility. 

To add a utility 

1 Navigate to the Branch Maintenance > Add Utility screen (Fast Tran 31). 

2 Complete the necessary fields.  

The required fields are described in the following table. 

Field Comment 

Utility Name Type the name of the utility. 

Branch Code Type the branch code.  

Account Number Type the number of the account.  

Bank Reference Type a reference of up to 60 characters. 

3 Click Submit. 

Maintaining Utility Details 
After you have set up the utilities in your system, you can search for utilities by utility name, branch 
code, or account number, and then maintain the details of utilities. You can change all of the details 
for a utility.  

To maintain utility details 

1 Navigate to the Utility Maintenance > Utility Search screen (Fast Tran 32).  

2 Select Utility Name, Branch Code, or Account Number, and select the appropriate utility name, or 
type the branch code or account number. 

3 Click Search.   
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4 Select a utility from the search results. 

5 Click Amend Utility Details. 

6 Change the utility details as required.  

7 Click Submit. 

Administering Users and Their 
Entitlements 
This topic covers the operations to set up the users in each branch in your system, maintain the set of 
users, and assign user entitlements. Siebel Retail Finance Entitlements uses a Role Based Access 
Control (RBAC) framework. In the Entitlements framework, users or user groups are assigned roles. 
The privileges assigned to the roles control the functionality and data to which the user or user group 
has access. 

Users are defined as individual users of the banking application such as a bank teller, branch 
manager, or branch customer. Within the Entitlements operations, users are referred to as actors. You 
can also define delegate actors. A delegate actor is a user to whom customers can, on a self-service 
channel like Internet Banking, grant selective access to their accounts. This is a mechanism for 
providing, for example, a personal advisor with access to specific accounts and the ability to make 
transfers up to a specific limit.  

Adding a Branch User 
When you add branch users, you define what type of user they are and whether they are a supervisor. 
You add the details of the users, including their contact details if required. For those users who have 
supervisors, you assign a supervisor. 

If you are a central administrator, you can add users for all branches. If you are a branch 
administrator, you can add users for your branch only. 

Before you can assign a supervisor to a user, there must be at least one supervisor set up in Branch 
Teller. 

To add a branch user 

1 Navigate to the User Maintenance > Add User Details screen (Fast Tran 41). 

2 Complete the necessary fields.  

The required fields are described in the following table.  

Field Comment 

Branch Code If you are a branch administrator, this field contains your 
branch code, and you cannot change it. If you are a 
central administrator, type the branch code. 
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Field Comment 

User Name Type the name of the user. 

User Logon Name Type the user name with which the branch user logs in. 

Password Type a password. 

Confirm Password Type the same password again. 

User Type Select one of the following: Administrator (for a central 
administrator), Branch Administrator, Branch Manager, 
Supervisor, or Teller.  

Language Preferences Select a language. 

3 Select the Supervisor check box if the user is to be a supervisor. 

4 Click Create User. 

5 Click Create Contact Details when you have typed any contact details that you want to add.  

The Assign Supervisor screen is then displayed. 

6 Select the supervisor in the list of Unassigned Supervisor list that the branch user is to be 
assigned to. 

7 Click the assign button (>>). 

 The supervisor is then added to the Assigned Supervisors list. 

8 Click Submit. 

Maintaining a Branch User 
After you have set up the branch users in your system, you can search for users by user name, user 
logon name, user type, or user status. You can then do the following: 

 View details of the users. 

 Change the details for the users, including the assignment of supervisors.  

 Delete users from the system. 

 Make users active (unlocked) or inactive (locked).  

To maintain a branch user 

1 Navigate to the User Maintenance > View Branch User Search Results screen (Fast Tran 42). 

2 Select or type details of the branch Code, name, login name, user type, or status of the branch 
user for which you want to search. 

3 Click Search.   
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The search results are displayed. The Locked column shows whether users are active, that is, 
unlocked (No), or inactive, that is, locked (Yes). 

4 Select the required user. 

5 Now click one of the following buttons depending on the maintenance activity that you want to 
perform: 

 Click View to view the details for the user. Click Next to view the contact details and 
supervisor details. 

 Click Amend to change the details for the user. Click Next to access the contact details and 
supervisor details. Click Submit when you have completed the changes. 

 Click Delete to remove a user from the system. You must confirm the deletion. 

 Click Lock to make a user who is active become inactive. Alternatively, if you select a user that 
is inactive (Yes in the Locked column), you can click Unlock to make the user active. 

6 Click Submit. 

Maintaining User Permissions 
The Maintain User Permissions operation allows you to: 

 Search for specific actors or retrieve all actors. 

 View actor and delegate actor details. 

 Add, amend, or delete privileges for an actor 

 Assign or unassign a role to or from an actor or delegate actor. 

 Assign or unassign an actor to or from an actor group. 

 Reset user logon tries, when the user exceeds the allowed number of logon attempts. 

 Lock or unlock an actor account. 

You perform some of these tasks from the list of actors, and others from the Actor Details list that is 
displayed when you select an actor from the list of actors. 

Viewing Actor Details 
You can search for a specific actor or delegate actor and then view their details.  

To view actor details 

1 Navigate to the User Maintenance > Actor Search screen (Fast Tran 43). 

2 Enter or select the user name, user logon name, actor type, or status. 

3 Click Search.  

The Actors list displays the user name, logon name, user type, and status for each user 
returned.  If you click Search without entering any search criteria, the Actors list displays all 
the active actors. 
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4 Select the actor for which you wish to display details. 

5 Click View. 

The Actor Details screen is displayed. 

Adding an Actor to the List 
Before you add an actor, you must display the Actors list.  

To add an actor 

1 Navigate to the User Maintenance > Actor Search screen (Fast Tran 43). 

2 Enter search criteria and click Search.  

The Actors screen is displayed.  

3 Click Add.  

4 Type the details for the user. 

Field Comment 

User Name Type the name of the user. 

User Logon Name Type the user name with which the branch user logs in. 

User Type Select a user type, for example, Administrator (for a 
central administrator), Branch Administrator, Branch 
Manager, Supervisor, or Teller.  The user type that you 
can select depends on your user type. If you are an 
Administrator, you can select all of the available types.  

Password Type a password. 

Confirm Password Type the same password again. 

5 Click Submit. 

Deleting an Actor from the List 
Before you delete an actor, you must display the Actors list.  

When you delete an actor or delegate actor, the system checks whether the actor or delegate has 
been assigned to any actor groups and removes any assignments. The system checks whether any 
roles have been assigned to the actor or delegate and if they have, it unassigns them. The system 
then deletes the actor or delegate. 

To delete an actor 

1 Navigate to the User Maintenance > Actor Search screen (Fast Tran 43). 

2 Enter search criteria and click Search. 

The Actors screen is displayed.  
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3 Select the actor that you want to delete.  

4 Click Delete.  

Maintaining User Details 
This topic covers the following sub topics: 

 Assign and unassign privileges to and from an actor 

 Assign and unassign roles to or from an actor 

 Assign and unassign actors to or from an actor group 

 Reset the count of user logon tries 

 Lock or unlock an actor account 

You navigate to the Actor Details screen as described in Viewing Actor Details on page 15. 

Assigning and Unassigning Actor-Specific Privileges 
You can assign and unassign privileges to a specific actor. You can also assign privileges to roles; see 
Administering Roles on page 20. 

To assign and unassign actor-specific privileges 

1 Navigate to the Actor Details screen for the actor. 

2 Click Actor Specific Privileges. 

The privileges of that actor are then displayed on the Privileges screen. 

3 Perform the maintenance activity that you require: 

 To create a privilege, click Add. Enter a Privilege Description, which is mandatory, and select 
one or more of the following: task description, limit value, and channel name. Finally, click 
Submit. 

 To amend a privilege, select the privilege from the list, click Amend, edit the details, and click 
Submit. 

 To delete a privilege, select the privilege from the list, and click Delete. 

Assigning and Unassigning Roles to an Actor 
You can assign and unassign roles to a specific actor.  

To assign and unassign roles to an actor 

1 Navigate to the Actor Details screen for the actor. 

2 Click Roles. 

The Roles screen is displayed. 
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3 Assign or unassign roles as required:   

 To assign a role, select the role in the Available Roles list, and click Assign/Unassign Role. The 
role is then displayed in the Assigned Roles list. 

 To unassign a role, select the role in the Assigned Roles list, and click Assign/Unassign Role. 
The role is then displayed in the Available Roles list. 

Click Cancel to return to the Actor Details screen. 

Assigning and Unassigning Actors to Actor Groups 
You can assign and unassign actors to actor groups.  

To assign and unassign actor to actor groups 

1 Navigate to the Actor Details screen for the actor. 

2 Click Actor Groups. 

3 Assign or unassign actors to actor groups as required:   

 To assign an actor, select the actor group in the Available Actor Groups list, and click 
Assign/Unassign Actor Group. The actor group is then displayed in the Assigned Actor Groups 
list. 

 To unassign an actor, select the actor group in the Assigned Actor Groups list, and click 
Assign/Unassign Actor Group. The actor group is then displayed in the Available Actors Group 
list. 

Click Cancel to return to the Actor Details screen. 

Maintaining the List of Delegates for an Actor 
You can specify delegates for a particular actor. 

To maintain the list of delegates for an actor 

1 Navigate to the Actor Details screen for the actor. 

2 Click View Delegates. 

3 To add a delegate, click Add, type the details, and click Submit. 

4 To delete a delegate, click Delete. 

Resetting an Actor’s Login Tries 
You can reset the number of logon tries for an actor who has exceeded their limit and therefore cannot 
log in. 

To reset an actors logon tries 

1 Navigate to the Actor Details screen for the actor. 
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2 Click Reset Logon Tries. 

The Logon Tries field is updated. 

Locking and Unlocking an Actor Account 
You can unlock an actor account tom make it active or lock an actor account to make it inactive. 

To lock or unlock an actor account 

1 Navigate to the Actor Details screen for the actor. 

2 Click Lock/Unlock. 

The Status field is updated. 

Administering User Groups 
User groups are flexible groupings of users, containing one or more members. A user can belong to 
zero or more groups. When you define a group, you can select another, previously-defined group as 
its parent group. The group being defined then inherits the roles assigned to the parent group. The 
following user group administration is provided: 

 View actor groups. 

 View roles assigned to a specific actor group. 

 Assign a role to or from an actor group. 

 Add, amend, or delete an actor group. 

When you delete an actor group, the system first checks whether any actors have been assigned to 
the actor group and unassigns any that have been assigned. The system checks whether any roles 
have been assigned to the actor group and unassigns any roles that have been assigned. The actor 
group is then deleted. 

To add and maintain actor groups 

1 Navigate to the Actor Maintenance > Actor Groups screen (Fast Tran 44). 

The Actor Groups screen is displayed showing the group name and any parent group name for 
each group. 

2 To add a group, click Add, and then type an actor group name, select a parent actor group, if 
required, and click Submit. 

3 Select the required actor group. 

4 Click a button according to the maintenance activity you want to perform: 

 To view the roles assigned to the group, click View Roles. Click Cancel to return to the Actor 
Groups screen. 

 To assign or unassign a role to or from a group, click View Roles.  



 
Administering Branch Teller  Administering Roles 

20 Siebel Retail Finance Banking Application Administration Guide Version 2007.1 

 

 

 

 

 

To assign a role, select the role in the Available Roles list, and click Assign/Unassign Role. 
The role is then displayed in the Roles list. 

To unassign a role, select the role in the Roles list, and click Assign/Unassign Role. The 
role is then displayed in the Available Roles list. 

Click Cancel to return to the Actor Groups screen. 

 To amend a group, click Amend. Edit the actor group name and parent actor group as 
required, and click Submit. 

 To delete a group, click Delete. 

Administering Roles 
Users and groups are assigned roles, with corresponding privileges. The privileges control the 
functionality and data to which they have access. The Roles operation allows you to: 

 View role details. 

 View the privileges assigned to a specific role. 

 Assign or unassign privileges to or from a role. 

 Add a role. 

 Amend a role name. 

 Delete a role. 

When you delete a role, the system first unassigns the role from any actor, actor group, or privilege to 
which it has been assigned. 

To add and maintain roles 

1 Navigate to the Actor Maintenance > Roles screen (Fast Tran 45). 

The Roles screen is displayed showing the role name for each role. 

2 To add a role, click Add, then type a role name, and click Submit. 

3 Select the required role. 

4 Click a button according to the maintenance activity you want to perform: 

 To view the privileges assigned to the role, click View Role Privileges. Click Cancel to return to 
the Roles screen. 

 To assign or unassign a privilege to or from a role, click Assign/Unassign Privilege.  

To assign a privilege, select the privilege in the Available Privileges list, and click Assign 
Privilege. The privilege is then displayed in the Assigned Privileges list. 

To unassign a privilege, select the privilege in the Assigned Privileges list, and click 
Unassign Privilege. The privilege is then displayed in the Available Privileges list. 

5 Click Submit when you have completed assigning or unassigning privileges.  
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 To amend a role, click Amend. Edit the role name and click Submit.  

 To delete a role, click Delete. 

Administering Privileges 
The Privileges operation allows you to: 

 View privilege details. 

 Revoke privilege from all actors irrespective of the role of any actor. This allows for situations 
where some services, for example, funds transfer, need to be blocked. 

 Restore a privilege to all actors who had the privilege before it was revoked. 

 Add a privilege 

 Assign a privilege to all existing roles 

 Delete a privilege 

When you create a privilege, you assigned to it one or more of the following privilege items:  

 Task. The details of the action that is to be carried out, for example, funds transfer. 

 Limit. A value imposed on a privilege such as a maximum amount that can be transferred. The 
limit type has an associated currency and limit type. The limit type can be, for example, daily or 
transactional. 

 Channel. The method of access to a system, which can affect the access control requirements. 
Examples of channels include Internet and branch. 

When you create a privilege, the system verifies that a privilege with the same task, limit, and channel 
does not exist (if it does exist, an error message is displayed). The system creates the new privilege, 
generates a privilege ID and sets the privilege type to general. A general privilege is a privilege that 
can be assigned to all actors or actor groups and which has not been created for a specific actor or 
actor group. 

When you delete a privilege, the system checks whether the privilege has been assigned to any role. 
If it has, the assignments are deleted. The system then deletes the privilege. For privileges that were 
created for an individual actor or delegate actor (only applicable when the Privileges screen is 
displayed from an actor or delegate actor screen) the system checks instead whether the individual 
role of the privilege has any other individual privileges assigned to it. If it has not, then the individual 
role is unassigned from the actor or delegate actor. The individual role is then deleted and the 
privilege is deleted. If the individual role has other individual privileges assigned to it then the 
individual role is not deleted. The individual privilege is then deleted. 

NOTE:  You can maintain privileges for a specific actor or delegate actor by using the Maintain Actor 
Permissions operation. See Assigning and Unassigning Actor-Specific Privileges on page 17 for more 
information.  

To add and maintain privileges 

1 Navigate to the Actor Maintenance > Privileges screen (Fast Tran 46). 
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The Privileges screen is displayed showing the privilege description, channel name, task 
description, limit amount, limit currency, limit type, and revoked status for each privilege set 
up on the system. 

2 To create a privilege, click Add.  Enter a Privilege Description, which is mandatory, and select 
values for one or more of the following:  

 Task Description  

 Limit Value  

 Channel Name  

3 Click Submit. 

4 Select the required privilege. 

5 Click a button according to the maintenance activity you want to perform: 

 To revoke a privilege from all actors, Click Revoke From All. 

 To restore a privilege to all actors, click Reinvoke Privilege. 

 To assign the privilege to all existing roles, click Assign Privilege to All Roles. 

 To delete a privilege, click Delete. 

Administering Limits 
A limit is assigned to a privilege when you create the privilege. 

A limit value can be a maximum amount that can be transferred. The limit type can be, for example, 
daily or transactional.  

The Limits operation allows you to: 

 View limit details 

 Add a limit 

 Delete a limit  

When you delete a limit, the system initially determines any privileges that the limit has been 
assigned to, unassigns those privileges from any roles they have been assigned to, deletes those 
privileges, and then deletes the limit. 

To maintain limits 

1 Navigate to the User Maintenance > Limits screen (Fast Tran 47). 

The Limits screen is displayed. 

2 Add or delete limits as required: 

 To add a limit, click Add, type or select a limit value, currency and type, and click Submit. 

 To delete a limit, select the limit to be deleted, and click Delete. 



 
Administering Branch Teller  Administering Passwords 

 

 Siebel Retail Finance Banking Application Administration Guide Version 2007.1 
 

23 
 

  

Administering Passwords 
When you change a user’s password, the system verifies that the Existing Password entered matches 
that stored against the current user and that both new entered passwords match. 

To change a user’s password 

1 Navigate to the User Maintenance > Change Password screen (Fast Tran 48).  

The system displays the user logon name. 

2 Enter values in the Old Password, New Password, and Confirm New Password fields, all of which 
are mandatory. 

3 Click Submit. 

Administering the Bond Table 
You use the Bond Table Maintenance operation to update the U.S. bond redemption values with values 
that are downloaded from the U.S. Treasury Web site. The bond redemption values, which are 
updated on the Web site twice a year, are used in Bond Redemption and Bond Inquiry operations in 
the Branch Teller application.  

Updating Bond Redemption Values 
The method used for converting the values, and the format depends on the type of database system 
that you are using.  

To update bond table redemption values 

1 Download the redemption values file from the treasury Web site: 
(ftp://ftp.publicdebt.treas.gov/SB200706.ASC) and save the file to a suitable location on your 
desktop or the network. 

2 Navigate to the Bond Tables > Bonds Table screen (Fast Tran 51). 

3 Type the location of the redemption values file in the Select the File Location field, or click Browse 
to search for the file location. 

4 Click Submit.  

Administering Fees 
You use the Fee Maintenance operations to set up, view, and change the fees applying to financial 
transactions. By maintaining the details of transaction fees, you make sure that the correct fees are 
charged when the teller runs a transaction.  

Fees are calculated based on the account type, customer type, transaction type, and the amount of 
the transaction. For each account type and customer type there is a factor value that is used in 
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calculating transaction fees. This allows, for example, fees for a particular type of transaction for 
company accounts to be higher than those for charity accounts. 

When you create transaction fees, you specify the fees that apply for a particular account type and 
customer type.  

To maintain transaction fee details 

1 Navigate to the Fees Maintenance > Maintain Fees screen (Fast Tran 61).  

2 Select an account type from the Account Types list. 

3 If required, edit the factor value for this account type. 

4 Select a customer type from the Customer Types list. 

5 If required, edit the factor value for this customer type. 

6 In the Transactions Fee Details table, enter or change the values for the flat fee, percentage fee, 
and maximum percentage fees for each transaction type as required. 

7 Repeat steps 2 through 6 for each set of transaction fees that you require to maintain. 

8 Click Submit. 

The transaction fees are saved and the New Transaction Fees screen is displayed. This screen 
displays all of the fees for each transaction type, account type, and customer type, and 
includes the changes that you made in the Maintain Fees screen. The details are shown in the 
following table. 

Field Comment 

Trx Code Displays the transaction code. 

Transaction Type Displays the transaction type. 

Account Type Displays the account type. 

Customer Type Displays the customer type. 

Flat Fee Displays the flat fee entered in the Transaction Fee 
Details table multiplied by both of the factor values for 
the account type and customer type. 

% Fee Displays the percentage fee entered in the Transaction 
Fee Details table multiplied by both of the factor values 
for the account type and customer type. 

Max Displays the maximum percentage fee entered in the 
Transaction Fee Details table multiplied by both of the 
factor values for the account type and customer type. 

9 Click Close. 

You are returned to the Maintain Fees screen. 
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Administering Negotiable Instruments  
You use the Negotiable Instruments operation to search the negotiable instrument log.  Negotiable 
instruments include travelers checks, drafts, cashier checks, money orders, customer checks, and U.S. 
savings bonds. 

Information is written to the log every time a negotiable instrument is sold or paid to a customer in 
the branch. The log is useful in preventing fraudulent activity. The following data is recorded in the 
log: 

 Teller ID  

 Transaction reference number 

 Branch code 

 Date of purchase 

 Negotiable instrument type 

 Negotiable instrument serial number 

 Negotiable instrument amount 

 Multiple instrument sale details 

 Payee (for drafts, money orders or cashier's checks) 

 Purchaser name 

 Purchaser date of birth 

 Purchaser address 

 Purchaser ID type and document number (for example, driver’s license, social security number, 
passport) 

The negotiable instrument log details are stored centrally. You can view them for a branch (typically, if 
you are a branch administrator), or for the whole bank (typically, if you are a central administrator). 

Querying the Negotiable Instruments Log 
You can display negotiable instrument log details for a specific teller, or for all tellers in a branch. 

To query the negotiable instruments log 

1 Navigate to the Negotiable Instruments > Query Log: Negotiable Instruments screen (Fast Tran 
71). 

2 Type your branch code if you are a branch administrator.  

If you are a central administrator, this field contains your branch code, and you cannot change 
it.  

3 Select the tellers for whom you want to display log details.  

 To retrieve log details for all tellers in the branch, select All in the Teller ID list.  
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 To retrieve log details for a specific teller, click Retrieve Tellers so that the Teller ID list 
contains all the tellers of the selected branch, and then select the required teller from the list. 

4 Select the Date Range, Transaction Type, or Amount Range radio button, depending on whether 
you want to search by a range of dates, by transaction type, or by a range of amounts associated 
with the log records. 

5 If you selected the Transaction Type radio button, select the required transaction type from the 
drop-down list.  

6 If required, complete the fields as shown in the following table. 

Field Comment 

Date Range From Type a date. The default value is the current working 
date. This date must be before the date in the Date 
Range To field. 

Date Range To Type a date. The default value is the current working 
date. This date must be the same as, or after the date in 
the Date Range From field. 

Amount Range From Type an amount. This amount must be less than or equal 
to the amount in the Amount Range To field. 

Amount Range To Type an amount. This amount must be greater than or 
equal to the amount in the Amount Range From field. 

7 Click Display Log to view the search results.  

Search results are displayed with the oldest results displayed first. 

8 Select an entry in the log, and click View Details to display additional log details such as purchaser 
details and sender details. 

Administering Currency Transaction 
Reports 
You use the Currency Trans Reports operations to maintain the list of currency transaction report 
(CTR) exemptions and to maintain the list of CTRs in your bank. 

To comply with Bank Secrecy Act and USA Patriot Act requirements, your bank must file currency 
CTRs with the Financial Crimes Enforcement Network (FinCen).  You must complete form FinCen 104 
for every transaction involving cash-in or cash-out amounts exceeding $10,000, unless the relevant 
customer or the account are exempt from currency transaction reporting. For more information about 
currency transaction reporting, see the Branch Teller Guide. 

The CTR exemption list is stored on the central server and at each branch start of day is downloaded 
to the branch data store. 
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Maintaining the CTR Exemption List 
A bank has the right to declare certain qualifying customers as exempt from the CTR process as long 
as these customers are first registered with FinCen:  

 Phase I customers are exempt on a permanent basis. These customers are publicly traded 
companies.  

 Phase II customer's exemption must be renewed every 2 years.  These companies are unlisted 
companies and eligible payroll customers. 

To create a new exemption, you complete a standard Treasury exemption form. The form contains the 
following parts: 

 Part 1. Details of the person to be exempted. 

 Part 2. Details of the reason for the exemption request. 

 Part 3. Details of your financial institution. 

The CTR Exemption list contains the details shown in Table 2. 

Table 2. CTR Exemption List Details 

Column Comments 

Business Name Displays the name of the business. 

Taxpayer Identification Number Displays the social security number masked apart from the 
last four digits. 

Effective Date of Exemption Displays the date when the exemption started. 

Next Review Date Displays the next date when the exemption status should be 
reviewed. 

Basis for Exemption Displays the basis for exemption, for example, eligible 
payroll company. 

To maintain the CTR exemption list 

1 Navigate to the Currency Trans Reports > CTR Exemption List screen (Fast Tran 81). 

2 To add an exemption, click New and complete the CTR Registration Exemption form.  

a Click Initial Designation 

b Complete parts 1, 2, and 3 of the form. 

3 To change an exemption, select the appropriate entry in the list, and click Amend. 

a If this is a review for a phase 2 customer, click Biannual Review. 

b Click Exemption Amended. 

c Amend the details in parts 1, 2, and 3 of the form as required. 

4 To revoke an exemption, select the appropriate entry in the list, and click Amend. 
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d Click Exemption Revoked. 

e Amend the details in parts 1, 2, and 3 of the form as required. 

5 Click Submit. 

Maintaining the CTR List 
You can view the list of filed CTR forms, including suspended CTR forms, for the whole bank. 

You can search for CTR forms by date, by transaction type, or by business name.  You can then view 
individual forms and print them as required.  

The details displayed for CTR forms are shown in Table 3. 

Table 3. CTR Form Details 

Column Comments 

Date/Time Displays the date and time of the transaction that required 
currency transaction reporting. 

Business Name Displays the business name associated with the CTR form, if 
any. 

Status Displays the status of the CTR form; either CTR_COMPLETE or 
CTR_SUSPENDED. 

Branch Displays the name of the branch that filed the CTR form. 

 

You can purge CTR forms that are more than five years old. 

To maintain the CTR list 

1 Navigate to the Currency Trans Reports > CTR Forms Maintenance screen (Fast Tran 82). 

2 Click a radio button to specify your required search criteria and then click Display CTRs: 

 Click Date and type a From date and a To date. 

 Click Transaction Type and select BOTH, CTR_COMPLETE, or CTR_SUSPENDED. 

 Click Business Name and type a business name. 

The list of filed CTR forms matching your search criteria is displayed. 

3 To view a CTR form, select the form from the list and click View. 

4 Click Print, if you want to print the CTR form. 

5 To purge all CTR forms older than five years, click Purge. 

6 Click Submit. 
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Administering Branch Teller Database 
Tables 
This topic describes maintenance tasks that must be performed by directly updating the database 
tables. The method that you use to update the tables will depend on the database system used in your 
organization. Table 4 shows the database tables that you must update for various maintenance tasks. 

Table 4. Maintenance Tasks and Manual Table Updates 

Task Tables Updated 

Adding a new bank card product, or changing details of a 
card product. 

AC_BANK_CARD_PROD, 
AC_BANK_CARD_PROD_RULES 

Adding a new credit card, or changing details of a card. CRCD_AC_HD_CRCD_AC, CREDIT_CARD, 
CREDIT_CARD_DETAILS, 
CREDIT_CARD_HOLDER, 
CRED_CARD_ACC 

Ordering a new checkbook for an account. CHEQUEBOOK, CHEQUEBOOK_FACILITY 

Changing details about your organization. COMPANY 

Adding details about new currencies in use at your bank. COMPANY_CURR, CURRENCY, 
CURRENCY_DENOM 

Updating details about the denominations for the 
currencies in use at your bank. 

CURRENCY_DENOM 

Changing details about exchange rates for currencies, 
used in foreign exchange (FX) deposit and withdrawal 
transactions. 

EXCHANGE_RATE 

Adding a new internal account and maintaining existing 
internal accounts, which are used in balancing 
transactions resulting from Teller End of Day and Teller 
Start of Day operations, when any fees or commissions 
are applied, and when any General Ledger postings are 
made.  

INTERNAL_ACCOUNT 

Recording checks in a new checkbook issued to a 
customer; issuing cashier’s checks, money orders, drafts, 
and FX drafts.  Transactions that use the table include: 

 Transactions involving any "on-us" checks only. 

 Any consignment item processing resulting from 
Issue Draft, Issue Money Order, or Issue Cashiers 
Check operations  

 Negotiable instrument transfers between cashboxes 

The table must be pre-filled with details of pre-printed 
stock and negotiable instruments for which you can 

NEGOTIABLE_INSTRUMENT 
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Task Tables Updated 

dynamically allocate serial numbers (cashier’s checks, 
money orders, and drafts). 

Changing details about retail account products. RET_ACC_PRODUCT, 
RET_ACC_PROD_RET_ACC 

Setting system control information such as sequential 
identifiers. 

SYSTEM_CONTROL 

 

This topic contains the following sub topics: 

 AC_BANK_CARD_RULES Table on page 31 

 CHEQUEBOOK Table on page 31 

 CHEQUEBOOK_FACILITY Table on page 32  

 COMPANY Table on page 33 

 COMPANY_CURR Table on page 33  

 CREDIT_CARD Table on page 34 

 CRED_CARD_ACC Table on page 35 

 CREDIT_CARD_DETS Table on page 36  

 CREDIT_CARD_HOLDER Table on page 37  

 CRCD_AC_HD_CRCD_AC Tables on page 37  

 CURRENCY Table on page 37 

 CURRENCY_DENOM Table on page 38 

 EXCHANGE_RATE Table on page 38  

 INTERNAL_ACCOUNT Table on page 39  

 NEGOTIABLE_INSTRUMENT Table on page 40 

 RET_ACC_PRODUCT Table on page 41 

 RET_ACC_PROD_RET_ACC Table on page 43 

 SYSTEM_CONTROL Table on page 43 

AC_BANK_CARD_PROD Table 
This table stores details of the types of bank card product associated with your bank's retail products.  

You maintain the table according to the types of cards used, for example, ATM card, check guarantee 
card, and debit card. You associate the card types with the relevant banking products. 

Table 5 describes the columns of the AC_BANK_CARD_PROD table. 
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Table 5. AC_BANK_CARD_PROD Columns 

Column Description 

CARD_TYPE  The type of card. 

PRODUCT_ID  The product identifier. 

COMPANY_CODE The company code. 

AC_BANK_CARD_RULES Table 
This table stores details of the rules for use of bank cards, such as the financial limits applicable to the 
card.   

You must maintain the table, for example, when the maximum credit limits must be increased for a 
particular card, and also when you add a new bank card type, such as ATM card, check guarantee 
card, and debit card.  

Table 6 describes the columns of the AC_BANK_CARD_RULES table. 

Table 6. AC_BANK_CARD_RULES Columns 

Column Description 

CARD_TYPE   The type of card. 

COMPANY_CODE The company code. 

AUT_RENEW_IND  Whether the card is renewed automatically. 

CARD_LIFE  The life of the card in months before it expires. 

MAX_CASH_WITH The maximum amount the cardholder can 
withdraw. 

MAX_CREDIT_LIMIT  The maximum credit limit for the card. 

STAND_WITH_AMNT  The standard amount the cardholder can 
withdraw. 

STAND_CREDIT_LIM  The standard credit limit for the card. 

CHEQUEBOOK Table 
This table, together with the CHEQUEBOOK_FACILITY table, stores details of the checkbooks 
associated with an account.   

You maintain the table when new checkbooks are ordered for an account. 

Table 7 describes the columns of the CHEQUEBOOK table. 



 
Administering Branch Teller  Administering Branch Teller Database Tables 

32 Siebel Retail Finance Banking Application Administration Guide Version 2007.1 

 

Table 7. CHEQUEBOOK Columns 

Column Description 

CHEQUEBOOK_NUMBER  The number of the checkbook. 

BRANCH_CODE  The branch code. 

ACCOUNT_NUMBER  The account number associated with the 
checkbook. 

START_SERIAL_NO The number of the first check in the book. 

END_SERIAL_NUMBER  The number of the last check in the book. 

CURRENCY  The currency. 

CHK_BOOK_FAC_NO  The checkbook facility number. 

COMPANY_CODE The company code. 

DISPATCH_CUSTOMER_INDICATOR  Whether the checkbook is dispatched to the 
customer. 

CHEQUEBOOK_FACILITY Table 
This table, together with the CHEQUEBOOK table, stores details of checkbooks associated with an 
account, for example, whether the checkbook is automatically reissued, the checkbook name, 
checkbook size, and so on. 

You maintain the table when new checkbooks are ordered for an account, and when details of 
checkbooks change, for example, when the name on the checkbook changes. 

Table 8 describes the columns of the CHEQUEBOOK_FACILITY table. Some columns that are not used 
are omitted. 

Table 8. CHEQUEBOOK_FACILITY Columns 

Column Description 

COMPANY_CODE  The company code. 

BRANCH_CODE  The branch code. 

ACCOUNT_NUMBER  The account number associated with the 
checkbook. 

CHK_BOOK_FAC_NO The checkbook facility number. 

METHOD_OF_DISPATCH  The method of dispatch for the checkbook, for 
example, ‘POST’ or ‘COLLECT_AT_BRANCH’. 

COLL_BRANCH_CODE  The branch code for the collection of the 
checkbook. 
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Column Description 

AUTOMATIC_REISSUE  Whether the checkbook is automatically re-
issued. 

AUTO_REISSUE_NO The automatic reissue number. 

CHEQUEBOOK_NAME1  The first name on the checkbook. 

CHEQUEBOOK_NAME2  The second name on the checkbook. 

CHK_BOOK_NO The number of the next checkbook. 

CHEQUE_TYPE  The type of checkbook, for example, ‘Checks 25’, 
‘Checks 50’, for books containing 25 and 50 
checks respectively.  

COMPANY Table 
This table contains general details about your bank, for example, the company name and company 
code. You maintain the table in response to changes in your bank’s details. 

Table 9 describes the columns of the COMPANY table. Some columns that are not used are omitted. 

Table 9. COMPANY Columns 

Column Description 

COMPANY_CODE   The company code. 

HOL_COMP_CODE   The holding company code. 

COMPANY_NAME   The name of the company. 

ACCNT_CURR   The accounting currency.  

NEXT_TRANS_ID  The next transaction identifier. 

COMPANY_CURR Table 
This table stores details of the currencies in use at your bank and indicates which currency is the base 
bank currency. You maintain this table when there are changes to the list of currencies handled by 
your bank, or when there is a change of base currency. 

Table 10 describes the columns of the COMPANY_CURR table. 
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Table 10. COMPANY_CURR Columns 

Column Description 

COMPANY_CODE   The company code. 

CURRENCY   The currency, for example, ‘GBP’, ‘EUR’, and 
‘USD’. 

BASE_CURRENCY_INDIC  Whether the currency is the base currency of the 
bank. 

CREDIT_CARD Table 
This table stores the details of a credit card account such as the account number, card number, card 
type, expiry date, cardholder name, issue date, and so on. 

You maintain the table when you add a new credit card, and when there are changes to the details for 
a card, for example, the expiry date, the cardholder name, or the security code. 

Table 11 describes the columns of the CREDIT_CARD table. 
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Table 11. CREDIT_CARD Columns 

Column Description 

ACCOUNT_NUMBER  The account number. 

CARD_NO  The credit card number. 

COMPANY_CODE  The company code. 

CARD_TYPE  The type of credit card. 

EXPIRY_DATE The expiry date of the card. 

CARD_STATUS  The status of the card, for example, 
‘ACTIVE’,’CLOSED’. 

AUTO_RENEW_IND  Whether the card is automatically renewed. 

CANCELLED_DATE  The date the card was cancelled. 

CARD_BALANCE  The account balance. 

HOLDER_NAME  The cardholder’s name. 

CANCELLED_REASON The reason for cancellation. 

ISSUE_DATE  The date the card was issued. 

LAST_AMEND_DATE  The date of the last amendment to the details. 

PIN_NO  The Personal Identification Number (PIN) number 
for the card. 

PIN_TRIES The number of PIN tries allowed. 

VALID_FROM_DATE  The date from which the card is valid. 

FACILITIES_CODE  The facilities code. 

SECURITY_CODE The security code on the card. 

PRODUCT_ID  The product identifier. 

OWNER_ID  The cardholder identifier. 

PRIM_HOLDER_IND  Whether the cardholder is the primary cardholder. 

CRED_CARD_ACC Table 
This table store details of all the credit card accounts and details of the accounts such as credit limits.  

You maintain the table when you add a new credit card, and when there are changes to details for 
accounts, for example, a change in the credit limit, or the maximum withdrawal limit. 
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Table 12 describes the columns of the CREDIT_CARD_ACC table. Some columns that are not used are 
omitted. 

Table 12. CREDIT_CARD_ACC Columns 

Column Description 

BRANCH_CODE The branch code. 

ACCOUNT_NUMBER The bank account number associated with the 
credit card. 

CREDIT_LIMIT  The credit limit for the card. 

MAX_CASH_WITH The maximum withdrawal amount. 

CC_AC_NO  The credit card account number. 

OWNER_ID The cardholder identifier. 

CARD_INS_IND  Whether there is credit card insurance. 

CREDIT_CARD_DETS Table 
This table stores details of credit card accounts such as card type, credit card limit, credit card issuer, 
and so on.  

You maintain the table when you add a new credit card, and when there are changes to details for 
accounts, for example, a change in the credit limit. 

Table 13 describes the columns of the CREDIT_CARD_DETS table. 

Table 13. CREDIT_CARD_DETS Columns 

Column Description 

CREDIT_CARD_ISSUER  The credit card issuer. 

CARD_TYPE  The type of credit card. 

CARD_CREDIT_LIMIT  The credit limit for the card. 

CARD_BALANCE The current balance for the card. 

CREDIT_CARD_DETAILS_ID The identifier of the credit card details. 

COMPANY_CODE  The company code. 

OWNER_ID  The cardholder identifier. 
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CREDIT_CARD_HOLDER Table 
This table store details of credit card account holders, such as the card number and whether the 
cardholder is the primary or the secondary owner of the card.  

You maintain the table when you add a new credit card, and when there are changes to the details for 
cardholders. 

Table 14 describes the columns of the CREDIT_CARD_HOLDER table. 

Table 14. CREDIT_CARD_HOLDER Columns 

Column Description 

OWNER_ID The cardholder identifier. 

COMPANY_CODE  The company code. 

STATUS The cardholder status, that is, ‘PRIMARY’ or 
‘SECONDARY’. 

CARD_NUMBER  The credit card number. 

CRCD_AC_HD_CRCD_AC Tables 
This table stores details of credit card account holders and associates them with retail account 
numbers.  

You maintain the table when you add a new credit card, and when there are changes to the details for 
cardholders. 

Table 15 describes the columns of the CRCD_AC_HD_CRCD_AC table. 

Table 15. CRCD_AC_HD_CRCD_AC Columns 

Column Description 

COMPANY_CODE  The company code. 

OWNER_ID  The cardholder identifier. 

ACCOUNT_NO The account number. 

HOLDER_POSITION  Indicates whether the holder is the primary holder 
of the card. 

CURRENCY Table 
This table stores details of currencies that your bank uses; typically these currencies are the U.S. 
dollar, the euro, and the pound sterling.  
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You maintain the table when there are changes to the list of currencies handled by your bank.   

Table 16 describes the columns of the CURRENCY table. 

Table 16. CURRENCY Columns 

Column Description 

CURRENCY   The currency. 

CURRENCY_NAME   The name of the currency, for example, 
‘STERLING’, ‘EURO’, ‘US_DOLLARS’. 

CURRENCY_DEC_PLA  The number of decimal places with which the 
currency is displayed. 

CURRENCY_DENOM Table 
This tables stores details of the types of note and coin for the currencies in use at your bank. 

You maintain the table when there are changes to the notes or coins in circulation for a currency, or 
when there is a change to the list of currencies handled by your bank. 

Table 17 describes the columns of the CURRENCY_DENOM table. 

Table 17. CURRENCY_DENOM Columns 

Column Description 

CURRENCY   The currency. 

DENOM_VALUE   The denomination value. 

DENOM_INDICATOR   Whether the denomination is a note ‘N’, or coin 
‘C’. 

DENOM_DES   The description of the denomination, that is, 
‘NOTE’ or ‘COIN’. 

CURR_SYMBOL  The symbol for the note or coin, for example ‘$’ 
for a U.S. dollar note, or ‘c’ for a U.S. dollar coin. 

BAG_BUNDLE_SIZE  The bag bundle size. 

EXCHANGE_RATE Table 
This table stores details of the exchange rates used at your bank for performing foreign exchange (FX) 
deposit and withdrawal transactions. The base currency for the exchange rates is identified in the 
COMPANY_CURR table.   

You maintain the table when there is a change in the exchange rates. For each supported currency 
represented in the table, you must update the buying and selling rates for FX transactions, as well as 
the amount of commission. 
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Table 18 describes the columns of the EXCHANGE_RATE table. Some columns that are not used are 
omitted. 

Table 18. EXCHANGE_RATE Columns 

Column Description 

COMPANY_CODE  The company code. 

CURRENCY   The currency. 

BRANCH_CODE   The branch code. 

CASH_SELLING_RATE   The exchange rate for selling cash in FX 
transactions. 

CASH_BUYING_RATE   The exchange rate for buying cash in FX 
transactions. 

COMMISSION  The amount of commission. 

TC_SELLING_RATE The selling exchange rate for non cash FX 
transactions. 

TC_BUYING_RATE The buying exchange rate for non cash FX 
transactions. 

MEAN Mean rate 

INTERNAL_ACCOUNT Table 
This table stores a list of account numbers used for internal posting or suspense account purposes. 
The table stores the branch and account number of the internal accounts, each of which is linked to a 
particular currency (any transactions that use these internal accounts need to be of that currency). 

Typically, the accounts referenced in the INTERNAL_ACCOUNT table are updated when balancing 
transactions resulting from Teller End of Day and Teller Start of Day operations are performed, when 
any fees or commissions are applied, and when any General Ledger postings are made.  

You maintain the table when you need to add a new internal account. 

Table 19 describes the columns of the INTERNAL_ACCOUNT table. 

Table 19. INTERNAL_ACCOUNT Columns 

Column Description 

COMPANY_CODE   The company code. 

ACCOUNT_NUMBER   The account number. 

BRANCH_CODE   The branch code. 

LEDGER_TYPE The ledger type. 
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NEGOTIABLE_INSTRUMENT Table 
This table stores details of negotiable instruments such as checks, cashier’s checks, money orders, 
drafts, and FX drafts. The table is used to check many attributes of a negotiable instrument such as 
the status, type, issuing branch, and account numbers of a negotiable instrument. The table also 
stores the important dates concerning negotiable instruments, such as when they were issued, 
deposited, or stopped.  

The financial transactions that use the NEGOTIABLE_INSTRUMENT table include:  

 Transactions involving any "on-us" checks only 

 Any consignment item processing resulting from Issue Draft, Issue Money Order, or Issue Cashiers 
Check operations  

 Negotiable instrument transfers between cashboxes 

You maintain the table when, for example, a new checkbook is issued to a customer, and you must 
add to the table all the negotiable instrument numbers in the checkbook. This is typically done by a 
"back office" application or manually when the checkbook is ordered.  You must perform similar 
maintenance for other negotiable instrument types such as cashier’s checks, money orders, drafts, FX 
drafts, and so on. The NEGOTIABLE_INSTRUMENT must be pre-filled with details of pre-printed stock 
and negotiable instruments for which you can dynamically allocate serial numbers (cashier’s checks, 
money orders, and drafts).  

Table 20 describes the columns of the NEGOTIABLE_INSTRUMENT table. 

Table 20. NEGOTIABLE_INSTRUMENT Columns 

Column Description 

COMPANY_CODE  The company code. 

SERIAL_NUMBER  The serial number. 

ISSUING_BRANCH_CODE The branch code of the issuing branch. 

ISSUING_ACCT_NUM  The issuing account number. 

NEG_INST_TYPE  The type of negotiable instrument, that is,  
‘DRAFT’, ‘CHECK’, ‘TRAVELLERS_CHECK’, 
‘CASHIERS_CHECK’, ‘MONEY_ORDER’. 

BRANCH_CODE  The branch code of your branch. 

CASHBOX_ID  The cashbox identifier. 

CURRENCY  The currency. 

AMOUNT  The amount.  

DOCUMENT_TYPE  The document type for the negotiable instrument, 
that is, ‘ACTIVE’, ‘CANCELLED’, ‘ON-US’, 
‘OTHER’. 

STATUS The status, which depends on the type of 
negotiable instrument as follows: 
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Column Description 

 Check. ‘ISSUED’, ‘RECEIVED’, ‘CLEARED’, 
‘STOPPED’, ‘REJECTED’, ‘RETURNED’, 
‘CANCELLED’, ‘AWAITING-DISPATCHMENT’, 
‘PRINTED’ ‘ACTIVE’, ‘INACTIVE’, 
‘IN_PROGRESS’. 

 Draft. ‘ISSUED’, ‘CLEARED’, ‘ACTIVE’, 
‘INACTIVE’, ‘IN_PROGRESS’. 

 Cashiers Check. ‘ACTIVE’, ‘AWAITING-
DISPATCHMENT’. 

 
BENEFICIARY_NAME  The name of the beneficiary 

EFFECTIVE_DATE  The effective date. 

LODGED_DATE  The date of depositing. 

DEST_BRANCH_CODE  The destination branch code. 

DEST_ACCT_NUM  The destination account number. 

STOP_REASON The reason for stopping the negotiable 
instrument. 

STOP_DATE  The date of stopping the negotiable instrument. 

CHEQUEBOOK_NUMBER  The checkbook number. 

BATCH_ID  The check batch identifier. 

DENOMINATION  The denomination of the negotiable instrument. 

PURCHASE_DATE  The purchase date of the negotiable instrument. 

NEG_INST_BOX_ID The negotiable instrument cashbox identifier. 

SUPPLIER_IND  Whether the negotiable instrument came from a 
supplier (1) or not (0). 

RET_ACC_PRODUCT Table 
This table together, with the RET_ACC_PROD_RET_ACC table, stores details for your bank’s retail 
account products. 

You maintain the table when there are changes to the retail account products, for example, to the 
facilities allowed with the account, or the limits for deposits and withdrawals. 

Table 21 describes the columns of the RET_ACC_PRODUCT table. 
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Table 21. RET_ACC_PRODUCT Columns 

Column Description 

 PRODUCT_ID  The product identifier. 

COMPANY_CODE  The company code. 

ATM_ALLOWED  Whether an ATM is allowed for the account. 

CHQ_BK_ALLOW  Whether a checkbook is allowed for the account. 

CHQ_GUA_ALLOW Whether a check guarantee card is allowed for 
the account. 

DEBIT_CARD_ALLOW  Whether a debit card is allowed for the account. 

DEF_INT_CODE  The default interest code. 

DEPOS_BK_ALLOW  Whether a deposit book is allowed for the 
account. 

MAX_DEPOSIT  The maximum amount that can be deposited. 

MIN_DEPOSIT  The minimum amount that can be deposited. 

OVERDRT_ALLOW Whether an overdraft is allowed for the account. 

DESCRIPTION  A description of the retail product. 

MINIMUM_AGE  The minimum age required for a holder of this 
product. 

PRODUCT_NAME  The product name. 

PRODUCT_TYPE  The product type, that is, ‘SAVINGS’, ‘LOAN’, or 
‘CHECK’. 

STAT_FREQ  The frequency of statements. 

DIRECT_DEBIT_ALLOW Whether direct debits are allowed for the account. 

DOMICILE_ALLOWED  Whether domicile is allowed. 

TRANS_FROM_ALLOW  Whether transfers to the account are allowed. 

ROLLOVER_FCLTY  Whether there is a rollover facility. 

STANDING_ORD_ALLOW  Whether standard orders are allowed for the 
account. 

MULT_HOLD_ALLOWED Whether the account can have multiple holders. 

MAX_AGE The maximum age for a holder of this account. 

MAX_WITHDRAW_LIMIT  The maximum amount that can be withdrawn. 

MIN_WITHDRAW_LIMIT  The minimum amount that can be withdrawn. 
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Column Description 

STAT_FREQ_TYPE  The statement frequency, that is, ‘STANDARD’ or 
‘COMMERCIAL’. 

TRANS_TO_ALLOW  Whether it is allowed to transfer to the account. 

PAYMENT_ALLOWED_ID Whether payments to the account are allowed. 

CLOSE_ACC_ALLOW  Whether it is allowed to close the account. 

WAIVE_OUST_CHGES_ALLWD_IND  Whether it is allowed to waive outstanding 
charges. 

OVERDRAFT_LIMIT The overdraft limit for the account. 

RET_ACC_PROD_RET_ACC Table 
This table relates your bank’s retail account products to account types.  

You maintain the table when there are changes to the retail account products offered by your bank. 

Table 22 describes the columns of the RET_ACC_PROD_RET_ACC table. 

Table 22. RET_ACC_PROD_RET_ACC Columns 

Column Description 

COMPANY_CODE  The company code. 

ACCOUNT_TYPE The type of account, for example, 
‘RETAIL_ACCOUNT’, 
‘CREDIT_CARD_ACCOUNT’, 
‘LOAN_ACCOUNT’, ‘INTERNAL_ACCOUNT’, 
‘BILLER_ACCOUNT’. 

PRODUCT_ID  The product identifier. 

SYSTEM_CONTROL Table 
The table stores system-wide information, and acts as a central repository for sequential identifiers 
and dates. As an example, the table is looked up to obtain the next sequence number when: 

 Adding beneficiaries for payments  

 Creating supervisor referral identifiers 

 Creating new accounts 

Table 23 describes some of the important columns of the SYSTEM_CONTROL table. The 
SYSTEM_CONTROL table is used to assign the origin point for sequential identifiers such as beneficiary 
IDs, account Ids. The SYSTEM_CONTROL table also contains the system date. 

Table 23. SYSTEM_CONTROL Columns 
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Column Description 

NEXT_BENE_ID  
 

An identifier used when creating a new 
beneficiary. 

NEXT_BANK_CARD_ID  
 

An identifier used when adding a new bank card. 
 

NEXT_ACCOUNT_ID  An identifier used when creating a new account. 
 

NEXT_CREDIT_CARD_ID  An identifier used when adding new credit card. 
 

SYSTEM_DATE  
 

The current system date. 

NEXT_SUP_OVER_REF_ID  An identifier used when creating a new supervisor 
referral. 
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3 Administering Internet Banking  
 

 

This chapter covers tasks required for administering Oracle’s Siebel Retails Finance Internet Banking 
application. It includes the following topics: 

 Administering Bank Details 

 Administering Retail Account Products 

 Administering Internet Banking Tasks 

 Administering System Identifiers and Dates 

 Administering Internal Accounts 

 Administering Users and Their Entitlements 

 Administering User Groups 

 Administering Roles 

 Administering Privileges 

 Administering Limits 

 Maintaining Customer Details 

 Administering User Passwords 

 Administering Utilities 

 Administering Fees 

 Administering Checkbooks 

 Maintaining Customer Details 

 Administering Customer Passwords 

 Resetting the Customer Logon Tries Counter 

 Administering Offers and Referrals 

Administering Bank Details 
Table 24 describes the columns of the COMPANY table. This table should be updated when bank 
details change, such as company name or company code. 
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Table 24. COMPANY 

Column Description 

COMPANY_CODE   The company code. 

HOL_COMP_CODE   The holding company code. 

COMPANY_NAME   The name of the company. 

ACCNT_CURR   The accounting currency.  

NEXT_TRANS_ID  The next transaction identifier. 

Administering Retail Account Products 
Table 25 describes the columns of the RET_ACC_PRODUCT table. This table together, with the 
RET_ACC_PROD_RET_ACC table, stores details for your bank’s retail account products. This table 
should be updated when there are changes to the retail account products, for example, to the facilities 
allowed with the account, or the limits for deposits and withdrawals. 

Table 25. RET_ACC_PRODUCT 

Column Description 

PRODUCT_ID  The product identifier. 

COMPANY_CODE  The company code. 

ATM_ALLOWED  Whether an ATM is allowed for the account. 

CHQ_BK_ALLOW  Whether a checkbook is allowed for the account. 

CHQ_GUA_ALLOW Whether a check guarantee card is allowed for 
the account. 

DEBIT_CARD_ALLOW  Whether a debit card is allowed for the account. 

DEF_INT_CODE  The default interest code. 

DEPOS_BK_ALLOW  Whether a deposit book is allowed for the 
account. 

MAX_DEPOSIT  The maximum amount that can be deposited. 

MIN_DEPOSIT  The minimum amount that can be deposited. 

OVERDRT_ALLOW Whether an overdraft is allowed for the account. 
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Column Description 

DESCRIPTION  A description of the retail product. 

MINIMUM_AGE  The minimum age required for a holder of this 
product. 

PRODUCT_NAME  The product name. 

PRODUCT_TYPE  The product type, that is, ‘SAVINGS’, ‘LOAN’, or 
‘CHECK’. 

STAT_FREQ  The frequency of statements. 

DIRECT_DEBIT_ALLOW Whether direct debits are allowed for the account. 

DOMICILE_ALLOWED  Whether domicile is allowed. 

TRANS_FROM_ALLOW  Whether transfers to the account are allowed. 

ROLLOVER_FCLTY  Whether there is a rollover facility. 

STANDING_ORD_ALLOW  Whether standard orders are allowed for the 
account. 

MULT_HOLD_ALLOWED Whether the account can have multiple holders. 

MAX_AGE The maximum age for a holder of this account. 

MAX_WITHDRAW_LIMIT  The maximum amount that can be withdrawn. 

MIN_WITHDRAW_LIMIT  The minimum amount that can be withdrawn. 

STAT_FREQ_TYPE  The statement frequency, that is, ‘STANDARD’ or 
‘COMMERCIAL’. 

TRANS_TO_ALLOW  Whether it is allowed to transfer to the account. 

PAYMENT_ALLOWED_ID Whether payments to the account are allowed. 

CLOSE_ACC_ALLOW  Whether it is allowed to close the account. 

WAIVE_OUST_CHGES_ALLWD_IND  Whether it is allowed to waive outstanding 
charges. 

OVERDRAFT_LIMIT The overdraft limit for the account. 

 

Table 26 describes the columns of the RET_ACC_PROD_RET_ACC table. This table relates your bank’s 
retail account products to account types. You maintain the table when there are changes to the retail 
account products offered by your bank. 

Table 26. RET_ACC_PROD_RET_ACC Columns 

Column Description 

COMPANY_CODE  The company code. 
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Column Description 

ACCOUNT_TYPE The type of account, for example, 
‘RETAIL_ACCOUNT’, 
‘CREDIT_CARD_ACCOUNT’, 
‘LOAN_ACCOUNT’, ‘INTERNAL_ACCOUNT’, 
‘BILLER_ACCOUNT’. 

PRODUCT_ID  The product identifier. 

Administering Internet Banking Tasks 
The TASK table stores all of the functions that the Internet Banking application can perform. Table 27 
describes some of the important columns of the TASK table that need to be modified when extending 
Internet Banking functionality. 

Table 27. RET_ACC_PROD_RET_ACC Columns 

Column Description 

ACCE_PROC_ID The company code. 

TASK_NAME The name of the task performed by the Internet 
Banking application. 

TASK_ID Unique Identifier for the task 

TASK_DESC Task description 

Administering System Identifiers and 
Dates 
Table 28 describes some of the important columns of the SYSTEM_CONTROL table. This table stores 
system-wide information, and acts as a central repository for sequential identifiers and dates. As an 
example, the table is looked up to obtain the next sequence number when: 

 Adding beneficiaries for payments  

 Creating supervisor referral identifiers 

 Creating new accounts 

Table 28. SYSTEM_CONTROL Columns 

Column Description 

NEXT_BENE_ID  An identifier used when creating a new 
beneficiary. 

NEXT_BANK_CARD_ID  An identifier used when adding a new bank card. 
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Column Description 

NEXT_ACCOUNT_ID  An identifier used when creating a new account. 

NEXT_CREDIT_CARD_ID  An identifier used when adding new credit card. 

SYSTEM_DATE  The current system date. 

NEXT_SUP_OVER_REF_ID  An identifier used when creating a new supervisor 
referral. 

Administering Internal Accounts 
Table 29. INTERNAL_ACCOUNT describes the columns of the INTERNAL_ACCOUNT table. This table 
stores a list of account numbers used for internal posting or suspense account purposes. The table 
stores the branch and account number of the internal accounts, each of which is linked to a particular 
currency (any transactions that use these internal accounts need to be of that currency). 

Typically, the accounts referenced in the INTERNAL_ACCOUNT table are updated when balancing 
transactions are performed or when any fees or commissions are applied.  

You maintain the table when you need to add a new internal account. 

Table 29. INTERNAL_ACCOUNT 

Column Description 

COMPANY_CODE   The company code. 

ACCOUNT_NUMBER   The account number. 

BRANCH_CODE   The branch code. 

Administering Users and Their 
Entitlements 
This topic covers the operations to set up Internet Banking Administrators, maintain the set of users, 
and assign user entitlements. Oracle’s Siebel Retail Finance Internet Banking application uses a Role 
Based Access Control (RBAC) framework. In the Entitlements framework, users or user groups are 
assigned roles. The privileges assigned to the roles control the functionality and data to which the user 
or user group has access. Within the Entitlements operations, users are referred to as actors. You can 
also define delegate actors. A delegate actor is a user to whom customers can, on a self-service 
channel like Internet Banking, grant selective access to their accounts. This is a mechanism for 
providing, for example, a personal advisor with access to specific accounts and the ability to make 
transfers up to a specific limit. This operation is executed in the Siebel Retail Finance Administrator, 
which is accessed at http://<ServerName>:<PortNumber>/branchadmin. 
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Adding an Internet Banking Administrator 
This topic covers setting up administrators for Internet Banking. 

To add an Internet Banking administrator 

1 Navigate to the User Maintenance > Add User Details screen (Fast Tran 41). 

2 Select User Type Administrator. 

3 Complete the user logon details and language preference. 

4 Click Create User. 

Maintaining Internet Banking Administrators 
After you have set up the Internet Banking administrators in your system, you can search for users by 
user name, user logon name, user type, or user status. You can then do the following: 

 View details of the users. 

 Change the details for the users, including the assignment of supervisors.  

 Delete users from the system. 

 Make users active (unlocked) or inactive (locked).  

To maintain an Internet Banking administrator 

1 Navigate to the User Maintenance > View Branch User Search Results screen (Fast Tran 42). 

2 Select or type details of the branch Code, name, login name, user type, or status of the branch 
user for which you want to search. 

3 Click Search.   

The search results are displayed. The Locked column shows whether users are active, that is, 
unlocked (No), or inactive, that is, locked (Yes). 

4 Select the required user. 

5 Now click one of the following buttons depending on the maintenance activity that you want to 
perform: 

 Click View to view the details for the user. Click Next to view the contact details and 
supervisor details. 

 Click Amend to change the details for the user. Click Next to access the contact details and 
supervisor details. Click Submit when you have completed the changes. 

 Click Delete to remove a user from the system. You must confirm the deletion. 

 Click Lock to make a user who is active become inactive. Alternatively, if you select a user that 
is inactive (Yes in the Locked column), you can click Unlock to make the user active. 

6 Click Submit. 
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Maintaining User Permissions 
The Maintain User Permissions operation allows you to: 

 Search for specific actors or retrieve all actors. 

 View actor and delegate actor details. 

 Add, amend, or delete privileges for an actor 

 Assign or unassign a role to or from an actor or delegate actor. 

 Assign or unassign an actor to or from an actor group. 

 Reset user logon tries, when the user exceeds the allowed number of logon attempts. 

 Lock or unlock an actor account. 

You perform some of these tasks from the list of actors, and others from the Actor Details list that is 
displayed when you select an actor from the list of actors. 

Viewing User Details 
You can search for a specific actor or delegate actor and then view their details.  

To view user details 

1 Navigate to the User Maintenance > Actor Search screen (Fast Tran 43). 

2 Enter or select the user name, user logon name, actor type, or status. 

3 Click Search.  

The Actors list displays the user name, logon name, user type, and status for each user 
returned. If you click Search without entering any search criteria, the Actors list displays all 
the active actors. 

4 Select the actor for which you wish to display details. 

5 Click View. 

The Actor Details screen is displayed. 

Adding a User to the List 
Before you add a user, you must display the Actors list.  

To add a user 

1 Navigate to the User Maintenance > Actor Search screen (Fast Tran 43). 

2 Enter search criteria and click Search.  

The Actors screen is displayed.  

3 Click Add.  

4 Type the details for the user. 
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Field Comment 

User Name Type the name of the user. 

User Logon Name Type the user name with which the branch user logs in. 

User Type Select Internet Administrator.  

Password Type a password. 

Confirm Password Type the same password again. 

5 Click Submit. 

Deleting a User from the List 
When you delete an actor or delegate actor, the system checks whether the actor or delegate has 
been assigned to any actor groups and removes any assignments. The system checks whether any 
roles have been assigned to the actor or delegate and if they have, it unassigns them. The system 
then deletes the actor or delegate. 

To delete a user 

1 Navigate to the User Maintenance > Actor Search screen (Fast Tran 43). 

2 Enter search criteria and click Search. 

The Actors screen is displayed.  

3 Select the user that you want to delete.  

4 Click Delete.  

Maintaining User Details 
This topic covers the following sub topics: 

 Assign and unassign privileges to and from a user 

 Assign and unassign roles to or from a user 

 Assign and unassign users to or from a user group 

 Reset the count of user logon tries 

 Lock or unlock a user account 

Assigning and Unassigning User-Specific Privileges 
You can assign and unassign privileges to a specific user. You can also assign privileges to roles. 
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To assign and unassign user-specific privileges 

1 Navigate to the Actor Details screen for the user. 

2 Click Actor Specific Privileges. 

The privileges of that user are then displayed on the Privileges screen. 

3 Perform the maintenance activity that you require: 

 To create a privilege, click Add. Enter a Privilege Description, which is mandatory, and select 
one or more of the following: task description, limit value, and channel name. Finally, click 
Submit. 

 To amend a privilege, select the privilege from the list, click Amend, edit the details, and click 
Submit. 

 To delete a privilege, select the privilege from the list, and click Delete. 

Assigning and Unassigning Roles to a User 
You can assign and unassign roles to a specific user.  

To assign and unassign roles to a user 

1 Navigate to the Actor Details screen for the user. 

2 Click Roles. 

The Roles screen is displayed. 

3 Assign or unassign roles as required:   

 To assign a role, select the role in the Available Roles list, and click Assign/Unassign Role. The 
role is then displayed in the Assigned Roles list. 

 To unassign a role, select the role in the Assigned Roles list, and click Assign/Unassign Role. 
The role is then displayed in the Available Roles list. 

4 Click Cancel to return to the Actor Details screen. 

Assigning and Unassigning Users to User Groups 
You can assign and unassign users to user groups.  

To assign and unassign user to user groups 

1 Navigate to the Actor Details screen for the user. 

2 Click Actor Groups. 

3 Assign or unassign users to user groups as required:   

 To assign a user, select the user group in the Available Actor Groups list, and click 
Assign/Unassign Actor Group. The user group is then displayed in the Assigned Actor Groups 
list. 
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 To unassign a user, select the user group in the Assigned Actor Groups list, and click 
Assign/Unassign Actor Group. The user group is then displayed in the Available Actors Group 
list. 

Click Cancel to return to the Actor Details screen. 

Maintaining the List of Delegates for a User 
You can specify delegates for a particular user. 

To maintain the list of delegates for a user 

1 Navigate to the Actor Details screen for the user. 

2 Click View Delegates. 

3 To add a delegate, click Add, type the details, and click Submit. 

4 To delete a delegate, click Delete. 

Resetting a User’s Logon Tries 
You can reset the Logon Tries counter for a user who has exceeded the allowed number of failed logon 
attempts, and therefore cannot log in. 

To reset a user’s logon tries 

1 Navigate to the Actor Details screen for the user. 

2 Click Reset Logon Tries. 

The Logon Tries counter is updated. 

Locking and Unlocking a User’s Account 
You can unlock a user’s account to make it active, or lock a user’s account to make it inactive. 

To lock or unlock a user account 

1 Navigate to the Actor Details screen for the actor. 

2 Click Lock/Unlock. 

The Status field is updated. 

Administering User Groups 
User groups are flexible groupings of users, containing one or more members. A user can belong to 
zero or more groups. When you define a group, you can select another, previously-defined group as 
its parent group. The group being defined then inherits the roles assigned to the parent group. The 
following user group administration is provided: 
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 View actor groups. 

 View roles assigned to a specific actor group. 

 Assign a role to or from a user group. 

 Add, amend, or delete a user group. 

When you delete a user group, the system first checks whether any actors have been assigned to the 
actor group and unassigns any that have been assigned. The system checks whether any roles have 
been assigned to the actor group and unassigns any roles that have been assigned. The actor group is 
then deleted. 

These operations are executed in the Siebel Retail Finance Administrator, which is accessed at 
http://<ServerName>:<PortNumber>/branchadmin. 

To add and maintain actor groups 

1 Navigate to the Actor Maintenance > Actor Groups screen (Fast Tran 44). 

The Actor Groups screen is displayed showing the group name and any parent group name for 
each group. 

2 To add a group, click Add, and then type an actor group name, select a parent actor group, if 
required, and click Submit. 

3 Select the required actor group. 

4 Click a button according to the maintenance activity you want to perform: 

 To view the roles assigned to the group, click View Roles. Click Cancel to return to the Actor 
Groups screen. 

 To assign or unassign a role to or from a group, click View Roles.  

To assign a role, select the role in the Available Roles list, and click Assign/Unassign Role. 
The role is then displayed in the Roles list. 

To unassign a role, select the role in the Roles list, and click Assign/Unassign Role. The 
role is then displayed in the Available Roles list. 

Click Cancel to return to the Actor Groups screen. 

 To amend a group, click Amend. Edit the actor group name and parent actor group as 
required, and click Submit. 

 To delete a group, click Delete. 

Administering Roles 
Users and groups are assigned roles, with corresponding privileges. The privileges control the 
functionality and data to which they have access. This operation is executed in the Siebel Retail 
Finance Administrator, which is accessed at http://<ServerName>:<PortNumber>/branchadmin. The 
Roles operation allows you to: 

 View role details. 
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 View the privileges assigned to a specific role. 

 Assign or unassign privileges to or from a role. 

 Add a role. 

 Amend a role name. 

 Delete a role. 

When you delete a role, the system first unassigns the role from any actor, actor group, or privilege to 
which it has been assigned. 

To add and maintain roles 

1 Navigate to the Actor Maintenance > Roles screen (Fast Tran 45). 

The Roles screen is displayed showing the role name for each role. 

2 To add a role, click Add, then type a role name, and click Submit. 

3 Select the Internet Administrator role. 

4 Click a button according to the maintenance activity you want to perform: 

 To view the privileges assigned to the role, click View Role Privileges. Click Cancel to return to 
the Roles screen. 

 To assign or unassign a privilege to or from a role, click Assign/Unassign Privilege.  

To assign a privilege, select the privilege in the Available Privileges list, and click Assign 
Privilege. The privilege is then displayed in the Assigned Privileges list. 

To unassign a privilege, select the privilege in the Assigned Privileges list, and click 
Unassign Privilege. The privilege is then displayed in the Available Privileges list. 

Click Submit when you have completed assigning or unassigning privileges.  

 To amend a role, click Amend. Edit the role name and click Submit.  

 To delete a role, click Delete. 

Administering Privileges 
The Privileges operation allows you to: 

 View privilege details. 

 Revoke privilege from all actors irrespective of the role of any actor. This allows for situations 
where some services, for example, funds transfer, need to be blocked. 

 Restore a privilege to all actors who had the privilege before it was revoked. 

 Add a privilege 

 Assign a privilege to all existing roles 

 Delete a privilege 
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When you create a privilege, you assigned to it one or more of the following privilege items:  

 Task. The details of the action that is to be carried out, for example, funds transfer. 

 Limit. A value imposed on a privilege such as a maximum amount that can be transferred. The 
limit type has an associated currency and limit type. The limit type can be, for example, daily or 
transactional. 

 Channel. The method of access to a system, which can affect the access control requirements. 
Examples of channels include Internet and branch. 

When you create a privilege, the system verifies that a privilege with the same task, limit, and channel 
does not exist (if it does exist, an error message is displayed). The system creates the new privilege, 
generates a privilege ID and sets the privilege type to general. A general privilege is a privilege that 
can be assigned to all actors or actor groups and which has not been created for a specific actor or 
actor group. 

When you delete a privilege, the system checks whether the privilege has been assigned to any role. 
If it has, the assignments are deleted. The system then deletes the privilege. For privileges that were 
created for an individual actor or delegate actor (only applicable when the Privileges screen is 
displayed from an actor or delegate actor screen) the system checks instead whether the individual 
role of the privilege has any other individual privileges assigned to it. If it has not, then the individual 
role is unassigned from the actor or delegate actor. The individual role is then deleted and the 
privilege is deleted. If the individual role has other individual privileges assigned to it then the 
individual role is not deleted. The individual privilege is then deleted. These operations are executed in 
the Siebel Retail Finance Administrator, which is accessed at 
http://<ServerName>:<PortNumber>/branchadmin. 

NOTE:  You can maintain privileges for a specific actor or delegate actor by using the Maintain Actor 
Permissions operation.  

To add and maintain privileges 

1 Navigate to the Actor Maintenance > Privileges screen (Fast Tran 46). 

The Privileges screen is displayed showing the privilege description, channel name, task 
description, limit amount, limit currency, limit type, and revoked status for each privilege set 
up on the system. 

2 To create a privilege, click Add.  Enter a Privilege Description, which is mandatory, and select 
values for one or more of the following:  

 Task Description  

 Limit Value  

 Channel Name  

3 Click Submit. 

4 Select the required privilege. 

5 Click a button according to the maintenance activity you want to perform: 

 To revoke a privilege from all actors, Click Revoke From All. 

 To restore a privilege to all actors, click Reinvoke Privilege. 
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 To assign the privilege to all existing roles, click Assign Privilege to All Roles. 

 To delete a privilege, click Delete. 

Administering Limits 
A limit is assigned to a privilege when you create the privilege. A limit value can be a maximum 
amount that can be transferred. The limit type can be, for example, daily or transactional. This 
operation is executed in the Siebel Retail Finance Administrator, which is accessed at 
http://<ServerName>:<PortNumber>/branchadmin. The Limits operation allows you to: 

 View limit details 

 Add a limit 

 Delete a limit  

When you delete a limit, the system initially determines any privileges that the limit has been 
assigned to, unassigns those privileges from any roles they have been assigned to, deletes those 
privileges, and then deletes the limit. 

To maintain limits 

1 Navigate to the User Maintenance > Limits screen (Fast Tran 47). 

The Limits screen is displayed. 

2 Add or delete limits as required: 

 To add a limit, click Add, type or select a limit value, currency and type, and click Submit. 

 To delete a limit, select the limit to be deleted, and click Delete. 

Administering User Passwords 
When you change a user’s password, the system verifies that the Existing Password entered matches 
that stored against the current user and that both new entered passwords match. This operation is 
executed in the Siebel Retail Finance Administrator, which is accessed at 
http://<ServerName>:<PortNumber>/branchadmin. 

To change a user’s password 

1 Navigate to the User Maintenance > Change Password screen (Fast Tran 48).  

The system displays the user logon name. 

2 Enter values in the Old Password, New Password, and Confirm New Password fields, all of which 
are mandatory. 

3 Click Submit. 



 
Administering Internet Banking  Administering Utilities 

 

 Siebel Retail Finance Banking Application Administration Guide Version 2007.1 
 

59 
 

  

Administering Utilities 
You use the Utility Maintenance operations to set up the utilities in your system, and maintain the 
details of the utilities. These operations are executed in the Siebel Retail Finance Administrator, which 
is accessed at http://<ServerName>:<PortNumber>/branchadmin. 

Adding a Utility 
When you add a utility, you enter the details of the utility. 

To add a utility 

1 Navigate to the Branch Maintenance > Add Utility screen (Fast Tran 31). 

2 Complete the necessary fields.  

The required fields are described in the following table. 

Field Comment 

Utility Name Type the name of the utility. 

Branch Code Type the branch code.  

Account Number Type the number of the account.  

Bank Reference Type a reference of up to 60 characters. 

3 Click Submit. 

Maintaining Utility Details 
After you have set up the utilities in your system, you can search for utilities by utility name, branch 
code, or account number, and then maintain the details of utilities. You can change all of the details 
for a utility.  

To maintain utility details 

1 Navigate to the Utility Maintenance > Utility Search screen (Fast Tran 32).  

2 Select Utility Name, Branch Code, or Account Number, and select the appropriate utility name, or 
type the branch code or account number. 

3 Click Search. 

4 Select a utility from the search results. 

5 Click Amend Utility Details. 

6 Change the utility details as required.  
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7 Click Submit. 

Administering Fees 
You use the Fee Maintenance operations to set up, view, and change the fees applying to financial 
transactions. By maintaining the details of transaction fees, you make sure that the correct fees are 
charged when the teller runs a transaction.  

Fees are calculated based on the account type, customer type, transaction type, and the amount of 
the transaction. For each account type and customer type there is a factor value that is used in 
calculating transaction fees. This allows, for example, fees for a particular type of transaction for 
company accounts to be higher than those for charity accounts. 

When you create transaction fees, you specify the fees that apply for a particular account type and 
customer type.  

These operations are executed in the Siebel Retail Finance Administrator, which is accessed at 
http://<ServerName>:<PortNumber>/branchadmin. 

To maintain transaction fee details 

1 Navigate to the Fees Maintenance > Maintain Fees screen (Fast Tran 61).  

2 Select an account type from the Account Types list. 

3 If required, edit the factor value for this account type. 

4 Select a customer type from the Customer Types list. 

5 If required, edit the factor value for this customer type. 

6 In the Transactions Fee Details table, enter or change the values for the flat fee, percentage fee, 
and maximum percentage fees for each transaction type as required. 

7 Repeat steps 2 through 6 for each set of transaction fees that you require to maintain. 

8 Click Submit. 

The transaction fees are saved and the New Transaction Fees screen is displayed. This screen 
displays all of the fees for each transaction type, account type, and customer type, and 
includes the changes that you made in the Maintain Fees screen. The details are shown in the 
following table. 

Field Comment 

Trx Code Displays the transaction code. 

Transaction Type Displays the transaction type. 

Account Type Displays the account type. 

Customer Type Displays the customer type. 

Flat Fee Displays the flat fee entered in the Transaction Fee 
Details table multiplied by both of the factor values for 
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Field Comment 

the account type and customer type. 

% Fee Displays the percentage fee entered in the Transaction 
Fee Details table multiplied by both of the factor values 
for the account type and customer type. 

Max Displays the maximum percentage fee entered in the 
Transaction Fee Details table multiplied by both of the 
factor values for the account type and customer type. 

9 Click Close. 

You are returned to the Maintain Fees screen. 

Administering Checkbooks 
Checkbooks are administered using the CHEQUEBOOK and CHEQUEBOOK_FACILITY tables. These 
tables store the details of the checkbooks associated with an account. Table 30 describes the columns 
of the CHEQUEBOOK table. You maintain this table when new checkbooks are ordered for an account. 

Table 30. CHEQUEBOOK Table 

Column Description 

CHEQUEBOOK_NUMBER  The number of the checkbook. 

BRANCH_CODE  The branch code. 

ACCOUNT_NUMBER  The account number associated with the 
checkbook. 

START_SERIAL_NO The number of the first check in the book. 

END_SERIAL_NUMBER  The number of the last check in the book. 

CURRENCY  The currency. 

CHK_BOOK_FAC_NO  The checkbook facility number. 

COMPANY_CODE The company code. 

DISPATCH_CUSTOMER_INDICATOR  Whether the checkbook is dispatched to the 
customer. 

 

Table 31 describes the columns of the CHEQUEBOOK_FACILITY table. This table, together with the 
CHEQUEBOOK table, stores details of checkbooks associated with an account, for example, whether 
the checkbook is automatically reissued, the checkbook name, and checkbook size. 

You maintain the table when new checkbooks are ordered for an account, and when details of 
checkbooks change, for example, when the name on the checkbook changes. 
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Table 31. CHEQUEBOOK_FACILITY Table 

Column Description 

COMPANY_CODE  The company code. 

BRANCH_CODE  The branch code. 

ACCOUNT_NUMBER  The account number associated with the 
checkbook. 

CHK_BOOK_FAC_NO The checkbook facility number. 

METHOD_OF_DISPATCH  The method of dispatch for the checkbook, for 
example, ‘POST’ or ‘COLLECT_AT_BRANCH’. 

COLL_BRANCH_CODE  The branch code for the collection of the 
checkbook. 

AUTOMATIC_REISSUE  Whether the checkbook is automatically re-
issued. 

AUTO_REISSUE_NO The automatic reissue number. 

CHEQUEBOOK_NAME1  The first name on the checkbook. 

CHEQUEBOOK_NAME2  The second name on the checkbook. 

CHK_BOOK_NO The number of the next checkbook. 

CHEQUE_TYPE  The type of checkbook, for example, ‘Checks 25’, 
‘Checks 50’, for books containing 25 and 50 
checks respectively.  

 

 

Maintaining Customer Details 
The customer maintenance operations provide the administrator with the facility to view and amend 
personal details that are held for a customer by the bank. Customer details which can be amended 
include address and contact details.  

Customer accounts are created using the Branch Teller application, see the Siebel Retail Finance 
Branch Teller Guide for details. These accounts must preexist in order for the customer to use the 
Internet Banking Online Registration functionality. The customer account details are held in the 
following database tables:  

 Person 

 PersonalDetails 

 CommonAddress 

 ContactDetails 

 CommonAccount 
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 RetailAccount 

 RetailAccountHolder 

 RetailAccountHolderRetailAccount 

 Bankcards 

Refer to the Siebel Retail Finance Branch Teller Guide for more information on creating customer 
accounts. 

This customer maintenance operations are executed in the Internet Banking Administration view at 
http://<server name>:<port number>/internetbanking/faces/ss/fins/pages/secure/logon/logon.jspx. 

Amending Customer Details 
This topic covers amending the address and contact details held for a customer. This operation is 
executed 

To amend customer details 

1 Navigate to the Customer Maintenance view. 

2 Enter the new details for the customer. 

3 Click Amend. 

Administering Customer Passwords 
This operation provides an administrative user with the functionality to change a customer’s password. 
It is executed in the Internet Banking Administration view at http://<server name>:<port 
number>/internetbanking/faces/ss/fins/pages/secure/logon/logon.jspx. 

To change a customer’s password 

1 Navigate to the Customer Maintenance > Change Password screen. 

The system displays the customer logon name. 

2 Enter a new value in the New Password field, and click OK. 

A message is displayed to confirm correct resetting of the Logon Tries counter. 

Resetting the Customer Logon Tries 
Counter 
Customer accounts are locked when the customer exceeds the number of allowed failed logon tries. 
The number of allowed failed logon tries is configured in NUMBER_OF_USER_LOGON_TRIES_LENGTH 
in the BankframeConstants.properties file. This operation provides the administrator with the 
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functionality to reset the Logon Tries counter, and enable the customer’s account. This operation is 
executed in the Internet Banking Administration view at http://<server name>:<port 
number>/internetbanking/faces/ss/fins/pages/secure/logon/logon.jspx. 

To reset the customer logon tries counter 

1 Navigate to the Customer Maintenance > Change Password screen. 

The system displays the customer logon name. 

2 Click Reset Logon Tries. 

A message is displayed to confirm correct resetting of the Logon Tries counter. 

Administering Offers and Referrals 
This topic covers creation of Offers and referrals for Internet Banking. These administration tasks are 
executed in the Siebel Financial Services application client. Refer to the chapter Configuring 
Integration of CRC Components, for prerequisite information on CRC setup. 

 This topic includes the following sub topics: 

 Adding Contacts and Prospects 

 Creating Offers 

 Creating Campaigns 

 Loading and Executing Campaigns 

Adding Contacts and Prospects 
This topic covers adding Contacts and Prospects for Offers and Referrals. 

To add Contacts and Prospects for Offers 

1 Navigate to the Lists Management > Lists view. 

2 Click New and enter a name for the Internet Banking Offers List. 

3 Select Menu > Save Record. 

4 Drill down on the List Name. 

5 Click New on the Select Contacts and Prospects tab. 

The Pick Contact dialog is launched. 

6 Select the contact to be associated with the list in the Contact Last Name field. 

7 Save the record. 
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Creating Offers 
This topic covers creation of Offers to add to a Campaign. 

To create Offers 

1 Navigate to the Offers > All Offers view. 

2 Click New to create a new Offer record. 

3 Select Web Announcements for the Channel Type. 

4 Drill down on this Offer and select All Treatments. 

5 Create a new Treatment using the above newly created parent offer. 

6 Select Web for the Channel. 

7 Navigate to Web Treatments > Advanced. 

8 Select the Inbound Active Flag to enable. 

Creating Campaigns 
This topic covers creation of campaigns, and associating Contacts, Offers and Treatments with a 
campaign. 

To create a campaign and associate it with Offers, Treatments and Contacts 

1 Navigate to the Campaign Management > Campaign List view. 

2 Click New, and create a new Campaign record. 

3 Drill down on the Campaign Name and select the Design > Offers sub tab. 

4 Click New on the Offers applet and select the Internet Banking Offer on the Add Offer dialog. 

5 Click New on the Treatments applet and select the Internet Banking Treatment on the Add 
Treatment dialog. 

6 Select the Design > Segments/Lists sub tab. 

7 Click New on the Segments/Lists applet and select the Internet Banking List on the Add Lists 
dialog. 

8 On the Allocation applet, select Web for the Internet Banking Segment/List. 

Loading and Executing Campaigns 
This topic covers loading and executing a Campaign. 

To load and execute a Campaign 

1 Navigate to the Campaign Management > Campaign List view. 
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2 Select Menu > Load Campaign. 

3 Select Execute > All Contact/Prospects. 

4 When the Campaign has loaded successfully the Execute Status will be set to Load Complete. 

5 Select Menu > Launch Campaign. 

6 Select Execute > All Contact/Prospects. 

When the Campaign has launched successfully the Execute Status will be set to Launched and 
the contacts that you have added should be listed in the All Contact/Prospects applet. 
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This chapter covers the configuration tasks required for integrating Siebel Retail Finance and Siebel 
 This chapter includes the 

lo

e Repository Object 

SiebelTCRCIntegrationConfigurationResources.jar in your installation image, for more information on 
integrating Siebel Retail Finance with Siebel Financial Services, to enable CRC components. 

el Retail Finance 

y be 
at 

contains modified versions of the Siebel repository file (.srf) in XML format. The .sif file has been 
updated for Siebel Retail Finance, and should be imported into Siebel Tools, and compiled. 

inance Repository Object 

a. 

3 

- Preview dialog box appears. This dialog box identifies the projects and 

epository in the Conflict Resolution area. 

6 Compile the TCRC Integration and VEAI Dashboard - Java projects. 

4 ntegration of CRC 
Components 
Configuring I

Financial Services, to enable the Siebel Retail Finance CRC components.
fol wing topics: 

 Importing the Siebel Retail Financ

 Importing Integration Workflows 

 Importing Data Transformation Maps 

 Importing Siebel eScript Business Services 

 Creating Named Subsystems for Integration Processes 

 Adding Named Subsystems to the EAI Configuration File 

Refer to Siebel Retail Finance Installation Guide, and the resource files provided in the file 

Importing the Sieb
Repository Object 
Siebel .sif files are archive files that contain object definitions exported from a repository, and ma
imported into another repository. Your Siebel Retail Finance installation includes a .sif file th

To import and compile the Siebel Retail F

1 Lock the project VEAI Dashboard – Jav

2 Choose Tools > Import from Archive. 

In the Select Archive To Import dialog box, select <SRF Install Root>\<version> Siebel 
Configuration - <vx.x>\Repository Objects\Repository Objects.sif, and then click Open. 

The Import Wizard 
the top-level objects in the archive file you have opened, allowing you to preview the contents 
of the archive file. 

4 Select Overwrite the object in the r

5 Choose Tools > Compile Projects. 
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Importing Integration Workflows 
You must import or create a Siebel Workflow in Siebel Tools for each Siebel Retail Finance integration 
Named Subsystem. For more information on importing, creating and configuring Siebel Workflow, see 
Siebel Business Process Designer Administration Guide and Transport and Interfaces: Siebel eBusiness 
Application Integration Volume III. 

To import and deploy TCRC Integration Workflow Processes 

1 Choose View > Object Explorer > Workflow Process. 

2 Right-click on the Workflow Process applet and select Import Workflow Process. 

3 Import the Workflow <SRF Install Root>\<vx.x> Siebel Configuration - <vx.x>\Workflows\TCRC 
Integration Workflows.xml. 

4 Accept the wizard defaults to complete importing and deploying the TCRC Integration Workflow 
processes. 

Importing Data Transformation Maps 
This topic covers importing the Siebel Data Transformation Maps used by the Siebel Retail Finance 
workflows. This task is executed in the Siebel Financial Services client. 

To import Data Transformation Maps 

1 Navigate to Administration – Integration screen > Data Maps > Integration Object Map. 

2 Select Menu > Import Data Map on the Integration Object Map applet. 

3 Select the <SRF Install Root>\<vx.x> Siebel Configuration - <vx.x>\DTE Maps \Data Maps.XML 
file to import. 

4 Accept the default options to complete the import process. 

Importing Siebel eScript Business 
Services 
This topic covers importing the Siebel eScript Business Services that are used by the Siebel Retail 
Finance Contact and Offer Integration processes. This task is executed in the Siebel Financial Services 
client. 

To import eScript Business Services 

1 Navigate to Administration – Business Service > Details view. 

2 Select Menu > Import Service on the Details applet. 

3 Import the following Business Services XML files: 
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 <SRF Install Root>\<vx.x> Siebel Configuration - <vx.x>\Business 
Service\BusService_SetProfileAttribute.xml. 

 <SRF Install Root>\<vx.x> Siebel Configuration - <vx.x>\Business 
Service\BusService_SetProfileAttributeWMsg.xml. 

4 Accept the default options to complete the import process. 

Creating Named Subsystems for 
Integration Processes 
Named Subsystems are groupings of defined enterprise parameters that are stored in the Siebel 
Gateway Name Server. The Named Subsystems receive inbound HTTP requests, and invoke the 
appropriate Siebel Workflow. A Named Subsystem must be created for each integration process for 
Oracle’s Siebel Retails Finance application. Named Subsystems are created and modified using the 
Siebel Server Manager UI. For more information on creating and configuring Named Subsystems, see 
Siebel Server Administration Guide and Transports and Interfaces: Siebel eBusiness Application 
Integration Volume III. 

To create Named Subsystems using the Siebel Server Manager 

1 Open a command prompt. 

2 Change directory to <Siebel_Install_Home>\siebsrvr\bin. 

3 Type the following commands: 

srvrmgr /g <gateway name> /e <enterprise name> /u <username> /p <password> 

create named subsystem TCRCQueryContact for subsystem 

EAITransportDataHandlingSubsys with DispatchWorkflowProcess="TCRC Integration 

Query Contact", DispatchMethod=RunProcess 

create named subsystem TCRCQueryOpportunity for subsystem 

EAITransportDataHandlingSubsys with DispatchWorkflowProcess="TCRC Integration 

Query Opportunity", DispatchMethod=RunProcess 

create named subsystem TCRCInsertReferral for subsystem 

EAITransportDataHandlingSubsys with DispatchWorkflowProcess="TCRC Integration 

Referral Insertion", DispatchMethod=RunProcess 

create named subsystem TCRCQueryOffer for subsystem EAITransportDataHandlingSwith 

DispatchWorkflowProcess="TCRC Integration Query Offer", DispatchMethod=RunProcess 

create named subsystem TCRCQueryOffer for subsystem EAITransportDataHandlingSubsys 

with DispatchWorkflowProcess="TCRC Integration Response Insertion", 

DispatchMethod=RunProcess 
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Adding Named Subsystems to the EAI 
Configuration File 
This topic covers adding the Named Subsystems to the EAI configuration file. 

To add Named Subsystems to the EAI configuration file 

1 Open the siebsrvr\bin\enu\eai.cfg file in a text editor. 

2 Add the following Named Subsystems to the  [HTTP Services] section of the EAI configuration file: 

TCRCQueryContact = TCRCQueryContact 

TCRCQueryOpportunity = TCRCQueryOpportunity 

TCRCQueryOffer = TCRCQueryOffer 

TCRCInsertReferral = TCRCInsertReferral 

TCRCInsertResponse = TCRCInsertResponse 

 


	Contents
	1 What’s New in This Release
	2 Administering Branch Teller
	Administering Branches
	Adding a Branch
	Maintaining Branch Details

	Administering the Calendar
	Setting Up the Calendar
	Updating the Calendar

	Administering Utilities
	Adding a Utility
	Maintaining Utility Details

	Administering Users and Their Entitlements
	Adding a Branch User
	Maintaining a Branch User
	Maintaining User Permissions
	Maintaining User Details

	Administering User Groups
	Administering Roles
	Administering Privileges
	Administering Limits
	Administering Passwords
	Administering the Bond Table
	Updating Bond Redemption Values

	Administering Fees
	Administering Negotiable Instruments 
	Querying the Negotiable Instruments Log

	Administering Currency Transaction Reports
	Maintaining the CTR Exemption List
	Maintaining the CTR List

	Administering Branch Teller Database Tables
	AC_BANK_CARD_PROD Table
	AC_BANK_CARD_RULES Table
	CHEQUEBOOK Table
	CHEQUEBOOK_FACILITY Table
	COMPANY Table
	COMPANY_CURR Table
	CREDIT_CARD Table
	CRED_CARD_ACC Table
	CREDIT_CARD_DETS Table
	CREDIT_CARD_HOLDER Table
	CRCD_AC_HD_CRCD_AC Tables
	CURRENCY Table
	CURRENCY_DENOM Table
	EXCHANGE_RATE Table
	INTERNAL_ACCOUNT Table
	NEGOTIABLE_INSTRUMENT Table
	RET_ACC_PRODUCT Table
	RET_ACC_PROD_RET_ACC Table
	SYSTEM_CONTROL Table


	3 Administering Internet Banking
	Administering Bank Details
	Administering Retail Account Products
	Administering Internet Banking Tasks
	Administering System Identifiers and Dates
	Administering Internal Accounts
	Administering Users and Their Entitlements
	Adding an Internet Banking Administrator
	Maintaining Internet Banking Administrators
	Maintaining User Permissions
	Maintaining User Details

	Administering User Groups
	Administering Roles
	Administering Privileges
	Administering Limits
	Administering User Passwords
	Administering Utilities
	Adding a Utility
	Maintaining Utility Details

	Administering Fees
	Administering Checkbooks
	Maintaining Customer Details
	Amending Customer Details

	Administering Customer Passwords
	Resetting the Customer Logon Tries Counter
	Administering Offers and Referrals
	Adding Contacts and Prospects
	Creating Offers
	Creating Campaigns
	Loading and Executing Campaigns


	4 Configuring Integration of CRC Components
	Importing the Siebel Retail Finance Repository Object
	Importing Integration Workflows
	Importing Data Transformation Maps
	Importing Siebel eScript Business Services
	Creating Named Subsystems for Integration Processes
	Adding Named Subsystems to the EAI Configuration File


